Introduction

1 Introduction

The Darwin Information Typing Architecture (DITA) 1.2 specification defines a set of document types for authoring and organizing topic-oriented information, as well as a set of mechanisms for combining, extending, and constraining document types.

The DITA 1.2 specification consists of the following components:
Document Type Definitions (DTDs) and XML Schemas (XSDs)
The DTDs and XSDs – along with the catalog files – define DITA markup for the DITA vocabulary modules and DITA document types. While the DTDs and XSDs should define the same DITA elements, the DTDs are normative if there is a discrepancy. If there is a discrepancy between the written specification (this document) and the DTDs, the written specification takes precedence.
DITA 1.2 written specification
While the DITA 1.2 documentation does contain some introductory information, it is intended neither as an introduction to DITA nor as a users guide. The intended audience of this documentation consists of implementers of the DITA standard, including tool developers and XML architects who develop specializations. The documentation contains several parts:
  • Architectural specification
  • Language reference
  • Conformance statement
  • Appendices

The DITA 1.2 written specification is available in the following formats: XHTML, CHM, PDF, and DITA source. The XHTML version is authoritative.

  • 1.1 Terminology
    The key words "must", "must not", "required", "shall", "shall not", "should", "should not", "recommend", "may", and "optional" in this document are to be interpreted as described in RFC 2119 (http://www.ietf.org/rfc/rfc2119.txt).
  • 1.2 Normative references
    Normative references are references to external documents or resources to which implementers of DITA must comply.
  • 1.3 Non-normative references
    Non-normative references are references to external documents or resources that implementers of DITA might find useful.
  • 1.4 Formatting conventions in the XHTML version of the specification
    Given the size and complexity of the specification, it is not generated as a single XHTML file. Instead, each DITA topic is rendered as a separate XHTML file. The XHTML version of the specification uses certain formatting conventions to aid readers in navigating through the specification and locating material easily: Link previews and navigation links.
Previous topic: DITA Version 1.2 Specification cover page
Next topic: 1.1 Terminology

OASIS DITA Version 1.2 -- OASIS Standard, 1 December 2010
Copyright © OASIS Open 2005, 2010. All Rights Reserved.


Terminology

1.1 Terminology

The key words "must", "must not", "required", "shall", "shall not", "should", "should not", "recommend", "may", and "optional" in this document are to be interpreted as described in RFC 2119 (http://www.ietf.org/rfc/rfc2119.txt).

must
This word, or the terms "required" or "shall", mean that the definition is an absolute requirement of the specification.
must not
This phrase, or the phrase "shall not", means that the definition is an absolute prohibition of the specification.
should
This word, or the adjective "recommended", means that there may exist valid reasons in particular circumstances to ignore a particular item, but the full implications must be understood and carefully weighed before choosing a different course.
should not
This phrase, or the phrase "not recommended", means that there may exist valid reasons in particular circumstances when the particular behavior is acceptable or even useful, but the full implications should be understood and the case carefully weighed before implementing any behavior described with this label.
may
This word, or the adjective "optional", means that an item is truly optional. One vendor may choose to include the item because a particular marketplace requires it or because the vendor feels that it enhances the product while another vendor may omit the same item. An implementation which does not include a particular option must be prepared to interoperate with another implementation which does include the option, though perhaps with reduced functionality. In the same vein an implementation which does include a particular option must be prepared to interoperate with another implementation which does not include the option (except, of course, for the feature the option provides).
Parent topic: 1 Introduction
Previous topic: 1 Introduction
Next topic: 1.2 Normative references


Normative references

1.2 Normative references

Normative references are references to external documents or resources to which implementers of DITA must comply.

[Namespaces in XML 1.0]
T. Bray, D. Hollander, A. Layman, R. Tobin, and H. S. Thompson, editors, Namespaces in XML 1.0 (Third Edition), http://www.w3.org/TR/2009/REC-xml-names-20091208/, W3C Recommendation, 8 December 2009.
[Namespaces in XML 1.1]
T. Bray, D. Hollander, A. Layman, and R. Tobin, editors, Namespaces in XML 1.1 (Second Edition), http://www.w3.org/TR/2006/REC-xml-names11-20060816/, W3C Recommendation, 16 August 2006
[RFC 2119]
S. Bradner, Key words for use in RFCs to Indicate Requirement Levels, http://www.ietf.org/rfc/rfc2119.txt, IETF RFC 2119, March 1997.
[RFC 3986]
T. Berners-Lee, R. Fielding, and L. Masinter, Uniform Resource Identifiers (URI): Generic Syntax, http://tools.ietf.org/html/rfc3986, IETF RFC 3986, January 2005.
[XML 1.0]
T. Bray, J. Paoli, C. M. Sperberg-McQueen, E. Maler, and F. Yergeau, editors, Extensible Markup Language (XML) 1.0 (Fifth Edition), http://www.w3.org/TR/REC-xml/, W3C Recommendation, 26 November 2008.
[XML 1.1]
T. Bray, J. Paoli, C.M. Sperberg-McQueen, E. Maler, F.Yergeau, and J. Cowan, editors, Extensible Markup Language (XML) 1.1 (Second Edition),http://www.w3.org/TR/2006/REC-xml11-20060816/, W3C Recommendation, 16 August 2006, edited in place 29 September 2006.
[XSD 1.0 Structures]
H. S. Thompson, D. Beech, M. Maloney, and N. Mendelsohn, editors, XML Schema Part 1: Structures Second Edition, http://www.w3.org/TR/xmlschema-1/, W3C Recommendation, 28 October 2004.
[XSD 1.0 Datatypes]
P. V. Biron and A. Malhotra, editors, XML Schema Part 2: Datatypes Second Edition, http://www.w3.org/TR/xmlschema-2/, W3C Recommendation, 28 October 2004.
Parent topic: 1 Introduction
Previous topic: 1.1 Terminology
Next topic: 1.3 Non-normative references


Non-normative references

1.3 Non-normative references

Non-normative references are references to external documents or resources that implementers of DITA might find useful.

[CSS 2.1]
B. Bos, T. Çelik, I. Hickson, and H.W. Lie, editors, Cascading Style Sheets Level 2 Revision 1 (CSS 2.1) Specification, http://www.w3.org/TR/CSS2/, W3C Candidate Recommendation, 08 September 2009.
[XHTML 1.0]
W3C HTML Working Group, XHTML 1.0 The Extensible HyperText Markup Language (Second Edition): A Reformulation of HTML 4 in XML 1.0, http://www.w3.org/TR/xhtml1/, W3C Recommendation, 26 January 2000, revised 1 August 2002.
[XHTML 1.1]
M. Altheim and S. McCarron, editors, XHTML 1.1 - Module-based XHTML, http://www.w3.org/TR/xhtml11/, W3C Recommendation, 31 May 2001.
[XPointer 1.0]
S. DeRose, E. Maler, and R. Daniel Jr., editors, XML Pointer Language (XPointer) Version 1.0, http://www.w3.org/TR/WD-xptr, W3C Last Call Working Draft, 8 January 2001.
[XLIFF 1.2]
OASIS Standard, XLIFF Version 1.2, 1 February 2008, http://docs.oasis-open.org/xliff/xliff-core/xliff-core.html.
[xml:tm 1.0]
A. Zydroń, R. Raya, and B. Bogacki, editors, XML Text Memory (xml:tm) 1.0 Specification, http://www.lisa.org/fileadmin/standards/xml-tm.html, The Localization Industry Standards Association (LISA) xml:tm 1.0, 26 February 2007.
[XQuery 1.0]
S. Boag, D. Chamberlin, M. F. Fernández, D. Florescu, J. Robie, and J. Siméon, editors, XQuery 1.0: An XML Query Language, http://www.w3.org/TR/xquery/, W3C Recommendation, 23 January 2007.
[XSL 1.0]
S. Adler, A. Berglund, J. Caruso, S. Deach, T. Graham, P. Grosso, E. Gutentag, A. Milowski, S. Parnell, J. Richman, and S. Zilles, Extensible Stylesheet Language (XSL) Version 1.0, http://www.w3.org/TR/2001/REC-xsl-20011015/, W3C Recommendation, 15 October 2001.
[XSL 1.1]
A. Berglund, editor, Extensible Stylesheet Language (XSL) Version 1.1, http://www.w3.org/TR/xsl11/, W3C Recommendation, 05 December 2006
[XSLT 1.0]
J. Clark, editor, XSL Transformations (XSLT) Version 1.0, http://www.w3.org/TR/xslt, W3C Recommendation, 16 November 1999
[XSLT 2.0]
M. Kay, editor, XSL Transformations (XSLT) Version 2.0, http://www.w3.org/TR/xslt20/, W3C Recommendation, 23 January 2007
[XTM 1.0]
S. Pepper and G. Moore, editors, XML Topic Maps (XTM) 1.0, http://www.topicmaps.org/xtm/index.html, TopicMaps.Org XTM 1.0, 2001.
Parent topic: 1 Introduction
Previous topic: 1.2 Normative references
Next topic: 1.4 Formatting conventions in the XHTML version of the specification


Formatting conventions in the XHTML version of the specification

1.4 Formatting conventions in the XHTML version of the specification

Given the size and complexity of the specification, it is not generated as a single XHTML file. Instead, each DITA topic is rendered as a separate XHTML file. The XHTML version of the specification uses certain formatting conventions to aid readers in navigating through the specification and locating material easily: Link previews and navigation links.

Link previews

The DITA 1.2 specification uses the content of the unique DITA <shortdesc> element to provide link previews for its readers. These link previews are visually highlighted by a border and a colored background. The link previews are not normative; they contain the content of the <shortdesc> element for the child topic, which is normatively rendered as the first paragraph of the child topic; the content is identical in both renditions. The link previews serve as enhanced navigation aids, enabling readers to more easily locate content. This usability enhancement is one of the ways in which the specification illustrates the capabilities of DITA and exemplifies DITA best practices.

The following screen capture illustrates how link previews are displayed in the XHTML version of the specification:
Figure 1. Link previews

Navigation links

To ease readers in navigating from one topic to another, each XHTML file generated by a DITA topic contains the following navigation links at the bottom:
Parent topic
Takes readers to the parent topic, which the topic referenced by the closest topic in the containment hierarchy
Previous topic
Takes readers to the previous topic in the reading sequence
Next topic
Takes readers to the next topic in the reading sequence
Return to main page
Takes readers to the place in the table of contents for the current topic in the reading sequence
The following screen capture illustrates how navigation links are displayed in the XHTML version of the specification:
Figure 2. Navigation links

When readers hover over the navigation links, the short description of the DITA topic also is displayed.
Parent topic: 1 Introduction
Previous topic: 1.3 Non-normative references
Next topic: 2 Architectural specification


Architectural specification

2 Architectural specification

The architectural specification provides information about how DITA is designed. It is divided into three sections: Base, technical content, and learning and training.

  • 2.1 Architectural Specification: Base
    Base DITA includes the topic, map elements, metadata, classification, and specialization elements. It also includes domains for hazard statement, typographic, and utility elements
  • 2.2 Architectural Specification: Technical Content Version
    Previously, the document types and specializations for technical content were included as an integral part of the base DITA specification. With the release of DITA 1.2 and the increasingly number of specializations that are part of the DITA specification, the document types and specializations for technical content have a dedicated section in the DITA specification.
  • 2.3 Architectural Specification: Learning and Training Version
    DITA 1.2 introduces the Learning and Training specialization, which is designed for developing instructional materials. It contains all of base DITA and some (but not all) parts of the Technical Content package.
Previous topic: 1.4 Formatting conventions in the XHTML version of the specification
Next topic: 2.1 Architectural Specification: Base


Architectural Specification: Base

2.1 Architectural Specification: Base

Base DITA includes the topic, map elements, metadata, classification, and specialization elements. It also includes domains for hazard statement, typographic, and utility elements

The base section of the architectural specification contains the following parts:
  • An introduction, which provides background concepts and an overview of the architecture
  • The DITA markup section, which provides an overview of DITA topics, DITA maps, and DITA metadata
  • The DITA processing section, which provides descriptions of common DITA-processing expectations
  • The configuration, specialization, and constraints section, which provides details of the mechanisms that DITA provides for defining, extending, and constraining DITA document types
  • 2.1.1 Introduction to DITA
    The Darwin Information Typing Architecture (DITA) is an XML-based architecture for authoring, producing, and delivering topic-oriented, information-typed content that can be reused and single-sourced in a variety of ways. While DITA historically has been driven by the requirements of large-scale technical documentation authoring, management, and delivery, it is a standard that is applicable to any kind of publication or information that might be presented to readers, including interactive training and educational materials, standards, reports, business documents, trade books, travel and nature guides, and more.
  • 2.1.2 DITA markup
    Topics and maps are the basic building blocks of the Darwin Information Typing Architecture (DITA). Metadata attributes and values can be added to DITA topics and maps, as well as to elements within topics, to allow for conditional publishing and content reuse.
  • 2.1.3 DITA processing
    Several common DITA processing behaviors are driven by attributes, including setting the set of vocabulary and constraint modules on which a DITA document depends, navigation, linking, content reuse (via direct or indirect addressing), conditional processing, chunking, and printing. In addition, translation of DITA content is expedited through the use of the @dir, @translate, and @xml:lang attributes, and the <index-sort-as> element.
  • 2.1.4 Configuration, specialization, and constraints
    The extension facilities of DITA allow existing vocabulary and constraint modules to be combined to create specific DITA document types. Additionally, vocabulary modules can be extended to create more-specialized markup to meet new requirements not satisfied by existing markup.
Parent topic: 2 Architectural specification
Previous topic: 2 Architectural specification
Next topic: 2.1.1 Introduction to DITA


Introduction to DITA

2.1.1 Introduction to DITA

The Darwin Information Typing Architecture (DITA) is an XML-based architecture for authoring, producing, and delivering topic-oriented, information-typed content that can be reused and single-sourced in a variety of ways. While DITA historically has been driven by the requirements of large-scale technical documentation authoring, management, and delivery, it is a standard that is applicable to any kind of publication or information that might be presented to readers, including interactive training and educational materials, standards, reports, business documents, trade books, travel and nature guides, and more.

DITA is designed for creating new document types and describing new information domains based on existing types and domains. The process for creating new types and domains is called specialization. Specialization enables the creation of very specific, targeted document-type definitions that still can share the common output transformations and design rules developed for more general types and domains; this is similar to how classes in an object-oriented system can inherit the methods of ancestor classes.

Because DITA topics are XML conforming, they can be readily viewed, edited, and validated using standard XML tools, although realizing the full potential of DITA requires using DITA-aware tools.

  • 2.1.1.1 About the specification source
    The DITA specification is authored as a DITA content set and published using the DITA Open Toolkit. It is an example of a complex document that is developed by a team of people and uses many DITA features, including key references (keyrefs) and content references (conrefs).
  • 2.1.1.2 DITA terminology and notation
    The DITA specification uses specific notation and terms to define the components of the DITA standard.
  • 2.1.1.3 Basic concepts
    DITA has been designed to satisfy requirements for information typing, semantic markup, modularity, reuse, interchange, and production of different deliverable forms from a single source. These topics provide an overview of the key DITA features and facilities that serve to satisfy these requirements.
  • 2.1.1.4 File naming conventions
    DITA uses certain naming conventions and file extension for topics, maps, modules, and document-type implementation files.
  • 2.1.1.5 Producing different deliverables from a single source
    DITA is designed to produce multiple deliverable formats from a single set of DITA content. This means that many rendition details are specified neither in the DITA specification nor in the DITA content; the rendition details are defined and controlled by the processors.
Parent topic: 2.1 Architectural Specification: Base
Previous topic: 2.1 Architectural Specification: Base
Next topic: 2.1.1.1 About the specification source


About the specification source

2.1.1.1 About the specification source

The DITA specification is authored as a DITA content set and published using the DITA Open Toolkit. It is an example of a complex document that is developed by a team of people and uses many DITA features, including key references (keyrefs) and content references (conrefs).

As a convenience for readers, the DITA specification is published in several packages which contain different combinations of required and optional modules. The ability to easily define, manage, and publish these packages is a result of using DITA for the specification source. The source files for the DITA specification are managed in a version control repository that is maintained by OASIS; they also can be downloaded from OASIS.

The PDF versions of the DITA specification were built using Antenna House XSL Formatter and RenderX XEP.

Parent topic: 2.1.1 Introduction to DITA
Previous topic: 2.1.1 Introduction to DITA
Next topic: 2.1.1.2 DITA terminology and notation


DITA terminology and notation

2.1.1.2 DITA terminology and notation

The DITA specification uses specific notation and terms to define the components of the DITA standard.

Notation

The following conventions are used throughout the specification:
attribute types
Attribute names may be preceded by @ to distinguish them from elements or surrounding text, for example, the @props or the @class attribute.
element types
Element names may be delimited with angle brackets (< and >) to distinguish them from surrounding text, for example, the <keyword> and the <prolog> element.

In general, the unqualified use of the term map or topic can be interpreted to mean "a <map> element and any specialization of a <map> element " or "a <topic> element or any specialization of a <topic> element."

Normative and non-normative information

The DITA specification contains normative and non-normative information:
Normative information
Normative information is the formal portion of the specification that describes the rules and requirements that make up the DITA standard and which must be followed.
Non-normative information
Non-normative information includes descriptions that provide background, examples, and other useful information that are not formal requirements or rules that must be followed. The terms non-normative and informative are used interchangeably.

All information in the specification should be considered normative unless it is an example, an appendix, or is explicitly labeled as informative or non-normative. Appendices are always non-normative, unless explicitly stated otherwise. The DITA specification contains examples to help clarify or illustrate specific aspects of the specification. Because examples are specific rather than general, they may not illustrate all aspects or be the only way to accomplish or implement an aspect of the specification. Therefore all examples are non-normative, unless explicitly stated otherwise.

Basic DITA terminology

The following terminology is used to discuss basic DITA concepts:

DITA attribute type
An attribute type that is one of the following:
  • One of the base attribute types that are defined by the DITA specification
  • A specialization of the either the @base or @props attribute
DITA document
An XML document that conforms to the requirements of this specification. A DITA document must have as its root element one of the following elements:
  • <map> or a specialization of the <map> element
  • <topic> or a specialization of the <topic> element
  • <dita>, which cannot be specialized, but which allows documents with multiple sibling topics
DITA document type
A unique set of structural modules, domain modules, and constraint modules that taken together provide the XML element and attribute declarations that define the structure of DITA documents. DITA document types normally are implemented using DITA document-type shells.
DITA document-type shell
A set of DTD or XSD declarations that implement a DITA document type by using the rules and design patterns that are included in the DITA specification. A DITA document-type shell includes and configures one or more structural modules, zero or more domain modules, and zero or more constraint modules. With the exception of the optional declarations for the <dita> element and its attributes, DITA document-type shells do not declare any element or attribute types directly.
DITA element
An XML element instance whose type is a DITA element type. DITA elements must exhibit a @class attribute that has a value that conforms to the rules for specialization hierarchy specifications.
DITA element type
An element type that is one of the following:
  • One of the base element types that are defined by the DITA specification
  • A specialization of one of the base element types
A DITA element type is declared in exactly one vocabulary module. DITA element types may only exhibit attributes that are DITA attribute types.
map instance
An occurrence of a map type in a document.
map type
An element type that defines a set of relationships among topic instances. The map type provides the root element and, through the contained element types, the substructure for the map instances. The map substructure provides hierarchy, group, and matrix organization of references to topic instances.
structural type instance
An occurrence of a topic type or a map type in a document.
topic instance
An occurrence of a topic type in a document.
topic type
An element type that defines a complete unit of content. The topic type provides the root element for the topic and, through the contained element types, the substructure for the topic instances. The root element of the topic type is not necessarily the same as the root element of a document type; document types may nest multiple topic types and may also declare non-DITA wrapper elements as the root element for compatibility with other processes.

Specialization terminology

The following terminology is used to discuss DITA specialization:

base content model
The content model of a DITA element before specialization or the application of constraints or extensions.
base type
An element or attribute type that is not a specialization. All base types are defined by the DITA specification.
extension element
Within a vocabulary module, an element type that can be extended, replaced, or constrained for use in a DITA document type.
generalization
The process by which a specialized element is transformed into a less-specialized ancestor element or a specialized attribute is transformed into a less-specialized ancestor attribute. The original specialization-hierarchy information may be preserved in the generalized instance, thus allowing the original specialized type to be recreated from the generalized instance.
restricted content model
For a DITA element type, a content model that has been restricted from the base content model for the element type by one or more of the following mechanisms:
  • Removing optional elements
  • Requiring optional elements
  • Ordering of unordered elements
  • Restricting repeatable (but optional) elements from repeating
Content models may be restricted through the use of constraint modules or through specialization.
selective domain extension
An extension that replaces an extension element with element types that are defined in an domain module, thus making the base type unavailable in the DITA document-type shell that configures the extension.
specialization
(1) The act of defining new element or attribute types as a semantic refinement of existing element or attribute types
(2) An element or attribute type that is a specialization of a base type
(3) A process by which a generalized element is transformed into one of its more specialized element types or a generalized attribute is transformed into a more specialized attribute.
specialization hierarchy
The sequence of element or attribute types, from the most general to most specialized, from which a given element or attribute type is specialized. The specialization hierarchy for a DITA element is formally declared through its @class attribute.
specialization parent
For a given DITA element type, the most specialized of its ancestors in its specialization hierarchy.
specialized attribute type
An attribute type that is defined as a semantic refinement of another attribute type. The attribute type must be specialized from either the @base or @props attribute, and its range of permissible values must be a subset of or identical to the values allowed by the original attribute type.
specialized element type
An element type that is defined as a semantic refinement of an existing element type. The content allowed by the specialized element type must be a subset of or identical to the content allowed by the original element type. Within a DITA document, all specialized element types must be refinements of one of the base element types, with the exception of elements that are used in the context of <foreign> or <unknown> elements.
structural type
A topic type or map type.

DITA modules

The following terminology is used to discuss DITA modules:

attribute domain module
A domain module that defines exactly one specialization of either the @base or @props attribute.
constraint module
A set of declarations that imposes additional constraints onto the element or attribute types that are defined in a specific vocabulary module.
domain module
A set of element types or an attribute type that supports a specific subject or functional area. Element types or attribute types in a domain can be integrated with topic types or map types to enhance semantic support for particular kinds of content. For example, the structural type <topic> declares the <keyword> element; when integrated with a domain for describing user interfaces, new keyword specializations (such as <wintitle>) become available wherever <keyword> was allowed in the original structural type.
element domain module
A domain module that defines one or more element types for use within maps or topics.
map module
A structural module that defines a single map type.
structural module
A vocabulary module that defines exactly one top-level map type or topic type. Structural modules may also define specializations of elements from domain modules.
topic module
A structural module that defines a single top-level topic type.
vocabulary module
A uniquely-named unit of element type or attribute type declaration. There are two types of vocabulary modules: structural modules and domain modules. For a given map type, topic type, or domain, there is exactly one vocabulary module that defines it.
The following figure illustrates the relationship between a DITA document, its DITA document-type shell, and the various vocabulary modules that it uses.
Figure 1. Instances, modules, and declarations Shows the relationship between a DITA document, its DITA document-type shell, and the various document-type modules that it uses.

Linking and addressing terms

The following terminology is used to discuss linking and addressing terms:

key name
An identifier defined by a value of the @keys attribute. A key is bound to one or more of the following items:
  • A resource addressed by the <topicref> element or a specialization of the <topicref> element
  • An element contained with the <topicmeta> element of the <topicref> element or a specialization of the<topicref> element
key definition
A <topicref> element or specialization of a <topicref> element that specifies the @keys attribute and defines one or more key names.
key resolution context
The root map that establishes the context for resolving key references. For a given key-resolution instance, there is at most one root map that defines the effective value of the key space, as determined by the key definition precedence rules..
key space
The effective set of unique key names that are defined by a given key resolution context. Within a given key resolution context, a key name has at most one binding.
referenced element
An element that is referenced by another DITA element. See also referencing element.
Example
The following code sample is from the installation-reuse.dita topic. The <step> element that it contains is a referenced element; other DITA topics reference the <step> element by using the @conref attribute.
<step id="run-startcmd-script">
    <cmd>Run the startcmd script that is applicable to your operating-system environment.</cmd>
</step>
referencing element
An element that references another DITA element by specifying an addressing attribute. See also referenced element and addressing attribute
Example
The following <step> element is a referencing element. It uses the @conref attribute to reference a <step> element in the installation-reuse.dita topic.
<step conref="installation-reuse.dita#reuse/run-startcmd-script>
    <cmd/>
</step>
addressing attribute
An attribute, such as @conref, @conkeyref, @keyref, and @href, that specifies an address (a URI reference or a key reference).
Parent topic: 2.1.1 Introduction to DITA
Previous topic: 2.1.1.1 About the specification source
Next topic: 2.1.1.3 Basic concepts


Basic concepts

2.1.1.3 Basic concepts

DITA has been designed to satisfy requirements for information typing, semantic markup, modularity, reuse, interchange, and production of different deliverable forms from a single source. These topics provide an overview of the key DITA features and facilities that serve to satisfy these requirements.

DITA topics
In DITA, a topic is the basic unit of authoring and reuse. All DITA topics have the same basic structure: a title and, optionally, a body of content. Topics can be generic or more specialized; specialized topics represent more specific information types or semantic roles, for example, <concept>, <task>, <reference>, or <learningContent>. See DITA topics for more information.
DITA maps
DITA maps are documents that organize topics and other resources into structured collections of information. DITA maps specify hierarchy and the relationships among the topics; they also provide the context in which keys are defined and resolved. DITA maps should have .ditamap file extensions. See DITA maps for more information.
Information typing
Information typing is the practice of identifying types of topics, such as concept, reference, and task, to clearly distinguish between different types of information. Topics that answer different reader questions (How ...? What is ...?) can be categorized with different information types. The base information types provided by DITA specializations (i.e., technical content, machine industry, and learning and training) provide starter sets of information types that can be adopted immediately by many technical and business-related organizations. See Information typing for more information.
DITA linking
DITA depends heavily on links. The purposes for which it provides links include defining the content and organization of publication structures (DITA maps), topic-to-topic navigation links and cross references, and reuse of content by reference. All DITA links use the same addressing facilities, either URI-based addresses or DITA-specific indirect addresses using keys and key references. See DITA linking for more information.
DITA addressing
DITA provides a number of facilities for establishing relationships among DITA elements and between DITA elements and non-DITA resources. All DITA relationships use the same addressing facilities irrespective of the semantics of the relationship established. DITA addresses are either direct, URI-based addresses, or indirect key-based addresses. Within DITA documents, individual elements are addressed by unique IDs specified on the common @id attribute. DITA defines two fragment identifier syntaxes for addressing DITA elements, one for topics and elements within maps and one for non-topic elements within topics. See DITA addressing for more information.
Content reuse
The DITA @conref, @conkeyref, @conrefend, and related attributes provide a mechanism for reuse of content fragments within DITA topics or maps. See Content reuse for more information
Conditional processing
Attribute-based profiling, also known as conditional processing or applicability, is the use of classifying metadata that enables the filtering, flagging, searching, indexing, and other processing based on the association of an element with one or more values in a specific classification domain. See Conditional processing for more information.
Configuration
A given DITA map or topic document is governed by a DITA document type that defines the set of structural modules (topic or map types), domain modules, and constraints modules that the map or topic can use. See Configuration for more information.
Specialization
The specialization feature of DITA allows for the creation of new element types and attributes that are explicitly and formally derived from existing types. The resulting specialization allows for the blind interchange of all conforming DITA content and a minimum level of common processing for all DITA content. It also allows specialization-aware processors to add specialization-specific processing to existing base processing. See Specialization for more information.
Constraints
Constraint modules define additional constraints for corresponding vocabulary modules in order to restrict content models or attribute lists for specific element types, remove extension elements from an integrated domain module, or replace base element types with domain-provided extension element types. Constraint modules do not and cannot change element semantics, only the details of how element types can be used in the context of a specific concrete document type. Because constraints can make optional elements required, documents that use the same vocabulary modules may still have incompatible constraints. Thus the use of constraints can affect the ability for content from one topic or map to be used directly in another topic or map. See Constraints for more information.
Parent topic: 2.1.1 Introduction to DITA
Previous topic: 2.1.1.2 DITA terminology and notation
Next topic: 2.1.1.4 File naming conventions


File naming conventions

2.1.1.4 File naming conventions

DITA uses certain naming conventions and file extension for topics, maps, modules, and document-type implementation files.

Files that contain DITA content should use the following naming conventions:

DITA topics
  • *.dita (recommended)
  • *.xml
DITA maps
*.ditamap
Conditional processing profiles
profilename.ditaval
Files that define DITA document-type components must use the following naming conventions:
Document-type shell files
  • typename.dtd
  • typename.xsd
Where typename is the name of the intended root topic or map type defined by the document type shell or, as needed, a name that clearly identifies both the intended root map or topic type and distinguishes the document type shell from other shells for the same root type.
non-normative: For example, the OASIS-provided document-type shells for technical content include two different document-type shells for the task topic type: task.dtd and generalTask.dtd, where task.dtd includes the strict task body constraint module and generalTask.dtd does not.
DTD structural module files
  • typename.mod
  • typename.ent
DTD domain module files
  • typenameDomain.mod
  • typenameDomain.ent
DTD constraint module files
constraintnameConstraint.mod
Schema structural module files
  • typenameMod.xsd
  • typenameGrp.xsd
Schema domain module files
typenameDomain.xsd
Schema constraint module files
  • constraintnameConstraintMod.xsd
  • constraintnameConstraintIntMod.xsd
Parent topic: 2.1.1 Introduction to DITA
Previous topic: 2.1.1.3 Basic concepts
Next topic: 2.1.1.5 Producing different deliverables from a single source


Producing different deliverables from a single source

2.1.1.5 Producing different deliverables from a single source

DITA is designed to produce multiple deliverable formats from a single set of DITA content. This means that many rendition details are specified neither in the DITA specification nor in the DITA content; the rendition details are defined and controlled by the processors.

Like many XML-based applications for human-readable documentation, DITA supports the separation of content from presentation. This is necessary when content is used in different contexts, since authors cannot predict how or where the material that they author will be used. The following features and mechanisms enable users to produce different deliverable formats from a single source:
DITA maps
Different DITA maps can be optimized for different delivery formats. For example, you might have a book map for printed output and another DITA map to generate online help; each map uses the same content set.
Specialization
The DITA specialization facility enables users to create the XML elements needed by a particular information set in order to provide appropriate rendition distinctions. In XML-based systems where presentation details are defined as styles bound to elements, the more precise and detailed the markup, the easier it is to define presentation rendering. Because the use of arbitrary specializations does not impede interchange or interoperability, DITA users can safely create the specializations demanded by their local delivery and rendition requirements, with a minimum of additional impact on the systems and business processes that depend on or use the content. While general XML practices suggest that element types should be semantic, specialization can be used to define element types that are purely presentational in nature. The highlighting domain is an example of such a specialization.
Conditional processing
Conditional processing makes it possible to have a topic or DITA map that contains delivery-specific content.
Content referencing
The conref mechanism makes it possible to construct delivery-specific maps or topics from a combination of generic components and delivery-context-specific components.
Key referencing
The keyref mechanism makes it possible to change variables for volatile content, redirect links, and reap the benefits of indirect addressing.
@outputclass attribute
The @outputclass attribute provides a mechanism whereby authors can indicate specific rendition intent where necessary. Note that the DITA specification does not define any values for the @outputclass attribute; the use of the @outputclass attribute is, by nature, processor specific.

While DITA is independent of any particular delivery format, it is a standard that supports the creation of human-readable content. As such, it defines some fundamental document components including paragraphs, lists, and table. When there is a reasonable expectation that such basic document components be rendered consistently, the DITA specification defines default or suggested renderings.

Parent topic: 2.1.1 Introduction to DITA
Previous topic: 2.1.1.4 File naming conventions
Next topic: 2.1.2 DITA markup


DITA markup

2.1.2 DITA markup

Topics and maps are the basic building blocks of the Darwin Information Typing Architecture (DITA). Metadata attributes and values can be added to DITA topics and maps, as well as to elements within topics, to allow for conditional publishing and content reuse.

DITA topics and maps are XML documents that conform to the XML specification. As such, they can be viewed, edited, validated, and processed with standard XML tools, although some DITA-specific features, such as content reference, key reference, and specialization require DITA-specific processing for full implementation and validation.

  • 2.1.2.1 DITA topics
    DITA topics are the basic units of DITA content and the basic units of reuse. Each topic contains a single subject. Topics may be of specific specialized information types, such as task, concept, or reference, or may be generic, that is, without a specified information type.
  • 2.1.2.2 DITA maps
    This topic collection contains information about DITA maps and the purposes that they serve. It also includes high-level information about DITA map elements, attributes, and metadata.
  • 2.1.2.3 DITA metadata
    Metadata can be applied in both DITA topics and DITA maps. Metadata that is assigned in DITA topics can be supplemented or overridden by metadata that is assigned in a DITA map; this design facilitates the reuse of DITA topics in different DITA maps and use-specific contexts.
Parent topic: 2.1 Architectural Specification: Base
Previous topic: 2.1.1.5 Producing different deliverables from a single source
Next topic: 2.1.2.1 DITA topics


DITA topics

2.1.2.1 DITA topics

DITA topics are the basic units of DITA content and the basic units of reuse. Each topic contains a single subject. Topics may be of specific specialized information types, such as task, concept, or reference, or may be generic, that is, without a specified information type.

  • 2.1.2.1.1 The topic as the basic unit of information
    In DITA, a topic is the basic unit of authoring and reuse. All DITA topics have the same basic structure: a title and, optionally, a body of content. Topics can be generic or more specialized; specialized topics represent more specific information types or semantic roles, for example, <concept>, <task>, <reference>, or <learningContent>.
  • 2.1.2.1.2 The benefits of a topic-based architecture
    Topics enable the development of usable and reusable content.
  • 2.1.2.1.3 Information typing
    Information typing is the practice of identifying types of topics, such as concept, reference, and task, to clearly distinguish between different types of information. Topics that answer different reader questions (How ...? What is ...?) can be categorized with different information types. The base information types provided by DITA specializations (i.e., technical content, machine industry, and learning and training) provide starter sets of information types that can be adopted immediately by many technical and business-related organizations.
  • 2.1.2.1.4 Generic topics
    The element type <topic> is the base topic type from which all other topic types are specialized. All topics have the same basic structure.
  • 2.1.2.1.5 Topic structure
    All topics have the same basic structure, regardless of topic type: title, description or abstract, prolog, body, related links, and nested topics.
  • 2.1.2.1.6 Topic content
    The content of all topics, regardless of topic type, is built on the same common structures.
  • 2.1.2.1.7 Topic domains: Basic DITA
    A DITA vocabulary domain defines a set of elements associated with a particular subject area or authoring requirement regardless of topic type. DITA incorporates three domains into the basic DITA content: typographic, utilities, and indexing. Other domains are incorporated into the DITA Technical Content and Learning and Training specializations.
Parent topic: 2.1.2 DITA markup
Previous topic: 2.1.2 DITA markup
Next topic: 2.1.2.1.1 The topic as the basic unit of information


The topic as the basic unit of information

2.1.2.1.1 The topic as the basic unit of information

In DITA, a topic is the basic unit of authoring and reuse. All DITA topics have the same basic structure: a title and, optionally, a body of content. Topics can be generic or more specialized; specialized topics represent more specific information types or semantic roles, for example, <concept>, <task>, <reference>, or <learningContent>.

DITA topics consist of content units that can be as generic as sets of paragraphs and unordered lists or as specific as sets of instructional steps in a procedure or cautions to be considered before a procedure is performed. Content units in DITA are expressed using XML elements and can be conditionally processed using metadata attributes and values.

Classically, a DITA topic is a titled unit of information that can be understood in isolation and used in multiple contexts. It should be short enough to address a single subject or answer a single question but long enough to make sense on its own and be authored as a self-contained unit. However, DITA topics also can be less self-contained units of information, such as topics that contain only titles and short descriptions and serve primarily to organize subtopics or links or topics that are designed to be nested for the purposes of information management, authoring convenience, or interchange.

DITA topics are used as components of DITA maps. DITA maps enable topics to be organized in a hierarchy for publication. Large units of content, such as complex reference documents or book chapters, are created by nesting topic references in a DITA map. The same set of DITA topics can be used in any number of maps.

DITA topics also can be used and published individually; for example, one can represent an entire deliverable as a single DITA document that consists of a root topic and nested topics. This strategy can accommodate the migration of legacy content that is not topic-oriented; it also can accommodate information that is not meaningful outside the context of a parent topic. However, the power of DITA is most fully realized by storing each DITA topic in a separate XML document and using DITA maps to organize how topics are combined for delivery. This enables a clear separation between how topics are authored and stored and how topics are organized for delivery.

Parent topic: 2.1.2.1 DITA topics
Previous topic: 2.1.2.1 DITA topics
Next topic: 2.1.2.1.2 The benefits of a topic-based architecture


The benefits of a topic-based architecture

2.1.2.1.2 The benefits of a topic-based architecture

Topics enable the development of usable and reusable content.

While DITA does not require the use of any particular writing practice, the DITA architecture is designed to support authoring, managing, and processing of content that is designed to be reused. Although DITA provides significant value even when reuse is not a primary requirement, the full value of DITA is realized when content is authored with reuse in mind. To develop topic-based information means creating units of standalone information that are meaningful with little or no surrounding context.

By organizing content into topics that are written to be reusable, authors can achieve several goals:

  • Content is readable when accessed from an index or search, not just when read in sequence as part of an extended narrative. Since most readers do not read technical and business-related information from beginning to end, topic-oriented information design ensures that each unit of information can be read independently.
  • Content can be organized differently for online and print delivery. Authors can create task flows and concept hierarchies for online delivery and create a print-oriented hierarchy to support a narrative content flow.
  • Content can be reused in different collections. Since a topic is written to support random access (as by search), it should also be understandable when included as part of various product deliverables. Topics permit authors to refactor information as needed, including only the topics that apply to each unique scenario.
  • Content is more manageable in topic form whether managed as individual files in a traditional file system or as objects in a content management system.
  • Content authored in topics can be translated and updated more efficiently and less expensively than information authored in larger or more sequential units.
  • Content authored in topics can be filtered more efficiently, encouraging the assembly and deployment of information subsets from shared information repositories.

Topics written for reuse should be small enough to provide opportunities for reuse but large enough to be coherently authored and read. Since each topic is written to address a single subject, authors can organize a set of topics logically and achieve an acceptable narrative content flow.

  • 2.1.2.1.2.1 Disciplined, topic-oriented writing
    Topic-oriented writing is a disciplined approach to writing that emphasizes modularity and reuse of concise units of information: topics. Well-designed DITA topics can be reused in many contexts, as long as writers are careful to avoid unnecessary transitional text.
  • 2.1.2.1.2.2 Transitional text solutions
    Topic orientation does not mean that transitions cannot be authored in DITA. The key to providing both locational independence and intentional sequences is the adroit use of DITA markup features.
Parent topic: 2.1.2.1 DITA topics
Previous topic: 2.1.2.1.1 The topic as the basic unit of information
Next topic: 2.1.2.1.2.1 Disciplined, topic-oriented writing


Disciplined, topic-oriented writing

2.1.2.1.2.1 Disciplined, topic-oriented writing

Topic-oriented writing is a disciplined approach to writing that emphasizes modularity and reuse of concise units of information: topics. Well-designed DITA topics can be reused in many contexts, as long as writers are careful to avoid unnecessary transitional text.

Conciseness and appropriateness

Readers who are trying to learn or do something quickly appreciate information that is written in a structure that is easy to follow and contains only the information needed to complete that task or grasp a fact. Recipes, encyclopedia entries, car repair procedures--all serve up a uniquely focused unit of information. The topic contains everything required by the reader.

Locational independence

A well-designed topic is reusable in other contexts to the extent that it is context free, meaning that it can be inserted into a new document without revision of its content. A context-free topic avoids transitional text. Phrases like "As we considered earlier ..." or "Now that you have completed the initial step ..." make little sense if a topic is reused in a new context in which the relationships are different or no longer exist. A well-designed topic reads appropriately in any new context because the text does not refer the reader outside the topic.

Navigational independence

Most print publications or web pages are a mixture of content and navigation. Internal links lead a reader through a sequence of choices as he or she navigates through a website. DITA supports the separation of navigation from content by assembling independent topics into DITA maps. Nonetheless, writers may want to provide links within a topic to additional topics or external resources. DITA does not prohibit such linking within individual topics. The DITA relationship table enables links between topics and to external content. Since it is defined in the DITA map, it is managed independently of the topic content.

Links in the content are best used for cross-references within a topic. Links from within a topic to additional topics or external resources should be avoided because they limit the reusability of the topic. To link from a term or keyword to its definition, use the DITA keyref facility to avoid creating topic-to-topic dependencies that are difficult to maintain. See Key-based addressing.

Parent topic: 2.1.2.1.2 The benefits of a topic-based architecture
Previous topic: 2.1.2.1.2 The benefits of a topic-based architecture
Next topic: 2.1.2.1.2.2 Transitional text solutions


Transitional text solutions

2.1.2.1.2.2 Transitional text solutions

Topic orientation does not mean that transitions cannot be authored in DITA. The key to providing both locational independence and intentional sequences is the adroit use of DITA markup features.

The print attribute on the topicref element includes the value, "printonly", which may be used to indicate that the topic be omitted when the DITA map is transformed to a format for which transitions are unnecessary. Consequently, a topic designated as "printonly" may be written in any style that serves as a transitional topic in the flow of printed information.

You can also use conditional text to insert transitional sequences into a map so that you can include or exclude the content of short descriptions or paragraphs at the end of a topic. However, if you share conditionally marked topics with other business partners or teams, you must instruct them on the proper runtime settings to enable the conditions to be used the way you intended.

DITA does not preclude authoring transitional text; it does provide an environment that allows you to tag and manage transitional elements apart from surrounding, topic-encapsulated information.

Parent topic: 2.1.2.1.2 The benefits of a topic-based architecture
Previous topic: 2.1.2.1.2.1 Disciplined, topic-oriented writing
Next topic: 2.1.2.1.3 Information typing


Information typing

2.1.2.1.3 Information typing

Information typing is the practice of identifying types of topics, such as concept, reference, and task, to clearly distinguish between different types of information. Topics that answer different reader questions (How ...? What is ...?) can be categorized with different information types. The base information types provided by DITA specializations (i.e., technical content, machine industry, and learning and training) provide starter sets of information types that can be adopted immediately by many technical and business-related organizations.

Information typing has a long history of use in the technical documentation field to improve information quality. It is based on extensive research and experience, including Robert Horn's Information Mapping and Hughes Aircraft's STOP (Sequential Thematic Organization of Proposals) technique. Note that many DITA topic types are not necessarily closely connected with traditional Information Mapping.

Information typing is a practice designed to keep documentation focused and modular, thus making it clearer to readers, easier to search and navigate, and more suitable for reuse. Classifying information by type helps authors perform the following tasks:
  • Develop new information more consistently
  • Ensure that the correct structure is used for closely related kinds of information (retrieval-oriented structures like tables for reference information and simple sequences of steps for task information)
  • Avoid mixing content types, thereby losing reader focus
  • Separate supporting concept and reference information from tasks, so that users can read the supporting information if needed and ignore if it is not needed
  • Eliminate unimportant or redundant detail
  • Identify common and reusable subject matter

DITA currently defines a small set of well-established information types that reflects common practices in certain business domains, for example, technical communication and instruction and assessment. However, the set of possible information types is unbounded. Through the mechanism of specialization, new information types can be defined as specializations of the base topic type (<topic>) or as refinements of existing topics types, for example, <concept>, <task>, <reference>, or <learningContent>.

You need not use any of the currently-defined information types. However, where a currently defined information type matches the information type of your content, the currently defined information type should be used, either directly, or as a base for specialization. For example, information that is procedural in nature should use the task information type or a specialization of task. Consistent use of established information types helps ensure smooth interchange and interoperability of DITA content.

Parent topic: 2.1.2.1 DITA topics
Previous topic: 2.1.2.1.2.2 Transitional text solutions
Next topic: 2.1.2.1.4 Generic topics


Generic topics

2.1.2.1.4 Generic topics

The element type <topic> is the base topic type from which all other topic types are specialized. All topics have the same basic structure.

For authors, typed content is preferred to support consistency in writing and presentation to readers. The generic topic type should only be used if authors are not trained in information typing or when a specialized topic type is inappropriate. The OASIS DITA standard provides several specialized topic types, including concept, task, and reference that are critical for technical content development.

For those pursuing specialization, new specialized topic types should be specialized from appropriate ancestors to meet authoring and output requirements.

Parent topic: 2.1.2.1 DITA topics
Previous topic: 2.1.2.1.3 Information typing
Next topic: 2.1.2.1.5 Topic structure


Topic structure

2.1.2.1.5 Topic structure

All topics have the same basic structure, regardless of topic type: title, description or abstract, prolog, body, related links, and nested topics.

All DITA topics must have an XML identifier (the @id attribute) and a title. The basic topic structure consists of the following parts, some of which are optional:
Topic element
The topic element holds the required @id attribute and contains all other elements.
Title
The title contains the subject of the topic.
Alternate titles
Titles specifically for use in navigation or search. When not provided, the base title is used for all contexts.
Short description or abstract
A short description of the topic or a longer abstract with an embedded short description. The short description may be used both in topic content (as the first paragraph), in generated summaries that include the topic, and in links to the topic. Alternatively, the abstract lets you create more complex introductory content and uses an embedded short description element to define the part of the abstract that is suitable for summaries and link previews.
While short descriptions aren't required, they can make a dramatic difference to the usability of an information set and should generally be provided for all topics.
Prolog
The prolog is the container for topic metadata, such as change history, audience, product, and so on.
Body
The topic body contains the topic content: paragraphs, lists, sections, and other content that the information type permits.
Related links
Related links connect to other topics. When an author creates a link as part of a topic, the topic becomes dependent on the other topic being available. To reduce dependencies between topics and thereby increase the reusability of each topic, authors may use DITA maps to define and manage links between topics, instead of embedding links directly in each related topic.
Nested topics
Topics can be defined inside other topics. However, nesting requires special care because it can result in complex documents that are less usable and less reusable. Nesting may be appropriate for information that is first converted from desktop publishing or word processing files or for topics that are unusable independent from their parent or sibling topics.
The rules for topic nesting can be configured in a document-type shells. For example, the standard DITA configuration for concept topics only allows nested concept topics. However, local configuration of the concept topic type could allow other topic types to nest or disallow topic nesting entirely. In addition, the @chunk attribute enables topics to be equally re-usable regardless of whether they are separate or nested. The standard DITA configuration for ditabase document-type documents allows unrestricted topic nesting and may be used for holding sets of otherwise unrelated topics that hold re-usable content. It may also be used to convert DITA topics from non-DITA legacy source without first determining how individual topics should be organized into separate XML documents.
Parent topic: 2.1.2.1 DITA topics
Previous topic: 2.1.2.1.4 Generic topics
Next topic: 2.1.2.1.6 Topic content


Topic content

2.1.2.1.6 Topic content

The content of all topics, regardless of topic type, is built on the same common structures.

Topic body
The topic body contains all content except for that contained in the title or the short description/abstract. The topic body may be specialized to impose constraints appropriate for the specific topic type even when titles and prolog are generic, or the topic body may be generic where the topic title and prolog are specialized.
Sections and examples
The body of a topic may contain divisions, such as sections and examples. They may contain block-level elements like titles and paragraphs and phrase-level elements like API names or text. It is recommend that sections have titles, whether they are entered directly into the title element or rendered using a fixed or default title.
Either body divisions or untitled sections or examples may be used to delimit arbitrary structures within a topic body. However, body divisions may nest, but sections and examples cannot contain sections.
Sectiondiv
Sectiondiv allows for the arbitrary grouping of content within a section for the purpose of content reuse. The sectiondiv does not include a title. Content that requires a title should use section or example.
Bodydiv
Bodydiv allows for the arbitrary grouping of content within the body of a topic for the purpose of content reuse. The bodydiv does not include a title. Content that requires a title should use section or example.
Block-level elements
Paragraphs, lists, and tables are types of "block" elements. As a class of content, they can contain other blocks, phrases, or text, though the rules vary for each structure.
Phrases and keywords
Block-level elements can contain markup to label parts of a paragraph or parts of a sentence as having special semantic meaning or presentation characteristics, such as <uicontrol> or <b>. Phrases can usually contain other phrases and keywords as well as text. Keywords can only contain text.
Images
Images can be inserted to display photos, illustrations, screen captures, diagrams, and the like. At the phrase level, they can display trademark characters, icons, toolbar buttons, and the like.
Multimedia
With the object element, multimedia information may be added to display, for example, diagrams that can be rotated and expanded. With the <foreign> element, media may be included within topic content, e.g., SVG graphics, MathML equations, and so on.
Parent topic: 2.1.2.1 DITA topics
Previous topic: 2.1.2.1.5 Topic structure
Next topic: 2.1.2.1.7 Topic domains: Basic DITA


Topic domains: Basic DITA

2.1.2.1.7 Topic domains: Basic DITA

A DITA vocabulary domain defines a set of elements associated with a particular subject area or authoring requirement regardless of topic type. DITA incorporates three domains into the basic DITA content: typographic, utilities, and indexing. Other domains are incorporated into the DITA Technical Content and Learning and Training specializations.

The elements in a domain are defined in a domain module. A domain module can be integrated with a topic type to make the domain elements available within the topic type structure. The following domains are provided as part of basic DITA:

Table 1. DITA topic domains: Basic DITA
Domain | Description | Short name | Module name
Typographic | For highlighting when the appropriate semantic element doesn't exist yet | hi-d | highlightDomain.mod (DTD) highlightDomain.xsd (Schema)
Utilities | For providing imagemaps and other useful structures | ut-d | utilitiesDomain.mod (DTD) utilitiesDomain.xsd (Schema)
Indexing | For extended indexing functions such as see and see-also | indexing-d | indexingDomain.mod (DTD) indexingDomain.xsd (Schema)
Parent topic: 2.1.2.1 DITA topics
Previous topic: 2.1.2.1.6 Topic content
Next topic: 2.1.2.2 DITA maps


DITA maps

2.1.2.2 DITA maps

This topic collection contains information about DITA maps and the purposes that they serve. It also includes high-level information about DITA map elements, attributes, and metadata.

  • 2.1.2.2.1 Definition of DITA maps
    DITA maps are documents that organize topics and other resources into structured collections of information. DITA maps specify hierarchy and the relationships among the topics; they also provide the context in which keys are defined and resolved. DITA maps should have .ditamap file extensions.
  • 2.1.2.2.2 Purpose of DITA maps
    DITA maps enable the scalable reuse of content across multiple contexts. They can be used by information architects, writers, and publishers to plan, develop, and deliver content.
  • 2.1.2.2.3 DITA map elements
    A DITA map describes the relationships among a set of DITA topics. The DITA map and map group elements organize topics into hierarchies, groups, and relationships; they also define keys.
  • 2.1.2.2.4 DITA map attributes
    DITA maps have unique attributes that are designed to control the way that relationships are interpreted for different output purposes. In addition, DITA maps share many metadata and linking attributes with DITA topics.
  • 2.1.2.2.5 Subject scheme maps
    A subject scheme map enables adopters to create custom controlled values and to manage metadata attribute values for an organization or a project without having to write a DITA specialization.
Parent topic: 2.1.2 DITA markup
Previous topic: 2.1.2.1.7 Topic domains: Basic DITA
Next topic: 2.1.2.2.1 Definition of DITA maps


Definition of DITA maps

2.1.2.2.1 Definition of DITA maps

DITA maps are documents that organize topics and other resources into structured collections of information. DITA maps specify hierarchy and the relationships among the topics; they also provide the context in which keys are defined and resolved. DITA maps should have .ditamap file extensions.

Maps draw on a rich set of existing best practices and standards for defining information models, such as hierarchical task analysis. They also support the definition of non-hierarchical relationships, such as matrices and groups, which provide a set of capabilities that has similarities to Resource Description Framework (RDF) and ISO topic maps.

DITA maps use <topicref> elements (or specializations of the <topicref> element) to reference DITA topics, DITA maps, and non-DITA resources, for example, HTML and TXT files. The <topicref> elements can be nested or grouped to create relationships between the referenced topics, maps, and non-DITA files; the <topicref> elements can be organized into hierarchies in order to represent a specific order of navigation or presentation.

DITA maps impose an architecture on a set of topics. Information architects can use DITA maps to specify what DITA topics are needed to support a given set of user goals and requirements; the sequential order of the topics; and the relationships that exist among those topics. Because DITA maps provide this context for topics, the topics themselves can be relatively context-free; they can be used and reused in multiple different contexts.

DITA maps often represent a single deliverable, for example, a specific Web site, a printed publication, or the online help for a product. DITA maps also can be subcomponents for a single deliverable, for example, a DITA map might contain the content for a chapter in a printed publication or the troubleshooting information for an online help system. The DITA specification provides specialized map types; book maps represent printed publications, subject scheme maps represent taxonomic or ontological classifications, and learning maps represent formal units of instruction and assessment. However, these map types are only a starter set of map types reflecting well-defined requirements.

DITA maps establish relationships through the nesting of <topicref> elements and the application of the @collection-type attribute. Relationship tables may also be used to associate topics with each other based on membership in the same row; for example, task topics can be associated with supporting concept and reference topics by placing each group in cells of the same row. During processing, these relationships can be rendered in different ways, although they typically result in lists of "Related topics" or "For more information" links. Like many aspects of DITA, the details about how such linking relationships are presented is determined by the DITA processor.

DITA maps also define keys and provide the context in which key references are resolved. A <topicref> element (or specialized <topicref> such as <keydef>) may be used to define a key which binds that key name to a specified resource.

Parent topic: 2.1.2.2 DITA maps
Previous topic: 2.1.2.2 DITA maps
Next topic: 2.1.2.2.2 Purpose of DITA maps


Purpose of DITA maps

2.1.2.2.2 Purpose of DITA maps

DITA maps enable the scalable reuse of content across multiple contexts. They can be used by information architects, writers, and publishers to plan, develop, and deliver content.

DITA maps support the following uses:

Defining an information architecture
Maps can be used to define the topics that are required for a particular audience, even before the topics themselves exist. DITA maps can aggregate multiple topics for a single deliverable.
Defining what topics to build for a particular output
Maps reference topics that are included in output processing. Information architects, authors, and publishers can use maps to specify a set of topics that are processed at the same time, instead of processing each topic individually. In this way, a DITA map can serve as a manifest or bill of materials.
Defining navigation
Maps can define the online navigation or table of contents for a deliverable.
Defining related links
Maps define relationships among the topics they reference. These relationships are defined by the nesting of elements in the DITA map, relationship tables, and the use of elements on which the @collection-type attribute is set. On output, these relationships might be expressed as related links or the hierarchy of a table of contents (TOC).
Defining an authoring context
The DITA map can define the authoring framework, providing a starting point for authoring new topics and integrating existing ones.
Defining keys
Maps can define keys, which provide an indirect addressing mechanism that enhances portability of content. The keys are defined by <topicref> elements or specialization of <topicref> elements, such as <keydef>. The <keydef> element is a convenience element; it is a specialized type of a <topicref> element with the following attributes:
  • A required @keys attribute
  • A @processing-role attribute with a default value of "resource-only".
Maps also are the context for resolving key-based references, such as elements that specify the @keyref or @conkeyref attribute.

Specialized maps can provide additional semantics beyond those of organization, linking, and indirection. For example, the subjectScheme map specialization adds the semantics of taxonomy and ontology definition.

Parent topic: 2.1.2.2 DITA maps
Previous topic: 2.1.2.2.1 Definition of DITA maps
Next topic: 2.1.2.2.3 DITA map elements


DITA map elements

2.1.2.2.3 DITA map elements

A DITA map describes the relationships among a set of DITA topics. The DITA map and map group elements organize topics into hierarchies, groups, and relationships; they also define keys.

Map and map group elements

A DITA map is composed of the following elements:
map
The <map> element is the root element of the DITA map.
topicref

The <topicref> elements are the basic elements of a map. A <topicref> element can reference a DITA topic, a DITA map, or any non-DITA resource. A <topicref> element also can have a title, short description, and the same kind of prolog-level metadata that is available in topics.

The <topicref> elements can be nested to create a hierarchy, which can be used to define a table of contents (TOC) for print output, online navigation, and parent/child links. Hierarchies can be annotated using the @collection-type attribute to define a particular type of relationship, such as a set of choices, a sequence, or a family. These collection types can affect link generation, and they may be interpreted differently for different outputs.

reltable

Relationship tables are defined with the <reltable> element. Relationship tables can be used to define relationships between DITA topics or between DITA topics and non-DITA resources. In a relationship table, the columns define common attributes, metadata, or information type (for example, task or troubleshooting) for the resources referenced in that column. The rows define relationships between the resources referenced in different cells of the same row.

The <relrow>, <relcell>, <relheader>, and <relcolspec> elements are used to define the components of the relationship table. Relationships defined in the relationship table also can be further refined by using the @collection-type attribute.

topicgroup
The <topicgroup> element defines a group or collection outside of a hierarchy or relationship table. It is a convenience element that is equivalent to a <topicref> element with no @href attribute or navigation title. Groups can be combined with hierarchies and relationship tables, for example, by including a <topicgroup> element within a set of siblings in a hierarchy or within a table cell. The <topicref> elements so grouped can then share inherited attributes and linking relationships with no effect on the navigation or table of contents.
topicmeta
Most map-level elements, including the map itself, can contain metadata inside the <topicmeta> element. Metadata typically is applied to the element and its descendants.
topichead
The <topichead> element provides a navigation title; it is an convenience element that is equivalent to a <topicref> element with a navigation title but no @href attribute.
anchor
The <anchor> element provides an integration point that another map can reference in order to insert its navigation into the current navigation tree. For those familiar with Eclipse help systems, this serves the same purpose as the <anchor> element in that system. It may not be supported for all output formats.
navref
The <navref> element represents a pointer to another map which should be preserved as a transcluding link rather than resolved. Output formats that support such linking will integrate the referenced resource when displaying the referencing map to an end user.
keydef
Enables authors to define keys. This element is a convenience element; it is a specialization of <topicref> that sets the default value of the @processing-role attribute to resource-only. Setting the @processing-role attribute to resource-only ensures that the resource referenced by the key definition is not directly included in the navigation that is defined by the map that includes the key definition.
mapref
Enables authors to reference an entire DITA map, including hierarchy and relationship tables. This element is a convenience element; it is a specialization of <topicref> that sets the default value of the @format attribute to ditamap. The <mapref> element represents a reference from a parent map to a subordinate map.
topicset
Enables authors to define a branch of navigation in a DITA map so that it can be referenced from another DITA map.
topicsetref
Enables authors to reference a navigation branch that is defined in another DITA map.
anchorref
Enables authors to define a map fragment that is pushed to the location defined by an anchor.

Example of a simple map with a relationship table

The following example contains the markup for a simple relationship table:

<map>
...
<reltable>
  <relheader>
    <relcolspec type="concept"/>
    <relcolspec type="task"/>
    <relcolspec type="reference"/>
  </relheader>
  <relrow>
    <relcell>
      <topicref href="A.dita"/>
    </relcell>
    <relcell>
      <topicref href="B.dita"/>
    </relcell>
    <relcell>
      <topicref href="C1.dita"/>
      <topicref href="C2.dita"/>
    </relcell>
  </relrow>
</reltable>
</map>
A DITA-aware tool might represent the <reltable> graphically:
type="concept" | type="task" | type="reference"
A | B | C1 C2

When the output is generated, the topics contain the following linkage:

A
Links to B, C1, and C2
B
Links to A, C1, and C2
C1, C2
Links to A and B

Example of a simple map that defines keys

The following example illustrates how keys can be defined:

<map>
    <keydef keys="dita-tc" href="dita_technical_committee.dita"/>
    <keydef keys="dita-adoption" href="dita_adoption_technical_committee.dita"/>
    ...
</map>

The map also could be tagged in either of the following ways:

<topicref> element with @processing-role attribute set to "resource-only"
<map>
    <topicref keys="dita-tc" href="dita_technical_committee.dita" processing-role="resource-only"/>
    <topicref keys="dita-adoption" href="dita_adoption_technical_committee.dita" processing-role="resource-only"/>
    ...
</map>
<topicref> element with @toc, @linking, and @search attributes set to "no"
<map>
    <topicref keys="dita-tc" href="dita_technical_committee.dita" toc="no" linking="no" search="no"/>
    <topicref keys="dita-adoption" href="dita_adoption_technical_committee.dita" toc="no" linking="no" search="no"/>
    ...
</map>

Example of a simple map that references another map

The following code sample illustrates how a DITA map can reference another DITA map:

<map>
    <title>DITA work at OASIS</title>
    <topicref href="oasis-dita-technical-committees.dita>
        <topicref href="dita_technical_committee.dita"/>
        <topicref href="dita_adoption_technical_committee.dita/>
    </topicref>
<mapref href"oasis-processes.ditamap"/>
...
</map>

The map also could be tagged in the following way:

<map>
    <title>DITA work at OASIS</title>
    <topicref href="oasis-dita-technical-committees.dita>
        <topicref href="dita_technical_committee.dita"/>
        <topicref href="dita_adoption_technical_committee.dita/>
    </topicref>
<topicref href"oasis-processes.ditamap" format="ditamap/>
...
</map>

With either of the above examples, during processing, the map is resolved in the following way:

<map>
    <title>DITA work at OASIS</title>
    <topicref href="oasis-dita-technical-committees.dita>
        <topicref href="dita_technical_committee.dita"/>
        <topicref href="dita_adoption_technical_committee.dita/>
    </topicref>
<-- Contents of the oasis-processes.ditamap file -->
<topicref href"oasis-processes.dita>
    ...
</topicref>
...
</map>

Example of maps that use the <anchor> element and the @anchorref attribute

In this example, an anchor is defined with an ID of "a1".
<map>
  <title>MyComponent tasks</title>
  <topicref navtitle="Start here" href="start.dita" toc="yes">
    <navref mapref="othermap2.ditamap"/>
    <navref mapref="othermap3.ditamap"/>
    <anchor id="a1"/>
  </topicref>
</map>
The id on <anchor> can be referenced by the anchorref attribute on another map's <map> element. For example, the map to be integrated at that spot would be defined as follows.
<map anchorref="a1">
  <title>This map is pulled into the MyComponent task map</title>
  ...
</map>
Parent topic: 2.1.2.2 DITA maps
Previous topic: 2.1.2.2.2 Purpose of DITA maps
Next topic: 2.1.2.2.4 DITA map attributes


DITA map attributes

2.1.2.2.4 DITA map attributes

DITA maps have unique attributes that are designed to control the way that relationships are interpreted for different output purposes. In addition, DITA maps share many metadata and linking attributes with DITA topics.

Attributes unique to DITA maps

DITA maps often encode structures that are specific to a particular medium or output, for example, Web pages or a PDF document. Attributes, such as @print and @toc, are designed to help processors interpret the DITA map for each kind of output. These attributes are not available in DITA topics; individual topics, once separated from the high-level structures and dependencies associated with a particular kind of output, should be entirely reusable regardless of the intended output format. The @collection-type and @linking attributes affect how related links are generated for topics that are referenced in the DITA map.

collection-type
The @collection-type attribute specifies how the children of a <topicref> element relate to their parent and to each other. This attribute, which is set on the parent element, typically is used by processors to determine how to generate navigation links in the rendered topics. For example, a @collection-type value of "sequence" indicates that children of the specifying <topicref> element represent an ordered sequence of topics; processors might add numbers to the list of child topics or generate next/previous links for online presentation. Where the @collection-type attribute is available on elements that cannot directly contain elements (such as <reltable> or <relcolspec>), the behavior of the attribute is reserved for future use.
linking
By default, the relationships between the topics that are referenced in a map are reciprocal:
  • Child topics link to parent topics and vice versa.
  • Next and previous topics in a sequence link to each other.
  • Topics in a family link to their sibling topics.
  • Topics referenced in the table cells of the same row in a relationship table link to each other. A topic referenced within a table cell does not (by default) link to other topics referenced in the same table cell.
This behavior can be modified by using the @linking attribute, which enables an author or information architect to specify how a topic should participate in a relationship. The following values are valid:
linking="none"
Specifies that the topic does not exist in the map for the purposes of calculating links.
linking="sourceonly"
Specifies that the topic will link to its related topics but not vice versa.
linking="targetonly"
Specifies that the related topics will link to it but not vice versa.
linking="normal"
Default value. It specifies that linking will be reciprocal (the topic will link to related topics, and they will link back to it).
Authors also can create links directly in a topic by using the <xref> or <link> elements, but in most cases map-based linking is preferable, because links in topics create dependencies between topics that can hinder reuse.

Note that while the relationships between the topics that are referenced in a map are reciprocal, the relationships merely imply reciprocal links in generated output that includes links. The rendered navigation links are a function of the presentation style that is determined by the processor.

toc
Specifies whether topics are excluded from navigation output, such as a Web site map or an online table of contents. By default, <topicref> hierarchies are included in navigation output; relationship tables are excluded.
navtitle
Specifies a navigation title. This is a shorter version of the title that is used in the navigation only. By default, the @navtitle attribute is ignored; it serves only to help the DITA map author keep track of the title of the topic.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
locktitle

If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.

Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
print
Specifies whether the topic should be included in printed output
search
Specifies whether the topic should be included in search indexes.
chunk
Specifies that the processor generates an interim set of DITA topics that are used as the input for the final processing. This can produce the following output results:
  • Multi-topic files are transformed into smaller files, for example, individual HTML files for each DITA topic.
  • Individual DITA topics are combined into a single file.
Specifying a value for the @chunk attribute on a <map> element establishes chunking behavior that applies to the entire map, unless overridden by @chunk attributes that are set on more specific elements in the DITA map. For a detailed description of the @chunk attribute and its usage, see Chunking.
copy-to

In most situations, specifies whether a duplicate version of the topic is created when it is transformed. This duplicate version can be either literal or virtual. The value of the @copy-to attribute specifies the uniform resource identifier (URI) by which the topic can be referenced by a @conref attribute, <topicref> element, or <xref> element. The duplication is a convenience for output processors that use the URI of the topic to generate the base address of the output. The @keys and @keyref attributes provide an alternative mechanism; they enable references to topics in specific-use contexts without making copies.

The @copy-to attribute also can be used to specify the name of a new chunk when topics are being chunked; it also can be used to determine the name of the stub topic that is generated from a <topicref> element that contains a title but does not specify a target. In both of those cases, no duplicate version of the topic is generated.

For information on how the @copy-to attribute can be used with the @chunk attribute, see Chunking.

processing-role
Specifies whether the topic or map referenced should be processed normally or treated as a resource that is only included in order to resolve key or content references.
processing-role="normal"
The topic is a readable part of the information set. It is included in navigation and search results. This is the default value for the <topicref> element.
processing-role="resource-only"
The topic should be used only as a resource for processing. It is not included in navigation or search results, nor is it rendered as a topic. This is the default value for the <keydef> element.
If the @processing-role attribute is not specified locally, the value cascades from the closest element in the containment hierarchy.

Attributes shared by DITA maps and DITA topics

The following metadata and reuse attributes are used by both DITA maps and DITA topics:
  • product, platform, audience, otherprops, rev, status, importance
  • dir, xml:lang, translate
  • id, conref, conrefend, conkeyref,, conaction
  • props, base
  • , search
DITA maps also use many of the following attributes that are used with <link> or <xref> elements in DITA topics:
  • format
  • href
  • keyref
  • scope
  • type
  • query

When new attributes are specialized from @props or @base as a domain, they may be incorporated into both map and topic structural types.

How the collection-type and linking attributes work in a relationship table

The following example illustrates how linkage is defined in a DITA map:
Figure 1. Simple linking example
<topicref href="A.dita" collection-type="sequence">
  <topicref href="A1.dita"/>
  <topicref href="A2.dita"/>
</topicref>
<reltable>
  <relrow>
    <relcell><topicref href="A.dita"/></relcell>
    <relcell><topicref href="B.dita"/></relcell>
  </relrow>
</reltable>
When the output is generated, the topics contain the following linkage:
A
Links to A1, A2 as children
Links to B as related
A1
Links to A as a parent
Links to A2 as next in the sequence
A2
Links to A as a parent
Links to A1 as previous in the sequence
B
Links to A as related
The following example illustrates how setting the @linking attribute can change the default behavior:
Figure 2. Linking example with the linking attribute
<topicref href="A.dita" collection-type="sequence">
  <topicref href="B.dita" linking="none"/>
  <topicref href="A1.dita"/>
  <topicref href="A2.dita"/>
</topicref>
<reltable>
  <relrow>
    <relcell><topicref href="A.dita"/></relcell>
    <relcell linking="sourceonly"><topicref href="B.dita"/></relcell>
  </relrow>
</reltable>
When the output is generated, the topics contain the following linkage:
A
Links to A1, A2 as children
Does not link to B as a child or related topic
A1
Links to A as a parent
Links to A2 as next in the sequence
Does not link to B as previous in the sequence
A2
Links to A as a parent
Links to A1 as previous in the sequence
B
Links to A as a related topic
Parent topic: 2.1.2.2 DITA maps
Previous topic: 2.1.2.2.3 DITA map elements
Next topic: 2.1.2.2.5 Subject scheme maps


Subject scheme maps

2.1.2.2.5 Subject scheme maps

A subject scheme map enables adopters to create custom controlled values and to manage metadata attribute values for an organization or a project without having to write a DITA specialization.

Subject scheme maps use key definition to define a collection of controlled values rather than a collection of topics. The highest level of map that uses the set of controlled values must reference the subject scheme map in which those controlled values are defined.

A controlled value is a short, readable, and meaningful keyword that can abe used as a value in a metadata attribute. For example, the @audience metadata attribute may take a value that identifies the user group associated with a particular content unit. Typical user values for a medical-equipment product line might include therapist, oncologist, physicist, radiologist, and so on. In a subject scheme map, an information architect can define a list of these audience values. Authoring tools may use these lists of controlled values to provide value lists from which authors may select values when they are entering metadata.

If controlled values for a metadata attribute are defined using the subject scheme map, tools may give an organization a list of readable labels, a hierarchy of values to simplify selection, and a shared definition of the value.

Controlled values may be used to classify content for filtering and flagging at build time. They may also be used for retrieval and traversal of the content at run time if information viewers that provide such functionality are available.

Tools may validate controlled values for attributes by reference to the subject scheme map. As with all key definitions and references, the reference must appear in the highest map that makes use of the controlled values.

Defining a list of controlled values

A specialized DITA map, <subjectScheme> is used to define a collection of controlled values. Each controlled value is defined using a specialized topic reference, called <subjectdef>. The <subjectdef> is used to define both a category and a list of controlled values. The top-level <subjectdef> defines the category and the children define the controlled values. The following example illustrates the use of <subjectdef> to define controlled values for a group of users:
<subjectScheme>
<!-- Pull in a scheme that defines audience user values -->
    <subjectdef keys="users">
        <subjectdef keys="therapist">
        <subjectdef keys="oncologist">
        <subjectdef keys="radiationphysicist">
        <subjectdef keys="radiologist">
    </subjectdef>

 <!-- Define an enumeration of the audience attribute, equal to
       each value in the users subject. This makes the following values
       valid for the audience attribute: therapist, oncologist, physicist, radiologist -->
     <enumerationdef>
         <attributedef name="audience"/>
         <subjectdef keyref="users"/>
     </enumerationdef>...
</subjectScheme>
Within the <subjectdef> element
  • <navtitle> can provide a more readable value name
  • <shortdesc> within <topicmeta> can provide a definition
An enumeration may be defined with hierarchical levels by nesting subject definitions. If filtering or flagging excludes "therapist" and does not explicity identify "novice", processing should apply filtering to all subsets of therapist. If filtering includes "novice" but does not explicity exclude "therapist", processing should include the general therapist content because it applies to "novice". If flagging explicity includes "therapist" but is not set explicity for "novice", processing should apply the "therapist" flag to the "novice" content as a special type of therapist.
<subjectScheme>
    <subjectdef keys="users">
        <subjectdef keys="therapist">
            <subjectdef keys="novice"/>
            <subjectdef keys="expert"/>
        </subjectdef>
        <subjectdef keys="oncologist">
        <subjectdef keys="physicist">
        <subjectdef keys="radiologist">
    </subjectdef>
The <subjectdef> element can use an @href attribute to refer to a more detailed definition of the subject. For example, the value of "oncologist" could refer to an encyclopedia entry that describes the oncologist role in medicine.
<subjectdef keys="oncologist" href="encyclopedia/oncologist.dita"/>
These definitions may help to clarify the meaning of a value, especially when different parts of an organization may use the same term differently. An editor may support drilling down to the subject definition topic for a detailed explanation of the subject. DITA output formatting may produce a help file, PDF, or other readable catalog for understanding the controlled values.

Validating metadata attributes against a subject scheme

After locating the scheme, editors may validate an attribute against the bound enumeration, preventing users from entering misspelled or undefined values. A map editor may validate the audience attribute in a map against the scheme. A processor may check that all values listed for an attribute in a DITAVAL file are bound to the attribute by the scheme before filtering or flagging.

Scaling a subject scheme to define a taxonomy

A taxonomy differs from a controlled values list primarily in the degree of precision with which the metadata values are defined. A set of controlled values lists is sometimes regarded as the simplest form of taxonomy. Regardless of whether the goal is a simple list of controlled values or a taxonomy:

  • The same core elements are used (subjectScheme, subjectdef, and schemeref).
  • A category and its subjects can have a binding that enumerates the values of a metadata attribute.

Beyond the core elements and the attribute binding elements, sophisticated taxonomies can take advantage of some optional elements in the scheme. Most of these optional elements make it possible to specify more precise relationships among subjects.

The <hasNarrower>, <hasPart>, <hasKind>, <hasInstance>, and <hasRelated> elements specify the kind of relationship in a hierarchy between a container subject and its contained subjects. The following example defines San Francisco as an instance of a city but a geographic part of California.
<subjectScheme>
  <hasInstance>
    <subjectdef keys="city" navtitle="City">
       <subjectdef keys="la" navtitle="Los Angeles"/>
       <subjectdef keys="nyc" navtitle=New York City"/>
       <subjectdef keys="sf" navtitle="San Francisco">
    </subjectdef>
    <subjectdef keys="state" navtitle="State">
       <subjectdef keys="ca" navtitle="California"/>
       <subjectdef keys="ny" navtitle=New York"/>
    </subjectdef>
   </hasInstance>
   <hasPart>
      <subjectdef keys="place" navtitle="Place">
        <subjectdef keys="ca">
          <subjectdef keys="la">
          <subjectdef keys="sf">
      </subjectdef>
      <subjectdef keys="ny">
         <subjectdef keys="nyc">
      </subjectdef>
    </hasPart>
 </subjectScheme>

Sophisticated tools can use this scheme to associate content about San Francisco with related content about other California places or with related content about other cities (depending on the interests of the current user).

The scheme can also define relationships between subjects that are not hierarchical. For instance, cities sometimes have "sister city" relationships. The example scheme could add a subjectRelTable element to define these associative relationships, with a row for each sister-city pair and the two cities in different columns in the row.

While users who have access to sophisticated processing tools benefit from defining taxonomies with this level of precision, other users can safely ignore this advanced markup and define taxonomies with hierarchies of subjectdef elements that aren't precise about the kind of relationship between the subjects.

Parent topic: 2.1.2.2 DITA maps
Previous topic: 2.1.2.2.4 DITA map attributes
Next topic: 2.1.2.3 DITA metadata


DITA metadata

2.1.2.3 DITA metadata

Metadata can be applied in both DITA topics and DITA maps. Metadata that is assigned in DITA topics can be supplemented or overridden by metadata that is assigned in a DITA map; this design facilitates the reuse of DITA topics in different DITA maps and use-specific contexts.

  • 2.1.2.3.1 Metadata elements
    The metadata elements, many of which map to Dublin core metadata, are available in topics and DITA maps. This design enables authors and information architects to use identical metadata markup in both topics and maps.
  • 2.1.2.3.2 Metadata attributes
    Certain attributes are common across most DITA elements. These attributes support content referencing, conditional processing, application of metadata, and globalization and localization.
  • 2.1.2.3.3 Metadata in maps and topics
    Topic metadata can be specified in a DITA map as well as in the topics that the map references. By default, metadata in the map supplements or overrides metadata that is specified at the topic level, unless the @lockmeta attribute of the <topicref> element is set to "no".
  • 2.1.2.3.4 Cascading of attributes and metadata in a DITA map
    Certain map-level attributes and metadata elements cascade throughout a map, which facilitates attribute and metadata management. When attributes or metadata elements cascade, they apply to the elements that are children of the element where the attributes or metadata were specified. Cascading applies to a containment hierarchy, as opposed to a element-type hierarchy.
  • 2.1.2.3.5 Map-to-map cascading behaviors
    When a DITA map (or branch of a DITA map) is referenced by another DITA map, by default, certain rules apply. These rules pertain to the cascading behaviors of attributes, metadata elements, and roles assigned to content (such as the role of "Chapter" assigned by a <chapter> element). Attributes and elements that cascade within a map generally follow the same rules when cascading from one map to another map; this topic covers the exceptions and additional rules that apply.
  • 2.1.2.3.6 Reconciling topic and map metadata
    The <topicmeta> element in maps contains numerous elements that can be used to declare metadata. These metadata elements have an effect on the parent <topicref> element, any child <topicref> elements, and – if a direct child of the <map> element – on the map as a whole.
Parent topic: 2.1.2 DITA markup
Previous topic: 2.1.2.2.5 Subject scheme maps
Next topic: 2.1.2.3.1 Metadata elements


Metadata elements

2.1.2.3.1 Metadata elements

The metadata elements, many of which map to Dublin core metadata, are available in topics and DITA maps. This design enables authors and information architects to use identical metadata markup in both topics and maps.

The <metadata> element is a wrapper element that contains many of the metadata elements. In topics, the <metadata> element is available in the <prolog> element. In maps, the <metadata> element is available in the <topicmeta> element.

In DITA maps, the metadata elements also are available directly in the <topicmeta> element. However, it is recommended to use the metadata elements available in the <metadata> element, as it better supports reuse between topics and maps. Collections of metadata can be shared between DITA maps and topics by using the conref or keyref mechanism.

In general, specifying metadata in a <topicmeta> element is equivalent to specifying it in the <prolog> element of a referenced topic. The value of specifying the metadata at the map level is that the topic then can be reused in other maps where different metadata might apply. Many items in the <topicmeta> element also cascade to nested <topicref> elements within the map.

Note: Not all metadata elements are currently available in the <metadata> element. However, they are available in either the topic <prolog> element or the map <topicmeta> element.
Parent topic: 2.1.2.3 DITA metadata
Previous topic: 2.1.2.3 DITA metadata
Next topic: 2.1.2.3.2 Metadata attributes
Dublin Core Metadata Initiative (DCMI)


Metadata attributes

2.1.2.3.2 Metadata attributes

Certain attributes are common across most DITA elements. These attributes support content referencing, conditional processing, application of metadata, and globalization and localization.

  • 2.1.2.3.2.1 Conditional processing attributes
    The metadata attributes specify properties of the content that can be used to determine how the content should be processed. Specialized metadata attributes can be defined to enable specific business processing needs, such as semantic processing and data mining.
  • 2.1.2.3.2.2 Translation and localization attributes
    DITA elements have several attributes that support localization and translation.
  • 2.1.2.3.2.3 Architectural attributes
    The architectural attributes specify the version of DITA that the content supports, identify the DITA domains that are in use by the content, and provide essential information about specializations that are in use by the content.
Parent topic: 2.1.2.3 DITA metadata
Previous topic: 2.1.2.3.1 Metadata elements
Next topic: 2.1.2.3.2.1 Conditional processing attributes


Conditional processing attributes

2.1.2.3.2.1 Conditional processing attributes

The metadata attributes specify properties of the content that can be used to determine how the content should be processed. Specialized metadata attributes can be defined to enable specific business processing needs, such as semantic processing and data mining.

Metadata attributes typically are used for the following purposes:

  • Filtering content based on the attribute values, for example, to suppress or publish profiled content
  • Flagging content based on the attribute values, for example, to highlight specific content on output
  • Performing custom processing, for example, to extract business-critical data and store in it a database

Typically @audience, @platform, @product, @otherprops, @props, and specializations of the @props attributes are used for filtering; the same attributes plus the @rev attribute are used for flagging. The @status and @importance attributes, as well as custom attributes specialized from @base, are used for application-specific behavior, such as identifying metadata to aid in search and retrieval.

Filtering and flagging attributes

The following conditional-processing attributes are available on most elements:

product
The product that is the subject of the discussion.
platform
The platform on which the product is deployed.
audience
The intended audience of the content.
rev
The revision or draft number of the current document. (This is typically used only for flagging.)
otherprops
Other properties that do not require semantic identification.
props
A generic conditional processing attribute that can be specialized to create new semantic conditional processing attributes.

In general, a conditional processing attribute provides a list of one or more values separated with whitespace. For instance, audience="administrator programmer" qualifies the content as applying to administrators and programmers.

Other metadata attributes

Other attributes are still considered metadata on an element, but they are not designed for filtering or flagging.

importance
The degree of priority of the content. This attribute takes a single value from an enumeration.
status
The current state of the content. This attribute takes a single value from an enumeration.
base
A generic attribute that has no specific purpose, but is intended to act as the basis for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace).
outputclass
Provides a label on one or more element instances, typically to specify a role or other semantic distinction. As the @outputclass attribute does not provide a formal type declaration or the structural consistency of specialization, it should be used sparingly, usually only as a temporary measure while a specialization is developed. For example, <uicontrol> elements that define button labels could be distinguished by adding an @outputclass attribute:
<uicontrol outputclass="button">Cancel</uicontrol>
The value of the @outputclass attribute may be used to trigger XSLT or CSS rules, while providing a mapping to be used for future migration to a more specialized set of user interface elements.
Parent topic: 2.1.2.3.2 Metadata attributes
Previous topic: 2.1.2.3.2 Metadata attributes
Next topic: 2.1.2.3.2.2 Translation and localization attributes
Related concepts
2.1.3.6 Conditional processing (profiling)
3.1.8 DITAVAL elements
Related reference
3.4.1.5 select-atts attribute group


Translation and localization attributes

2.1.2.3.2.2 Translation and localization attributes

DITA elements have several attributes that support localization and translation.

xml:lang
Identifies the language of the content, using the standard language and country codes. For instance, French Canadian is identified by the value fr-ca. The @xml:lang attribute asserts that all content and attribute values within the element bearing the attribute are in the specified language, except for contained elements that declare a different language.
translate
Determines whether the element requires translation. A default value may be inferred from the element type. For example, <apiname> may be untranslated by default, whereas <p> may be translated by default.
dir
Determines the direction in which the content should be rendered.
Parent topic: 2.1.2.3.2 Metadata attributes
Previous topic: 2.1.2.3.2.1 Conditional processing attributes
Next topic: 2.1.2.3.2.3 Architectural attributes


Architectural attributes

2.1.2.3.2.3 Architectural attributes

The architectural attributes specify the version of DITA that the content supports, identify the DITA domains that are in use by the content, and provide essential information about specializations that are in use by the content.

The architectural attributes should not be marked up in the source DITA map and topic instances. Instead, the values of the architectural attributes are handled by the processor when the content is processed, preferably through defaults set in the DTD or Schema declaration. This practice ensures that the DITA content instances do not specify invalid values for the architectural attributes.

The architectural attributes are as follows:

class
This attribute identifies the specialization modules for the element type as well as its ancestors. Every DITA element (except the <dita> element that is used as the root of a ditabase document) has a @class attribute.
domains
This attribute identifies the domain specialization modules used in a map or topic and, for each domain module, its module dependencies. The root element of every topic and map has a @domains attribute.
DITAArchVersion
This attribute identifies the version of the DITA architecture used by the DTD or schema. The root element of every topic and map has a @DITAArchVersion attribute. The attribute is declared in a DITA namespace to allow namespace-sensitive tools to detect DITA markup.

To make the document instance usable in the absence of a DTD or Schema declaration, a normalization process may set the architectural attributes in the document instance.

Parent topic: 2.1.2.3.2 Metadata attributes
Previous topic: 2.1.2.3.2.2 Translation and localization attributes
Next topic: 2.1.2.3.3 Metadata in maps and topics


Metadata in maps and topics

2.1.2.3.3 Metadata in maps and topics

Topic metadata can be specified in a DITA map as well as in the topics that the map references. By default, metadata in the map supplements or overrides metadata that is specified at the topic level, unless the @lockmeta attribute of the <topicref> element is set to "no".

Where metadata about topics can be specified

Information about topics can be specified as metadata on the map, as attributes on the <topicref> element, or as metadata attributes or elements in the topic itself:
DITA map: Metadata elements

At the map level, properties can be set by using metadata elements. They can be set for an individual topic, for a set of topics, or globally for the entire document. The metadata elements are authored within a <topicmeta> element, which associates metadata with the parent element, plus the other children of that element. Because the topics in a branch of the hierarchy typically have some common subjects or properties, this is a convenient mechanism to set properties for a set of topics. For example, the <topicmeta> element in a <relcolspec> can associate metadata with all the topics that are referenced in the <reltable> column.

A map can override or supplement everything about a topic except its primary title and body content. All the metadata elements that are available in a topic also are available in a map. In addition, a map may provide alternate titles and a short description. The alternate titles can override their equivalents in the topic. The short description in the map may override the short description in the topic if both following conditions are true:
  • The <topicref> element specifies a @copy-to attribute.
  • The processor implements this behavior. Processors may or may not implement this behavior.
DITA map: Attributes of the <topicref> element
At the map level, properties can be set as attributes of the <topicref> element.
DITA topic
Within a topic, authors can either set metadata attributes on the root element or add metadata elements in the <prolog> element.

How metadata set at both the map and topic level is handled

In a topic, the metadata elements apply to the entire topic. In a map, they supplement or override any metadata that is provided in the referenced topics. When the same metadata element or attribute is specified in both a map and a topic, by default the value in the map takes precedence, on the assumption that the author of the map has more knowledge of the reusing context than the author of the topic had. The @lockmeta attribute on the <topicmeta> element controls whether map-specified values override values in the referenced topic.

The <navtitle> element is an exception to the rule of how metadata specified by the <topicmeta> element is propagated. The content of the <navtitle> element is used as a navigation title only if the @locktitle attribute of the parent <topicref> element is set to "yes".

Associating attribute-based metadata with element-based metadata

At the topic level, the content of the prolog metadata elements can provide more information about the values that are used for attributes on the elements in the body of the DITA topic. However, prolog metadata and attribute metadata also can be used and expressed independently. The coordination shown here is possible but is not required.

<prolog>
  <metadata>
    <audience name="AdminNovice"
              type="administrator"
              job="customizing"
              experiencelevel="novice">

  </metadata>
</prolog>
....
<p audience="AdminNovice ProgrammerExp">This paragraph applies to both
novice administrators and expert programmers</p>

In the preceding example, the attribute value AdminNovice is associated with the audience element with the same name, which gives authors and processes more information about the audience in question: in this case, that the "AdminNovice" audience consists of administrators who are customizing and who are new at it.

Parent topic: 2.1.2.3 DITA metadata
Previous topic: 2.1.2.3.2.3 Architectural attributes
Next topic: 2.1.2.3.4 Cascading of attributes and metadata in a DITA map


Cascading of attributes and metadata in a DITA map

2.1.2.3.4 Cascading of attributes and metadata in a DITA map

Certain map-level attributes and metadata elements cascade throughout a map, which facilitates attribute and metadata management. When attributes or metadata elements cascade, they apply to the elements that are children of the element where the attributes or metadata were specified. Cascading applies to a containment hierarchy, as opposed to a element-type hierarchy.
The following attributes and metadata elements cascade throughout the entire map:
  • Attributes set on the <map> element
  • Metadata elements that are contained in the <topicmeta> element that is a child of the <map> element
Attribute values and metadata elements in relationship tables can be applied to entire columns or rows as well as individual cells, a practice that is particularly useful for attribute and metadata management.

Attributes and metadata that cascade

The following attributes and metadata elements cascade:
Attributes
  • @audience, @platform, @product, @otherprops, @rev
  • @props and any attribute specialized from @props
  • @linking, @toc, @print, @search
  • @format, @scope, @type
  • @xml:lang, @dir, @translate
  • @processing-role
Metadata elements
  • author, source, publisher, copyright, critdates, permissions
  • audience, category, prodinfo, othermeta
Cascading is additive for attributes and metadata elements that accept multiple values. For attributes that take a single value, the closest value defined on a containing element takes effect. In a relationship table, row-level metadata is considered more specific than column-level metadata, as shown in the following containment hierarchy:
  • <map> (most general)
    • <topicref> container (more specific)
      • <topicref> (most specific)
    • <reltable> (more specific)
      • <relcolspec> (more specific)
        • <relrow> (more specific)
          • <topicref> (most specific)

Rules for cascading in the map

When determining the value of an attribute, processors must evaluate each attribute on each individual element in a specific order; this order is specified in the following list. Applications should continue through the list until a value is established or until the end of the list is reached (at which point no value is established for the attribute). In essence, the list provides instructions on how processors can construct a map where all attribute values are set and all cascading is complete.

For example, in the case of <topicref toc="yes>, applications must stop at 2 in the list; a value is specified for @toc in the document instance, so @toc values from containing elements will not cascade to that specific <topicref> element. The @toc="yes" setting on that <topicref> element may cascade to contained elements, provided those elements reach 5 below when evaluating the @toc attribute.

For attributes within a map, the following processing order must occur:
  1. The @conref and @keyref attributes are evaluated.
  2. The explicit values specified in the document instance are evaluated. For example, a <topicref> element with the @toc attribute set to "no" will use that value.
  3. The default or fixed attribute values that are expressed within DTDs or XSDs are evaluated. For example, in the DTDs and XSDs, the @toc attribute on the <reltable> element has a default value of "no".
  4. The default values that are supplied by a controlled values file are evaluated.
  5. The attributes cascade.
  6. The processing-supplied default values are applied.
  7. After the attributes are resolved within the map, they cascade to referenced maps.
    Note: The processing-supplied default values do not cascade to other maps. For example, most
       processors will supply a default value of @toc="yes" when no @toc attribute is specified.
       However, a processor-supplied default of toc="yes" must not override a value of toc="no" that
       is set on a referenced map. If the toc="yes" value is explicitly specified, is given as a
       default through a DTD, XSD, or controlled values file, or cascades from a containing element
       in the map, it will override a toc="no" setting on the referenced map. See Map-to-map cascading behaviors for more details.
  8. Repeat steps 1 to 4 for each referenced map.
  9. The attributes cascade within each referenced map.
  10. The processing-supplied default values are applied within each referenced map.
  11. Repeat the process for maps referenced within the referenced maps.

Example of metadata elements cascading in a DITA map

The following code sample illustrates how an information architect can apply certain metadata to all the DITA topics in a map:
<map title="DITA maps" xml:lang="en-us">
    <topicmeta>
        <author>Kristen James Eberlein</author>
        <copyright>
            <copyryear year="2009"/>
            <copyrholder>OASIS</copyrholder>
        </copyright>
    </topicmeta>
    <topicref href="dita_maps.dita" navtitle="DITA maps">
        <topicref href="definition_ditamaps.dita" navtitle="Definition of DITA maps"></topicref>
        <topicref href="purpose_ditamaps.dita" navtitle="Purpose of DITA maps"></topicref>
        ...
</map>

The author and copyright information cascades to each of the DITA topics referenced in the DITA map. When the DITA map is processed to XHTML, for example, each XHTML files contains the metadata information.

Parent topic: 2.1.2.3 DITA metadata
Previous topic: 2.1.2.3.3 Metadata in maps and topics
Next topic: 2.1.2.3.5 Map-to-map cascading behaviors


Map-to-map cascading behaviors

2.1.2.3.5 Map-to-map cascading behaviors

When a DITA map (or branch of a DITA map) is referenced by another DITA map, by default, certain rules apply. These rules pertain to the cascading behaviors of attributes, metadata elements, and roles assigned to content (such as the role of "Chapter" assigned by a <chapter> element). Attributes and elements that cascade within a map generally follow the same rules when cascading from one map to another map; this topic covers the exceptions and additional rules that apply.

Cascading of attributes from map to map

The following attributes cascade within a single map:
  • @audience, @platform, @product, @otherprops, @rev
  • @props and any attribute specialized from @props
  • @linking, @toc, @print, @search
  • @format, @scope, @type
  • @xml:lang, @dir, @translate
  • @processing-role
Of these, the following attributes do not cascade from map to map:
  • @format: this attribute must be set to "ditamap" in order to reference a map or a branch of a map, so it cannot cascade through to the referenced map.
  • @xml:lang and @dir: cascading behavior for xml:lang is defined in The @xml:lang attribute. The @dir and translate attributes work the same way.
  • @scope: the @scope value describes the map itself, rather than the content. A @scope value of "external" indicates that the referenced map itself is external and unavailable, so the value cannot cascade into that referenced map.

The @class attribute does not cascade within a map, but is used to determine processing roles that cascade from map to map. See Cascading of roles in specialized maps for more details.

As with values that cascade within a map, the cascading is additive if the attribute permits multiple values (such as @audience). When the attribute only permits one value, the cascading value overrides the top-level element.

Example of attributes cascading between maps

For example, assume the following references in test.ditamap:
<map>
  <topicref href="a.ditamap" format="ditamap" toc="no"/>
  <mapref   href="b.ditamap" audience="developer"/>
  <topicref href="c.ditamap#branch1" format="ditamap" print="no"/>
  <mapref   href="c.ditamap#branch2" platform="myPlatform"/>
</map>
  • The map a.ditamap is treated as if toc="no" is specified on the root <map> element. This means that the topics that are referenced by a.ditamap do not appear in the navigation generated by test.ditamap (except for branches within the map that explicitly set toc="yes").
  • The map b.ditamap is treated as if audience="developer" is set on the root <map> element. If the audience attribute is already set on the root <map> element within b.ditamap, the value "developer" is added to any existing values.
  • The element with id="branch1" within the map c.ditamap is
treated as if print="no" is specified on that element. This means
that the topics within the branch with id="branch1" do not appear
in the printed output generated by test.ditamap (except
for nested branches within that branch that explicitly set print="yes").
  • The element with id="branch2" within the map c.ditamap is treated as if platform="myPlatform" is specified on that element. If the @platform attribute is already specified on the element with id="branch", the value "myPlatform" is added to existing values.

Cascading of metadata elements

Elements that are contained within <topicmeta> or <metadata> follow the same rules for cascading as apply within a single DITA map. For a complete list of which elements cascade within a map, see the column "Does it cascade to child <topicref> elements?" in the topic Reconciling topic and map metadata.

For example, consider the following code snippets:

Figure 1. test-2.ditamap
<map>
    <topicref href="a.ditamap" format="ditamap">
        <topicmeta>
            <shortdesc>This map contains information about Acme defects.</shortdesc>
        </topicmeta>
    </topicref>
    <topicref href="b.ditamap" format="ditamap">
        <topicmeta>
            <audience type="programmer"/>
        </topicmeta>
    </topicref>
    <mapref href="c.ditamap" format="ditamap"/>
    <mapref href="d.ditamap" format="ditamap"/>
    </map>
Figure 2. b.ditamap
<map>
    <topicmeta>
        <audience type="writer"/>
    </topicmeta>
    <topicref href="b-1.dita"/>
    <topicref href="b-2.dita"/>
</map>
When test-2.ditamap is processed, the following behaviour occurs:
  • Because the <shortdesc> element does not cascade, it does not apply to the DITA topics that are referenced in a.ditamap.
  • Because the <audience> element cascades, the <audience> element in the reference to b.ditamap combines with the <audience> attribute that is already specified at the top level of that map. The result is that the b-1.dita topic and b-2.dita topic are processed as if they each contained the following child <topicmeta> element:
    <topicmeta>
    <audience type="programmer"/>
    <audience type="writer"/>
</topicmeta>
Note: It is possible that a specialization might define metadata that should replace rather than add to metadata in the referenced map, but DITA (by default) does not currently support this behavior.

Cascading of roles in specialized maps

When a <topicref> element or a specialization of a <topicref> element references a DITA resource, it defines a role for that resource. In some cases this role is straightforward, such as when a <topicref> element references a DITA topic (giving it the already known role of "topic"), or when a <mapref> element references a DITA map (giving it the role of "DITA map").

Unless otherwise instructed, a specialized topicref element that references a map supplies a role for the referenced content. This means that, in effect, the @class attribute of the referencing element cascades to top-level topicref elements in the referenced map. In situations where this should not happen - such as all elements from the OASIS-supplied "mapgroup" domain - the non-default behavior should be clearly specified.

For example, when a <chapter> element from the bookmap specialization references a map, it supplies a role of "chapter" for each top-level element in the referenced map. When the <chapter> element references a branch in another map, it supplies a role of "chapter" for that branch. In effect, the @class attribute for <chapter> ("- map/topicref bookmap/chapter ") cascades to the top-level topicref in the nested map, although it does not cascade any further.

Alternatively, the <mapref> element in the "mapgroup" domain is a convenience element; the top-level <topicref> elements in the map referenced by a <mapref> element must not be processed as if they are <mapref> elements. The @class attribute from the <mapref> element ("+ map/topicref mapgroup-d/mapref ") does not cascade to the referenced map.

In some cases, preserving the role of the referencing element might result in out-of-context content. For example, a <chapter> element that references a bookmap might pull in <part> elements that contain nested <chapter> elements. Treating the <part> element as a <chapter> will result in a chapter that nests other chapters, which is not valid in bookmap and may not be understandable by processors. The result is implementation specific; processors may or may not choose to treat this as an error, issue a warning, or simply assign new roles to the problematic elements.

Example of cascading roles between maps

Consider the scenario of a <chapter> element that references a DITA map. This scenario could take several forms:
Referenced map contains a single top-level <topicref> element
The entire branch functions as if it were included in the bookmap; the top-level <topicref> element is processed as if it were the <chapter> element.
Referenced map contains multiple top-level <topicref> elements
Each top-level <topicref> element is processed as if it were a <chapter> element (the referencing element).
Referenced map contains a single <appendix> element
The <appendix> element is processed as it were a <chapter> element.
Referenced map contains a single <part> element, with nested <chapter> elements.
The <part> element is processed as it were a chapter element. Nested <chapter> elements may not be understandable by processors; applications may recover as described above.
<chapter> element references a single <topicref> element rather than a map
The referenced <topicref> element is processed as if it were a <chapter> element.
Parent topic: 2.1.2.3 DITA metadata
Previous topic: 2.1.2.3.4 Cascading of attributes and metadata in a DITA map
Next topic: 2.1.2.3.6 Reconciling topic and map metadata


Reconciling topic and map metadata

2.1.2.3.6 Reconciling topic and map metadata

The <topicmeta> element in maps contains numerous elements that can be used to declare metadata. These metadata elements have an effect on the parent <topicref> element, any child <topicref> elements, and – if a direct child of the <map> element – on the map as a whole.

For each element that can be contained in the <topicmeta> element, the following table addresses the following questions:
How does it apply to the topic?
This column describes how the metadata specified within the <topicmeta> element interacts with the metadata specified in the topic. In most cases, the properties are additive. For example, when the <audience> element is set to "user" at the map level, the value "user" is added during processing to any audience metadata that is specified within the topic.
Does it cascade to other topics in the map?
This column indicates whether the specified metadata value cascades to nested <topicref> elements. For example, when an <audience> element is set to "user" at the map level, all child <topicref> elements implicitly have an <audience> element set to "user" also. Elements which can apply only to the specific <topicref> element, such as <linktext>, do not cascade.
What is the purpose when specified on the <map> element?
The map element allows metadata to be specified for the entire map. This column describes what effect, if any, an element has when specified at this level.
Table 1. Topicmeta elements and their properties
Element | How does it apply to the topic? | Does it cascade to child <topicref> elements? | What is the purpose when set on the <map> element?
<audience> | Add to the topic | Yes | Specify an audience for the entire map
<author> | Add to the topic | Yes | Specify an author for the entire map
<category> | Add to the topic | Yes | Specify a category for the entire map
<copyright> | Add to the topic | Yes | Specify a copyright for the entire map
<critdates> | Add to the topic | Yes | Specify critical dates for the entire map
<data> | Add to the topic | No, unless specialized for a purpose that cascades | No stated purpose, until the element is specified
<data-about> | Add the property to the specified target | No, unless specialized for a purpose that cascades | No stated purpose, until the element is specified
<foreign> | Add to the topic | No, unless specialized for a purpose that cascades | No stated purpose, until the element is specified
<keywords> | Add to the topic | No | No stated purpose
<linktext> | Not added to the topic; applies only to links created based on this occurrence in the map | No | No stated purpose
<metadata> | Add to the topic | Yes | Specify metadata for the entire map
<navtitle> | Not added to the topic; applies only to navigation that is created based on this occurrence in the map. The @locktitle attribute of the parent <topicref> element must be set to "yes" in order for the navigation title to be used. | No | No stated purpose
<othermeta> | Add to the topic | No | Define metadata for the entire map
<permissions> | Add to the topic | Yes | Specify permissions for the entire map
<prodinfo> | Add to the topic | Yes | Specify product info for the entire map
<publisher> | Add to the topic | Yes | Specify a publisher for the map
<resourceid> | Add to the topic | No | Specify a resource ID for the map
<searchtitle> | Replace the one in the topic. If multiple <searchtitle> elements are specified for a singletarget, processors may choose to issue a warning. | No | No stated purpose
<shortdesc> | Only added to the topic when the <topicref> element specifies a @copy-to attribute. Otherwise, it applies only to links created based on this occurrence in the map. Note: Processors may or may not implement this behavior. | No | Provide a description of the map
<source> | Add to the topic | No | Specify a source for the map
<unknown> | Add to the topic | No, unless specialized for a purpose that cascades | No stated purpose, until the element is specified
Parent topic: 2.1.2.3 DITA metadata
Previous topic: 2.1.2.3.5 Map-to-map cascading behaviors
Next topic: 2.1.3 DITA processing


DITA processing

2.1.3 DITA processing

Several common DITA processing behaviors are driven by attributes, including setting the set of vocabulary and constraint modules on which a DITA document depends, navigation, linking, content reuse (via direct or indirect addressing), conditional processing, chunking, and printing. In addition, translation of DITA content is expedited through the use of the @dir, @translate, and @xml:lang attributes, and the <index-sort-as> element.

  • 2.1.3.1 Module compatibility and the @domains attribute
    A given DITA document declares, through the @domains attribute on <map> and <topic> elements, the set of vocabulary and constraint modules on which it depends.
  • 2.1.3.2 Navigation behaviors
    DITA includes markup that processors may use to generate reader navigation to or across DITA topics.
  • 2.1.3.3 DITA linking
    DITA depends heavily on links. The purposes for which it provides links include defining the content and organization of publication structures (DITA maps), topic-to-topic navigation links and cross references, and reuse of content by reference. All DITA links use the same addressing facilities, either URI-based addresses or DITA-specific indirect addresses using keys and key references.
  • 2.1.3.4 DITA addressing
    DITA provides a number of facilities for establishing relationships among DITA elements and between DITA elements and non-DITA resources. All DITA relationships use the same addressing facilities irrespective of the semantics of the relationship established. DITA addresses are either direct, URI-based addresses, or indirect key-based addresses. Within DITA documents, individual elements are addressed by unique IDs specified on the common @id attribute. DITA defines two fragment identifier syntaxes for addressing DITA elements, one for topics and elements within maps and one for non-topic elements within topics.
  • 2.1.3.5 Content inclusion (conref)
    The DITA @conref, @conkeyref, @conrefend, and related attributes provide a mechanism for reuse of content fragments within DITA topics or maps.
  • 2.1.3.6 Conditional processing (profiling)
    Attribute-based profiling, also known as conditional processing or applicability, is the use of classifying metadata that enables the filtering, flagging, searching, indexing, and other processing based on the association of an element with one or more values in a specific classification domain.
  • 2.1.3.7 Chunking
    Content may be chunked (divided or merged into new output documents) in different ways for the purposes of authoring, for delivering content, and for navigation. For example, something best authored as a set of separate topics may need to be delivered as a single Web page. A map author can use the chunk attribute to split up multi-topic documents into component topics or combine multiple topics into a single document as part of output processing.
  • 2.1.3.8 Printing
    By default, the content of most elements is included in all output media. The DITA map provides a means to suppress element content from appearing in print-oriented media, or from appearing in non-print-oriented media, such as HTML. The generation or non-generation of print and other forms of output can also be affected through the use of other navigation-related attributes.
  • 2.1.3.9 Translation and localization
    DITA has features that facilitate preparing content for translation and working with multilingual content, including the @xml:lang attribute, the @dir attribute, and the @translate attribute. In addition, the <index-sort-as> element provides support for index sorting in languages in which the index sort order must be modified by the author or translator.
Parent topic: 2.1 Architectural Specification: Base
Previous topic: 2.1.2.3.6 Reconciling topic and map metadata
Next topic: 2.1.3.1 Module compatibility and the @domains attribute


Module compatibility and the @domains attribute

2.1.3.1 Module compatibility and the @domains attribute

A given DITA document declares, through the @domains attribute on <map> and <topic> elements, the set of vocabulary and constraint modules on which it depends.

The @domains attribute serves two primary purposes:

  • To indicate to DITA processors the specific features that they should or must provide in order to completely process the document.
  • To determine the validity of elements that are copied from one DITA document to another. This copying may occur as the result of a content reference (conref) or key reference (keyref), or may occur in the context of an author editing a DITA document.

A processor can examine the value of the @domains attribute and compare the set of modules listed to the set of modules for which it provides direct support. It then can take appropriate action if it does not provide support for a given module, for example, issuing a warning before applying fallback processing.

When copying, it is necessary to determine if the data being copied (the copy source) requires modules that are not required by the document into which the data is to be copied (the copy target). Such a copy operation is always safe if the copy source requires a subset of the modules that are required by the copy target. Such a copy is unsafe if the copy source requires modules that are not required by the copy target.

When a copy operation is unsafe, processors may compare the copy source to the copy target to determine if the copy source satisfies the constraints of the copy target. If the copy source meets the copy target constraints, the copy may be allowed. Processors should issue a warning that the copy was allowed but the constraints are not compatible. If the copy source does not meet the constraints of the copy target, processors may apply generalization until the generalized result either satisfies the copy target constraints or no further generalization can be performed. If the copy operation can be performed following generalization, the processor should issue a warning that the constraints are not compatible and generalization had to be performed in order to complete the copy operation.

Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3 DITA processing
Next topic: 2.1.3.2 Navigation behaviors


Navigation behaviors

2.1.3.2 Navigation behaviors

DITA includes markup that processors may use to generate reader navigation to or across DITA topics.

While DITA content can be processed to create output with media-specific navigational aids, this topic discusses only the behaviors that are derived from markup.

Tables of contents (TOCs)

Processors may generate a TOC based on the hierarchy of the <topicref> elements in the DITA map. Each <topicref> element in the map represents a node in the TOC (unless it is set as a "resource only" topic reference). These topic references define a navigation tree. When a map contains a topic reference to a map (often called a map reference), processors should integrate the referenced map's navigation tree with the referencing map's navigation tree at the point of reference. In this way, a deliverable may be compiled from multiple DITA maps.

Note:

If a <topicref> element that references a map contains child <topicref> elements, the processing behavior of the child <topicref> elements is undefined.

By default, the text for each node in the TOC is obtained from the referenced topic's title. If the @locktitle attribute on the <topicref> element is set to "yes", the node text must be taken from the @navtitle attribute or <navtitle> child element of the <topicref> element and must not be read from the referenced topic's title. If a <topicref> element contains both a <navtitle> child element and a @navtitle attribute, the @locktitle attribute applies to both <navtitle> and @navtitle and, when set to "yes", the value of the <navtitle> element must be used.

A TOC node is generated for every <topicref> element (or specialization thereof) that references a topic or specifies a navigation title, except in the following cases:

  • The @processing-role attribute is specified on the <topicref> element or an ancestor element.
  • The @print attribute is specified on the <topicref> element or an ancestor element and the current processing is not for print output.
  • Conditional processing is used to filter out this node or an ancestor node.
  • No @href or @navtitle attribute is set and no child <navtitle> element exists, or the node is a <topicgroup> element.

To suppress a <topicref> element from appearing in the TOC, set its @toc attribute to "no". The value of the @toc attribute cascades to child <topicref> elements, so if @toc is set to "no" on a particular <topicref>, all of that <topicref>'s children are also excluded from the TOC. If a child <topicref> overrides the cascading TOC node suppression by specifying @toc="yes", then the node that specifies @toc="yes" must appear in the TOC (minus the intermediate nodes that turned off @toc).

Indexing

An index may be generated from index entries occurring in topic bodies, topic prologs, or DITA maps. For more information, see the language reference for the <indexterm> element.

Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3.1 Module compatibility and the @domains attribute
Next topic: 2.1.3.3 DITA linking


DITA linking

2.1.3.3 DITA linking

DITA depends heavily on links. The purposes for which it provides links include defining the content and organization of publication structures (DITA maps), topic-to-topic navigation links and cross references, and reuse of content by reference. All DITA links use the same addressing facilities, either URI-based addresses or DITA-specific indirect addresses using keys and key references.

At its most general, a link establishes a relationship among two or more objects. In DITA, relationships are among DITA elements and either other DITA elements or non-DITA resources, such as Web pages. Relationships may be explicitly typed in some cases (relationship tables and subject scheme maps for example) but are not always associated with a specific relationship type.

Note: For example, a <keyword> element that uses a key reference to link to the definition of the keyword can be considered to be establishing a "mention-of" relationship from the <keyword> element to the definition and a "definition-of" relationship from the definition to the <keyword> element. But those link types are not formally defined either in the DITA definition of <keyword> or in the markup for the <keyword> element itself. While DITA enables the formal definition of typed relationships for some types of link elements, it does not require that all links be formally typed and does not provide a general mechanism for associating explicit link types with links.

In the abstract, link relationships may be explicit, defined directly by some type of markup in the source data, or implicit, implied by properties of the content that a processor uses to infer relationships (for example, matching the content of a <keyword> element to the title of a topic of a specific topic type). DITA formally defines only explicit links, although processors may implement implicit links.

A link may establish either a navigation relationship or a use-by-reference relationship (e.g., content references). Navigation relationships are used primarily to enable navigation from one element to another, although they may also be used for other purposes, such as classification, or association of metadata. Use-by-reference relationships establish the effective structure and content of the information set.

An element that establishes one or more such relationships is a "link-defining element". Some element types, such as <link> and <xref>, are always link-defining elements. Other element types become link-defining elements when they use specific link-defining attributes.

Almost any element may become a use-by-reference link by using the @conref or @conkeyref attribute to establish a content reference (conref) relationship to another element or set of elements (see Use by reference). Elements such as <term> and <keyword> may become navigation links by using the @keyref attribute to establish a relationship to another DITA element or non-DITA resource.

In general, elements within topics that take both the @href and @keyref attributes always act as elements that define a navigation link, while elements that take @keyref but not @href act as elements that define a navigation link only when they specify @keyref.

A given link-defining element may establish more than one relationship. For example, an element may establish both a content reference link and a navigation link. A single row in a relationship table may establish a number of distinct relationships among the topics referenced in the different cells of the relationship table. A topic reference within a hierarchy of topic references establishes not only a use-by-reference relationship from the map to the topic, but also hierarchical relationships from the referenced topic to other topics in the navigation hierarchy (parents, siblings, and children).

DITA defines two forms of addresses for use in defining links, direct URI-based addresses and indirect key references. In all cases, the nature of the relationships established is independent of the form of address used. For example, a cross reference that uses a key reference to address the target of the cross reference is functionally equivalent to having addressed the same target by URI reference, in that the final processing result should be the same in both cases. However, the two forms of address have different practical and intermediate processing implications. See DITA addressing.

Links from maps to other maps, topics, or non-DITA resources establish explicit dependencies from the map containing the links to the associated resources. Links from maps to maps create a "map tree". The set of dependencies for a root map is the union of the dependencies of all the maps in the map tree.

Links from a topic to other topics, maps, or non-DITA resources establish explicit dependencies from the topic containing the links to the associated resources, and implicit dependencies from any maps that use that linking topic to its dependencies.

For the purposes of determining the set of dependencies for a given map tree, processors may ignore any implicit dependencies created by links within topics that are not also established by explicit dependencies in the map tree. In the case where a map includes a topic that includes a topic-to-topic link, where the linked topic is not explicitly included in the map, and the processor considers only dependencies that are explicitly defined in the map, the processor may fail to resolve the topic-to-topic link. This case can be avoided by using a resource-only topic reference in the map tree to establish the dependency explicitly. If the resource-only topicref also defines a key, the link within the topic can then be changed to use a key reference (@keyref or @conkeyref) instead of a URI reference (@href, @conref). See Key-based addressing.

Navigation links have an associated "scope" indicating the closeness of the relationship of the linking element to associated resources. See The scope attribute.

Most navigation links have an associated "link text", which is the text used to render the link so that it can be used. For all elements that allow or require link text, the link text may be specified as part of the linking element or, if unspecified, should be taken from the referenced resource. The details for how the link text for a given element should or may be generated are defined for that element type and may also be determined entirely by a rendition processor.

In the specific case of cross references created using <xref> and related links using <link>, the potential set of rules for constructing link text is essentially unbounded. Processors may, for example, define conventions for the value of @outputclass by which authors can indicate the details of how the link text should be constructed, or they may provide appropriate configuration options for controlling or customizing the construction of link text in cross references.

  • 2.1.3.3.1 Links within maps
    DITA maps serve primarily to define a navigation hierarchy of topics and non-DITA resources. Through relationship tables, maps may also define arbitrary topic-to-topic relationships such as "related links". Maps may also link to topics or non-DITA resources to establish dependency relationships without binding the linked resource into the navigation tree.
  • 2.1.3.3.2 Links within topics
    A topic may contain several types of links.
Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3.2 Navigation behaviors
Next topic: 2.1.3.3.1 Links within maps


Links within maps

2.1.3.3.1 Links within maps

DITA maps serve primarily to define a navigation hierarchy of topics and non-DITA resources. Through relationship tables, maps may also define arbitrary topic-to-topic relationships such as "related links". Maps may also link to topics or non-DITA resources to establish dependency relationships without binding the linked resource into the navigation tree.

By default, the topic references within a map but not within a relationship table establish a navigation tree rooted at the root map within a map tree. A topic reference contributes to the navigation tree when it specifies a navigation title or references a topic or non-DITA resource. The @collection-type attribute of the <topicref> element determines the relationships established between the topicref and its parent, sibling, and child topicrefs, as well as among its child topicrefs.

A <topicref> or <navref> element that references a map does not bind the map to the navigation tree but acts as a form of use-by-reference link to the direct subelements of <map> and the relationship tables of the referenced map.

Maps may also contain relationship tables (<reltable>). Relationship tables establish navigation links among sets of topics and non-DITA resources. A given relationship table defines one or more links of a specific relationship type. See reltable. A map may include any number of relationship tables. Within a map tree, the effective set of relationship tables is the union of all the relationship tables in all the maps in the map tree.

Topic references that specify a @processing-role value of "resource-only" establish dependencies from the map to the associated resource but do not bind the resource to the navigation tree. Resource-only topic references are typically used for key definitions where the key is not intended to represent a specific navigation tree location and for topics that hold elements used only for content reference or that otherwise should not be reflected in the navigation tree.

Topic references in the navigation tree can further control whether or not they are included in tables of contents using the @toc attribute. A topic reference that specifies "no" for the @toc attribute and is not a resource-only topic reference still contributes to the navigation tree. In particular, any relationships determined by the value of the @collection-type attribute are created.

Topic references in the navigation tree can use the @linking attribute to control how links created by the effective @collection-type value apply to the topic reference's associated resource. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups.

Within maps, subordinate maps may be linked in either of two ways:
  • <topicref> with a @format value of "ditamap" (this type of map reference is sometimes referred to as a "mapref")
  • <navref>

The <navref> element links to an otherwise independent map and indicates that the integration of that map's navigation structure into the larger navigation tree is deferred so that it can be performed as a final step in any delivery of the rendered content. Maps referenced by <navref> do not contribute to the key space of the map tree from which they are referenced. The map referenced by <navref> need not be available for processing at the time the referencing map is processed.

Parent topic: 2.1.3.3 DITA linking
Previous topic: 2.1.3.3 DITA linking
Next topic: 2.1.3.3.2 Links within topics


Links within topics

2.1.3.3.2 Links within topics

A topic may contain several types of links.

  • Content reference links from any element in the topic that allows @conref or @conkeyref.
  • Related information links, within a <related-links> element following the topic body. The related links are usually rendered at the end of the topic.
  • Image links created using <image>. Image elements may use <longdescref> to link to the long description for the image as a supplement to the <alt> element.
  • Object links created using <object>. Object elements may use <longdescref> to link to the long description for the object as a supplement to the <alt> element.
  • Navigation links created using <xref>. For output media that support hyperlinking, the <xref> should result in a hyperlink.
  • Navigation links created using @keyref on elements that allow @keyref but not @href (e.g., <ph>, <cite>, <keyword>, and <term>).
  • Metadata associations using <data-about> in contexts where <data> is allowed.
  • Navigation links from long quotes to the source of the quote using <longquoteref>.
Links to resources outside a topic's containing XML document that use direct URI-based addresses establish unconditional topic-to-resource dependencies. Such dependencies can impede reuse in two ways:
  • The linking topic cannot be used in a given map unless the dependent resource is also used.
  • The linked resource cannot be dynamically changed based on the map context in which the linking topic is used.

These issues can be avoided by using key-based addressing. Because keys are defined in maps, each map that uses the linking topic can bind the key to the most appropriate resource.

Parent topic: 2.1.3.3 DITA linking
Previous topic: 2.1.3.3.1 Links within maps
Next topic: 2.1.3.4 DITA addressing


DITA addressing

2.1.3.4 DITA addressing

DITA provides a number of facilities for establishing relationships among DITA elements and between DITA elements and non-DITA resources. All DITA relationships use the same addressing facilities irrespective of the semantics of the relationship established. DITA addresses are either direct, URI-based addresses, or indirect key-based addresses. Within DITA documents, individual elements are addressed by unique IDs specified on the common @id attribute. DITA defines two fragment identifier syntaxes for addressing DITA elements, one for topics and elements within maps and one for non-topic elements within topics.

  • 2.1.3.4.1 ID attribute
    The DITA identity attribute provides a mechanism for identifying content for linking.
  • 2.1.3.4.2 URI-based (direct) addressing
    Content reference and link relationships can be established from DITA elements using URI references to point directly to targets.
  • 2.1.3.4.3 Key-based addressing
    The DITA key-reference mechanism provides a layer of abstraction so that the resources addressed by references can be defined globally at the DITA map level instead of locally in each topic.
  • 2.1.3.4.4 Summary of addressing elements
    This topic contains a table of DITA elements that may be used to link to or address other items. The table describes how and why each element uses the addressing mechanism, rather than defining the element itself.
Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3.3.2 Links within topics
Next topic: 2.1.3.4.1 ID attribute


ID attribute

2.1.3.4.1 ID attribute

The DITA identity attribute provides a mechanism for identifying content for linking.

The id attribute assigns an identifier to DITA elements so the elements can be referenced. The id attribute is available for most elements. The id attribute is required on some elements. For a specific element to be referenced, it must have an id attribute with a valid value, although entire maps and the first topic, only topic, or all direct-child topics (depending on processing context) in a topic-containing document may be referenced without using an ID. The requirements for the id attribute differ depending on whether it is used on a topic element, a map element, or an element within a topic or map.

The id attributes for topic and map elements are true XML IDs and therefore must be unique with respect to other XML IDs within the scope of the XML document that contains the topic or map element. The id attribute for most other elements within topics and maps are not declared to be XML IDs. This means that XML parsers do not require that the values of those attributes be unique. All id attribute values must be XML name tokens.

Within documents containing multiple topics, the IDs for all non-topic elements that have the same nearest ancestor topic element should be unique with respect to each other. The IDs for non-topic elements may be the same as non-topic elements with different nearest ancestor topic elements.

Note: Thus, within a single XML document containing multiple peer or nested topics, the IDs of the non-topic elements only need to be unique within each topic without regard to the IDs of elements within any ancestor or descendant topics.

The IDs of all elements within a map should be unique within that map document. When two elements within a map have the same ID value, the first element with a given ID value, in document order, must be used as the target of any reference to that ID.

Figure 1. ID requirements summary table
Element | Attribute type | Unique within | Required | Value type
map | ID | document | No | XML non-colonized name token
topic | ID | document | Yes | XML non-colonized name token
sub-map | NMTOKEN | document | Usually no, with some exceptions | Any legal XML name token
sub-topic | NMTOKEN | individual topic | Usually no, with some exceptions | Any legal XML name token
Parent topic: 2.1.3.4 DITA addressing
Previous topic: 2.1.3.4 DITA addressing
Next topic: 2.1.3.4.2 URI-based (direct) addressing


URI-based (direct) addressing

2.1.3.4.2 URI-based (direct) addressing

Content reference and link relationships can be established from DITA elements using URI references to point directly to targets.

URI references address "resources" and, optionally, subcomponents of those resources. In the context of DITA, a resource is a DITA document (map, topic, or DITA base document) or a non-DITA resource (e.g., a Web page, a PDF document, etc.). For DITA resources, fragment identifiers can be used with the URI to address individual elements. The fragment identifier is the part of the URI that starts with a number sign ("#"), e.g., "#topicid/elementid". URI references may also include a query component, introduced with "?". DITA processors may ignore queries on URI references to DITA resources.

Note: URI references that are URLs must conform to the rules for URLs and URIs. In particular, Windows paths with backslashes are not valid URLs.

URIs and DITA fragment identifiers

DITA uses URI references in @href, @conref, or other attributes for all direct addressing of resources.

For addressing DITA elements within maps and topics or individual topics within documents containing multiple topics, URI references must include the appropriate DITA-defined fragment identifier. URI references may be relative or absolute. A relative URI reference may consist of just a fragment identifier. Such a reference is a reference to the document that contains the reference.

When addressing a DITA topic element, URI references may include a fragment identifier that includes the ID of the topic element (filename.dita#topicId or #topicId).

When addressing a non-topic element within a DITA topic, a URI reference must use a fragment identifier that contains the ID of the ancestor topic element of the non-topic element being referenced, a solidus ("/"), and the ID of the non-topic element (filename.dita#topicId/elementId or #topicId/elementId).

This addressing model makes it possible to reliably address elements whose id attribute values are unique within a single DITA topic but which may not be unique within a larger XML document that contains multiple DITA topics. (See ID attribute for more information on ID attributes.)

When addressing a DITA map element, URI references may include a fragment identifier that includes the ID of the map element (filename.ditamap#mapId or #mapId).

If a target DITA element is within the same XML document as the element making the reference, the URI reference may consist of only the fragment identifier (including the "#" (number sign) character).

Addressing non-DITA targets via URI

All resources, regardless of type, are directly addressed by URI references from DITA elements. When addressing targets within non-DITA resources, any fragment identifier used must conform to the fragment identifier requirements defined for the target media type, including references to non-DITA XML resources.

Addressing DITA topics via URI

Topics can always be addressed by a URI reference whose fragment identifier consists of the topic's ID. For the purposes of linking, a reference to a topic-containing document addresses the first topic within that document in document order. For the purposes of rendering, a reference to a topic-containing document addresses the root element of the document.

Note: For example, given a document whose root element is a topic, a URI reference (with no fragment identifier) addressing that document implicitly references the topic element. Given a <dita> document containing multiple topics, a URI reference addressing the <dita> document implicitly addresses the first child topic of the <dita> element for purposes of linking (for example, from a cross reference element) but addresses the <dita> element for the purposes of rendering (implying that all the topics contained by the <dita> element will be rendered in the result).

Addressing non-topic DITA elements via URI

To address non-topic elements within topics via URI, a topicID/elementID fragment identifier must be used.

To address elements within a DITA map via URI, an elementID fragment identifier must be used. The linking element must specify a value of "ditamap" for the format attribute.

URI reference syntax examples

The following table shows the URI syntax for common use cases.

Use case | Sample syntax
target a table in a topic at a network location | "http://example.com/file.dita#topicID/tableID"
target a section in a topic on a local file system | "directory/file.dita#topicID/sectionID"
target a figure contained in the same XML document | "#topicID/figureID"
target an element within an map | "http://example.com/map.ditamap#elementID" (and a value of "ditamap" for the format attribute)
target a map element within the same map document | "#elementID" (and a value of "ditamap" for the format attribute)
reference an external Web site | "http://www.somesite.com", "http://www.somesite.com#somefragment" or any other valid URI
reference an element within a local map | "filename.ditamap#elementid" (and a value of "ditamap" for the format attribute)
reference a local map | "filename.ditamap" (and a value of "ditamap" for the format attribute)
reference a local topic | reference a local topic "filename.dita" or "path/filename.dita"
reference a specific topic in a local document | "filename.dita#topicid" or "path/filename.dita#topicid"
reference a specific topic in the same file | "#topicid"
Parent topic: 2.1.3.4 DITA addressing
Previous topic: 2.1.3.4.1 ID attribute
Next topic: 2.1.3.4.3 Key-based addressing


Key-based addressing

2.1.3.4.3 Key-based addressing

The DITA key-reference mechanism provides a layer of abstraction so that the resources addressed by references can be defined globally at the DITA map level instead of locally in each topic.

When using DITA topics in the context of different maps, it is often necessary to have a relationship resolve to different resources. For example, a content reference to a <ph> element that contains a product name might need to resolve to a different <ph> element when used in a different product-specific map. The DITA key-reference mechanism provides an indirect addressing mechanism that separates references (topicrefs, conrefs, cross references, etc.) from the direct address of the target. (A direct address is the address specified on the element that references the key, for example via @href or @conref.) Linking elements can refer to key names; the key names then are bound to specific resources by maps. Different maps can bind the same key names to different resources. This form of indirection is late bound, because the binding of key names to resources is determined at processing time based on the current set of key definitions for the map context rather than from a static binding that is created when a topic or map is authored.

  • 2.1.3.4.3.1 Overview of keys
    To use key references, one must understand how keys are defined and bound to resources, how a map hierarchy establishes a key space, and the interaction of keys with conditional processing.
  • 2.1.3.4.3.2 Using keys to address DITA elements
    For topic references, image references, and navigation link relationships (<link>, <xref>, and elements that take the @keyref but not the @href attribute), resources can be addressed by key using the @keyref attribute. For content reference relationships, resources can be addressed by key using the @conkeyref attribute.
  • 2.1.3.4.3.3 Processing key references
  • 2.1.3.4.3.4 Examples of keys
Parent topic: 2.1.3.4 DITA addressing
Previous topic: 2.1.3.4.2 URI-based (direct) addressing
Next topic: 2.1.3.4.3.1 Overview of keys


Overview of keys

2.1.3.4.3.1 Overview of keys

To use key references, one must understand how keys are defined and bound to resources, how a map hierarchy establishes a key space, and the interaction of keys with conditional processing.

Key definition

Keys are defined within maps. Key names are defined using the @keys attribute on <topicref> elements (or specializations of topicref, such as <keydef>).

The @keys attribute uses the following syntax:
  • The value of the @keys attribute is one or more space separated key names.
  • Key names consist of characters that are legal in a URI. The case of key names is significant.
  • The following characters are prohibited in key names: "{", "}", "[", "]", "/", "#", "?", and whitespace characters.

The @keys attribute in any <topicref> element can be used to define keys, regardless of any other purpose that it may serve in the map. However, common practice is to define most or all keys separately from the topic references that are used to establish navigation hierarchies and relationships. If a separate DITA map is created that contains only key definitions, it should have the @processing-role attribute set to "resource-only". The map-group vocabulary module includes the <keydef> element, a specialization of <topicref> in which the value of the @processing-role attribute is set by default to "resource-only".

Key binding

A key can be bound simultaneously to several resources:

  • It is directly bound to the resource addressed by the @href attribute of the key-defining element, if a @keyref either is not specified or cannot be resolved following key space construction.
  • If the key-defining element specifies a @keyref attribute and the key reference can be resolved following key space construction, the key is bound to any directly addressed resource bound to the referenced key (directly or indirectly). (It is an error for a topicref to refer directly or indirectly to any key that it defines.)
  • It is bound to the subelements of the <topicmeta> element within the key-defining element, if any are present.

Key spaces

A root map and its directly addressed, local scope descendant maps establish a unique key space within which each unique key name has exactly one binding to a set of resources.

For the purposes of determining the effective key definitions for the key space represented by a given root map, a map tree is determined by considering only directly addressed, local scope maps descending from the root map. The order of subordinate maps is determined by the document order of the topicrefs that point to them. Indirect references to maps with key references are necessarily ignored until after the key space is determined.

Maps addressed by <navref> do not contribute to the key space of a map tree. Maps referenced by <navref> are equivalent to maps referenced with a scope of "peer" or "external" and therefore need not be present or available at the time the referencing map is processed for purposes of key space construction.

Keys and conditional processing

The effective keys for a map might be affected by conditional processing (filtering). Processors should perform conditional processing before determining effective key definitions. However, processors may determine effective key bindings before filtering. Consequently, different processors might produce different effective bindings for the same map when there are key definitions that might be filtered out based on their select attributes.

If filtering is not done first, the same root map may result in different effective key spaces for different sets of conditions. For processors that provide sets of available keys within an information set, such as authoring support systems, keys may need to be associated with the conditions specified on their key definitions. For example, given a map that defines the key "os-name" twice with different conditions, an author may need to know both that the key has two possible bindings within the key space and what the conditions are under which those bindings are effective. It also means that processors might need both a root map and a set of active conditions (for example, a DITAVAL document) in order to correctly determine the effective key space.

A relative URI reference in a key definition is resolved relative to the base URI established for the location of the key definition rather than relative to the various locations of references using the key.

Effective key definitions

For a given key there is at most one effective definition within a key space. A key definition is the effective definition for a given key if it is the first, in document order, within the map document that contains it, and is the first in the map tree in breadth-first order. It is not an error for the same key name to be defined more than once within a map or map tree, and duplicate key definitions should be ignored without warning.

Note: A given <topicref> element that defines more than one key may be the effective definition for some of its keys but not for others. It is the duplicate binding of a key name to its definition that is ignored, not the key-defining topic reference as a whole.

Key definitions are not scoped by the map document within which they occur or by the element hierarchy of their containing map document. Keys do not have to be declared before they are referenced. The key space is effective for the entire document, so the order of key definitions and key references relative to one another within the map hierarchy is not significant, and keys defined in any map in the map tree are available for use with key references from all maps and topics processed in the context of the root map.

Note: These rules mean that key definitions higher in the map tree hierarchy take precedence over key definitions lower in the map tree and that key definitions in referencing maps always take precedence over key definitions in referenced maps. These rules also mean that the entire key space must be determined before any keys can be resolved to their ultimately-addressed resources (if any).
Note: Because keys are defined in maps, all key-based processing must be done in the context of a root map that establishes the effective key space.

For key definitions in a submap to be included in the key space, there must be a direct URI reference to that submap from another directly addressed map in the map tree. However, if that same submap is referenced indirectly and has no direct URI reference as a backup (using @keyref without providing a fallback @href value, or using @conkeyref without providing a fallback @conref value), that reference is ignored for purposes of constructing the key space, and the definitions in that submap consequently do not enter into the construction of the key space at that point.

Parent topic: 2.1.3.4.3 Key-based addressing
Previous topic: 2.1.3.4.3 Key-based addressing
Next topic: 2.1.3.4.3.2 Using keys to address DITA elements


Using keys to address DITA elements

2.1.3.4.3.2 Using keys to address DITA elements

For topic references, image references, and navigation link relationships (<link>, <xref>, and elements that take the @keyref but not the @href attribute), resources can be addressed by key using the @keyref attribute. For content reference relationships, resources can be addressed by key using the @conkeyref attribute.

Syntax

For references to topics, maps, and non-DITA resources, the value of the @keyref attribute is simply a key name: keyref="topic-key".

For references to non-topic elements within topics and non-topicref elements within maps, the value of the @keyref attribute is a key name, a solidus ("/"), and the ID of the target element: keyref="topic-key/some-element-id".

If both @keyref and @href attributes are specified on an element, the @href value must be used as a fall-back address when the key name is undefined, and should be used as a fall-back address when the key name is defined but the key reference cannot be resolved to a resource. If both @conkeyref and @conref attributes are specified on an element, the @conref value must be used as a fall-back address when the key name is undefined, and should be used as a fall-back address when the key name is defined but the key reference cannot be resolved to a resource.

Example

For example, consider this topic in the document "file.dita":
<topic id="topicid">
 <title>Example referenced topic</title>
 <body>
  <p id="para-01">Some content.</p>
 </body>
</topic>
and this key definition:
<map>
  <topicref keys="myexample"
    href="file.dita"
  />
</map>

A keyref of the form "myexample/para-01 resolves to the <p> element in the topic. The key reference would be equivalent, in the context of this map, to the URI reference file.dita#topicid/para-01.

A key reference to a topicref element where the linking element specifies a format value of "ditamap" addresses the topicref element itself as though the topicref element had been addressed by ID. In particular, a topicref with a key reference to another topicref and a format value of "ditamap" is a use of the map branch rooted at the referenced topicref.

Parent topic: 2.1.3.4.3 Key-based addressing
Previous topic: 2.1.3.4.3.1 Overview of keys
Next topic: 2.1.3.4.3.3 Processing key references


Processing key references

2.1.3.4.3.3 Processing key references

When a key definition is bound to a resource addressed by @href or @keyref and does not specify "none" for the @linking attribute, all references to that key definition become navigation links to the bound resource. When a key definition is not bound to a resource or specifies "none" for the @linking attribute, references to that key do not become navigation links.

When a key definition has a <topicmeta> subelement, elements that refer to that key and that are empty may get their effective content from the first matching subelement of the <topicmeta> subelement of the key-defining topicref. If no matching element is found, the contents of the <linktext> tag, if present, should be used. Elements within <linktext> that do not match the content model of the key reference directly or after generalization should be skipped. For <link> tags with a keyref attribute, the contents of the <shortdesc> tag in the key-defining element should provide the <desc> contents.

When a key definition has no @href value and no @keyref value, references to that key will not result in a link, even if they do contain an @href attribute of their own. If the key definition also does not contain a <topicmeta> subelement, empty elements that refer to the key (such as <link keyref="a"/> or <xref keyref="a" href="fallback.dita"/>) are removed.

Matching element content for key references contained in @keyref attributes falls into one of two categories:
  1. For elements on which no @href attribute is available (such as cite, dt, keyword, term, ph, indexterm, index-base, and indextermref, and their specializations), matching content is taken from the <keyword> or <term> elements within <keywords> within <topicmeta>. If more than one <keyword> or <term> is present, the matching content is taken from the first of them.
  2. For elements that in addition to @keyref or @conkeyref do specify an @href attribute (such as author, data, data-about, image, link, lq, navref, publisher, source, topicref, xref, and their specializations), matching content includes all elements from within the key definition element that are in valid context within the key reference. Elements that are invalid within the key reference element directly or after generalization are not included or are filtered out.

For key reference elements that become navigation links, if there is no matching element in the key definition, normal link text determination rules apply as for <xref>.

If a referencing element contains a key reference with an undefined key, it is processed as if there were no key reference, and the value of the @href attribute is used as the reference. If the @href attribute is not specified either, the element is not treated as a navigation link. If it is an error for the element to be empty, an implementation may give an error message, and may recover from this error condition by leaving the key reference element empty.

For topic references that use the @keyref attribute, the effective value of the <topicref> element is determined as follows:

  • The effective resource bound to the <topicref> element is determined by resolving all intermediate key references. Each key reference is resolved either to a resource addressed directly by URI reference in an @href attribute, or to no resource. Processors may impose reasonable limits on the number of intermediate key references they will resolve. Processors should support at least three levels of key references.

    Note: This rule applies to all topic references, including those that define keys. Thus, the effective bound resource for a key definition that uses the @keyref attribute cannot be determined until the key space has been constructed.

    The attributes that are common to a key definition element and a key reference element using that key, other than the @keys, @processing-role, and @id attributes, are combined as for content references, including the special processing for the @xml:lang, @dir, and @translate attributes. There is no special processing associated with either the @locktitle or the @lockmeta attributes when attributes are combined.

  • Content from a key reference element and a key-defining element is combined following the rules for combining metadata between maps and other maps and between maps and topics. The @lockmeta attribute is honored when metadata content is combined.
  • The combined attributes and content cascade from one map to another or from a map to a topic, but this is controlled by existing rules for cascading, which are not affected by the use of key references.
Parent topic: 2.1.3.4.3 Key-based addressing
Previous topic: 2.1.3.4.3.2 Using keys to address DITA elements
Next topic: 2.1.3.4.3.4 Examples of keys


Examples of keys

2.1.3.4.3.4 Examples of keys

A generic topicref element used to define a key bound to a topic:

<map>
  ...
  <topicref keys="apple-definition"
    href="topics/glossary/apple-gloss-en-US.dita"
  />
  ...
</map>

In this example, the topicref is acting as both a key definition and contributing to the navigation structure of the map, meaning the topic apple-gloss-en-US.dita will be processed as it would be if the @keys attribute were not present.

The same key definition using the <keydef> specialization of <topicref>:

<map domains="(map mapgroup-d)">
  ...
  <keydef keys="apple-definition"
    href="topics/glossary/apple-gloss-en-US.dita"
  />
  ...
</map>

Because the <keydef> element sets the default value of the @processing-role attribute to "resource-only", the key definition does not contribute to the map's navigation structure, but only serves to establish the key-to-resource binding for the key "apple-definition".

Duplicate definition of the same key:

<map domains="(map mapgroup-d)">
  ...
  <keydef keys="load-toner"
    href="topics/tasks/model-1235-load-toner-proc.dita"
  />
  <keydef keys="load-toner"
    href="topics/tasks/model-4545-load-toner-proc.dita"
  />
  ...
</map>

In this example, only the first definition in document order of the "load-toner" key is effective, so all references to the key within the scope of the root map will resolve to the topic model-1235-load-toner-proc.dita, not topic model-4545-load-toner-proc.dita.

Duplicate definitions with different conditions:

<map domains="(map mapgroup-d)">
  ...
  <keydef keys="file-chooser-dialog"
    href="topics/ref/file-chooser-osx.dita"
    platform="osx"
  />
  <keydef keys="file-chooser-dialog"
    href="topics/tasks/file-chooser-win7.dita"
    platform="windows7"
  />
  ...
</map>

In this example, both key definitions use the @platform metadata attribute to indicate that they apply to different operating system platforms. In this case, the effective key definition is determined not just by the order in which the definitions occur but whether the active value of @platform is "osx" or "windows7" when the key space is determined or the key is resolved. In this case both key definitions are potentially effective because they have distinct values for conditional attributes. Note that if no active value is specified for the @platform condition when determining the effective keys, then both of the definitions are effective and thus the first one in document order is the effective definition.

If the DITA value configuration were defined such that the default behavior is "exclude" rather than the normal default of "include", then neither definition would be effective and the key would be undefined. That case can be avoided by specifying an unconditional key definition after any conditional key definitions, e.g.:
<map domains="(map mapgroup-d)">
  ...
  <keydef keys="file-chooser-dialog"
    href="topics/ref/file-chooser-osx.dita"
    platform="osx"
  />
  <keydef keys="file-chooser-dialog"
    href="topics/tasks/file-chooser-win7.dita"
    platform="windows7"
  />
  <keydef keys="file-chooser-dialog"
    href="topics/tasks/file-chooser-generic.dita"
  />
  ...
</map>

In this case, with an explicitly-configured default behavior of "exclude", if no active value for the platform condition is specified, the third definition will be the effective definition, binding the key "file-chooser-dialog" to the topic file-chooser-generic.dita.

Duplicate key definitions using subordinate maps

Root map:

<map domains="(map mapgroup-d)">
  <keydef keys="toner-specs"
   href="topics/reference/toner-type-a-specs.dita"
  />
  <mapref href="submap-01.ditamap"/>
  <mapref href="submap-02.ditamap"/>
</map>

submap-01.ditamap:

<map domains="(map mapgroup-d)">
  <keydef keys="toner-specs"
   href="topics/reference/toner-type-b-specs.dita"
  />
  <keydef keys="toner-handling"
   href="topics/concepts/toner-type-b-handling.dita"
  />
</map>

submap-02.ditamap:

<map domains="(map mapgroup-d)">
  <keydef keys="toner-specs"
   href="topics/reference/toner-type-c-specs.dita"
  />
  <keydef keys="toner-handling"
   href="topics/concepts/toner-type-c-handling.dita"
  />
  <keydef keys="toner-disposal"
   href="topics/tasks/toner-type-c-disposal.dita"
  />
</map>
In this example the effective key space is:
Key | Bound resource
toner-specs | toner-type-a-specs.dita
toner-handling | toner-type-b-handling.dita
toner-disposal | toner-type-c-disposal.dita

The binding for the key "toner-specs" in the root map is effective because it is the first encountered in a breadth-first traversal of the map tree. The binding for the key "toner-handling" to the definition in submap-01.ditamap is effective because submap-01 is included before submap-02 and therefore comes first in the map tree. The binding for the key "toner-disposal" is effective because it is the only definition of the key in the map tree.

A key definition that uses elements within the key definition rather than a separately-addressed resource

<map domains="(map mapgroup-d)">
  <keydef keys="product-name">
    <topicmeta>
     <keywords>
       <keyword>Thing-O-Matic</keyword>
     </keywords>
    </topicmeta>
  </keydef>
</map>
This form of key definition would normally be used from a <keyword> element in order to use the value defined in the key definition:
<topic id="topicid">
  <title>About the <keyword keyref="product-name"/> product</title>
</topic>

Normal processing results in the effective title text "About the Thing-O-Matic product".

A key definition that uses both elements within the key definition and points to a resource

<map domains="(map mapgroup-d)">
  <keydef keys="yaw-restrictor"
    href="parts/subassem/subassm-9414-C.dita"
  >
    <topicmeta>
     <keywords>
       <keyword>yaw restrictor assembly</keyword>
     </keywords>
    </topicmeta>
  </keydef>
</map>

When referenced from a <keyword> element with no directly-specified content, normal processing sets the effective content of the keyword to "yaw restrictor assembly" and makes the keyword a navigation link to the topic subassm-9414-C.dita.

Redirect a link or xref

  1. Author 1 creates a map that associates keys with each topic, for example <topicref keys="a" href="a1.dita"/>
  2. Author 1 creates topic c.dita that contains a related link to a0.dita - but uses the keyref attribute: <link keyref="a" href="a0.dita"/>
  3. Author 2 reuses c.dita, but wants to redirect the link, so applies a different map with <topicref keys="a" href="a2.dita"/>. The link in c.dita now resolves to a2.dita when author 2 builds it (it continues to resolve to a1.dita when author 1 builds it)
  4. Author 3 also reuses c.dita, but wants the link to point to an external resource, so creates an external-pointing topicref to resolve the key:
    <topicref  keys="a" href="http://www.a..." scope="external">
  <topicmeta>
    <linktext>This links to A2</linktext>
    <shortdesc>Because it does.</shortdesc>
  </topicmeta>
</topicref>

    The link in c.dita now resolves to an external URI reference when author 3 builds it (without affecting how it resolves for the other two reusers).

  5. Author 4 wants to get rid of the link, so creates an explicitly empty topicref to get rid of it: <topicref keys="a"/>. This gets rid of the link for author 4 without affecting the other reusers.
  6. Author 5 wants to turn the link into just plain text (not hypertext) - for example a citation of a print-only magazine article.
    <topicref  keys="a">
  <topicmeta>
    <linktext>This is just text.</linktext>
  </topicmeta>
</topicref>
  7. Author 6 reuses c.dita, but does not include a topicref that defines the key “a” in the map. Topic a0.dita is used as the “fallback” related link.

Redirect conref

  1. Author 1 creates a map that associates a key with a topic that contains reusable elements, for example <topicref keys="reuse" href="prodA/reuse.dita"/>
  2. Author 1 uses the key instead of the full href whenever creating conrefs - for example <p conkeyref="reuse/para1"/>
  3. Author 2 wants to reuse author 1's content, but swap in a different set of reusable content. So Author 2 associates the key "reuse" with a different topic: <topicref keys="reuse" href="prodB/mytopic.dita"/>. So now <p conkeyref="reuse/para1"/> will resolve to a paragraph with the id “para1” in prodB/mytopic.dita when author 2 builds the content, while continuing to resolve to the para with the id “para1” in prodA/reuse.dita for author 1.

Create links from keywords, terms, or other elements

  1. Author 1 creates a map that contains glossary entries, and associates keys for each entry: <topicref keys="myterm" href="myterm.dita"/>
  2. Author 1 then uses the keys to create links to the appropriate glossary entry from occurrences of terms in content: <term keyref="myterm">my term</term>.
Note: The reusing author must create a parallel set of elements and IDs in the replacement topic; the element IDs within the topic are not remapped, only the pointer to the topic container.

Swap out variable content

  1. Author 1 creates a map for key words and phrases that tend to change, such as UI labels and product names. The topicrefs do not in this case contain any actual hrefs, just the text that should be used:
    <topicref keys="prodname">
  <topicmeta>
    <linktext>My Product</linktext>
  </topicmeta>
</topicref>
  2. Author 1 then uses the keys to draw text into empty keywords: <keyword keyref="prodname"/>
  3. Author 2 reuses the content but wants to use a different product name, so associates prodname with a different string:
    <topicref keys="prodname">
  <topicmeta>
    <linktext>Another Product</linktext>
  </topicmeta>
</topicref>

    The keyword now resolves to "Another Product" for author 2, while continuing to resolve to "My Product" for author 1.

Note: A processor should generate a warning message when a key reference on an empty element cannot be resolved, resulting in the element effectively being removed.

Splitting or combining targets

  1. Author 1 creates a map in which most branches have the same structure: intro, example, reference. Two branches have only very little content in them, because the product support is only minimal. In anticipation of future elaboration, author 1 assigns 4 keys to the container under which more topics are expected in the future:
    <topicref keys="blat-overview blat-intro blat-example blat-reference"
          href="blat-overview.dita"/>
  2. Author 2 references blat-example, and in the future when Author 1 moves blat-example into a separate topic, author 2's link remains appropriate and valid and does not need to be reworked.
  3. Author 3 is reusing a bunch of author 1's content, but in a context where blats are not available, and are instead replaced by foobars. So author 3 simply adds the blat keys to their own foobar topicref:
    <topicref keys="blat-overview blat-intro blat-example blat-reference foobar"
          href="foobar.dita"/>

Removing a link

  1. Author 1 creates a map which defines the key "overview":
    <topicref keys="overview"
          href="blat-overview.dita"/>
  2. Author 1 adds a link to the topic productInfo.dita using they keyref attribute, and using the href as a fallback:
    <link keyref="overview" href="blat-overview.dita"/>
  3. Author 2 wishes to reuse productInfo.dita, but does not want a link to overview information. So, author 2 creates a new definition for the key overview that does not have a target:
    <topicref keys="overview"/>

    The link element which uses keyref="overview" is now removed, because there is no target and no link text.

Parent topic: 2.1.3.4.3 Key-based addressing
Previous topic: 2.1.3.4.3.3 Processing key references
Next topic: 2.1.3.4.4 Summary of addressing elements


Summary of addressing elements

2.1.3.4.4 Summary of addressing elements

This topic contains a table of DITA elements that may be used to link to or address other items. The table describes how and why each element uses the addressing mechanism, rather than defining the element itself.

Table 1. DITA addressing elements
Base element type | Description and notes
topicref | Establishes a relationship between the containing map and another map, DITA topic, or non-DITA resource when @href or @keyref is specified. When @processing-role is "resource-only", establishes a dependency on the target resource but does not contribute to the navigation tree. May establish additional relationships between the referenced resource and other resources in the navigation hierarchy as determined by the values of the @collection-type attribute. By default, these additional relationships are bi-directional. The directionality of additional relationships can be controlled using the @linking attribute.
reltable | Establishes relations of a specific type (as defined by the relationship table) among topicref-linked resources where each row in the table establishes a single set of relationships among the topicref-linked resources in each cell of the row. Relationships defined in relationship tables are outside of any navigation structure defined by the map.
navref | Establishes a map-to-map relationship where the integration of the referenced map's navigation structure is deferred. The referenced map is processed independently from the referencing map and does not contribute to the referencing map's key space.
link | Establishes a link from its containing topic to another resource. Any <link> element within a topic can be functionally replaced by the equivalent link defined in a relationship table. Likewise, topic-to-topic links defined by relationship tables can be replaced by the equivalent set of <link> elements in the topics involved.
xref | Establishes a navigation link from a topic's abstract or body to another DITA element or non-DITA resource.
image | Links to an image for display at the point of reference.
object | Links to a media object for display at the point of reference.
longdescref | Links to a long description for an image or object. Can be used in place of the @longdescref attribute on the parent image or object element.
longquoteref | Links to the source of a long quotation. Used in place of the @href or @keyref attribute on <lq> and enables use of all the normal link-controlling attributes.
data-about | Establishes an explicit relationship between one or more <data> elements and the DITA element or non-DITA resource to which the data applies.
Elements that take @keyref but not @href | Elements that take @keyref but not @href establish navigation links to the referenced DITA element or non-DITA resource when @keyref is specified and the key is bound to a topic, map, or non-DITA resource. If the linking element has empty content and the key definition has a matching subelement in its <topicmeta>, establishes a use-by-reference relationship to the matchin element in the key definition. Includes <ph>, <cite>, <keyword>, and <term>.
imagemap (utilities domain) | Enables linking from defined areas overlaid on a graphic. Modeled on the HTML image map facility.
author | May link to a resource that represents the author in some way, such as a biographical topic or image.
data | May link to a resource that represents the metadata value in some way.
fragref (programming domain) | Links to a syntax definition fragment.
lq | May link to the source of the quotation.
publisher | May link to a resource that represents the publisher in some way, such as the Publisher's Web site or a publisher description topic.
source | May link to a description of the source for the topic to which the <source> element applies.
synnoteref (programming domain) | May link to a syntax note.
fn | Establishes a relationship between the content within which the footnote appears and the note itself, such that the footnote is an annotation of the content.
Parent topic: 2.1.3.4 DITA addressing
Previous topic: 2.1.3.4.3.4 Examples of keys
Next topic: 2.1.3.5 Content inclusion (conref)


Content inclusion (conref)

2.1.3.5 Content inclusion (conref)

The DITA @conref, @conkeyref, @conrefend, and related attributes provide a mechanism for reuse of content fragments within DITA topics or maps.

  • The @conref or @conkeyref attribute can be used to pull the referenced content into the location of the referencing element. The combination of either of these attributes with the @conrefend attribute can be used to pull the content of a range of elements.

  • The @conref attribute can be used in combination with the @conaction attribute to push content from the referencing element to the location of the referenced element.

Pulling content to the referencing element

When the @conref or @conkeyref attribute is used alone, the referencing element acts as a placeholder for the referenced element, and the content of the referenced element is rendered in place of the referencing element.

The combination of the @conrefend attribute with either @conref or @conkeyref specifies a range of sibling elements that is rendered in place of the referencing element. See The conrefend attribute for examples of how to combine @conrefend with either @conref or @conkeyref.

Pushing content from the referencing element

The @conaction attribute reverses the direction of reuse from pull to push. When the @conref or @conkeyref attribute is used in combination with the @conaction attribute, content can be rendered before, after, or in place of the referenced element, depending on the value of the @conaction attribute. See The conaction attribute for more details.

Note: The @conaction and @conrefend attributes cannot both be used within the same referencing element, so it is not possible to push a range of elements.

The identifier for the referenced element must be either absolute or resolvable in the context of the referencing element.

More formally, the DITA @conref attribute can be considered a transclusion mechanism similar to XInclude and to HyTime value references. DITA differs from these mechanisms, however, in that conref validity does not apply simply to the current content at the time of replacement, but to the ranges of possible content given the constraints of both the referencing document type and the referenced document type. DITA compares the constraints of each context to ensure the continued validity of the replacement content in its new context. A conref processor must not permit resolution of a reuse relationship that could be rendered invalid under the rules of either the reused or reusing content.

When pulling content with the conref mechanism – if the referenced element is the same type as the referencing element, and the list of domains declared on the domains attribute in the referenced topic or map instance is the same as or a subset of the list of domains declared in the referencing document, the element set allowed in the referenced element is guaranteed to be the same as, or a subset of, the element set allowed in the referencing element. A processor resolving a conref should tolerate specializations of valid elements and should generalize elements in the pulled content fragment as needed for the referencing context.

When pushing content with the conref mechanism, the domain checking algorithm is reversed. In this case, the domains attribute on the referenced document's topic or map must be the same as or a superset of the domains declared on the referencing document. Once again, a processor resolving a conref should tolerate specializations of valid elements and should generalize elements in the pushed content fragment as needed for the referenced context.

All replacement of content based on @conref occurs after parsing of the document but prior to any styling or other transformational or presentational operations on the full topic.

The referenced element may replace the referencing element based on build-time or runtime conditions. For example, content such as product names or install paths may differ from one product to another. It is advantageous to separate such content from topic content which is reused for more than one product. When the content is reused in a different context, different resources are substituted as reference elements.

A fragment of DITA content, such as an XML document containing only a single paragraph without a topic or map ancestor, does not contain enough information for the conref processor to be able to determine the validity of a reference to it. Consequently, the value of a conref must specify a referenced element within a DITA topic or DITA map (or it may point to the entire topic or map).

The attribute specifications on the resolved element can be drawn from both the referencing element and the referenced element, according to the following priority:
  1. All attributes as specified on the referencing element, except for attributes which specify the value "-dita-use-conref-target". (The term "target" here refers to the referenced element.)
  2. All attributes as specified on the referenced element except:
    1. The id attribute
    2. Any attribute that is also specified on the referencing element, except when the value specified on the referencing element is "-dita-use-conref-target"
  3. The xml:lang attribute has special treatment as described in The @xml:lang attribute.

The only time the resolved element would include an attribute whose specified value is "-dita-use-conref-target" is when the referenced element had that attribute specified with the "-dita-use-conref-target" value and the referencing element either had no specification for that attribute or had it also specified with the "-dita-use-conref-target" value. If the final resolved element (after the complete resolution of any conref chain, as explained below) has an attribute with the "-dita-use-conref-target" value, that should be treated as equivalent to having that attribute unspecified.

A given attribute value on the resolved element comes in its entirety from either the referencing element or the referenced element; the attribute values of the referencing and referenced elements for a given attribute are never additive, even if the property (such as the audience type) takes a list of values.

If the referenced element has a @conref attribute specified, the above rules should be applied recursively with the resolved element from one referencing/referenced combination becoming one of the two elements participating in the next referencing/referenced combination. The result should preserve without generalization all elements that are valid in the originating context, even if they are not valid in an intermediate context. For example, if topicA and topicC allow highlighting, and topicB does not, then a content reference chain of topicA->topicB->topicC should preserve any highlighting elements in the referenced content. The result, however it is achieved, must be equivalent to the result of resolving the conref pairs recursively starting from the original referencing element in topicA.

The @conrefend attribute is used when referencing a range of elements with the conref mechanism. The @conref attribute references the first element in the range, while @conrefend points to the last element in the range. Although the start and end referenced elements must both be of the same type as the referencing element (or specialized from that element type), the intermediary, contiguous nodes in the middle of the range do not have to be the same.

Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3.4.4 Summary of addressing elements
Next topic: 2.1.3.6 Conditional processing (profiling)


Conditional processing (profiling)

2.1.3.6 Conditional processing (profiling)

Attribute-based profiling, also known as conditional processing or applicability, is the use of classifying metadata that enables the filtering, flagging, searching, indexing, and other processing based on the association of an element with one or more values in a specific classification domain.

DITA defines attributes that are specifically intended to enable filtering or flagging of individual elements. Those attributes are @audience, @platform, @product, @otherprops, @props, and @rev (flagging only). This enables the creation of topics and maps that can be dynamically configured at processing time to reflect a specific set of conditions, using the DITA-defined conditional processing profile (DITAVAL).

Processors should be able to perform filtering and flagging using the attributes listed above. Although metatdata elements exist with similar names, such as the <audience> element, processors are not required to perform conditional processing using metadata elements. The @props attribute can be specialized to create new attributes, and processors should be able to perform conditional processing on specializations of @props.

Conditional processing attributes

For a topic or topicref, the audience, platform, and product metadata can be expressed with attributes on the topic or topicref element or with elements within the topic prolog or topicmeta element. While the metadata elements are more expressive, the meaning of the values is the same, and can be used in coordination. For example, the prolog elements can fully define the audiences for a topic, and then metadata attributes can be used within the content to identify parts that apply to only some of those audiences.

audience
The values in the audience attribute may also be used to reference a more complete description of an audience in an audience element. Use the name of the audience in the audience element when referring to the same audience in an audience attribute.

The audience attribute takes a space-delimited list of values, which may or may not match the name value of any audience elements.

platform
The platform might be the operating system, hardware, or other environment. This attribute is equivalent to the platform element for the topic metadata.

The platform attribute takes a space-delimited list of values, which may or may not match the content of a platform element in the prolog.

product
The product or component name, version, brand, or internal code or number. This attribute is equivalent to the prodinfo element for the topic metadata.

The product attribute takes a space-delimited list of values, which may or may not match the value of the prodname element in the prolog.

rev
The identifier for the revision level. For example, if a paragraph was changed or added during revision 1.1, the rev attribute might contain the value "1.1".
otherprops
A catch-all for metadata qualification values about the content. This attribute is equivalent to the othermeta element for the topic metadata.

The attribute takes a space-delimited list of values, which may or may not match the values of othermeta elements in the prolog.

For example, a simple otherprops value list: <codeblock otherprops="java cpp">

The attribute may take labeled groups of values as for @props. Processors may treat such values as equivalent to @props or they may treat such values as simple strings. The use of labeled groups in @otherprops is deprecated in favor of using specializations of @props. Processors should clearly document how they treat grouped @otherprops values. See Attribute generalization for details on generalized @props attribute values.

props
A generic attribute for conditional processing values. Starting with DITA 1.1, the props attribute can be specialized to create new conditional processing attributes. See Attribute generalization.

Using conditional processing attributes

Each attribute takes zero or more space-delimited string values. For example, you can use the product attribute to identify that an element applies to two particular products.

Figure 1. Example source
<p audience="administrator">Set the configuration options:
    <ul>
        <li product="extendedprod">Set foo to bar</li>
        <li product="basicprod extendedprod">Set your blink rate</li>
        <li>Do some other stuff</li>
        <li platform="Linux">Do a special thing for Linux</li>
    </ul>
</p>

Evaluating conditional processing attributes

At processing time, a DITAVAL conditional processing profile may be used to specify values you want to include, exclude, or flag.

For example, a publisher producing information for a mixed audience using the basic product could choose to flag information that applies to administrators, and exclude information that applies to the extended product, by defining a conditional processing profile like this:
<val>
  <prop att="audience" val="administrator" action="flag">
    <startflag><alt-text>ADMIN</alt-text></startflag>
  </prop>
  <prop att="product" val="extendedprod" action="exclude"/>
</val>

At output time, the paragraph is flagged, and the first list item is excluded (since it applies to extendedprod), but the second list item is still included (even though it does apply to extendedprod, it also applies to basicprod, which was not excluded).

The result should look something like:
ADMIN Set the configuration options:
  • Set your blink rate
  • Do some other stuff
  • Do a special thing for Linux

Filtering logic

By default, values in conditional processing attributes that are not defined in a DITAVAL profile evaluate to "include". For example, if the value audience="novice" is used on a paragraph, but this value is not defined in a DITAVAL profile, the attribute evaluates to "include". However, the DITAVAL profile may change this default to "exclude", so that any value not explicitly defined in the DITAVAL profile will evaluate to "exclude". The profile may also be used to change the default for a single attribute; for example, it may declare that values in the platform attribute default to exclude while those in the product attribute default to include. See DITAVAL elements for information on how to set up a DITAVAL profile and how to change default behaviors.

When deciding whether to include or exclude a particular element, a processor should evaluate each attribute, and then evaluate the set of attributes.
  • If all the values in a single attribute evaluate to "exclude", the attribute evaluates to "exclude".
  • If any single attribute evaluates to exclude, the element is excluded.

For example, if a paragraph applies to three products and the publisher has chosen to exclude all of them, the processor should exclude the paragraph. This is true even if the paragraph applies to an audience or platform that is not excluded. But if the paragraph applies to an additional product that has not been excluded, then its content is still relevant for the intended output and should be preserved.

Flagging logic

When deciding whether to flag a particular element, a processor should evaluate each value. Wherever a value that has been set as flagged appears in its attribute (for example, audience="administrator") the process should add the flag. When multiple flags apply to a single element, multiple flags should be rendered, typically in the order they are encountered.

Flagging could be done using text (for example, bold text against a colored background) or using images. When the same element evaluates as both flagged and filtered (for example, flagged because of an audience attribute value and filtered because of its product attribute values), the element should be filtered.

Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3.5 Content inclusion (conref)
Next topic: 2.1.3.7 Chunking
Related concepts
2.1.2.3.2.1 Conditional processing attributes
3.1.8 DITAVAL elements
Related reference
3.4.1.5 select-atts attribute group


Chunking

2.1.3.7 Chunking

Content may be chunked (divided or merged into new output documents) in different ways for the purposes of authoring, for delivering content, and for navigation. For example, something best authored as a set of separate topics may need to be delivered as a single Web page. A map author can use the chunk attribute to split up multi-topic documents into component topics or combine multiple topics into a single document as part of output processing.

Examples of use

Here are some examples of potential uses of the chunk attribute:

Reuse of a nested topic
A content provider creates a set of topics as a single document. Another user wants to incorporate only one of the nested topics from the document. The new user can reference the nested topic from a DITA map, using the chunk attribute to specify that the topic should be produced in its own document.
Identification of a set of topics as a unit
A curriculum developer wants to compose a lesson for a SCORM LMS (Learning Management System) from a set of topics without constraining reuse of those topics. The LMS can save and restore the learner's progress through the lesson if the lesson is identified as a referenceable unit. The curriculum developer defines the collection of topics with a DITA map, using the chunk attribute to identify the learning module as a unit before generating the SCORM manifest.

Using the chunk attribute

When a set of topics is processed for output using a map, the map author may use the chunk attribute to override whatever default chunking behavior is set by the processor. The chunk attribute allows the map author to request that multi-topic documents be be broken into multiple documents, and that multiple individual topics be combined into a single document.

Chunking is necessarily output processor specific with chunked output required for some and not supported for other types of output. Chunking is also implementation specific with some implementations supporting some, but not all, chunking methods, or adding new implementation specific chunking methods to the standard methods described in this specification.

The value of the chunk attribute consists of one or more space delimited tokens. Tokens are defined in three categories: for selecting topics, for setting chunking policies, and for defining how the chunk values impact rendering. It is an error to use two tokens from the same category on a single topicref element.
Selecting topics
These values describe what portion of a target document is referenced. Such tokens are only useful when addressing a document that is made up of multiple topics. These values are ignored when the element on which they are specified does not reference a topic. Recognized values include:
  • select-topic: The "select-topic" token is used to select an individual topic without any ancestors, descendents, or peers from within the same document.
  • select-document: The "select-document" token is used to select the target topic together with all ancestors, descendents, and peers within the target document.
  • select-branch: The "select-branch" token is used to select the target topic together with its descendents.
Policies for splitting or combining documents
Two tokens are defined for setting chunking policies. Each token applies only to the current topicref or topicref specialization, except when used on the map element, in which case the value establishes a policy for the entire map.
  • by-topic: The "by-topic" token establishes a policy for the current topicref (or topicref specialization) where a separate output chunk is produced for each of the selected topics.
  • by-document: The "by-document" token establishes a policy for the current topicref (or topicref specialization) where a single output chunk is produced for the referenced topic or topics.
Rendering the selection
The following tokens affect how the chunk values impact rendering of the map or topics.
  • to-content: The "to-content" token indicates that the selection should be rendered as a new chunk of content.
    • When specified on a topicref or topicref specialization, this means that the topics selected by this topicref and its children will be rendered as a single chunk of content.
    • When specified on the map element, this indicates that the contents of all topics referenced by the map are to be rendered as a single document.
    • When specified on a topicref or topicref specialization that contains a title but no target, this indicates that a title-only topic must be generated in the rendered result, along with any topics referenced by child topicrefs (and topicref specializations) of this topicref. The rendition address of the generated topic is determined as defined for the copy-to attribute. If the copy-to attribute is not specified and the topicref has no id attribute, the address of the generated topic is not required to be predictable or consistent across rendition instances.

    For cross references to topicref elements, if the value of the chunk attribute is "to-content" or is unspecified, the cross reference is treated as a reference to the target topic. If the reference is to a topicref with no target, it is treated as a reference to the generated title-only topic.

  • to-navigation: The "to-navigation" token indicates that a new chunk of navigation should be used to render the current selection (such as an individual Table of Contents or related links). When specified on the map element, this token indicates that the map should be presented as a single navigation chunk. If a cross reference is made to a topicref that has a title but no target, and the chunk value of that topicref is set to "to-navigation", the resulting cross reference is treated as a reference to the rendered navigation document (such as an entry in the table of contents).

Some tokens or combinations of tokens may not be appropriate for all output types. When unsupported or conflicting tokens are encountered during output processing, warning or error messages should be produced. Recovery from such conflicts or other errors is implementation dependent.

There is no default value for the chunk attribute and the chunk attribute does not cascade from container elements, meaning that the chunk value on one topicref is not passed to its children. A default by-xxx policy for an entire map may be established by setting the chunk attribute on the map element, which will apply to any topicref that does not specify its own by-xxx policy.

When no chunk attribute values are given, chunking behavior is implementation dependent. When variations of this sort are not desired, a default for a specific map may be established by including a chunk attribute value on the map element.

When creating new documents via chunk processing, the storage object name or identifier (if relevant) is determined as follows:
  1. If an entire map is used to generate a single chunk (by placing to-content on the map element), the name is taken from the name of the map.
  2. If the @copy-to attribute is specified, the name is taken from the @copy-to attribute.
  3. If @copy-to is not specified and the by-topic policy is in effect, the name is taken from the @id attribute of the topic.
  4. If @copy-to is not specified and the by-document policy is in effect, the name is taken from the name of the referenced document.

Examples

In the examples below, an extension of ".xxxx" is used in place of the actual extensions that will vary by output format. For example, when the output format is HTML, the extension may actually be ".html", but this is not required.

The examples below assume the existence of the following files:
  • parent1.dita, parent2.dita, etc., each containing a single topic with id P1, P2, etc.
  • child1.dita, child2.dita, etc., each containing a single topic with id C1, C2, etc.
  • grandchild1.dita, grandchild2.dita, etc., each containing a single topic with id GC1, GC2, etc.
  • nested1.dita, nested2.dita, etc., each containing two topics: parent topics with id N1, N2, etc., and child topics with ids N1a, N2a, etc.
  • ditabase.dita, with the following contents:
    <dita xml:lang="en-us">
  <topic id="X">
    <title>Topic X</title><body><p>content</p></body>
  </topic>
  <topic id="Y">
    <title>Topic Y</title><body><p>content</p></body>
    <topic id="Y1">
      <title>Topic Y1</title><body><p>content</p></body>
      <topic id="Y1a">
       <title>Topic Y1a</title><body><p>content</p></body>
      </topic>
    </topic>
    <topic id="Y2">
      <title>Topic Y2</title><body><p>content</p></body>
    </topic>
  </topic>
  <topic id="Z">
    <title>Topic Z</title><body><p>content</p></body>
    <topic id="Z1">
      <title>Topic Z1</title><body><p>content</p></body>
    </topic>
  </topic>
</dita>
  1. The following map causes the entire map to generate a single output chunk.
    <map chunk="to-content">
   <topicref href="parent1.dita">
      <topicref href="child1.dita"/>
      <topicref href="child2.dita"/>
   </topicref>
</map>
  2. The following map will generate a separate chunk for every topic in every document referenced by the map. In this case, it will result in the topics P1.xxxx, N1.xxxx, and N1a.xxxx.
    <map chunk="by-topic">
   <topicref href="parent1.dita">
      <topicref href="nested1.dita"/>
   </topicref>
</map>
  3. The following map will generate two chunks: parent1.xxxx will contain only topic P1, while child1.xxxx will contain topic C1, with topics GC1 and GC2 nested within C1.
    <map>
   <topicref href="parent1.dita">
      <topicref href="child1.dita" chunk="to-content">
        <topicref href="grandchild1.dita"/>
        <topicref href="grandchild2.dita"/>
      </topicref>
   </topicref>
</map>
  4. The following map breaks down portions of ditabase.dita into three chunks. The first chunk Y.xxxx will contain only the single topic Y. The second chunk Y1.xxxx will contain the topic Y1 along with its child Y1a. The final chunk Y2.xxxx will contain only the topic Y2. For navigation purposes, the chunks for Y1 and Y2 are still nested within the chunk for Y.
    <map>
  <topicref href="ditabase.dita#Y" copy-to="Y.dita"
            chunk="to-content select-topic">
    <topicref href="ditabase.dita#Y1" copy-to="Y1.dita"
              chunk="to-content select-branch"/>
    <topicref href="ditabase.dita#Y2" copy-to="Y2.dita"
              chunk="to-content select-topic"/>
  </topicref>
</map>
  5. The following map will produce a single output chunk named parent1.xxxx, containing topic P1, with topic Y1 nested within P1, but without topic Y1a.
    <map chunk="by-document">
   <topicref href="parent1.dita" chunk="to-content">
      <topicref href="ditabase.dita#Y1"
         chunk="select-topic"/>
   </topicref>
</map>
  6. The following map will produce a single output chunk, parent1.xxxx, containing topic P1, topic Y1 nested within P1, and topic Y1a nested within Y1.
    <map chunk="by-document">
   <topicref href="parent1.dita" chunk="to-content">
      <topicref href="ditabase.dita#Y1"
         chunk="select-branch"/>
   </topicref>
</map>
  7. The following map will produce a single output chunk, P1.xxxx. The topic P1 will be the root topic, and topics X, Y, and Z (together with their descendents) will be nested within topic P1.
    <map chunk="by-topic">
   <topicref href="parent1.dita" chunk="to-content">
      <topicref href="ditabase.dita#Y1"
         chunk="select-document"/>
   </topicref>
</map>
  8. The following map will produce a single output chunk named parentchunk.xxxx containing topic P1 at the root. Topic N1 will be nested within P1, and N1a will be nested within N1.
    <map chunk="by-document">
   <topicref href="parent1.dita" chunk="to-content" copy-to="parentchunk.dita">
      <topicref href="nested1.dita" chunk="select-branch"/>
   </topicref>
</map>
  9. The following map will produce two output chunks. The first chunk named parentchunk.xxxx will contain the topics P1, C1, C3, and GC3. The "to-content" token on the reference to child2.dita causes that branch to begin a new chunk named child2chunk.xxxx, which will contain topics C2 and GC2.
    <map chunk="by-document">
   <topicref href="parent1.dita"
      chunk="to-content" copy-to="parentchunk.dita">
      <topicref href="child1.dita" chunk="select-branch"/>
      <topicref href="child2.dita"
         chunk="to-content select-branch"
         copy-to="child2chunk.dita">
         <topicref href="grandchild2.dita"/>
      </topicref>
      <topicref href="child3.dita">
         <topicref href="grandchild3.dita"
            chunk="select-branch"/>
      </topicref>
   </topicref>
 </map>
  10. The following map produces a single chunk named nestedchunk.xxxx, which contains topic N1 with no topics nested within.
    <map>
   <topicref href="nested1.dita#N1"
             copy-to="nestedchunk.dita"
             chunk="to-content select-topic"/>
</map>
  11. The following map will produce two navigation chunks, one for P1, C1, and the other topic references nested under parent1.dita, and a second for P2, C2, and the other topic references nested under parent2.dita.
    <map>
    <topicref href="parent1.dita"
          navtitle="How to set up a web server"
          chunk="to-navigation">
       <topicref href="child1.dita"
          chunk="select-branch"/>
       <!-- ... -->
    </topicref>
    <topicref href="parent2.dita"
          navtitle="How to ensure database security"
          chunk="to-navigation">
       <topicref href="child2.dita"
          chunk="select-branch"/>
       <!-- ... -->
    </topicref>
    <!-- ... -->
</map>

Implementation-specific tokens and future considerations

Additional chunk tokens may be added to the DITA Standard in the future. In addition, implementers may define their own custom, implementation-specific tokens. To avoid name conflicts between implementations or with future additions to the standard, implementation-specific tokens should consist of a prefix that gives the name or an abbreviation for the implementation followed by a colon followed by the chunking method name. For example: “acme:level2” could be a token for the Acme DITA Toolkit that requests the “level2” chunking method.

Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3.6 Conditional processing (profiling)
Next topic: 2.1.3.8 Printing


Printing

2.1.3.8 Printing

By default, the content of most elements is included in all output media. The DITA map provides a means to suppress element content from appearing in print-oriented media, or from appearing in non-print-oriented media, such as HTML. The generation or non-generation of print and other forms of output can also be affected through the use of other navigation-related attributes.

The author can specify whether individual topics or groups of topics referenced in a DITA map should be included for processing to print-oriented outputs such as PDF. Each map (or map specialization) and topicref (or topicref specialization) in a DITA map supports the attributes @toc, @processing-role, and @print. The @print attribute supports the following enumerated values, each controlling the way that print-oriented processors handle the inclusion or exclusion of topics or groups of topics.

@print value | Print-oriented Processing | Non-print-oriented Processing
unspecified (default) Example: <topicref href="foo.dita"> | Topics referenced by the map element are included in output. | Topics referenced by the map element are included in output.
yes Example: <topicref href="foo.dita" print="yes"> | Topics referenced by the map element are included in output. | Topics referenced by the map element are included in output.
printonly Example: <topicref href="foo.dita" print="printonly"> | Topics referenced by the map element are included in output. | Topics referenced by the map element are excluded in output.
no Example: <topicref href="foo.dita" print="no"> | Topics referenced by the map element are excluded in output. | Topics referenced by the map element are included in output.
-dita-use-conref-target Example: <topicref conref="#foo-topic" print="-dita-use-conref-target"> | Topics referenced by the map element derive a value for @print from the @print value of the referenced map element. See Using the -dita-use-conref-target value for more details on this value. | Topics referenced by the map element derive a value for @print from the @print value of the referenced map element. See Using the -dita-use-conref-target value for more details on this value.
Note: If a value for @print is not specified explicitly in a map element, but is specified in a map that references the map element, the @print value cascades to the referenced map. If the @print value is not specified on the referencing map, a default of "yes" is assumed.

Use @print="printonly" to identify transitional topics to be included exclusively in highly contextual or linear print-oriented output.

If the referenced topic should be excluded from all output formats, set the @processing-role attribute to "resource-only" instead of using the @print attribute. Content within that topic may still be referenced for display in other locations.

Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3.7 Chunking
Next topic: 2.1.3.9 Translation and localization


Translation and localization

2.1.3.9 Translation and localization

DITA has features that facilitate preparing content for translation and working with multilingual content, including the @xml:lang attribute, the @dir attribute, and the @translate attribute. In addition, the <index-sort-as> element provides support for index sorting in languages in which the index sort order must be modified by the author or translator.

  • 2.1.3.9.1 The @xml:lang attribute
    The @xml:lang attribute specifies the language (and optionally the locale) of the element content. The @xml:lang attribute applies to all attributes and content of the element where it is specified, unless it is overridden with @xml:lang on another element within that content. If the @xml:lang attribute on the document (outermost) element of a map or of a top-level topic has no value, the processor should assume a default value. The default value of the processor may be either fixed, configurable, or derived from the content itself, such as the @xml:lang attribute on the primary map file. As the default value of a processor may be fixed, it is strongly recommended that the @xml:lang attribute be set on each map and top-level topic.
  • 2.1.3.9.2 The dir attribute
    The dir attribute provides direction about how processors should render bidirectional text. Languages such as Arabic, Hebrew, Farsi, Urdu, and Yiddish have text written from right to left. Numerics and embedded sections of Western language text, however, are written from left to right. Some multilingual documents also contain a mixture of text segments in two directions. This attribute specifies how such text should be rendered to a reader.
Parent topic: 2.1.3 DITA processing
Previous topic: 2.1.3.8 Printing
Next topic: 2.1.3.9.1 The @xml:lang attribute


The @xml:lang attribute

2.1.3.9.1 The @xml:lang attribute

The @xml:lang attribute specifies the language (and optionally the locale) of the element content. The @xml:lang attribute applies to all attributes and content of the element where it is specified, unless it is overridden with @xml:lang on another element within that content. If the @xml:lang attribute on the document (outermost) element of a map or of a top-level topic has no value, the processor should assume a default value. The default value of the processor may be either fixed, configurable, or derived from the content itself, such as the @xml:lang attribute on the primary map file. As the default value of a processor may be fixed, it is strongly recommended that the @xml:lang attribute be set on each map and top-level topic.

The @xml:lang attribute is described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. Note that the recommended style for the @xml:lang attribute is lower case language and uppercase locale (if used), separated by a hyphen, i.e., en-US or sp-SP.

Recommended use in topics

For a DITA document that contains a single language, the highest level element that contains content should set the @xml:lang attribute to the language (and optionally the locale) that applies to the document.

When a DITA document contains more than one language, the highest level element should set the @xml:lang attribute to the primary language (and optionally the locale) that applies to the document. If part of a document is written in a different language, authors should ensure that the part is enclosed in an element with the @xml:lang attribute set appropriately. Processors should style each element in a way that is appropriate for its language as identified by the @xml:lang attribute. This method of overriding the default document language applies to both block and inline elements that use the alternate language.

The @xml:lang attribute should be explicitly set on the root element of each map and topic. When the @xml:lang attribute is specified for a document, DITA processors must use the specified value to determine the language of the document. It is strongly recommended to author the @xml:lang value in the source language document, in order to facilitate the translation process, where translation tools (or translators) simply change the existing @xml:lang attribute value to the value of the target language.

Note: Some translation tools support changing the value of an existing @xml:lang attribute, but do not support adding new markup to the document being translated. Therefore, if the author of the source language content does not set the @xml:lang attribute, it may not be possible (or may be difficult) for the translator to add the @xml:lang attribute to the translated document.

Use in maps

The @xml:lang attribute can be specified on the <map> element. The @xml:lang attribute cascades within the map the same way that it cascades within a topic. The @xml:lang value does not cascade from one map to another or from a map to a topic, and an @xml:lang value specified in a map does not override @xml:lang values specified in other maps or in topics.

The primary language for the map should be set on the <map> element. The specified language should remain in effect for all child <topicref> elements, unless a child specifies a different value for the @xml:lang attribute.

When no @xml:lang value is supplied locally or on an ancestor, a processor determined default value is assumed.

Use with the @conref or @conkeyref attribute

When a @conref or @conkeyref attribute is used to include content from one element into another, the processor must use the effective value of the @xml:lang attribute from the referenced element, that is, the element that contains the content. If the reference element does not have an explicit value for the @xml:lang attribute, the effective value for its @xml:lang attribute is determined by using the standard @xml:lang inheritance from the referenced source.. If this action results in no effective value for @xml:lang, the processor should default to using the same value that is used for topics that do not set the @xml:lang attribute.

This behavior is shown in the following example, where the value of the @xml:lang attribute of the included note is obtained from its parent <section> element (id="qqwwee") that sets the @xml:lang attribute. In this example, the @xml:lang value "fr" is applied to the note with the id attribute "mynote".

<-- ****************installingAcme.dita********************* -->

<?xml version="1.0"?>
<!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd">
<topic xml:lang="en" id="install_acme">
 <title>Installing Acme</title>
 <shortdesc>Step-by-step details about how to install Acme.</shortdesc>
 <body>
  <section>
   <title>Before you begin</title>
   <p>Special notes when installing Acme in France:</p>
   <note conref="warningsAcme.dita#topic_warnings/frenchwarnings"></note>
  </section>
 </body>
</topic>
</dita>
*******************************************

<-- **************** warningsAcme.dita ********************* -->
<?xml version="1.0"?>
<!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd">
<topic id="topic_warnings">
 <title>Warnings</title>
 <body>
  <section id="qqwwee" xml:lang="fr">
   <title>French warnings</title>
   <p>These are our French warnings.</p>
   <note id="frenchwarnings">Note in French!</note>
  </section>
  <section xml:lang="en">
   <title>English warnings</title>
   <p>These are our English warnings.</p>
   <note id="englishwarnings">Note in English!</note>
  </section>
 </body>
</topic>
*************************************
Parent topic: 2.1.3.9 Translation and localization
Previous topic: 2.1.3.9 Translation and localization
Next topic: 2.1.3.9.2 The dir attribute


The dir attribute

2.1.3.9.2 The dir attribute

The dir attribute provides direction about how processors should render bidirectional text. Languages such as Arabic, Hebrew, Farsi, Urdu, and Yiddish have text written from right to left. Numerics and embedded sections of Western language text, however, are written from left to right. Some multilingual documents also contain a mixture of text segments in two directions. This attribute specifies how such text should be rendered to a reader.

Bidirectional text processing is controlled by several factors:
  • The xml:lang attribute may be used to identify text that requires bidirectional rendering. The Unicode Bidirectional algorithm provides the means to properly identify western content in mixed text.
  • The dir attribute may be set on the root element, in combination with the xml:lang attribute. For example, to correctly set in a web browser a text in Arabic with embedded English content, the root element should be set with xml:lang="ar" and dir="rtl". All text, including punctuation marks, will be set correctly.
  • The dir attribute may be set to either "ltr" or "rtl" on an element in the document.
  • The dir attribute may be set to either "lro" or "rlo" on an element in the document.

The Unicode bidirectional algorithm positions the punctuation correctly for a given language. The rendering is responsible for displaying the text properly.

The use of the dir attribute and the Unicode algorithm is explained in the article Specifying the direction of text and tables: the dir attribute (http://www.w3.org/TR/html4/struct/dirlang.html#adef-dir) . This article contains several examples of how to use the dir attribute set to either left-to-right or right-to-left. There is no example of setting the dir attribute to either "lro" or "rlo", although it can be inferred from the example that uses the <bdo> element, a now-deprecated W3C mechanism for overriding the entire Unicode bidirectional algorithm.

Note that properly written mixed text does not need any special markers. The Unicode bidirectional algorithm is sufficient. However, some rendering systems may need directions for displaying bidirectional text, such as Arabic, properly. For example, the Apache FOP tool may not render Arabic properly unless the left-to-right and right-to-left indicators are used.

Recommended usage

The dir attribute, together with the xml:lang attribute, is essential for rendering table columns and definition lists <dl> to ensure proper order.

In general text, the Unicode Bidirectional algorithm, as specified by the xml:lang attribute together with the dir attribute, provides for various levels of bidirectionality, as follows:
  • Directionality is either explicitly specified via the xml:lang attribute in combination with the dir attribute on the highest level element (topic or derived peer for topics, map for ditamaps) or assumed by the processing application. If used, it is recommended to specify the dir attribute on the highest level element in the topic or document element of the map.
  • When embedding a right-to-left text run inside a left-to-right text run (or vice-versa), the default direction may provide incorrect results based on the rendering mechanism, especially if the embedded text run includes punctuation that is located at one end of the embedded text run. Unicode defines spaces and punctuation as having neutral directionality and defines directionality for these neutral characters when they appear between characters having a strong directionality (most characters that are not spaces or punctuation). While the default direction is often sufficient to determine the correct directionality of the language, sometimes it renders the characters incorrectly (for example, a question mark at the end of a Hebrew question may appear at the beginning of the question instead of at the end or a parenthesis may render incorrectly). To control this behavior, the dir attribute is set to "ltr" or "rtl" as needed, to ensure that the desired direction is applied to the characters that have neutral bidirectionality. The "ltr" and "rtl" values override only the neutral characters (e.g. spaces and punctuation), not all Unicode characters.
    Note: Problems with Unicode rendering may be caused by the rendering mechanism. The problems are not due to the XML markup itself.
  • Sometimes you may want to override the default directionality for strongly bidirectional characters. Overrides are done using the "lro" and "rlo" values, which overrides the Unicode Bidirectional algorithm. This override forces a direction on the contents of the element. These override attributes give the author a brute force way of setting the directionality independent of the Unicode Bidirectional algorithm. The gentler "ltr" and "rtl" values have a less radical effect, only affecting punctuation and other so-called neutral characters.

For most authoring needs, the "ltr" and "rtl" values are sufficient. Only when the desired effect cannot be achieved using these values, should the override values be used.

Implementation precautions

Applications that process DITA documents, whether at the authoring, translation, publishing, or any other stage, should fully support the Unicode bidirectional algorithm to correctly implement the script and directionality for each language used in the document.

Applications should ensure every highest level topic element and the root map element explicitly assign the dir attribute, as well as the xml:lang attribute.

Parent topic: 2.1.3.9 Translation and localization
Previous topic: 2.1.3.9.1 The @xml:lang attribute
Next topic: 2.1.4 Configuration, specialization, and constraints
Related information
What you need to know about the BIDI algorithm and inline markup (http://www.w3.org/International/articles/inline-bidi-markup/)
XHTML Bi-directional Text Attribute Module (http://www.w3.org/TR/2004/WD-xhtml2-20040722/mod-bidi.html)
Specifying the direction of text and tables: the dir attribute (http://www.w3.org/TR/html4/struct/dirlang.html#adef-dir)
HTML 4.0 Common Attributes (http://www.htmlhelp.com/reference/html40/attrs.html)


Configuration, specialization, and constraints

2.1.4 Configuration, specialization, and constraints

The extension facilities of DITA allow existing vocabulary and constraint modules to be combined to create specific DITA document types. Additionally, vocabulary modules can be extended to create more-specialized markup to meet new requirements not satisfied by existing markup.

  • 2.1.4.1 Overview of DITA extension facilities
    DITA provides three extension facilities: configuration of the vocabulary modules used by DITA document types, constraint of base content models and attribute lists, and creation of new element and attribute types (specialization).
  • 2.1.4.2 Configuration (Document type shells)
    A given DITA map or topic document is governed by a DITA document type that defines the set of structural modules (topic or map types), domain modules, and constraints modules that the map or topic can use.
  • 2.1.4.3 Specialization
    The specialization feature of DITA allows for the creation of new element types and attributes that are explicitly and formally derived from existing types. The resulting specialization allows for the blind interchange of all conforming DITA content and a minimum level of common processing for all DITA content. It also allows specialization-aware processors to add specialization-specific processing to existing base processing.
  • 2.1.4.4 Constraints
    Constraint modules define additional constraints for corresponding vocabulary modules in order to restrict content models or attribute lists for specific element types, remove extension elements from an integrated domain module, or replace base element types with domain-provided extension element types. Constraint modules do not and cannot change element semantics, only the details of how element types can be used in the context of a specific concrete document type. Because constraints can make optional elements required, documents that use the same vocabulary modules may still have incompatible constraints. Thus the use of constraints can affect the ability for content from one topic or map to be used directly in another topic or map.
Parent topic: 2.1 Architectural Specification: Base
Previous topic: 2.1.3.9.2 The dir attribute
Next topic: 2.1.4.1 Overview of DITA extension facilities


Overview of DITA extension facilities

2.1.4.1 Overview of DITA extension facilities

DITA provides three extension facilities: configuration of the vocabulary modules used by DITA document types, constraint of base content models and attribute lists, and creation of new element and attribute types (specialization).

Configuration enables the definition of DITA document types that include only those vocabulary modules required for a given set of documents without the need to modify the vocabulary modules in any way. Configurations are implemented as document type shells.

Constraint enables the unilateral modification of content models and attribute lists for individual elements without modifying the base vocabulary modules involved, in the context of a specific configuration. Constraints are implemented as constraint modules, which are integrated into document type shells.

Specialization enables the creation of new element types in a way that preserves the ability to blindly interchange those new element types with any conforming DITA application. Specializations are implemented as vocabulary modules, which are then integrated into any number of document type shells.

Specialization hierarchies are implemented as sets of vocabulary modules, each of which declares the markup and entities that are unique to a specialization. The separation of the markup vocabulary and its implementing declarations into modules makes it easy to extend the hierarchy, because new modules can be added without affecting existing document types. It also makes it easy to assemble design elements from different sources into a single integrated document type shell and makes it easy to reuse specific parts of the specialization hierarchy in more than one document type shell.

DITA documents are governed by DITA document types that represent the combination of one or more structural types (maps or topics), domain vocabularies, and constraint modules that define the set of element types and attributes available to a specific document. In short, DITA provides a framework by which XML vocabulary and constraint modules can be combined in an infinite number of ways to create specific document types, as well as a set of base modules that serve as the base for further configuration, constraint, or specialization.

DITA documents are typically governed by a conforming DITA document type shell as defined in this section. However, the conformance of a DITA document is a function of the document instance, not its governing schema. Therefore conforming DITA documents are not required to use a conforming document type shell.

Conforming DITA documents are not required to have any governing document type declaration or schema. In addition, there may compelling or practical reasons to use non-conforming document type shells. For example, a document might use a document type shell that does not conform to the DITA requirements for shells in order to meet the needs of a specific tool, but the document can still be a conforming DITA document and, if the document type only allows content and attributes that are conforming, it can ensure that the documents it governs are conforming DITA documents even though the document type itself does not conform to the requirements for DITA document type shells. That is, there can be document type shells that do not conform to the coding requirements for document shells that can still ensure the creation of conforming DITA documents. There can also be document type shells that do not conform to the coding requirements for document type shells and that allow, but do not ensure, the creation of conforming DITA documents.

  • 2.1.4.1.1 Recognized XML document constraint mechanisms
    The DITA standard currently recognizes two XML document grammar mechanisms by which conforming DITA vocabulary modules and document types may be constructed: document type declarations (DTDs) and XML Schema declarations (XSDs).
Parent topic: 2.1.4 Configuration, specialization, and constraints
Previous topic: 2.1.4 Configuration, specialization, and constraints
Next topic: 2.1.4.1.1 Recognized XML document constraint mechanisms


Recognized XML document constraint mechanisms

2.1.4.1.1 Recognized XML document constraint mechanisms

The DITA standard currently recognizes two XML document grammar mechanisms by which conforming DITA vocabulary modules and document types may be constructed: document type declarations (DTDs) and XML Schema declarations (XSDs).

This specification defines implementation requirements for both of these document constraint mechanisms. The OASIS DITA Technical Committee recognizes that other XML grammar languages might provide similar modularity and extensibility mechanisms. However, the Technical Committee has not yet defined implementation requirements for those languages so their conformance cannot be determined.

Parent topic: 2.1.4.1 Overview of DITA extension facilities
Previous topic: 2.1.4.1 Overview of DITA extension facilities
Next topic: 2.1.4.2 Configuration (Document type shells)


Configuration (Document type shells)

2.1.4.2 Configuration (Document type shells)

A given DITA map or topic document is governed by a DITA document type that defines the set of structural modules (topic or map types), domain modules, and constraints modules that the map or topic can use.

The DITA document type is defined entirely by the set of modules declared on the @domains attribute of the document's root element and by the values of the @class attributes of all the elements in the document. If the @domains attribute declares both structural and domain vocabulary modules, then the @domains attribute by itself serves to define the DITA document type. The information on the @domains and @class attributes is sufficient to implement all DITA-defined processing and constraint checking on documents (for example, determining if a referenced element in a content reference has a set of modules compatible with the modules used by the referencing element's document).

Thus, DITA does not require that conforming DITA documents have an associated DTD, XSD, or other formal document type definition as long as all required attributes are explicit in document instances. However, most DITA documents have an associated DTD or XML schema document by which the documents can be validated using normal XML processors and that can provide default values for the @domains and @class attributes, in particular. In addition, while the DITA specification only defines coding requirements for DTDs and XML schema documents, conforming DITA documents may use other document type constraint languages, such as RelaxNG or Schematron.

Per the coding requirements for DITA document types, document type shells are always implemented as a top-level file that only includes and configures vocabulary modules—they never directly define new element or attribute types.

Two document type shells define the same DITA document type if they integrate the same set of vocabulary and constraint modules. For example, a shell document type that is an unmodified copy of the OASIS-provided topic document type shell (topic.dtd or topic.xsd) defines the same DITA document type as the original but, because it is a distinct file, has a distinct system identifier (because it is not a replacement for the OASIS-provided shell but a copy of it, which must be stored in a different location) and must have a unique public identifier if a public identifier is associated with it. In particular, for document type shells not created by OASIS, the public identifier or URN for the document type shell must not indicate OASIS as the owner and should reflect the owner or creator of the document type shell. For example, if example.com creates a copy of the topic.dtd document type shell for its own use, an appropriate public identifier would be "-//example.com//DTD DITA Topic//EN", where "example.com" is the owner identifier component of the public identifier. An appropriate URN would be "urn:example.com:names:dita:xsd:topic.xsd".
Note: The public or system identifier associated with a given document type shell is not, by itself, necessarily distinguishing. This is because two different shell document types, owned by different owners, may define the same DITA document type as indicated by the effective value of the @domains attribute.

While the DITA specification includes a starter set of document type shells for common combinations of modules, those document type shells are not mandatory.

Note: Even if an initial implementation does not require configuration, constraint, or specialization, it can be useful to create new shell document types. That way, if modification is required in the future, documents will not need to be modified to point to a new shell document type.

DITA document type shells must follow the coding requirements defined in this specification. This ensures consistency of implementation and also serves to make the task of creating document type shells almost entirely mechanical.

  • 2.1.4.2.1 DTD document-type shell: Coding requirements
    A document type shell integrates one or more topic type or map type modules, zero or more domain modules, and zero or more constraint modules. A DTD document type shell is organized into sections, where each section contains a specific type of declaration.
  • 2.1.4.2.2 XSD document-type shell: Coding requirements
    A shell document type integrates one or more topic type or map type modules, zero or more domain modules, and zero or more constraint modules. A shell XSD is organized into sections, where each section contains a specific type of declaration.
Parent topic: 2.1.4 Configuration, specialization, and constraints
Previous topic: 2.1.4.1.1 Recognized XML document constraint mechanisms
Next topic: 2.1.4.2.1 DTD document-type shell: Coding requirements


DTD document-type shell: Coding requirements

2.1.4.2.1 DTD document-type shell: Coding requirements

A document type shell integrates one or more topic type or map type modules, zero or more domain modules, and zero or more constraint modules. A DTD document type shell is organized into sections, where each section contains a specific type of declaration.

DTD document type shells may not directly declare element types or attributes. A DTD document type shell must conform to the following coding requirements.

Each section of the shell is introduced by a comment. Shells should use these comments to identify each section of the shell. Each section should be present in the shell DTD, even if the section contains no declarations, and must occur in the order they are presented here. The ordering is required by the XML rules for entity declaration precedence and also serve to enable automatic shell creation and modification. Shells should have an initial set of comments that describe the shell and indicate the public identifiers, URNs, or absolute URLs by which the shell should be referenced in DOCTYPE declarations.

Topic or map entity inclusions
The topic or map entity declarations section includes the .ent file for the top-level topic or map type the shell is configuring.
Topic shells should use the comment:
<!-- ============================================================= -->
<!--                    TOPIC ENTITY DECLARATIONS                  -->
<!-- ============================================================= -->
Map shells should use the comment:
<!-- ============================================================= -->
<!--                    MAP ENTITY DECLARATIONS                    -->
<!-- ============================================================= -->
This section must declare and reference as an external parameter entity the .ent file for the topic or map module where the entity is named %typename-dec. For example:
<!ENTITY % concept-dec
  PUBLIC "-//OASIS//ENTITIES DITA 1.2 Concept//EN"
         "concept.ent"
>%concept-dec;
Domain entity inclusions
The domain entity inclusions section includes the entity declaration files for each element domain integrated by the document type. This section should use the comment:
<!-- ============================================================= -->
<!--                    DOMAIN ENTITY DECLARATIONS                 -->
<!-- ============================================================= -->

For each element domain included in the shell, this section must declare an external parameter entity for the domain's entity declaration file and immediately reference the entity. The entity name for the domain declaration consists of the domain name plus the dec suffix. In the following example, the entity file for the highlight domain is included in the document type shell:

<!ENTITY % hi-d-dec PUBLIC
    "-//OASIS//ENTITIES DITA Highlight Domain//EN"
    "highlightDomain.ent"
>%hi-d-dec;
Domain attribute inclusions

The domain attribute inclusions section includes the entity declaration files for each attribute domain integrated by the document type. This section should use the comment:

<!-- ============================================================= -->
<!--                    DOMAIN ATTRIBUTE DECLARATIONS              -->
<!-- ============================================================= -->

For each attribute domain included in the shell, this section must declare an external parameter entity for the domain's entity declaration file and immediately reference the entity. The entity name for the domain declaration consists of the domain name plus the ent suffix. In the following example, the entity file for a new attribute domain is included in the document type shell:

<!ENTITY % newAtt-d-dec PUBLIC
    "-//My Company//ENTITIES New Attribute Domain//EN"
    "newAttDomain.ent"
>%newAtt-d-dec;
Element extension redefinitions
The element extension redefinition section contains redefinitions of element name parameter entities to reflect the integration of domain-provided element types into base content models. This section should use the comment:
<!-- ============================================================= -->
<!--                    DOMAIN EXTENSIONS                          -->
<!-- ============================================================= -->

For each element that is extended by one or more domains, the document type shell redefines the entity for the element. The new definition is a disjunctive list of alternatives comprising the literal name of the element followed by the element extension entity from each domain that is providing specializations. In the following example, the entity for the <pre> element is redefined to allow specializations from the programming, software, and user interface domains:

<!ENTITY % pre
    "pre        |
     %pr-d-pre; |
     %sw-d-pre; |
     %ui-d-pre;">
The value of the entity may omit any base types from which other types listed are specialized. For example, the preceding example could omit the <pre> element, effectively allowing only specializations of <pre>, but not <pre> itself:
<!ENTITY % pre
    "%pr-d-pre; |
     %sw-d-pre; |
     %ui-d-pre;">
Note: Omitting base types from domain extensions constitutes a form of constraint. The constraint must be represented by a constraint module that declares the @domains attribute declaration for the constraint. For the omission of <pre> in the preceding example the constraint might be called "noBasePre-c" and would be declared in a file named "noBasePreConstraint.mod", containing the following declarations:
<!ENTITY noBasePre-c-pre  "%pr-d-pre; | %sw-d-pre; | %ui-d-pre;">
<!ENTITY noBasePre-c-att  "(topic noBasePre-c)" >
<!ENTITY % pre          “%noBasePre-c-pre ;“>
Attribute extension redefinitions
The attribute extension redefinition section integrates the declarations of specializations of the base and props attributes (defined in attribute domain modules included in the attribute domain inclusion section). This section must use the comment:
<!-- ============================================================= -->
<!--                    DOMAIN ATTRIBUTE EXTENSIONS                -->
<!-- ============================================================= -->

The entities for extending the props and base attributes have a null value by default:

<!ENTITY % props-attribute-extensions  "" >
<!ENTITY % base-attribute-extensions   "" >

For each attribute domain included by the shell, the shell must redefine the entity that is extended. The new definition is a list of the attribute extension entities for the domains that are providing specializations.

<!ENTITY % props-attribute-extensions
        "%newAtt-d-attribute;
         %othernewAtt-d-attribute;">
<!ENTITY % base-attribute-extensions
        "%newfrombaseAtt-d-attribute;
         %othernewfrombaseAtt-d-attribute;">
Topic nesting redefinitions
The topic nesting section contains redefinitions of the topic nesting control parameter entities defined by the topic modules integrated in the shell. This section should use the comment:
<!-- ============================================================= -->
<!--                    TOPIC NESTING OVERRIDES                    -->
<!-- ============================================================= -->

For each topic type integrated in the shell, the document type shell may control nesting of subtopics by redefining the topictype-info-types entity. The definition is usually an OR list of topic types that can be nested in the corresponding parent topic type. Use the literal root element name of each topic, not the corresponding element entity, as in the following example:

<!ENTITY % concept-info-types "concept | myTopicType">
The document type shell may also set the default for most topic types by defining the global info-types entity, for example:
<!ENTITY % info-types "concept | myTopicType">
Domain declaration redefinition
The domain declaration redefinition section sets the effective value of the @domains attribute for the topic or map type modules integrated into the shell. This section should use the comment:
<!-- ============================================================= -->
<!--                    DOMAINS ATTRIBUTE OVERRIDE                 -->
<!-- ============================================================= -->

The document type shell must redefine the included-domains entity to list the domains for specializations that are included in the document type, as well as any constraint modules, as in the following example:

<!ENTITY included-domains
    "&hi-d-att;
     &ut-d-att;
     &ui-d-att;
     &pr-d-att;
     &sw-d-att;
     &newAtt-d-att;
     &noBasePre-c-ph;
   "
>

For a domain or structural module, the domains attribute value entity is declared in the domain's .ent file. For constraint modules, the domains attribute value entity is declared in the module's .mod file constraint modules do not use separate .ent files).

Content constraint module inclusions
The content constraint module inclusion section includes constraint modules that override the base content models for structural or domain types integrated in the shell. This section should use the comment:
<!-- ============================================================= -->
<!--                    CONTENT CONSTRAINT INTEGRATION             -->
<!-- ============================================================= -->
For each constraint module integrated in the shell, the shell must declare an external parameter entity for the constraint's .mod file and immediately reference the entity. The entity name for the constraint declaration consists of the constraint module name plus the -c-mod suffix. For example, this constraint inclusion for the task topic type constrains the DITA 1.2 relaxed task content model to match the more constrained DITA 1.1 task content model:
<!ENTITY % strictTaskbody-c-def
  PUBLIC "-//OASIS//ELEMENTS DITA 1.2 Strict Taskbody Constraint//EN"
  "strictTaskbodyConstraint.mod"
>%strictTaskbody-c-def;
Structural definition inclusions
The structural definition inclusion section includes the element type declaration (.mod) files for each topic or map type integrated into the shell. For topic shells, this section should use the comment:
<!-- ============================================================= -->
<!--                    TOPIC ELEMENT INTEGRATION                  -->
<!-- ============================================================= -->
For map shells, this section should use the comment:
<!-- ============================================================= -->
<!--                    MAP ELEMENT INTEGRATION                    -->
<!-- ============================================================= -->

For each structural type integrated in the document type, the document type shell must declare and reference an external parameter entity for the structural type module's .mod file. The entity name consists of the name of the structural type plus a -type suffix. For example:

<!ENTITY % topic-type PUBLIC
    "-//OASIS//ELEMENTS DITA Topic//EN"
    "topic.mod"
>%topic-type;
Element domain definition inclusions
The element domain definition inclusion section includes the element definition files for each element domain integrated into the shell. This section should use the comment:
<!-- ============================================================= -->
<!--                    DOMAIN ELEMENT INTEGRATION                 -->
<!-- ============================================================= -->

For each element domain used in the document type, the document type shell must declare and reference an external parameter entity for the domain definition module file (.mod). The entity name consists of the domain name plus a -def suffix. For example:

<!ENTITY % hi-d-def PUBLIC
    "-//OASIS//ELEMENTS DITA Highlight Domain//EN"
    "highlightDomain.mod"
>%hi-d-def;
Parent topic: 2.1.4.2 Configuration (Document type shells)
Previous topic: 2.1.4.2 Configuration (Document type shells)
Next topic: 2.1.4.2.2 XSD document-type shell: Coding requirements


XSD document-type shell: Coding requirements

2.1.4.2.2 XSD document-type shell: Coding requirements

A shell document type integrates one or more topic type or map type modules, zero or more domain modules, and zero or more constraint modules. A shell XSD is organized into sections, where each section contains a specific type of declaration.

An XSD document type shell must conform to the following coding requirements. XSD document type shells may not directly declare element types or attributes (except for the @domains attribute, which always reflects the details of the domains and structural types integrated by the shell).

DITA XSDs use the XML Schema redefine feature (xs:redefine) to override base group definitions for content models and attribute lists. This facility is analogous to the parameter entities used for DTDs. Unlike DTD parameter entities, an xs:redefine both includes the XSD file it redefines and holds the redefinition applied to the groups in the included XSD file. Thus, for XSD files that define groups, the file may be included via xs:include if it is used without modification or via xs:redefine if any of its groups are redefined.

Shell XSDs are organized into sections. Each section of the shell XSD is introduced by a comment. Shells should use these comments to identify each section of the shell. Each section should be present in the shell XSD, even if the section contains no declarations, and should occur in the order they are presented here. Shell XSDs should have an initial set of comments that describe the shell and indicate the URNs or absolute URLs by which the shell should be referenced from document instances or otherwise associated with documents. Shell XSDs may use the XSD appinfo and documentation elements to contain additional documentation about the shell.

Element domain inclusions

The element domain inclusion section contains includes of each element domain integrated by the shell. This section should use the comment:

<!--  ================ ELEMENT DOMAINS =====================  -->
For each element domain used by the map or topic type, the shell XSD must have an xs:include element that includes the XSD module for that domain. For example:
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:programmingDomain.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:softwareDomain.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:highlightDomain.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:uiDomain.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:utilitiesDomain.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:indexingDomain.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:hazardstatementDomain.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:abbreviateDomain.xsd:1.2" />
Attribute domain inclusions
The attribute domain inclusion section contains includes of each attribute domain integrated by the shell. This section should use the comment:
<!--  ================ ATTRIBUTE DOMAINS =====================  -->
For each attribute domain used by the map or topic type, the shell XSD must have an xs:include element that includes the XSD module for that domain. For example:
<xs:include schemaLocation="urn:example.com:dita:domains:newAtt.xsd" />
Group inclusions
The group inclusion section contains includes or redefinitions of the group definitions for the structural types integrated in the shell. Group redefinitions are used to integrate domain-provided element and attribute types into base content models. This section should use the comment:
<!--  ================ GROUP DEFINITIONS =====================  -->

For both map and topic shells, this section must include or redefine the common element group, the metadata declaration group, and the table model group.

For topic shells, this section must include or redefine the group XSD for each topic type used by the shell. For example, from a shell for the task topic type:
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:taskGrp.xsd:1.2" />
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:metaDeclGrp.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:tblDeclGrp.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:topicGrp.xsd:1.2"/>
For map shells, this section must include or redefine the group XSD for each map type used by the shell (that is, the module for the specialization of <map> the shell uses, as well as any ancestor map types from which the shell's map element is specialized). For example, from the learningMap shell:
    <xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:tblDeclGrp.xsd:1.2"/>
    <xs:redefine schemaLocation="urn:oasis:names:tc:dita:xsd:mapGrp.xsd:1.2">
      <xs:group name="topicref">
        <xs:choice>
          <xs:group ref="topicref"/>
          <xs:group ref="mapgroup-d-topicref"/>
          <xs:group ref="learningmap-d-topicref"/>
        </xs:choice>
      </xs:group>
    </xs:redefine>

    <xs:redefine schemaLocation="urn:oasis:names:tc:dita:xsd:commonElementGrp.xsd:1.2">
      <xs:group name="index-base">
        <xs:choice>
          <xs:group ref="index-base"/>
          <xs:group ref="indexing-d-index-base"/>
        </xs:choice>
      </xs:group>

    </xs:redefine>

    <xs:redefine schemaLocation="urn:oasis:names:tc:dita:xsd:metaDeclGrp.xsd:1.2">
      <xs:group name="metadata">
        <xs:choice>
          <xs:group ref="metadata"/>
          <xs:group ref="learningmeta-d-metadata"/>
        </xs:choice>
      </xs:group>
      <xs:group name="keywords">
        <xs:choice>
          <xs:group ref="keywords"/>
          <xs:group ref="delay-d-keywords"/>
        </xs:choice>
      </xs:group>
    </xs:redefine>
For each element extended by one or more domains, the document type shell must redefine the model group for the element to a list of alternatives including the literal name of the element and the element extension model group from each domain that is providing specializations. To integrate a new domain in the document type shell use the schema <redefine> mechanism to manage the number of domains used by the document type shell. The model group requires a reference to itself to extend the base model group. To see an example, look at the topic.xsd schema document.
<xs:group name="pre">
  <xs:choice>
    <xs:group ref="pre" />
    <xs:group ref="pr-d-pre" />
    <xs:group ref="ui-d-pre" />
    <xs:group ref="sw-d-pre" />
  </xs:choice>
</xs:group>
To add domains to a new structural type you can copy the contents of the parent structural type domains schema document into the document type shell. Add or remove the model group from the new domain to the appropriate named group.
<xs:group name="pre">
  <xs:choice>
    <xs:group ref="pre"/>
    <xs:group ref="pr-d-pre" />
    <xs:group ref="domainName-d-element"/>
  </xs:choice>
</xs:group>
For each attribute extended by one or more domains, the document type shell must redefine the attribute extension model group for the attribute to a list of alternatives including the literal name of the attribute and the attribute extension model group from each domain that is providing specializations. To integrate a new attribute domain in the document type shell use the schema <redefine> mechanism to manage the number of attribute domains used by the document type shell.
<xs:attributeGroup name="props-attribute-extensions">
  <xs:attributeGroup ref="props-attribute-extensions"/>
  <xs:attributeGroup ref="newAtt-d-attribute"/>
  <xs:attributeGroup ref="othernewAtt-d-attribute"/>
</xs:attributeGroup>

<xs:attributeGroup name="base-attribute-extensions">
  <xs:attributeGroup ref="base-attribute-extensions"/>
  <xs:attributeGroup ref="newfrombaseAtt-d-attribute"/>
  <xs:attributeGroup ref="othernewfrombaseAtt-d-attribute"/>
</xs:attributeGroup>
Module inclusions
The module inclusion section includes the module XSD files for the structural types used in the shell. This section should use the comment:
<!-- =================  MODULE INCLUDE DEFINITION  ==================  -->
For each map or topic type used by the shell, this section must include either the module XSD file for that type or a constraint module for that type . It must also include any other module XSD files required by the topic or map types, normally the common element module, meta declaration module, and table declaration module. For example:
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:commonElementMod.xsd:1.2"/>
<!-- ======== Table elements ======== -->
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:tblDeclMod.xsd:1.2"/>
<!-- ======= MetaData elements, plus keyword and indexterm ======= -->
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:metaDeclMod.xsd:1.2"/>
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:topicMod.xsd:1.2" />
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:conceptMod.xsd:1.2" />
Domains attribute declaration
The @domains attribute declaration section contains the declaration of the domains attribute for the shell. This section should use the comment:
<!-- =================  DOMAINS ATTRIBUTE DECLARATION  ==================  -->
The shell must declare the @domains attribute such that the @domains attribute value reflects each vocabulary module and constraint module integrated by the shell. The declaration has the form:
<xs:attributeGroup name="domains-att">
   <xs:attribute name="domains" type="xs:string"
        default="domain usage declarations"
   />
</xs:attributeGroup>
Where domain usage declarations is a sequence of domain usage specifications (see Domain usage declaration (the @domains attribute) for details). For example, from the learningMap shell:
<xs:attributeGroup name="domains-att">
  <xs:attribute name="domains" type="xs:string"
     default="(map mapgroup-d)
              (topic delay-d)
              (topic indexing-d)
              (topic learningmeta-d)
              (map learningmap-d) "
  />
</xs:attributeGroup>
Info types definition
Each topic type defines an info types group that defines the default set of allowed subordinate topics for that topic type. Topic shells may redefine this group to change the effective set of allowed subordinate topics.
The info types section contains the definition of the effective value of the info types groups for topics used by the shell. This section should use the comment:
<!-- =================  INFO TYPES DEFINITION  ==================  -->

This section must not be included in map shells.

The shell must define a model group with the name info-types. This model group may define a list of allowed subordinate topics. If the topic type should not allow subordinate topics, then the default value for the info-types model group must be defined as an empty group, as follows:
<xs:group name="info-types">
  <xs:sequence/>
</xs:group>
The document type shell may control how topics are allowed to nest within specific topic types by redefining the topic-type-specific info types group, named topictype-info-types. The info-types group is declared in the module XSD file for a given topic type. For example, in a shell for the concept topic type, allowing concept or generic topic to nest within concept:
<xs:redefine schemaLocation="urn:oasis:names:tc:dita:xsd:conceptMod.xsd:1.2" >
  <xs:group name="concept-info-types">
    <xs:choice>
      <xs:group ref="concept-info-types"/>
      <xs:group ref="topic"/>
    </xs:choice>
  </xs:group>
</xs:redefine>

Note that XSD rules require that the redefined group include a reference to itself in addition to any other components specified for the redefined group.

Parent topic: 2.1.4.2 Configuration (Document type shells)
Previous topic: 2.1.4.2.1 DTD document-type shell: Coding requirements
Next topic: 2.1.4.3 Specialization


Specialization

2.1.4.3 Specialization

The specialization feature of DITA allows for the creation of new element types and attributes that are explicitly and formally derived from existing types. The resulting specialization allows for the blind interchange of all conforming DITA content and a minimum level of common processing for all DITA content. It also allows specialization-aware processors to add specialization-specific processing to existing base processing.

Specializations are explicitly declared in documents

The specialization feature of DITA defines both a specialization hierarchy declaration syntax used in document instances and a set of document type implementation requirements. The specialization declarations allow processors to determine what set of specializations and associated local constraints a given DITA document uses. The specialization declarations for individual elements and attributes allow processors to determine what the type hierarchies of those elements and attributes are, from which processors can determine the most appropriate (or available) processing to apply.

Specialization enables controlled extension

Specialization allows you to define new kinds of information (new structural types or new domains of information), while reusing as much of existing design and code as possible, and minimizing or eliminating the costs of interchange, migration, and maintenance.

In traditional XML applications, all semantics for a given element instance are bound to the element type, such as <para> for a paragraph or <title> for a title. The XML specification provides no built-in mechanism for relating two element types to say "element type B is a subtype of element type A". However, in most documentation-focused XML applications there is often a clear hierarchy of types. For example, in a technical manual, there might be generic sections and more specialized sections, e.g. "Troubleshooting" or "Assembly Procedures". The presentation of the generic and specialized sections might be identical, but the more specialized sections might have more restrictive constraints or include additional element types relevant only to those section types. While these relationships might be understood by authors and system implementors, the XML standard provides no direct way to express the relationship, to say explicitly "A Troubleshooting section is a generic section and must conform to all requirements of generic sections". Having created the element type <section> and implemented presentation processing for it and then having later created the element type <troubleshooting>, there is no obvious mechanism for having all <troubleshooting> elements automatically get the processing associated with <section> elements. To get that behavior someone has to explicitly update all processors involved to apply <section> processing to <troubleshooting>.

The DITA specialization feature provides a standard mechanism for saying explicitly, using normal XML syntax, "A Troubleshooting section is a generic section and must conform to all requirements of generic sections" and, having said that, makes it possible for generic section processing to be applied to troubleshooting sections with no further effort.

When to use or not use specialization

Specialization is used when new structural types or new domains are needed. DITA specialization can be used when you want to make changes to your design for the sake of increased consistency or descriptiveness or have specific needs for output that cannot be addressed using the current data model. Specialization is not normally used for simply creating different output types, as DITA documents may be transformed to different outputs.

Do not use specialization to simply eliminate unneeded or unwanted element types from specific content models. The content models for element types defined in vocabulary modules can be configured using separately-defined constraint modules without the need to create new specializations. See Constraints.

Use specialization when you are dealing with new semantics (new, meaningful categories of information, either in the form of new structural types or new domains). The new semantics can be encoded as part of a specialization hierarchy, that allows them to be processed by existing specialization-aware transforms or transformed back to more general equivalents ("generalization") for processing by transforms that only understand the unspecialized base types. Use constraints to configure content models and attribute lists without changing semantics.

Types of specialization hierarchy

There are two kinds of specialization hierarchy: one for structural types (with topic or map at the root) and one for domains (with elements in topic or map at their root, or the @props or @base attributes). Structural types define topic or map structures, such as concept or task or reference, which often apply across subject areas (for example, a user interface task and a programming task may both consist of a series of steps). Domains define markup for a particular information domain or subject area, such as programming, or hardware. Each type of vocabulary module represents an “is a” hierarchy, in object-oriented terms, with each structural type or domain being a subclass of its parent. For example, a specialization of task is still a task and a specialization of the user interface domain is still part of the user interface domain. A given domain can be used with any map or topic type, as appropriate for the domain. In addition, specific structural types may require the use of specific domains.

Specialization of attributes

With structural specializations you can limit the allowed values of attributes defined on the base types of specialized types. You can also define new attributes through domain specializations based off of the @props attribute (for conditional processing) or the @base attribute (for other simple token attributes).

non-normative: As a general practice, structural specializations should not limit the values of the built-in selection attributes. Use constraint modules to define specific value lists for built-in selection attributes.

Attribute specialization allows you to define new conditional processing attributes that can be used for filtering and flagging (specializations of @props) or new attributes with no existing equivalent that can be managed and generalized in the same way as conditional processing attributes (specializations of @base).

New attributes need to be specialized from either @props or @base:
  • Attributes specialized from @props are recognized as conditional processing attributes
  • Attributes specialized from @base have no existing behavior associated with them
  • Values in specialized attributes should be preserved during generalization and respecialization as for @props
  • While generalized, the attribute values should still be understandable by both general and specialized behaviors, and be treated as equivalent to their specialized form. For example, conditional filtering should work the same way on specialized attributes and on generalized attributes.
  • 2.1.4.3.1 Vocabulary modules
    Vocabulary modules are atomic units of XML vocabulary definition (element types and attributes). A given DITA element type or attribute is declared in exactly one vocabulary module.
  • 2.1.4.3.2 Requirements for specialized element types and attributes
    When you specialize one element from another, or a new attribute from @props or @base, the new element or attribute must obey certain rules in order to be a conforming specialization.
  • 2.1.4.3.3 Element type specialization hierarchy declaration (the @class attribute)
    Each DITA element declares its specialization hierarchy as the value of the @class attribute. The @class attribute usually provides a mapping from the element's current name to its more general equivalents, but it can also provide a mapping from the current name to more general and more specialized equivalents. All specialization-aware processing can be defined in terms of @class attribute values without reference to a given element's tagname.
  • 2.1.4.3.4 Domain usage declaration (the @domains attribute)
    Structural types must declare the domain vocabulary modules and constraint modules they use. This is done with the @domains attribute, whose value is a sequence of parenthesized module ancestry specifications. The @domains attribute is declared on the root element for each topic or map type. Structural modules should declare their structural ancestry.
  • 2.1.4.3.5 Generalization
    Specialized content can be generalized to any ancestor type. The generalization process can preserve information about the former level of specialization to allow round-tripping between specialized and unspecialized forms of the same content.
  • 2.1.4.3.6 Attribute generalization
    There is a particular syntax to generalize attributes that have been specialized from the @props or @base attribute. Specialization-aware processors should be able to recognize and process both the specialized and generalized forms of an attribute as being equivalent in their values.
  • 2.1.4.3.7 Specializing foreign or unknown content
    Specializing the <foreign> or <unknown> element is an open extension to DITA for the purpose of incorporating standard vocabularies for non-textual content, such as MathML and SVG, as in-line objects. These elements should not be used to include textual content or metadata in DITA documents except where such content acts as an example or display, rather than as the primary content of a topic.
  • 2.1.4.3.8 Specialization module coding requirements
    The base DITA element and attribute types may be extended through the creation of new vocabulary modules that define specializations of more-general types.
Parent topic: 2.1.4 Configuration, specialization, and constraints
Previous topic: 2.1.4.2.2 XSD document-type shell: Coding requirements
Next topic: 2.1.4.3.1 Vocabulary modules


Vocabulary modules

2.1.4.3.1 Vocabulary modules

Vocabulary modules are atomic units of XML vocabulary definition (element types and attributes). A given DITA element type or attribute is declared in exactly one vocabulary module.

Vocabulary modules must reflect the implementation requirements defined in this specification for each recognized constraint mechanism. These requirements ensure that all vocabulary modules of a given type follow the same basic coding patterns for how their components are named and organized.

Vocabulary modules intended to be used outside of a narrowly-restricted context should have one or more associated globally-unique names (public IDs, URNs, or absolute URLs) by which modules can be referenced without regard to their local storage location.

There are three types of vocabulary module:
structural
A vocabulary module that defines exactly one top-level map or topic type. Structural modules may also define specializations of elements from domain modules. Structural modules are either topic modules or map modules.

A topic vocabulary module must define exactly one top-level topic type. It may define additional topic types that are then allowed to occur as subordinate topics within the top-level topic. However, such subordinate topic types may not be used as the root elements of conforming DITA documents. For example, a given top-level topic type may require the use of subordinate topic types that would only ever be meaningful in the context of their containing type and thus would never be candidates for standalone authoring or aggregation via maps. In that case, the subordinate topic type may be declared in the module for the top-level topic type that uses it. However, in most cases, potential subordinate topics should be defined in their own vocabulary modules.

A map vocabulary module must define exactly one element type that specializes map.

element domain
A vocabulary module that defines one or more element types that specialize element types used within maps or topics.
attribute domain
A vocabulary module that defines exactly one specialization of either the @base or @props attribute.

A given vocabulary module exists in an exclusive hierarchy relative to its ancestor modules. For example, the <concept> topic type is defined in the concept topic module and is itself derived from the topic topic module (that is, the topic-defining structural module that defines the topic type <topic>). Likewise, the <task> topic type is defined in the task topic module and is derived from the <topic> topic type. Thus the concept and task topic types are children of the <topic> topic type in the module hierarchy rooted at the <topic> topic vocabulary module.

All topic types must ultimately be specialized from <topic>. All map types must ultimately be specialized from <map>. Domain elements intended for use in topics must ultimately be specialized from elements defined in the topic module. Domain elements intended for use in maps must ultimately be specialized from elements defined by or used in the map module (maps share some element types with topics but no map-specific elements may be used within topics). Domain attributes must ultimately be specialized from either the @base or @props attribute.

Each vocabulary module has an associated short name, which is used to identify the module in @class and @domains attribute values. While module names need not be globally unique, module names must be unique within the scope of a given specialization hierarchy. The short name must be a valid XML name token.

For structural types, the module name must be the same as the root element. For example, "task" is the name of the structural vocabulary module whose root element is <task>. For domains, the name is assigned by the developer of the vocabulary module. By convention, domain names end with "-d" and are kept short; for example, "ui-d" for the user interface domain and "pr-d" for the programming domain.

When integrated into concrete document types, vocabulary modules may be further constrained through the use of constraint modules. See Constraints.

Parent topic: 2.1.4.3 Specialization
Previous topic: 2.1.4.3 Specialization
Next topic: 2.1.4.3.2 Requirements for specialized element types and attributes


Requirements for specialized element types and attributes

2.1.4.3.2 Requirements for specialized element types and attributes

When you specialize one element from another, or a new attribute from @props or @base, the new element or attribute must obey certain rules in order to be a conforming specialization.

A specialized element:

  • Must have a properly formed @class attribute specifying inheritance from its parent.
  • Must not have a more inclusive content model than its parent has.
  • Must not have attributes that its parent lacks.
  • Must not have values or value ranges of these attributes that are more extensive than those in the parent.

An attribute specialized from the @props or @base attribute:

  • Must follow the rules for attribute domain specialization.
  • Must not have values or value ranges that are more extensive than those of the parent.
  • Must conform to the rules for conditional processing values, that is, alphanumeric space-delimited values. In generalized form, the values must conform to the rules for attribute generalization.
  • Must be declared as a global attribute. Attribute specializations cannot be limited to specific element types.

DITA elements are never in a namespace. Only the @DITAArchVersion attribute is in a DITA-defined namespace. All other attributes, except for those defined by the XML standard, are in no namespace.

This limitation is imposed by the details of the @class attribute syntax, which makes it impractical to have namespace-qualified names for either vocabulary modules or individual element types or attributes. Elements included as descendants of the DITA <foreign> element type may be in any namespace.
Note: For this reason, domain modules that are intended for wide use should take care to define element type and attribute names that are unlikely to conflict with names used in other domains, for example, by using a domain-specific prefix on all names.
Parent topic: 2.1.4.3 Specialization
Previous topic: 2.1.4.3.1 Vocabulary modules
Next topic: 2.1.4.3.3 Element type specialization hierarchy declaration (the @class attribute)


Element type specialization hierarchy declaration (the @class attribute)

2.1.4.3.3 Element type specialization hierarchy declaration (the @class attribute)

Each DITA element declares its specialization hierarchy as the value of the @class attribute. The @class attribute usually provides a mapping from the element's current name to its more general equivalents, but it can also provide a mapping from the current name to more general and more specialized equivalents. All specialization-aware processing can be defined in terms of @class attribute values without reference to a given element's tagname.

Specialization hierarchy declaration requirements

Values for the @class attribute must conform to the following syntax requirements:
  • An initial "-" or "+" character followed by one or more spaces, "-" for element types defined in structural vocabulary modules, "+" for element types defined in domain modules.
  • A sequence of one or more module/type pair tokens of the form "modulename/typename", with each pair of tokens separated by one or more spaces, where modulename is the short name of the vocabulary module and typename is the element type name. Tokens are ordered left to right from most general to most specialized.
  • At least one trailing space character (" "). The trailing space ensures that string matches on module/name pairs can always include a leading and trailing space in order to reliably match full tokens.

When the @class attribute is declared in a DTD or XSD, it must be declared with a default value. In order to support generalization round-tripping (generalizing specialized content into a generic form and then returning it to the specialized form) the default value must not be fixed. This allows a generalization process to overwrite the default values defined by a general document type with specialized values taken from the document being generalized.

When a vocabulary module declares new element types, it must provide a @class attribute for each element type that it declares. The @class attribute must include a mapping for every structural type or domain in the specialized type's ancestry, even those in which no element renaming occurred. The mapping must start with the value for the base type (for example topic or map), and finish with the current element type.

A vocabulary module must not change the @class attribute for elements that it does not specialize, but simply reuses by reference from more generic levels. For example, since task, bctask, and guitask use the <p> element without specializing it, they must not declare mappings for it.

The @class attribute should not be modified by authors.

Examples (non-normative)

The @class attribute for the task topic type's <step> element is:
<!ATTLIST step         class  CDATA "- topic/li task/step ">

This tells us that the <step> element is equivalent to the <li> element in a generic topic. It also tells us that <step> is equivalent to a <step> in a task topic, which we already knew, but it's worth noting this in the attribute because it enables round-trip migration between upper level and lower level types without loss of information.

While a given element's tagname is normally the same as the typename of the last token in the @class value, this is not required. Processors that perform generalization may transform elements from specialized types to less-specialized types, leaving the values of the @class attribute unchanged (thus preserving knowledge of the original most-specialized form). For example, if a user runs a generalizing transformation that maps all elements to their first @class value, but preserves their content and attribute values, then the user can follow it up with a "specialize" transformation that maps all elements to their last @class value (preserving content and attribute values), and provide a full round trip for all content between the two document types, using nothing but two generic transformations and the information in the @class attribute.

The @class attribute tells a processor what general classes of elements the current element belongs to. DITA scopes elements by module type (for example topic type, domain type, or map type) instead of document type, which lets document type developers combine multiple topic types in a single document without complicating transformation logic.

The sequence of values in the @class attribute is important because it tells processors which value is the most general and which is most specific. This is especially important for "specializing" transformations, where you can apply a general rule that says: if the element doesn't have a mapping to the target topic type, simply use the last value of the @class attribute (and assume that the specialized topic type is reusing some general element declarations, which only have mappings for the level at which they were declared).

Figure 1. Example of structural type element with @class attribute
<appstep class="- topic/li task/step bctask/appstep ">
  <cmd class="- topic/ph task/cmd ">A specialized step</cmd>
</appstep>
Figure 2. Example of domain element with @class attribute
<wintitle class="+ topic/keyword ui-d/wintitle ">A specialized keyword</wintitle>

While this example is trivial, more complicated hierarchies (say, five levels deep, with renaming occurring at levels two and four only) make explicit intermediate values essential.

The specialization hierarchy for a given element type must reflect any intermediate modules between the base type and the specialization type, as shown in this example:

Figure 3. Example of @class attribute with intermediate value
<windowname class="- topic/keyword task/keyword guitask/windowname ">

The intermediate values are necessary so that generalizing and specializing transformations can map values simply and accurately. For example, if task/keyword was missing as a value, and a user decided to generalize this guitask up to a task topic, then the transformation would have to guess whether to map to keyword (appropriate if task is more general than guitask, which it is) or leave it as windowname (appropriate if task were more specialized, which it isn't). By always providing mappings for more general values, processors can then apply the simple rule that missing mappings must by default be to more specialized values than the one we are generalizing to, which means the last value in the list is appropriate. For example, when generalizing <guitask> to <task>, if a <p> element has no target value for <task>, we can safely assume that <p> does not specialize from <task> and should not be generalized.

Parent topic: 2.1.4.3 Specialization
Previous topic: 2.1.4.3.2 Requirements for specialized element types and attributes
Next topic: 2.1.4.3.4 Domain usage declaration (the @domains attribute)


Domain usage declaration (the @domains attribute)

2.1.4.3.4 Domain usage declaration (the @domains attribute)

Structural types must declare the domain vocabulary modules and constraint modules they use. This is done with the @domains attribute, whose value is a sequence of parenthesized module ancestry specifications. The @domains attribute is declared on the root element for each topic or map type. Structural modules should declare their structural ancestry.

Each structural, element, and attribute domain defines its module ancestry as a parenthesized sequence of space-separated module names from root module to provided module.

For element domains, the group syntax is:
 '(', modulename, (' ', modulename)+, ')'
For attribute domains, the group syntax is:
 'a(', attname, (' ', attname)+, ')'
The module ancestry specifications are added to the effective value of the @domains attribute to form a set of specifications, one for each domain used by the topic or map type.
The @domains values for the different module types are as follows:
structural domains
The structural type ancestry. For example: (topic concept glossentry). When a structural domain depends on one or more element or attribute domains, the structural domain's @domains specification must include the domain dependencies following the name of the specialize structural domain, e.g. (topic reference cppApiRef cpp-d compilerTypeAtt-d), here reflecting a topic specialization that depends on two domains, "cpp-d" and "compilerTypeAtt-d".
non-normative: The specification of domain dependencies serves in part as a signal to document type shell authors that the domain module must always be integrated along with the structural module.
constraint modules
The structural type ancestry followed by the name of the constraint domain. For example: (topic task strictTaskbody-c).
element domains
The structural type ancestry and, if applicable, the domain module ancestry from which the domain is specialized. For example: (topic hi-d) (topic pr-d cpp-d).
attribute domains
The attribute specialization hierarchy. For example: a(props mySelectAttribute).

The @domains attribute allows processors to determine whether or not two elements use compatible domains. For example, when pasting content from one topic into another topic within an editor, the editor can use the @domains attribute to determine if the paste target topic's domains are compatible with the paste source topic's domains and therefore whether or not the pasted content needs to be generalized before it can be pasted. Likewise, processors can use the value of the @domains attribute to determine if they have whatever may be necessary to support a particular domain.

The effective value of the @domains attribute is constructed using integration mechanisms specific to each XML document constraint language. Each domain and constraint module must provide a @domains attribute value fragment that can be used by DITA document types to construct the effective @domains attribute value. Each structural vocabulary module should provide a @domains attribute value fragment. See Configuration (Document type shells).

Example: task with multiple domains

<task id="mytask" class="- topic/topic task/task "
    domains="(topic ui-d) (topic sw-d) (topic pr-d)">
...
</task>

In this example, the task allows the use of elements for describing user interfaces (ui-d), software (sw-d), and also programming (pr-d).

If the document used a specialization of the programming domain to describe C++ programming, the new domain would need a separate entry in the @domains attribute, e.g.:

<task id="mytask" class="- topic/topic task/task "
    domains="(topic ui-d) (topic sw-d) (topic pr-d) (topic pr-d cpp-d)">
...
</task>

Example: How editing tools and processors can use the @domains attribute

The @domains attribute enables processors to determine whether two elements use compatible domains. For example, when pasting content from one topic into another topic within an editor, the editor can use the @domains attribute to determine if the paste target topic's domains are compatible with the paste source topic's domains and therefore whether or not the pasted content needs to be generalized before it can be pasted. Likewise, processors can use the @domains value to determine if they have whatever may be necessary to support a particular domain.

Another example is when an element references an element that is a more specialized version of the element, for example. a <li> element of concept topic references a <step> element in a task topic. During processing, the <step> element will be generalized back to a <li> element.

Parent topic: 2.1.4.3 Specialization
Previous topic: 2.1.4.3.3 Element type specialization hierarchy declaration (the @class attribute)
Next topic: 2.1.4.3.5 Generalization


Generalization

2.1.4.3.5 Generalization

Specialized content can be generalized to any ancestor type. The generalization process can preserve information about the former level of specialization to allow round-tripping between specialized and unspecialized forms of the same content.

Among the purposes of generalization:
  • Migration of content (for example, when retiring an unsuccessful specialization),
  • Temporary round-tripping (for example, when moving content through a process that is not specialization aware and has only been enabled for instances of the base structural type),
  • Reuse of specialized content in an environment that does not support one or more of its specializations (which may be thought of as a special case of round-tripping).

When generalizing for migration, the @class attribute and @domains attribute should be absent from the generalized instance document so that the default values in the DITA document type shell will be used. When generalizing for round-tripping, the @class attribute and @domains attribute should retain the original specialized values in the generalized instance document.

All DITA documents contain a mix of markup from at least one structural type and zero or more domains. When generalizing the document, the generalizer may choose to leave a structural type or domain as-is, or may choose to generalize that type or domain to any of its ancestors.

The generalizer can supply the source and target modules for each generalization, for example, "generalize from reference to topic". The generalizer can specify multiple target modules, for example, "generalize from reference to topic and from ui-d to topic". When the source and target modules are not supplied, generalization is assumed to be from all structural types to the base (topic or map), and no generalization is performed for domains.

The generalizer can also supply the target DITA document type shell. When the target document type is not supplied, the generalized document will not contain a reference to a DITA document-type shell. With the exception of topic nesting constraints, it is possible to generate a document type shell based on the @class and @domains attributes in the specialized documents. If the@ domains attribute includes all structural, domain, and constraint modules used, the @domains attribute alone is sufficient to enable generation of a document type shell.

A generalization process should be able to handle cases where it is given:
  • Just source modules for generalization (in which case the designated source types are generalized to topic or map),
  • Just target modules for generalization (in which case all descendants of the target are generalized to that target), or
  • Both (in which case only the specified descendants of the target are generalized to that target).

For each structural type instance, the generalization process checks whether the structural type instance is a candidate for generalization, or whether it has domains that are candidates for generalization. It is important to be selective about which structural type instances to process; if the process simply generalizes every element based on its @class attribute values, an instruction to generalize "reference" to "topic" could leave an APIReference topic with an invalid content model, since any elements it reuses from "reference" would have been renamed to topic-level equivalents.

The @class attribute for the root element of the structural type is checked before generalizing structural types:
 | Source module unspecified | Source module specified
Target module unspecified | Generalize this structural type to its base ancestor | Check whether the root element of the topic type matches a specified source module; generalize to its base ancestor if it does, otherwise ignore the structural type instance unless it has domains to generalize.
Target module specified | Check whether the @class attribute contains the target module. If it does contain the target, rename the element to the value associated with the target module. Otherwise, ignore the element. | It is an error if the root element matches a specified source but its @class attribute does not contain the target. If the root element matches a specified source module and its @class attribute does contain the target module, generalize to the target module. Otherwise, ignore the structural type instance unless it has domains to generalize.
The @domains attribute for the root element of the structural type is checked before generalizing domains:
 | Source module unspecified | Source module specified
Target module unspecified | Do not generalize domain specializations in this structural type. | Check whether the @domains attribute lists the specified domain; proceed with generalization if it does, otherwise ignore the structural type instance unless it is itself a candidate for generalization.
Target module specified | Check whether the @domains attribute contains the target module. If it does, generalize to the target module. Otherwise, skip the structural type instance unless it is itself a candidate for generalization. | It is an error if the @domains attribute matches a specified source but the domain value string does not contain the target. If the @domains attribute matches a specified source module and the domain value string does contain the target module, generalize to the target module. Otherwise, ignore the structural type instance unless it is itself a candidate for generalization.
For each element in a candidate structural type instance:
 | Source module unspecified | Source module specified
Target module unspecified | If the @class attribute starts with "-" (part of a structural type), rename the element to its base ancestor equivalent. Otherwise ignore it. | Check whether the last value of the @class attribute matches a specified source; generalize to its base ancestor if it does, otherwise ignore the element.
Target module specified | Check whether the @class attribute contains the target module; rename the element to the value associated with the target module if it does contain the target, otherwise ignore the element. | It is an error if the last value in the @class attribute matches a specified source but the previous values do not include the target. If the last value in the @class attribute matches a specified source module and the previous values do include the target module, rename the element to the value associated with the target module. Otherwise, ignore the element.
When renaming elements during round-trip generalization, the generalization process should preserve the values of all attributes. When renaming elements during one-way or migration generalization, the process should preserve the values of all attributes except the @class and @domains attribute, both of which should be supplied by the target document type.
Parent topic: 2.1.4.3 Specialization
Previous topic: 2.1.4.3.4 Domain usage declaration (the @domains attribute)
Next topic: 2.1.4.3.6 Attribute generalization


Attribute generalization

2.1.4.3.6 Attribute generalization

There is a particular syntax to generalize attributes that have been specialized from the @props or @base attribute. Specialization-aware processors should be able to recognize and process both the specialized and generalized forms of an attribute as being equivalent in their values.

When a specialized attribute is generalized to an ancestor attribute, the value of the ancestor attribute consists of the name of the specialized attribute followed by its specialized value in parentheses. For example, given that "jobrole" is an attribute specialized from "person", which in turn is specialized from "props":

  • jobrole="programmer" can be generalized to person="jobrole(programmer)" or to props="jobrole(programmer)"
  • props="jobrole(programmer)" can be respecialized to person="jobrole(programmer)" or to jobrole="programmer"

In this example, generalization and respecialization can use the @domains attribute to determine the ancestry of the specialized @jobrole attribute, and therefore the validity of the specialized @person attribute as an intermediate target for generalization.

If more than one attribute is generalized, the value of each is separately represented in this way in the value of the ancestor attribute.

Generalized attributes are typically not expected to be authored or edited directly, but are used by generalizing processors to preserve the values of the specialized attributes during the time or in the circumstances in which the document is in a generalized form.

A single element may not contain both generalized and specialized values for the same attribute. For example, this element:
<p person="jobrole(programmer)" jobrole="admin">...</p>
provides two values for the @jobrole attribute, but one is in a generalized syntax and the other in a specialized syntax. This is an error condition, since it means the document has been only partially generalized, or has been generalized and then edited using a specialized document type.
Parent topic: 2.1.4.3 Specialization
Previous topic: 2.1.4.3.5 Generalization
Next topic: 2.1.4.3.7 Specializing foreign or unknown content


Specializing foreign or unknown content

2.1.4.3.7 Specializing foreign or unknown content

Specializing the <foreign> or <unknown> element is an open extension to DITA for the purpose of incorporating standard vocabularies for non-textual content, such as MathML and SVG, as in-line objects. These elements should not be used to include textual content or metadata in DITA documents except where such content acts as an example or display, rather than as the primary content of a topic.

Incorporating foreign or unknown content

There are three methods of incorporating foreign content into DITA.

  • A domain specialization of the <foreign> or <unknown> element. This is the usual implementation.
  • A structural specialization using the <foreign> or <unknown> element. This affords more control over the content.
  • Do nothing: simply embed the foreign content within <foreign> or <unknown>.

Foreign or unknown content and the architectural @class attribute

Foreign content that is incorporated in DITA by one of these methods is not specialized. Specialization depends upon the architectural @class attribute found in every DITA element. If the foreign content has interoperability or vocabulary naming issues such as those that are addressed by specialization in DITA, they must be addressed by means that are appropriate to the foreign content.

Example of specializing foreign or unknown content using DTDs

The sample below describes how to create a domain declaration of the svg element, but does not show how to integrate that declaration in a DITA document-type shell. For more specific information on creating document-type shells, see DTD syntax specialization module coding requirements.

<!-- declaration for the specialized wrapper -->
<!ENTITY % svg "svg">

<!-- included SVG document type -->
<!ENTITY % SVG.prefix "svg" >
<!ENTITY % svg-qname.mod
    PUBLIC "-//W3C//ENTITIES SVG 1.1 Qualified Name//EN"
           "svg-qname.mod"
>%svg-qname.mod;

<!-- definition for the specialized wrapper  -->
<!ENTITY % svg.content "
     (%SVG.svg.qname;)
">
<!ATTLIST % svg.attributes "
">
<!ELEMENT svg %svg.content; >
<!ATTLIST svg %svg.attributes; >

<!ATTLIST svg %global-atts; class CDATA "+ topic/foreign svg-d/svg ">
Note: The example assumes that parameter entity SVG.svg.qname is declared in the SVG DTD or schema.

Example of SVG within a <p> element

<p>This is an ellipse:
  <svg>
    <svg:svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<ellipse cx="300" cy="150" rx="200" ry="80"
style="fill:rgb(200,100,50);
stroke:rgb(0,0,100);stroke-width:2"/>

    </svg:svg>
  </svg>.
</p>

Example of specializing foreign content using XML Schemas

The sample below describes how to create a domain declaration of the mathML element, but does not show how to integrate that declaration in a DITA document-type shell. For more specific information on creating document-type shells, see XSD schema specialization module coding requirements

<!-- importing MathML document type -->
<xs:import namespace="http://www.w3.org/1998/Math/MathML" schemaLocation="mathml2.xsd">

<!-- definition for the specialized wrapper  -->
<xs:element name="mathML" type="mathML.class" />
<xs:complexType name="mathML.class">
  <xs:choice>
      <xs:element ref="mml:math" />
  </xs:choice>
  <xs:attribute name="outputclass" type="xs:string"/>
    <xs:attributeGroup ref="univ-atts"/>
    <xs:attributeGroup ref="global-atts"/>
    <xs:attribute ref="class" default="+ topic/foreign mathML/mathML"/>
</xs:complexType>

<!-- definition for each element extended by the domain  -->
<xs:group name="ma-d-foreign">
  <xs:choice>
     <xs:element ref="mathML" />
  </xs:choice>
</xs:group>

<!-- definition for the named model groups  -->
<xs:group name="foreign">
   <xs:choice>
     <xs:group ref="foreign"/>
     <xs:group ref="ma-d-foreign"/>
   </xs:choice>
</xs:group>

Example of MathML within an <object> element

<p>... as in the formula
<object>
  <desc>4 + x</desc>
  <mathML>
    <mml:math display="block">
      <mml:mrow>
        <mml:mo>&sum;</mml:mo>
        <mml:mn>4</mml:mn>
        <mml:mo>+</mml:mo>
        <mml:mi>x</mml:mi>
      </mml:mrow>
    </mml:math>
  </mathML>
 <object>.
</p>
Parent topic: 2.1.4.3 Specialization
Previous topic: 2.1.4.3.6 Attribute generalization
Next topic: 2.1.4.3.8 Specialization module coding requirements


Specialization module coding requirements

2.1.4.3.8 Specialization module coding requirements

The base DITA element and attribute types may be extended through the creation of new vocabulary modules that define specializations of more-general types.

  • 2.1.4.3.8.1 DTD syntax specialization module coding requirements
    To be extensible and backward compatible, DITA requires that a DTD implementation of structural and domain specialization modules conform to well-defined implementation (coding) requirements.
  • 2.1.4.3.8.2 XSD schema specialization module coding requirements
    To be extensible and backward compatible, DITA requires that an XSD implementation of structural and domain specialization modules conform to well-defined implementation (coding) requirements.
Parent topic: 2.1.4.3 Specialization
Previous topic: 2.1.4.3.7 Specializing foreign or unknown content
Next topic: 2.1.4.3.8.1 DTD syntax specialization module coding requirements


DTD syntax specialization module coding requirements

2.1.4.3.8.1 DTD syntax specialization module coding requirements

To be extensible and backward compatible, DITA requires that a DTD implementation of structural and domain specialization modules conform to well-defined implementation (coding) requirements.

These coding requirements implement the specialization architecture with the capabilities and within the limitations of the DTD grammar. They are the coding requirements for structural specializations, element domain specializations, and attribute domain specializations.

  • 2.1.4.3.8.1.1 General element type declaration coding requirements
    Structural and element domain vocabulary modules must reflect the same coding requirements for element type declarations.
  • 2.1.4.3.8.1.2 Structural module coding requirements
    A structural vocabulary module defines a new topic or map type as a specialization of a base topic or map type. The purpose is usually to enhance the user's interaction by adapting the topic or map type to its particular purposes.
  • 2.1.4.3.8.1.3 Topic type module coding requirements
    Topic type vocabulary modules must conform to additional coding requirements for defining default topic nesting.
  • 2.1.4.3.8.1.4 Element domain module coding requirements
    An element domain vocabulary module defines element types that are appropriate for the subject-matter or application domain for which they are designed. The purpose is usually to enhance the user's interaction by providing "semantic" elements whose names more accurately denote their content, making that content easier to search and retrieve.
  • 2.1.4.3.8.1.5 Attribute domain module coding requirements
    An attribute domain vocabulary module declares a new attribute specialized from either the @props or @base attribute. An attribute domain module defines exactly one new attribute type.
Parent topic: 2.1.4.3.8 Specialization module coding requirements
Previous topic: 2.1.4.3.8 Specialization module coding requirements
Next topic: 2.1.4.3.8.1.1 General element type declaration coding requirements


General element type declaration coding requirements

2.1.4.3.8.1.1 General element type declaration coding requirements

Structural and element domain vocabulary modules must reflect the same coding requirements for element type declarations.

Module names

Each vocabulary module has a short name that is used to construct file names, entity names, and other names used in associated declarations. Modules may also have abbreviated names that further shorten the short name, for example "sw" for the "software" domain, where "software" is the short name and "sw" is the abbreviated name.

For structural modules, the module name must be the element type name of the top-level topic or map type defined by the module, such as "concept", "bookmap".

For element domain modules, the module name must be a name that reflects the subject domain to which the domain applies, such as "highlight", "software". Domain module names should be sufficiently unique that they are unlikely to conflict with any other domains.

Module files

A structural or element domain vocabulary module must have two files:

  • A module entity declaration file, which declares the entities used to integrate the module into a shell DTD.

    For structural modules, the file name is the module name plus the ent extension, e.g. concept.ent.

    For domain modules, the file name is the domain name plus Domain plus the ent extension, e.g. highlightDomain.ent, newAttDomain.ent.

  • A definition module, which contains the element type and/or attribute list declarations for the module.

    For structural modules, the file name is the module name plus the mod extension, e.g., concept.mod

    For domain modules, the file name is the domain name plus "Domain" and the mod extension, e.g., highlightDomain.mod, newAttDomain.mod.

Domain declaration entity

The domain declaration entity must conform to the following implementation pattern:

The declaration file must define an entity that associates the domain with a module. The name of the entity is the structure type name or domain abbreviation plus the -att suffix, e.g. "concept-att", "hi-d-att".

The value of the entity must list the dependencies of the domain module in order of dependency from left to right within enclosing parentheses, starting with the topic module. Domain abbreviations are used in the list, and the defining domain is the last item in the list. The following example declares the dependency of the highlight domain on the base topic module.

<!ENTITY hi-d-att "(topic hi-d)">

The domain declaration entity is used to construct the effective value of the domains attribute for a map or topic type as configured in a shell DTD.

Element definitions

A structural or domain vocabulary module must contain a declaration for each specialized element type named by the module. While the XML standard allows content models to refer to undeclared element types, all element types named in content models or attribute list declarations within a vocabulary module must have an ELEMENT declaration, in one of:
  • The vocabulary module
  • A base module of which the vocabulary module is a direct or indirect specialization
  • A required domain module (if the vocabulary module is a structural module).

The specialized elements must follow the rules of the architecture in defining content models and attributes.

For each element type declared in the vocabulary module there must be an element name parameter entity whose default value is the name of the element, e.g.:
<!ENTITY % conbody "conbody">

The element name entity provides a layer of abstraction that facilitates redefinition. A document type shell can predefine an element entity to add domain-specialized elements or replace a base element type with one or more specializations of that type. Because declarations use the entity rather than the element type name to include the element in a content model, the redefinition given in a shell is propagated to every context in which the base element occurs.

The element name parameter entities must be grouped together at the top of the vocabulary module before any other declarations to ensure they are declared before any use in content models declared in the same module. The declarations may occur in any order. By convention, they are usually ordered alphabetically or grouped logically.

For each element type, the content model and attribute list declarations should start with a descriptive comment. For example:
<!--                    LONG NAME: Topic Head                      -->
Each element type must have a corresponding content model parameter entity named %tagname.content. The value of the entity must be the complete content model definition. For example:
<!ENTITY % topichead.content
  "((%topicmeta;)?,
    (%anchor; |
     %data.elements.incl; |
     %navref; |
     %topicref;)*)
">

The content model parameter entity may be overridden in shell DTDs or constraint modules to further constrain the content model for the element type.

Each element type must have a corresponding attribute list parameter entity named %tagname.attributes. The parameter entity must declare all attributes used by the element type (except for the attributes provided by the %global-atts; parameter entity, which is always referenced as part of the attribute list declaration for an element's class attribute). For example:
<!ENTITY % topichead.attributes
 "navtitle
     CDATA
          #IMPLIED
   outputclass
     CDATA
          #IMPLIED
   keys
     CDATA
          #IMPLIED
   %topicref-atts;
   %univ-atts;"
>
The ELEMENT declaration for each element type must consist entirely of a reference to the corresponding content model parameter entity:
<!ELEMENT topichead    %topichead.content;>
The ATTLIST declaration for each element type must consist entirely of a reference to the corresponding attribute list parameter entity:
<!ATTLIST topichead    %topichead.attributes;>
The content model parameter entity, attribute list parameter entity, ELEMENT declaration, and ATTLIST declaration should be grouped together within the module. Each such group of declarations may occur in any order within the module. For example:
<!--                    LONG NAME: Topic Head                      -->
<!ENTITY % topichead.content
  "((%topicmeta;)?,
    (%anchor; |
     %data.elements.incl; |
     %navref; |
     %topicref;)* )
">
<!ENTITY % topichead.attributes
  "navtitle
      CDATA
          #IMPLIED
   outputclass
      CDATA
           #IMPLIED
   keys
      CDATA
          #IMPLIED
   %topicref-atts;
   %univ-atts;"
>
<!ELEMENT topichead    %topichead.content;>
<!ATTLIST topichead    %topichead.attributes;>

Attributes

The attributes of an element type must restrict or conserve those of the element type it specializes. Specialized element types may not add new attributes. New global attributes may be defined via attribute domain modules. Structural modules may require the use of attribute domain modules.

A vocabulary module must define a @class attribute for every specialized element declared in the module. The @class attribute must include the value of the @class attribute of the base element, and append to it the element name qualified by the topic element name with at least one leading and trailing space. The @class attribute for an element introduced by a structural specialization must start with a minus sign ("-"). The @class attribute for a domain specialization must start with a plus sign ("+"). The initial minus or plus sign must be followed by one or more spaces. The attribute value must end with one or more trailing spaces.

The ATTLIST declaration for the @class attribute must also include a reference to the %global-atts parameter entity.

For example, the ATTLIST definition for the <conbody> element (a specialization of the <body> element in the <topic> base type) includes global attributes with an entity, then the definition of the @class attribute, as follows:

<!ATTLIST conbody     %global-atts;  class CDATA "- topic/body  concept/conbody ">

The @class attribute declarations for a module must be grouped together at the end of the module after any other declarations. The declarations may occur in any order. By convention they are often ordered alphabetically or grouped logically.

See Element type specialization hierarchy declaration (the @class attribute) for complete details on the @class attribute.

Parent topic: 2.1.4.3.8.1 DTD syntax specialization module coding requirements
Previous topic: 2.1.4.3.8.1 DTD syntax specialization module coding requirements
Next topic: 2.1.4.3.8.1.2 Structural module coding requirements


Structural module coding requirements

2.1.4.3.8.1.2 Structural module coding requirements

A structural vocabulary module defines a new topic or map type as a specialization of a base topic or map type. The purpose is usually to enhance the user's interaction by adapting the topic or map type to its particular purposes.

A structural type module must conform to the following coding requirements in addition to the general module coding requirements:

Default included domains entity

The module must define the included-domains entity with a default value, as in the following example:
<!ENTITY included-domains "">

A document type shell can predefine the included-domains entity to list domains to be added to the document type.

Structural vocabulary modules may require the use of specific domains. In that case, the default value of the included-domains entity must include the appropriate domain use declaration, for example:
<!ENTITY included-domains "(topic myDomain)">

The list of included domains must declare the domains from most generic (on the left) to most specialized, current domain (on the right). See Domain usage declaration (the @domains attribute).

Topic and map element attributes

The topic or map element type must set the @DITAArchVersion attribute to the DITAArchVersion entity and the @domains attribute to the included-domains entity. These attributes give processors a reliable way to check the architecture version and look up the list of domains available in the document type.

<!ATTLIST concept
  %concept.attributes;
  %arch-atts;
  domains
    CDATA
       "&included-domains;"
>
Parent topic: 2.1.4.3.8.1 DTD syntax specialization module coding requirements
Previous topic: 2.1.4.3.8.1.1 General element type declaration coding requirements
Next topic: 2.1.4.3.8.1.3 Topic type module coding requirements


Topic type module coding requirements

2.1.4.3.8.1.3 Topic type module coding requirements

Topic type vocabulary modules must conform to additional coding requirements for defining default topic nesting.

Default nested topics entity

A topic type module must define an entity to specify default subordinate topics. The entity name must be the topic element name plus the -info-types suffix. For example, the info-types entity for the concept topic is concept-info-types. If the topic has default subordinate topics, this entity can default to a list of element entities. If not, the entity can default to the value of the info-types entity as in the following example:

<!ENTITY % concept-info-types "%info-types;">

A document type shell can then control how topics are allowed to nest by redefining the topictype-info-types entity for each topic type, or it can efficiently create common nesting rules by redefining the main info-types entity.

In the declaration of the root element of a topic type, the last position in the content model must be the topictype-info-types nested topics entity, as in the following example:

<!ENTITY % concept.content
  "((%title;),
    (%titlealts;)?,
    (%abstract; |
     %shortdesc;)?,
    (%prolog;)?,
    (%conbody;)?,
    (%related-links;)?,
    (%concept-info-types;)*)"
>
Parent topic: 2.1.4.3.8.1 DTD syntax specialization module coding requirements
Previous topic: 2.1.4.3.8.1.2 Structural module coding requirements
Next topic: 2.1.4.3.8.1.4 Element domain module coding requirements


Element domain module coding requirements

2.1.4.3.8.1.4 Element domain module coding requirements

An element domain vocabulary module defines element types that are appropriate for the subject-matter or application domain for which they are designed. The purpose is usually to enhance the user's interaction by providing "semantic" elements whose names more accurately denote their content, making that content easier to search and retrieve.

Domain entity file

In addition to the domain declaration entity, the entity declaration file for element domain modules must include the following components:

Element extension entity

The declaration (.ent) file must define an entity for each element extended by the domain. The base of the entity name is the abbreviation for the domain and the extension of the entity name is the name of the extended element. For example, the highlight domain (abbreviated as hi-d) extends the ph element, so the entity for the extended element is named hi-d-ph.

The value of the entity is a disjunctive list of the specialized elements that are intended to occur in the same locations as the extended element.

For example, the hi-d-ph entity is defined as follows:

<!ENTITY % hi-d-ph "b | u | i | tt | sup | sub">
Parent topic: 2.1.4.3.8.1 DTD syntax specialization module coding requirements
Previous topic: 2.1.4.3.8.1.3 Topic type module coding requirements
Next topic: 2.1.4.3.8.1.5 Attribute domain module coding requirements


Attribute domain module coding requirements

2.1.4.3.8.1.5 Attribute domain module coding requirements

An attribute domain vocabulary module declares a new attribute specialized from either the @props or @base attribute. An attribute domain module defines exactly one new attribute type.

An attribute domain's name is the name of the attribute plus "Att" to distinguish the domain attribute from any element domains with the same name. For example, for an attribute named "new" the attribute domain name would be "newAtt". The attribute domain name is used to construct filenames and entity names for the domain.

An attribute domain must consist of one file, whose name consists of the module name plus Domain plus the ent extension. For example: newAttDomain.ent for an attribute named "new".

The file must have two parts:
Attribute extension entity

The attribute declaration is in an entity. This entity can then be used in document type shells to add the new attribute. The attribute declaration entity name consists of the attribute name plus "-d-attribute". For example:

<!ENTITY % newAtt-d-attribute "new   CDATA #IMPLIED">

For an attribute named "new".

Domain declaration entity

The attribute domain is declared in @domains attribute values through a general text entity that contains the attribute domain's domain declaration fragment. The entity name consists of the module name plus "-d-att". For example, "newAtt-d-att" for an attribute named "new". See Domain usage declaration (the @domains attribute) for details on attribute domain @domains values.

For example:

<!ENTITY newAtt-d-att       "a(props new)"  >

Attribute domains do not have domain module declaration (.mod) files.

Parent topic: 2.1.4.3.8.1 DTD syntax specialization module coding requirements
Previous topic: 2.1.4.3.8.1.4 Element domain module coding requirements
Next topic: 2.1.4.3.8.2 XSD schema specialization module coding requirements


XSD schema specialization module coding requirements

2.1.4.3.8.2 XSD schema specialization module coding requirements

To be extensible and backward compatible, DITA requires that an XSD implementation of structural and domain specialization modules conform to well-defined implementation (coding) requirements.

These design patterns implement the specialization architecture with the capabilities and within the limitations of the XML Schema grammar. They are the coding requirements for structural specializations, domain specializations, and attribute domain specializations.

  • 2.1.4.3.8.2.1 General element type declaration coding requirements
    Structural and element domain vocabulary modules must reflect the same coding requirements for element type declarations.
  • 2.1.4.3.8.2.2 Structural specialization coding requirements
    An XSD structural module declares a top-level map or topic type, implemented as a pair of XSD documents, one that defines groups used to integrate and override the type and one that defines the element types specific to the type.
  • 2.1.4.3.8.2.3 Attribute domain coding requirements
Parent topic: 2.1.4.3.8 Specialization module coding requirements
Previous topic: 2.1.4.3.8.1.5 Attribute domain module coding requirements
Next topic: 2.1.4.3.8.2.1 General element type declaration coding requirements


General element type declaration coding requirements

2.1.4.3.8.2.1 General element type declaration coding requirements

Structural and element domain vocabulary modules must reflect the same coding requirements for element type declarations.

Module names

Each vocabulary module has a short name that is used to construct file names, entity names, and other names used in associated declarations.

For structural modules, the module name must be the element type name of the top-level topic or map type defined by the module, such as "concept", "bookmap".

For element domain modules, the module name must be a name that reflects the subject domain to which the domain applies, such as "highlight", "software". Domain module names should be sufficiently unique that they are unlikely to conflict with any other domains.

For attribute domain modules, the module name must be the name of the attribute defined by the module plus "Att" (to avoid conflict with similarly-named structural types or element domains).

Element definitions

A structural or domain vocabulary module must contain a declaration for each specialized element type named by the module. While the XSD standard allows content models to refer to undeclared element types, all element types named in content models within a vocabulary module must have an xs:element declaration, either in the vocabulary module, in a base module of which the vocabulary module is a direct or indirect specialization, or, for structural modules, in a required domain module. The specialized elements must follow the rules of the architecture in defining content models and attributes.

Domain modules must consist of a single XSD document named modulenameMod.xsd. Structural modules must consist of two modules, modulenameGrp.xsd, which contains all element name groups, and modulenameMod.xsd, which contains all other declarations for the module.

For each element type declared in the vocabulary module there must be an xs:group whose name is the element type name and whose one member is a reference to the element type, e.g.:
<xs:group name="codeph">
  <xs:sequence>
    <xs:choice>
      <xs:element ref="codeph"/>
    </xs:choice>
  </xs:sequence>
</xs:group>

The element name group provides a layer of abstraction that facilitates redefinition. A document type shell can redefine an element group to add domain-specialized elements or replace a base element type with one or more specializations of that type.

For domain modules, the group definitions should be grouped together at the start of the domain's XSD document. The definitions may occur in any order.

Each element type must have a corresponding content model group named tagname.content. The value of the group must be the complete content model definition. For example:
<xs:group name="codeph.content">
  <xs:sequence>
    <xs:choice minOccurs="0" maxOccurs="unbounded">
      <xs:group ref="basic.ph.notm" minOccurs="0"/>
      <xs:group ref="data.elements.incl" minOccurs="0"/>
      <xs:group ref="foreign.unknown.incl" minOccurs="0"/>
    </xs:choice>
  </xs:sequence>
</xs:group>

The content model group may be overridden in constraint modules to further constrain the content model for the element type.

Each element type must have a corresponding attribute group named tagname.attributes. The group must declare all attributes used by the element type except for the @class attribute. For example:
<xs:attributeGroup name="codeph.attributes">
  <xs:attribute name="outputclass" type="xs:string"/>
  <xs:attributeGroup ref="global-atts"/>
  <xs:attributeGroup ref="univ-atts"/>
</xs:attributeGroup>
Each element type must have a complex type definition named tagname.class, which references the tagname.content and tagname.attributes groups. For example:
<xs:complexType name="codeph.class" mixed="true">
  <xs:sequence>
    <xs:group ref="codeph.content"/>
  </xs:sequence>
  <xs:attributeGroup ref="codeph.attributes"/>
</xs:complexType>
Each element type must have an xs:element declaration named tagname, that uses as its type the tagname.class complex type and extends that complex type to add the class attribute for the element. For example:
<xs:element name="codeph">
  <xs:annotation>
    <xs:documentation>
      The code phrase (&lt;<keyword>codeph</keyword>&gt;) element represents a snippet
      of code within the main flow of text. The code phrase may be displayed in
      a monospaced font for emphasis. This element is part of the DITA programming
      domain, a special set of DITA elements designed to document programming tasks,
      concepts and reference information.
    </xs:documentation>
  </xs:annotation>
  <xs:complexType mixed="true">
    <xs:complexContent>
      <xs:extension base="codeph.class">
        <xs:attribute ref="class" default="+ topic/ph pr-d/codeph "/>
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
</xs:element>
The content model group, attribute group, complex type, and element type definition for an element should be grouped together within the module. Each such group of declarations may occur in any order within the module. It is recommended to sort the element type definitions alphabetically or group them into categories. Here is an example declaration for the <codeblock> element:
  <xs:element name="codeblock">
    <xs:annotation>
      <xs:documentation>
        The &lt;<keyword>codeblock</keyword>&gt; element represents lines of
        program code. Like the <ph>
          <xref href="xref.xml">&lt;<keyword>pre</keyword>&gt;</xref>
        </ph> element,
        content of this element has preserved line endings and is output in a monospaced
        font. This element is part of the DITA programming domain, a special set of
        DITA elements designed to document programming tasks, concepts and reference
        information.
      </xs:documentation>
    </xs:annotation>
    <xs:complexType mixed="true">
      <xs:complexContent>
        <xs:extension base="codeblock.class">
          <xs:attribute ref="class" default="+ topic/pre pr-d/codeblock "/>
        </xs:extension>
      </xs:complexContent>
    </xs:complexType>
  </xs:element>

  <xs:complexType name="codeblock.class" mixed="true">
        <xs:sequence>
          <xs:group ref="codeblock.content"/>
        </xs:sequence>
        <xs:attributeGroup ref="codeblock.attributes"/>
  </xs:complexType>

  <xs:group name="codeblock.content">
    <xs:sequence>
      <xs:choice minOccurs="0" maxOccurs="unbounded">
          <xs:group ref="basic.ph.notm" minOccurs="0"/>
          <xs:group ref="coderef" minOccurs="0"/>
          <xs:group ref="txt.incl" minOccurs="0"/>
          <xs:group ref="data.elements.incl" minOccurs="0"/>
          <xs:group ref="foreign.unknown.incl" minOccurs="0"/>
        </xs:choice>
    </xs:sequence>
  </xs:group>

  <xs:attributeGroup name="codeblock.attributes">
    <xs:attribute name="outputclass" type="xs:string"/>
        <xs:attribute name="spectitle" type="xs:string"/>
        <xs:attributeGroup ref="display-atts"/>
        <xs:attributeGroup ref="univ-atts"/>
        <xs:attribute ref="xml:space" fixed="preserve"/>
        <xs:attributeGroup ref="global-atts"/>
  </xs:attributeGroup>

Each xs:element declaration should include descriptive documentation as in the examples above.

Parent topic: 2.1.4.3.8.2 XSD schema specialization module coding requirements
Previous topic: 2.1.4.3.8.2 XSD schema specialization module coding requirements
Next topic: 2.1.4.3.8.2.2 Structural specialization coding requirements


Structural specialization coding requirements

2.1.4.3.8.2.2 Structural specialization coding requirements

An XSD structural module declares a top-level map or topic type, implemented as a pair of XSD documents, one that defines groups used to integrate and override the type and one that defines the element types specific to the type.

A structural type module must conform to the following coding requirements in addition to the general module coding requirements:

Module files

A structural vocabulary module must have two files:

  • A module schema document. The file name is the name of the root structural element plus Mod plus the .xsd extension. For example, conceptMod.xsd is the module schema document for the concept topic type.
  • A module group definition schema document. The file name is the name of the root structural element plus Grp plus the .xsd extension. For example, conceptGrp.xsd is the module group definition schema document for the concept topic type.

Structural module schema document

The root element must reference the @DITAArchVersion attribute and the @domains attribute. These attributes give processors a reliable way to check the architecture version and look up the list of domains available in the document type. The @DITAArchVersion attribute is referenced as in the following example:

<xs:attribute name="id" type="xs:ID" use="required"/>
<xs:attribute ref="ditaarch:DITAArchVersion" />

See XSD document-type shell: Coding requirements for information on how to set the values for the domains attibute for XSD shells.

For topic modules, the last position in the content model must be the topictype-info-types nested topics group as in the following example of the root element of the concept topic:

<xs:complexType name="concept.class">
  <xs:sequence>
    <xs:group ref="title"/>
    <xs:group ref="titlealts" minOccurs="0"/>
    <xs:choice minOccurs="0">
      <xs:group ref="shortdesc" />
      <xs:group ref="abstract" />
    </xs:choice>
    <xs:group ref="prolog" minOccurs="0"/>
    <xs:group ref="conbody" minOccurs="0"/>
    <xs:group ref="related-links" minOccurs="0"/>
    <xs:group ref="concept-info-types" minOccurs="0" maxOccurs="unbounded"/>
  </xs:sequence>
  ...
</xs:complexType>

Topic module schema document

For topic modules, the module schema document must define an info-type model group. The name of this group is the topic element name plus -info-types. Thus, the info-type model group for the concept topic type is concept-info-types. The following example shows how this group is defined in conceptMod.xsd:
<xs:group name="concept-info-types">
  <xs:choice>
    <xs:group ref="concept" minOccurs="0"/>
    <xs:group ref="info-types" minOccurs="0"/>
  </xs:choice>
</xs:group>
Parent topic: 2.1.4.3.8.2 XSD schema specialization module coding requirements
Previous topic: 2.1.4.3.8.2.1 General element type declaration coding requirements
Next topic: 2.1.4.3.8.2.3 Attribute domain coding requirements


Attribute domain coding requirements

2.1.4.3.8.2.3 Attribute domain coding requirements

An attribute domain must consist of one file, whose name consists of the module name plus Domain plus the xsd extension. For example: newAttDomain.xsd for an attribute named "new". The file must have a single attribute group definition that contains the definition of the attribute itself, where the attribute group is named attnameAtt-d-attribute.

For example, for an attribute named "new":
<xs:attributeGroup name="newAtt-d-attribute">
  <xs:attribute name="new" type="xs:string"/>
</xs:attributeGroup>

The attribute domain must be reflected in a shell document type XSD that integrates it. See Domain usage declaration (the @domains attribute) for details of attribute domain @domains values.

For example, if the attribute named "new" is a specialization of the @props attribute, the @domains value would be "a(props new)".

Parent topic: 2.1.4.3.8.2 XSD schema specialization module coding requirements
Previous topic: 2.1.4.3.8.2.2 Structural specialization coding requirements
Next topic: 2.1.4.4 Constraints


Constraints

2.1.4.4 Constraints

Constraint modules define additional constraints for corresponding vocabulary modules in order to restrict content models or attribute lists for specific element types, remove extension elements from an integrated domain module, or replace base element types with domain-provided extension element types. Constraint modules do not and cannot change element semantics, only the details of how element types can be used in the context of a specific concrete document type. Because constraints can make optional elements required, documents that use the same vocabulary modules may still have incompatible constraints. Thus the use of constraints can affect the ability for content from one topic or map to be used directly in another topic or map.

Each constraint integrated into a DITA document type must be declared in the @domains attribute for each structural type integrated into the document type.

A constraint module may define any of the following types of constraint:

Restriction of content model or attributes for an element
Constraint modules may modify base content models by removing optional elements, making optional elements required, or requiring unordered elements to occur is a specific sequence. Constraint modules cannot make required elements optional or change the order of element occurrence for ordered elements.

For example, a constraint for <topic> could require <shortdesc>, could remove <abstract> altogether, and could require that the first child of <body> be <p>. A constraint cannot allow <shortdesc> to follow <prolog>, because the base content model for <topic> declares <shortdec> to precede <prolog>.

Restriction of extension elements from a domain
Constraint modules for element domains may define a subset of the base set of extension elements provided by the element domain.

For example, a constraint on the programming domain could reduce the list of included extension elements to <codeph> and <codeblock>.

Replacement of base elements by domain extensions
Constraint modules may replace base element types with domain-provided extension elements.

For example, a constraint module could replace the <ph> element with the domain-provided elements, making <ph> unavailable.

In a shell document type, when integrating a domain, the base domain element may be omitted from the domain extension group or parameter entity. While there is no separate content model constraint declaration in this case (because the content model is configured directly in the shell document type) the constraint should be declared in the @domains attribute and therefore there must be a domains module file that provides the constraint's contribution to the @domains attribute.

There may be at most one constraint module that defines the content model for a given element type included in a given concrete document type. This means that constraints for the same element type defined in two different constraint modules cannot be aggregated together. In that case, a new constraint module must be created that reflects the aggregation of the two original constraints.

Constraint rules

Constraint modules must conform to the following requirements:

  • Designers must implement constrained content models for element types that are more restrictive than the unconstrained content models for the same element types.

  • The content model and attributes of one element type can be constrained only by one constraint module included in a document type shell.

  • The list of extension element types provided by a domain module can be constrained only by one constraint module included in a document type shell.

  • Each constraint module may constrain element types from only one vocabulary module. This rule maintains granularity of reuse at the module level.

  • Constraint modules that restrict different element types within the same vocabulary module can be combined with one another or with a constraint module that selects a subset of the extension element types for the vocabulary. Such combinations of constraints on a single vocabulary module have no meaningful order or precedence.

  • Designers have the option to declare a constraint module or combination of constraint modules to be more restrictive than another constraint module or combination of constraint modules on the same vocabulary module or a base vocabulary module. This option is particularly useful when a designer wants to constrain base and specialized element types in a consistent way. The advantage of declaring the consistency is that processors can take advantage of the consistency when converting document instances.

    For example, a constraint module for <topic> that requires both <shortdesc> and <body> is more restrictive than a similar constraint module that only requires <body>. By declaring this relationship, a designer may indicate that documents which use the first constraint also comply with the looser constraint.

Content processing

A document type with constraints allows a subset of the possible instances of a document type for the same vocabularies without constraints. To put it another way, all instances of the constrained document type are guaranteed to be valid instances of the unconstrained document type.

As a result, a constraint does not and cannot change basic or inherited element semantics. The constrained instances remain valid instances of the unconstrained element type, and the element type retains the same semantics and class attribute declaration. Thus, a constraint never creates a new case to which content processing may need to react.

For example, a document type constrained to require the <shortdesc> element allows a subset of the possible instances of the unconstrained document type with an optional <shortdesc> element. Thus, the content processing for topic still works when topic is constrained to require a short description.

Content interoperability

DITA document instances declare (by means of the @domains attribute and the @class attribute for the topic or map elements) the vocabularies available in its document type. A processor may examine these declarations to determine whether or not a document instance uses a subset of the vocabularies in another DITA document type and is thus compatible with the other DITA document type.

A constrained document type allows only a subset of the possible instances of the unconstrained document type. Thus, for a processor to determine whether a document instance is compatible with another document type, the document instance must declare any constraints on the document type.

For instance, an unconstrained task is compatible with an unconstrained topic because the task can be generalized to topic. If, however, the topic is constrained to require the <shortdesc> element, a document type with an unconstrained task is not compatible with the constrained document type because some instances of the task might not have a <shortdesc> element. If, however, the task document type has also been constrained to require the <shortdesc> element, it is compatible with the constrained topic document type.

  • 2.1.4.4.1 Constraint module DTD coding requirements
  • 2.1.4.4.2 Constraint module XSD coding requirements
  • 2.1.4.4.3 Conref and generalization for constraint modules
    When documents use different constraints, conref and generalization processors may examine the @domains to verify compatibility between the document instances.
  • 2.1.4.4.4 Examples of constraint declaration modules
    This section provides examples of constraint declaration modules.
Parent topic: 2.1.4 Configuration, specialization, and constraints
Previous topic: 2.1.4.3.8.2.3 Attribute domain coding requirements
Next topic: 2.1.4.4.1 Constraint module DTD coding requirements


Constraint module DTD coding requirements

2.1.4.4.1 Constraint module DTD coding requirements

Requirements for structural constraint modules

A structural constraint module defines the constraints for exactly one map or topic element type.

Constraint modules should be named "qualifiertagnameConstraints.mod", where qualifier is specific to the constraints module and characterizes it, e.g. "strict", "requiredTitle", etc. and tagname is the name of the element type to which the constraints apply, e.g. "topic", "p", "myNewTopicType", etc.

Within the constraint module there must be a declaration for a general text entity named "tagname-constraints", where tagname is the name of the element type to which the constraints apply. The replacement text for the entity must be of the form "(tagname qualifierTagname-c)", where tagname is the name of the element type to which the constraints apply, qualifier is as for the module filename (e.g., "strict"), and Tagname is the element type name with an initial capital (e.g. "Topic"). The literal "-c" indicates that the name is the name of a constraints domain. There must also be a declaration of the %tagname.content parameter entity that defines the constrained content model. For example:
<!ENTITY  topic-constraints  "(topic strictTopic-c)">
<!ENTITY % topic.content
  "((%title;),
    (%titlealts;)?,
    (%shortdesc;|
     %abstract;),
    (%prolog;)?,
    (%body;)?,
    (%topic-info-types;)*)"
>

In this example, the shortdesc-or-abstract choice, which is optional in the base <topic> content model, is required, defining a more-constrained content model.

Requirements for domain constraint modules

A domain constraint module defines the constraints for exactly one element domain module.

Domain constraint modules should be named "qualifierdomainDomainConstraints.mod", where qualifier is specific to the constraints module and characterizes it, e.g. "strict", "requiredTitle", etc. and domain is the name of the domain to which the constraints apply, e.g. "hi-d", "pr-d", "mydomain-d", etc.

Within the constraint module there must be a declaration for a general text entity named "tagname-constraints", where tagname is the name of the element type to which the constraints apply. The replacement text for the entity must be of the form "(tagname qualifierTagname-c)", where tagname is the name of the element type to which the constraints apply, qualifier is as for the module filename (e.g., "strict"), and Tagname is the element type name with an initial capital (e.g. "Topic"). The literal "-c" indicates that the name is the name of a constraints domain. There must also be a declaration of the %tagname.content parameter entity that defines the constrained content model.

For example:
<!ENTITY % basicHighlight-c-ph  "b | i">

<!ENTITY   basicHighlight-c-att   "(topic hi-d basicHighlight-c)">

In this example, the set of highlight domain elements has been reduced to just <b> and <i>.

Requirements for shell document types

Information on how to incorporate a constraint module into a DTD document type shell can be found in DTD document-type shell: Coding requirements.

Parent topic: 2.1.4.4 Constraints
Previous topic: 2.1.4.4 Constraints
Next topic: 2.1.4.4.2 Constraint module XSD coding requirements


Constraint module XSD coding requirements

2.1.4.4.2 Constraint module XSD coding requirements

A given constraint definition module corresponds to exactly one topic, map, or domain vocabulary module.

Requirements for constraint definition modules

Topic and map type constraint modules should be named "qualifiertagnameConstraints.xsd", where qualifier is specific to the constraints module and characterizes it, e.g. "strict", "requiredTitle", etc. and tagname is the name of the element type to which the constraints apply, e.g. "topic", "p", "myNewTopicType", etc.

Domain constraint modules should be named "qualifierdomainDomainConstraints.xsd", where qualifier is specific to the constraints module and characterizes it, e.g. "strict", "requiredTitle", etc. and domain is the name of the domain to which the constraints apply, e.g. "hi-d", "pr-d", "mydomain-d", etc.

Because of restrictions on the redefine feature of XML Schema, it is sometimes necessary to use an intermediate level of redefinition, which requires a separate XSD document. In that case, the intermediate XSD document should be named "qualifierdomainDomainConstraintsInt.xsd".

For each extension element type in the base vocabulary module whose content model or attributes are to be constrained in the constraint module, there must be a xs:redefine element that defines the restricted content model for the base element. Attributes for an element type may be constrained as part of the redefinition of the complex type.

non-normative: When adding an xs:redefine element to an existing document type shell you must remove any xs:include elements that refer to the XSD module to which the redefine is applied. For example, to redefine groups defined in commonElementsMod.xsd you must remove any xs:include of commonElementsMod.xsd.
Figure 1. Example of a structural constraint module. The following code sample shows how the <topic> element may be constrained to create a stricter form of the element, in this case, disallowing the <body> element. This xs:redefine element would be placed in a file named noBodyTopicConstraint.xsd.
...
<xs:redefine schemaLocation="urn:oasis:names:tc:dita:xsd:topicMod.xsd:1.2">
  <xs:group name="topic.content">
    <xs:sequence>
      <xs:sequence>
        <xs:group ref="title"/>
        <xs:group ref="titlealts" minOccurs="0"/>
        <xs:choice minOccurs="1" >
          <xs:group ref="shortdesc" />
          <xs:group ref="abstract" />
        </xs:choice>
        <xs:group ref="prolog" minOccurs="0"/>
        <!--<xs:group ref="body" minOccurs="0"/>-->
        <xs:group ref="related-links" minOccurs="0"/>
        <xs:group ref="topic-info-types" minOccurs="0"
          maxOccurs="unbounded"/>
      </xs:sequence>
    </xs:sequence>
  </xs:group>
</xs:redefine>
...

For selective restriction there must be a group with a subset list of extension elements for a domain in a reusable constraints module. The group name should be named "qualifierdomain-c-tagname" where qualifier is a description for the constraint vocabulary constraint module file, domain is the name of the domain, map, or topic being constrained, and tagname is the name of the extension element being restricted.

Figure 2. Example of a domain constraint module. The following code sample shows how the highlight domain can be constrained to limit the elements that are available in the domain to only <b> and <i>. These declarations would be placed in a file named basicHighlightConstraint.xsd.
...
<xs:group name="basicHighlight-c-ph">
  <xs:choice>
    <xs:element ref="b"/>
    <xs:element ref="i"/>
  </xs:choice>
</xs:group>
...

Requirements for shell document types

Document type shell schemas that integrate constraint modules must reflect these requirements:
  • For content model constraints, must include the constraint module instead of the vocabulary module that it constrains.
  • For selective extension, must include the extension subset constraint module and use that group for domain or topic type extension.
  • Must declare the constraints in the domains attribute.
Figure 3. strictTopic.xsd (shell). The following code sample demonstrates the markup used to constrain the standard <topic> element. These declarations would be placed in a shell file named "strictTopic.xsd".
...
<xs:include schemaLocation="basicHighlightConstraint.xsd"/>
...
<xs:redefine schemaLocation="commonElementGrp.xsd">
  <xs:group name="ph">
    <!-- drop base <ph> as well as apply basic subset of highlight domain -->
    <xs:choice>
      <xs:group ref="basicHighlight-c-ph"/>
    </xs:choice>
  </xs:group>
  ...
</xs:redefine>

<xs:redefine schemaLocation="strictTopicConstraint.xsd">
  <xs:complexType name="topic.class">
    <xs:complexContent>
      <xs:extension base="topic.class">
        <!-- declare the constraint of topic and highlight vocabulary modules
             and compatibility of constrained highlight with subset of
             topic constraints -->
        <xs:attribute name="domains" type="xs:string"
            default="(topic noBasePhrase-c)
                     (topic strictTopic-c)
                     (topic strictTopic-c hi-d basicHighlight-c)"/>
        ...
      </xs:extension>
    </xs:complexContent>
  </xs:complexType>
  ...
</xs:redefine>
...
Parent topic: 2.1.4.4 Constraints
Previous topic: 2.1.4.4.1 Constraint module DTD coding requirements
Next topic: 2.1.4.4.3 Conref and generalization for constraint modules


Conref and generalization for constraint modules

2.1.4.4.3 Conref and generalization for constraint modules

When documents use different constraints, conref and generalization processors may examine the @domains to verify compatibility between the document instances.

Conref compatibility with constraints

To determine compatibility between two document instances, a conref processor can check the @domains attribute to confirm that

  • The referencing document has a superset of the vocabulary modules in the referenced document.
  • For each vocabulary module in the referenced document, the referencing document qualifies the common module with a subset of the constraints in the referenced document.

Some examples:

Referencing | Referenced | Resolution
(topic) | (topic shortdescReq-c) | Allowed - content model of referenced topic is more constrained
(topic shortdescReq-c) | (topic) | Prevented - content model of referenced topic is less constrained
(topic hi-d) | (topic hi-d basicHighlight-c) | Allowed - domain extension list of referenced document type shell is more constrained
(topic hi-d basicHighlight-c) | (topic hi-d) | Prevented - domain extension list of referenced document type shell is less constrained.
(topic hi-d) | (topic noBasePhrase-c) (topic hi-d) | Allowed - referencing document type shell doesn't replace base element with domain extensions.
(topic noBasePhrase-c) (topic hi-d) | (topic hi-d) | Prevented - referencing document type shell does replace base element with domain extensions.
(topic task) (topic hi-d basicHighlight-c) | (topic simpleSection-c task simpleTaskSection-c) | Allowed - referencing shell has a subset of the constraints of the referenced shell on the common vocabulary modules.
(topic shortdescReq-c task shortdescTaskReq-c) (topic hi-d basicHighlight-c) | (topic simpleSection-c task simpleTaskSection-c) | Prevented - referencing shell has constraints on common vocabulary modules that aren't in the referenced shell.

Generalization and constraints

Similarly, to determine compatibility between a document instance and a target document type, a generalization processor can use the @domains and @class attributes for the document instance and the @domains attribute for the target document type to determine how to rename elements in the document instance. For each element instance, the generalization processor:

  • Iterates over the @class attribute on the element instance from specific to general, inspecting the vocabulary modules.

  • Looks for the first vocabulary module that is both present in the target document type and that has a subset of the constraints in the document instance.

    If a module is found in the target document type, that module becomes the minimum threshhold for the generalization of contained element instances.

    If a module is not found, the document instance cannot be generalized to the target document type and, instead, can only be generalized to a less constrained document type.

Note that a document instance can always be converted from a constrained document type to an unconstrained document type merely by switching the binding of the document instance to the less restricted schema (which would also have a different @domains attribute declaration). No renaming of elements is needed to remove constraints.

Parent topic: 2.1.4.4 Constraints
Previous topic: 2.1.4.4.2 Constraint module XSD coding requirements
Next topic: 2.1.4.4.4 Examples of constraint declaration modules


Examples of constraint declaration modules

2.1.4.4.4 Examples of constraint declaration modules

This section provides examples of constraint declaration modules.

Constraining element content in a topic vocabulary module

A constraint module named shortdescReq redefines the content model of the <topic> element so that the <shortdesc> element is required. The DTD declarations for this module would be:
<!ENTITY shortdescReq.constraint
  "(topic shortdescReq-c)"
>

<!ENTITY % topic.content
   "((%title;),
     (%titlealts;)?,
     (%shortdesc;),
     (%prolog;)?,
     (%body;)?,
     (%related-links;)?,
     (%topic-info-types;)*)"
>
<!ENTITY % topic.attributes
            "id          ID                                #REQUIRED
             conref      CDATA                             #IMPLIED
             %select-atts;
             %localization-atts;
             outputclass CDATA                             #IMPLIED">
...
<!ELEMENT topic  %topic.content;>
<!ATTLIST topic  %topic.attributes;>
<!ATTLIST topic
             %arch-atts;
             domains    CDATA
             "&included-domains;"
>

Integrating a subset of the extension elements from a domain module

A constraint module named basicHighlight includes the <b> and <i> elements but not the <u>, <sub>, <sup>, and <tt> elements from the highlight domain. The DTD declarations for this module would be:
<!ENTITY   basicHighlight-c-att
   "(topic hi-d basicHighlight-c)"
>

<!ENTITY % basicHighlight-c-ph  "b | i">
The XSD declarations for this module would be:
<xs:group name="basicHighlight-c-ph">
  <xs:choice>
    <xs:element ref="b"/>
    <xs:element ref="i"/>
  </xs:choice>
</xs:group>
Note that the basicHighlight constraint module subsets extension, but does not redefine any content models. If another constraint is created to restrict the content model of the <b> element, it will not conflict with the basicHighlight domain, because they do not attempt to revise the same content model. This means that the two can be combined in the same shell document type. The effective value of the @domains attribute will include the contributions from both constraint modules, as well as any other modules integrated by the shell, e.g.:
...
(topic hi-d noNestedHighlight-c)
(topic hi-d basicHighlight-c)
...

Applying multiple constraints to a single vocabulary module

A constraint module named simpleSection redefines the content models of the <section> and <example> elements to allow a single initial <title> element and to remove text and phrase elements. Because this constraint module redefines different elements than the shortdescReq constraint module shown above, both modules can apply to the topic module. The order in which the constraint modules are listed is not significant. The DTD declarations for this module would be:
<!ENTITY simpleSection.constraints
  "(topic simpleSection-c)"
>

<!ENTITY % section.content
  "((%title),
    (%basic.block; |
     %data.elements.incl; |
     %foreign.unknown.incl; |
     %sectiondiv;)*)

  "
>

Note that this constraint module and the shortdescReq constraint module both constrain task but because they constrain different element types they do not conflict and can be used together. Each constraint module provides its own contribution to the @domains attribute, so that when integrated the effective value of the @domains attribute will include the declarations for both constraint modules, as well as the declarations for the other modules integrated by the shell document type, e.g.:

...
(topic shortdescReq-c)
(topic simpleSection-c)
..

A topic with elements replaced by domain extensions

A document type shell replaces the <ph> element with extension elements from the highlighting and programming domains. Because the highlighting and programming domains cannot be generalized to a topic without the <ph> element, the removal constraint must be declared on the topic module with a separate parenthetical expression.

The @domains attribute declaration:

(topic noBasePhrase-c)
(topic hi-d)
(topic pr-d)
Parent topic: 2.1.4.4 Constraints
Previous topic: 2.1.4.4.3 Conref and generalization for constraint modules
Next topic: 2.2 Architectural Specification: Technical Content Version


Architectural Specification: Technical Content Version

2.2 Architectural Specification: Technical Content Version

Previously, the document types and specializations for technical content were included as an integral part of the base DITA specification. With the release of DITA 1.2 and the increasingly number of specializations that are part of the DITA specification, the document types and specializations for technical content have a dedicated section in the DITA specification.

  • 2.2.1 Overview of the DITA 1.2 Specification: Technical Content
    This section describes the DITA document types and specializations for technical content.
  • 2.2.2 Technical content: Document and information types
    The Technical Content package contains five topic specializations that support seven document types: concept, reference, general task, strict task, machinery task, glossary entry, and glossary group. These topic types are specialized from the base topic and are designed specifically for information that describes how to use products and processes they are dominated by procedural, task-oriented information. The Technical Content package also includes the map document type.
  • 2.2.3 Topic domains: Technical content
    A DITA domain defines a set of elements associated with a particular subject area or authoring requirement. DITA incorporates several domains into the Technical Content specializations. Other domains are incorporated into basic DITA.
  • 2.2.4 The xNAL domain
    The DITA xNAL domain specialization defines a number of metadata elements and attributes that are useful in representing personal/organizational names and addresses. The metadata can be used to identify authors and content owners. The OASIS xNAL Standard (extensible Name and Address Langauge) was selected to represent close mappings from the DITA bookmap metadata content model to an existing standard. xNAL is included in the Bookmap and the LearningBookmap document types.
Parent topic: 2 Architectural specification
Previous topic: 2.1.4.4.4 Examples of constraint declaration modules
Next topic: 2.2.1 Overview of the DITA 1.2 Specification: Technical Content


Overview of the DITA 1.2 Specification: Technical Content

2.2.1 Overview of the DITA 1.2 Specification: Technical Content

This section describes the DITA document types and specializations for technical content.

Prior to the release of DITA 1.2, the document types and specializations for technical content were included as an integral part of the base DITA specification. With the release of DITA 1.2, the document types and specializations for technical content have a dedicated section in the DITA specification. This change reflects the addition of an increasing number of specializations that are part of the DITA standard.

The document types and specializations included in the technical content package and described in this section were designed to meet the requirements of those authoring content for technically oriented products in which the concept, task, and reference information types provide the basis for the majority of the content. These information types are used by technical-communication and information-development organizations that provide procedures-oriented content to support the implementation and use of computer hardware, computer software, and machine-industry content. However, many other organizations producing policies and procedures, multi-component reports, and other business content also use the concept, task, and reference information types as essential to their information models.

The DITA 1.2 technical content package includes the following document types and supporting structural specializations and constraints:
  • Concept document type and structural specialization
  • Reference document type and structural specialization
  • Task document type (general task with the Strict Taskbody Constraint)
  • General task document type and specialization
  • Machinery task document type (general task with the Machinery Taskbody Constraint)
  • Glossary entry (glossentry) document type and structural specialization
  • Glossary group (glossgroup) document type and structural specialization
  • Bookmap document type and structural specialization

The DITA technical content package includes the following domain specializations:

  • Programming elements
  • Software elements
  • User interface elements
  • Task requirements elements
  • Extensible Name and Address Language (xNAL) elements
  • Abbreviated form element
  • Glossary reference (glossref) element

The DITA technical content package includes the following constraint modules:

  • Strict Taskbody
  • Machinery Taskbody

The technical content document type shells included in the DITA technical content package use information types included in other packages, and other packages use the information types from the technical content package.

The technical content package consists of the technicalContent, machineIndustry, and xnal directories, as well as the map document type but not the base map information types.

Parent topic: 2.2 Architectural Specification: Technical Content Version
Previous topic: 2.2 Architectural Specification: Technical Content Version
Next topic: 2.2.2 Technical content: Document and information types


Technical content: Document and information types

2.2.2 Technical content: Document and information types

The Technical Content package contains five topic specializations that support seven document types: concept, reference, general task, strict task, machinery task, glossary entry, and glossary group. These topic types are specialized from the base topic and are designed specifically for information that describes how to use products and processes they are dominated by procedural, task-oriented information. The Technical Content package also includes the map document type.

Concept

The concept document and information types provide conceptual information to support the performance of tasks. Concepts may include extended definitions of terms, expositions of background information, descriptions of systems and objects, and other content that helps to build the users' understanding of the tasks to be performed.

Reference

The reference document and information types provide for the separation of fact-based information from concepts and tasks. Factual information may include tables and lists of specifications, parameters, parts, commands, and other information that the users are likely to look up. The reference information type allows fact-based content to be maintained by those responsible for its accuracy and consistency.

Task (strict task)

The task document type provides procedural information to support the performance of a task. The task document type implements the strict task content model from DITA 1.0 and 1.1 by combining the new general task (task) information type and the new Strict Taskbody constraint. This information model provides detailed semantics to encourage authors to label standard parts of the task, including pre-requisites, sufficient conceptual information required to perform the task, the commands that introduce each step in a procedure, additional support information required to understand a step, the result of performing the task, and examples that demonstrate the performance of the task.

General task

The general task document and information types are new to DITA 1.2. They provide a less strict task model for task-oriented information than was available in DITA 1.0 and 1.1. The general task model may be preferred over the strict task model by some organizations. It can facilitate the migration of legacy task content that does not follow the strict task topic model. The general task information type serves as the base for the strict task and machine-industry task document types, can be used to create new document types, and can be a base for new structural specializations.

Unfortunately, for historical reasons and to maintain compatibility with DITA 1.0 and 1.1, the names used for the various task components can be confusing:

  • General task is the name for the general task document type
  • Task is the name for the strict task document type
  • Task is also the name for the general task information type
  • Task is the name of the specialized topic tag in the general information type which is used in the strict task, general task, and machine-industry task document types

Machinery task

The machinery-task document type is new to DITA 1.2 and is built by combining the general task information type with the Task Requirements Domain and the Machinery Taskbody Constraint. It provides procedural information, similar to other task types, and has a well-defined semantic structure to meet the special requirements of organizations that develop instructional material for industrial equipment, such as industrial products like trucks, mining machinery, and automobiles. The machine-industry task requirements domain adds several new descriptive elements in the preliminary requirements (prelreqs) and closing requirements (closereqs) sections.

Glossary entry

The glossary entry (glossentry) document type replaces the glossary document type of DITA 1.1. It provides for the development of glossary topics that define terms, acronyms, and abbreviations. It may also contain terminology information.

Glossary group

The glossary group (glossgroup) document type, new in DITA 1.2, allows authors to incorporate multiple glossary entries in a single collection tile.

  • 2.2.2.1 Concept topic
    The DITA concept document type uses the concept information type. Concept topics are specialized from the base topic information type. They include the standard topic elements, including the short description, prolog, a body, and related links.
  • 2.2.2.2 Reference topic
    The DITA reference document type uses the reference information type. Reference topics are specialized from the base topic information type. They contain the standard topic elements, including title, short descriptions or abstract, prolog, a body, and related links.
  • 2.2.2.3 General task topic
    The general task document and information types are new to DITA 1.2. They provide a less strict content model for task-oriented information than was available in DITA 1.0 and 1.1. The general task content model may be preferred over the strict task model by some organizations. It can facilitate the migration of legacy content that does not follow the strict task topic model. The general task information type serves as the base for the strict task and machine-industry task document types, can be used to create new document types, and serves as a base for new structural specializations.
  • 2.2.2.4 Task topic (strict task)
    The strict task document type supports the development of instructions for the completion of a procedure. The strict task document type is built using the general task information type combined with the Strict Taskbody Constraint. See the reference below to ensure that you have the correct task document type when you update to DITA 1.2.
  • 2.2.2.5 Machinery task topic
    The machinery task document type supports the development of instructions for the completion of a procedure. The machinery task document type is built using the general task information type combined with the Machinery Taskbody Constraint.
  • 2.2.2.6 Glossary entry topic
    Each glossary entry <glossentry> topic defines a single sense of one term. Besides identifying the term and providing a definition, the topic accommodates basic terminology information, such as part of speech. A glossentry topic may also include acronyms and acronym expansions. Glossentry topics may be assembled by authors or processes to create glossaries for various purposes, including books, websites, or other projects.
  • 2.2.2.7 Glossary group topic
    Glossary group <glossgroup> topics may be used to contain multiple glossentry topics in a single collection file.
  • 2.2.2.8 Bookmap
    The DITA bookmap specialization represents the key markup requirements for managing DITA content through book-oriented publication processes, including book metadata and book structures for organizing content.
Parent topic: 2.2 Architectural Specification: Technical Content Version
Previous topic: 2.2.1 Overview of the DITA 1.2 Specification: Technical Content
Next topic: 2.2.2.1 Concept topic


Concept topic

2.2.2.1 Concept topic

The DITA concept document type uses the concept information type. Concept topics are specialized from the base topic information type. They include the standard topic elements, including the short description, prolog, a body, and related links.

The purpose of the concept information type

Concepts provide background that helps readers understand essential information about a product, a task, a process, or any other conceptual or descriptive information. A concept may be an extended definition of a major abstraction such as a process or function. Conceptual information may explain the nature and components of a product and describe how it fits into a category of products. Conceptual information helps readers to map their knowledge and understanding to the tasks they need to perform and to provide other essential information about a product, process, or system.

The structure of the concept topic

The concept topic is specialized from the base topic information type. The top-level element for a DITA concept topic is the <concept> element. Every concept topic contains the standard topic elements, including title, short descriptions or abstract, prolog, a body, and related links.

The <conbody> element holds the main body-level elements of the concept topic. Like the body element of a base topic, the <conbody> allows paragraphs, lists, tables, figures and other general elements. It also provides two key elements that allow authors to subdivide the topic into parts, with or without titles. These subdivisions are called sections and examples. The <conbody> also allows <bodydiv> and <sectiondiv> to facilitate grouping elements in the <conbody> for reuse.

Limitations within <conbody>

The <conbody> provides for an unlimited number of subdivisions in the form of sections and examples. However, once an author decides to incorporate a section or example in the <conbody>, only additional sections or examples are allowed. Sections and examples may not nest, meaning that only one level of subdivision is permitted in the concept topic.

Concept body primary subdivisions

<section>
Represents an organizational division in a concept topic. Sections organize subsets of information within a larger topic. You can only include a simple list of peer sections in a topic; sections cannot be nested. A section may have an optional title.
<example>
Provides examples that illustrate or support the current topic. The <example> element has the same content model as <section>.

Following is an example of a simple concept topic. Note that once an example is used, it may be followed only by another example or by a section.

<concept id="concept">
 <title>Bird Songs</title>

<shortdesc>Bird songs are complex vocalizations used to attract mates or defend territories.
<conbody>
  <p>Bird songs vary widely among species, from simple songs that are genetically imprinted to complex songs that are learned over a lifetime.</p>
  <example>
   <p>Flycatchers know their songs from birth:</p>
   <ul>
    <li>Flycatcher songs are simple sequences of notes.</li>
    <li>Flycatcher songs never vary but are unique to each member of the Flycatcher family.</li>
   </ul>
  </example>
 </conbody>
</concept>

Modules

The following DITA modules are provided for the concept topic:

  • concept.mod, concept.ent (DTD)
  • conceptMod.xsd, conceptGrp.xsd (Schema)
Parent topic: 2.2.2 Technical content: Document and information types
Previous topic: 2.2.2 Technical content: Document and information types
Next topic: 2.2.2.2 Reference topic


Reference topic

2.2.2.2 Reference topic

The DITA reference document type uses the reference information type. Reference topics are specialized from the base topic information type. They contain the standard topic elements, including title, short descriptions or abstract, prolog, a body, and related links.

The purpose of the reference information type

Reference topics that provide data in support of the performance of a task. Reference topics may provide lists and tables that include product specifications, parts lists, constraints on use or performance, and other data that is often “looked up” rather than memorized. A reference topic may also describe regular constituents of a subject or product, such as commands in a programming language. or required tools for a series of maintenance tasks.

Reference topics provide quick access to fact-based information. In technical information, reference topics are used to list product specifications and parameters, provide essential data, and provide detailed information on subjects such as the commands in a programming language. Reference topics may hold any subject matter that has regular content, such as ingredients for food in recipes, bibliographic lists, catalogue items, and so on.

The structure of the reference topic

The top-level element for a reference topic is the <reference> element.

The <refbody> element holds the main body-level elements of the reference topic. Reference topics limit the body to tables (both simple and complex), property lists, syntax sections, and generic sections and examples.

All of the elements of <refbody> are optional and may appear in any sequence and number.

Limitations on the reference body

The <refbody> provides for an unlimited number of subdivisions in the form of sections, examples, syntax sections, property lists, and tables. However, once an author decides to incorporate a section, example, property list, or syntax section in the <refbody>, only additional sections, examples, property lists, or syntax sections are allowed. Simple and complex tables may appear within sections, examples, and syntax sections. They may not appear within the property list or simple or complex table sections. Sections, examples, syntax sections, table subdivisions, and property lists may not nest, meaning that only one level of subdivision is permitted in the reference topic.

The sections of the reference body

<section>
Represents an organizational division in a reference topic. Sections organize subsets of information within a larger topic. You can only include a simple list of peer sections in a topic; sections cannot be nested. A section may have an optional title.
<refsyn>
Contains syntax or signature content (for example, a command-line utility's calling syntax or an API's signature). The <refsyn> contains a brief, possibly diagrammatic description of the subject's interface or high-level structure.
<example>
Provides examples that illustrate or support the current topic. The <example> element has the same content model as <section>.
<table>
Organizes information according into a rows and columns. Table markup also allows for more complex structures, including spanning rows and columns, as well as table captions.
<simpletable>
Holds information in regular rows and columns and does not allow a caption.
<properties>
Lists properties of a subject and their types, values, and descriptions.
Following is an example of a simple reference topic, including the <refsyn> element.
<reference id="boldproperty">
<title>Bold property</title>
<shortdesc>(Read-write) Whether to use a bold font for the specified text string.</shortdesc>
<refbody>
  <refsyn>
    <synph>
      <var>object</var><delim>.</delim><kwd>Font</kwd><delim>.</delim>
      <kwd>Bold</kwd><delim> = </delim><var>trueorfalse</var>
    </synph>
  </refsyn>
  <properties>
    <property>
      <proptype>Data type</proptype>
      <propvalue>Boolean</propvalue>
    </property>
    <property>
      <proptype>Legal values</proptype>
      <propvalue>True (1) or False (0)</propvalue>
    </property>
  </properties>
</refbody>
</reference>
Following is an example of a simple reference topic, including the <property> element.
<reference id="oiltypes">
<title>Oil Types</title>
<shortdesc>The tables provide the recommended oil types.</shortdesc>
<refbody>
    <properties>
    <property>
      <prophead>
          <proptypehd>Oil type</proptypehd>
          <propvaluehd>Oil brand</propvaluehd>
          <propdeschd>Appropriate use</propdeschd>
      </prophead>
     <property>
      <proptype>Primary oil</proptype>
      <propvalue>A1X<propvalue>
      <propdesc>Appropriate for one-cylinder engines</propdesc>
    </property>
    <property>
      <proptype>Secondary oil</proptype>
      <propvalue>B2Z</propvalue>
      <propdesc>Appropriate for two-cylinder engines</propdesc>
    </property>
  </properties>
</refbody>
</reference>

Modules

The following DITA modules are provided for the reference topic.

  • reference.mod, reference.ent (DTD)
  • referenceMod.xsd, referenceGrp.xsd (Schema)
Parent topic: 2.2.2 Technical content: Document and information types
Previous topic: 2.2.2.1 Concept topic
Next topic: 2.2.2.3 General task topic


General task topic

2.2.2.3 General task topic

The general task document and information types are new to DITA 1.2. They provide a less strict content model for task-oriented information than was available in DITA 1.0 and 1.1. The general task content model may be preferred over the strict task model by some organizations. It can facilitate the migration of legacy content that does not follow the strict task topic model. The general task information type serves as the base for the strict task and machine-industry task document types, can be used to create new document types, and serves as a base for new structural specializations.

The purpose of the general task information type

Like the DITA strict task document type, the general task document and information types contain the essential building blocks to provide procedural information. Both task information types answer the "How do I?" question by providing step-by-step instructions detailing the requirements that must be fulfilled, the actions that must be performed, and the order in which the actions must be performed. Both task topics include sections for describing the context, prerequisites, expected results, and other aspects of a task.

The general task information type is specifically designed to accommodate task specializations that differ from the DITA task information type. It may also be used for the conversion of loosely structured tasks from other sources into DITA before they are restructured to follow the more restrictive DITA task model.

The structure of the general task topic

The <task> element is the top-level element for the general task topic. The general task topic contains a title and a taskbody with optional alternative titles (titlealts), a short description or abstract, a prolog,and related-links.

The following elements are described here because they are introduced as part of the general task model. All other elements are described in the strict task topic.

<section>
Represents an organizational division in a task topic. Sections organize subsets of information within the larger topic. Sections may not be nested. A section may have an optional title.
<steps-informal>
Describes procedural task information that would not normally be ordered as steps, such as a group of general procedures that may all be applied in a particular situation. Instead of <step>, the <steps-informal> element uses <ol> and <ul> elements, which are less strictly defined than the <step> element. When converting legacy content, it may be simpler to convert numbered lists to <ol> elements than to <step> elements.

Comparison of general and strict task

The following table compares the structures of general and strict task:

General taskbody | Strict taskbody constraint
prerequisite (optional, in any order, any number) | prerequisite (optional, one only, must precede context)
context (optional, in any order, any number) | context (optional, one only, must follow prerequisite)
section (optional, in any order, any number) | (not defined for strict taskbody)
steps | steps
steps-unordered | steps-unordered
steps-informal | (not defined for strict taskbody))
result (optional, one only, precedes example) | result (optional, one only, precedes example)
example (optional, any number, precedes post-req) | example (optional, one only, precedes post-req)
post-requisite (optional, any number) | post-requisite (optional, one only)

Modules

The following DITA modules are provided for the task topic.

  • task.mod, task.ent(DTD)
  • taskMod.xsd, taskGrp.xsd (Schema)
Parent topic: 2.2.2 Technical content: Document and information types
Previous topic: 2.2.2.2 Reference topic
Next topic: 2.2.2.4 Task topic (strict task)


Task topic (strict task)

2.2.2.4 Task topic (strict task)

The strict task document type supports the development of instructions for the completion of a procedure. The strict task document type is built using the general task information type combined with the Strict Taskbody Constraint. See the reference below to ensure that you have the correct task document type when you update to DITA 1.2.

The purpose of the standard task information type

Tasks are the essential building blocks to provide procedural information. A task information type answers the "How do I?" question by providing precise step-by-step instructions detailing the requirements that must be fulfilled, the actions that must be performed, and the order in which the actions must be performed. The task topic includes sections for describing the context, prerequisites, expected results, and other aspects of a task.

The structure of the task topic

The <task> element is the top-level element for the strict task topic. The strict task document type contains a title and a taskbody with optional alternative titles (titlealts), a short description or abstract, a prolog,and related-links.

The <taskbody> element is the main body element inside a strict task document type. The strict task body has a constrained structure, with these optional elements in the following order:

<prereq>
Describes information that the user needs to know or do before starting the immediate task. This section may occur only once.
<context>
Provides background information for the task. This information helps the users understand the purpose of the task and what they will gain by completing the task correctly. This section should be brief and does not replace or recreate a concept topic on the same subject, although the context section may include some conceptual information. This section may occur only once.
<steps>
Provides the main content of the task topic. A task consists of a series of steps that accomplish the task. The <steps> element must have one or more <step> elements, which provide the specifics about each step in the task. The <steps> element may occur only once.

The <step> element represents an action that a user must follow to accomplish a task. Each step in a task must contain a command <cmd> element which describes the particular action the user must perform to accomplish the overall task. The step element may also contain information <info>, substeps <substeps>, tutorial information <tutorialinfo>, a step example <stepxmp>, choices <choices>, or a stepresult <stepresult>, although these are optional.

<steps-unordered>
Provides alternative content for the task topic, allowing for a single step in a procedure or a set of commands that need not be performed in a specific order.
<result>
Describes the expected outcome for the task as a whole.
<example>
Provides an example that illustrates or supports the task.
<postreq>
Describes steps or tasks that the user should do after the successful completion of the current task. It is often supported by links to the next task or tasks in the <related-links> section.
Here is an example of a task topic:
<task id="birdhousebuilding">
    <title>Building a bird house</title>
    <shortdesc>Building a birdhouse is a perfect activity
    for adults to share with their children or grandchildren.
    It can be used to teach about birds, as well as the proper use of tools.
    </shortdesc>
 <taskbody>
  <context>Birdhouses provide safe locations for birds to build nests and raise their young. They also provide shelter during cold and rainy spells.</context>
  <prereq>To build a sound birdhouse, you will need a complete set of tools:
  <ul><li>hand saw</li>
      <li>hammer ... </li>
  </ul></prereq>
 <steps>
   <step><cmd>Lay out the dimensions for the birdhouse elements.</cmd></step>
   <step><cmd>Cut the elements to size.</cmd></step>
   <step><cmd>Drill a 1 1/2" diameter hole for the bird entrance on the front.</cmd>
         <info>You need to look at the drawing for the correct placement of the
               hole.</info></step>
   ...
  </steps>
  <result>You now have a beautiful new birdhouse!</result>
  <postreq>Now find a good place to mount it.</postreq>
 </taskbody>
</task>

Maintaining specializations using the strict task model

Organizations that have created specializations based on the DITA 1.0 and 1.1 strict task model should review the recommendations in Migrating from DITA 1.1 to 1.2 to maintain their specializations.

Modules

The following DITA modules are provided for the task topic.

  • task.mod. task.ent, strictTaskbody constraint (DTD)
  • taskMod.xsd, taskGrp.xsd, strictTaskbodyConstraintMod.xsd (Schema)
Parent topic: 2.2.2 Technical content: Document and information types
Previous topic: 2.2.2.3 General task topic
Next topic: 2.2.2.5 Machinery task topic


Machinery task topic

2.2.2.5 Machinery task topic

The machinery task document type supports the development of instructions for the completion of a procedure. The machinery task document type is built using the general task information type combined with the Machinery Taskbody Constraint.

The purpose of the machinery task information type

The machinery-task is designed to provide procedural information, similar to the strict task topic, and has a well-defined semantic structure that describes how to perform the steps required to accomplish a specific goal. Compared to the strict task information type, the machinery-task information type contains additional descriptive elements in the prelreqs section that add detail to the pre-requisites required to perform a task. The machinery-task topic is developed using the DITA constraint mechanism, in addition to specializations for new elements.

Machinery tasks are the essential building blocks to provide procedural information for machines, machinery equipment, assemblies, and apparatuses. A machinery-task information type answers the "How do I?" question by providing precise step-by-step instructions detailing the requirements that must be fulfilled, the actions that must be performed, and the order in which the actions must be performed. The machinery-task topic includes sections for describing the context, preliminary requirements, expected results, examples, closing requirements, and other aspects of a task.

The structure of the machinery-task topic

Similar to a strict DITA task, the <task> element is the top-level element for a machinery task topic. The machinery task document type contains a title and a taskbody with optional alternative titles (titlealts), a short description or abstract, a prolog,and related-links.

The <taskbody> element is the main body element inside a machinery-task topic. A machinery-task body has a very specific structure, with the following elements in this order: (<prelreqs> or <context> or <section>)*, <steps>, <result>, <example>, and <closereqs>. Each of the body sections is optional.

The machinery task includes two specialized element groups: <prelreqs> and <closereqs>. All other element groups are the same as the general task model.

<prelreqs>
The preliminary-requirements section of a task is used to describe what the user needs to know or do before starting the immediate task. The <prelreqs> element is similar to the prerequisites section of the general task model but contains a more descriptive content model. The <prelreqs> element contains required conditions, required personnel, required equipment, supplies, spares, and safety information.
<closereqs>
The close-requirements section is used to describe conditions that must be fulfilled after the successful completion of the current task. It is often supported by links to the next task or tasks in the <related-links> section. The <closereqs> element contains required conditions <reqconds>.

Modules

The following DITA modules are provided for the machinery task topic.

  • machineryTask.dtd (DTD), machineryTaskbodyConstraint.mod
  • machineryTask.xsd, machineryTaskbodyConstraintMod.xsd, machineryTaskbodyConstraintIntMod.xsd (Schema)
Parent topic: 2.2.2 Technical content: Document and information types
Previous topic: 2.2.2.4 Task topic (strict task)
Next topic: 2.2.2.6 Glossary entry topic


Glossary entry topic

2.2.2.6 Glossary entry topic

Each glossary entry <glossentry> topic defines a single sense of one term. Besides identifying the term and providing a definition, the topic accommodates basic terminology information, such as part of speech. A glossentry topic may also include acronyms and acronym expansions. Glossentry topics may be assembled by authors or processes to create glossaries for various purposes, including books, websites, or other projects.

The purpose of the glossary entry topic

Defining terminology in a glossary ensures that a team of writers uses the same term for the same concept. A glossary added to a book or available online in conjunction with other subject matter provides the reader with definitions of unfamiliar terms and expands acronyms.

The structure of the glossentry topic

The top-level element for a DITA glossentry topic is the <glossentry> element. Every glossentry topic contains a <glossterm> and a <glossdef> element and optional <related-links>.

Where a term has multiple senses, the writer should create multiple glossentry topics with the same term in the <glossterm> element but different definitions in the <glossdef> element. A process can collate and group glossentry topics by term when generating formatted output. Note that definitions with the same term in one language can have different terms in other languages, so translations can result in different collation and grouping of the same set of glossentry topics.

Here is an example of a simple glossentry topic:

<glossentry id="ddl">
    <glossterm>Data Definition Language</glossterm>
    <glossdef>A language used for defining database schemas.</glossdef>
</glossentry>
To create a glossary, authors can group multiple entries together by
  • authoring in a single document using the Glossary group document type
  • authoring in a single document under a container topic using the ditabase document type
  • referencing the glossentry topics from a map
  • using an automated process
For example, an automated process may assemble glossentry topics from a repository based on the <term> markup in a particular collection of topics.

Acronyms defined within glossentry topics

The glossentry topic may be used to provide expansions of acronyms in online text and assist in the proper translation of acronyms into multiple languages. The acronym elements of the glossentry topic include the following:
  • <glossterm> to enter the full text to which the acronym refers
  • <glossSurfaceForm> to provide the appropriate rendering of the full text plus the acronym in each language
  • <glossAcronym> to provide the acronym text itself

Here is an example of an acronym used in the glossentry topic:

<glossentry id="wmd" xml:lang="en">
  <glossterm>Weapons of Mass Destruction</glossterm>
  <glossBody>
    <glossSurfaceForm>Weapons of Mass Destruction (WMD)</glossSurfaceForm>
    <glossAlt>
      <glossAcronym>WMD</glossAcronym>
    </glossAlt>
  </glossBody>
</glossentry>

Here is an example of how the glossentry topic would be translated into Spanish:

<glossentry id="wmd" xml:lang="es">
  <glossterm>armas de destrucción masiva</glossterm>
  <glossBody>
    <glossSurfaceForm></glossSurfaceForm>
    <glossAlt>
      <glossAcronym></glossAcronym>
    </glossAlt>
  </glossBody>

Note that because no acronym exists for the term in Spanish, the <glossSurfaceForm> and <glossAcronym> elements are left blank.

In some languages, the surface form that expands the acronym in its first use handles the formatting differently than in English. For example, in Polish, the acronym precedes the expansion.

<glossentry id="eu" xml:lang="pl">
  <glossterm>Unia Europejska</glossterm>
  <glossBody>
    <glossSurfaceForm>UE (Unia Europejska)</glossSurfaceForm>
    <glossAlt>
      <glossAcronym>UE</glossAcronym>
    </glossAlt>
  </glossBody>
</glossentry>

For more information about the correct use of acronym expansions in multiple languages, see Best Practice for Managing Acronyms and Abbreviations in DITA, produced by the DITA Translation Subcommittee. http://www.oasis-open.org/committees/download.php/29734/AcronymBestPractice_08112008.doc

Modules

The following DITA modules are provided for the glossary entry topic.
Note: The glossary.dtd, glossary.ent, and glossary.mod are deprecated versions of the files glossentry.dtd., glossentry.ent, and glossentry.mod. The deprecated files are included in DITA 1.2 to provide backward compatibility with DITA 1.0 and 1.1.
  • glossentry.dtd, glossentry.ent, glossentry.mod (DTD)
  • glossentryMod.xsd, glossentryGrp.xsd (Schema)
Parent topic: 2.2.2 Technical content: Document and information types
Previous topic: 2.2.2.5 Machinery task topic
Next topic: 2.2.2.7 Glossary group topic


Glossary group topic

2.2.2.7 Glossary group topic

Glossary group <glossgroup> topics may be used to contain multiple glossentry topics in a single collection file.

The glossgroup topic allows authors to include one or more glossentry topics in a single collection file rather than authoring each glossentry topic in a separate file. The glossgroup topic is a specialization of concept.

Modules

The following DITA modules are provided for the glossgroup topic.

  • glossgroup.dtd, glossgroup.ent, glossgroup.mod (DTD)
  • glossgroup.xsd, (Schema)
Parent topic: 2.2.2 Technical content: Document and information types
Previous topic: 2.2.2.6 Glossary entry topic
Next topic: 2.2.2.8 Bookmap


Bookmap

2.2.2.8 Bookmap

The DITA bookmap specialization represents the key markup requirements for managing DITA content through book-oriented publication processes, including book metadata and book structures for organizing content.

The purpose of the bookmap specialization

Books and other printed media are popular ways to present DITA content. By specializing the general DITA map structure into the general structure and subject areas used by most book-oriented DTDs, bookmaps enable users to organize their DITA information into front matter, parts, chapters, and so forth. A rich set of metadata allows for recording information about the book, such as its authors and owners, versions, and production history.

The structure of the bookmap specialization

The <bookmap> element is the top-level element for a DITA bookmap. Most of the content for a bookmap is optional, allowing for specializations that further restrict the bookmap model..

A bookmap allows the following parts:

  • An intial title or booktitle (booktitle has more semantics)
  • Book metadata (publisher, author, copyright holders and dates, etc.)
  • Front matter (placement for Table of Contents and other preliminary information)
  • Any number of chapters or parts (parts can group chapters, chapters can group topics)
  • An appendices section (similar to a part or a chapter, can group multiple appendices
  • Back matter (similar to front matter, notices, glossary, index, etc.)
  • Relationship table

In typical book-oriented DTDs or schemas, authors commonly manage major content structures as external entities, separate from the body of the book, and referenced as imbedded elements into the overall structure. Bookmap follows the same organizational approach, using the topicref-based structure of DITA maps as the archetype for the major divisions of a book.

Here is an example of a simple bookmap. It includes several mechanisms to include chapter content:
  • Referencing a DITA map
  • Referencing a DITA topic
  • Nesting <topicref> elements
<bookmap id="taskbook">
  <booktitle>
    <mainbooktitle>Product tasks</mainbooktitle>
    <booktitlealt>Tasks and what they do</booktitlealt>
  </booktitle>
  <bookmeta>
    <author>John Doe</author>
    <bookrights>
      <copyrfirst>
        <year>2006</year>
      </copyrfirst>
      <bookowner>
        <person href="task_preface.dita>Jane Doe</person>
      </bookowner>
    </bookrights>
  </bookmeta>
  <frontmatter>
    <preface/>
  </frontmatter>
  <chapter format="ditamap" href="installing.ditamap"/>
  <chapter href="configuring.dita"/>
  <chapter href="maintaining.dita">
    <topicref href="maintainstorage.dita"/>
    <topicref href="maintainserver.dita"/>
    <topicref href="maintaindatabase.dita"/>
  </chapter>
  <appendix href="task_appendix.dita"/>
  </bookmap>

Modules

The following DITA modules are provided for the bookmap specialization.

  • bookmap.dtd, bookmap.ent, bookmap.mod (DTD)
  • bookmap.xsd, bookmapGrp.xsd, bookmapMod.xsd (Schema)
Parent topic: 2.2.2 Technical content: Document and information types
Previous topic: 2.2.2.7 Glossary group topic
Next topic: 2.2.3 Topic domains: Technical content


Topic domains: Technical content

2.2.3 Topic domains: Technical content

A DITA domain defines a set of elements associated with a particular subject area or authoring requirement. DITA incorporates several domains into the Technical Content specializations. Other domains are incorporated into basic DITA.

The elements in a domain are defined in a domain module which can be integrated with a topic type to make the domain elements available within the topic type structure. Currently the following domains are provided as part of the Technical Content specializations:

Table 1. Technical content domains. DITA includes domain specializations that are especially useful for authoring technical content. The typographic, utilities, and indexing domains associated with Base DITA are described under DITA Markup.
Domain | Description | Short name | Module name
Programming | For describing programming and programming languages | pr-d | programmingDomain.mod (DTD) programmingDomain.ent programmingDomain.xsd (Schema)
Software | For describing software | sw-d | softwareDomain.mod (DTD) softwareDomain.ent softwareDomain.xsd (Schema)
User interface | For describing elements in a user interface | ui-d | uiDomain.mod (DTD) uiDomain.ent uiDomain.xsd (Schema)
Hazard statements | For providing detailed information about safety hazards | hazard-d | hazardstatementDomain.mod (DTD) hazardstatementDomain.ent hazardstatementDomain.xsd (Schema)
Abbreviated form | For linking between a text reference to a glossentry topic. A specialization of <term> to provide an <abbreviated-form> element | abbrev-d | abbreviateDomain.mod (DTD) abbreviateDomain.ent abbreviateDomain.xsd (Schema)
Glossary reference | For linking from a term to its glossary topic | glossref-d | glossrefDomain.mod (DTD) glossrefDomain.ent glossrefDomain.xsd (Schema)

The technical content domain specializations, like all domain specializations, may be included in the DITA document types beyond those in the technical content section. The DITA document types in the technical content section make use of other domain specializations in addition to those listed in the table.

The elements and attributes included in specific domain specializations are described in the domain elements of the DITA 1.2 Language Reference.

Parent topic: 2.2 Architectural Specification: Technical Content Version
Previous topic: 2.2.2.8 Bookmap
Next topic: 2.2.4 The xNAL domain


The xNAL domain

2.2.4 The xNAL domain

The DITA xNAL domain specialization defines a number of metadata elements and attributes that are useful in representing personal/organizational names and addresses. The metadata can be used to identify authors and content owners. The OASIS xNAL Standard (extensible Name and Address Langauge) was selected to represent close mappings from the DITA bookmap metadata content model to an existing standard. xNAL is included in the Bookmap and the LearningBookmap document types.

The OASIS Customer Information Quality (CIQ) standard for global-customer information management contains the definition of the OASIS extensible Name and Address Language (xNAL) metadata elements. Version 2 of the standard states:

The objective of xNAL is to describe a common structure for Personal/Organization Names and Addresses that would enable any applications that want to represent customer names and addresses in a common standard format. The applications could be CRM/e-CRM, Customer Information Systems, Data Quality (Parsing, Matching, Validation, Verification, etc.), Customer Data Warehouses, Postal services, etc.

However, any party for its own purposes and applications may use xNAL grammar or parts of it.

The DITA xNAL specialization is based on the OASIS extensible Name and Address Language metadata elements. Due to differences between the two processing architectures, the DITA xNAL domain does not incorporate all of the definitions from the OASIS xNAL standard directly. Instead, there is a transformational equivalence between the DITA and OASIS xNAL definitions for names and addresses. This equivalence enables XML-aware tools in workflow systems to capture and manipulate names and addresses in a standard manner.

The xNAL domain is available for use in the bookmap and learningBookmap document types, which are distributed as part of the DITA 1.2 specification. It can be included in specialized DITA document types that require metadata for names and addresses.

Parent topic: 2.2 Architectural Specification: Technical Content Version
Previous topic: 2.2.3 Topic domains: Technical content
Next topic: 2.3 Architectural Specification: Learning and Training Version


Architectural Specification: Learning and Training Version

2.3 Architectural Specification: Learning and Training Version

DITA 1.2 introduces the Learning and Training specialization, which is designed for developing instructional materials. It contains all of base DITA and some (but not all) parts of the Technical Content package.

  • 2.3.1 Overview
    The DITA 1.2 Learning and Training specialization addresses several key problems facing developers and consumers of instructional content.
  • 2.3.2 Objectives of the DITA Learning and Training Specialization
    The DITA Learning and Training specialization builds on best practices for modular content design, following DITA principles.
  • 2.3.3 A learning objects approach to learning and training content
    The DITA Learning and Training specialization applies DITA principles and best practices for using topic-based and modular content to plan, develop, and deliver learning and training content.
  • 2.3.4 Use cases
    Several use cases inform the design and development of the DITA Learning and Training Specialization.
  • 2.3.5 Summary of learning topic, map, and domain designs
    The DITA 1.2 Learning and Training specialization provides a set of specialized DITA topics, a learning interactions domain, a learning metadata domain, and a learning map domain to support creating and delivering structured learning content.
Parent topic: 2 Architectural specification
Previous topic: 2.2.4 The xNAL domain
Next topic: 2.3.1 Overview


Overview

2.3.1 Overview

The DITA 1.2 Learning and Training specialization addresses several key problems facing developers and consumers of instructional content.

Today's learners confront a complex world with many inter-related bits and pieces of information, many different ways to access that information, and a strong need to identify the connection points, the objectives, and the context for what to know and what to learn.

In this environment, developers of learning and training content face many challenges, including:
  • How to find the context for developing and delivering the right content to the right person at the right time?
  • How to identify the learning goals and objectives?
  • Who and how many are the audiences?
  • How to pull together and integrate content from many different sources and content providers?
  • How to enable customers and partners to add, integrate, assemble, and deliver their own content?
These key challenges and issues for delivery of learning and training content mirror long-standing pain points and requirements for content delivery in general.
  • Content consumers value consistency of content and learning experiences.
  • They desire management of content to make it shareable across and within teams.
  • They seek to simplify the information needed to support the complex environments.
  • Finally, they want a content development process that can enable the assembly and delivery of custom content that addresses specific learning contexts and use cases.
Parent topic: 2.3 Architectural Specification: Learning and Training Version
Previous topic: 2.3 Architectural Specification: Learning and Training Version
Next topic: 2.3.2 Objectives of the DITA Learning and Training Specialization


Objectives of the DITA Learning and Training Specialization

2.3.2 Objectives of the DITA Learning and Training Specialization

The DITA Learning and Training specialization builds on best practices for modular content design, following DITA principles.

The objectives of the specialization include the following:
  1. Provide a general top-level design for authoring of education content with good learning architecture, following DITA principles and best practices.
    Some specifics of good DITA design for learning content include:
    1. offers a starter set of specialized topic types that support structured, intent-based authoring of content for learning and training, including assessments
    2. provides a map domain for structuring the specialized learning topics as reusable learning objects, and for managing the linking and relationships among them
    3. offers basic map-driven processing to support topic linking, relationships, and simple sequencing
    4. includes a starter set of commonly-used learning interactions, for use in testing and assessment
    5. provides support for learning metadata based on the IEEE standard for learning objects metadata (LOM), for use in both topics and maps
  2. Establish guidelines that promote best practices for applying standard DITA approaches to learning content, which include:
    1. separation of presentation and content (as much as possible)
    2. separation of content and context
    3. single sourcing, repurposing, and reuse
  3. Provide basic support for processing DITA content for delivery as learning and training in a variety of forms, including print and presentation delivery to support instructor-led training (ILT) and web delivery for distance learning.
  4. Provide a framework for developing targeted support for processing DITA learning content for delivery with standards-based learning, specifically targeting SCORM. Extend DITA processing to support basic SCORM packaging and required SCORM LMS runtime behaviors. Build on best practices for behaviors to drive and present the interactions.
  5. Build on existing DITA infrastructures as much as possible, so learning content developers do not have to start from scratch because with minimal adaptation they can use standard approaches for DITA content and reuse content previously developed for other purposes.
Note: Simply using the content models described in this specification, of course, does not ensure quality learning content. Quality learning content only results from good instructional design and in-depth learning needs analysis.
Parent topic: 2.3 Architectural Specification: Learning and Training Version
Previous topic: 2.3.1 Overview
Next topic: 2.3.3 A learning objects approach to learning and training content


A learning objects approach to learning and training content

2.3.3 A learning objects approach to learning and training content

The DITA Learning and Training specialization applies DITA principles and best practices for using topic-based and modular content to plan, develop, and deliver learning and training content.

The reusable learning objects, or RLO, approach to learning content derives from the pioneering work of learning content designers at several companies, including Autodesk®, Oracle®, and Cisco®. Author Peder Jacobsen defines an RLO as "a discrete reusable collection of content used to present and support a single learning objective." With this approach, it is possible to gather a pool of information objects and make them available for reuse and repurposing in a variety of learning delivery contexts.

There is a strong affinity between the DITA topic-based, modular approach to content in general, and the learning objects approach to learning content in particular.

Working assumptions about learning content and how to support authoring and delivering it with DITA include the following:
  • The DITA Learning and Training specialization builds on a reusable learning objects (RLO) approach to learning content.
  • DITA topic types are the basic building blocks for learning objects and specify the meaning and intention of content provided in instructional and information objects.
  • DITA domains provide the mechanism for defining interactions, which can be used across the learning topic types.
  • DITA domains also provide the mechanism for defining learning metadata, which can be assigned either in topics or in maps.
  • DITA maps arrange the DITA learning topics into a hierarchy of learning objects and group such content for delivery as lessons, modules, and courses.
  • DITA specialization provides the mechanism for creating the learning-based topic types, domains, and maps needed for instructional and information object content requirements.
Figure 1. Learning objects and specialized DITA learning and training topic types

This figure shows the composition of learning objects as a) instructional objects, b) information objects, and c) the specialized DITA topic types to support them.

Learning objects and the DITA learning types that support them
In this approach, a learning object comprises a "discrete reusable collection of content used to present and support a single learning objective," and consists of two primary information components:
  • instructional objects, which provide the structured framework for a learning experience. The learningOverview, learningSummary, and learningAssassessment topic types provide content for instructional objects.
  • information objects, which provide the source learning content - the topic-based learning content and other supplemental content that supports the learning goals identified in the instructional objects. The learningContent topic type provides content for information objects.
  • instructional plans, which identify the learning goals, needs, and objectives. The learningPlan topic type provides content for instructional plans.
Figure 2. Learning content design, authoring, and delivery through DITA specialization

This picture shows the end-to-end process for designing, authoring, and delivering specialized learning content with DITA.
The end-to-end process for designing, authoring, and delivery specialized learning content with DITA.

In this approach, a learning content developer:
  1. Uses learning map elements to identify the learning objects and the supporting content needed to address specific learning goals and objectives.
  2. Uses learning topic elements to structure the learning content.
  3. Applies learning metadata elements to describe specific characteristics of the learning content, following a sub-set of the IEEE LOM standard.
  4. Constructs specific build maps and relationship tables to organize learning objects for delivery as a course with specific output and delivery needs.
  5. Invokes processing to generate specific learning deliverables, based on the default processing available with DITA content and specialized as needed for learning-specific purposes and delivery formats.
Parent topic: 2.3 Architectural Specification: Learning and Training Version
Previous topic: 2.3.2 Objectives of the DITA Learning and Training Specialization
Next topic: 2.3.4 Use cases


Use cases

2.3.4 Use cases

Several use cases inform the design and development of the DITA Learning and Training Specialization.

Enable indexing, searching, and retrieval of learning content
By structuring content with DITA topics and maps as self-contained learning objects matched with appropriate DITA metadata, it is possible to enable fast indexing, search, and retrieval of learning content that meets specific learning goals and objectives.
Creating custom courses quickly
A company has a large inventory of topic-based content that is used to provide technical and troubleshooting information about a set of componentized software products. It desires to enable field engineers to quickly identify technical content that is suitable for providing on-site training. The DITA Learning and Training Specialization enables field engineers to draw on their inventory of topics and quickly assemble learning content to meet specific customer needs.
Making technical content available for direct sharing and reuse in learning and training
A DITA learning specialization makes it possible to define a context for and directly assemble and use existing technical content for delivery as learning and training. The DITA approach identifies consistent structures and patterns and leverages them to enable a consistent approach for sharing content across teams. The result is much more opportunity to share content between different providers and across areas of expertise, to learn from each other, and to deliver content and the learning experience consistently. As a result, instead of copy, paste, and make unique as the norm, we have write once and share with others as the new norm.
Parent topic: 2.3 Architectural Specification: Learning and Training Version
Previous topic: 2.3.3 A learning objects approach to learning and training content
Next topic: 2.3.5 Summary of learning topic, map, and domain designs
Resources
"Recycling Knowledge with Learning Objects," by Ruth Clark.
"Thinking XML: Learning Objects Metadata," by Uche Obguji (IBM developerWorks, 2003).
"DITA in Education," by Dan Schneider, EduTech Wiki.
"An XML-based information architecture for learning content," by John Hunt and Robert Bernard (IBM developerWorks, 2005).
"Design patterns for information architecture with DITA map domains," by Erik Hennum, Don Day, John Hunt, and Dave Schell (IBM developerWorks, 2004).


Summary of learning topic, map, and domain designs

2.3.5 Summary of learning topic, map, and domain designs

The DITA 1.2 Learning and Training specialization provides a set of specialized DITA topics, a learning interactions domain, a learning metadata domain, and a learning map domain to support creating and delivering structured learning content.

Learning topic types

The following specialized DITA topic types provide support for creating learning and training content.

Learning Plan topic type
Describes learning needs and goals, instructional design models, task analyses, learning taxonomies, and other information necessary to the lesson planning process.
Learning Overview topic type
Identifies the learning objectives and includes other information helpful to the learner, such prerequisites, duration, and intended audience.
Learning Content topic type
Provides the learning content itself and enables direct use of content from DITA task, concept, and reference topics, as well as additional content of any topic type that supports specific objectives declared in the Learning Overview topic type.
Learning Summary topic type
Recaps and provides context for the learning objectives and provides guidance to reinforce learning and long-term memory.
Learning Assessment topic type
Presents instruments that measure progress, encourage retrieval, and stimulate reinforcement of the learning content and can be presented before the content as a pre-assessment or after the content as a post-assessment checkpoint or test.

Learning map domain

Use the learning map domain to organize groups of topics as learning objects.

Note: The learning map domain is part of the learningMap and the learningBookmap document types. As these learning map structures are delivered as a domain specialization rather than as a structural specialization, it is possible to extend any type of DITA map to include these structures.
learningGroup
A map container and optional topic reference to introduce and group learning objects into higher-level organizations, such as course-level, module-level, or lesson-level. A learningGroup can contain other learningGroup elements, allowing you to organize learning content at course, module, or other higher levels of hierarchy.
learningObject
A map container and optional topic reference to introduce and group the topic references for a learning object.
learningPlanRef
A topic reference to a learning plan or other topic that provides the learning plan.
learningOverviewRef
A topic reference to a learning overview or other topic that introduces the learning object.
learningContentRef
A topic reference to a learning content topic, or a topic, task, concept, reference or other specialized topic.
learningContentComponentRef
A topic reference to a learning content topic, or a topic, task, concept, reference or other specialized topic.
learningSummaryRef
A topic reference to a learning summary or other topic that provides the summary.
learningPreAssessmentRef
A topic reference to a learning assessment or other topic that is used as a pre-assessment.
learningPostAssessmentRef
A topic reference to a learning assessment or other topic that is used as a post-assessment.

Learning interactions domain

The learning interactions domain defines a set of basic learning interaction elements as a DITA domain.
lcOpenQuestion
Poses an open-ended question in an assessment interaction.
lcTrueFalse
Presents the learner with two choices, one correct, the other incorrect, often presented as true/false or yes/no responses.
lcSingleSelect
Presents three or more choices, only one of which is correct.
lcMultipleSelect
Presents two or more choices, two or more of which are correct.
lcMatching
In a list of paired choices, the learner identifies the correct choice that matches another choice.
lcHotspot
Presents an image, and the learner clicks on one or more regions to indicate a choice.
lcSequencing
Presents choices in a list that the learner must arrange in a correct ordered sequence.

Learning metadata domain

The learning metadata domain defines a set of basic learning metadata elements as a DITA domain and available for use in the learning topic types, as specialized prolog metadata and in the learning map domain, as specialized topicmeta.

lcLom makes the learning metadata elements available in the learning topics and learning map domain.

Elements in lcLom include:
  • lomAggregationLevel
  • lomContext
  • lomCoverage
  • lomDifficulty
  • lomInstallationRemarks
  • lomIntendedUserRole
  • lomInteractivityLevel
  • lomInteractivityType
  • lomLearningResourceType
  • lomOtherPlatformRequirements
  • lomSemanticDensity
  • lomStructure
  • lomTechRequirement
  • lomTypicalAgeRange
  • lomTypicalLearningTime

Instructor notes

The learning interactions domain also makes available an lcInstructornote element for providing instructor-specific information.

Parent topic: 2.3 Architectural Specification: Learning and Training Version
Previous topic: 2.3.4 Use cases
Next topic: 3 Language reference


Language reference

3 Language reference

The language reference provides information about each element in the DITA vocabulary modules. It is divided into three sections: Base, technical content, and learning and training. It also includes a section titled "Attributes" that applies to all three of the preceding sections.

  • 3.1 Base elements
    Base elements include the core DITA topic and map elements that are the building blocks for other specializations as well as several basic specializations that are not applicable to a specific information domain.
  • 3.2 Technical content elements
    Elements in the technical content section include the original Concept, Task, and Reference specializations, as well as the Bookmap and Glossary specializations added with DITA 1.1. It also includes domains designed primarily for technical content, such as the task requirements and software domains.
  • 3.3 Learning and training elements
    Elements in the Learning and Training section include specialized topic types designed for learning and training content, as well as specialized domain elements for organizing learning content within maps, specifying learning metadata, and describing learning interactions.
  • 3.4 Attributes
    Many DITA attributes are reused in groups or are too complex to describe in the usual table cell format. Those attributes are collected in this section.
  • 3.5 Element quick reference
Previous topic: 2.3.5 Summary of learning topic, map, and domain designs
Next topic: 3.1 Base elements


Base elements

3.1 Base elements

Base elements include the core DITA topic and map elements that are the building blocks for other specializations as well as several basic specializations that are not applicable to a specific information domain.

  • 3.1.1 Topic elements
    The base topic elements include elements that make up the core building blocks of the DITA topic, such as topic, body, and related-links, as well as elements like <p> and <ph> that are used in many topic specializations. Some of these elements are also available inside the <topicmeta> map element.
  • 3.1.2 Map elements
    Map elements include the core components of DITA maps, such as <topicref> and <reltable>, as well as general purpose map specializations in the map group domain.
  • 3.1.3 Metadata elements
    Metadata elements include information that is located within the <topicmeta> element (in maps) or <prolog> element (in topics), as well as indexing elements that can be placed in additional locations within topic content.
  • 3.1.4 Domain elements
    General purpose domains are not specific to any type of information, such as the hazard statement domain that provides elements for describing hazardous situations.
  • 3.1.5 Classification elements
    Classification elements support managing metadata. Those in the Subject Scheme map are used to define controlled values, and to bind them to DITA attributes as enumerations. Those declared in the classification domain are used in other maps to classify content according to the scheme.
  • 3.1.6 Specialization elements
    Several DITA elements exist either for architectural reasons or for support of specialized markup yet to be designed. Although there is little need to use these elements unless you are directed to, some of them, such as <state>, can be used if your content makes use of these semantic distinctions. For example, a discussion of signals on a gate of an integrated logic circuit might use the state element to represent either on or off conditions of that gate.
  • 3.1.7 Legacy conversion elements
    Conversion elements exist primarily to aid in the conversion of content to DITA.
  • 3.1.8 DITAVAL elements
    A conditional processing profile (DITAVAL file) is used to identify which values are to be used for conditional processing during a particular output, build, or some other purpose. The profile should have an extension of .ditaval.
Parent topic: 3 Language reference
Previous topic: 3 Language reference
Next topic: 3.1.1 Topic elements


Topic elements

3.1.1 Topic elements

The base topic elements include elements that make up the core building blocks of the DITA topic, such as topic, body, and related-links, as well as elements like <p> and <ph> that are used in many topic specializations. Some of these elements are also available inside the <topicmeta> map element.

  • 3.1.1.1 Basic topic elements
    The generic topic structure is used for untyped topics. While much of the DITA architecture is built on generic topics, it is generally better to use more specific information types (such as concept, task, or reference) when they are available.
  • 3.1.1.2 Body elements
    The body elements support the most common types of content authoring for topics: paragraphs, lists, phrases, figures, and other common types of exhibits in a document.
  • 3.1.1.3 Table elements
    DITA topics support two types of tables. The <table> element uses the OASIS Exchange Table Model (formerly known as the CALS table model). The OASIS table supports the spanning of multiple rows or columns for special layout or organizational needs, and provides a wide variety of controls over the display properties of the data and even the table structure itself.
  • 3.1.1.4 Related links elements
    The related-links section of DITA topics is a special structure that contains links. Links support navigation from a topic to other related topics or resources.
Parent topic: 3.1 Base elements
Previous topic: 3.1 Base elements
Next topic: 3.1.1.1 Basic topic elements


Basic topic elements

3.1.1.1 Basic topic elements

The generic topic structure is used for untyped topics. While much of the DITA architecture is built on generic topics, it is generally better to use more specific information types (such as concept, task, or reference) when they are available.

For an answer to the question "What are topics?" and more details on when to use different information types, please refer to DITA topics.

  • 3.1.1.1.1 topic
    The <topic> element is the top-level DITA element for a single-subject topic or article. Other top-level DITA elements that are more content-specific are <concept>, <task>, <reference>, and <glossentry>, all of which are specializations of the <topic> element.
  • 3.1.1.1.2 title
    The <title> element contains a heading or label for the main parts of a topic, including the topic as a whole, its sections and examples, and its labelled content, such as figures and tables. Beginning with DITA 1.1, the element may also be used to provide a title for a map. With DITA 1.2, the element is also available in reltables, although in the reltable a title is typically used for reference information (not for content displayed to an end user).
  • 3.1.1.1.3 titlealts
    The <titlealts> element allows the insertion of alternate titles, such as titles that should be used in creating a table of contents for navigation or a title specific to search results. When the <titlealts> element is absent, the title element is used for all title purposes.
  • 3.1.1.1.4 searchtitle
    The <searchtitle> element is used to specify a title that should be displayed by search tools that locate the topic. This is most useful when the topic has a title that makes sense in the context of a single information set, but may be too general in a list of search results; for example, a topic title of "Markup example" may make sense as part of a guide to DITA, but when found among thousands of unrelated topics, a search title of "DITA markup example" is more useful.
  • 3.1.1.1.5 navtitle
    The navigation title (<navtitle>) element is one of a set of alternate titles that can be included inside the <titlealts> element. This navigation title may differ from the first level heading that shows in the main browser window. Use <navtitle> when the actual title of the topic isn't appropriate for use in a table of contents, navigation pane, or online content (for example, because the actual title is too long). Beginning with DITA 1.2, the navtitle element is also available in the <topicmeta> element in a <topicref> in a map, and its use is preferred over the topicref's navtitle attribute.
  • 3.1.1.1.6 shortdesc
    The short description (<shortdesc>) element occurs between the topic title and the topic body, as the initial paragraph-like content of a topic, or it can be embedded in an abstract element. The short description, which represents the purpose or theme of the topic, is also intended to be used as a link preview and for searching. The <shortdesc> element also can be used in a DITA map.
  • 3.1.1.1.7 abstract
    The abstract element occurs between the topic title and the topic body, as the initial content of a topic. It can contain paragraph-level content as well as one or more shortdesc elements which can be used for providing link previews or summaries. The <abstract> element cannot be overridden by maps, but its contained <shortdesc> elements can be, for the purpose of creating link summaries or previews.
  • 3.1.1.1.8 body
    The <body> element is the container for the main content of a <topic>.
  • 3.1.1.1.9 bodydiv
    The <bodydiv> element is used to contain informal blocks of information within the body of a topic. The bodydiv element is specifically designed to be a grouping element, without any explicit semantics, other than to organize subsets of content into logical groups that are not intended or should not be contained as a topic. As such, it does not contain an explicit title to avoid enabling the creation of deeply nested content that would otherwise be written as separate topics. Content that requires a title should use a section element or a nested topic.
  • 3.1.1.1.10 related-links
    The related information links of a topic (<related-links> element) are stored in a special section following the body of the topic. After a topic is processed into its final output form, the related links are usually displayed at the end of the topic, although some Web-based help systems might display them in a separate navigation frame.
  • 3.1.1.1.11 dita
    The <dita> element provides a top-level container for multiple topics when you create documents using the ditabase document type. The <dita> element lets you create any sequence of concept, task, and reference topics, and the ditabase document type lets you nest these topic types inside each other. The <dita> element has no particular output implications; it simply allows you to create multiple topics of different types at the same level in a single document.
Parent topic: 3.1.1 Topic elements
Previous topic: 3.1.1 Topic elements
Next topic: 3.1.1.1.1 topic


topic

3.1.1.1.1 topic

The <topic> element is the top-level DITA element for a single-subject topic or article. Other top-level DITA elements that are more content-specific are <concept>, <task>, <reference>, and <glossentry>, all of which are specializations of the <topic> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, glossary, glossentry, glossgroup, reference, task, machineryTask, learningAssessment, learningOverview, learningPlan, learningSummary | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (body) (optional) then (related-links) (optional) then (topic) (any number) )
ditabase | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (body) (optional) then (related-links) (optional) then (topic or concept or task or reference or glossentry or glossgroup) (any number) )
learningContent | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (body) (optional) then (related-links) (optional) then ( (no-topic-nesting) (optional) ) (any number) )

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, reference, task (strict), task (general), machineryTask | topic
ditabase | dita, topic, concept, task, reference
glossary, glossentry, glossgroup | topic, concept
learningAssessment, learningOverview, learningPlan, learningSummary | topic, learningBase
learningContent | learningBase, learningContent

Inheritance

- topic/topic

Example

<topic id="topic">
 <title>Some little topic</title>
 <body>
  <p>Here's a little topic.</p>
  <ul>
   <li>Some item</li>
   <li>Another item</li>
  </ul>
 </body>
</topic>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1 Basic topic elements
Next topic: 3.1.1.1.2 title


3.1.1.1.2 title

The <title> element contains a heading or label for the main parts of a topic, including the topic as a whole, its sections and examples, and its labelled content, such as figures and tables. Beginning with DITA 1.1, the element may also be used to provide a title for a map. With DITA 1.2, the element is also available in reltables, although in the reltable a title is typically used for reference information (not for content displayed to an end user).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or data or data-about or foreign or unknown or image) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or data or data-about or foreign or unknown or image) (any number)
machineryTask | ( text data or boolean or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or state or data or data-about or foreign or unknown or image) (any number)

Contained by

Doctype | Content model
topic (base) | data, fig, figgroup, table, topic, section, example, linklist
map (base), learningMap | data, fig, figgroup, table, map, reltable, relcolspec
topic (technical content) | data, fig, figgroup, table, topic, section, example, linklist, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
map (technical content) | data, fig, figgroup, table, map, reltable, relcolspec, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
concept | data, fig, figgroup, table, topic, section, example, linklist, concept, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
ditabase | data, fig, figgroup, table, topic, section, example, linklist, concept, task, reference, refsyn, glossProperty, glossgroup, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
glossary, glossentry | data, fig, figgroup, table, topic, section, example, linklist, concept, glossProperty, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
glossgroup | data, fig, figgroup, table, topic, section, example, linklist, concept, glossProperty, glossgroup, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
reference | data, fig, figgroup, table, topic, section, example, linklist, reference, refsyn, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
task (strict), task (general) | data, fig, figgroup, table, topic, section, example, linklist, task, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
bookmap | data, fig, figgroup, table, map, reltable, relcolspec, bookmap, syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment
classifyMap | data, fig, figgroup, table, map, reltable, relcolspec, topicSubjectTable
subjectScheme | data, fig, figgroup, table, map, reltable, relcolspec, subjectScheme, subjectRelTable
machineryTask | data, fig, figgroup, table, topic, section, example, linklist, task
learningAssessment | data, fig, figgroup, table, topic, section, example, linklist, learningBase, lcIntro, lcObjectives, lcAudience, lcDuration, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, learningAssessment, lcInteractionBase, lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion
learningBookmap | data, fig, figgroup, table, map, reltable, relcolspec, bookmap
learningContent | data, fig, figgroup, table, topic, section, example, linklist, learningBase, lcIntro, lcObjectives, lcAudience, lcDuration, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, task, concept, reference, refsyn, learningSummary, learningAssessment, learningContent, lcInteractionBase, lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion
learningOverview | data, fig, figgroup, table, topic, section, example, linklist, learningBase, lcIntro, lcObjectives, lcAudience, lcDuration, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, learningOverview, lcInteractionBase, lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion
learningPlan | data, fig, figgroup, table, topic, section, example, linklist, learningBase, lcIntro, lcObjectives, lcAudience, lcDuration, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, learningPlan, lcProject, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcNeedsAnalysis, lcOrganizational, lcPlanAudience, lcWorkEnv, lcTask, lcGapAnalysis, lcGapItem, lcIntervention, lcInterventionItem, lcTechnical, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion
learningSummary | data, fig, figgroup, table, topic, section, example, linklist, learningBase, lcIntro, lcObjectives, lcAudience, lcDuration, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, learningSummary, lcInteractionBase, lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion

Inheritance

- topic/title

Example

<topic id="topic">
 <title>Some little topic</title>
 <body>
  <p>Some discourse.</p>
 </body>
</topic>

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.1 topic
Next topic: 3.1.1.1.3 titlealts


3.1.1.1.3 titlealts

The <titlealts> element allows the insertion of alternate titles, such as titles that should be used in creating a table of contents for navigation or a title specific to search results. When the <titlealts> element is absent, the title element is used for all title purposes.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, ditabase, glossary, glossentry, glossgroup, reference, task, machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (navtitle) (optional) then (searchtitle) (optional) )

Contained by

Doctype | Content model
topic (base), topic (technical content) | topic
concept, glossary, glossentry, glossgroup | topic, concept
ditabase | topic, concept, task, reference
reference | topic, reference
task (strict), task (general), machineryTask | topic, task
learningAssessment | topic, learningBase, learningAssessment
learningContent | topic, learningBase, task, concept, reference, learningSummary, learningAssessment, learningContent
learningOverview | topic, learningBase, learningOverview
learningPlan | topic, learningBase, learningPlan
learningSummary | topic, learningBase, learningSummary

Inheritance

- topic/titlealts

Example

<task id="progexample">
   <title>Example of Required Programming</title>
      <titlealts><navtitle>Programming Example</navtitle></titlealts>
   <taskbody> . . . </taskbody>
</task>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.2 title
Next topic: 3.1.1.1.4 searchtitle


searchtitle

3.1.1.1.4 searchtitle

The <searchtitle> element is used to specify a title that should be displayed by search tools that locate the topic. This is most useful when the topic has a title that makes sense in the context of a single information set, but may be too general in a list of search results; for example, a topic title of "Markup example" may make sense as part of a guide to DITA, but when found among thousands of unrelated topics, a search title of "DITA markup example" is more useful.

When a topic is rendered as XHTML, the contents of the <searchtitle> will typically appear in the XHTML's title element, which used in the result summary for many search engines. This element may not be supported for output formats that do not support distinct search titles for topics.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or ph or b or i or sup or sub or tt or u) (any number)
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol) (any number)
map (technical content), bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or ph or b or i or sup or sub or tt or u or menucascade or uicontrol) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | titlealts
map (base), map (technical content), classifyMap, subjectScheme, learningMap | topicmeta
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

"- topic/searchtitle " when used in topics, and "- map/searchtitle " when used in maps.

Example

In the following example, the general title "Programming Example" is likely very useful in a set of information about XSLT basics; however, the same title is not helpful among a set of search results from the entire internet. In that case, "Example of basic programming in XSLT" will be much more helpful.

<task id="progexample">
 <title>Programming Example</title>
  <titlealts><searchtitle>Example of basic
             programming in XSLT</searchtitle></titlealts>
 <taskbody> . . . </taskbody>
</task>
When searchtitle is used in maps, the element provides a new search title for the topic when used in a specific context. For example, the if the following map includes information about programming in many languages, searches among that information set will be most useful when they return "Example of programming in XSLT":
<topicref href="progexample.dita">
  <topicmeta>
    <navtitle>Programming example</navtitle>
    <searchtitle>Example of programming in XSLT</searchtitle>
  </topicmeta>
</topicref>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.3 titlealts
Next topic: 3.1.1.1.5 navtitle


3.1.1.1.5 navtitle

The navigation title (<navtitle>) element is one of a set of alternate titles that can be included inside the <titlealts> element. This navigation title may differ from the first level heading that shows in the main browser window. Use <navtitle> when the actual title of the topic isn't appropriate for use in a table of contents, navigation pane, or online content (for example, because the actual title is too long). Beginning with DITA 1.2, the navtitle element is also available in the <topicmeta> element in a <topicref> in a map, and its use is preferred over the topicref's navtitle attribute.

When navtitle is used in a map, it functions in the same way as the navtitle attribute; both are used to specify a navigation title for the target of the <topicref> element. That is, the title itself will only be used as an actual navigation title when the title is locked; the title is locked when the closest ancestor topicref element sets or inherits the attribute locktitle="yes". If the title is not locked, processing systems will typically retrieve the current title from the target topic, looking first for a navtitle element and second for the general title.

When both a navtitle element and a navtitle attribute are specified, the navtitle element should be used.

Because the navtitle element is available within topicmeta, and topicmeta is used in many different contexts, it is possible that navtitle can be specified in contexts where a navigation title does not make sense (for example, on the topicgroup element). In those situations, the navtitle element has no defined purpose.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or ph or b or i or sup or sub or tt or u) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or ph or b or i or sup or sub or tt or u or menucascade or uicontrol) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | titlealts
map (base), map (technical content), bookmap, classifyMap, learningBookmap, learningMap | topicmeta
subjectScheme | topicmeta, subjectHeadMeta

Inheritance

- topic/navtitle

Example

Figure 1. Navtitle sample in a topic
<task id=progexample">
 <title>Publishing a DITA information set in PDF</title>
  <titlealts><navtitle>Publishing in PDF</navtitle></titlealts>
 <taskbody> . . . </taskbody>
</task>
Figure 2. Navtitle samples in a map

In this sample, the first title is not locked, and will generally be replaced with a title retrieved from a.dita. The second title is locked, and will be displayed when this map is used as a basis for navigation.

<map xml:lang="en">
  <title>This is a sample map</title>
  <topicref href="a.dita">
    <topicmeta>
      <navtitle>Title of A</navtitle>
    </topicmeta>
  </topicref>
  <topicref href="b.dita" locktitle="yes">
    <topicmeta>
      <navtitle>Short Title for B</navtitle>
    </topicmeta>
  </topicref>
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.4 searchtitle
Next topic: 3.1.1.1.6 shortdesc


shortdesc

3.1.1.1.6 shortdesc

The short description (<shortdesc>) element occurs between the topic title and the topic body, as the initial paragraph-like content of a topic, or it can be embedded in an abstract element. The short description, which represents the purpose or theme of the topic, is also intended to be used as a link preview and for searching. The <shortdesc> element also can be used in a DITA map.

Use the <shortdesc> element when the first paragraph of topic content is simple enough to be suitable for use as a link preview or for summaries. Otherwise use the <abstract> element to provide richer content around the <shortdesc>. See the abstract description for more details on the behavior of <shortdesc> in an abstract.

While inclusion of the <shortdesc> element is not mandated by DITA or the tools, it is recommended that topics contain this element. In cases where a topic contains only one paragraph, then it is preferable to include this text in the <shortdesc> and leave the topic body empty.

The short description should be a single, concise paragraph containing one or two sentences of no more than 50 words.

Type Recommended content
Task

The short description should explain what the task information helps users accomplish, the benefits of the task, or the purpose of the task. Do not simply repeat the title. Try to include information that will help users understand when the task is appropriate or why the task is necessary. Avoid stating the obvious, such as "You can use XYZ to do A" as the only statement in the short description for Task A. In some cases, add more information about why the task is beneficial.

Do not use sentence fragments. Use complete sentences. Avoid starting short descriptions with phrases such as "This topic describes . . . ." or "This topic is about . . . ."
Concept

Introduce the concept and provide a concise answer to the question "What is this?" and in some cases "Why do I care about this?" If the concept is unfamiliar, you can start with a brief definition. Avoid using the short description to lead in or build up to a topic. The short description paragraph should contain the main point of the concept topic. The concept short description should clearly apply to a concept. Avoid turning the concept topic into a task. Do not simply repeat the title.

Do not use sentence fragments. Use complete sentences. Avoid starting short descriptions with phrases such as "This topic describes . . . ." or "This topic is about . . . ."
Reference

Briefly describe what the reference item does, what it is, or what it is used for.

In most cases, use a complete sentence. You can use a sentence fragment only for a topic that is very short, such as an API topic and each of its subtopics. Use consistent phrasing across libraries and information centers so that your information can be seamlessly integrated with another product's information.

Short descriptions in maps

The <shortdesc> element is also available in maps within the <topicmeta> element. In a map, the element specifies that a topic has a short description that is specific to the context of that topicref in that map. When constructing link previews, links that are generated according to the context of the map should use the <shortdesc> content provided in the map rather than the <shortdesc> provided in the topic. The <shortdesc> element in the map allows authors to provide short descriptions for references to non-DITA objects.

The content of the <shortdesc> element also can be used to override the short description of the topic, when the copy-to attribute is specified.
Note: Processors may or may not implement this behavior.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or data or data-about or foreign or unknown or image or draft-comment) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or data or data-about or foreign or unknown or image or draft-comment) (any number)
machineryTask | ( text data or boolean or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or state or data or data-about or foreign or unknown or image or draft-comment) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content) | topic, abstract
map (base), map (technical content), classifyMap, learningMap | topicmeta
concept | topic, abstract, concept
ditabase | topic, abstract, concept, task, reference, glossdef
glossary, glossentry, glossgroup | topic, abstract, concept, glossdef
reference | topic, abstract, reference
task (strict), task (general), machineryTask | topic, abstract, task
bookmap, learningBookmap | topicmeta, bookmeta
subjectScheme | topicmeta, subjectHeadMeta
learningAssessment | topic, abstract, learningBase, learningAssessment
learningContent | topic, abstract, learningBase, task, concept, reference, learningSummary, learningAssessment, learningContent
learningOverview | topic, abstract, learningBase, learningOverview
learningPlan | topic, abstract, learningBase, learningPlan
learningSummary | topic, abstract, learningBase, learningSummary

Inheritance

"- topic/shortdesc " when used in topics, and "- map/shortdesc " when used in maps.

Examples

The following example demonstrates the use of a stand-alone shortdesc inside of a concept topic.

<concept id="concept">
 <title>Introduction to Bird Calling</title>
 <shortdesc>If you wish to attract more birds to your Acme Bird Feeder,
learn the art of bird calling. Bird calling is an efficient way
to alert more birds to the presence of your bird feeder.</shortdesc>
 <conbody>
   <p>Bird calling requires learning:</p>
   <ul>
    <li>Popular and classical bird songs</li>
    <li>How to whistle like a bird</li>
   </ul>
 </conbody>
</concept>

Example: short description within a map

<topicref href="myThing.dita">
  <topicmeta>
    <navtitle>Navigation title for my topic</navtitle>
    <shortdesc>A description of myThing that is specific to this context.</shortdesc>
  </topicmeta>
</topicref>
<topicref href="http://www.example.org" scope="external">
  <topicmeta>
    <navtitle>Example website</navtitle>
    <shortdesc>The example.org address is often used in examples</shortdesc>
  </topicmeta>
</topicref>

Example: abstract with phrase-level short description

<abstract>The abstract is being used to provide more complex content.
    <shortdesc>The shortdesc must be directly contained by the abstract.</shortdesc>
The abstract can put text around the shortdesc.
</abstract>
Topic output
The abstract is being used to provide more complex content. The shortdesc must be directly contained by the abstract. The abstract can put text around the shortdesc.
Preview/summary output
The shortdesc must be directly contained by the abstract.

Example: abstract with block-level short description

<abstract><p>The abstract is being used to provide more complex content.</p>
    <shortdesc>The shortdesc must be directly contained by the abstract.</shortdesc>
<p>The abstract can put text around the shortdesc.</p>
</abstract>
Topic output

The abstract is being used to provide more complex content.

The shortdesc must be directly contained by the abstract.

The abstract can put text around the shortdesc.

Preview/summary output
The shortdesc must be directly contained by the abstract.

Example: abstract with multiple short descriptions

<abstract>The abstract is being used to provide more complex content.
    <shortdesc>The shortdesc must be directly contained by the abstract.</shortdesc>
    <p>The abstract can put text around the shortdesc.</p>
    <shortdesc>There can be more than one shortdesc.</shortdesc>
</abstract>
Topic output

The abstract is being used to provide more complex content. The shortdesc must be directly contained by the abstract.

The abstract can put text around the shortdesc.

There can be more than one shortdesc.

Preview/summary output
The shortdesc must be directly contained by the abstract. There can be more than one shortdesc.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.5 navtitle
Next topic: 3.1.1.1.7 abstract


abstract

3.1.1.1.7 abstract

The abstract element occurs between the topic title and the topic body, as the initial content of a topic. It can contain paragraph-level content as well as one or more shortdesc elements which can be used for providing link previews or summaries. The <abstract> element cannot be overridden by maps, but its contained <shortdesc> elements can be, for the purpose of creating link summaries or previews.

Use the <abstract> element when the initial paragraph of a topic is unsuitable for use as a link preview or for summaries, because, for example, it contains lists or tables, or because only a portion of the paragraph is suitable. Note that when the initial paragraph is suitable as a summary, that content should be placed in a <shortdesc> element rather than in an <abstract> element. The <abstract> element allows for a wider range of content in your initial paragraph, such as lists and tables, and allows you to identify portions of the <abstract> content as useful for previews or summaries by embedding the <shortdesc> element within <abstract>.

When the contained <shortdesc> occurs within phrase-level content, it is treated as phrase-level content and should not create a separate paragraph on output of the topic. When the contained <shortdesc> occurs as a peer to paragraph-level content, it is treated as block-level content and should create a separate paragraph on output of the topic. When multiple <shortdesc> elements are included in an <abstract>, they are concatenated in output of link previews or summaries (separated by spaces).

When a <shortdesc> element occurs in a DITA map, it overrides the short description provided in the topic for the purpose of generating link previews, but does not replace the <shortdesc> in the rendered topic itself. This means that generated links to this topic will use the short description from the map for purposes any link previews provided with the link, while the rendered topic continues to use the short description inside the topic. If the <topicref> element in the DITA map also specifies the copy-to attribute, the content of the <shortdesc> element in the DITA map also overrides the short description provided in the topic. In this case, the rendered topic itself will display the <shortdesc> contents from the map in place of the <shortdesc> originally specified in the topic.
Note: Processors may or may not implement this behavior.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base) | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or shortdesc or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or shortdesc or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or shortdesc or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or shortdesc or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content) | topic
concept, glossary, glossentry, glossgroup | topic, concept
ditabase | topic, concept, task, reference
reference | topic, reference
task (strict), task (general), machineryTask | topic, task
learningAssessment | topic, learningBase, learningAssessment
learningContent | topic, learningBase, task, concept, reference, learningSummary, learningAssessment, learningContent
learningOverview | topic, learningBase, learningOverview
learningPlan | topic, learningBase, learningPlan
learningSummary | topic, learningBase, learningSummary

Inheritance

- topic/abstract

Example: abstract with phrase-level short description

<abstract>The abstract is being used to provide more complex content.
    <shortdesc>The shortdesc must be directly contained by the abstract.</shortdesc>
The abstract can put text around the shortdesc.
</abstract>
Topic output
The abstract is being used to provide more complex content. The shortdesc must be directly contained by the abstract. The abstract can put text around the shortdesc.
Preview/summary output
The shortdesc must be directly contained by the abstract.

Example: abstract with block-level short description

<abstract><p>The abstract is being used to provide more complex content.</p>
    <shortdesc>The shortdesc must be directly contained by the abstract.</shortdesc>
<p>The abstract can put text around the shortdesc.</p>
</abstract>
Topic output

The abstract is being used to provide more complex content.

The shortdesc must be directly contained by the abstract.

The abstract can put text around the shortdesc.

Preview/summary output
The shortdesc must be directly contained by the abstract.

Example: abstract with multiple short descriptions

<abstract>The abstract is being used to provide more complex content.
    <shortdesc>The shortdesc must be directly contained by the abstract.</shortdesc>
    <p>The abstract can put text around the shortdesc.</p>
    <shortdesc>There can be more than one shortdesc.</shortdesc>
</abstract>
Topic output

The abstract is being used to provide more complex content. The shortdesc must be directly contained by the abstract.

The abstract can put text around the shortdesc.

There can be more than one shortdesc.

Preview/summary output
The shortdesc must be directly contained by the abstract. There can be more than one shortdesc.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.6 shortdesc
Next topic: 3.1.1.1.8 body


body

3.1.1.1.8 body

The <body> element is the container for the main content of a <topic>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base) | (dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or data or data-about or draft-comment or foreign or unknown or required-cleanup or bodydiv or example or section) (any number)
topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task | (dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or data or data-about or draft-comment or foreign or unknown or required-cleanup or bodydiv or example or section) (any number)
machineryTask | (dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or data or data-about or draft-comment or foreign or unknown or required-cleanup or bodydiv or example or section) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | (dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or data or data-about or draft-comment or foreign or unknown or required-cleanup or bodydiv or example or section) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | topic

Inheritance

- topic/body

Example

<topic>
<title>Sample title</title>
<prolog><!-- metadata here --></prolog>
<body> <!-- Body content goes here --> </body>
</topic>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.7 abstract
Next topic: 3.1.1.1.9 bodydiv


bodydiv

3.1.1.1.9 bodydiv

The <bodydiv> element is used to contain informal blocks of information within the body of a topic. The bodydiv element is specifically designed to be a grouping element, without any explicit semantics, other than to organize subsets of content into logical groups that are not intended or should not be contained as a topic. As such, it does not contain an explicit title to avoid enabling the creation of deeply nested content that would otherwise be written as separate topics. Content that requires a title should use a section element or a nested topic.

The bodydiv element may nest itself, which means that it may be used by specializers to create structured information within a body. Another common use case for the bodydiv element is to group a sequence of related elements for reuse, so that another topic may reference the entire set with a single conref attribute.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base) | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup or bodydiv or section) (any number)
topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup or bodydiv or section) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup or bodydiv or section) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup or bodydiv or section) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | body, bodydiv

Inheritance

- topic/bodydiv

Example

<topic id="sample" xml:lang="en">
 <title>Sample for bodydiv</title>
 <body>
  <bodydiv id="div">
   <p>This set of information is reusable as a group.</p>
   <p>Lists of three contain three items.</p>
   <ul>
    <li>This is one item.</li>
    <li>This is another item.</li>
    <li>This is the third item.</li>
   </ul>
  </bodydiv>
  <p>This concludes my topic.</p>
 </body>
</topic>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.8 body
Next topic: 3.1.1.1.10 related-links


related-links

3.1.1.1.10 related-links

The related information links of a topic (<related-links> element) are stored in a special section following the body of the topic. After a topic is processed into its final output form, the related links are usually displayed at the end of the topic, although some Web-based help systems might display them in a separate navigation frame.

Links specified within the <related-links> element are typically displayed together with links generated based on a map context; see DITA linking for more information on map based linking.

Processing notes:
  1. Links within a <linklist> element must appear in the order defined, while those outside of a linklist may be sorted and displayed in a different order or location (based upon their role, target, importance, or other qualifiers).
  2. PDF output typically ignores hierarchical links such as those with roles of ancestor, parent, child, descendant, next, previous, or sibling, although this behavior is not required.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, ditabase, glossary, glossentry, glossgroup, reference, task, machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | (link or linklist or linkpool) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content) | topic
concept | topic, concept
ditabase | topic, concept, task, reference, glossentry
glossary, glossentry, glossgroup | topic, concept, glossentry
reference | topic, reference
task (strict), task (general), machineryTask | topic, task
learningAssessment | topic, learningBase, learningAssessment
learningContent | topic, learningBase, task, concept, reference, learningSummary, learningAssessment, learningContent
learningOverview | topic, learningBase, learningOverview
learningPlan | topic, learningBase, learningPlan
learningSummary | topic, learningBase, learningSummary

Inheritance

- topic/related-links

Example

The following indicates that the two external links are always applicable to this topic, regardless of how the topic is used.

<related-links scope="external" format="html">
  <link href="http://www.example.org">
    <linktext>Example 1</linktext>
  </link>
  <link href="http://www.example.com">
    <linktext>Example 2</linktext>
  </link>
</related-links>

Attributes

Name | Description | Data Type | Default Value | Required?
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
role | The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time. See The role attribute for information on supported values. The role attribute values sample and external are deprecated. | (parent | child | sibling | friend | next | previous | cousin | ancestor | descendant | sample | external | other | -dita-use-​conref-​target) | #IMPLIED | No
otherrole | Indicates an alternate role. This value is used when the role attribute is set to other. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.9 bodydiv
Next topic: 3.1.1.1.11 dita


dita

3.1.1.1.11 dita

The <dita> element provides a top-level container for multiple topics when you create documents using the ditabase document type. The <dita> element lets you create any sequence of concept, task, and reference topics, and the ditabase document type lets you nest these topic types inside each other. The <dita> element has no particular output implications; it simply allows you to create multiple topics of different types at the same level in a single document.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase | ( topic or concept or task or reference or glossentry or glossgroup) (one or more)

Contained by

This element is not contained by any other elements.

Inheritance

Not a specializable DITA element.

Example

<dita>
  <concept id="batintro">...</concept>
  <reference id="batparts">...</reference>
  <task id="batfeeding">...</task>
  <task id="battraining">...</task>
  <task id="batcleanup">...</task>
</dita>

Attributes

Name | Description | Data Type | Default Value | Required?
xml:lang | Specifies the language of the element content. The xml:lang attribute and its values are described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. | language token or the null string | #IMPLIED | No
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
Parent topic: 3.1.1.1 Basic topic elements
Previous topic: 3.1.1.1.10 related-links
Next topic: 3.1.1.2 Body elements


Body elements

3.1.1.2 Body elements

The body elements support the most common types of content authoring for topics: paragraphs, lists, phrases, figures, and other common types of exhibits in a document.

  • 3.1.1.2.1 alt
    The alt element provides alternate text for an image. It is equivalent to the alt attribute on the image element; since the attribute is deprecated, use the alt element instead. As an element, alt provides direct text entry within an XML editor and is more easily accessed than an attribute for translation.
  • 3.1.1.2.2 cite
    The <cite> element is used when you need a bibliographic citation that refers to a book or article. It specifically identifies the title of the resource.
  • 3.1.1.2.3 dd
    The definition description (<dd>) element contains the description of a term in a definition list entry.
  • 3.1.1.2.4 desc
    The <desc> element contains the description of the current element. In elements that also allow a title, such as table and fig, this is used to provide more information than is appropriate for the title. In the xref and link elements it contains a description of the target; processors may (but need not) choose to display this as hover help for a link. In the object element, desc provides alternate content to use when the context does not permit displaying the object.
  • 3.1.1.2.5 ddhd
    The <ddhd> element contains an optional heading or title for a column of descriptions or definitions in a definition list.
  • 3.1.1.2.6 dl
    A definition list (<dl>) is a list of terms and corresponding definitions. The term (<dt>) is usually flush left. The description or definition (<dd>) is usually either indented and on the next line, or on the same line to the right of the term. However, actual rendering is up to the rendering engine.
  • 3.1.1.2.7 dlentry
    In a definition list, each list item is defined by the definition list entry (<dlentry>) element. The definition list entry element includes a term <dt> and one or more definitions or descriptions <dd> of that term.
  • 3.1.1.2.8 dlhead
    The <dlhead> element contains optional headings for the term and description columns in a definition list. The definition list heading may contain a heading <dthd> for the column of terms and a heading <ddhd> for the column of descriptions.
  • 3.1.1.2.9 dt
    The definition term <dt> element contains a term in a definition list entry.
  • 3.1.1.2.10 draft-comment
    The <draft-comment> element is designed to facilitate review and discussion of topic contents within the marked-up content. Use the <draft-comment> element to ask a question or to make a comment that you want others to review. To indicate the source of the draft comment or the status of the comment, use the author, time or disposition attributes.
  • 3.1.1.2.11 dthd
    The definition term heading (<dthd>) element is contained in a definition list head (<dlhead>) and provides an optional heading for the column of terms in a description list.
  • 3.1.1.2.12 example
    The <example> element is a section with the specific role of containing examples that illustrate or support the current topic. The <example> element has the same content model as <section>.
  • 3.1.1.2.13 fig
    The figure (<fig>) element is a display context (sometimes called an "exhibit") with an optional title for a wide variety of content. Most commonly, the figure element contains an image element (a graphic or artwork), but it can contain several kinds of text objects as well. A title is placed inside the figure element to provide a caption that describes the content.
  • 3.1.1.2.14 figgroup
    The <figgroup> element is used primarily for specialization, in order to create segments within a figure. The element may nest itself, which allows it to create complex specialized structures (such as the nestable groups of syntax within a syntax diagram). Figure groups can be used to contain multiple cross-references, footnotes or keywords, but not multipart images. Multipart images in DITA should be represented by a suitable media type displayed by the <object> element.
  • 3.1.1.2.15 fn
    Use footnote (<fn>) to annotate text with notes that are inappropriate for inline inclusion or to indicate the source for facts or other material used in the text.
  • 3.1.1.2.16 image
    Include artwork or images in a DITA topic by using the <image> element. The <image> element has optional attributes that indicate whether the placement of the included graphic or artwork should be inline (like a button or icon) or on a separate line for a larger image. There are also optional attributes that indicate the size to which the included graphic or artwork should be scaled. An image element must specify an href attribute, a keyref attribute, or both. When both keyref and href are specified, the href is used as a fallback when the key reference cannot be resolved. The image addressed by the keyref or href is brought into the main flow of the content as rendered. To make the intent of the image more accessible for users using screen readers or text-only readers, authors should include a description of the image's content in the alt element.
  • 3.1.1.2.17 keyword
    The <keyword> element identifies a keyword or token, such as a single value from an enumerated list, the name of a command or parameter, product name, or a lookup key for a message.
  • 3.1.1.2.18 li
    A list item (<li>) is a single item in an ordered (<ol>) or unordered (<ul>) list. When a DITA topic is rendered, numbers and alpha characters are usually displayed with list items in ordered lists, while bullets and dashes are usually displayed with list items in unordered lists.
  • 3.1.1.2.19 lines
    The <lines> element may be used to represent dialogs or text fragments where line breaks are significant. The <lines> element is similar to <pre> in that hard line breaks are preserved, but the font style is not set to monospace, and extra spaces inside the lines are not preserved.
  • 3.1.1.2.20 longdescref
    The <longdescref> element supports a reference to a text description of the graphic or object. This element replaces the deprecated longdescref attribute on image and object elements.
  • 3.1.1.2.21 longquoteref
    The <longquoteref> element provides a reference to the source of a long quote. The long quote (<lq>) element itself allows an href attribute to specify the source of a quote, but it does not allow other standard linking attributes such as keyref, scope, and format. The <longquoteref> element should be used for references that make use of these attributes.
  • 3.1.1.2.22 lq
    The long quote (<lq>) element indicates content quoted from another source. Use the quote element <q> for short, inline quotations, and long quote <lq> for quotations that are too long for inline use, following normal guidelines for quoting other sources. You can store a URL to the source of the quotation in the href attribute; the href value may point to a DITA topic. For more complex references to the source of a quote, you may use the <longquoteref> element, which was added in DITA 1.2.
  • 3.1.1.2.23 object
    DITA's <object> element corresponds to the HTML <object> element, and its attributes' semantics derive from their HTML definitions. For example, the type attribute differs from the type attribute on many other DITA elements.
  • 3.1.1.2.24 note
    A <note> element contains information, differentiated from the main text, which expands on or calls attention to a particular point.
  • 3.1.1.2.25 ol
    An ordered list (<ol>) is a list of items sorted by sequence or order of importance.
  • 3.1.1.2.26 p
    A paragraph element (<p>) is a block of text containing a single main idea.
  • 3.1.1.2.27 param
    The parameter (<param>) element specifies a set of values that may be required by an <object> at runtime. Any number of <param> elements may appear in the content of an object in any order, but must be placed at the start of the content of the enclosing object. This element is comparable to the XHMTL <param> element, and its attributes' semantics derive from their HTML definitions. For example, the type attribute differs from the type attribute on many other DITA elements.
  • 3.1.1.2.28 ph
    The phrase (<ph>) element is used to organize content for reuse or conditional processing (for example, when part of a paragraph applies to a particular audience). It can be used by specializations of DITA to create semantic markup for content at the phrase level, which then allows (but does not require) specific processing or formatting.
  • 3.1.1.2.29 pre
    The preformatted element (<pre>) preserves line breaks and spaces entered manually by the author in the content of the element, and also presents the content in a monospaced type font (depending on your output formatting processor). Do not use <pre> when a more semantically specific element is appropriate, such as <codeblock>.
  • 3.1.1.2.30 q
    A quotation element (<q>) indicates content quoted from another source. This element is used for short quotes which are displayed inline. Use the long quote element (<lq>) for quotations that should be set off from the surrounding text.
  • 3.1.1.2.31 section
    The <section> element represents an organizational division in a topic. Sections are used to organize subsets of information that are directly related to the topic. For example, the titles Reference Syntax, Example and Properties might represent section-level discourse within a topic about a command-line process—the content in each section relates uniquely to the subject of that topic. Multiple sections within a single topic do not represent a hierarchy, but rather peer divisions of that topic. Sections cannot be nested. A section may have an optional title.
  • 3.1.1.2.32 sectiondiv
    The <sectiondiv> element allows logical grouping of content within a section. There is no additional meaning associated with the sectiondiv element, aside from its function as a container for other content. The sectiondiv element does not contain a title; the lowest level of titled content within a topic is the section itself. If additional hierarchy is required, nested topics should be used in place of the section.
  • 3.1.1.2.33 sl
    The <sl> element contains a simple list of items of short, phrase-like content, such as a list of materials in a kit or package.
  • 3.1.1.2.34 sli
    The <sli> element is an item in a simple list (<sl>). Simple list items have phrase or text content, adequate for describing package contents, for example. When a DITA topic is formatted for output, the items of a simple list should be placed each on its own line, with no other prefix such as a number (as in an ordered list) or bullet (as in an unordered list).
  • 3.1.1.2.35 term
    The <term> element identifies words that may have or require extended definitions or explanations.
  • 3.1.1.2.36 text
    The text element associates no semantics with its content. It exists to serve as a container for text where a container is needed (e.g., for conref, or for restricted content models in specializations). Unlike ph, text cannot contain images. Unlike keyword, text does not imply keyword-like semantics. The text element contains only text data, or nested text elements. All universal attributes are available on text.
  • 3.1.1.2.37 tm
    The trademark (<tm>) element in DITA is used to markup and identify a term or phrase that is trademarked. Trademarks include registered trademarks, service marks, slogans and logos.
  • 3.1.1.2.38 ul
    In an unordered list (<ul>), the order of the list items is not significant. List items are typically styled on output with a "bullet" character, depending on nesting level.
  • 3.1.1.2.39 xref
    Use the cross-reference (<xref>) element to link to a different location within the current topic, or a different topic within the same help system, or to external sources, such as Web pages, or to a location in another topic. The target of the cross-reference is specified using the href or keyref attributes.
Parent topic: 3.1.1 Topic elements
Previous topic: 3.1.1.1.11 dita
Next topic: 3.1.1.2.1 alt


alt

3.1.1.2.1 alt

The alt element provides alternate text for an image. It is equivalent to the alt attribute on the image element; since the attribute is deprecated, use the alt element instead. As an element, alt provides direct text entry within an XML editor and is more easily accessed than an attribute for translation.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or ph or b or i or sup or sub or tt or u) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or ph or b or i or sup or sub or tt or u or menucascade or uicontrol) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | image, hazardsymbol
ditabase, glossary, glossentry, glossgroup | image, glossSymbol, hazardsymbol
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | image

Inheritance

- topic/alt

Example

The markup for alt text within an image looks like this:

<image href="tip-ing.jpg">
  <alt>Here's a Tip!</alt>
</image>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2 Body elements
Next topic: 3.1.1.2.2 cite


cite

3.1.1.2.2 cite

The <cite> element is used when you need a bibliographic citation that refers to a book or article. It specifically identifies the title of the resource.

Though citations will often be set apart from surrounding text, such as through italics, rendering of the <cite> element is left up to implementations.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or boolean or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, b, u, i, tt, sup, sub, howtoavoid
topic (technical content), concept | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
map (technical content) | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
ditabase | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
glossary, glossentry, glossgroup | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
reference | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
task (strict), task (general) | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
bookmap | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, organizationname, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
machineryTask | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, organizationname, b, u, i, tt, sup, sub, howtoavoid
learningContent | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/cite

Example

<p>The online article <cite>Specialization in the Darwin Information Typing
Architecture</cite> provides a detailed explanation of how to define new
topic types.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.1 alt
Next topic: 3.1.1.2.3 dd


dd

3.1.1.2.3 dd

The definition description (<dd>) element contains the description of a term in a definition list entry.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | dlentry

Inheritance

- topic/dd

Example

Figure 1. Simple definition list example
<dl>
<dlentry>
<dt>Bytes returned</dt>
<dd>The number of bytes of data returned.</dd>
</dlentry>
<dlentry>
<dt>Bytes available</dt>
<dd>The number of bytes of data available to be returned.</dd>
</dlentry>
<dlentry><dt>Handle</dt>
<dd>The returned handle value</dd>
</dlentry>
</dl>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.2 cite
Next topic: 3.1.1.2.4 desc


desc

3.1.1.2.4 desc

The <desc> element contains the description of the current element. In elements that also allow a title, such as table and fig, this is used to provide more information than is appropriate for the title. In the xref and link elements it contains a description of the target; processors may (but need not) choose to display this as hover help for a link. In the object element, desc provides alternate content to use when the context does not permit displaying the object.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or image or lines or lq or note or hazardstatement or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or image or lines or lq or note or hazardstatement or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or dl or image or lines or lq or note or hazardstatement or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or image or lines or lq or note or lcInstructornote or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | fig, object, xref, table, link, linklist
map (base), map (technical content), bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | fig, object, xref, table

Inheritance

- topic/desc

Example

<fig><title>The Handshake</title>
<desc>This image shows two hands clasped in a formal,
business-like handshake.</desc>
<image href="handshake.jpg">
 <alt>The handshake</alt>
</image>
</fig>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.3 dd
Next topic: 3.1.1.2.5 ddhd


ddhd

3.1.1.2.5 ddhd

The <ddhd> element contains an optional heading or title for a column of descriptions or definitions in a definition list.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or data or data-about or foreign or unknown or image) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or data or data-about or foreign or unknown or image) (any number)
machineryTask | ( text data or boolean or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or state or data or data-about or foreign or unknown or image) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | dlhead

Inheritance

- topic/ddhd

Example

Figure 1. Definition list with a heading
<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extension</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.4 desc
Next topic: 3.1.1.2.6 dl


dl

3.1.1.2.6 dl

A definition list (<dl>) is a list of terms and corresponding definitions. The term (<dt>) is usually flush left. The description or definition (<dd>) is usually either indented and on the next line, or on the same line to the right of the term. However, actual rendering is up to the rendering engine.

You can also provide an optional heading for the terms and definitions, using the <dlhead> element, which contains header elements for those columns. The default formatting for the <dlhead> generally looks like a table with a heading row, but this is also up to the rendering engine.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (dlhead) (optional) then (dlentry) (one or more) )

Contained by

Doctype | Content model
topic (base) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase, lcInstructornote
learningPlan | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/dl

Examples

Figure 1. Simple definition list example
<dl>
<dlentry>
<dt>Bytes returned</dt>
<dd>The number of bytes of data returned.</dd>
</dlentry>
<dlentry>
<dt>Bytes available</dt>
<dd>The number of bytes of data available to be returned.</dd>
</dlentry>
<dlentry><dt>Handle</dt>
<dd>The returned handle value</dd>
</dlentry>
</dl>
Figure 2. Definition list with a heading
<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extension</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>

Rendering of definition lists will vary by application and by display format. The second example may, but need not, be rendered as follows.

Image File View Selection
Resulting Information
File Type
Image's file extension
Image Class
Image is raster, vector, metafile or 3D
Number of pages
Number of pages in the image
Fonts
Names of the fonts contained within a vector image

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.5 ddhd
Next topic: 3.1.1.2.7 dlentry


dlentry

3.1.1.2.7 dlentry

In a definition list, each list item is defined by the definition list entry (<dlentry>) element. The definition list entry element includes a term <dt> and one or more definitions or descriptions <dd> of that term.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (dt) (one or more) then (dd) (one or more) )

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | dl

Inheritance

- topic/dlentry

Example

Figure 1. Simple definition list example
<dl>
<dlentry>
<dt>Bytes returned</dt>
<dd>The number of bytes of data returned.</dd>
</dlentry>
<dlentry>
<dt>Bytes available</dt>
<dd>The number of bytes of data available to be returned.</dd>
</dlentry>
<dlentry><dt>Handle</dt>
<dd>The returned handle value</dd>
</dlentry>
</dl>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.6 dl
Next topic: 3.1.1.2.8 dlhead


dlhead

3.1.1.2.8 dlhead

The <dlhead> element contains optional headings for the term and description columns in a definition list. The definition list heading may contain a heading <dthd> for the column of terms and a heading <ddhd> for the column of descriptions.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (dthd) (optional) then (ddhd) (optional) )

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | dl

Inheritance

- topic/dlhead

Example

Figure 1. Definition list with a heading
<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extension</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.7 dlentry
Next topic: 3.1.1.2.9 dt


dt

3.1.1.2.9 dt

The definition term <dt> element contains a term in a definition list entry.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or image) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or image) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | dlentry

Inheritance

- topic/dt

Example

Figure 1. Simple definition list example
<dl>
<dlentry>
<dt>Bytes returned</dt>
<dd>The number of bytes of data returned.</dd>
</dlentry>
<dlentry>
<dt>Bytes available</dt>
<dd>The number of bytes of data available to be returned.</dd>
</dlentry>
<dlentry><dt>Handle</dt>
<dd>The returned handle value</dd>
</dlentry>
</dl>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.8 dlhead
Next topic: 3.1.1.2.10 draft-comment


draft-comment

3.1.1.2.10 draft-comment

The <draft-comment> element is designed to facilitate review and discussion of topic contents within the marked-up content. Use the <draft-comment> element to ask a question or to make a comment that you want others to review. To indicate the source of the draft comment or the status of the comment, use the author, time or disposition attributes.

Processing systems should provide a run-time flag or parameter to cause the content of this element to be specially displayed for draft output only. By default, processors should strip them out to prevent publishing internal comments by mistake.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example
map (base), classifyMap, subjectScheme, learningMap | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry
topic (technical content) | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, screen, codeblock, pd
map (technical content) | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, screen, codeblock, pd
concept | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, screen, codeblock, pd
ditabase | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, glossdef, glossUsage, glossScopeNote, screen, codeblock, pd
glossary, glossentry, glossgroup | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, glossdef, glossUsage, glossScopeNote, screen, codeblock, pd
reference | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, screen, codeblock, pd
task (strict), task (general) | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, screen, codeblock, pd
bookmap | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, organizationname, screen, codeblock, pd
machineryTask | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, screen
learningAssessment, learningOverview, learningSummary | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, organizationname
learningContent | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | shortdesc, p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/draft-comment

Example

<draft-comment author="EBP">Where's the usage information for this
section?</draft-comment>

Attributes

Name | Description | Data Type | Default Value | Required?
author | Designates the originator of the draft comment. | CDATA | #IMPLIED | No
time | Describes when the draft comment was created. | CDATA | #IMPLIED | No
disposition | Status of the draft comment. Values can be issue, open, accepted, rejected, deferred, duplicate, reopened, unassigned, or completed. | CDATA | #IMPLIED | No
translate | Indicates whether the content of the element should be translated or not. Setting to "yes" will override the default. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value; because this element uses an actual default, it will always be treated as translate="no" unless overridden as described. | yes | no | -dita-use-​conref-​target | "no" | No
xml:lang | Specifies the language of the element content. The xml:lang attribute and its values are described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. | language token or the null string | #IMPLIED | No
dir | Specifies the directionality of text: left-to-right (ltr, the processing default) or right-to-left (rtl). The value lro indicates an override of normal bidi text presentation, forcing the element into left-to-right mode; rlo overrides normal rules to force right-to-left presentation. See The dir attribute for more information on the dir attribute. | (ltr | rtl | lro | rlo | -dita-use-​conref-​target) | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.9 dt
Next topic: 3.1.1.2.11 dthd


dthd

3.1.1.2.11 dthd

The definition term heading (<dthd>) element is contained in a definition list head (<dlhead>) and provides an optional heading for the column of terms in a description list.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or data or data-about or foreign or unknown or image) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or data or data-about or foreign or unknown or image) (any number)
machineryTask | ( text data or boolean or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or state or data or data-about or foreign or unknown or image) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | dlhead

Inheritance

- topic/dthd

Example

Figure 1. Definition list with a heading
<dl>
 <dlhead>
  <dthd>Image File View Selection</dthd>
  <ddhd>Resulting Information</ddhd>
 </dlhead>
 <dlentry>
  <dt>File Type</dt>
  <dd>Image's file extension</dd>
 </dlentry>
 <dlentry>
  <dt>Image Class</dt>
  <dd>Image is raster, vector, metafile or 3D</dd>
 </dlentry>
 <dlentry>
  <dt>Number of pages</dt>
  <dd>Number of pages in the image</dd>
 </dlentry>
 <dlentry>
  <dt>Fonts</dt>
  <dd>Names of the fonts contained within a vector image</dd>
 </dlentry>
</dl>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.10 draft-comment
Next topic: 3.1.1.2.12 example


example

3.1.1.2.12 example

The <example> element is a section with the specific role of containing examples that illustrate or support the current topic. The <example> element has the same content model as <section>.

DITA uses <example> to contain both discussion and sample code or outputs. Hence, in a DITA topic, to represent programming code and results within the discussion in an example, use the <codeblock> and <systemoutput> elements within the example element. For lines of text, use the <lines> element. For pre-formatted text such as email headers, use the <pre> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base) | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), learningAssessment, learningOverview, learningPlan, learningSummary | body
concept, glossary, glossentry, glossgroup | body, conbody, conbodydiv
ditabase | body, conbody, conbodydiv, taskbody, refbody, refbodydiv
reference | body, refbody, refbodydiv
task (strict), task (general), machineryTask | body, taskbody
learningContent | body, taskbody, conbody, conbodydiv, refbody, refbodydiv

Inheritance

- topic/example

Example

<example id="example">
  <title>Example</title>
  <codeblock>&lt;p&gt;Example of the p element&lt;/p&gt;</codeblock>
</example>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.11 dthd
Next topic: 3.1.1.2.13 fig


fig

3.1.1.2.13 fig

The figure (<fig>) element is a display context (sometimes called an "exhibit") with an optional title for a wide variety of content. Most commonly, the figure element contains an image element (a graphic or artwork), but it can contain several kinds of text objects as well. A title is placed inside the figure element to provide a caption that describes the content.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( (title) (optional) then (desc) (optional) then (figgroup or dl or image or lines or lq or note or hazardstatement or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (title) (optional) then (desc) (optional) then (figgroup or dl or parml or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )
machineryTask | ( (title) (optional) then (desc) (optional) then (figgroup or dl or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (desc) (optional) then (figgroup or dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
topic (base) | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry
topic (technical content) | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, pd
map (technical content), bookmap | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, pd
concept | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, pd
ditabase | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, pd
task (strict), task (general) | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

- topic/fig

Example

<fig expanse="column">
  <title>The Handshake</title>
  <image href="handshake.jpg" placement="break">
    <alt>The Handshake</alt>
  </image>
</fig>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.12 example
Next topic: 3.1.1.2.14 figgroup


figgroup

3.1.1.2.14 figgroup

The <figgroup> element is used primarily for specialization, in order to create segments within a figure. The element may nest itself, which allows it to create complex specialized structures (such as the nestable groups of syntax within a syntax diagram). Figure groups can be used to contain multiple cross-references, footnotes or keywords, but not multipart images. Multipart images in DITA should be represented by a suitable media type displayed by the <object> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( (title) (optional) then (figgroup or (dl or image or lines or lq or note or hazardstatement or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or fn or foreign or unknown) ) (any number) )
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (title) (optional) then (figgroup or (dl or parml or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or fn or foreign or unknown) ) (any number) )
machineryTask | ( (title) (optional) then (figgroup or (dl or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or fn or foreign or unknown) ) (any number) )
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (figgroup or (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or fn or foreign or unknown) ) (any number) )

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | fig, figgroup

Inheritance

- topic/figgroup

Example

<fig>
  <title>Sample complex figure</title>
  <figgroup>
    <title>First group</title>
    <ph>These elements</ph>
    <ph>are grouped together</ph>
    <ph>for some purpose</ph>
  </figgroup>
  <figgroup>
    <title>Second group</title>
    <data name="MetaItem" value="13"/>
    <data name="MetaThing" value="31"/>
    <ph>These elements</ph>
    <ph>are grouped with associated metadata</ph>
  </figgroup>
</fig>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.13 fig
Next topic: 3.1.1.2.15 fn


fn

3.1.1.2.15 fn

Use footnote (<fn>) to annotate text with notes that are inappropriate for inline inclusion or to indicate the source for facts or other material used in the text.

Footnote content is skipped at the place where it was entered and rendered elsewhere, according to these rules:
  • A footnote with no given id attribute is a single-use footnote. Upon output, it generates a number as a superscript "callout" that is linked to the placement of the footnote, such as at the bottom of the immediate printed page or at the end of an online article. If a character is specified in the callout attribute for the footnote, that character should be used as the superscript "callout" that is linked to the placement of the footnote.
  • A footnote entered with an id attribute is a use-by-reference footnote. Upon output, it does not appear anywhere unless it has been referenced using an <xref> with the type attribute set to "fn".
  • Ordinarily, a footnote in one topic can't be referenced in another topic. The previous behaviors are local to each topic. But by using the conref mechanism, you can create a new copy of another topic's footnote within the local topic where it will then follow these behaviors:
    • If you use <fn conref="file.dita#topic/thatid"></fn> all by itself, the result will be the same as the single-use footnote entered literally in the same location. That is, it creates a local copy of the footnote with no local id attribute, so it uses the behavior from the first bullet above.
    • If you use <fn conref="file.dita#topic/thatid" id="thisid"></fn>, followed by <xref href="#thistopic/thisid" type="fn"/>, the result will be the same as the use-by-reference model described in the second bullet. That is, the <fn> element creates a local copy of the footnote with an id of "thisid"; that local copy is then referenced by the <xref> element.
Note: The details of footnote processing and styling are implementation and/or stylesheet dependent. For example, a tool that renders DITA as PDF may lack support for the callout attribute, or footnotes may be collected as endnotes for certain types of publications.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example
map (base), classifyMap, subjectScheme, learningMap | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry
topic (technical content), concept | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, screen, codeblock, pd
map (technical content) | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, screen, codeblock, pd
ditabase | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, glossdef, glossUsage, glossScopeNote, screen, codeblock, pd
glossary, glossentry, glossgroup | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, glossdef, glossUsage, glossScopeNote, screen, codeblock, pd
reference | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, screen, codeblock, pd
task (strict), task (general) | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, screen, codeblock, pd
bookmap | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, organizationname, screen, codeblock, pd
machineryTask | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, screen
learningAssessment, learningOverview, learningSummary | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, organizationname
learningContent | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | p, note, lq, sli, li, itemgroup, dd, fig, figgroup, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/fn

Example

The first example is of a single-use footnote. It uses a simple fn element, with no ID and no callout attribute. In that case, markup such as the following:
The memory storage capacity of the computer is
2 GB<fn>A GB (gigabyte) is equal to
1000 million bytes</fn> with error correcting support.
may produce output similar to the following:

The memory storage capacity of the computer is 2 GB1 with error correcting support.

......

1 A GB (gigabyte) is equal to 1000 million bytes

----- [bottom of page] -----------------------------------------------------------------

The second example is a single-use footnote that uses a callout attribute. It is marked up as follows:
The memory storage capacity of the computer is
2 GB<fn callout="#">A GB (gigabyte) is equal to
1000 million bytes</fn> with error correcting support.
That DITA markup may produce output similar to the following:

The memory storage capacity of the computer is 2 GB# with error correcting support.

......

# A GB (gigabyte) is equal to 1000 million bytes

----- [bottom of page] -----------------------------------------------------------------

The third example is a use-by-reference footnote. It uses an ID on a footnote, and then references that ID multiple times. The DITA markup looks like this:
I like pets. <fn id="reuse-fn">This is the name of an animal.</fn>
At my house, I have a dog<xref href="#topic/reuse-fn" type="fn"/>, a
cat<xref href="#topic/reuse-fn" type="fn"/>, and a
llama<xref href="#topic/reuse-fn" type="fn"/>.
and may produce output similar to the following:

I like pets. At my house, I have a dog1, a cat1, and a llama1.

......

1This is the name of an animal.

----- [bottom of page] -----------------------------------------------------------------

Attributes

Name | Description | Data Type | Default Value | Required?
callout | Specifies what character is used for the footnote link, for example a number or an alpha character. The attribute may also specify a short string of characters. When no callout value is specified, footnotes are numbered. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.14 figgroup
Next topic: 3.1.1.2.16 image


image

3.1.1.2.16 image

Include artwork or images in a DITA topic by using the <image> element. The <image> element has optional attributes that indicate whether the placement of the included graphic or artwork should be inline (like a button or icon) or on a separate line for a larger image. There are also optional attributes that indicate the size to which the included graphic or artwork should be scaled. An image element must specify an href attribute, a keyref attribute, or both. When both keyref and href are specified, the href is used as a fallback when the key reference cannot be resolved. The image addressed by the keyref or href is brought into the main flow of the content as rendered. To make the intent of the image more accessible for users using screen readers or text-only readers, authors should include a description of the image's content in the alt element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (alt) (optional) then (longdescref) (optional) )

Contained by

Doctype | Content model
topic (base) | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, imagemap
map (base), classifyMap, subjectScheme, learningMap | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, imagemap
topic (technical content) | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, imagemap, uicontrol, pt, pd
map (technical content) | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, imagemap, uicontrol, pt, pd
concept | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, imagemap, uicontrol, pt, pd
ditabase | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, imagemap, uicontrol, pt, pd
glossary, glossentry, glossgroup | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, imagemap, uicontrol, pt, pd
reference | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, imagemap, uicontrol, pt, pd
task (strict), task (general) | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, imagemap, uicontrol, pt, pd
bookmap | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, imagemap, uicontrol, pt, pd
machineryTask | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, imagemap, uicontrol
learningAssessment, learningOverview, learningSummary | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, imagemap, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcAsset, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcHotspotMap
learningBookmap | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, imagemap
learningContent | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, imagemap, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcAsset, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcHotspotMap
learningPlan | data, title, shortdesc, desc, p, note, lq, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, ph, stentry, draft-comment, fn, xref, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, imagemap, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcAsset, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcHotspotMap

Inheritance

- topic/image

Example

<image href="bike.gif" placement="break">
  <alt>Two-wheeled bicycle</alt>
</image>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to the image. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
height | Indicates the vertical dimension for the resulting image display. If necessary, the image is scaled to the specified size. The value of this attribute is a real number optionally followed by a unit of measure from the set of pc, pt, px, in, cm, mm, em (picas, points, pixels, inches, centimeters, millimeters, and ems respectively). The default unit is px (pixels). Possible values include: "5", "5in", and "10.5cm". If a height value is specified and no width value is specified, the width will be scaled by the same factor as the height. If both a height value and width value are specified, some implementations may not be able to scale the two directions by a different factor and may therefore ignore one of the two values. | NMTOKEN | #IMPLIED | No
width | Indicates the horizontal dimension for the resulting image display. If necessary, the image is scaled to the specified size. The value of this attribute is a real number optionally followed by a unit of measure from the set of pc, pt, px, in, cm, mm, em (picas, points, pixels, inches, centimeters, millimeters, and ems respectively). The default unit is px (pixels). Possible values include: "5", "5in", and "10.5cm". If a width value is specified and no height value is specified, the height will be scaled by the same factor as the width. If both a height value and width value are specified, some implementations may not be able to scale the two directions by a different factor and may therefore ignore one of the two values. | NMTOKEN | #IMPLIED | No
align | Controls the horizontal alignment of an image when placement is specified as "break." Common values include left, right, and center. | CDATA | #IMPLIED | No
scale | Specifies a percentage by which to scale the image in the absence of any specified image height or width; a value of 100 implies that the image should be presented at its intrinsic size. If a value has been specified for this image's height or width attribute (or both), the scale attribute is ignored. It is an error if the value of this attribute is not an unsigned integer. In this case, the implementation may (but need not) give an error message and may (but need not) recover by ignoring this attribute. | NMTOKEN | #IMPLIED | No
scalefit | Allow an image to be scaled to fit within available space. If, for a given image, any one of height, width, or scale is specified, those attributes determine the graphic size, and any setting of scalefit is ignored. If none of those attributes are specified and scalefit="yes", then the image is scaled (the same factor in both dimensions) so that the graphic will just fit within the available height or width (whichever is more constraining). The available width would be the prevailing column (or table cell) width--that is, the width a paragraph of text would have if the graphic were a paragraph instead. The available height is implementation dependent, but if feasible, it is suggested to be the page (or table cell) height or some other reasonable value. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
placement | Indicates whether an image should be displayed inline or separated from the surrounding text. The processing default is inline. Allowable values are: inline or break. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | (inline | break | -dita-use-​conref-​target) | inline | No
alt (deprecated) | Alternative text that describes the image to provide accessibility to page readers or provides a text description when an image cannot be displayed by the user's software. The alt attribute is deprecated; use the alt element instead. | CDATA | #IMPLIED | No
longdescref (deprecated) | A reference to a textual description of the graphic or object. This attribute supports creating accessible content. See The href attribute for detailed information on supported values and processing implications. For examples of how this attribute is used in output, see this this topic on long descriptions. NOTE: This attribute is deprecated in favor of the longdescref subelement to this element. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.15 fn
Next topic: 3.1.1.2.17 keyword


keyword

3.1.1.2.17 keyword

The <keyword> element identifies a keyword or token, such as a single value from an enumerated list, the name of a command or parameter, product name, or a lookup key for a message.

"Keyword" means any text that has a unique or key-like value, such as a product name. Where there is an element that has a better meaning for what you are describing, use that element. The keyword element is a generic element; use it when no other element applies. The keyword element can also be used to contain reusable text.

With DITA 1.2, another option for reusable text is the <text> element, which is designed to be free of any extra semantics. The <text> element is available within keyword, and it should be possible to use either keyword or text to reuse content in any situation.

Specific markup recommendations:
  • Use <apiname> for API names and <cmdname> for command names.
  • Use <term> to indicate what you are defining with inline paragraph definitions.
  • Use <ph> for general phrases when keyword is not appropriate.
  • Use <kwd> to indicate programming keywords in syntax diagrams and syntax phrases.

Specialized elements derived from <keyword> may also have extended processing, such as different formatting or automatic indexing.

All <keyword> or <indexterm> elements in the <keywords> metadata element are considered part of the topic's metadata and should be processed accordingly as appropriate for the given output medium.
Note: While the <keyword> element may be used inline, the <keywords> element is not an inline element. The <keywords> element only appears in the <topicmeta> or <prolog>, and is used to specify keywords that apply to the topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or text or tm) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid
map (base), classifyMap, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
subjectScheme | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, uicontrol, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords

Inheritance

- topic/keyword

<p>The <keyword>assert</keyword> pragma statement allows messages to be passed
to the emulator, pre-compiler, etc..</p>
<p>The <keyword id="myProduct">AmazingProduct</keyword> can make use of
this feature to do really neat stuff.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.16 image
Next topic: 3.1.1.2.18 li


li

3.1.1.2.18 li

A list item (<li>) is a single item in an ordered (<ol>) or unordered (<ul>) list. When a DITA topic is rendered, numbers and alpha characters are usually displayed with list items in ordered lists, while bullets and dashes are usually displayed with list items in unordered lists.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ul, ol

Inheritance

- topic/li

Example

<ul>
  <li>This is an item in an unordered list.</li>
  <li>This is another item in an unordered list.</li>
</ul>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.17 keyword
Next topic: 3.1.1.2.19 lines


lines

3.1.1.2.19 lines

The <lines> element may be used to represent dialogs or text fragments where line breaks are significant. The <lines> element is similar to <pre> in that hard line breaks are preserved, but the font style is not set to monospace, and extra spaces inside the lines are not preserved.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase, lcInstructornote
learningPlan | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/lines

Example

This is a sample of my favorite sonnet.
<lines>
Shall I compare thee to a summer's day?
Thou art more lovely and more temperate:
Rough winds do shake the darling buds of May,
and summer's lease hath all too short a date:
...</lines>

Though exact formatting will vary, the previous sample will typically be rendered as follows.

This is a sample of my favorite sonnet

Shall I compare thee to a summer's day?
Thou art more lovely and more temperate:
Rough winds do shake the darling buds of May,
and summer's lease hath all too short a date:
...

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, xml:space | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.18 li
Next topic: 3.1.1.2.20 longdescref


longdescref

3.1.1.2.20 longdescref

The <longdescref> element supports a reference to a text description of the graphic or object. This element replaces the deprecated longdescref attribute on image and object elements.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | image, object, hazardsymbol
ditabase, glossary, glossentry, glossgroup | image, object, glossSymbol, hazardsymbol
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | image, object

Inheritance

- topic/longdescref

Example

Figure 1. Longdescref which references a local DITA description
<image href="llama.jpg">
  <alt>Llama picture</alt>
  <longdescref href="my-pet-llama.dita"/>
</image>
Figure 2. Longdescref which references an external description
<image href="puffin.jpg">
  <alt>Puffin pigure</alt>
  <longdescref href="http://www.example.org/birds/puffin.html"
               scope="external"
               format="html"/>
</image>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.19 lines
Next topic: 3.1.1.2.21 longquoteref


longquoteref

3.1.1.2.21 longquoteref

The <longquoteref> element provides a reference to the source of a long quote. The long quote (<lq>) element itself allows an href attribute to specify the source of a quote, but it does not allow other standard linking attributes such as keyref, scope, and format. The <longquoteref> element should be used for references that make use of these attributes.

Rendering of this element is left up to DITA processors. Depending on the presentation format, it may be appropriate to ignore the element, present it as a link, use it to turn the entire quote into a link, or do something else.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lq

Inheritance

- topic/longquoteref

Example

<p>A great person once said the following thing.
<lq>Examples are the key to any
specification.<longquoteref href="http://www.example.org/quotes" scope="external"/></lq></p>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.20 longdescref
Next topic: 3.1.1.2.22 lq


lq

3.1.1.2.22 lq

The long quote (<lq>) element indicates content quoted from another source. Use the quote element <q> for short, inline quotations, and long quote <lq> for quotations that are too long for inline use, following normal guidelines for quoting other sources. You can store a URL to the source of the quotation in the href attribute; the href value may point to a DITA topic. For more complex references to the source of a quote, you may use the <longquoteref> element, which was added in DITA 1.2.

Although rendering is left up to implementations, processors generally render <lq> as an indented block.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or longquoteref or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or longquoteref or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or longquoteref or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or longquoteref or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base) | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase, lcInstructornote
learningPlan | desc, p, note, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/lq

Example

<p>This is the first line of the address that
Abraham Lincoln delivered on November 19, 1863 for the dedication
of the cemetery at Gettysburg, Pennsylvania.</p>
<lq>Four score and seven years ago our fathers brought forth on this continent a new
nation, conceived in liberty, and dedicated to the proposition that all men
are created equal.</lq>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type Indicates the location of the source of the quote. Note that this allows some values in addition to those allowed on the type attribute on many other DITA elements. See The type attribute for detailed information on the usual supported values and processing implications. In addition, the following attribute values are allowed (but deprecated) for backward compatibility:
external
the href is to a Web site. This value is deprecated in favor of use of the scope and format attributes.
internal
the href is to a DITA topic. This value is deprecated in favor of use of the scope and format attributes.

When either the scope or format attribute has an explicit setting, a type attribute value of external or internal is ignored.

CDATA #IMPLIED No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. In the absence of an explicit specification for the scope attribute, an explicit value of type="external" implies scope="external". | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. In the absence of an explicit specification for the format attribute, an explicit value of type="internal" implies format="dita". | CDATA | #IMPLIED | No
reftitle | The title of the document or topic being quoted. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.21 longquoteref
Next topic: 3.1.1.2.23 object


object

3.1.1.2.23 object

DITA's <object> element corresponds to the HTML <object> element, and its attributes' semantics derive from their HTML definitions. For example, the type attribute differs from the type attribute on many other DITA elements.

The <object> element allows authors to include animated images, applets, plug-ins, ActiveX controls, video clips, and other multimedia objects in a topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (desc) (optional) then (longdescref) (optional) then (param) (any number) then (foreign or unknown) (any number) )

Contained by

Doctype | Content model
topic (base) | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, pd
map (technical content), bookmap | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, pd
ditabase | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, glossdef, glossProperty, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, glossdef, glossProperty, glossUsage, glossScopeNote, pd
reference | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, pd
task (strict), task (general) | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote, lcAsset
learningContent | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInteractionBase, lcInstructornote, lcAsset
learningPlan | data, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote, lcAsset

Inheritance

- topic/object

Example

Output processors may need to modify data to enable compatible function across various browsers, so these examples are only representative:
<p>Cutting the keys from the system unit:</p>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=6,0,0,0"
 data="cutkey370.swf"
 type="application/x-shockwave-flash"
 height="280"
 width="370"
 id="cutkey370">
 <desc>A description of the task</desc>
 <param name="movie" value="cutkey370.swf"/>
 <param name="quality" value="high"/>
 <param name="bgcolor" value="#FFFFFF"/>
</object>

<p>What's EIM?</p>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/
flash/swflash.cab#version=6,0,0,0"
 data="eim.swf"
 height="400"
 width="500"
 id="eim">
 <desc>Some great, glorious info</desc>
 <param name="movie" value="eim.swf"/>
 <param name="quality" value="high"/>
 <param name="bgcolor" value="#FFFFFF"/>
 <param name="pluginspace"
 value="http://www.macromedia.com/go/getflashplayer"/>
</object>

Attributes

Name | Description | Data Type | Default Value | Required?
declare | When this attribute is set to declare, the current object definition is a declaration only. The object must be instantiated by a later nested object definition referring to this declaration. | declare | #IMPLIED | No
classid | Contains a URL that specifies the location of an object's implementation. It can be used together with the data attribute which is specified relative to the value of the codebase attribute. | CDATA | #IMPLIED | No
codebase | Specifies the base path (a URL) used for resolving the URL values given for classid, data, and archive attributes. If codebase is not set, the default is the base URL of the current document. | CDATA | #IMPLIED | No
data | Contains a reference to the location of an object's data. If this attribute is a URL, it is specified relative to the value of the codebase attribute. If this attribute is set, the type attribute should also be set. | CDATA | #IMPLIED | No
type | Indicates the content type for the data specified by the data attribute. This attribute should be set when the data attribute is set to avoid loading unsupported content types. Note that this differs from the type attribute on many other DITA elements. | CDATA | #IMPLIED (No default type) | No
codetype | Indicates the content type for the data specified by the classid attribute. This attribute should be set when the classid attribute is set to avoid loading unsupported content types. If this attribute value is not set, the processing default is the value of the type attribute. | CDATA | #IMPLIED | No
archive | Specifies a space-separated list of URLs indicating resources needed by the object. These resources may include those URLs specified by the classid and data attributes. Preloading these resources usually results in faster loadtimes for objects. The URLs in the list should be relative to the URL specified in the codebase attribute. | CDATA | #IMPLIED | No
standby | Contains a message to be displayed while an object is loading. | CDATA | #IMPLIED | No
height | Indicates the vertical dimension for the resulting object display. If necessary, the object is scaled to the specified size. The value of this attribute is a real number optionally followed by a unit of measure from the set of pc, pt, px, in, cm, mm, em (picas, points, pixels, inches, centimeters, millimeters, and ems respectively). The default unit is px (pixels). Possible values include: "5", "5in", and "10.5cm". If a height value is specified and no width value is specified, the width will be scaled by the same factor as the height. If both a height value and width value are specified, some implementations may not be able to scale the two directions by a different factor and may therefore ignore one of the two values. | NMTOKEN | #IMPLIED | No
width | Indicates the horizontal dimension for the resulting object display. If necessary, the object is scaled to the specified size. The value of this attribute is a real number optionally followed by a unit of measure from the set of pc, pt, px, in, cm, mm, em (picas, points, pixels, inches, centimeters, millimeters, and ems respectively). The default unit is px (pixels). Possible values include: "5", "5in", and "10.5cm". If a width value is specified and no height value is specified, the height will be scaled by the same factor as the width. If both a height value and width value are specified, some implementations may not be able to scale the two directions by a different factor and may therefore ignore one of the two values. | NMTOKEN | #IMPLIED | No
usemap | Indicates that a client-side image map is to be used. An image map specifies active geometric regions of an included object and assigns a link to each region. When a link is selected, a document may be retrieved or a program may run on the server. | CDATA | #IMPLIED | No
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
tabindex | Position the object in tabbing order. | NMTOKEN | #IMPLIED | No
longdescref (deprecated) | A reference to a textual description of the graphic or object. This attribute supports creating accessible content. See The href attribute for detailed information on supported values and processing implications. For examples of how this attribute is used in output, see this this topic on long descriptions. NOTE: This attribute is deprecated in favor of the longdescref subelement to this element. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.22 lq
Next topic: 3.1.1.2.24 note


note

3.1.1.2.24 note

A <note> element contains information, differentiated from the main text, which expands on or calls attention to a particular point.

Tip: Variant types of note (tip, caution, danger, restriction, etc.) can be indicated through values selected on the type attribute. This note is typed as a "tip."

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base) | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, step, info, substep, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossBody, glossAlt, pd
glossary, glossentry, glossgroup | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossBody, glossAlt, pd
reference | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, step, info, substep, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, step, info, substep, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase
learningContent | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, step, info, substep, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase
learningPlan | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase

Inheritance

- topic/note

Example

This example:
<note type="tip">Thinking of a seashore, green meadow, or cool
mountain overlook can help you to relax and be more
patient.</note>
produces this result:
Tip: Thinking of a seashore, green meadow, or cool mountain overlook can help you to relax and be more patient.

Attributes

Name | Description | Data Type | Default Value | Required?
type | Defines the type of a note. For example, if the note is a tip, the word Tip is used to draw the reader's attention to it. Note that this differs from the type attribute on many other DITA elements. See The type attribute for detailed information on supported values and processing implications. | (note | tip | fastpath | restriction | important | remember | attention | caution | notice | danger | warning | other | -dita-use-​conref-​target) |  | No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
othertype | Indicates an alternate note type, when the type is not available in the type attribute value list. This value is used as the user-provided note title when the type attribute value is set to "other." | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.23 object
Next topic: 3.1.1.2.25 ol


ol

3.1.1.2.25 ol

An ordered list (<ol>) is a list of items sorted by sequence or order of importance.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | (li) (one or more)

Contained by

Doctype | Content model
topic (base) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase, lcInstructornote
learningPlan | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/ol

Example

Here are the colors of the rainbow in order of appearance from top to bottom:
<ol>
<li>Red</li>
<li>Orange</li>
<li>Yellow</li>
<li>Green</li>
<li>Blue</li>
<li>Indigo</li>
<li>Violet</li>
</ol>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.24 note
Next topic: 3.1.1.2.26 p


p

3.1.1.2.26 p

A paragraph element (<p>) is a block of text containing a single main idea.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base) | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase, lcInstructornote
learningPlan | desc, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/p

Example

<p>
It is probable that <q>temporary</q> or <q>new</q> stars, as these
wonderful apparitions are called, really are <term>conflagrations</term>;
not in the sense of a bonfire or a burning house or city, but in that of
a sudden eruption of <i>inconceivable</i> heat and light, such as would
result from the stripping off the shell of an encrusted sun or the crashing
together of two mighty orbs flying through space with a hundred times
the velocity of the swiftest cannon-shot.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.25 ol
Next topic: 3.1.1.2.27 param


param

3.1.1.2.27 param

The parameter (<param>) element specifies a set of values that may be required by an <object> at runtime. Any number of <param> elements may appear in the content of an object in any order, but must be placed at the start of the content of the enclosing object. This element is comparable to the XHMTL <param> element, and its attributes' semantics derive from their HTML definitions. For example, the type attribute differs from the type attribute on many other DITA elements.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | object

Inheritance

- topic/param

Example

See object.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name of the parameter. | CDATA | #REQUIRED | Yes
value | Specifies the value of a run-time parameter specified by the name attribute. | CDATA | #IMPLIED | No
valuetype Specifies the type of the value attribute. Allowed values are:
data
A value of data means that the value will be evaluated and passed to the object's implementation as a string.
ref
A value of ref indicates that the value of the value attribute is a URL that designates a resource where run-time values are stored. This allows support tools to identify URLs that are given as parameters.
object
A value of object indicates that the value of valuetype is an identifier that refers to an object declaration in the document. The identifier must be the value of the ID attribute set for the declared object element.
CDATA #IMPLIED No
type | This attribute specifies the content type of the resource designated by the value attribute only in the case where valuetype is set to "ref". This attribute specifies for the user agent the type of values that will be found at the URI designated by value. Note that this differs from the type attribute on many other DITA elements. | CDATA | #IMPLIED (No default type) | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class | A common attribute described in Other common DITA attributes
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.26 p
Next topic: 3.1.1.2.28 ph


ph

3.1.1.2.28 ph

The phrase (<ph>) element is used to organize content for reuse or conditional processing (for example, when part of a paragraph applies to a particular audience). It can be used by specializations of DITA to create semantic markup for content at the phrase level, which then allows (but does not require) specific processing or formatting.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup or text) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup or text) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup or text) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/ph

Example

<p>This was not changed. <ph rev="v5r2">This was updated.</ph> This was not.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.27 param
Next topic: 3.1.1.2.29 pre


pre

3.1.1.2.29 pre

The preformatted element (<pre>) preserves line breaks and spaces entered manually by the author in the content of the element, and also presents the content in a monospaced type font (depending on your output formatting processor). Do not use <pre> when a more semantically specific element is appropriate, such as <codeblock>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase, lcInstructornote
learningPlan | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/pre

Example

The following example will preserve all line breaks.

<pre>
MEMO: programming team fun day
Remember to bring a kite, softball glove, or other favorite
outdoor accessory to tomorrow's fun day outing at Zilker Park.
Volunteers needed for the dunking booth.
</pre>
The rendered result will differ depending on the processor that is rendering your DITA content. It will generally look something like this:
MEMO: programming team fun day
Remember to bring a kite, softball glove, or other favorite
outdoor accessory to tomorrow's fun day outing at Zilker Park.
Volunteers needed for the dunking booth.

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, xml:space | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.28 ph
Next topic: 3.1.1.2.30 q


q

3.1.1.2.30 q

A quotation element (<q>) indicates content quoted from another source. This element is used for short quotes which are displayed inline. Use the long quote element (<lq>) for quotations that should be set off from the surrounding text.

Authors should not add quote punctuation manually when using the <q> element. Processors that render the <q> element should add appropriate styling, such as locale-specific quotation marks.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, b, u, i, tt, sup, sub, howtoavoid
topic (technical content), concept | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, glossterm, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, howtoavoid
learningContent | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/q

Example

George said, <q>Disengage the power supply before servicing the unit.</q>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.29 pre
Next topic: 3.1.1.2.31 section


section

3.1.1.2.31 section

The <section> element represents an organizational division in a topic. Sections are used to organize subsets of information that are directly related to the topic. For example, the titles Reference Syntax, Example and Properties might represent section-level discourse within a topic about a command-line process—the content in each section relates uniquely to the subject of that topic. Multiple sections within a single topic do not represent a hierarchy, but rather peer divisions of that topic. Sections cannot be nested. A section may have an optional title.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base) | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), task (strict) | body, bodydiv
concept, glossary, glossentry, glossgroup | body, bodydiv, conbody, conbodydiv
ditabase | body, bodydiv, conbody, conbodydiv, refbody, refbodydiv
reference | body, bodydiv, refbody, refbodydiv
task (general), machineryTask | body, bodydiv, taskbody
learningAssessment | body, bodydiv, learningBasebody, learningAssessmentbody
learningContent | body, bodydiv, learningBasebody, taskbody, conbody, conbodydiv, refbody, refbodydiv, learningSummarybody, learningAssessmentbody, learningContentbody
learningOverview | body, bodydiv, learningBasebody, learningOverviewbody
learningPlan | body, bodydiv, learningBasebody, learningPlanbody
learningSummary | body, bodydiv, learningBasebody, learningSummarybody

Inheritance

- topic/section

Example

<reference id="reference">
 <title>Copy Command</title>
 <refbody>
  <section>
   <title>Purpose</title>
   <p>This little command copies
   things.</p>
  </section>
 </refbody>
</reference>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.30 q
Next topic: 3.1.1.2.32 sectiondiv


sectiondiv

3.1.1.2.32 sectiondiv

The <sectiondiv> element allows logical grouping of content within a section. There is no additional meaning associated with the sectiondiv element, aside from its function as a container for other content. The sectiondiv element does not contain a title; the lowest level of titled content within a topic is the section itself. If additional hierarchy is required, nested topics should be used in place of the section.

The sectiondiv element nests itself, which means that it will often be used by specializers to create structured information within sections. Another common use case for the sectiondiv element is to group a sequence of related elements for reuse, so that another topic may reference the entire set with a single conref attribute.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base) | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup or sectiondiv) (any number)
topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup or sectiondiv) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup or sectiondiv) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup or sectiondiv) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, glossary, glossentry, glossgroup | section, sectiondiv
ditabase | section, sectiondiv, prereq, context, steps-informal, result, postreq, refsyn
reference | section, sectiondiv, refsyn
task (strict), task (general), machineryTask | section, sectiondiv, prereq, context, steps-informal, result, postreq
learningAssessment, learningOverview, learningPlan, learningSummary | section, sectiondiv, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction
learningContent | section, sectiondiv, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, result, postreq, refsyn

Inheritance

- topic/sectiondiv

Example

In the example below, the sectiondiv element is used to group content that may be reused in other situations.

<section>
  <title>Nice pets</title>
  <sectiondiv id="smallpets">
    <p>Cats are nice.</p>
    <p>Dogs are nice.</p>
    <p>Friends of mine really love their hedgehogs.</p>
  </sectiondiv>
  <sectiondiv id="biggerpets">
    <p>Lots of people want ponies when they grow up.</p>
    <p>Llamas are also popular.</p>
  </sectiondiv>
</section>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.31 section
Next topic: 3.1.1.2.33 sl


sl

3.1.1.2.33 sl

The <sl> element contains a simple list of items of short, phrase-like content, such as a list of materials in a kit or package.

On output, the list should have no bullets, on the assumption that each item is short enough to fit on one line, and needs no additional differentiation from its neighbors.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | (sli) (one or more)

Contained by

Doctype | Content model
topic (base) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, howtoavoid
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, howtoavoid
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, howtoavoid, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, howtoavoid, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, howtoavoid, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, howtoavoid, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, howtoavoid, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, howtoavoid, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, howtoavoid, pd
machineryTask | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, howtoavoid
learningAssessment, learningOverview, learningSummary | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase, lcInstructornote
learningPlan | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/sl

Example

In a reference topic discussing related modules, the following sample markup could be used:
<section><title>Messages</title>
 <p>Messages from the ags_open module are identical with messages from:</p>
 <sl>
  <sli>ags_read</sli>
  <sli>ags_write</sli>
  <sli>ags_close</sli>
 </sl>
</section>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.32 sectiondiv
Next topic: 3.1.1.2.34 sli


sli

3.1.1.2.34 sli

The <sli> element is an item in a simple list (<sl>). Simple list items have phrase or text content, adequate for describing package contents, for example. When a DITA topic is formatted for output, the items of a simple list should be placed each on its own line, with no other prefix such as a number (as in an ordered list) or bullet (as in an unordered list).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | sl

Inheritance

- topic/sli

Example

See sl.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.33 sl
Next topic: 3.1.1.2.35 term


term

3.1.1.2.35 term

The <term> element identifies words that may have or require extended definitions or explanations.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or text or tm) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid
map (base), classifyMap, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
subjectScheme | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, uicontrol, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords

Inheritance

- topic/term

Example

<p>The <term>reference implementation</term> of DITA represents the standard,
<q>fallback</q> behaviors intended for DITA elements.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.34 sli
Next topic: 3.1.1.2.36 text


text

3.1.1.2.36 text

The text element associates no semantics with its content. It exists to serve as a container for text where a container is needed (e.g., for conref, or for restricted content models in specializations). Unlike ph, text cannot contain images. Unlike keyword, text does not imply keyword-like semantics. The text element contains only text data, or nested text elements. All universal attributes are available on text.

For contexts where ph is available, authors should use that element. Where keyword is available, authors should use that element. Where neither ph nor keyword is available, text can be used to pull content by conref.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | text, keyword, term, ph, tm, shape
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | text, keyword, term, ph, tm, shape, wintitle, shortcut, option, parmname, synph, apiname, kwd, msgnum, cmdname, varname
machineryTask | text, keyword, term, ph, tm, shape, wintitle, shortcut
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | text, keyword, term, ph, tm, shape, lcAreaShape

Inheritance

- topic/text

Example

<p>This an example of <keyword><text id="reuse">Text
   that is reusable</text></keyword>, with no extra
   semantics attached to the text when it is reused.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.35 term
Next topic: 3.1.1.2.37 tm


tm

3.1.1.2.37 tm

The trademark (<tm>) element in DITA is used to markup and identify a term or phrase that is trademarked. Trademarks include registered trademarks, service marks, slogans and logos.

The business rules for indicating and displaying trademarks may differ from company to company and may be enforced by authoring policy and by specific processing.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or text or tm) (any number)

Contained by

Doctype | Content model
topic (base) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
topic (technical content), concept | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, pt, pd, fragref, synnote
map (technical content) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, pt, pd, fragref, synnote
ditabase | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, pt, pd, fragref, synnote
reference | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, pt, pd, fragref, synnote
task (strict), task (general) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, pt, pd, fragref, synnote
bookmap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, pt, pd, fragref, synnote
machineryTask | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub
learningAssessment, learningOverview, learningSummary | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
learningContent | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, keyword, term, ph, tm, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/tm

Example

<p>The advantages of using <tm trademark="DB2 Universal Database" tmtype="tm">
<tm trademark="DB2" tmtype="reg" tmclass="ibm">DB2</tm> Universal Database</tm> are
well known.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
trademark | The trademarked term | CDATA | #IMPLIED | No
tmowner | The trademark owner, for example "OASIS" | CDATA | #IMPLIED | No
tmtype | Specifies the trademark type: trademark (tm), registered trademark (regtm), or service mark (service) | CDATA | (tm | reg | service | -dita-use-​conref-​target) | Yes
tmclass | Classification of the trademark. This may used to differentiate different groupings of trademarks. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.36 text
Next topic: 3.1.1.2.38 ul


ul

3.1.1.2.38 ul

In an unordered list (<ul>), the order of the list items is not significant. List items are typically styled on output with a "bullet" character, depending on nesting level.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | (li) (one or more)

Contained by

Doctype | Content model
topic (base) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase, lcInstructornote
learningPlan | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/ul

Example

<ul>
 <li>This is an item in an unordered list.</li>
 <li>To separate it from other items in the list, the
 formatter puts a bullet beside it.</li>
 <li>The following paragraph, contained in the list item
 element, is part of the list item which contains it.
 <p>This is the contained paragraph.</p></li>
 <li>This is the last list item in our unordered list.</li>
</ul>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.37 tm
Next topic: 3.1.1.2.39 xref


xref

3.1.1.2.39 xref

Use the cross-reference (<xref>) element to link to a different location within the current topic, or a different topic within the same help system, or to external sources, such as Web pages, or to a location in another topic. The target of the cross-reference is specified using the href or keyref attributes.

Typically, it is best to restrict yourself to linking to reference topics where the content of the target is clear from the <xref>'s text, for example API names and their descriptions. With other information types, it may be less clear to the user whether they should follow the link, and often they will, thereby missing important information in following paragraphs. Therefore, it is a good idea to use links at the end of the topic, in the <related-links> element, wherever possible, rather than linking from within body content using <xref>. Links at the end of a topic can also be managed from outside the topic, using DITA maps. The DITA map method allows allows topics to be quickly integrated into new contexts without breaking links.

Cross references that link to elements in other topics should use key-based addressing (keyref) in order to make it possible to have the cross-reference point to different topics in the context of different top-level maps. Cross references that use only direct URI-based addressing (href) to point to other topics create dependencies such that if the topic with the cross-reference is included in a given map, the target topic must also be included or the cross-reference will not be resolvable in the context of that map. While you can use conditional processing to have different cross-references for different contexts, it is usually easier and more effective to use keys. By using keys, the cross-reference can be independent of the contexts it might used in because it is up to each different map to bind the key used by the cross-reference to the appropriate target.

Note:

When creating a cross-reference, link to the element structure, not the title element of the object. For example, to create a cross-reference to a figure, link to the <figure> element, not the <title> element within the <figure> element. Output processing should determine whether the text of the object's title element is used when rendering the cross-reference.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or data or data-about or foreign or unknown or image or desc) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or data or data-about or foreign or unknown or image or desc) (any number)
machineryTask | ( text data or boolean or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or state or data or data-about or foreign or unknown or image or desc) (any number)

Contained by

Doctype | Content model
topic (base) | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, area, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, b, u, i, tt, sup, sub, area, howtoavoid
topic (technical content), concept | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, area, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
map (technical content) | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, b, u, i, tt, sup, sub, area, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
ditabase | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, area, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
glossary, glossentry, glossgroup | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, area, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
reference | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, area, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
task (strict), task (general) | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, area, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
bookmap | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, organizationname, b, u, i, tt, sup, sub, area, howtoavoid, screen, codeph, codeblock, pt, pd, synnote
machineryTask | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, howtoavoid, b, u, i, tt, sup, sub, area, screen
learningAssessment, learningOverview, learningSummary | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, area, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcArea
learningBookmap | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, organizationname, b, u, i, tt, sup, sub, area, howtoavoid
learningContent | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, area, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcArea
learningPlan | desc, p, note, lq, q, sli, li, itemgroup, dt, dd, fig, figgroup, pre, lines, ph, stentry, draft-comment, fn, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, b, u, i, tt, sup, sub, area, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcArea

Inheritance

- topic/xref

Examples

Here's an example of a cross-reference to another topic; that topic's title will be used as the link text.

<p>Background information about DITA is provided in the topic entitled
<xref href="whatsdita.dita#tmmdita"></xref>.</p>

Here's an example of a cross-reference to another topic; the supplied text will be used as the link text:

<p><xref href="whatsdita.dita#tmmdita">Background information about
DITA</xref> is provided free of charge.</p>
If you are linking to an element inside of a topic, you should use the following format in the href attribute:
filename.dita#topicid/elementid
If you are linking within the same file, you can leave off the "filename.dita" part. So, for a section with the ID "mysection", you should use:
#topicid/mysection
For a list item within that section, assuming the item has an ID of "mylist", use
#topicid/mylist

See DITA addressing for details on using URI references and key references.

If your URL has an ampersand (&) in it, you need to code that using a entity reference. For example, this URL includes an & character:
http://www.example.com/docview.wss?rs=757&context=SSVNX5
When used in an href attribute, the ampersand must be entered as &amp; as shown here:
<xref href="http://www.example.com/docview.wss?rs=757&amp;context=SSVNX5"
scope="external">Part number SSVNX5</xref>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.2 Body elements
Previous topic: 3.1.1.2.38 ul
Next topic: 3.1.1.3 Table elements


Table elements

3.1.1.3 Table elements

DITA topics support two types of tables. The <table> element uses the OASIS Exchange Table Model (formerly known as the CALS table model). The OASIS table supports the spanning of multiple rows or columns for special layout or organizational needs, and provides a wide variety of controls over the display properties of the data and even the table structure itself.

The other table structure in DITA is called <simpletable>. As the name implies, it is structurally less complex than the OASIS table, and can be used as a very simple, regular table for which close control of formatting is not as important. The main advantage of simpletable is for describing lists of data with regular headings, such as telephone directory listings, display adapter configuration data, or API properties.

  • 3.1.1.3.1 table
    The <table> element organizes arbitrarily complex relationships of tabular information. This standard table markup allows column or row spanning and table captions or descriptions. An optional title allowed inside the table element provides a caption to describe the table.
  • 3.1.1.3.2 tgroup
    The <tgroup> element in a table contains column, row, spanning, header, and the body (<tbody>) of the table.
  • 3.1.1.3.3 colspec
    The <colspec> element contains a column specification for a table, including assigning a column name and number, cell content alignment, and column width.
  • 3.1.1.3.4 thead
    The table header (<thead>) element precedes the table body (<tbody>) element in a complex table.
  • 3.1.1.3.5 tbody
    The <tbody> element contains the rows in a table.
  • 3.1.1.3.6 row
    The <row> element contains a single row in a table <tgroup>.
  • 3.1.1.3.7 entry
    The <entry> element defines a single cell in a table.
  • 3.1.1.3.8 simpletable
    The <simpletable> element is used for tables that are regular in structure and do not need a caption. Choose the simple table element when you want to show information in regular rows and columns. For example, multi-column tabular data such as phone directory listings or parts lists are good candidates for simpletable. Another good use of simpletable is for information that seems to beg for a three-part definition list; the keycol attribute may be used to indicate which column represents the "key" or term-like column of your structure.
  • 3.1.1.3.9 sthead
    The simpletable header (<sthead>) element contains the table's header row. The header row is optional in a simple table.
  • 3.1.1.3.10 strow
    The <simpletable> row (<strow>) element specifies a row in a simple table.
  • 3.1.1.3.11 stentry
    The simpletable entry (<stentry>) element represents a single table cell, like <entry> in <table>. You can place any number of stentry cells in either an <sthead> element (for headings) or <strow> element (for rows of data).
Parent topic: 3.1.1 Topic elements
Previous topic: 3.1.1.2.39 xref
Next topic: 3.1.1.3.1 table


table

3.1.1.3.1 table

The <table> element organizes arbitrarily complex relationships of tabular information. This standard table markup allows column or row spanning and table captions or descriptions. An optional title allowed inside the table element provides a caption to describe the table.

The DITA table is based on the OASIS Exchange Table Model, augmented with DITA attributes that enable it for specialization, conref, and other DITA processing. In addition, the table includes a desc element, which enables table description that is parallel with figure description. See simpletable for a simplified table model that can be specialized to represent more regular relationships of data.

In DITA tables, in place of the expanse attribute used by other DITA elements, the pgwide attribute is used in order to conform to the OASIS Exchange Table Model. This attribute has a similar semantic (1=page width; 0=resize to galley or column).

Note: The scale attribute represents a stylistic markup property that is maintained (for now) in tables for legacy purposes. External stylesheets should enable less dependency on this attribute. You should use the scale attribute judiciously in your topics.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( ( (title) (optional) then (desc) (optional) ) (optional) then (tgroup) (one or more) )

Contained by

Doctype | Content model
topic (base) | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | p, note, lq, li, itemgroup, dd, draft-comment
topic (technical content) | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, pd
map (technical content), bookmap | p, note, lq, li, itemgroup, dd, draft-comment, pd
concept | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, conbody, pd
ditabase | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, stepresult, result, postreq, refbody, refbodydiv, refsyn, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, refbody, refbodydiv, refsyn, pd
task (strict), task (general) | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, stepresult, result, postreq, pd
machineryTask | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, stepresult, result, postreq, conbody, refbody, refbodydiv, refsyn, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

- topic/table

Example

Source:
<table>
<tgroup cols="2">
<colspec colname="COLSPEC0" colwidth="121*"/>
<colspec colname="COLSPEC1" colwidth="76*"/>
<thead>
<row>
<entry colname="COLSPEC0" valign="top">Animal</entry>
<entry colname="COLSPEC1" valign="top">Gestation</entry>
</row>
</thead>
<tbody>
<row>
<entry>Elephant (African and Asian)</entry>
<entry>19-22 months</entry>
</row>
<row>
<entry>Giraffe</entry>
<entry>15 months</entry>
</row>
<row>
<entry>Rhinoceros</entry>
<entry>14-16 months</entry>
</row>
<row>
<entry>Hippopotamus</entry>
<entry>7 1/2 months</entry>
</row>
</tbody>
</tgroup>
</table>
Formatted output:
Animal | Gestation
Elephant (African and Asian) | 19-22 months
Giraffe | 15 months
Rhinoceros | 14-16 months
Hippopotamus | 7 1/2 months

Attributes

Name | Description | Data Type | Default Value | Required?
frame Specifies which portion of a border should surround the element. Allowable values are:
top
Draw a line before the element
bottom
Draw a line after the element
topbot
Draw a line both before and after the element
all
Draw a box around the element
sides
Draw a line at each side of the element
none
Don't draw any lines around this element
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Some DITA processors or output formats may not be able to support all values.

(top | bottom | topbot | all | sides | none | -dita-use-​conref-​target) #IMPLIED No
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
rowsep | Row separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
pgwide Determines the horizontal placement of the element. Supported values are 1 and 0, although these are not mandated by the DTD or Schema.

For print-oriented display, the value "1" places the element on the left page margin; "0" aligns the element with the left margin of the current text line and takes indention into account.

For XHTML, the table surrounds the table data. Either value sets the table width to 100%.

NMTOKEN #IMPLIED No
rowheader This attribute specifies whether the content of the first column in a table contains row headings. In the same way that a column header introduces a table column, the row header introduces the table row. This attribute makes tables whose first column contains row headings more readable on output. Allowable values are:
firstcol
The first column contains the row headings.
norowheader
Indicates that no column contains row headings. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Note that this attribute is not part of the OASIS Exchange Table model upon which DITA tables are based; because of this, some DITA processors or output formats may not be able to support all values.

(firstCol | norowheader| -dita-use-​conref-​target) #IMPLIED No
scale Specifies a percentage, selected from an enumerated list, that is used to resize fonts in relation to the normal text size. This attribute is primarily useful for print-oriented display.

The scale attribute provides an acknowledged style-based property directly on DITA elements. For the table and fig elements, the intent of the property is to allow authors to adjust font sizes on the content of the containing element, primarily for print accomodation. An image in these contexts is to be scaled only by its own direct scale property. If not specifically scaled, such an image is unchanged by the scale property of its parent table or fig.

Some DITA processors or output formats may not be able to support all values.

(50 | 60 | 70 | 80 | 90 | 100 | 110 | 120 | 140 | 160 | 180 | 200 | -dita-use-​conref-​target) #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3 Table elements
Next topic: 3.1.1.3.2 tgroup


tgroup

3.1.1.3.2 tgroup

The <tgroup> element in a table contains column, row, spanning, header, and the body (<tbody>) of the table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (colspec) (any number) then (thead) (optional) then tbody)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | table

Inheritance

- topic/tgroup

Example

See table.

Attributes

Name | Description | Data Type | Default Value | Required?
cols | Indicates the number of columns in a <tgroup> in a table. | NMTOKEN | #REQUIRED | Yes
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
rowsep | Row separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
align Describes the alignment of text in a table column. Allowable values are:
left
Indicates left alignment of the text.
right
Indicates right alignment of the text.
center
Indicates center alignment of the text.
justify
Justifies the contents to both the left and the right.
char
Use the character specified on the char attribute for alignment.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(left | right | center | justify | char | -dita-use-​conref-​target) #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.1 table
Next topic: 3.1.1.3.3 colspec


colspec

3.1.1.3.3 colspec

The <colspec> element contains a column specification for a table, including assigning a column name and number, cell content alignment, and column width.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | tgroup

Inheritance

- topic/colspec

Example

See table.

Attributes

Name | Description | Data Type | Default Value | Required?
colnum | Indicates the number of a column in the table, counting from the first logical column to the last column. | NMTOKEN | #IMPLIED | No
colname | Specifies the table column name in which an entry is found. | NMTOKEN | #IMPLIED | No
colwidth | Describes the column width. | CDATA | #IMPLIED | No
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
rowsep | Row separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
align Describes the alignment of text in a table column. Allowable values are:
left
Indicates left alignment of the text.
right
Indicates right alignment of the text.
center
Indicates center alignment of the text.
justify
Justifies the contents to both the left and the right.
char
Use the character specified on the char attribute for alignment.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(left | right | center | justify | char | -dita-use-​conref-​target) #IMPLIED No
char Specifies the character for aligning the table entry data.

Default source for entry elements starting in this column. If character alignment is specified, the value is the single alignment character source for any implied char values for entry immediately in this column. A value of "" (the null string) means there is no aligning character.

For example, if align="char" and char="r", then text in the entry should align with the first occurrence of the letter "r" within the entry.

CDATA #IMPLIED No
charoff Specifies the horizontal offset of alignment character when align="char".

Default source for entry elements starting in this column. For character alignment on an entry in the column, horizontal character offset is the percent of the current column width to the left of the (left edge of the) alignment character.

This value should be number, greater than 0 and less than or equal to 100.

For example, if align="char", char="r", and charoff="50", then text in the entry should align 50% of the distance to the left of the first occurrence of the character "r" within the entry.

NMTOKEN #IMPLIED No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group.
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class | A common attribute described in Other common DITA attributes
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.2 tgroup
Next topic: 3.1.1.3.4 thead


thead

3.1.1.3.4 thead

The table header (<thead>) element precedes the table body (<tbody>) element in a complex table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (row) (one or more) )

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | tgroup

Inheritance

- topic/thead

Example

See table.

Attributes

Name | Description | Data Type | Default Value | Required?
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(top | bottom | middle | -dita-use-​conref-​target) #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.3 colspec
Next topic: 3.1.1.3.5 tbody


tbody

3.1.1.3.5 tbody

The <tbody> element contains the rows in a table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | (row) (one or more)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | tgroup

Inheritance

- topic/tbody

Example

See table.

Attributes

Name | Description | Data Type | Default Value | Required?
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(top | bottom | middle | -dita-use-​conref-​target) #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.4 thead
Next topic: 3.1.1.3.6 row


row

3.1.1.3.6 row

The <row> element contains a single row in a table <tgroup>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (entry) (one or more) )

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | thead, tbody

Inheritance

- topic/row

Example

See table.

Attributes

Name | Description | Data Type | Default Value | Required?
rowsep | Row separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(top | bottom | middle | -dita-use-​conref-​target) #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.5 tbody
Next topic: 3.1.1.3.7 entry


entry

3.1.1.3.7 entry

The <entry> element defines a single cell in a table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | row

Inheritance

- topic/entry

Example

See table.

Attributes

Name | Description | Data Type | Default Value | Required?
colname | Specifies the table column name in which an entry is found. | NMTOKEN | #IMPLIED | No
namest | Specifies the first logical column that is included in a horizontal span. | NMTOKEN | #IMPLIED | No
nameend | Specifies the last logical column that is included in a horizontal span. | NMTOKEN | #IMPLIED | No
morerows | Specifies the number of additional rows to add in a vertical span. | NMTOKEN | #IMPLIED | No
colsep | Column separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
rowsep | Row separator. A value of 0 indicates no separators; 1 indicates separators. | NMTOKEN | #IMPLIED | No
align Describes the alignment of text in a table column. Allowable values are:
left
Indicates left alignment of the text.
right
Indicates right alignment of the text.
center
Indicates center alignment of the text.
justify
Justifies the contents to both the left and the right.
char
Use the character specified on the char attribute for alignment.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(left | right | center | justify | char | -dita-use-​conref-​target) #IMPLIED No
char Specifies the character for aligning the table entry data.

Default source for entry elements starting in this column. If character alignment is specified, the value is the single alignment character source for any implied char values for entry immediately in this column. A value of "" (the null string) means there is no aligning character.

For example, if align="char" and char="r", then text in the entry should align with the first occurrence of the letter "r" within the entry.

CDATA #IMPLIED No
charoff Specifies the horizontal offset of alignment character when align="char".

Default source for entry elements starting in this column. For character alignment on an entry in the column, horizontal character offset is the percent of the current column width to the left of the (left edge of the) alignment character.

This value should be number, greater than 0 and less than or equal to 100.

For example, if align="char", char="r", and charoff="50", then text in the entry should align 50% of the distance to the left of the first occurrence of the character "r" within the entry.

NMTOKEN #IMPLIED No
valign Indicates the vertical alignment of text in a table entry (cell). Allowable values are:
top
Align the text to the top of the table entry (cell).
bottom
Align the text to the bottom of the table entry (cell).
middle
Align the text to the middle of the table entry (cell).
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(top | bottom | middle | -dita-use-​conref-​target) #IMPLIED No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group.
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.6 row
Next topic: 3.1.1.3.8 simpletable


simpletable

3.1.1.3.8 simpletable

The <simpletable> element is used for tables that are regular in structure and do not need a caption. Choose the simple table element when you want to show information in regular rows and columns. For example, multi-column tabular data such as phone directory listings or parts lists are good candidates for simpletable. Another good use of simpletable is for information that seems to beg for a three-part definition list; the keycol attribute may be used to indicate which column represents the "key" or term-like column of your structure.

This close match of simpletable to tabular, regular data makes simpletable suitable as the basis for specialized structures such as properties (for programming information) and choice tables (for tasks).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (sthead) (optional) then (strow) (one or more) )

Contained by

Doctype | Content model
topic (base) | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, howtoavoid
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | p, note, lq, li, itemgroup, dd, fig, draft-comment, howtoavoid
topic (technical content) | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, howtoavoid, pd
map (technical content), bookmap | p, note, lq, li, itemgroup, dd, fig, draft-comment, howtoavoid, pd
concept | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, conbody, howtoavoid, pd
ditabase | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, stepresult, result, postreq, refbody, refbodydiv, refsyn, glossdef, glossUsage, glossScopeNote, howtoavoid, pd
glossary, glossentry, glossgroup | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, conbody, glossdef, glossUsage, glossScopeNote, howtoavoid, pd
reference | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, refbody, refbodydiv, refsyn, howtoavoid, pd
task (strict), task (general) | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, stepresult, result, postreq, howtoavoid, pd
machineryTask | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, howtoavoid
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, stepresult, result, postreq, conbody, refbody, refbodydiv, refsyn, lcInteractionBase, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, fig, draft-comment, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase, lcInstructornote

Inheritance

- topic/simpletable

Example

Source:
<simpletable>
 <sthead>
  <stentry>Type style</stentry>
  <stentry>Elements used</stentry>
 </sthead>
 <strow>
  <stentry>Bold</stentry>
  <stentry>b</stentry>
 </strow>
 <strow>
  <stentry>Italic</stentry>
  <stentry>i</stentry>
 </strow>
 <strow>
  <stentry>Underlined</stentry>
  <stentry>u</stentry>
 </strow>
</simpletable>
Formatted output:
Type style | Elements used
Bold | b
Italic | i
Underlined | u

Example using keycol

In this sample, the first column is identified as a header column through the use of keycol="1" on the <simpletable> element. This indicates that items in the first column should be treated as headers for the row that follows. Rendering of the header column is left up to the implementation.

Source:
<simpletable keycol="1">
 <sthead>
  <stentry>Term</stentry>
  <stentry>Categorization</stentry>
  <stentry>Definition</stentry>
 </sthead>
 <strow>
  <stentry>Widget</stentry>
  <stentry>noun</stentry>
  <stentry>Thing that is used for something</stentry>
 </strow>
 <strow>
  <stentry>Frustration</stentry>
  <stentry>noun</stentry>
  <stentry>What you feel when you drop the widget</stentry>
 </strow>
</simpletable>
Formatted output:
Term | Categorization | Definition
Widget | noun | Thing that is used for something
Frustration | noun | What you feel when you drop the widget

Attributes

Name | Description | Data Type | Default Value | Required?
relcolwidth A relative value to specify the width of a column in relationship to the width of the other columns. The values are totaled and made a percent. For example:
relcolwidth="1* 2* 3*"
causes widths of 16.7%, 33.3%, and 66.7%.
relcolwidth="90* 150*"
causes width of 37.5% and 62.5%. 		CDATA #IMPLIED No
keycol | Defines the column that can contains headings for each row. No value indicates no key column. When present, the numerical value causes the specified column to be treated as a vertical header. | NMTOKEN | #IMPLIED | No
refcols | The refcols attribute is currently undefined, and is reserved for future use. | NMTOKENS | #IMPLIED | No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.7 entry
Next topic: 3.1.1.3.9 sthead


sthead

3.1.1.3.9 sthead

The simpletable header (<sthead>) element contains the table's header row. The header row is optional in a simple table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | (stentry) (one or more)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | simpletable

Inheritance

- topic/sthead

Example

See simpletable.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.8 simpletable
Next topic: 3.1.1.3.10 strow


strow

3.1.1.3.10 strow

The <simpletable> row (<strow>) element specifies a row in a simple table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | (stentry) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | simpletable

Inheritance

- topic/strow

Example

See simpletable.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.9 sthead
Next topic: 3.1.1.3.11 stentry


stentry

3.1.1.3.11 stentry

The simpletable entry (<stentry>) element represents a single table cell, like <entry> in <table>. You can place any number of stentry cells in either an <sthead> element (for headings) or <strow> element (for rows of data).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | sthead, strow

Inheritance

- topic/stentry

Example

See simpletable.

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.3 Table elements
Previous topic: 3.1.1.3.10 strow
Next topic: 3.1.1.4 Related links elements


Related links elements

3.1.1.4 Related links elements

The related-links section of DITA topics is a special structure that contains links. Links support navigation from a topic to other related topics or resources.

Links are different from cross-references. While cross-references occur only within the body of a topic and can target any element in this or other topics, links only represent topic-to-topic connections, or connections to non-DITA-topic resources. Links are located after the body of a topic, in the related-links element.

Links can also be managed indirectly using DITA maps, which provide a more efficient way to manage links and avoids embedded pointers in each topic. This helps keep topics free from specific contexts, and makes it easier to reuse those topics in new locations.

  • 3.1.1.4.1 link
    The <link> element defines a relationship to another topic. Links are typically sorted when displayed based on their attributes, which define the type or role of the link's target in relation to the current topic.
  • 3.1.1.4.2 linklist
    The <linklist> element defines an author-arranged group of links. When you use a <linklist> element, the organization of links on final output is in the same order as originally authored inside that element.
  • 3.1.1.4.3 linkpool
    The <linkpool> element defines a group of links that have common characteristics, such as type or audience or source. When links are in <related-links> or <linkpool> elements, the organization of links on final output is determined by the output process, not by the order that the links actually occur in the DITA topic.
  • 3.1.1.4.4 linktext
    The <linktext> element provides the literal label or line of text for a link. In most cases, the text of a link can be resolved during processing by cross reference with the target resource. Use the <linktext> element only when the target cannot be reached, such as when it is a peer or external link, or when the target is local but not in DITA format. When used inside a topic, it is used as the text for the specified link; when used within a map, it is used as the text for generated links that point to the specified topic.
  • 3.1.1.4.5 linkinfo
    The <linkinfo> element allows you to place a descriptive paragraph after the links that are contained in a <linklist> element.
Parent topic: 3.1.1 Topic elements
Previous topic: 3.1.1.3.11 stentry
Next topic: 3.1.1.4.1 link


link

3.1.1.4.1 link

The <link> element defines a relationship to another topic. Links are typically sorted when displayed based on their attributes, which define the type or role of the link's target in relation to the current topic.

The optional container elements for link (<linkpool> and <linklist>) allow authors to define groups with common attributes or to preserve the authored sequence of links on output. Links placed in a <linkpool> may be rearranged or removed for display purposes (combined with other local or map-based links); links in a <linklist> should be displayed in the order they are defined. Refer to those elements for additional explanation.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, ditabase, glossary, glossentry, glossgroup, reference, task, machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (linktext) (optional) then (desc) (optional) )

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | related-links, linklist, linkpool

Inheritance

- topic/link

Example

<related-links>
  <linkpool type="concept">
    <link href="czez.dita#czez" role="next"></link>
    <link href="czunder.dita"></link>
    <link format="html" href="czover.htm#sqljsupp" role="parent">
      <linktext>Overview of the CZ</linktext>
    </link>
    <link format="html" href="czesqlj.htm#sqljemb">
      <linktext>Working with CZESQLJ</linktext>
      <desc>When you work with CZESQLJ, you need to know...</desc>
    </link>
  </linkpool>
<related-links>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
role | The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time. See The role attribute for information on supported values. The role attribute values sample and external are deprecated. | (parent | child | sibling | friend | next | previous | cousin | ancestor | descendant | sample | external | other | -dita-use-​conref-​target) | #IMPLIED | No
otherrole | Indicates an alternate role. This value is used when the role attribute is set to other. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.4 Related links elements
Previous topic: 3.1.1.4 Related links elements
Next topic: 3.1.1.4.2 linklist


linklist

3.1.1.4.2 linklist

The <linklist> element defines an author-arranged group of links. When you use a <linklist> element, the organization of links on final output is in the same order as originally authored inside that element.

There are two ways to organize related information links within a topic. First, you can add them all in no particular order, either by using <linkpool> elements or by placing <link> elements directly within <related-links>, in which case the rendering is implementation dependent. For example, tools may choose to sort all links based on the role or type; tools may also move or remove links to fit the context (for example, moving a prerequisite link to the top of a browser window, or removing links to the next topic if it is rendered on the same page in a PDF). These behaviors are examples only and are not required.

Second, links may be grouped using one or more <linklist> elements. When you group them using <linklist>, then the order of the links within each <linklist> is preserved when rendered. You may also use a combination of the two approaches, which will allow some links to be automatically sorted while the others are left as-is.

Attributes set on the <linkpool> and <linklist> elements are inherited by their descendants. For example, if you have a <linklist> element that contains all external links, you can set scope="external" on that outer <linklist> element and leave it off the <link> elements within that <linklist>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, ditabase, glossary, glossentry, glossgroup, reference, task, machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (desc) (optional) then (linklist or link) (any number) then (linkinfo) (optional) )

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | related-links, linklist

Inheritance

- topic/linklist

Example

<related-links>
  <linklist scope="external">
    <title>Example links</title>
    <desc>These links will always appear in this order.</desc>
    <link href="http://www.example.org">
      <linktext>Example 1</linktext>
    </link>
    <link href="http://www.example.com">
      <linktext>Example 2</linktext>
    </link>
  </linklits>
</related-links>

Attributes

Name | Description | Data Type | Default Value | Required?
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
duplicates | Specifies whether or not duplicate links will be filtered out of a linklist. Allowable values are: "yes" (allow duplicate links), or "no" (filter out duplicate links). In general, duplicate links in linklists are preserved.. Note that links are regarded as duplicates only if their content plus all attributes match. | #IMPLIED | The attribute value is currently ignored, but should default to yes for links in linklists and no for all other links. | No
mapkeyref | Identifies the map, if any, from which the contained links are derived. This value is automatically generated by the same process that creates the links from the map, as a way to identify which map the links came from. If the <linklist> or <linkpool> is manually created by the author, there is no need to use this attribute. Note that this attribute is not related to the keyref attribute, and is not used for key based processing. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
role The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time. See The role attribute for information on supported values.

The role attribute values sample and external are deprecated.

(parent | child | sibling | friend | next | previous | cousin | ancestor | descendant | sample | external | other | -dita-use-​conref-​target) #IMPLIED No
otherrole | Indicates an alternate role. This value is used when the role attribute is set to other. | CDATA | #IMPLIED | No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.4 Related links elements
Previous topic: 3.1.1.4.1 link
Next topic: 3.1.1.4.3 linkpool


linkpool

3.1.1.4.3 linkpool

The <linkpool> element defines a group of links that have common characteristics, such as type or audience or source. When links are in <related-links> or <linkpool> elements, the organization of links on final output is determined by the output process, not by the order that the links actually occur in the DITA topic.

There are two ways to organize related information links within a topic. First, you can add them all in no particular order, either by using <linkpool> elements or by placing <link> elements directly within <related-links>, in which case the rendering is implementation dependent. For example, tools may choose to sort all links based on the role or type; tools may also move or remove links to fit the context (for example, moving a prerequisite link to the top of a browser window, or removing links to the next topic if it is rendered on the same page in a PDF). These behaviors are examples only and are not required.

Second, links may be grouped using one or more <linklist> elements. When you group them using <linklist>, then the order of the links within each <linklist> is preserved when rendered. You may also use a combination of the two approaches, which will allow some links to be automatically sorted while the others are left as-is.

Attributes set on the <linkpool> and <linklist> elements are inherited by their descendants. For example, if you have a <linklist> element that contains all external links, you can set scope="external" on that outer <linklist> element and leave it off the <link> elements within that <linklist>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, ditabase, glossary, glossentry, glossgroup, reference, task, machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | (linkpool or link) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | related-links, linkpool

Inheritance

- topic/linkpool

Example

<related-links>
  <linkpool type="concept">
    <link href="czez.dita#czez" role="next"></link>
    <link href="czunder.dita"></link>
    <link format="html" href="czover.htm#sqljsupp" role="parent">
      <linktext>Overview of the CZ</linktext>
    </link>
    <link format="html" href="czesqlj.htm#sqljemb">
      <linktext>Working with CZESQLJ</linktext>
      <desc>When you work with CZESQLJ, you need to know...</desc>
    </link>
  </linkpool>
<related-links>

Attributes

Name | Description | Data Type | Default Value | Required?
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
duplicates | Specifies whether or not duplicate links will be filtered out of a linklist. Allowable values are: "yes" (allow duplicate links), or "no" (filter out duplicate links). In general, duplicate links in linklists are preserved.. Note that links are regarded as duplicates only if their content plus all attributes match. | #IMPLIED | The attribute value is currently ignored, but should default to yes for links in linklists and no for all other links. | No
mapkeyref | Identifies the map, if any, from which the contained links are derived. This value is automatically generated by the same process that creates the links from the map, as a way to identify which map the links came from. If the <linklist> or <linkpool> is manually created by the author, there is no need to use this attribute. Note that this attribute is not related to the keyref attribute, and is not used for key based processing. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
role The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time. See The role attribute for information on supported values.

The role attribute values sample and external are deprecated.

(parent | child | sibling | friend | next | previous | cousin | ancestor | descendant | sample | external | other | -dita-use-​conref-​target) #IMPLIED No
otherrole | Indicates an alternate role. This value is used when the role attribute is set to other. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.1.4 Related links elements
Previous topic: 3.1.1.4.2 linklist
Next topic: 3.1.1.4.4 linktext


linktext

3.1.1.4.4 linktext

The <linktext> element provides the literal label or line of text for a link. In most cases, the text of a link can be resolved during processing by cross reference with the target resource. Use the <linktext> element only when the target cannot be reached, such as when it is a peer or external link, or when the target is local but not in DITA format. When used inside a topic, it is used as the text for the specified link; when used within a map, it is used as the text for generated links that point to the specified topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or ph or b or i or sup or sub or tt or u) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or ph or b or i or sup or sub or tt or u or menucascade or uicontrol) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | link
map (base), map (technical content), classifyMap, subjectScheme, learningMap | topicmeta
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

"- topic/linktext " when used in topics, and "- map/linktext " when used in maps.

Example

<link href="tzover.htm#accsqlj">
 <linktext>Accessing relational data with SQLJ</linktext>
</link>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.4 Related links elements
Previous topic: 3.1.1.4.3 linkpool
Next topic: 3.1.1.4.5 linkinfo


linkinfo

3.1.1.4.5 linkinfo

The <linkinfo> element allows you to place a descriptive paragraph after the links that are contained in a <linklist> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base) | ( text data or dl or image or lines or lq or note or hazardstatement or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task | ( text data or dl or parml or image or lines or lq or note or hazardstatement or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or dl or image or lines or lq or note or hazardstatement or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or image or lines or lq or note or lcInstructornote or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | linklist

Inheritance

- topic/linkinfo

Example

<linklist>
  <title>Repairing widgets</title>
  <link href="debug.dita" type="task"></link>
  <link href="repair.dita" type="task"></link>
  <link href="test.dita" type="task"></link>
  <linkinfo>To repair a reciprocating widget,
you must follow the instructions very carefully. Note
the sequence to follow. Do it.</linkinfo>
</linklist>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.1.4 Related links elements
Previous topic: 3.1.1.4.4 linktext
Next topic: 3.1.2 Map elements


Map elements

3.1.2 Map elements

Map elements include the core components of DITA maps, such as <topicref> and <reltable>, as well as general purpose map specializations in the map group domain.

  • 3.1.2.1 Basic map elements
    DITA maps are built from a few core elements that are used for referencing and organizing topics. The <topicmeta> element is also available to specify metadata for the map, for individual topics, or for groups of topics. Many elements inside <topicmeta> are also available inside the topic prolog.
  • 3.1.2.2 Map group elements
    The map group domain elements define, group, or reference content. Many of the map group elements are convenience elements, which means that they simply make it easier for an author to make use of existing functions.
Parent topic: 3.1 Base elements
Previous topic: 3.1.1.4.5 linkinfo
Next topic: 3.1.2.1 Basic map elements


Basic map elements

3.1.2.1 Basic map elements

DITA maps are built from a few core elements that are used for referencing and organizing topics. The <topicmeta> element is also available to specify metadata for the map, for individual topics, or for groups of topics. Many elements inside <topicmeta> are also available inside the topic prolog.

  • 3.1.2.1.1 map
    The <map> element describes the relationships among a set of resources, such as DITA topics. Maps consist of references to topics, maps, and other resources organized into hierarchies, groups, and tables. Maps express these relationships in a single common format that can be used for different outputs.
  • 3.1.2.1.2 topicref
    The <topicref> element identifies a topic (such as a concept, task, or reference) or other resource. A <topicref> can contain other <topicref> elements, allowing you to express navigation or table-of-contents hierarchies, as well as implying relationships between a containing (parent) <topicref> and its children. You can set the collection-type of a parent <topicref> to determine how its children are related to each other. You can also express relationships among <topicref> elements by using group and table structures (<topicgroup> and <reltable>). Relationships are expressed as links in the output; by default, each participant in a relationship has links to the other participants in that relationship.
  • 3.1.2.1.3 topicmeta
    The <topicmeta> element defines the metadata that applies to a topic when it appears in a map. When appropriate, that metadata also applies to the other topics in the map that are contained by the same element that contains the <topicmeta> element. When creating links, <topicmeta> content can also be used to override the title and short description that are used for the link. In addition, it can be used to add index entries to referenced content using the <keywords> element.
  • 3.1.2.1.4 anchor
    The <anchor> element provides an integration point that another map can reference in order to insert its navigation into the current navigation tree. For those familiar with Eclipse help systems, this serves the same purpose as the <anchor> element in that system. It may not be supported for all output formats.
  • 3.1.2.1.5 navref
    The <navref> element represents a pointer to another map which should be preserved as a transcluding link rather than resolved. Output formats that support such linking will integrate the referenced resource when displaying the referencing map to an end user.
  • 3.1.2.1.6 reltable
    The <reltable> element is a relationship table that specifies relationships between topics, based on the familiar table model of rows (<relrow>), columns (<relheader>), and cells (<relcell>).
  • 3.1.2.1.7 relrow
    The <relrow> element defines a row in the relationship table (<reltable>). It creates a relationship between the cells in the row, which is expressed in output as links between the topics or resources referenced in those cells.
  • 3.1.2.1.8 relcell
    The <relcell> element defines a cell in the relationship table (<reltable>). The <topicref> elements that it contains are related to the <topicref> elements in other cells of the same row. By default, topics or resources that are referenced in the same cell are not related to each other, unless you change the collection-type attribute of the <relcell> to indicate that they are related.
  • 3.1.2.1.9 relheader
    The <relheader> element is a row in a relationship table that contains column definitions (<relcolspec> elements). Each table can have only one set of column definitions.
  • 3.1.2.1.10 relcolspec
    The <relcolspec> element is used to define a column in a relationship table. The <relcolspec> element may be used to set default values for the <topicref> elements in the column.
Parent topic: 3.1.2 Map elements
Previous topic: 3.1.2 Map elements
Next topic: 3.1.2.1.1 map


map

3.1.2.1.1 map

The <map> element describes the relationships among a set of resources, such as DITA topics. Maps consist of references to topics, maps, and other resources organized into hierarchies, groups, and tables. Maps express these relationships in a single common format that can be used for different outputs.

The containing element for a map is the <map> element. Within the map, use the <topicref> element to add and organize references to the topics, and the <topicgroup> and <reltable> elements to provide non-hierarchical relationships. You can use the <map> element to set default attribute values for all <topicref> elements in the map.

A map describes the relationships among a set of DITA topics. The following are some examples of relationships that can be described in a map:
  • Hierarchical (Parent/Child). Nested topics create a hierarchical relationship. The topic that does the nesting is the parent, and the topics that are nested are the children.
  • Ordered. Child topics can be labeled as having an ordered relationship, which means they are referenced in a definite sequence.
  • Family. Child topics can be labeled as having a family relationship, which means they all refer to each other.

When rendering a map, processors may make use of these relationships, such as to create a Table of Contents (TOC), aggregate topics into a PDF document, or create links between topics in output.

The title element may optionally be used to provide a title for the map (the title element is preferred over the title attribute). In some scenarios the title is purely informational, and is present as an aid to the author. In other scenarios it may be useful or even required. For example, if a map is converted to Eclipse Help, the Eclipse system will require a title for the resulting table of contents. In the bookmap specialization of map, the <title> element provides a title for the book represented by that map.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (title) (optional) then (topicmeta) (optional) then (anchor or data or data-about or navref or reltable or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (title) (optional) then (topicmeta) (optional) then (anchor or data or data-about or navref or reltable or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (title) (optional) then (topicmeta) (optional) then (anchor or data or data-about or navref or reltable or (topicSubjectTable) or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (title) (optional) then (topicmeta) (optional) then (anchor or data or data-about or navref or reltable or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (title) (optional) then (topicmeta) (optional) then (anchor or data or data-about or navref or reltable or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

This element is not contained by any other elements.

Inheritance

- map/map

Example

In this example, there are six topicrefs. They are nested and have a hierarchical relationship. The file bats.dita is the parent topic and the other topics are its children. The hierarchy could be used to generate a PDF, a navigation pane in an information center, a summary of the topics, or related links between the parent topic and its children.

<map id="mybats">
  <title>Bats</title>
  <topicref href="bats.dita" type="topic">
    <topicref href="batcaring.dita" type="task"></topicref>
    <topicref href="batfeeding.dita" type="task"></topicref>
    <topicref href="batsonar.dita" type="concept"></topicref>
    <topicref href="batguano.dita" type="reference"></topicref>
    <topicref href="bathistory.dita" type="reference"></topicref>
  </topicref>
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
title | An identifying title for the map. May be used or ignored, depending on the capabilities of the display mechanism. Note that beginning with DITA 1.1, the map can include a title element, which is preferred over the title attribute. | CDATA | #IMPLIED | No
id | Allows an ID to be specified for the map. Note that maps do not require IDs (unlike topics), and the map ID is not included in references to elements within a map. | ID | #IMPLIED | No
conref | This attribute is used to reference an ID on a map that can be reused. See The conref attribute for examples and details about the syntax. | CDATA | #IMPLIED | No
anchorref | Identifies a location within another map file where this map will be anchored at runtime. Resolution of the map is deferred until the final step in the delivery of any rendered content. For example, anchorref="map1.ditamap/a1" causes this map to be pulled into the location of the anchor point "a1" inside map1.ditamap when map1.ditamap is rendered for delivery. | CDATA | #IMPLIED | No
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1 Basic map elements
Next topic: 3.1.2.1.2 topicref


topicref

3.1.2.1.2 topicref

The <topicref> element identifies a topic (such as a concept, task, or reference) or other resource. A <topicref> can contain other <topicref> elements, allowing you to express navigation or table-of-contents hierarchies, as well as implying relationships between a containing (parent) <topicref> and its children. You can set the collection-type of a parent <topicref> to determine how its children are related to each other. You can also express relationships among <topicref> elements by using group and table structures (<topicgroup> and <reltable>). Relationships are expressed as links in the output; by default, each participant in a relationship has links to the other participants in that relationship.

You can fine tune the output from your map by setting different attributes on the <topicref> element. For example, the linking attribute controls how a topic's relationships to other topics are expressed as links, and the toc attribute controls whether the topic shows up in TOC or navigation output.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
bookmap, learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell
subjectScheme | map, topicref, relcolspec, relcell, subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

- map/topicref

Example

In this example, there are six <topicref> elements. They are nested and have a hierarchical relationship. Bats.dita is the parent topic and the other topics are its children.
<map title="Bats">
 <topicref href="bats.dita" type="topic">
  <topicref href="batcaring.dita" type="task"></topicref>
  <topicref href="batfeeding.dita" type="task"></topicref>
  <topicref href="batsonar.dita" type="concept"></topicref>
  <topicref href="batguano.dita" type="reference"></topicref>
  <topicref href="bathistory.dita" type="reference"></topicref>
 </topicref>
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.1 map
Next topic: 3.1.2.1.3 topicmeta


topicmeta

3.1.2.1.3 topicmeta

The <topicmeta> element defines the metadata that applies to a topic when it appears in a map. When appropriate, that metadata also applies to the other topics in the map that are contained by the same element that contains the <topicmeta> element. When creating links, <topicmeta> content can also be used to override the title and short description that are used for the link. In addition, it can be used to add index entries to referenced content using the <keywords> element.

The metadata given in a <topicmeta> element is specific to a given context within a map. If a reference to a single resource appears more than once in a map or set of maps, unique metadata may be specified in each instance. For example, the two references to a single resource may specify different navigation titles or search titles, each of which is specific to a single context.
Note: The topic Cascading of attributes and metadata in a DITA map in the DITA Architectural Specification provides more information about which metadata elements inside <topicmeta> cascade to other <topicref> elements. In addition, the topic Reconciling topic and map metadata provides more information about how metadata specified in the map interacts with metadata specified in each topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, classifyMap | ( (navtitle) (optional) then (linktext) (optional) then (searchtitle) (optional) then (shortdesc) (optional) then (author) (any number) then (source) (optional) then (publisher) (optional) then (copyright) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata) (any number) then (audience) (any number) then (category) (any number) then (keywords or exportanchors) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (resourceid) (any number) then (data or data-about or foreign or unknown) (any number) )
bookmap | ( (navtitle) (optional) then (linktext) (optional) then (searchtitle) (optional) then (shortdesc) (optional) then (author or authorinformation) (any number) then (source) (optional) then (publisher) (optional) then (copyright) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata) (any number) then (audience) (any number) then (category) (any number) then (keywords or exportanchors) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (resourceid) (any number) then (data or data-about or foreign or unknown) (any number) )
subjectScheme | ( (navtitle) (optional) then (linktext) (optional) then (searchtitle) (optional) then (shortdesc) (optional) then (author) (any number) then (source) (optional) then (publisher) (optional) then (copyright) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata) (any number) then (audience) (any number) then (category) (any number) then (keywords) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (resourceid) (any number) then (data or data-about or foreign or unknown) (any number) )
learningBookmap | ( (navtitle) (optional) then (linktext) (optional) then (searchtitle) (optional) then (shortdesc) (optional) then (author or authorinformation) (any number) then (source) (optional) then (publisher) (optional) then (copyright) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata or lcLom) (any number) then (audience) (any number) then (category) (any number) then (keywords or exportanchors) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (resourceid) (any number) then (data or data-about or foreign or unknown) (any number) )
learningMap | ( (navtitle) (optional) then (linktext) (optional) then (searchtitle) (optional) then (shortdesc) (optional) then (author) (any number) then (source) (optional) then (publisher) (optional) then (copyright) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata or lcLom) (any number) then (audience) (any number) then (category) (any number) then (keywords or exportanchors) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (resourceid) (any number) then (data or data-about or foreign or unknown) (any number) )

Contained by

Doctype | Content model
map (base) | map, topicref, reltable, relcolspec, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef
map (technical content) | map, topicref, reltable, relcolspec, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, glossref
bookmap | map, topicref, reltable, relcolspec, draftintro, preface, chapter, part, appendix, appendices, notices, glossarylist, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef
classifyMap | map, topicref, reltable, relcolspec, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, topicsubject, topicapply, subjectref, topicSubjectTable
subjectScheme | map, topicref, reltable, relcolspec, subjectScheme, schemeref, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectRelTable, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef
learningBookmap | map, topicref, reltable, relcolspec, draftintro, preface, chapter, part, appendix, appendices, notices, glossarylist, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, learningGroup, learningObject, learningPlanRef, learningOverviewRef, learningSummaryRef, learningContentRef, learningContentComponentRef, learningPreAssessmentRef, learningPostAssessmentRef
learningMap | map, topicref, reltable, relcolspec, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, learningGroup, learningObject, learningPlanRef, learningOverviewRef, learningSummaryRef, learningContentRef, learningContentComponentRef, learningPreAssessmentRef, learningPostAssessmentRef

Inheritance

- map/topicmeta

Example

In this example, the metadata defined by the <topicmeta> element applies to the associated <topicref> (bats.dita) and all of its children. The <topicmeta> element contains an audience definition which indicates that bats.dita and its children are of interest to experienced programmers who are troubleshooting.
<map>
  <topicref href="bats.dita">
    <topicmeta>
      <audience type="programmer" job="troubleshooting" experiencelevel="expert"/>
    </topicmeta>
    <topicref href="batcaring.dita"></topicref>
    <topicref href="batfeeding.dita"></topciref>
  </topicref>
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
lockmeta | Indicates whether any of the meta information should be replaced by meta information in the referenced topic. If the value is yes, the information inside <topicmeta> should not be replaced with information from the topic. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.2 topicref
Next topic: 3.1.2.1.4 anchor


anchor

3.1.2.1.4 anchor

The <anchor> element provides an integration point that another map can reference in order to insert its navigation into the current navigation tree. For those familiar with Eclipse help systems, this serves the same purpose as the <anchor> element in that system. It may not be supported for all output formats.

The <anchor> element is typically used to allow integration of run-time components. For build-time integration, you can instead use the conref or conkeyref attribute on an element inside the map. For example, a <topicref> element may use conref to pull in content at build-time from a <topicref> in another map.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | no content

Contained by

Doctype | Content model
map (base), map (technical content), bookmap, classifyMap, learningBookmap, learningMap | map, topicref, topichead, topicgroup, topicset, keydef
subjectScheme | map, topicref, subjectScheme, topichead, topicgroup, topicset, keydef

Inheritance

- map/anchor

Example

In this example, an anchor is defined with an ID of "a1".
<map>
  <title>MyComponent tasks</title>
  <topicref navtitle="Start here" href="start.dita" toc="yes">
    <navref mapref="othermap2.ditamap"/>
    <navref mapref="othermap3.ditamap"/>
    <anchor id="a1"/>
  </topicref>
</map>
The id on <anchor> can be referenced by the anchorref attribute on another map's <map> element. For example, the map to be integrated at that spot would be defined as follows.
<map anchorref="a1">
  <title>This map is pulled into the MyComponent task map</title>
  ...
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
id | Provides an integration point that another map may reference in order to insert its navigation into the current navigation tree. The anchorref attribute on a map may be used to reference this attribute. See ID attribute in the Architectural Specification for more details. | NMTOKEN | #REQUIRED | Yes
conref | This attribute is used to reference an ID on content that can be reused. See The conref attribute for examples and details about the syntax. | CDATA | #IMPLIED | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.3 topicmeta
Next topic: 3.1.2.1.5 navref


navref

3.1.2.1.5 navref

The <navref> element represents a pointer to another map which should be preserved as a transcluding link rather than resolved. Output formats that support such linking will integrate the referenced resource when displaying the referencing map to an end user.

For example, if a map is converted to the Eclipse help system format, the DITA element <navref mapref="other.ditamap"/> should be converted to the Eclipse element <link toc="other.xml"/>. When Eclipse loads the referencing map, it will replace this link element with the contents of the file "other.xml", provided that the file "other.xml" is available.

Note that not all output formats support such linking. In order to include another map directly without depending on the output format, use a <topicref> element with the format attribute set to "ditamap". The effect is similar to a conref. For example, the following markup represents a literal inclusion of the map "other.ditamap":
<topicref href="other.ditamap" format="ditamap"/>

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | no content

Contained by

Doctype | Content model
map (base), map (technical content), bookmap, classifyMap, learningBookmap, learningMap | map, topicref, topichead, topicgroup, topicset, keydef
subjectScheme | map, topicref, subjectScheme, topichead, topicgroup, topicset, keydef

Inheritance

- map/navref

Example

In this example, the map titled "MyComponent tasks" references the maps "othermap2.ditamap" and "othermap3.ditamap".

<map title="MyComponent tasks">
 <navref mapref="../com.ibm.xml.doc/othermap1.ditamap"/>
 <navref mapref="../com.ibm.xml.doc/othermap2.ditamap"/>
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
mapref | Specifies the URL (local filename, at least) of the map file to reference. It may point to a DITA map, or to a file that is appropriate for your output format (such as XML TOC file for Eclipse output). | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.4 anchor
Next topic: 3.1.2.1.6 reltable


reltable

3.1.2.1.6 reltable

The <reltable> element is a relationship table that specifies relationships between topics, based on the familiar table model of rows (<relrow>), columns (<relheader>), and cells (<relcell>).

A frequently-used type of relationship table establishes relationships between task, concept, and reference topics. Each column in a relationship table typically represents a specific role in a set of relationships; for example, the first column often contains references to tasks, while the second and third columns often reference concept and reference topics. The relationship table rows define relationships between the resources referenced in different cells of the same row; in this example, each row establishes relationships between tasks and the concept and reference topics that support the tasks. When used in this manner, relationship tables make it easy to determine where related information is missing or undefined.

By default, the contents of a <reltable> element are not output for navigation or TOC purposes; they are used only to define relationships that can be expressed as topic-to-topic links. The <relcell> elements can contain <topicref> elements, which are then related to other <topicref> elements in the same row (although not necessarily in the same cell).

Relationship tables can be used in conjunction with hierarchies and groups to manage all the related links in an information set.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | ( (title) (optional) then (topicmeta) (optional) then (relheader) (optional) then (relrow) (one or more) )

Contained by

Doctype | Content model
map (base), map (technical content), classifyMap, learningMap | map
bookmap, learningBookmap | map, bookmap
subjectScheme | map, subjectScheme

Inheritance

- map/reltable

Example

In this example, a relationship table is defined with three columns; one for "concept", one for "task", and one for "reference". Three cells are defined within one row. The first cell contains one concept topic: batsonar.dita. The second cell contains two task topics: batcaring.dita and batfeeding.dita. The third cell contains two reference topics: batguano.dita and bathistory.dita.

<map>
  <reltable>
    <relheader>
      <relcolspec type="concept"/>
      <relcolspec type="task"/>
      <relcolspec type="reference"/>
    </relheader>
    <relrow>
      <relcell>
        <topicref href="batsonar.dita"/>
      </relcell>
      <relcell>
        <topicref href="batcaring.dita"/>
        <topicref href="batfeeding.dita"/>
      </relcell>
      <relcell>
        <topicref href="batguano.dita"/>
        <topicref href="bathistory.dita"/>
      </relcell>
    </relrow>
  </reltable>
</map>

A DITA-aware tool may represent the <reltable> element graphically:

type="concept" | type="task" | type="reference"
batsonar.dita | batcaring.dita batfeeding.dita | batguano.dita bathistory.dita

On output, links should be added to topics that are in the same row, but not in the same cell. This allows simple maintenance of parallel relationships: for example, in this case, batcaring.dita and batfeeding.dita are two tasks that require the same supporting information (concept and reference topics) but might otherwise be unrelated. When topics in the same cell are in fact related, the cell's collection-type attribute can be set to family. If some cells or columns are intended solely as supporting information and should not link back to topics in other cells, you can set the linking attribute on the cell or relcolspec to targetonly.

In this example, the related links would be as follows:
batsonar.dita
batcaring.dita, batfeeding.dita, batguano.dita, bathistory.dita
batcaring.dita
batsonar.dita, batguano.dita, bathistory.dita
batfeeding.dita
batsonar.dita, batguano.dita, bathistory.dita
batguano.dita
batsonar.dita, batcaring.dita, batfeeding.dita
bathistory.dita
batsonar.dita, batcaring.dita, batfeeding.dita

Although such tables may initially take some time to learn and manipulate, they are inherently an efficient way to manage these links. In particular, they increase the prospect for reuse among topics, because those topics do not contain context-specific links. A relationship table also makes it easy to see and manage patterns; for example, the fact that batfeeding.dita and batcaring.dita have the same relationships to supporting information is clear from the table, but would require some comparison and counting to determine from the list summary just before this paragraph.

Attributes

Name | Description | Data Type | Default Value | Required?
title | An identifying title for this element. | CDATA | #IMPLIED | No
topicref-atts-no-toc attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A related set of attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.5 navref
Next topic: 3.1.2.1.7 relrow


relrow

3.1.2.1.7 relrow

The <relrow> element defines a row in the relationship table (<reltable>). It creates a relationship between the cells in the row, which is expressed in output as links between the topics or resources referenced in those cells.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | (relcell) (any number)

Contained by

Doctype | Content model
map (base), map (technical content), bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | reltable

Inheritance

- map/relrow

Example

See reltable.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.6 reltable
Next topic: 3.1.2.1.8 relcell


relcell

3.1.2.1.8 relcell

The <relcell> element defines a cell in the relationship table (<reltable>). The <topicref> elements that it contains are related to the <topicref> elements in other cells of the same row. By default, topics or resources that are referenced in the same cell are not related to each other, unless you change the collection-type attribute of the <relcell> to indicate that they are related.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or data or data-about) (any number)
map (technical content) | (topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) or data or data-about) (any number)
classifyMap | (topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or data or data-about) (any number)
subjectScheme | (topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or data or data-about) (any number)
learningBookmap, learningMap | (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup or data or data-about) (any number)

Contained by

Doctype | Content model
map (base), map (technical content), bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | relrow

Inheritance

- map/relcell

Example

See reltable.

Attributes

Name | Description | Data Type | Default Value | Required?
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.7 relrow
Next topic: 3.1.2.1.9 relheader


relheader

3.1.2.1.9 relheader

The <relheader> element is a row in a relationship table that contains column definitions (<relcolspec> elements). Each table can have only one set of column definitions.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | (relcolspec) (one or more)

Contained by

Doctype | Content model
map (base), map (technical content), bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | reltable

Inheritance

- map/relheader

Example

See reltable.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.8 relcell
Next topic: 3.1.2.1.10 relcolspec


relcolspec

3.1.2.1.10 relcolspec

The <relcolspec> element is used to define a column in a relationship table. The <relcolspec> element may be used to set default values for the <topicref> elements in the column.

You can use the <relcolspec> element to set default values for the attributes of the topics that are referenced in the column. For example, when you set the type attribute to "concept," all <topicref> elements in the column that do not have a type attribute specified are treated as concepts. When values are specified for attributes of <relcell> or <relrow> elements, those values are inherited before those defined for <relcolspec> elements. Values specified for attributes of <relcolspec> elements are inherited before those defined for the <reltable> element.

Beginning with DITA 1.2, you also can add <topicref> elements to the <relcolspec> element; this defines a relationship between the topics that are referenced in the <recolspec> element and the topics that are referenced in the column of the relationship table. Note that this does not define a relationship between two cells in the same column; the only new relationship is between <topicref> targets in a <relcell> and <topicref> targets in that column's <relcolspec>.

Also beginning with DITA 1.2, if you add a <title> element to the <relcolspec> element, the content of the <title> element is used as the label for the related links that are defined and generated by the column. If the <title> element is not present, the labels for the related links are generated in the following ways:
  • If the <relcolspec> element contains a <topicref> element that points to a non-DITA source, the value of the topicref's navtitle element or attribute is used for the label.
  • If the <relcolspec> element contains a <topicref> element that points to a DITA source and the locktitle attribute is set to "yes," the value of the topicref's navtitle element or attribute is used for the label.
  • If the <relcolspec> element contains a <topicref> element that points to a DITA source and the locktitle attribute is missing or set to "no," the label is derived from the <navtitle> or <title> element specified within the topic.
  • If no title is specified and no topicref is present in the <relcolspec>, a rendering tool may choose to generate a title for the links generated from that column.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (title) (optional) then (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (title) (optional) then (topicmeta) (optional) then (topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (title) (optional) then (topicmeta) (optional) then (topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (title) (optional) then (topicmeta) (optional) then (topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (title) (optional) then (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | relheader

Inheritance

- map/relcolspec

Example

In this example, a relationship table is defined with three columns; one for "concept", one for "task", and one for "reference". Three cells are defined within one row. The first cell contains one concept topic: puffins.dita. The second cell contains two task topics: puffinFeeding.dita and puffinCleaning.dita. The third cell contains a reference topic: puffinHistory.dita. Setting the type on each column allows (but does not require) processors to validate that the topics in each column are of the expected type.

<map>
 <reltable>
  <relheader>
   <relcolspec type="concept"/>
   <relcolspec type="task"/>
   <relcolspec type="reference"/>
  </relheader>
  <relrow>
   <relcell><topicref href="puffins.dita"/></relcell>
   <relcell>
     <topicref href="puffinFeeding.dita"/>
     <topicref href="puffinCleaning.dita"/>
   </relcell>
   <relcell>
     <topicref href="puffinHistory.dita"/>
   </relcell>
  </relrow>
 </reltable>
</map>

Example with column titles

Consider the following relationship table:

<reltable>
  <relheader>
    <relcolspec type="task">
      <topicref navtitle="Troubleshooting" href="tbs.dita" locktitle="yes"/>
    </relcolspec>
    <relcolspec type="reference">
      <topicref navtitle="Messages" href="msg.dita" locktitle="yes"/>
    </relcolspec>
  </relheader>
  <relrow>
    <relcell>
      <topicref navtitle="Debugging login errors" href="debug_login.dita"/>
    </relcell>
    <relcell>
      <topicref navtitle="Login not found" href="login_error_1.dita"/>
    </relcell>
  </relrow>
  <relrow>
    <relcell>
      <topicref navtitle="Checking access controls" href="checking_access.dita"/>
    </relcell>
    <relcell>
      <topicref navtitle="Login not allowed" href="login_error_2.dita"/>
    </relcell>
  </relrow>
</reltable>
In addition to the relationships defined by the rows in the relationship table, the following relationships are now defined by the columns in the relationship table:
  • tbs.dita <–> debug_login.dita
  • tbs.dita <–> checking_access.dita
  • msg.dita <–> login_error_1.dita
  • msg.dita <–> login_error_2.dita

Ignoring the headers for a moment, the <reltable> here would ordinarily define a two-way relationship between debug_login.dita and login_error1.dita. This will typically be expressed as a link from each to the other. An application may, but need not, render the link with a language-appropriate heading such as "Related reference", indicating that the target of the link is a reference topic.

The headers change this by specifying a new title. In the second column, the topicref specifies a title of "Messages", which should now be used together with the link to anything in that column. So, a generated link from debug_login.dita to login_error1.dita should be rendered together with the title of "Messages". How this is rendered together with the link is up to the application.

Attributes

Name | Description | Data Type | Default Value | Required?
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.1 Basic map elements
Previous topic: 3.1.2.1.9 relheader
Next topic: 3.1.2.2 Map group elements


Map group elements

3.1.2.2 Map group elements

The map group domain elements define, group, or reference content. Many of the map group elements are convenience elements, which means that they simply make it easier for an author to make use of existing functions.

For example, the <topichead> element allows a map to specify a heading without allowing a reference to a topic. While a <topicref> element may accomplish the same thing by creating a title and leaving off the href attribute, the <topichead> element simply makes the intent clearer and prevents the accidental inclusion of an href attribute.

  • 3.1.2.2.1 anchorref
    The <anchorref> element is used to reference an <anchor> element in a map. The contents of an <anchorref> element are rendered both in the original authored location and at the location of the referenced <anchor> element. The referenced <anchor> element may be defined in the current map or another map. When possible, this integration is done when displaying the map with <anchor> to an end user.
  • 3.1.2.2.2 keydef
    The <keydef> element is a convenience element that is used to define keys without any of the other effects that occur when using a <topicref> element: no content is included in output, no title is included in the table of contents, and no linking or other relationships are defined. The <keydef> element is not the only way to define keys; its purpose is to simplify the process by defaulting several attributes to achieve the described behaviors.
  • 3.1.2.2.3 mapref
    The <mapref> element is a convenience element that is equivalent to a <topicref> element with the format attribute set to "ditamap". The hierarchy of the referenced map is merged into the container map at the position of the reference, and the relationship tables of the child map are added to the parent map.
  • 3.1.2.2.4 topicgroup
    The <topicgroup> element groups <topicref> elements for common treatment without affecting the structural hierarchy of the map, as opposed to nesting <topicref> elements, which does imply a structural hierarchy. The <topicgroup> element can provide linking relationships and shared, inherited attributes to the set of elements that it contains without affecting the resulting table of contents or navigation.
  • 3.1.2.2.5 topichead
    The <topichead> element provides a title-only entry in a navigation map, which should appear as a heading when the map is rendered as a table of contents. In print contexts it should also appear as a heading in the rendered content.
  • 3.1.2.2.6 topicset
    The <topicset> element defines a complete unit of content that can be reused in other DITA maps or other <topicset> elements. The <topicset> element can be especially useful for task composition in which larger tasks are composed of smaller tasks. The id attribute on a <topicset> is required, which ensures that the complete unit is available for reuse in other contexts.
  • 3.1.2.2.7 topicsetref
    The <topicsetref> element references a <topicset> element. The referenced <topicset> element can be defined in the current map or in another map.
Parent topic: 3.1.2 Map elements
Previous topic: 3.1.2.1.10 relcolspec
Next topic: 3.1.2.2.1 anchorref


anchorref

3.1.2.2.1 anchorref

The <anchorref> element is used to reference an <anchor> element in a map. The contents of an <anchorref> element are rendered both in the original authored location and at the location of the referenced <anchor> element. The referenced <anchor> element may be defined in the current map or another map. When possible, this integration is done when displaying the map with <anchor> to an end user.

This function of the <anchorref> element is similar to that provided by the anchorref attribute of the <map> element. However, instead of attaching an entire map to an anchor point, this element allows the author to attach only the contents of a single map branch. This enables architects to reuse a branch of content without reusing the entire map.

If the rendering platform does not support runtime integration of navigation based on the anchor point, a build system should treat the <anchorref> element similar to a "conref push" instruction by pushing the content to the spot that contains the anchor. Note that many <anchorref> elements may push content to the same point; the order in which items are pushed is left undefined, although the order within a single <anchorref> is preserved.

Metadata cascading must take place in the original authored context, because the branch of content defined with the <anchorref> remains independent from the referenced map. The <anchorref> content does not take on the cascading metadata at the <anchor> location. For example, if the map containing the <anchorref> element sets a local copyright, that copyright cascades to the <anchorref> element and its children; it is retained after the content is rendered at the target <anchor> element.

By default, the content of the <anchorref> element is rendered at both the anchor target and the original location. To prevent the content from being rendered at the location of the <anchorref> element, set toc="no" on the <anchorref> element, and then set toc="yes" on each of its children so that they will not inherit the toc="no" setting.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (topicmeta) (optional) then (data or data-about or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (topicmeta) (optional) then (data or data-about or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (topicmeta) (optional) then (data or data-about or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (topicmeta) (optional) then (data or data-about or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (topicmeta) (optional) then (data or data-about or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
bookmap, learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell
subjectScheme | map, topicref, relcolspec, relcell, subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

+ map/topicref mapgroup-d/anchorref

Example

Figure 1. Initial map contents
<topicref href="carPrep.dita">
    <topicref href="beforePrep.dita"/>
    <anchor id="prepDetail"/>
    <topicref href="afterPrep.dita"/>
</topicref>
...
<topicref href="astroTasks.dita">
    <topicref href="astroOverview.dita"/>
    <anchorref href="#prepDetail">
        <topicref href="astroChecklist.dita"/>
        <topicref href="otherPreparation.dita"/>
    </anchorref>
    <topicref href="astroConclusion.dita"/>
</topicref>
Figure 2. Effective result of evaluating the <anchorref> element
<topicref href="carPrep.dita">
    <topicref href="beforePrep.dita"/>
    <anchor id="prepDetail"/>
    <topicref href="astroChecklist.dita"/>
    <topicref href="otherPreparation.dita"/>
    <topicref href="afterPrep.dita"/>
</topicref>
...
<topicref href="astroTasks.dita">
    <topicref href="astroOverview.dita"/>
    <topicref href="astroChecklist.dita"/>
    <topicref href="otherPreparation.dita"/>
    <topicref href="astroConclusion.dita"/>
</topicref>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to an <anchor> element in this or another DITA map. When rendered, the contents of the <anchorref> element will be copied to the location of the anchor. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified.

Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy.

CDATA #IMPLIED No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
type | Describes the target of a reference. For the anchorref element, this value defaults to "anchor", because the element is expected to point to an anchor element in this or another map. | CDATA | anchor | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. For the anchorref element, this value defaults to "ditamap", because the element references a point in a map. | CDATA | ditamap | No
linking Defines some specific linking characteristics of a topic's current location in the map. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (TOC). If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
print Specifies whether the topic should be included in a print-specific rendition, such as PDF. The processing default is "yes". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
Include the topic in the print-oriented file.
no
Do not include the topic in a print-oriented file.
printonly
Only include the topic when rendering the DITA content in a print-oriented context; the topic should not be included in other contexts, such as when rendering as HTML.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | printonly | -dita-use-​conref-​target) #IMPLIED No
search Describes whether the target is available for searching. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
no
-dita-use-​conref-​target
(yes | no | -dita-use-​conref-​target) #IMPLIED No
chunk When a set of topics is transformed using a map, the chunk attribute allows multi-topic documents to be broken into smaller files and multiple individual topics to be combined into larger combined documents.

For a detailed description of the chunk attribute and its usage, see Chunking in the DITA Architectural Specification.

CDATA #IMPLIED No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.2.2 Map group elements
Previous topic: 3.1.2.2 Map group elements
Next topic: 3.1.2.2.2 keydef


keydef

3.1.2.2.2 keydef

The <keydef> element is a convenience element that is used to define keys without any of the other effects that occur when using a <topicref> element: no content is included in output, no title is included in the table of contents, and no linking or other relationships are defined. The <keydef> element is not the only way to define keys; its purpose is to simplify the process by defaulting several attributes to achieve the described behaviors.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
bookmap, learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell
subjectScheme | map, topicref, relcolspec, relcell, subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

+ map/topicref mapgropup-d/keydef

Example

The following example defines keys that can be used to refer to the indicated topics. These keys may be used from any topic in this map, or in any context where this map is imported. Note that the processing-role attribute defaults to "resource-only", which ensures that specified topics will not be rendered in a print document or in a navigation TOC based on this definition in the map. In addition, it means that links will not be generated to or from the <keydef> elements.

<map>
  <title>Defining bird keys</title>
  <keydef keys="darwinfinch galapagosfinch"  href="galapagosfinch.dita"/>
  <keydef keys="goldfinch"  href="about-goldfinches.dita"/>
  <keydef keys="puffin"     href="about-puffins.dita"/>
  <keydef keys="loon diver" href="common-loon.dita"/>
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified.

Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy.

CDATA #IMPLIED No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
processing-role Describes the processing role of the referenced topic. The default for this attribute on <keydef> is "resource-only". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) resource-only No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
linking Defines some specific linking characteristics of a topic's current location in the map. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (TOC). If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
print Specifies whether the topic should be included in a print-specific rendition, such as PDF. The processing default is "yes". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
Include the topic in the print-oriented file.
no
Do not include the topic in a print-oriented file.
printonly
Only include the topic when rendering the DITA content in a print-oriented context; the topic should not be included in other contexts, such as when rendering as HTML.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | printonly | -dita-use-​conref-​target) #IMPLIED No
search Describes whether the target is available for searching. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
no
-dita-use-​conref-​target
(yes | no | -dita-use-​conref-​target) #IMPLIED No
chunk When a set of topics is transformed using a map, the chunk attribute allows multi-topic documents to be broken into smaller files and multiple individual topics to be combined into larger combined documents.

For a detailed description of the chunk attribute and its usage, see Chunking in the DITA Architectural Specification.

CDATA #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.2.2 Map group elements
Previous topic: 3.1.2.2.1 anchorref
Next topic: 3.1.2.2.3 mapref


mapref

3.1.2.2.3 mapref

The <mapref> element is a convenience element that is equivalent to a <topicref> element with the format attribute set to "ditamap". The hierarchy of the referenced map is merged into the container map at the position of the reference, and the relationship tables of the child map are added to the parent map.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | ( (topicmeta) (optional) then (data or data-about) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
bookmap, learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell
subjectScheme | map, topicref, relcolspec, relcell, subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

+ map/topicref mapgroup-d/mapref

Example

Figure 1. Sample document "lib.ditamap" that is reusable in other locations
<map id="lib">
  <topicref href="netlib.dita"/>
  <topicref href="dblib.dita"/>
  <!-- ... -->
</map>
Figure 2. Map that reuses lib.ditamap
<map id="standardlib">
  <topichead navtitle="Developing with standard libraries">
    <mapref href="lib.ditamap"/>
  </topichead>
  <!-- ... -->
</map>
Figure 3. Rendered result
<map id="standardlib">
  <topichead navtitle="Developing with standard libraries">
    <topicref href="netlib.dita"/>
    <topicref href="dblib.dita"/>
    <!-- ... -->
  </topichead>
  <!-- ... -->
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. For elements like this one that are designed to reference another map, the value defaults to "ditamap". See The format attribute for details on other supported values. | CDATA | ditamap | No
topicref-atts-without-format attribute group (collection-type, processing-role, type, scope, locktitle, linking, toc, print, search, chunk) | A related set of attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.2 Map group elements
Previous topic: 3.1.2.2.2 keydef
Next topic: 3.1.2.2.4 topicgroup


topicgroup

3.1.2.2.4 topicgroup

The <topicgroup> element groups <topicref> elements for common treatment without affecting the structural hierarchy of the map, as opposed to nesting <topicref> elements, which does imply a structural hierarchy. The <topicgroup> element can provide linking relationships and shared, inherited attributes to the set of elements that it contains without affecting the resulting table of contents or navigation.

Beginning with DITA 1.2, you are able to specify a <navtitle> element within the <topicmeta> element inside of a <topicgroup>. The <topicgroup> element is meant as a non-titled grouping element, so adding a <navtitle> element to the <topicgroup> element has no defined purpose, and processors must ignore the title. Processors may (but need not) issue a message when ignoring the title.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
bookmap, learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell
subjectScheme | map, topicref, relcolspec, relcell, subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

+ map/topicref mapgroup-d/topicgroup

Example

Each <topicref> element in the following example inherits the audience and linking attributes. In this way the common attributes are set for the entire group of <topicref> elements without affecting the navigation hierarchy.

<topicgroup audience="novice" linking="none">
  <topicref href="this.dita"/>
  <topicref href="that.dita"/>
  <topicref href="theother.dita"/>
</topicgroup>

Attributes

Name | Description | Data Type | Default Value | Required?
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.2 Map group elements
Previous topic: 3.1.2.2.3 mapref
Next topic: 3.1.2.2.5 topichead


topichead

3.1.2.2.5 topichead

The <topichead> element provides a title-only entry in a navigation map, which should appear as a heading when the map is rendered as a table of contents. In print contexts it should also appear as a heading in the rendered content.

Beginning with DITA 1.2, the navtitle can be specified by using a <navtitle> element within the <topicmeta> element, so the <topichead> element no longer requires the navtitle attribute. In order to ensure backward compatibility with earlier versions of DITA, the new <navtitle> element is not required. However, a <topichead> element must contain either a navtitle attribute or a <topicmeta> element that contains a <navtitle> element. DITA processors should generate a warning if a navigation title is not specified.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
bookmap, learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell
subjectScheme | map, topicref, relcolspec, relcell, subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

+ map/topicref mapgroup-d/topichead

Example

Note that in the following example, the first <topichead> element uses a <navtitle> element to provide the title, while the second <topichead> element uses a navtitle attribute. This is only to illustrate that both uses are valid; in general, the element is preferred over the attribute.

<map>
  <topichead>
    <topicmeta><navtitle>Computers</navtitle></topicmeta>
    <topicref href="eniac.dita"/>
    <topicref href="system360.dita"/>
    <topicref href="pdp8.dita"/>
  </topichead>
  <topichead navtitle="Books">
    <topicref href="hardback.dita"/>
    <topicref href="paperback.dita"/>
  </topichead>
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.2.2 Map group elements
Previous topic: 3.1.2.2.4 topicgroup
Next topic: 3.1.2.2.6 topicset


topicset

3.1.2.2.6 topicset

The <topicset> element defines a complete unit of content that can be reused in other DITA maps or other <topicset> elements. The <topicset> element can be especially useful for task composition in which larger tasks are composed of smaller tasks. The id attribute on a <topicset> is required, which ensures that the complete unit is available for reuse in other contexts.

A <topicset> is similar to a source file that contains nested topics, in that the combination of topics constitutes a complete self-contained unit. That unit of content can stand independently of the containing, prior, and following content within the original map context.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (topicmeta) (optional) then (anchor or data or data-about or navref or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
bookmap, learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell
subjectScheme | map, topicref, relcolspec, relcell, subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

+ map/topicref mapgroup-d/topicset

Example

This topic set represents a set of overview information about SQL. The information is reusable as a unit.

<topicset id="sqlbasics" href="sqlOverview.dita">
  <topicref href="sqlSelection.dita"/>
  <topicref href="sqlJoin.dita"/>
  <topicref href="sqlFilter.dita"/>
  ...
</topicset>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
id | This ID is the target for references by to the current set of information. The ID is required in order to ensure that a topicset is defined as a reusable unit of information. See ID attribute in the Architectural Specification for more details. | ID | #REQUIRED | Yes
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified.

Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy.

CDATA #IMPLIED No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
linking Defines some specific linking characteristics of a topic's current location in the map. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (TOC). If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
print Specifies whether the topic should be included in a print-specific rendition, such as PDF. The processing default is "yes". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
Include the topic in the print-oriented file.
no
Do not include the topic in a print-oriented file.
printonly
Only include the topic when rendering the DITA content in a print-oriented context; the topic should not be included in other contexts, such as when rendering as HTML.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | printonly | -dita-use-​conref-​target) #IMPLIED No
search Describes whether the target is available for searching. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
no
-dita-use-​conref-​target
(yes | no | -dita-use-​conref-​target) #IMPLIED No
chunk A topicset defines a group of information that will generally be used as a single navigable unit. The chunk attribute defaults to to-navigation to indicate that this is a distinct unit of information.

For a detailed description of the chunk attribute and its usage see the section on Chunking in the DITA Architectural Specification.

CDATA to-navigation No
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute.
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group.
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.2.2 Map group elements
Previous topic: 3.1.2.2.5 topichead
Next topic: 3.1.2.2.7 topicsetref


topicsetref

3.1.2.2.7 topicsetref

The <topicsetref> element references a <topicset> element. The referenced <topicset> element can be defined in the current map or in another map.

When possible, applications should treat the referenced <topicset> as an independent unit that always retains its identity. For example, an application that renders DITA for a dynamic navigation platform may generate a reusable navigation structure for each <topicset>, and each <topicsetref> is retained as a reference to that structure. This differs slightly from the processing of the conref attribute, which results in a literal copy of the referenced content.

For situations that do not support reusing a topic set as an independent unit, such as a rendered PDF, applications may resolve the <topicsetref> element in a manner similar to other <topicref> elements that have the format attribute set to "ditamap". This may result in a new instance of the <topicset> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (base), bookmap | ( (topicmeta) (optional) then (data or data-about or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
map (technical content) | ( (topicmeta) (optional) then (data or data-about or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) or (glossref) ) (any number) )
classifyMap | ( (topicmeta) (optional) then (data or data-about or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
subjectScheme | ( (topicmeta) (optional) then (data or data-about or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap, learningMap | ( (topicmeta) (optional) then (data or data-about or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
map (base), map (technical content), learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
bookmap, learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell
subjectScheme | map, topicref, relcolspec, relcell, subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

+ map/topicref mapgroup-d/topicsetref

Example

Figure 1. Reusable chunk of information in a ditamap

The following <topicset> groups several topics that together make up an overview of SQL.

<topicset id="sqlbasics" href="sqlOverview.dita">
  <topicref href="sqlSelection.dita"/>
  <topicref href="sqlJoin.dita"/>
  <topicref href="sqlFilter.dita"/>
  <!-- ... -->
</topicset>
Figure 2. <topicsetref> element that reuses the chunk from within the same map

In this case, another map includes the entire set of SQL Basics together with content related to programming with JDBC.

<topichead navtitle="Mastering JDBC">
  <topicsetref href="#sqlbasics"/>
  <topicref href="jdbcPrepare.dita"/>
  <!-- ... -->
</topichead>
Figure 3. Result of the reuse

A reader of the JDBC information will see the content integrated as a single unit.

<topichead navtitle="Mastering JDBC">
  <topicset id="sqlbasics" href="sqlOverview.dita">
    <topicref href="sqlSelection.dita"/>
    <topicref href="sqlJoin.dita"/>
    <topicref href="sqlFilter.dita"/>
    <!-- ... -->
  </topicset>
  <topicref href="jdbcPrepare.dita"/>
  <!-- ... -->
</topichead>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the topicset represented by the <topicsetref>. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified.

Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy.

CDATA #IMPLIED No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
type | Describes the target of a reference. For the topicsetref element, this value defaults to "topicset". See The type attribute for detailed information on other supported values and processing implications. | CDATA | topicset | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. For the topicsetref element, this value defaults to "ditamap", because the element typically references a branch of a map. See The format attribute for details on other supported values. | CDATA | ditamap | No
linking Defines some specific linking characteristics of a topic's current location in the map. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (TOC). If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
print Specifies whether the topic should be included in a print-specific rendition, such as PDF. The processing default is "yes". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
Include the topic in the print-oriented file.
no
Do not include the topic in a print-oriented file.
printonly
Only include the topic when rendering the DITA content in a print-oriented context; the topic should not be included in other contexts, such as when rendering as HTML.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | printonly | -dita-use-​conref-​target) #IMPLIED No
search Describes whether the target is available for searching. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
no
-dita-use-​conref-​target
(yes | no | -dita-use-​conref-​target) #IMPLIED No
chunk When a set of topics is transformed using a map, the chunk attribute allows multi-topic documents to be broken into smaller files and multiple individual topics to be combined into larger combined documents.

For a detailed description of the chunk attribute and its usage, see Chunking in the DITA Architectural Specification.

CDATA #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.2.2 Map group elements
Previous topic: 3.1.2.2.6 topicset
Next topic: 3.1.3 Metadata elements


Metadata elements

3.1.3 Metadata elements

Metadata elements include information that is located within the <topicmeta> element (in maps) or <prolog> element (in topics), as well as indexing elements that can be placed in additional locations within topic content.

  • 3.1.3.1 Prolog (metadata) elements
    The prolog elements represent the metadata associated with a document. Most of the metadata in a topic prolog can also be authored in a DITA map, in the map's <topicmeta> element.
  • 3.1.3.2 Indexing group elements
    The indexing domain provides several new elements for use with indexing. The new elements allow authors to define "See" and "See also" references, and to override the default sort order for a term.
  • 3.1.3.3 Delayed conref resolution elements
    The delayed conref resolution domain provides several elements for use when using DITA in situations that enable delayed or run time resolution of conref. The elements allow users to resolve some conref values statically, while delaying others for later resolution.
Parent topic: 3.1 Base elements
Previous topic: 3.1.2.2.7 topicsetref
Next topic: 3.1.3.1 Prolog (metadata) elements


Prolog (metadata) elements

3.1.3.1 Prolog (metadata) elements

The prolog elements represent the metadata associated with a document. Most of the metadata in a topic prolog can also be authored in a DITA map, in the map's <topicmeta> element.

The primary types of information that you can store in the prolog include:

  • author
  • copyright information
  • critical tracking dates
  • permissions for use/management of the content
  • key words and index terms related to the topic
  • extensive metadata about the content of the document
  • a resourceid that allows a topic to be associated with external resources such as linking to programming components as contextual help
  • 3.1.3.1.1 prolog
    The <prolog> element contains information about the topic as an whole (for example, author information or subject category) that is either entered by the author or maintained by a software application. Much of the metadata inside the <prolog> will not be displayed with the topic when the topic is rendered, but may be used by processes that generate search indexes or customize navigation.
  • 3.1.3.1.2 audience
    The <audience> metadata element indicates, through the value of its type attribute, the intended audience for a topic.
  • 3.1.3.1.3 author
    The <author> metadata element contains the name of the topic's author.
  • 3.1.3.1.4 brand
    The <brand> element indicates the manufacturer or brand associated with the product described by the parent <prodinfo> element.
  • 3.1.3.1.5 category
    The <category> element represents any category by which a topic might be classified for retrieval or navigation. For example, the categories could be used to group topics in a generated navigation bar. Topics can belong to multiple categories.
  • 3.1.3.1.6 component
    The <component> element describes the component of the product that this topic is concerned with. For example, a product might be made up of many components, each of which is installable separately. Components might also be shared by several products so that the same component is available for installation with many products. An implementation may (but need not) use this identification to check cross-component dependencies when some components are installed, but not others. An implementation may also (but need not) use the identification to make sure that topics are hidden, removed, or flagged in some way when the component they describe isn't installed.
  • 3.1.3.1.7 copyright
    The <copyright> element specifies legal ownership of the content.
  • 3.1.3.1.8 copyrholder
    The copyright holder (<copyrholder>) element names the entity that holds legal rights to the material contained in the topic.
  • 3.1.3.1.9 copyryear
    The <copyryear> element contains the copyright year as specified by the year attribute.
  • 3.1.3.1.10 created
    The <created> element specifies the document creation date using the date attribute.
  • 3.1.3.1.11 critdates
    The <critdates> element contains the critical dates in a document life cycle, such as the creation date and multiple revision dates.
  • 3.1.3.1.12 featnum
    The <featnum> element contains the feature number of a product in the metadata.
  • 3.1.3.1.13 keywords
    The <keywords> element contains a list of terms from a controlled or uncontrolled subject vocabulary that applies to the topic or map. The keywords may be used by a search engine. The keywords are marked up using the <indexterm> and/or <keyword> elements.
  • 3.1.3.1.14 metadata
    The <metadata> section of the prolog contains information about a topic such as audience and product information. Metadata can be used by computational processes to select particular topics or to prepare search indexes or to customize navigation. Elements inside of <metadata> provide information about the content and subject of a topic; prolog elements outside of <metadata> provide lifecycle information for the content unit (such as the author or copyright), which are unrelated to the subject.
  • 3.1.3.1.15 othermeta
    The <othermeta> element can be used to identify properties not otherwise included in <metadata> and to assign name/content values to those properties. The name attribute identifies the property and the content attribute specifies the property's value. All <othermeta> elements are considered part of the topic's metadata and should be reflected in the output as appropriate for the output medium.
  • 3.1.3.1.16 permissions
    The <permissions> prolog element specifies the level of entitlement needed to access the content.
  • 3.1.3.1.17 platform
    The <platform> metadata element contains a description of the operating system and/or hardware related to the product being described by the <prodinfo> element. The platform element may be used to provide a more detailed definition of values used throughout the map or topic on the platform attribute.
  • 3.1.3.1.18 prodinfo
    The <prodinfo> metadata element contains information about the product or products that are the subject matter of the current topic. The prodinfo element may be used to provide a more detailed definition of values used throughout the map or topic on the product attribute.
  • 3.1.3.1.19 prodname
    The <prodname> metadata element contains the name of the product that is supported by the information in this topic.
  • 3.1.3.1.20 prognum
    The <prognum> metadata element identifies the program number of the associated product. This is typically an order number or a product tracking code that could be replaced by an order number when a product completes development.
  • 3.1.3.1.21 publisher
    The <publisher> metadata element contains the name of the person, company, or organization responsible for making the content or subject of the topic available.
  • 3.1.3.1.22 resourceid
    The <resourceid> element provides an identifier for applications that require them in a particular format, when the normal id attribute of the topic cannot be used.
  • 3.1.3.1.23 revised
    The <revised> element in the prolog is used to maintain tracking dates that are important in a topic development cycle, such as the last modification date, the original availability date, and the expiration date.
  • 3.1.3.1.24 series
    The <series> metadata element contains information about the product series that the topic supports.
  • 3.1.3.1.25 source
    The <source> element identifies a resource from which the present topic is derived, either completely or in part.
  • 3.1.3.1.26 vrmlist
    The <vrmlist> element contains a set of <vrm> elements for logging the version, release, and modification information for multiple products or versions of products to which the topic applies.
  • 3.1.3.1.27 vrm
    The vrm element contains information about a single product's version, modification, and release, to which the current topic applies.
Parent topic: 3.1.3 Metadata elements
Previous topic: 3.1.3 Metadata elements
Next topic: 3.1.3.1.1 prolog


prolog

3.1.3.1.1 prolog

The <prolog> element contains information about the topic as an whole (for example, author information or subject category) that is either entered by the author or maintained by a software application. Much of the metadata inside the <prolog> will not be displayed with the topic when the topic is rendered, but may be used by processes that generate search indexes or customize navigation.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, ditabase, glossary, glossentry, glossgroup, reference, task, machineryTask | ( (author) (any number) then (source) (optional) then (publisher) (optional) then (copyright) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata) (any number) then (resourceid) (any number) then (data or data-about or foreign or unknown) (any number) )
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (author) (any number) then (source) (optional) then (publisher) (optional) then (copyright) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata or lcLom) (any number) then (resourceid) (any number) then (data or data-about or foreign or unknown) (any number) )

Contained by

Doctype | Content model
topic (base), topic (technical content) | topic
concept | topic, concept
ditabase | topic, concept, task, reference, glossentry, glossgroup
glossary, glossentry | topic, concept, glossentry
glossgroup | topic, concept, glossentry, glossgroup
reference | topic, reference
task (strict), task (general), machineryTask | topic, task
learningAssessment | topic, learningBase, learningAssessment
learningContent | topic, learningBase, task, concept, reference, learningSummary, learningAssessment, learningContent
learningOverview | topic, learningBase, learningOverview
learningPlan | topic, learningBase, learningPlan
learningSummary | topic, learningBase, learningSummary

Inheritance

- topic/prolog

<prolog>
  <metadata>
    <audience type="user" job="using" experiencelevel="novice"/>
  </metadata>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1 Prolog (metadata) elements
Next topic: 3.1.3.1.2 audience


audience

3.1.3.1.2 audience

The <audience> metadata element indicates, through the value of its type attribute, the intended audience for a topic.

Since a topic can have multiple audiences, you can include multiple audience elements. For each audience you specify, you can identify the high-level task (job) they are trying to accomplish and the level of experience (experiencelevel) expected. The audience element may be used to provide a more detailed definition of values used throughout the map or topic on the audience attribute.

Many of the attributes on the <audience> element have enumerated values, which may be extended by using constaints or by using associated attributes. For instance, the @othertype attribute can be used to extend the audience type enumeration.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | metadata
map (base), map (technical content), classifyMap, subjectScheme, learningMap | metadata, topicmeta
bookmap, learningBookmap | metadata, topicmeta, bookmeta

Inheritance

- topic/audience

Example

For a command reference topic for experienced programmers, the following might be an appropriate indication of that audience:

<audience type="programmer" job="programming" experiencelevel="expert"/>

Attributes

Name | Description | Data Type | Default Value | Required?
type Indicates the kind of person for whom the content of the topic is intended. Note that this differs from the type attribute on many other DITA elements. Allowable values are:
user
A user of the product
purchaser
A product purchaser
administrator
A product administrator
programmer
A programmer
executive
An executive
services
Someone who provides services related to the product
other
Use the value specified by the othertype attribute
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(user | purchaser | administrator | programmer | executive | services | other | -dita-use-​conref-​target) #IMPLIED No
othertype | Indicates an alternate audience type, when the type is not available in the type attribute value list. This value is used as the user-provided audience when the type attribute value is set to "other." | CDATA | #IMPLIED | No
job | Indicates the high-level task the audience for the topic is trying to accomplish. Different audiences may read the same topic in terms of different high-level tasks; for example, an administrator may read the topic while administering, while a programmer may read the same topic while customizing. Beginning with DITA 1.2, values in this attribute are not limited to a small number of choices; the following values were used in DITA 1.0 and DITA 1.1, and are still provided as sample values: installing, customizing, administering, programming, using, maintaining, troubleshooting, evaluating, planning, migrating, other, -dita-use-​conref-​target. | NMTOKEN | #IMPLIED | No
otherjob | If the job attribute value is "other" the value of this attribute is used to identify a kind of job other than the default ones provided by the job attribute. | CDATA | #IMPLIED | No
experiencelevel Indicates the level of experience the audience is assumed to possess. Different audiences may have different experience levels with respect to the same topic; for example, a topic may require general knowledge from a programmer, but expert knowledge from a user. Beginning with DITA 1.2, values in this attribute are not limited to a small number of choices; the following values were used in DITA 1.0 and DITA 1.1, and are still provided as sample values:
novice
A first time user.
general
The most common user.
expert
An experienced user.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
NMTOKEN #IMPLIED No
name | Used to associate the audience element with values used in the audience attribute | CDATA | #REQUIRED | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class | A common attribute described in Other common DITA attributes
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.1 prolog
Next topic: 3.1.3.1.3 author


author

3.1.3.1.3 author

The <author> metadata element contains the name of the topic's author.

The author is usually the person, organization, or application that created the content. This element is equivalent to the Creator element in Dublin Core.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
map (base), map (technical content), classifyMap, subjectScheme, learningMap | topicmeta
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

- topic/author

Example

<prolog>
  <author type="creator">Jane</author>
  <author type="contributor">John</author>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. Note that this differs from the type attribute on many other DITA elements. Beginning with DITA 1.2, values in this attribute are not limited to a small number of choices; the following values were used in DITA 1.0 and DITA 1.1, and are also recognized for the author element (and its specializations):
creator
The primary or original author of the content.
contributor
An additional author who is not primary.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
NMTOKEN #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class | A common attribute described in Other common DITA attributes
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.2 audience
Next topic: 3.1.3.1.4 brand


brand

3.1.3.1.4 brand

The <brand> element indicates the manufacturer or brand associated with the product described by the parent <prodinfo> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | prodinfo

Inheritance

- topic/brand

Example

<prodinfo>
 <prodname>Some Product</prodname>
 <vrmlist><vrm version="1"/></vrmlist>
 <brand>eServer</brand>
 <series>iSeries</series>
</prodinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.3 author
Next topic: 3.1.3.1.5 category


category

3.1.3.1.5 category

The <category> element represents any category by which a topic might be classified for retrieval or navigation. For example, the categories could be used to group topics in a generated navigation bar. Topics can belong to multiple categories.

Such classifications are likely to come from an enumerated or hierarchical set.

This element is equivalent to both the Coverage element and the Subject element in Dublin Core.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | metadata
map (base), map (technical content), classifyMap, subjectScheme, learningMap | metadata, topicmeta
bookmap, learningBookmap | metadata, topicmeta, bookmeta

Inheritance

- topic/category

Example

 <prolog>
  <metadata>
   <category>Things that are blue</category>
  </metadata>
 </prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.4 brand
Next topic: 3.1.3.1.6 component


component

3.1.3.1.6 component

The <component> element describes the component of the product that this topic is concerned with. For example, a product might be made up of many components, each of which is installable separately. Components might also be shared by several products so that the same component is available for installation with many products. An implementation may (but need not) use this identification to check cross-component dependencies when some components are installed, but not others. An implementation may also (but need not) use the identification to make sure that topics are hidden, removed, or flagged in some way when the component they describe isn't installed.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | prodinfo

Inheritance

- topic/component

Example

<prodinfo>
 <prodname>BatCom</prodname>
 <vrmlist>
  <vrm version="v5r2"/>
 </vrmlist>
 <component>TCP/IP</component>
</prodinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.5 category
Next topic: 3.1.3.1.7 copyright


copyright

3.1.3.1.7 copyright

The <copyright> element specifies legal ownership of the content.

The <copyright> element is used for a single copyright entry. It includes the copyright years and the copyright holder. Multiple <copyright> statements are allowed.

This element is equivalent to the Rights element in Dublin Core.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (copyryear) (one or more) then (copyrholder) )

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
map (base), map (technical content), bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | topicmeta

Inheritance

- topic/copyright

Example

<prolog>
 <copyright>
  <copyryear year="2001-04-12"></copyryear>
  <copyrholder>IBM</copyrholder>
 </copyright>
 <copyright type=secondary>
  <copyryear year="2002-03-03></copyryear>
  <copyrholder>Schweetones Publishing, Inc.</copyrholder>
 </copyright>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
type Indicates the legal status of the copyright holder. Note that this differs from the type attribute on many other DITA elements. Beginning with DITA 1.2, values in this attribute are not limited to a small number of choices; the following values were used in DITA 1.0 and DITA 1.1, and are still provided as sample values:
primary
The copyright holder with first claim on the copyright
secondary
An additional copyright holder who is not primary
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
NMTOKEN #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class | A common attribute described in Other common DITA attributes
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.6 component
Next topic: 3.1.3.1.8 copyrholder


copyrholder

3.1.3.1.8 copyrholder

The copyright holder (<copyrholder>) element names the entity that holds legal rights to the material contained in the topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | copyright

Inheritance

- topic/copyrholder

Example

<copyright>
  <copyryear year="2001"></copyryear>
  <copyrholder>IBM</copyrholder>
</copyright>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.7 copyright
Next topic: 3.1.3.1.9 copyryear


copyryear

3.1.3.1.9 copyryear

The <copyryear> element contains the copyright year as specified by the year attribute.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | copyright

Inheritance

- topic/copyryear

Example

<copyright>
  <copyryear year="2001"></copyryear>
  <copyrholder>IBM</copyrholder>
</copyright>

Attributes

Name | Description | Data Type | Default Value | Required?
year | The year in YYYY format. | CDATA | #IMPLIED | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.8 copyrholder
Next topic: 3.1.3.1.10 created


created

3.1.3.1.10 created

The <created> element specifies the document creation date using the date attribute.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | critdates

Inheritance

- topic/created

Example

<prolog>
 <critdates>
  <created date="2001-06-12"></created>
  <revised golive="2001-08-20"></revised>
 </critdates>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
date | The document creation date. Enter the date as YYYY-MM-DD where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. See A Summary of the International Standard Date and Time Notation for background. | CDATA | #IMPLIED | Yes
golive | The publication or general availability (GA) date, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | No
expiry | The date when the information should be retired or refreshed, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.9 copyryear
Next topic: 3.1.3.1.11 critdates


critdates

3.1.3.1.11 critdates

The <critdates> element contains the critical dates in a document life cycle, such as the creation date and multiple revision dates.

This element is equivalent to the Date element in Dublin Core.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (created) (optional) then (revised) (any number) )

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
map (base), map (technical content), classifyMap, subjectScheme, learningMap | topicmeta
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

- topic/critdates

Example

<prolog>
  <critdates>
    <created date="2001-06-12"></created>
    <revised modified="2001-08-20"></revised>
  </critdates>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.10 created
Next topic: 3.1.3.1.12 featnum


featnum

3.1.3.1.12 featnum

The <featnum> element contains the feature number of a product in the metadata.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | prodinfo

Inheritance

- topic/featnum

Example

<prodinfo>
 <prodname>BatCom</prodname>
 <vrmlist>
  <vrm version="v5r2"/>
 </vrmlist>
 <featnum>135</featnum>
 <component>TCP/IP</component>
</prodinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.11 critdates
Next topic: 3.1.3.1.13 keywords


keywords

3.1.3.1.13 keywords

The <keywords> element contains a list of terms from a controlled or uncontrolled subject vocabulary that applies to the topic or map. The keywords may be used by a search engine. The keywords are marked up using the <indexterm> and/or <keyword> elements.

All <keyword> and/or <indexterm> elements in the <keywords> element are considered part of the topic's metadata and should be reflected in the output as appropriate for the output medium.
Note: While the <keyword> element may be used inline, the <keywords> element is not an inline element. The <keywords> element only appears in the <topicmeta> or <prolog>, and is used to specify keywords that apply to the topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | (indexterm or keyword) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | (indexterm or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
machineryTask | (indexterm or keyword or wintitle) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | metadata
map (base), map (technical content), classifyMap, subjectScheme, learningMap | metadata, topicmeta
bookmap, learningBookmap | metadata, topicmeta, bookmeta

Inheritance

- topic/keywords

Example

The following example is metadata from an installation task:

<prolog>
 <metadata>
  <keywords>
   <keyword>installing</keyword>
   <keyword>uninstalling</keyword>
   <keyword>prerequisites</keyword>
   <keyword>helps</keyword>
   <keyword>wizards</keyword>
  </keywords>
 </metadata>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.12 featnum
Next topic: 3.1.3.1.14 metadata


metadata

3.1.3.1.14 metadata

The <metadata> section of the prolog contains information about a topic such as audience and product information. Metadata can be used by computational processes to select particular topics or to prepare search indexes or to customize navigation. Elements inside of <metadata> provide information about the content and subject of a topic; prolog elements outside of <metadata> provide lifecycle information for the content unit (such as the author or copyright), which are unrelated to the subject.

Beginning with DITA 1.2, the metadata element is available inside topicmeta in maps, although the contents of metadata are still available directly inside topicmeta. As with the prolog, the metadata element within topicmeta allows you to group elements that describe the content or subject of the target. The primary purpose for enabling the metadata element within maps is to allow easier reuse between topics and maps.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, ditabase, glossary, glossentry, glossgroup, reference, task, subjectScheme, machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (audience) (any number) then (category) (any number) then (keywords) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (data or data-about or foreign or unknown) (any number) )
map, bookmap, classifyMap, learningBookmap, learningMap | ( (audience) (any number) then (category) (any number) then (keywords or exportanchors) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (data or data-about or foreign or unknown) (any number) )

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
map (base), map (technical content), classifyMap, subjectScheme, learningMap | topicmeta
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

- topic/metadata

Example

Metadata within a topic:

<prolog>
  <metadata>
    <audience type="user" job="using" experiencelevel="novice"/>
  </metadata>
</prolog>

Metadata within a map:

<topicref href="metadata.dita" navtitle="metadata element">
  <topicmeta>
    <metadata>
      <keywords>
        <indexterm>metadata element</indexterm>
      </keywords>
    </metadata>
  </topicmeta>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
mapkeyref | Identifies the map, if any, from which the contained links are derived. This value is automatically generated by the same process that creates the links from the map, as a way to identify which map the links came from. If the <linklist> or <linkpool> is manually created by the author, there is no need to use this attribute. Note that this attribute is not related to the keyref attribute, and is not used for key based processing. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.13 keywords
Next topic: 3.1.3.1.15 othermeta


othermeta

3.1.3.1.15 othermeta

The <othermeta> element can be used to identify properties not otherwise included in <metadata> and to assign name/content values to those properties. The name attribute identifies the property and the content attribute specifies the property's value. All <othermeta> elements are considered part of the topic's metadata and should be reflected in the output as appropriate for the output medium.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | metadata
map (base), map (technical content), classifyMap, subjectScheme, learningMap | metadata, topicmeta
bookmap, learningBookmap | metadata, topicmeta, bookmeta

Inheritance

- topic/othermeta

Example

<othermeta name="ThreadWidthSystem" content="metric"/>

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name of the metadata property. | CDATA | #REQUIRED | Yes
content | The value for the property named in the name attribute. | CDATA | #REQUIRED | Yes
translate-content | Indicates whether the content attribute of the defined metadata property should be translated or not. | yes | no | -dita-use-​conref-​target | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.14 metadata
Next topic: 3.1.3.1.16 permissions


permissions

3.1.3.1.16 permissions

The <permissions> prolog element specifies the level of entitlement needed to access the content.

The <permissions> element indicates any preferred controls for access to content. Topics can be filtered based on the permissions element. This capability depends on your output formatting process.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
map (base), map (technical content), classifyMap, subjectScheme, learningMap | topicmeta
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

- topic/permissions

Example

<prolog>
  <permissions view="entitled"/>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
view Defines the classifications of viewers allowed to view the document. Beginning with DITA 1.2, values in this attribute are not limited to a small number of choices; the following values were used in DITA 1.0 and DITA 1.1, and are still provided as sample values:
internal
For internal use only.
classified
For a certain group, only.
all
The world.
entitled
Special folks, only.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(internal | classified | all | entitled | -dita-use-​conref-​target) #IMPLIED Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class | A common attribute described in Other common DITA attributes
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.15 othermeta
Next topic: 3.1.3.1.17 platform


platform

3.1.3.1.17 platform

The <platform> metadata element contains a description of the operating system and/or hardware related to the product being described by the <prodinfo> element. The platform element may be used to provide a more detailed definition of values used throughout the map or topic on the platform attribute.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | prodinfo

Inheritance

- topic/platform

Example

See prodinfo.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.16 permissions
Next topic: 3.1.3.1.18 prodinfo


prodinfo

3.1.3.1.18 prodinfo

The <prodinfo> metadata element contains information about the product or products that are the subject matter of the current topic. The prodinfo element may be used to provide a more detailed definition of values used throughout the map or topic on the product attribute.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (prodname) then (vrmlist) then (brand or component or featnum or platform or prognum or series) (any number) )

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | metadata
map (base), map (technical content), classifyMap, subjectScheme, learningMap | metadata, topicmeta
bookmap, learningBookmap | metadata, topicmeta, bookmeta

Inheritance

- topic/prodinfo

Example

<prolog>
 <metadata>
  <prodinfo>
   <prodname>Transcription Assistant</prodname>
   <vrmlist><vrm version="1" release="3" modification="1"/></vrmlist>
   <platform>Linux</platform>
   <prognum>SN-12345T</prognum>
  </prodinfo>
 </metadata>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.17 platform
Next topic: 3.1.3.1.19 prodname


prodname

3.1.3.1.19 prodname

The <prodname> metadata element contains the name of the product that is supported by the information in this topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | prodinfo

Inheritance

- topic/prodname

Example

See prodinfo

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.18 prodinfo
Next topic: 3.1.3.1.20 prognum


prognum

3.1.3.1.20 prognum

The <prognum> metadata element identifies the program number of the associated product. This is typically an order number or a product tracking code that could be replaced by an order number when a product completes development.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | prodinfo

Inheritance

- topic/prognum

Example

See prodinfo.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.19 prodname
Next topic: 3.1.3.1.21 publisher


publisher

3.1.3.1.21 publisher

The <publisher> metadata element contains the name of the person, company, or organization responsible for making the content or subject of the topic available.

This element is equivalent to the Publisher element in Dublin Core.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
map (base), map (technical content), bookmap, classifyMap, subjectScheme, learningBookmap, learningMap | topicmeta

Inheritance

- topic/publisher

Example

<prolog>
  <author>Ivan</author>
  <publisher>AJ Printing Inc.</publisher>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.20 prognum
Next topic: 3.1.3.1.22 resourceid


resourceid

3.1.3.1.22 resourceid

The <resourceid> element provides an identifier for applications that require them in a particular format, when the normal id attribute of the topic cannot be used.

Each resourceid entry should be unique. While DITA only requires IDs to be unique within a single topic or map, applications using the resourceid will generally require IDs to be universally unique or unique within a given collection of topics.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
map (base), map (technical content), classifyMap, subjectScheme, learningMap | topicmeta
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

- topic/resourceid

Example

<prolog>
  <resourceid id="sqlid00375" appname="dbaccess"/>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
id | The value used by a specific application to identify the topic. | CDATA | #REQUIRED | Yes
conref | This attribute is used to reference an ID on content that can be reused. See The conref attribute for examples and details about the syntax. | CDATA | #IMPLIED | No
appname | Contains the name of the application that will use the resource id to identify the topic. | CDATA | #IMPLIED | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.21 publisher
Next topic: 3.1.3.1.23 revised


revised

3.1.3.1.23 revised

The <revised> element in the prolog is used to maintain tracking dates that are important in a topic development cycle, such as the last modification date, the original availability date, and the expiration date.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | critdates

Inheritance

- topic/revised

Example

<prolog>
  <critdates>
    <created date="1999-01-01" golive="1999-02-15" expiry="9999-09-09"/>
    <revised modified="2003-03-03" golive="2002-02-03" expiry="9999-09-09"/>
 </critdates>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
modified | The last modification date, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #REQUIRED | Yes
golive | The publication or general availability (GA) date, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | No
expiry | The date when the information should be retired or refreshed, entered as YYYY-MM-DD, where YYYY is the year, MM is the month from 01 to 12, and DD is the day from 01-31. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.22 resourceid
Next topic: 3.1.3.1.24 series


series

3.1.3.1.24 series

The <series> metadata element contains information about the product series that the topic supports.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | prodinfo

Inheritance

- topic/series

Example

<prodinfo>
 <prodname>BatCom</prodname>
 <vrmlist><vrm version="5"/></vrmlist>
 <series>tSeries</series>
 <prognum>5412-SS1</prognum>
 <featnum>135</featnum>
 <component>TCP/IP</component>
</prodinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.23 revised
Next topic: 3.1.3.1.25 source


source

3.1.3.1.25 source

The <source> element identifies a resource from which the present topic is derived, either completely or in part.

The <source> element contains a description of the resource. Alternatively, the href attribute is used to reference a description of the resource. It is implementation-dependent what it means when the element has both content and an href attribute value.

This element is equivalent to the Source element in Dublin Core.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or ph or b or i or sup or sub or tt or u) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or ph or b or i or sup or sub or tt or u or menucascade or uicontrol) (any number)

Contained by

Doctype | Content model
topic (base), topic (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
map (base), map (technical content), classifyMap, subjectScheme, learningMap | topicmeta
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

- topic/source

Example

<prolog>
 <source>Somewhere, someplace</source>
</prolog>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource from which the present resource is derived. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.24 series
Next topic: 3.1.3.1.26 vrmlist


vrmlist

3.1.3.1.26 vrmlist

The <vrmlist> element contains a set of <vrm> elements for logging the version, release, and modification information for multiple products or versions of products to which the topic applies.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | (vrm) (one or more)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | prodinfo

Inheritance

- topic/vrmlist

Example

The recent versions of a hypothetical product might be logged thus using the vrmlist markup:

<prolog>
 <metadata>
  <prodinfo>
   <prodname>Widge-o-matic</prodname>
   <vrmlist>
     <vrm version="1" release="2" modification="0"/>
     <vrm version="1" release="2" modification="1"/>
   </vrmlist>
  </prodinfo>
 </metadata>
</prolog>

This indicates that the topic covers Version 1, release 2, modification levels 0 and 1 (often expressed as version 1.2.0 and 1.2.1).

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.25 source
Next topic: 3.1.3.1.27 vrm


vrm

3.1.3.1.27 vrm

The vrm element contains information about a single product's version, modification, and release, to which the current topic applies.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | vrmlist

Inheritance

- topic/vrm

Example

The recent versions of a hypothetical product might be logged thus using the vrmlist markup:

<prolog>
 <metadata>
  <prodinfo>
   <prodname>Widge-o-matic</prodname>
   <vrmlist>
     <vrm version="1" release="2" modification="0"/>
     <vrm version="1" release="2" modification="1"/>
   </vrmlist>
  </prodinfo>
 </metadata>
</prolog>

This indicates that the topic covers Version 1, release 2, modification levels 0 and 1 (often expressed as version 1.2.0 and 1.2.1).

Attributes

Name | Description | Data Type | Default Value | Required?
version | Indicates the released version number of the product(s) that the document describes. | CDATA | #IMPLIED | Yes
release | Contains the product release identifier. | CDATA | #IMPLIED | No
modification | Indicates the modification level of the current version and release. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.1 Prolog (metadata) elements
Previous topic: 3.1.3.1.26 vrmlist
Next topic: 3.1.3.2 Indexing group elements


Indexing group elements

3.1.3.2 Indexing group elements

The indexing domain provides several new elements for use with indexing. The new elements allow authors to define "See" and "See also" references, and to override the default sort order for a term.

Indexing domain elements typically work with the indexterm and index-base elements; index-base is grouped with elements that are typically useful only in specialization contexts, and can be found using the link below.
  • 3.1.3.2.1 indexterm
    The content of an <indexterm> element is used to produce an index entry in the generated index. You can nest indexterm elements to create multi-level indexes. The content is not output as part of the topic content, only as part of the index.
  • 3.1.3.2.2 indextermref
    This element is not completely defined; it is reserved for future use.
  • 3.1.3.2.3 index-see
    An <index-see> element within an <indexterm> redirects the reader to another index entry that the reader should reference instead of the current one.
  • 3.1.3.2.4 index-see-also
    An <index-see-also> element within an <indexterm> redirects the reader to another index entry that the reader should reference in addition to the current one.
  • 3.1.3.2.5 index-sort-as
    The <index-sort-as> element specifies a sort phrase under which an index entry would be sorted.
Parent topic: 3.1.3 Metadata elements
Previous topic: 3.1.3.1.27 vrm
Next topic: 3.1.3.2.1 indexterm
Related reference
3.1.6.5 index-base


indexterm

3.1.3.2.1 indexterm

The content of an <indexterm> element is used to produce an index entry in the generated index. You can nest indexterm elements to create multi-level indexes. The content is not output as part of the topic content, only as part of the index.

An <indexterm> element (with no start or end attribute specified) is interpreted as a point reference that will contribute the number of the current page to an index entry whose contents is the content of the indexterm. All indexterms with the same content are "merged" to form a single index entry in the resulting index, and all contributed page numbers are included in that index entry.

In the case of nested indexterms, the indexterms with no indexterm children (i.e., the "leaves") each contribute a page number to the generated index; the ancestral indexterm elements for each leaf indexterm provide the higher levels for the multilevel entry.

An indexterm that occurs in a topic prolog is interpreted as a point reference to the title of the topic. Likewise, an indexterm that occurs in <topicmeta> inside of a <topicref> is interpreted as a point reference to the title of the referenced topic.

It is an error if an indexterm containing no indexterm children contains both an index-see and an index-see-also. (Note: index-see and index-see-also elements within indexterms that do contain indexterm children are ignored.) In the case of this error condition, an implementation may (but need not) give an error message, and may (but need not) recover by treating all such index-see elements as index-see-also elements.

Note: The index-see and index-see-also elements are domain specializations of the <index-base> element, and are discussed in detail with the indexing domain.

The start and end attribute on indexterm can be used in cases where one wants to index an extended discussion that may continue over a number of pages. The start of a range is indicated by an indexterm with a start attribute. The end of a range is indicated with an indexterm with an end attribute whose value matches that of the start attribute on the start-of-range indexterm. Such markup contributes to the generated index a page range covering all pages in the index range.

The end-of-range indexterm should have no content of its own; if it contains content, that content is ignored. There is no reason for the end-of-range indexterm to have any indexterm ancestors; however, an implementation should be able to handle an end-of-range indexterm that is nested within one or more indexterms.

The start and end attributes are defined as CDATA, though it is recommended that the values should not contain any whitespace characters (e.g., space or tab) or control characters. Matching of start and end attributes is done as a character-by-character comparison with all characters significant and no case folding occurring. The start and end attributes are ignored if they occur on an indexterm element that has child indexterm elements.

Index range indications may occur in the topicmeta of a topicref at the map level, in the prolog of a topic, or in the body of a topic, and are interpreted as follows (see Figure 3 for samples):
  • In a map, the start range points to the start of the topic title of the topic being referenced by its containing topicref. The end range points to the end of the final child contained by the topic being referenced by its containing topicref, or to the end of the final topic referenced by the current map (whichever comes first). When a start and end range occur in the same topicmeta, the range applies to the containing topicref and its children.
  • In the prolog of a topic, the start range points to the start of the containing topic's title. The range ends with a matching index range end in the same prolog, regardless of whether the end range is specified. The range applies to the containing topic and all its children including child relationships defined in a map.
  • In the body of a topic, the range starts where the start indexterm occurs and ends at the matching index range end indication within the same body, or at the end of the body, whichever comes first. Such an index range does not span sub-topics of the topic.

When index ranges with the same identifier overlap, the widest range applies, and end ranges are matched with start ranges by last-in-first-out. In other words, the ranges are interpreted as nested rather than overlapping with the highest-level container taking precedence over narrower contained ranges.

As defined above, there is no such thing as an index range start that isn't terminated by either a matching end or some maximum scope. There can, however, be unmatched index range end indications; these should be ignored.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or indexterm or index-base or index-see or index-see-also or index-sort-as) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or indexterm or index-base or index-see or index-see-also or index-sort-as) (any number)
subjectScheme | ( text data or data or data-about or foreign or unknown or keyword or term or indexterm or index-base) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or indexterm or index-base or index-see or index-see-also or index-sort-as) (any number)

Contained by

Doctype | Content model
topic (base) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, index-see, index-see-also
map (base), classifyMap, learningMap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, index-see, index-see-also
topic (technical content), concept | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, index-see, index-see-also, screen, codeblock, pd
map (technical content) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, index-see, index-see-also, screen, codeblock, pd
ditabase | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, glossdef, glossUsage, glossScopeNote, index-see, index-see-also, screen, codeblock, pd
glossary, glossentry, glossgroup | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, glossdef, glossUsage, glossScopeNote, index-see, index-see-also, screen, codeblock, pd
reference | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, index-see, index-see-also, screen, codeblock, pd
task (strict), task (general) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, index-see, index-see-also, screen, codeblock, pd
bookmap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, index-see, index-see-also, organizationname, screen, codeblock, pd
subjectScheme | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords
machineryTask | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, index-see, index-see-also, screen
learningAssessment, learningOverview, learningSummary | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, index-see, index-see-also, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, index-see, index-see-also, organizationname
learningContent | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, index-see, index-see-also, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, indexterm, index-base, entry, keywords, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, index-see, index-see-also, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/indexterm

Example

Figure 1. Single point index terms
  • The following index term is a point reference to a specific paragraph within a topic:
    <p><indexterm>databases</indexterm>Databases are used to ...</p>
  • The following index term is a point reference to the start of the title of the concept:
    <concept id="db">
  <title>About databases</title>
  <prolog>
    <metadata>
      <keywords><indexterm>databases</indexterm></keywords>
    </metadata>
  </prolog>
  <body><!-- content... --></body>
</concept>
  • The following index term is a point reference to the start of the title of aboutdatabases.dita:
    <topicref href="aboutdatabases.dita">
  <topicmeta>
    <keywords><indexterm>databases</indexterm></keywords>
  </topicmeta>
  <!-- other topicref elements -->
</topicref>
Figure 2. Nested index terms
The following sample represents three levels of index markup:
<indexterm>cheese
  <indexterm>sheeps milk
    <indexterm>pecorino</indexterm>
  </indexterm>
  <indexterm>goats milk
    <indexterm>chevre</indexterm>
  </indexterm>
</indexterm>
The previous sample is equivalent to the following sample:
<indexterm>cheese
  <indexterm>sheeps milk
    <indexterm>pecorino</indexterm>
  </indexterm>
</indexterm>
<indexterm>cheese
  <indexterm>goats milk
    <indexterm>chevre</indexterm>
  </indexterm>
</indexterm>
In each case, a generated index would include something like the this:
  • cheese
    • goats milk
      • chevre 14
    • sheeps milk
      • pecorino 14
Figure 3. Index ranges
A simple index range will look something like this:
<indexterm start="cheese">Cheese</indexterm>
<!-- ... additional content -->
<indexterm end="cheese"/>
The previous combination of terms will generate a top-level index term for "Cheese" that covers a series of pages, such as:
  • Cheese 18-24
Specifying a range for nested terms is similar. In this sample, the range is specified for the tertiary index entry "pecorino":
<indexterm>cheese
  <indexterm>sheeps milk
    <indexterm start="level-3-pecorino">pecorino</indexterm>
  </indexterm>
</indexterm>
 <!-- ... additional content ... -->
<indexterm end="level-3-pecorino"/>
The generated index for that range would look something like this:
  • cheese
    • sheeps milk
      • pecorino 18-24

There are three locations that may declare a range - the body of a topic, the prolog of a topic, and a map.

  • In the following example, the range begins at the start of the second paragraph, and continues to the last paragraph. If the matching end range was not included, the range would end at the end of the body element.
    <topic id="accounting">
  <title>Accounting regulations</title>
  <body>
    <p>Be ethical in your accounting.</p>
    <p><indexterm start="acctrules">Rules</indexterm>Remember to do all of the following: ...</p>
    <!-- ...pages worth of rules... -->
    <p><indexterm end="acctrules"/>Failure to comply will get you audited.</p>
  </body>
  <!-- Potential sub-topics -->
</topic>
  • In the following example, the range begins with the start of the topic's title, and covers the entire topic and any sub-topics. The range ends within the same prolog, regardless of whether <indexterm end="acct"/> is specified in the prolog.
    <topic id="accounting">
  <title>Accounting rugulations</title>
  <prolog>
    <metadata>
      <keywords><indexterm start="acct">Accounting</indexterm></keywords>
    </metadata>
  </prolog>
  <!-- Body and sub-topics -->
</topic>
  • Now assume that the topic in the previous sample is named acct.dita. Ranges defined in a prolog cover sub-topics, including those nested based on a map; in the following example, this means that the range covers all of acct.dita, as well as procedures.dita and forms.dita:
    <topicref href="acct.dita">
  <topicref href="procedures.dita"/>
  <topicref href="forms.dita"/>
</topicref>
  • In the final example, the range is specified in a map. The index range for "Accounting" begins with the start of the first topic title in acct.dita, and covers that file as well as any sub-topics. The index range for "Government forms" begins with the start of the first topic title in acct.dita, and continues until the end of the last element in the file taxfiling.dita. If the end range for "govt" was not specified, the range would continue to the end of the map.
    <topicref href="acct.dita">
  <topicmeta>
    <keywords>
      <indexterm start="acct">Accounting</indexterm>
      <indexterm end="acct"/>
      <indexterm start="govt">Government forms</indexterm>
    </keywords>
  </topicmeta>
  <!-- Nested topicref elements -->
</topicref>
<topicref href="taxfiling.dita">
  <topicmeta>
    <keywords>
      <indexterm end="govt"/>
    </keywords>
  </topicmeta>
</topicref>

Attributes

Name | Description | Data Type | Default Value | Required?
start | Specifies that an index entry is positioned at the beginning of a range. See the description of <indexterm> for more information. | CDATA | #IMPLIED | No
end | Specifies that an index entry is positioned at the end of a range; value matches the start attribute on another indexterm. See the description of <indexterm> for more information. | CDATA | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.2 Indexing group elements
Previous topic: 3.1.3.2 Indexing group elements
Next topic: 3.1.3.2.2 indextermref


indextermref

3.1.3.2.2 indextermref

This element is not completely defined; it is reserved for future use.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example
map (base), classifyMap, subjectScheme, learningMap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry
topic (technical content), concept | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, screen, codeblock, pd
map (technical content) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, screen, codeblock, pd
ditabase | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, glossdef, glossUsage, glossScopeNote, screen, codeblock, pd
glossary, glossentry, glossgroup | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, glossdef, glossUsage, glossScopeNote, screen, codeblock, pd
reference | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, screen, codeblock, pd
task (strict), task (general) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, screen, codeblock, pd
bookmap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, organizationname, screen, codeblock, pd
machineryTask | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, screen
learningAssessment, learningOverview, learningSummary | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, organizationname
learningContent | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/indextermref

Example

Examples will be added when this element is fully defined.

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.2 Indexing group elements
Previous topic: 3.1.3.2.1 indexterm
Next topic: 3.1.3.2.3 index-see


index-see

3.1.3.2.3 index-see

An <index-see> element within an <indexterm> redirects the reader to another index entry that the reader should reference instead of the current one.

The <index-see> and <index-see-also> elements allow a form of redirection to another index entry within the generated index. The <index-see> element refers to an index entry that the reader should use instead of the current one, whereas the <index-see-also> element refers to an index entry that the reader should use in addition to the current one.

The <index-see> and <index-see-also> elements are ignored if their parent indexterm element contains any indexterm children.

Because an index-see indicates a redirection to use instead of the current entry, it is an error if, for any index-see, there is also an index-see-also or an indexterm for the same index entry (i.e., with an identical sort key). An implementation may (but need not) give an error message, and may (but need not) recover from this error condition by treating the index-see as an index-see-also.

It is not an error for there to be multiple index-see elements for a single index entry.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or indexterm) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or indexterm) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or indexterm) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | indexterm

Inheritance

+ topic/index-base indexing-d/index-see

The following example illustrates the use of an <index-see> redirection element within an <indexterm>:

<indexterm>Carassius auratus
   <index-see>Goldfish</index-see>
</indexterm>

This will typically generate an index entry without a page reference:

  • Carassius auratus, see Goldfish

The following example illustrates the use of an <index-see> redirection element to a more complex (multilevel) <indexterm>:

<indexterm>Feeding goldfish
   <index-see>Goldfish <indexterm>feeding</indexterm></index-see>
</indexterm>

This is part of the indexing markup that might generate index entries such as:

  • Feeding goldfish
    • see Goldfish feeding
  • Goldfish
    • feeding, 56
    • flushing, 128, 345

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.2 Indexing group elements
Previous topic: 3.1.3.2.2 indextermref
Next topic: 3.1.3.2.4 index-see-also


index-see-also

3.1.3.2.4 index-see-also

An <index-see-also> element within an <indexterm> redirects the reader to another index entry that the reader should reference in addition to the current one.

The <index-see> and <index-see-also> elements allow a form of redirection to another index entry within the generated index. The <index-see> element refers to an index entry that the reader should use instead of the current one, whereas the <index-see-also> element refers to an index entry that the reader should use in addition to the current one.

The <index-see> and <index-see-also> elements are ignored if their parent indexterm element contains any indexterm children.

In addition to its "see also" redirection, an index-see-also functions as a pointwise indexterm, thereby typically generating a page reference as well as the "see also" indication.

It is not an error for there to be multiple index-see-also elements for a single index entry.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or indexterm) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or indexterm) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or indexterm) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | indexterm

Inheritance

+ topic/index-base indexing-d/index-see-also

The following example illustrates the use of an <index-see-also> redirection element within an <indexterm>:

<indexterm>Carp
   <index-see-also>Goldfish</index-see-also>
</indexterm>
This will typically generate a page reference to "Carp" and a redirection:
  • Carp, 56
    • see also Goldfish

The following example illustrates the use of an <index-see-also> redirection element to a more complex (multilevel) <indexterm>:

<indexterm>Feeding
   <index-see-also>Goldfish <indexterm>feeding</indexterm></index-see-also>
</indexterm>

This is part of the indexing markup that might generate index entries such as:

  • Feeding, 348
    • see also Goldfish feeding
  • Goldfish
    • feeding, 56
    • flushing, 128, 345

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.2 Indexing group elements
Previous topic: 3.1.3.2.3 index-see
Next topic: 3.1.3.2.5 index-sort-as


index-sort-as

3.1.3.2.5 index-sort-as

The <index-sort-as> element specifies a sort phrase under which an index entry would be sorted.

This element gives an author the flexibility to sort an index entry in an index differently from how its text normally would be sorted. The common use for this is to disregard insignificant leading text, such as punctuation or words like "the" or "a". For example, the author may want <data> to be sorted under the letter D rather than the left angle bracket (<). An author may want to include such an entry under both the punctuation heading and the letter D, in which case there can be two index entry directives differentiated only by the sort order.

Certain languages may have special sort order needs. For example, Japanese index entries might be written partially or wholly in kanji, but need to be sorted in phonetic order according to its hiragana/katakana rendition. There is no reliable automated way to map written to phonetic text: for kanji text, there can be multiple phonetic possibilities depending on the context. The only way to correctly sort Japanese index entries is to keep the phonetic counterparts with the written forms. The phonetic text would be presented as the sort order text for indexing purposes.

The <index-sort-as> element's content is logically augmented by the textual content of its parent <indexterm> element to produce the effective sort key (i.e., the textual content acts as a secondary sort field), so two indexterms with different content but the same <index-sort-as> value would never merge into a single index entry.

An <index-sort-as> element provides sort key information for the indexterm that is its parent; therefore, in a multiple level indexterm, the index-sort-as only affects the level in which it occurs.

It is an error if there is more than one index-sort-as child for a given indexterm. An implementation may (but need not) give an error message, and may (but need not) recover from this error condition by ignoring all but the last index-sort-as.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | indexterm

Inheritance

+ topic/index-base indexing-d/index-sort-as

This is an example of an index entry for <data> that will be sorted as "data":

<indexterm>&lt;data&gt;<index-sort-as>data</index-sort-as></indexterm>

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.2 Indexing group elements
Previous topic: 3.1.3.2.4 index-see-also
Next topic: 3.1.3.3 Delayed conref resolution elements


Delayed conref resolution elements

3.1.3.3 Delayed conref resolution elements

The delayed conref resolution domain provides several elements for use when using DITA in situations that enable delayed or run time resolution of conref. The elements allow users to resolve some conref values statically, while delaying others for later resolution.

Many publishing systems for which DITA is used as a source format do not have a way to dynamically resolve content references; those systems will not see any benefit from this element. When DITA is used for those systems, behaviors related to this element should be ignored.

  • 3.1.3.3.1 exportanchors
    The <exportanchors> element is used to delay conref resolution within DITA documents. This allows you to process or display DITA content in a way that will resolve only some of the conref values in that content, while remaining values are left for later resolution. The element contains a list of IDs or keys that should not be resolved during the initial preparation of the content for display; those IDs and keys will be preserved after that preparation, as will the conref relationship itself.
  • 3.1.3.3.2 anchorid
    The <anchorid> element allows an author to define a conref target that will be resolved dynamically when rendered for an end user of the content. This element is useful when doing an initial process of the DITA content prior to final rendering of the content; it causes specified IDs to be preserved after that process, and conref relationships that reuse the element will not be resolved during the initial process.
  • 3.1.3.3.3 anchorkey
    The <anchorkey> element allows an author to define a conref target that will be resolved dynamically when rendered for an end user of the content. This element is useful when doing an initial process of the DITA content prior to final rendering of the content; it allows specified keys to be preserved after that process, and conref relationships which use that key will not be resolved during that initial process.
Parent topic: 3.1.3 Metadata elements
Previous topic: 3.1.3.2.5 index-sort-as
Next topic: 3.1.3.3.1 exportanchors


exportanchors

3.1.3.3.1 exportanchors

The <exportanchors> element is used to delay conref resolution within DITA documents. This allows you to process or display DITA content in a way that will resolve only some of the conref values in that content, while remaining values are left for later resolution. The element contains a list of IDs or keys that should not be resolved during the initial preparation of the content for display; those IDs and keys will be preserved after that preparation, as will the conref relationship itself.

The exportanchors element may be used within a topic prolog, in which case the defined IDs apply to IDs within that topic (excluding sub-topics). Alternatively it may be defined in the topicmeta in a map. In the second case the IDs apply to the single topic referenced by the current topicref element. If the topicref points to a file without referencing a specific topic, it is treated as a reference to the first or root topic. In order to define anchor ids for a topic that is not the first or root topic, a topicref must directly reference the desired sub-topic.

Note: When an element's ID is defined for delayed resolution, it must contain only the element ID, not the usual "topicid/elementid" syntax that is required for most other DITA references. The <anchorid> topic explains the format in detail.

One possible way to use this is with a system that renders DITA dynamically. A user may process information locally in a way that resolves conref for all static information, while delaying resolution for information that is subject to change. The exportanchors element is used to define conref values that are delayed.

Another potential use is when DITA is used as the source format for a publishing system that is able to render information dynamically. In this case some conref values may be resolved, while leaving pre-selected values to be resolved live in that publishing system.

Many publishing systems for which DITA is used as a source format do not have a way to dynamically resolve content references; those systems will not see any benefit from this element. When DITA is used for those systems, behaviors related to this element should be ignored.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, learningBookmap, learningMap | (anchorid or anchorkey) (any number)

Contained by

Doctype | Content model
map (base), map (technical content), classifyMap, learningMap | metadata, topicmeta
bookmap, learningBookmap | metadata, topicmeta, bookmeta

Inheritance

+ topic/keywords delay-d/exportanchors

Example

Figure 1. Use case 1: Runtime resolution of conref to an id, determined by original author
  1. Author 1 creates topics for information component A, which is a common component used by many products. The configuration task for component A is often reused in whole or in part, so the author assigns ids to each of the steps in the procedure and exports them.
    <task id="configA">
  <title>ABC<title>
  <shortdesc>...</shortdesc>
  <prolog><metadata>
    <exportanchors>
      <anchorid id="step1"/>
      <anchorid id="step2"/>
      <anchorid id="step3"/>
    </exportanchors>
  </metadata></prolog>
  <taskbody>
    <steps>
      <step id="step1"><cmd>Do this</cmd></step>
      <step id="step2"><cmd>Do the other</cmd></step>
      <step id="step3"><cmd>And then finish</cmd></step>
    </steps>
  </taskbody>
</task>
  2. Author 2 is working on information component B, which has information component A as a prerequisite.
  3. Author 2 creates a configuration task that reuses two steps from the configuration task in information component A.
    <task id="configB">
  <title>..</title>
  <shortdesc>..</shortdesc>
  <taskbody>
    <steps>
      <step><cmd>Do the very first thing</cmd></step>
      <step conref="componentA/configA.dita#configA/step1"><cmd/></step>
      <step><cmd>Do the middle thing</cmd></step>
      <step conref="componentA/configA.dita#configA/step2"><cmd/></step>
    </steps>
  </taskbody>
</task>
  4. Author 2 builds the content for component B into a deliverable format that supports dynamic content resolution. As with traditional conref, the source for component A must be available during this process. Because the ids in configA are exported, the build process knows to preserve the reuse relationship rather than resolve it - so the conref to the steps becomes an equivalent reuse artifact in that deliverable format. This way the relationship to component A can be resolved at runtime, and pick up the user's version of component A, which may be more up-to-date than the one used by Author 2 when component B was built.
Figure 2. Use case 2: Runtime resolution to an id exported by the information builder
  1. Author 1 is creating content that will be packaged into multiple deliverable components. In one of those components, component A, the ids should be exported for runtime reuse by other components. In other components, the ids should not be exported because all reuse is local (for example, the output is a single infocenter, or a helpset that has only one component).
  2. When author 1 builds component A, the author uses a map that exports the ids, rather than exporting the ids from the topic prolog.
    <map>
  <topicref href="componentA/configA.dita">
    <topicmeta>
      <exportanchors>
        <anchorid id="step1"/>
        <anchorid id="step2"/>
        <anchorid id="step3"/>
      </exportanchors>
    </topicmeta>
  </topicref>
</map>
  3. The rest of the use case is the same as previous - the conref is passed on to the runtime/display format to deal with, rather than being resolved during native DITA processing.
Figure 3. Delaying resolution for a topic

The ID on an <anchorid> element is first compared with the topic's id, and then with elements inside that topic. This results in the following situation.

<map>
  <topicref href="componentA/this.dita">
    <topicmeta>
      <exportanchors>
        <anchorid id="this"/>
        <anchorid id="that"/>
      </exportanchors>
    </topicmeta>
  </topicref>
</map>

<topic id="this">
  <title>This and that</title>
  <shortdesc>Oh, you know, this and that.</shortdesc>
  <body>
    <fig id="that"><p>more of that</p></fig>
  </body>
</topic>
  • The first ID to be exported is "this", which matches the topic id, so resolution of conref values that target the topic should be delayed.
  • The second value is "that", which matches a figure within the topic, so resolution of conref values that target the figure should be delayed.
  • Note that if the "this" is also used within the topic (which is legal from a DITA perspective), it will not be possible to export that id, because processors will match on the topic's id first.

Example

In this example, a set of information contains multiple components. Some references to component A use keys rather than a direct reference, so that conref can be redirected to a different component when component A is not installed. The keys may be exported, in addition to the IDs, so that some references become bound to the actual component while other references may be redirected.

<map>
  <topicref keys="componentAconfig commonconfig"
            href="componentA/configA.dita#configA">
    <topicmeta>
      <exportanchors>
        <anchorkey keyref="commonconfig"/>
        <anchorid id="step1"/>
        <anchorid id="step2"/>
      </exportanchors>
    </topicmeta>
  </topicref>
</map>

The keys attributes declares two distinct keys that may be used to refer to this topic (componentAconfig and commonconfig). Only the second is preserved using anchorkey. A task topic from another component may reuse steps within this topic in a variety of ways.

<steps>
  <step conkeyref="componentAconfig/step1"><cmd/></step>
  <step conkeyref="componentAconfig/step1.5"><cmd/></step>
  <step conkeyref="commonconfig/step2"><cmd/></step>
  <step conkeyref="commonconfig/step2.5"><cmd/></step>
  <step><cmd>And that is the end of that</cmd>
</steps>
  • The componentAconfig key is not preserved, so the first step becomes <step conref="componentA/configA.dita#configA/step1"><cmd/></step>. At that point the anchorid element instructs the step1 ID to be preserved; for runtime applications which support it, this relationship will be preserved in the processed DITA output.
  • The second step with the same key becomes <step conref="componentA/configA.dita#configA/step1.5"><cmd/></step>. However, conref relationships to step1.5 are not preserved, so this conref should be resolved into static content.
  • For step three, the map instructs that both the key commonconfig and the ID step2 should be preserved in any content generated for this DITA topic. For formats that support runtime resolution through keys, a process must convert the conkeyref value into an equivalent value for that format.
  • Although resolution for the key used in step four is delayed, the specific element that is referenced should not be delayed. Thus the fourth step becomes <step conref="componentA/configA.dita#configA/step2.5"><cmd/></step>. This value is then processed as an ordinary conref value.

This allows the information assembler to resolve references that must be to componentA while deferring references that can be fulfilled by alternative component content.

Note: This example demonstrates why the anchorid element cannot reference an element with the usual topicid/elementid format. If the two anchorid elements in the example had been set to config/step1 and config/step2, then they would only ever apply in a topic with id="config". It would not be possible to redirect the key to another topic, but still preserve conref behaviors as desired.
Note: Although it is not specifically called out in this example, it is possible to delay conref resolution for an entire topic using the key. If conkeyref on a task topic element is set to "componentAconfig", which is not delayed, the conref will be evaluated as usual. However, if conkeyref on the task is set to "commonconfig", which is delayed, resolution of conref on that element should be delayed by a processor.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.3 Delayed conref resolution elements
Previous topic: 3.1.3.3 Delayed conref resolution elements
Next topic: 3.1.3.3.2 anchorid


anchorid

3.1.3.3.2 anchorid

The <anchorid> element allows an author to define a conref target that will be resolved dynamically when rendered for an end user of the content. This element is useful when doing an initial process of the DITA content prior to final rendering of the content; it causes specified IDs to be preserved after that process, and conref relationships that reuse the element will not be resolved during the initial process.

When the anchorid element is defined within a topic prolog, the specified IDs will be found within that topic. When an anchorid element is defined within a topicref element, the specified IDs will be found within the referenced topic (if the topicref points to a collection of topics, such as a reference that uses only a file name, the IDs will be found within the first or root topic).

The only difference between specifying an anchorid in the prolog and in topicmeta is that from the map it is possible to export the ID of the entire referenced topic. If <anchorid id="zero"/> is specified in the topicmeta, and the referenced topic has an id of "zero", this means that the anchorid is a reference to the entire topic. If the topic id is not "zero", then the anchorid is a reference to the element with id="zero" within that topic.

Along with the preservation of the element's ID, any conref attribute that references the element's ID will not be resolved during an initial process. In that case, the conref will be resolved during a later rendering process.

This description does not imply that IDs are not discarded when anchorid is not used; though this element requires that IDs be preserved in some manner, it is also common for IDs to be preserved when anchorid is not used. Thus the primary impact of the anchorid element is on conref resolution.

Many publishing systems for which DITA is used as a source format do not have a way to dynamically resolve content references; those systems will not see any benefit from this element. When DITA is used for those systems, behaviors related to this element should be ignored.

Why not use topicid/elementid?

This element differs from normal DITA referencing syntax in that it may reference an element within a topic without using the topic's ID. There are two reasons for this. First, the anchorid element may only be defined in a situation that refers unambiguously to a single topic (in the prolog, or in the topicmeta for a reference to a topic). Second, it allows the anchorid to be combined with keyref values.

It is possible to combine an anchor id with a key in order to delay resolution of conref in the topic represented by that key (see the second set of examples below). This would not be possible if the anchorid element required both the topic id and the element id. That is, keyref allows a modifiable reference to a topic, so a map may instruct processors to delay conref for item step1 in the topic represented by the key "commonconfig". If the anchorid element required a topic id, the delayed conref would always be bound to that specific topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, learningBookmap, learningMap | no content

Contained by

Doctype | Content model
map (base), map (technical content), bookmap, classifyMap, learningBookmap, learningMap | exportanchors

Inheritance

+ topic/keyword delay-d/anchorid

Example

Figure 1. Use case 1: Runtime resolution of conref to an id, determined by original author
  1. Author 1 creates topics for information component A, which is a common component used by many products. The configuration task for component A is often reused in whole or in part, so the author assigns ids to each of the steps in the procedure and exports them.
    <task id="configA">
  <title>ABC<title>
  <shortdesc>...</shortdesc>
  <prolog><metadata>
    <exportanchors>
      <anchorid id="step1"/>
      <anchorid id="step2"/>
      <anchorid id="step3"/>
    </exportanchors>
  </metadata></prolog>
  <taskbody>
    <steps>
      <step id="step1"><cmd>Do this</cmd></step>
      <step id="step2"><cmd>Do the other</cmd></step>
      <step id="step3"><cmd>And then finish</cmd></step>
    </steps>
  </taskbody>
</task>
  2. Author 2 is working on information component B, which has information component A as a prerequisite.
  3. Author 2 creates a configuration task that reuses two steps from the configuration task in information component A.
    <task id="configB">
  <title>..</title>
  <shortdesc>..</shortdesc>
  <taskbody>
    <steps>
      <step><cmd>Do the very first thing</cmd></step>
      <step conref="componentA/configA.dita#configA/step1"><cmd/></step>
      <step><cmd>Do the middle thing</cmd></step>
      <step conref="componentA/configA.dita#configA/step2"><cmd/></step>
    </steps>
  </taskbody>
</task>
  4. Author 2 builds the content for component B into a deliverable format that supports dynamic content resolution. As with traditional conref, the source for component A must be available during this process. Because the ids in configA are exported, the build process knows to preserve the reuse relationship rather than resolve it - so the conref to the steps becomes an equivalent reuse artifact in that deliverable format. This way the relationship to component A can be resolved at runtime, and pick up the user's version of component A, which may be more up-to-date than the one used by Author 2 when component B was built.
Figure 2. Use case 2: Runtime resolution to an id exported by the information builder
  1. Author 1 is creating content that will be packaged into multiple deliverable components. In one of those components, component A, the ids should be exported for runtime reuse by other components. In other components, the ids should not be exported because all reuse is local (for example, the output is a single infocenter, or a helpset that has only one component).
  2. When author 1 builds component A, the author uses a map that exports the ids, rather than exporting the ids from the topic prolog.
    <map>
  <topicref href="componentA/configA.dita">
    <topicmeta>
      <exportanchors>
        <anchorid id="step1"/>
        <anchorid id="step2"/>
        <anchorid id="step3"/>
      </exportanchors>
    </topicmeta>
  </topicref>
</map>
  3. The rest of the use case is the same as previous - the conref is passed on to the runtime/display format to deal with, rather than being resolved during native DITA processing.
Figure 3. Delaying resolution for a topic

The ID on an <anchorid> element is first compared with the topic's id, and then with elements inside that topic. This results in the following situation.

<map>
  <topicref href="componentA/this.dita">
    <topicmeta>
      <exportanchors>
        <anchorid id="this"/>
        <anchorid id="that"/>
      </exportanchors>
    </topicmeta>
  </topicref>
</map>

<topic id="this">
  <title>This and that</title>
  <shortdesc>Oh, you know, this and that.</shortdesc>
  <body>
    <fig id="that"><p>more of that</p></fig>
  </body>
</topic>
  • The first ID to be exported is "this", which matches the topic id, so resolution of conref values that target the topic should be delayed.
  • The second value is "that", which matches a figure within the topic, so resolution of conref values that target the figure should be delayed.
  • Note that if the "this" is also used within the topic (which is legal from a DITA perspective), it will not be possible to export that id, because processors will match on the topic's id first.

Example

In this example, a set of information contains multiple components. Some references to component A use keys rather than a direct reference, so that conref can be redirected to a different component when component A is not installed. The keys may be exported, in addition to the IDs, so that some references become bound to the actual component while other references may be redirected.

<map>
  <topicref keys="componentAconfig commonconfig"
            href="componentA/configA.dita#configA">
    <topicmeta>
      <exportanchors>
        <anchorkey keyref="commonconfig"/>
        <anchorid id="step1"/>
        <anchorid id="step2"/>
      </exportanchors>
    </topicmeta>
  </topicref>
</map>

The keys attributes declares two distinct keys that may be used to refer to this topic (componentAconfig and commonconfig). Only the second is preserved using anchorkey. A task topic from another component may reuse steps within this topic in a variety of ways.

<steps>
  <step conkeyref="componentAconfig/step1"><cmd/></step>
  <step conkeyref="componentAconfig/step1.5"><cmd/></step>
  <step conkeyref="commonconfig/step2"><cmd/></step>
  <step conkeyref="commonconfig/step2.5"><cmd/></step>
  <step><cmd>And that is the end of that</cmd>
</steps>
  • The componentAconfig key is not preserved, so the first step becomes <step conref="componentA/configA.dita#configA/step1"><cmd/></step>. At that point the anchorid element instructs the step1 ID to be preserved; for runtime applications which support it, this relationship will be preserved in the processed DITA output.
  • The second step with the same key becomes <step conref="componentA/configA.dita#configA/step1.5"><cmd/></step>. However, conref relationships to step1.5 are not preserved, so this conref should be resolved into static content.
  • For step three, the map instructs that both the key commonconfig and the ID step2 should be preserved in any content generated for this DITA topic. For formats that support runtime resolution through keys, a process must convert the conkeyref value into an equivalent value for that format.
  • Although resolution for the key used in step four is delayed, the specific element that is referenced should not be delayed. Thus the fourth step becomes <step conref="componentA/configA.dita#configA/step2.5"><cmd/></step>. This value is then processed as an ordinary conref value.

This allows the information assembler to resolve references that must be to componentA while deferring references that can be fulfilled by alternative component content.

Note: This example demonstrates why the anchorid element cannot reference an element with the usual topicid/elementid format. If the two anchorid elements in the example had been set to config/step1 and config/step2, then they would only ever apply in a topic with id="config". It would not be possible to redirect the key to another topic, but still preserve conref behaviors as desired.
Note: Although it is not specifically called out in this example, it is possible to delay conref resolution for an entire topic using the key. If conkeyref on a task topic element is set to "componentAconfig", which is not delayed, the conref will be evaluated as usual. However, if conkeyref on the task is set to "commonconfig", which is delayed, resolution of conref on that element should be delayed by a processor.

Attributes

Name | Description | Data Type | Default Value | Required?
id | Indicates an ID within the a specific topic that will be preserved during processing. Any conref values referencing the indicated ID will not be resolved; when possible, the original relationship should be preserved in any processed document. Note that this element creates an exception to the general rules that IDs may only be used once within a single topic or within a map; this is because the ID is actually a pointer to another target, rather than being a target itself. | CDATA | #REQUIRED | Yes
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.3.3 Delayed conref resolution elements
Previous topic: 3.1.3.3.1 exportanchors
Next topic: 3.1.3.3.3 anchorkey


anchorkey

3.1.3.3.3 anchorkey

The <anchorkey> element allows an author to define a conref target that will be resolved dynamically when rendered for an end user of the content. This element is useful when doing an initial process of the DITA content prior to final rendering of the content; it allows specified keys to be preserved after that process, and conref relationships which use that key will not be resolved during that initial process.

When a keyref attribute is specified on an anchorkey element, it indicates that any conref relationships using that key will not be resolved. Applications that support run-time resolution of conref with keys will then be able to dynamically resolve this conref at display time.

There is no difference between specifying anchorkey within a map (in topicmeta) and specifying anchorkey within a topic. In both cases, processors are instructed to delay resolution of that key for the current set of information. However, the best practice is to only use anchorkey within a map. If it is specified in a topic, that topic will define a usage for the key for every user of that topic. This makes the topic less portable, because users that do not want to delay resolution of that specific key will not be able to include the topic in their information.

Many publishing systems for which DITA is used as a source format do not have a way to dynamically resolve content references; those systems will not see any benefit from this element. When DITA is used for those systems, behaviors related to this element should be ignored.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map, bookmap, classifyMap, learningBookmap, learningMap | no content

Contained by

Doctype | Content model
map (base), map (technical content), bookmap, classifyMap, learningBookmap, learningMap | exportanchors

Inheritance

+ topic/keyword delay-d/anchorkey

Example

In this example, a set of information contains multiple components. Some references to component A use keys rather than a direct reference, so that conref can be redirected to a different component when component A is not installed. The keys may be exported, in addition to the IDs, so that some references become bound to the actual component while other references may be redirected.

<map>
  <topicref keys="componentAconfig commonconfig"
            href="componentA/configA.dita#configA">
    <topicmeta>
      <exportanchors>
        <anchorkey keyref="commonconfig"/>
        <anchorid id="step1"/>
        <anchorid id="step2"/>
      </exportanchors>
    </topicmeta>
  </topicref>
</map>

The keys attributes declares two distinct keys that may be used to refer to this topic (componentAconfig and commonconfig). Only the second is preserved using anchorkey. A task topic from another component may reuse steps within this topic in a variety of ways.

<steps>
  <step conkeyref="componentAconfig/step1"><cmd/></step>
  <step conkeyref="componentAconfig/step1.5"><cmd/></step>
  <step conkeyref="commonconfig/step2"><cmd/></step>
  <step conkeyref="commonconfig/step2.5"><cmd/></step>
  <step><cmd>And that is the end of that</cmd>
</steps>
  • The componentAconfig key is not preserved, so the first step becomes <step conref="componentA/configA.dita#configA/step1"><cmd/></step>. At that point the anchorid element instructs the step1 ID to be preserved; for runtime applications which support it, this relationship will be preserved in the processed DITA output.
  • The second step with the same key becomes <step conref="componentA/configA.dita#configA/step1.5"><cmd/></step>. However, conref relationships to step1.5 are not preserved, so this conref should be resolved into static content.
  • For step three, the map instructs that both the key commonconfig and the ID step2 should be preserved in any content generated for this DITA topic. For formats that support runtime resolution through keys, a process must convert the conkeyref value into an equivalent value for that format.
  • Although resolution for the key used in step four is delayed, the specific element that is referenced should not be delayed. Thus the fourth step becomes <step conref="componentA/configA.dita#configA/step2.5"><cmd/></step>. This value is then processed as an ordinary conref value.

This allows the information assembler to resolve references that must be to componentA while deferring references that can be fulfilled by alternative component content.

Note: This example demonstrates why the anchorid element cannot reference an element with the usual topicid/elementid format. If the two anchorid elements in the example had been set to config/step1 and config/step2, then they would only ever apply in a topic with id="config". It would not be possible to redirect the key to another topic, but still preserve conref behaviors as desired.
Note: Although it is not specifically called out in this example, it is possible to delay conref resolution for an entire topic using the key. If conkeyref on a task topic element is set to "componentAconfig", which is not delayed, the conref will be evaluated as usual. However, if conkeyref on the task is set to "commonconfig", which is delayed, resolution of conref on that element should be delayed by a processor.

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Defines a key that, when possible, should be preserved in content generated from the DITA source material. Conref relationships that use this key should not be resolved when generating that material, so that conref may be resolved at run-time when an end user is reading the content. | NMTOKEN | #REQUIRED | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
Parent topic: 3.1.3.3 Delayed conref resolution elements
Previous topic: 3.1.3.3.2 anchorid
Next topic: 3.1.4 Domain elements


Domain elements

3.1.4 Domain elements

General purpose domains are not specific to any type of information, such as the hazard statement domain that provides elements for describing hazardous situations.

  • 3.1.4.1 Hazard statement elements
    The hazard statement domain elements are used to provide information about product safety hazards. The domain can be included in any topic type or map. Its elements are used to inform readers about potential hazards, consequences, and avoidance strategies.
  • 3.1.4.2 Typographic elements
    The typographic elements are used to highlight text with styles (such as bold, italic, and monospace). Never use these elements when a semantically specific element is available. These elements are not intended for use by specializers, and are intended solely for use by authors when no semantically appropriate element is available and a formatting effect is required.
  • 3.1.4.3 Utilities elements
    The utilities domain elements represent common features of a language that may not necessarily be semantic, such as image maps.
Parent topic: 3.1 Base elements
Previous topic: 3.1.3.3.3 anchorkey
Next topic: 3.1.4.1 Hazard statement elements


Hazard statement elements

3.1.4.1 Hazard statement elements

The hazard statement domain elements are used to provide information about product safety hazards. The domain can be included in any topic type or map. Its elements are used to inform readers about potential hazards, consequences, and avoidance strategies.

  • 3.1.4.1.1 hazardstatement
    The <hazardstatement> element contains hazard warning information. It is based on the regulations of ANSI Z535 and ISO 3864. It enables the author to select the type of hazard, add information about the specific hazard and how to avoid it, and add one or more safety symbols.
  • 3.1.4.1.2 consequence
    The <consequence> element specifies the consequence of failing to avoid a hazard, for example, "Contact may cause burn."
  • 3.1.4.1.3 hazardsymbol
    The <hazardsymbol> element specifies a graphic. The graphic might represent a hazard, a hazardous situation, a result of not avoiding a hazard, or any combination of these messages.
  • 3.1.4.1.4 howtoavoid
    The <howtoavoid> element contains information about how a user can avoid a hazard, for example, "Do not use solvents to clean the drum surface."
  • 3.1.4.1.5 messagepanel
    The <messagepanel> element contains the textual information that is displayed on the hazard statement. This information identifies the hazard, specifies how to avoid the hazard, and states the probable consequences of failing to avoid the hazard.
  • 3.1.4.1.6 typeofhazard
    The <typeofhazard> element contains a description of the type of hazard, for example, "Hot surfaces inside."
Parent topic: 3.1.4 Domain elements
Previous topic: 3.1.4 Domain elements
Next topic: 3.1.4.1.1 hazardstatement


hazardstatement

3.1.4.1.1 hazardstatement

The <hazardstatement> element contains hazard warning information. It is based on the regulations of ANSI Z535 and ISO 3864. It enables the author to select the type of hazard, add information about the specific hazard and how to avoid it, and add one or more safety symbols.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | ( (messagepanel) (one or more) then (hazardsymbol) (any number) )

Contained by

Doctype | Content model
topic (base) | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry
topic (technical content) | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, step, info, substep, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossBody, glossAlt, pd
glossary, glossentry, glossgroup | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossBody, glossAlt, pd
reference | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, step, info, substep, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, step, info, substep, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond

Inheritance

+ topic/note hazard-d/hazardstatement

Example

Danger: Indicates an imminently hazardous situation which, if not avoided, will result in death or serious injury.
<hazardstatement type="danger">
  <messagepanel>
    <typeofhazard>Rotating blade.</typeofhazard>
    <consequence>Moving parts can crush and cut.</consequence>
    <howtoavoid>Follow lockout procedure before servicing.</howtoavoid>
  </messagepanel>
  <hazardsymbol href="rotatingblade.png"/>
</hazardstatement>
Warning: Indicates a potentially hazardous situation which, if not avoided, could result in death or serious injury.
<hazardstatement type="warning">
  <messagepanel>
    <typeofhazard>Hot surfaces inside.</typeofhazard>
    <consequence>Contact may cause burn.</consequence>
    <howtoavoid>Wear protective gear before servicing internal parts.</howtoavoid>
  </messagepanel>
  <hazardsymbol href="hotsurface.png"/>
</hazardstatement>
Caution: Indicates a potentially hazardous situation which, if not avoided, may result in minor or moderate injury.
<hazardstatement type="caution">
  <messagepanel>
    <typeofhazard>Lifting Hazard.</typeofhazard>
    <consequence>May result in injury.</consequence>
    <howtoavoid>See safety manual for lifting instructions.</howtoavoid>
  </messagepanel>
  <hazardsymbol href="heavy.png"/>
</hazardstatement>
Notice: Indicates a potential situation which, if not avoided, may result in property damage or in an undesirable result or state.
<hazardstatement type="notice">
  <messagepanel>
    <typeofhazard>Battery low</typeofhazard>
    <howtoavoid>Push and hold for charge state test.</howtoavoid>
  </messagepanel>
  <hazardsymbol href="general.png"/>
</hazardstatement>

Attributes

Name | Description | Data Type | Default Value | Required?
type | Describes the level of hazard. Safety hazard level definitions correspond to the same values in the ANSI Z535 and the ISO 3864 standards. | (note | tip | fastpath | restriction | important | remember | attention | caution | notice | danger | warning | other | -dita-use-​conref-​target) | #IMPLIED | No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
othertype | Indicates an alternate note type, when the type is not available in the type attribute value list. This value is used as the user-provided note title when the type attribute value is set to "other." | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.1 Hazard statement elements
Previous topic: 3.1.4.1 Hazard statement elements
Next topic: 3.1.4.1.2 consequence


consequence

3.1.4.1.2 consequence

The <consequence> element specifies the consequence of failing to avoid a hazard, for example, "Contact may cause burn."

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or data or data-about or foreign or unknown or keyword or term or ph or b or i or sup or sub or tt or u or tm) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or tm) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or tm) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | messagepanel

Inheritance

+ topic/li hazard-d/consequence

Example

<hazardstatement type="warning">
  <messagepanel>
    <typeofhazard>Hot surfaces inside.</typeofhazard>
    <consequence>Contact may cause burn.</consequence>
    <howtoavoid>Wear protective gear before servicing internal parts.</howtoavoid>
  </messagepanel>
  <hazardsymbol href="hotsurface.png"></hazardsymbol>
</hazardstatement>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.1 Hazard statement elements
Previous topic: 3.1.4.1.1 hazardstatement
Next topic: 3.1.4.1.3 hazardsymbol


hazardsymbol

3.1.4.1.3 hazardsymbol

The <hazardsymbol> element specifies a graphic. The graphic might represent a hazard, a hazardous situation, a result of not avoiding a hazard, or any combination of these messages.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | ( (alt) (optional) then (longdescref) (optional) )

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | hazardstatement

Inheritance

+ topic/image hazard-d/hazardsymbol

Example

<hazardstatement type="danger">
  <messagepanel>
    <typeofhazard>Rotating blade.</typeofhazard>
    <consequence>Moving parts can crush and cut.</consequence>
    <howtoavoid>Follow lockout procedure before servicing.</howtoavoid>
  </messagepanel>
  <hazardsymbol href="rotatingblade.png"/>
</hazardstatement>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to the image. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | Yes
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
longdescref (deprecated) | A reference to a textual description of the graphic or object. This attribute supports creating accessible content. See The href attribute for detailed information on supported values and processing implications. For examples of how this attribute is used in output, see this this topic on long descriptions. NOTE: This attribute is deprecated in favor of the longdescref subelement to this element. | CDATA | #IMPLIED | No
height | Indicates the vertical dimension for the resulting image display. If necessary, the image is scaled to the specified size. The value of this attribute is a real number optionally followed by a unit of measure from the set of pc, pt, px, in, cm, mm, em (picas, points, pixels, inches, centimeters, millimeters, and ems respectively). The default unit is px (pixels). Possible values include: "5", "5in", and "10.5cm". If a height value is specified and no width value is specified, the width will be scaled by the same factor as the height. If both a height value and width value are specified, some implementations may not be able to scale the two directions by a different factor and may therefore ignore one of the two values. | NMTOKEN | #IMPLIED | No
width | Indicates the horizontal dimension for the resulting image display. If necessary, the image is scaled to the specified size. The value of this attribute is a real number optionally followed by a unit of measure from the set of pc, pt, px, in, cm, mm, em (picas, points, pixels, inches, centimeters, millimeters, and ems respectively). The default unit is px (pixels). Possible values include: "5", "5in", and "10.5cm". If a width value is specified and no height value is specified, the height will be scaled by the same factor as the width. If both a height value and width value are specified, some implementations may not be able to scale the two directions by a different factor and may therefore ignore one of the two values. | NMTOKEN | #IMPLIED | No
align | Controls the horizontal alignment of an image when placement is specified as "break." Common values include left, right, and center. | CDATA | #IMPLIED | No
scale | Specifies a percentage by which to scale the image in the absence of any specified image height or width; a value of 100 implies that the image should be presented at its intrinsic size. If a value has been specified for this image's height or width attribute (or both), the scale attribute is ignored. It is an error if the value of this attribute is not an unsigned integer. In this case, the implementation may (but need not) give an error message and may (but need not) recover by ignoring this attribute. | NMTOKEN | #IMPLIED | No
scalefit | Allow an image to be scaled to fit within available space. If, for a given image, any one of height, width, or scale is specified, those attributes determine the graphic size, and any setting of scalefit is ignored. If none of those attributes are specified and scalefit="yes", then the image is scaled (the same factor in both dimensions) so that the graphic will just fit within the available height or width (whichever is more constraining). The available width would be the prevailing column (or table cell) width--that is, the width a paragraph of text would have if the graphic were a paragraph instead. The available height is implementation dependent, but if feasible, it is suggested to be the page (or table cell) height or some other reasonable value. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
placement | Indicates whether an image should be displayed inline or separated from the surrounding text. The processing default is inline. Allowable values are: inline or break. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | (inline | break | -dita-use-​conref-​target) | inline | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.1 Hazard statement elements
Previous topic: 3.1.4.1.2 consequence
Next topic: 3.1.4.1.4 howtoavoid


howtoavoid

3.1.4.1.4 howtoavoid

The <howtoavoid> element contains information about how a user can avoid a hazard, for example, "Do not use solvents to clean the drum surface."

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or sl or simpletable) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or sl or simpletable) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or sl or simpletable) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | messagepanel

Inheritance

+ topic/li hazard-d/howtoavoid

Example

<hazardstatement type="notice">
  <messagepanel>
    <typeofhazard>Machinery Damage</typeofhazard>
    <howtoavoid>
         <sl>
           <sli>Do NOT use solvents to clean the drum surface</sli>
           <sli>Read manual for proper drum cleaning procedure</sli>
         </sl>
    </howtoavoid>
  </messagepanel>
  <hazardsymbol href="readmanual.png"></hazardsymbol>
  <hazardsymbol href="agressivesolvent.png"></hazardsymbol>
</hazardstatement>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.1 Hazard statement elements
Previous topic: 3.1.4.1.3 hazardsymbol
Next topic: 3.1.4.1.5 messagepanel


messagepanel

3.1.4.1.5 messagepanel

The <messagepanel> element contains the textual information that is displayed on the hazard statement. This information identifies the hazard, specifies how to avoid the hazard, and states the probable consequences of failing to avoid the hazard.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | ( (typeofhazard) then (consequence) (any number) then (howtoavoid) (one or more) )

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | hazardstatement

Inheritance

+ topic/ul hazard-d/messagepanel

Example

<hazardstatement type="caution">
  <messagepanel>
    <typeofhazard>Lifting Hazard.</typeofhazard>
    <consequence>May result in injury.</consequence>
    <howtoavoid>See safety manual for lifting instructions.</howtoavoid>
  </messagepanel>
  <hazardsymbol href="heavy.png"></hazardsymbol>
</hazardstatement>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.4.1 Hazard statement elements
Previous topic: 3.1.4.1.4 howtoavoid
Next topic: 3.1.4.1.6 typeofhazard


typeofhazard

3.1.4.1.6 typeofhazard

The <typeofhazard> element contains a description of the type of hazard, for example, "Hot surfaces inside."

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or data or data-about or foreign or unknown or keyword or term or ph or b or i or sup or sub or tt or u or tm) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or tm) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or tm) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningBookmap, learningMap | messagepanel

Inheritance

+ topic/li hazard-d/typeofhazard

Example

<hazardstatement type="caution">
  <messagepanel>
    <typeofhazard>Lifting Hazard.</typeofhazard>
    <consequence>May result in injury.</consequence>
    <howtoavoid>See safety manual for lifting instructions.</howtoavoid>
  </messagepanel>
  <hazardsymbol href="heavy.png"></hazardsymbol>
</hazardstatement>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.1 Hazard statement elements
Previous topic: 3.1.4.1.5 messagepanel
Next topic: 3.1.4.2 Typographic elements


Typographic elements

3.1.4.2 Typographic elements

The typographic elements are used to highlight text with styles (such as bold, italic, and monospace). Never use these elements when a semantically specific element is available. These elements are not intended for use by specializers, and are intended solely for use by authors when no semantically appropriate element is available and a formatting effect is required.

  • 3.1.4.2.1 b
    The bold (<b>) element is used to apply bold highlighting to the content of the element. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available. For example, for specific items such as GUI controls, use the <uicontrol> element.
  • 3.1.4.2.2 i
    The italic (<i>) element is used to apply italic highlighting to the content of the element. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available. For example, for specific items such as variable names, use the <varname> element.
  • 3.1.4.2.3 sup
    The superscript (<sup>) element indicates that text should be superscripted, or vertically raised in relationship to the surrounding text. Superscripts are usually a smaller font than the surrounding text. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available.
  • 3.1.4.2.4 sub
    A subscript (<sub>) indicates that text should be subscripted, or placed lower in relationship to the surrounding text. Subscripted text is often a smaller font than the surrounding text. Formatting may vary depending on your output process. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available.
  • 3.1.4.2.5 tt
    The teletype (<tt>) element is used to apply monospaced highlighting to the content of the element. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available. For example, for specific items such as inline code fragments, use the <codeph> element.
  • 3.1.4.2.6 u
    The underline (<u>) element is used to apply underline highlighting to the content of the element. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available. For example, for specific items such as GUI controls, use the <uicontrol> element.
Parent topic: 3.1.4 Domain elements
Previous topic: 3.1.4.1.6 typeofhazard
Next topic: 3.1.4.2.1 b


b

3.1.4.2.1 b

The bold (<b>) element is used to apply bold highlighting to the content of the element. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available. For example, for specific items such as GUI controls, use the <uicontrol> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

+ topic/ph hi-d/b

Example

<p><b>STOP!</b> This is <b>very</b> important!</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.2 Typographic elements
Previous topic: 3.1.4.2 Typographic elements
Next topic: 3.1.4.2.2 i


i

3.1.4.2.2 i

The italic (<i>) element is used to apply italic highlighting to the content of the element. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available. For example, for specific items such as variable names, use the <varname> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

+ topic/ph hi-d/i

Example

<p>Unplug the unit <i>before</i> placing the metal screwdriver
against the terminal screw.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.2 Typographic elements
Previous topic: 3.1.4.2.1 b
Next topic: 3.1.4.2.3 sup


sup

3.1.4.2.3 sup

The superscript (<sup>) element indicates that text should be superscripted, or vertically raised in relationship to the surrounding text. Superscripts are usually a smaller font than the surrounding text. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

+ topic/ph hi-d/sup

Example

The power produced by the electrohydraulic dam was 10<sup>10</sup> more than
the older electric plant.  The difference was H<sub>2</sub>O.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.2 Typographic elements
Previous topic: 3.1.4.2.2 i
Next topic: 3.1.4.2.4 sub


sub

3.1.4.2.4 sub

A subscript (<sub>) indicates that text should be subscripted, or placed lower in relationship to the surrounding text. Subscripted text is often a smaller font than the surrounding text. Formatting may vary depending on your output process. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

+ topic/ph hi-d/sub

Example

The power produced by the electrohydraulic dam was 10<sup>10</sup> more than
the older electric plant.  The difference was H<sub>2</sub>O.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.2 Typographic elements
Previous topic: 3.1.4.2.3 sup
Next topic: 3.1.4.2.5 tt


tt

3.1.4.2.5 tt

The teletype (<tt>) element is used to apply monospaced highlighting to the content of the element. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available. For example, for specific items such as inline code fragments, use the <codeph> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

+ topic/ph hi-d/tt

Example

<p>Make sure that the screen displays <tt>File successfully created</tt> before
proceeding to the next stage of the task.</p>
(Tag purists may delight to point out that this example could be more correctly marked with the systemoutput element.)

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.2 Typographic elements
Previous topic: 3.1.4.2.4 sub
Next topic: 3.1.4.2.6 u


u

3.1.4.2.6 u

The underline (<u>) element is used to apply underline highlighting to the content of the element. This element is part of the DITA highlighting domain. Use this element only when a more semantically appropriate element is not available. For example, for specific items such as GUI controls, use the <uicontrol> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

+ topic/ph hi-d/u

Example

Beware: <u>overuse</u> <i>of</i> <b>highlighting</b> is
sometimes known as font-itis!

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.2 Typographic elements
Previous topic: 3.1.4.2.5 tt
Next topic: 3.1.4.3 Utilities elements


Utilities elements

3.1.4.3 Utilities elements

The utilities domain elements represent common features of a language that may not necessarily be semantic, such as image maps.

  • 3.1.4.3.1 area
    The <area> element describes a linkable area within an imagemap. It allows the author to specify a shape within the image, the coordinates of that shape, and a link target for the area.
  • 3.1.4.3.2 coords
    The coords element specifies the coordinates of a linkable region in an imagemap.
  • 3.1.4.3.3 imagemap
    The imagemap element supports the basic functionality of the HTML "client-side" image map markup. Imagemap allows you to designate a linkable area or region over an image, allowing a link in that region to display another topic.
  • 3.1.4.3.4 shape
    The <shape> element defines the shape of a linkable area in an imagemap.
Parent topic: 3.1.4 Domain elements
Previous topic: 3.1.4.2.6 u
Next topic: 3.1.4.3.1 area


area

3.1.4.3.1 area

The <area> element describes a linkable area within an imagemap. It allows the author to specify a shape within the image, the coordinates of that shape, and a link target for the area.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (shape) then (coords) then (xref) )

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | imagemap

Inheritance

+ topic/figgroup ut-d/area

Example

<area>
 <shape>rect</shape>
 <coords>54,1,117,60</coords>
 <xref href="d1-s2.dita"></xref>
</area>

A more complete example is located in the description for imagemap.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.3 Utilities elements
Previous topic: 3.1.4.3 Utilities elements
Next topic: 3.1.4.3.2 coords


coords

3.1.4.3.2 coords

The coords element specifies the coordinates of a linkable region in an imagemap.

This element contains text data representing coordinate data for image maps. Pixels are the recommended units for describing coordinates. The syntax of the coordinate data depends on the shape described by the coordinates, and is based on the image map definition in HTML. It uses the following data for the appropriate shapes:
Shape
Data format
rect
left-x, top-y, right-x, bottom-y
circle
center-x, center-y, radius
poly
x1, y1, x2, y2, ..., xN, yN. The first x and y coordinate pair and the last should be the same to close the polygon.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | area

Inheritance

+ topic/ph ut-d/coords

Example

<area>
 <shape>rect</shape>
 <coords>54,1,117,60</coords>
 <xref href="d1-s2.dita"></xref>
</area>

Attributes

Name | Description | Data Type | Default Value | Required?
translate | Indicates whether the content of the element should be translated or not. Setting to "yes" will override the default. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value; because this element uses an actual default, it will always be treated as translate="no" unless overridden as described. | yes | no | -dita-use-​conref-​target | "no" | No
xml:lang | Specifies the language of the element content. The xml:lang attribute and its values are described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. | language token or the null string | #IMPLIED | No
dir | Specifies the directionality of text: left-to-right (ltr, the processing default) or right-to-left (rtl). The value lro indicates an override of normal bidi text presentation, forcing the element into left-to-right mode; rlo overrides normal rules to force right-to-left presentation. See The dir attribute for more information on the dir attribute. | (ltr | rtl | lro | rlo | -dita-use-​conref-​target) | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.3 Utilities elements
Previous topic: 3.1.4.3.1 area
Next topic: 3.1.4.3.3 imagemap


imagemap

3.1.4.3.3 imagemap

The imagemap element supports the basic functionality of the HTML "client-side" image map markup. Imagemap allows you to designate a linkable area or region over an image, allowing a link in that region to display another topic.

An HTML client-side image map binds an image to the navigation structure (the "map") by means of an ID association from the map to the image. In contrast, the DITA version of imagemap markup simply includes the target image as the first required element in the markup, followed by a sequence of area elements that represent the links associated with the contained image.

An imagemap structure can be output either to a standard HTML image map or to alternative forms of navigation (such as table-based image maps). When output as PDF, the minimal form would be to represent at least the image; advanced PDF output processors should be able to provide equivalent region-oriented hyperlinks.

The xref content contains the intended alternative text or hover text for the map area.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (image) then (area) (one or more) )

Contained by

Doctype | Content model
topic (base) | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example
map (base), classifyMap, subjectScheme, learningBookmap, learningMap | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry
topic (technical content) | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, pd
map (technical content), bookmap | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, pd
concept | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, pd
ditabase | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, pd
task (strict), task (general) | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInstructornote, lcAsset
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote, lcAsset
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote, lcAsset

Inheritance

+ topic/fig ut-d/imagemap

Example

A simple imagemap looks like this (note that the rendering will depend on how this markup is supported for particular output formats):
<imagemap>
 <image href="imagemapworld.jpg">
   <alt>Map of the world showing 5 areas</alt>
 </image>
 <area><shape>rect</shape><coords>2,0,53,59</coords>
  <xref href="d1-s1.dita">Section 1</xref>
 </area>
 <area><shape>rect</shape><coords>54,1,117,60</coords>
  <xref href="d1-s2.dita"></xref>
 </area>
 <area><shape>rect</shape><coords>54,62,114,116</coords>
  <xref href="#inline" type="topic"></xref>
 </area>
 <area><shape>circle</shape><coords>120,154,29</coords>
  <xref format="html" href="test.html"></xref>
 </area>
 <area><shape>poly</shape>
  <coords>246,39,200,35,173,52,177,86,215,90,245,84,254,65</coords>
  <xref format="pdf" href="test.pdf"></xref>
 </area>
</imagemap>

The areas defined correspond to this graphic image with the areas visible:
Map of the world showing 5 areas

The values for use in the shape and coords elements must follow the guidelines defined for image maps in HTML 4.1, Client-side image maps: the MAP and AREA elements

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.3 Utilities elements
Previous topic: 3.1.4.3.2 coords
Next topic: 3.1.4.3.4 shape


shape

3.1.4.3.4 shape

The <shape> element defines the shape of a linkable area in an imagemap.

The <shape> element supports these values:
rect
Define a rectangular region. If you leave the shape element blank, a rectangular shape is assumed.
circle
Define a circular region.
poly
Define a polygonal region.
default
Indicates the entire diagram.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | area

Inheritance

+ topic/keyword ut-d/shape

Example

<area>
 <shape>rect</shape>
 <coords>54,1,117,60</coords>
 <xref href="d1-s2.dita"></xref>
</area>

Attributes

Name | Description | Data Type | Default Value | Required?
translate | Indicates whether the content of the element should be translated or not. Setting to "yes" will override the default. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value; because this element uses an actual default, it will always be treated as translate="no" unless overridden as described. | yes | no | -dita-use-​conref-​target | "no" | No
xml:lang | Specifies the language of the element content. The xml:lang attribute and its values are described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. | language token or the null string | #IMPLIED | No
dir | Specifies the directionality of text: left-to-right (ltr, the processing default) or right-to-left (rtl). The value lro indicates an override of normal bidi text presentation, forcing the element into left-to-right mode; rlo overrides normal rules to force right-to-left presentation. See The dir attribute for more information on the dir attribute. | (ltr | rtl | lro | rlo | -dita-use-​conref-​target) | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.1.4.3 Utilities elements
Previous topic: 3.1.4.3.3 imagemap
Next topic: 3.1.5 Classification elements


Classification elements

3.1.5 Classification elements

Classification elements support managing metadata. Those in the Subject Scheme map are used to define controlled values, and to bind them to DITA attributes as enumerations. Those declared in the classification domain are used in other maps to classify content according to the scheme.

  • 3.1.5.1 Subject scheme maps
    A subject scheme map is used to define sets of controlled values for use in classifying content. Sets of controlled values can be bound to DITA attributes. This allows DITA users to share the controlled values for an information set without having to modify a DTD or XML schema. The list of available values can be modified quickly to adapt to new situations, without the need to manage updates to a document type. In addition, DITA users can define relationships between controlled values and extend a set of controlled values maintained by another team or organization. The list of defined values are not validated by basic XML parsers. Instead, the defined values should be validated by DITA processors.
  • 3.1.5.2 Classification domain elements
    The classification domain elements are used to identify the subject matter of content that is referenced in a map. These subjects must be subjects defined in a subject scheme map. In particular, this allows an author to classify content in new subject categories that are not bound to existing metadata attributes.
Parent topic: 3.1 Base elements
Previous topic: 3.1.4.3.4 shape
Next topic: 3.1.5.1 Subject scheme maps


Subject scheme maps

3.1.5.1 Subject scheme maps

A subject scheme map is used to define sets of controlled values for use in classifying content. Sets of controlled values can be bound to DITA attributes. This allows DITA users to share the controlled values for an information set without having to modify a DTD or XML schema. The list of available values can be modified quickly to adapt to new situations, without the need to manage updates to a document type. In addition, DITA users can define relationships between controlled values and extend a set of controlled values maintained by another team or organization. The list of defined values are not validated by basic XML parsers. Instead, the defined values should be validated by DITA processors.

The same core elements in a subject scheme map may be used both to define controlled values and to define hierarchical taxonomies:
  • schemeref
  • subjectdef
The following elements are used to bind taxonomies or controlled values to an attribute:
  • enumerationdef
  • elementdef
  • attributedef
  • defaultSubject

The remaining elements in the subject scheme map are used to make more precise statements about how values in a taxonomy relate to one another.

  • 3.1.5.1.1 subjectScheme
    A subjectScheme is a specialized DITA map that defines a collection of controlled values rather than a collection of topics.
  • 3.1.5.1.2 schemeref
    A <schemeref> element provides a reference to another scheme. Typically, the referenced scheme defines a base set of controlled values extended by the current scheme. The values in the referenced scheme are merged with the current scheme; the result is equivalent to specifying all of the values in a single map.
  • 3.1.5.1.3 hasInstance
    The <hasInstance> element specifies that the contained subjects have an INSTANCE-OF relationship with the container subject. In an INSTANCE-OF hierarchy, the child subject is a specific entity or object and the parent subject is a type, kind, or class of entity or object.
  • 3.1.5.1.4 hasKind
    The <hasKind> element specifies that the contained hierarchy expresses KIND-OF relationships between subjects.
  • 3.1.5.1.5 hasNarrower
    For subjects within the <hasNarrower> element, the container subject is more general than each of the contained subjects. That is, this element makes the default hierarchical relationship explicit, although the way in which a relationship is narrower is not specified.
  • 3.1.5.1.6 hasPart
    The <hasPart> element specifies that the contained hierarchy expresses PART-OF relationships between subjects.
  • 3.1.5.1.7 hasRelated
    The <hasRelated> element identifies an associative relationship between the container subject and each of the contained subjects.
  • 3.1.5.1.8 enumerationdef
    The <enumerationdef> element identifies one attribute and one or more categories that contain the controlled values for the enumeration. The type attribute has a default value of keys.
  • 3.1.5.1.9 elementdef
    The <elementdef> element identifies an element on which an attribute is enumerated. When the <elementdef> is left out of an <enumerationdef> element, the enumeration is bound to the attribute in all elements.
  • 3.1.5.1.10 attributedef
    The <attributedef> element specifies the attribute to which a set of controlled values from a subject scheme map are to be applied.
  • 3.1.5.1.11 defaultSubject
    The <defaultSubject> element is used within an attribute enumeration to set the default value for that attribute in cases where no value is specified on the attribute. The default subject must be one of the controlled values within the categories specified for the attribute.
  • 3.1.5.1.12 subjectHead
    The <subjectHead> element provides a heading for a group of subjects, for use if the scheme is displayed. For instance, a scheme may be displayed to let a user select subjects as part of faceted browsing. The subjectHead element itself does not reference a file and cannot be referenced as a key, so it does not define any controlled values.
  • 3.1.5.1.13 subjectHeadMeta
    The <subjectHeadMeta> element allows a navigation title and short description to be associated with a subject heading.
  • 3.1.5.1.14 subjectdef
    The <subjectdef> element defines a subject (also known as a controlled value) within a scheme. To make the subject easy to identify, a <subjectdef> may use a keys attribute to assign a key to the subject. A subject with a key can be identified elsewhere with a keyref. The <subjectdef> may use a navtitle element or attribute to supply a label for the subject. The <subjectdef> may also refer to a topic that captures the consensus definition for the subject.
  • 3.1.5.1.15 relatedSubjects
    The <relatedSubjects> element establishes associative relationships between each child subject and every other child subject (unless the association is restricted by the linking attribute of the subjects).
  • 3.1.5.1.16 subjectRelTable
    The <subjectRelTable> element is a specialized relationship table which establishes relationships between the subjects in different columns of the same row. This element provides an efficient way to author non-hierarchical relationships between subjects. Tools (such as search tools) that use subject relationships to find related content may use these associative relationships in a similar way to the hierarchical relationships.
  • 3.1.5.1.17 subjectRelHeader
    The <subjectRelHeader> element specifies the roles played by subjects in associations.
  • 3.1.5.1.18 subjectRel
    The <subjectRel> element contains a set of subjects that are related in some manner. Each group of subjects is contained in a <subjectRole> element; the associations between different columns in the same row are evaluated in the same way as those in a <relrow> (from which <subjectRel> is specialized) but define relationships between the subjects instead of links between topic documents.
  • 3.1.5.1.19 subjectRole
    The <subjectRole> element, when used within a <subjectRel> element, contains a set of subjects that are related to other subjects in the same row of the current <subjectRelTable>. By default, no relationship is defined between multiple subjects in the same <subjectRole> element. When used within the <subjectRelHeader>, the <subjectRole> element defines the category of subject or relationship provided by that column.
Parent topic: 3.1.5 Classification elements
Previous topic: 3.1.5 Classification elements
Next topic: 3.1.5.1.1 subjectScheme


subjectScheme

3.1.5.1.1 subjectScheme

A subjectScheme is a specialized DITA map that defines a collection of controlled values rather than a collection of topics.

Default values in the scheme (specified by <defaultSubject>) apply only if the XML DTD / schema or instance doesn't specify a value in some other way. The precedence of the different methods of setting a value is:
  1. An explicit value in the element instance
  2. A default value in the DTD or XML Schema
  3. Cascaded values within the document
  4. Cascades from a higher level document to this document
  5. A default controlled value for a scheme
  6. Values in processing rules

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (title) (optional) then (topicmeta) (optional) then ( (anchor or data or data-about or enumerationdef or hasInstance or hasKind or hasNarrower or hasPart or hasRelated or navref or relatedSubjects or reltable or schemeref or subjectdef or subjectHead or subjectRelTable or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) ) )

Contained by

This element is not contained by any other elements.

Inheritance

- map/map subjectScheme/subjectScheme

Example

<subjectScheme>
  <!-- Pull in a scheme that defines unix OS values -->
  <schemeref href="unixOS.ditamap"/>
  <!-- Define new OS values that are merged with those in the unixOS scheme -->
  <subjectdef keys="os">
    <subjectdef keys="linux"/>
    <subjectdef keys="mswin"/>
    <subjectdef keys="zos"/>
  </subjectdef>
  <!-- Define application values -->
  <subjectdef keys="app" navtitle="Applications">
    <subjectdef keys="apacheserv" href="subject/apache.dita"/>
    <subjectdef keys="mysql"      href="subject/sql.dita"/>
  </subjectdef>

  <!-- Define an enumeration of the platform attribute, equal to
       each value in the OS subject. This makes the following values
       valid for the platform attribute: linux, mswin, zos -->
  <enumerationdef>
    <attributedef name="platform"/>
    <subjectdef keyref="os"/>
  </enumerationdef>
  <!-- Define an enumeration of the otherprops attribute, equal to
       each value in the application subjects.
       This makes the following values valid for the otherprops attribute:
       apacheserv, mysql -->
  <enumerationdef>
    <attributedef name="otherprops"/>
    <subjectdef keyref="app"/>
  </enumerationdef>
</subjectScheme>

Example: how hierarchies affect filtering

In the following sample, there are subcategories within the general "os" category.

<subjectScheme>
  <subjectdef keys="os" navtitle="Operating system">
    <subjectdef keys="linux" navtitle="Linux">
      <subjectdef keys="redhat" navtitle="RedHat Linux"/>
      <subjectdef keys="suse"   navtitle="SuSE Linux"/>
    </subjectdef>
    <subjectdef keys="mswin" navtitle="Windows"/>
    <subjectdef keys="zos"   navtitle="z/OS"/>
  </subjectdef>
  <enumerationdef>
    <attributedef name="platform"/>
    <subjectdef keyref="os"/>
  </enumerationdef>
</subjectScheme>
The following values are valid on the platform attribute: linux, redhat, suse, mswin, zos. If any other values are encountered, processors validating against the scheme should give a warning. As a result, the values could be used in this way:
<p platform="linux">You must set up a cron job to ...</p>
<p platform="redhat">To set up the cron job, ...</p>
Processors should be aware of hierarchies of attributes defined in subject scheme maps, and process them differently than they might if the attributes were not defined in a hierarchy. Using the values "linux" and "redhat" from the scheme above, where the subject "linux" is a container for the subject "redhat", filtering and flagging operate as follows:
Table 1. How to evaluate subjects in a hierarchy
Behavior of "linux" | Behavior of "redhat" | How to evaluate platform="redhat" | How to evaluate platform="linux"
set to "exclude" | set to "exclude" | Excluded | Excluded
 | set to "include" or "flag" | Excluded. This is an error condition, because if all linux content is excluded, redhat is also excluded. Applications may recover by generating an error message. | Excluded
 | unspecified | Excluded, because "redhat" is a special kind of "linux", and linux is excluded. | Excluded
set to "include" | set to "exclude" | Excluded, because all redhat content is excluded | Included
 | set to "include" | Included | Included
 | set to "flag" | Included and flagged with the "redhat" flag | Included
 | unspecified | Included, because all Linux content is included | Included
set to "flag" | set to "exclude" | Excluded, because all redhat content is excluded | Included and flagged with the "linux" flag
 | set to "include" | Included and flagged with the "linux" flag, because linux is flagged and redhat is a type of linux | Included and flagged with the "linux" flag
 | set to "flag" | Included and flagged with the "redhat" flag, because a flag is available that is specifically for redhat | Included and flagged with the "linux" flag
 | unspecified | Included and flagged with the "linux" flag, because linux is flagged and redhat is a type of linux | Included and flagged with the "linux" flag
unspecified | set to "exclude" | Excluded, because all redhat content is excluded | If the default for platform values is "include", this is included. If the default for platform values is "exclude", this is excluded.
 | set to "include" | Included | Included, because all "redhat" content is included, and general Linux content also applies to RedHat
 | set to "flag" | Included and flagged with the "redhat" flag | Included, because all "redhat" content is included, and general Linux content also applies to RedHat
 | unspecified | If the default for platform values is "include", this is included. If the default for platform values is "exclude", this is excluded. | If the default for platform values is "include", this is included. If the default for platform values is "exclude", this is excluded.

Attributes

Name | Description | Data Type | Default Value | Required?
id | Allows an ID to be specified for the map. Note that maps do not require IDs (unlike topics), and the map ID is not included in references to elements within a map. | ID | #IMPLIED | No
conref | This attribute is used to reference an ID on a map that can be reused. See The conref attribute for examples and details about the syntax. | CDATA | #IMPLIED | No
conrefend | The conrefend attribute is used when reusing a range of elements through conref. The syntax is the same as for the conref attribute; see The conrefend attribute for examples. | CDATA | #IMPLIED | No
conaction | This attribute enables users to push content into a new location. See The conaction attribute for examples and details about the syntax. | (mark | pushafter | pushbefore | pushreplace | -dita-use-​conref-​target) | #IMPLIED | No
conkeyref | Allows conref to operate using a key instead of a URI. See The conkeyref attribute for more details about the syntax and behaviors. | CDATA | #IMPLIED | No
anchorref | Identifies a location within another map file where this map will be anchored at runtime. Resolution of the map is deferred until the final step in the delivery of any rendered content. For example, anchorref="map1.ditamap/a1" causes this map to be pulled into the location of the anchor point "a1" inside map1.ditamap when map1.ditamap is rendered for delivery. | CDATA | #IMPLIED | No
xmlns:ditaarch | Declares the default DITA namespace. | "http://dita.​oasis-open.​org/​architecture/​2005/"
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
processing-role Describes the processing role of the referenced topic. The default for this attribute on this element is "resource-only". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) resource-only No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
linking Defines some specific linking characteristics of a topic's current location in the map. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (toc); on this element the default is no. This value defaults to no for elements such as reltable, which typically cannot appear in the toc, and for elements such as glossref that generally are not desired in the toc. | (yes | no | -dita-use-​conref-​target) | "no" | No
print Specifies whether the topic should be included in a print-specific rendition, such as PDF. The processing default is "yes". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
Include the topic in the print-oriented file.
no
Do not include the topic in a print-oriented file.
printonly
Only include the topic when rendering the DITA content in a print-oriented context; the topic should not be included in other contexts, such as when rendering as HTML.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | printonly | -dita-use-​conref-​target) #IMPLIED No
search Describes whether the target is available for searching. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
no
-dita-use-​conref-​target
(yes | no | -dita-use-​conref-​target) #IMPLIED No
chunk When a set of topics is transformed using a map, the chunk attribute allows multi-topic documents to be broken into smaller files and multiple individual topics to be combined into larger combined documents.

For a detailed description of the chunk attribute and its usage, see Chunking in the DITA Architectural Specification.

CDATA #IMPLIED No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group.
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1 Subject scheme maps
Next topic: 3.1.5.1.2 schemeref


schemeref

3.1.5.1.2 schemeref

A <schemeref> element provides a reference to another scheme. Typically, the referenced scheme defines a base set of controlled values extended by the current scheme. The values in the referenced scheme are merged with the current scheme; the result is equivalent to specifying all of the values in a single map.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (topicmeta) (optional) then (data or data-about) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme

Inheritance

- map/topicref subjectScheme/schemeref

Example: Extending a category with more specific values

Figure 1. The map baseOS.ditamap
<subjectScheme>
  <subjectdef keys="os" navtitle="Operating system">
    <subjectdef keys="linux" navtitle="Linux">
      <subjectdef keys="redhat" navtitle="RedHat Linux"/>
      <subjectdef keys="suse"   navtitle="SuSE Linux"/>
    </subjectdef>
    <subjectdef keys="mswin" navtitle="Windows"/>
    <subjectdef keys="zos"   navtitle="z/OS"/>
  </subjectdef>
  <enumerationdef>
    <attributedef name="platform"/>
    <subjectdef keyref="os"/>
  </enumerationdef>
</subjectScheme>
Figure 2. Second map that references baseOS.ditamap

Because a scheme establishes relationships between subjects rather than a contextual navigation structure, new relationships can be added to existing subjects. In particular, the referencing scheme can extend an enumeration by adding new relationships to existing subjects that belong to the enumeration. For instance, a scheme could extend the baseOS.ditamap scheme shown above by adding Macintosh OS as a child of the existing os subject and adding special versions of Windows under the existing mswin subject:

<subjectScheme>
  <schemeref href="baseOS.ditamap"/>
  <subjectdef keyref="os">
    <subjectdef keys="macos" navtitle="Macintosh"/>
    <subjectdef keyref="mswin">
      <subjectdef keys="winxp"  navtitle="Windows XP"/>
      <subjectdef keys="winvis" navtitle="Windows Vista"/>
    </subjectdef>
  </subjectdef>
</subjectScheme>

The references to the subjects defined by the base scheme use the keyref attribute to avoid duplicate definitions of the keys.

Figure 3. Resulting scheme

The result of merging the extension scheme with the base scheme is exactly the same as the following single scheme.

<subjectScheme>
  <subjectdef keys="os" navtitle="Operating system">
    <subjectdef keys="linux" navtitle="Linux">
      <subjectdef keys="redhat" navtitle="RedHat Linux"/>
      <subjectdef keys="suse"   navtitle="SuSE Linux"/>
    </subjectdef>
    <subjectdef keys="macos" navtitle="Macintosh"/>
    <subjectdef keys="mswin" navtitle="Windows">
      <subjectdef keys="winxp" navtitle="Windows XP"/>
      <subjectdef keys="win98" navtitle="Windows Vista"/>
    </subjectdef>
    <subjectdef keys="zos"   navtitle="z/OS"/>
  </subjectdef>
  <enumerationdef>
    <attributedef name="platform"/>
    <subjectdef keyref="os"/>
  </enumerationdef>
</subjectScheme>

Because the extended baseOS scheme bound the os subject to the platform attribute, the extension scheme doesn't provide that binding. The controlled values added by the extension to the hierarchy for the os subject become part of the enumeration bound to the platform attribute.

Example: Extending a category upwards

A category can also be extended upward. For instance, an extension scheme could create a Software category that includes operating systems as well as applications.

<subjectScheme>
  <schemeref href="baseOS.ditamap"/>
  <subjectdef keys="sw" navtitle="Software">
    <subjectdef keyref="os"/>
    <subjectdef keys="app" navtitle="Applications">
      <subjectdef keys="apacheserv" navtitle="Apache Web Server"/>
      <subjectdef keys="mysql"      navtitle="MySQL Database"/>
    </subjectdef>
  </subjectdef>
</subjectScheme>

If the extended baseOS scheme defines the binding of the os subject with the platform attribute, the app subjects provided by the extension scheme aren't subordinate to the os subject and thus don't become part of that enumeration. To leave open the possibility of upward extension of an enumeration, the content provider should define the controlled values in one scheme and define the binding to the attribute separately in a extension scheme. That way, the content provider can substitute a binding to a different extension without rework.

An adopter would identify the extension scheme as the scheme governing controlled values in the DITA environment. Any base schemes referenced by the extension scheme are, from a logical view, part of the extension scheme.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
type | Describes the target of a reference. For the schemeref element, this value defaults to "scheme", because the element is expected to point to another subject scheme. | CDATA | scheme | No
format | The format attribute identifies the format of the resource being referenced. For elements like this one that are designed to reference another map, the value defaults to "ditamap". See The format attribute for details on other supported values. | CDATA | ditamap | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.1 subjectScheme
Next topic: 3.1.5.1.3 hasInstance


hasInstance

3.1.5.1.3 hasInstance

The <hasInstance> element specifies that the contained subjects have an INSTANCE-OF relationship with the container subject. In an INSTANCE-OF hierarchy, the child subject is a specific entity or object and the parent subject is a type, kind, or class of entity or object.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (topicmeta) (optional) then (data or data-about or subjectdef or subjectHead or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme, subjectdef

Inheritance

- map/topicref subjectScheme/hasInstance

Example

This example specifies that New York City, Reykjavik, and Moscow are each specific instances of a city.

<subjectScheme>
  <hasInstance>
    <subjectdef keys="city" navtitle="City">
      <subjectdef keys="nyc"       navtitle="New York City"/>
      <subjectdef keys="reykjavik" navtitle="Reykjavik"/>
      <subjectdef keys="moscow"    navtitle="Moscow"/>
    </subjectdef>
  </hasInstance>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.2 schemeref
Next topic: 3.1.5.1.4 hasKind


hasKind

3.1.5.1.4 hasKind

The <hasKind> element specifies that the contained hierarchy expresses KIND-OF relationships between subjects.

In a KIND-OF hierarchy, the child subject is a particular variety of the parent subject. A KIND-OF hierarchy is sometimes known as an IS-A, generic, or subsumption hierarchy.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (topicmeta) (optional) then (data or data-about or subjectdef or subjectHead or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme, subjectdef

Inheritance

- map/topicref subjectScheme/hasKind

Example

This examples specifies that cars, trucks, and motorcycles are kinds of vehicles. In addition, compact, sedan, and station wagon are each a kind of car, while pickup and van are each a type of truck.

<subjectScheme>
  <hasKind>
    <subjectdef keys="vehicle" navtitle="Vehicle">
      <subjectdef keys="car" navtitle="Passenger car">
          <subjectdef keys="compact" navtitle="Compact car"/>
          <subjectdef keys="sedan" navtitle="Sedan"/>
          <subjectdef keys="stationWagon" navtitle="Station wagon"/>
      </subjectdef>
      <subjectdef keys="truck" navtitle="Truck">
          <subjectdef keys="pickup" navtitle="Pickup truck"/>
          <subjectdef keys="van" navtitle="Van"/>
      </subjectdef>
      <subjectdef keys="motorcycle" navtitle="Motorcycle"/>
    </subjectdef>
  </hasInstance>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.3 hasInstance
Next topic: 3.1.5.1.5 hasNarrower


hasNarrower

3.1.5.1.5 hasNarrower

For subjects within the <hasNarrower> element, the container subject is more general than each of the contained subjects. That is, this element makes the default hierarchical relationship explicit, although the way in which a relationship is narrower is not specified.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (topicmeta) (optional) then (data or data-about or subjectdef or subjectHead or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme, subjectdef

Inheritance

- map/topicref subjectScheme/hasNarrower

Example

This example specifies that Planting Roses is a narrower subject category than Horticulture, although it is part of the Horticulture subject area.

<subjectScheme>
  <hasNarrower>
    <subjectdef keys="horticulture" navtitle="Horticulture">
      <subjectdef keys="plantrose"  navtitle="Planting Roses"/>
    </subjectdef>
  </hasNarrower>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.4 hasKind
Next topic: 3.1.5.1.6 hasPart


hasPart

3.1.5.1.6 hasPart

The <hasPart> element specifies that the contained hierarchy expresses PART-OF relationships between subjects.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (topicmeta) (optional) then (data or data-about or subjectdef or subjectHead or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme, subjectdef

Inheritance

- map/topicref subjectScheme/hasPart

Example

This example specifies that a tire and a horn are each a part of a car.

<subjectScheme>
  <hasPart>
    <subjectdef keys="car" navtitle="Car">
      <subjectdef keys="tire" navtitle="Tire"/>
      <subjectdef keys="horn" navtitle="Horn"/>
    </subjectdef>
  </hasPart>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.5 hasNarrower
Next topic: 3.1.5.1.7 hasRelated


hasRelated

3.1.5.1.7 hasRelated

The <hasRelated> element identifies an associative relationship between the container subject and each of the contained subjects.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (topicmeta) (optional) then (data or data-about or subjectdef or subjectHead or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme, subjectdef

Inheritance

- map/topicref subjectScheme/hasRelated

Example

This example specifies that myProgram runs on Linux and Windows.

<subjectScheme>
  <subjectdef keys="myProgram" navtitle="My Program">
    <hasRelated keys="runsOn" navtitle="runs on">
      <subjectdef keys="linux" navtitle="Linux"/>
      <subjectdef keys="mswin" navtitle="Microsoft Windows"/>
    </hasRelated>
  </subjectdef>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.6 hasPart
Next topic: 3.1.5.1.8 enumerationdef


enumerationdef

3.1.5.1.8 enumerationdef

The <enumerationdef> element identifies one attribute and one or more categories that contain the controlled values for the enumeration. The type attribute has a default value of keys.

When the <enumerationdef> element contains an <elementdef> element, the defined enumeration applies to that attribute only on the element specified by <elementdef>. The enumeration does not apply to the same attribute on other elements. For example, when the element contains both <elementdef name="lomDifficulty"/> and <attributedef name="value"/>, this means that the only the value attribute on the <lomDifficulty> element is limited to the specified enumeration. The value attribute on other elements is not affected.

When the <enumerationdef> element does not contain an <elementdef> element, the attribute specified is limited to the enumeration on all elements. For example, when <enumerationdef> contains <attributedef name="value"/> but does not contain <elementdef>, the value attribute is limited to the specified enumeration for all elements.

Note: An enumeration can specify an empty category without children. In this case, no value is valid for the attribute.
Note: Whether an attribute takes a single value or multiple values from the enumeration is part of the structural definition of the element controlled by the DTD or XML Schema. That is, an attribute which is defined as CDATA may take multiple values, while an attribute defined as NMTOKEN may take only one.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (elementdef) (optional) then (attributedef) then (subjectdef) (one or more) then (defaultSubject) (optional) then (data or data-about) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme

Inheritance

- map/topicref subjectScheme/enumerationdef

Example

In this example, enumerations are specified for the platform and otherprops attributes. Note that the enumeration identifies a category of values; the values within the category are valid, while the category itself is not a valid value. For example, in the code sample here, the platform attribute is associated with the enumeration for the category "os"; all values within the "os" category are thus valid on the platform attribute, while the value "os" itself is not.

<subjectScheme>
  <!-- Pull in a scheme that defines unix OS values -->
  <schemeref href="unixOS.ditamap"/>
  <!-- Define new OS values that are merged with those in the unixOS scheme -->
  <subjectdef keys="os">
    <subjectdef keys="linux"/>
    <subjectdef keys="mswin"/>
    <subjectdef keys="zos"/>
  </subjectdef>
  <!-- Define application values -->
  <subjectdef keys="app" navtitle="Applications">
    <subjectdef keys="apacheserv" href="subject/apache.dita"/>
    <subjectdef keys="mysql"      href="subject/sql.dita"/>
  </subjectdef>

  <!-- Define an enumeration of the platform attribute, equal to
       each value in the OS subject. This makes the following values
       valid for the platform attribute: linux, mswin, zos -->
  <enumerationdef>
    <attributedef name="platform"/>
    <subjectdef keyref="os"/>
  </enumerationdef>
  <!-- Define an enumeration of the otherprops attribute, equal to
       each value in the application subjects.
       This makes the following values valid for the otherprops attribute:
       apacheserv, mysql -->
  <enumerationdef>
    <attributedef name="otherprops"/>
    <subjectdef keyref="app"/>
  </enumerationdef>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.7 hasRelated
Next topic: 3.1.5.1.9 elementdef


elementdef

3.1.5.1.9 elementdef

The <elementdef> element identifies an element on which an attribute is enumerated. When the <elementdef> is left out of an <enumerationdef> element, the enumeration is bound to the attribute in all elements.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (data or data-about) (any number) )

Contained by

Doctype | Content model
subjectScheme | enumerationdef

Inheritance

- topic/data subjectScheme/elementdef

Example

In this example, the <lomDifficulty> element has been specialized from the <data> element. The value attribute on the <lomDifficulty> element (but not the value attribute on other elements) is bound to a specific set of values. This means that processors should limit that attribute on that element to the values veryEasy, easy, medium, difficult, or veryDifficult.

<subjectScheme>
  <subjectdef keys="difficulty">
    <subjectdef keys="veryEasy"/>
    <subjectdef keys="easy"/>
    <subjectdef keys="medium"/>
    <subjectdef keys="difficult"/>
    <subjectdef keys="veryDifficult"/>
  </subjectdef>
  ...
  <enumerationdef>
    <elementdef name="lomDifficulty"/>
    <attributedef name="value"/>
    <subjectdef keyref="difficulty"/>
  </enumerationdef>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines the element for which an attribute enumeration is defined. | CDATA | #REQUIRED | Yes
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
translate | Indicates whether the content of the element should be translated or not. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value. | yes | no | -dita-use-​conref-​target | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.8 enumerationdef
Next topic: 3.1.5.1.10 attributedef


attributedef

3.1.5.1.10 attributedef

The <attributedef> element specifies the attribute to which a set of controlled values from a subject scheme map are to be applied.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (data or data-about) (any number) )

Contained by

Doctype | Content model
subjectScheme | enumerationdef

Inheritance

- topic/data subjectScheme/attributedef

Example

In this example, enumerations are specified for the platform and otherprops attributes. Note that the enumeration identifies a category of values; the values within the category are valid, while the category itself is not a valid value. For example, in the code sample here, the platform attribute is associated with the enumeration for the category "os"; all values within the "os" category are thus valid on the platform attribute, while the value "os" itself is not.

<subjectScheme>
  <!-- Pull in a scheme that defines unix OS values -->
  <schemeref href="unixOS.ditamap"/>
  <!-- Define new OS values that are merged with those in the unixOS scheme -->
  <subjectdef keys="os">
    <subjectdef keys="linux"/>
    <subjectdef keys="mswin"/>
    <subjectdef keys="zos"/>
  </subjectdef>
  <!-- Define application values -->
  <subjectdef keys="app" navtitle="Applications">
    <subjectdef keys="apacheserv" href="subject/apache.dita"/>
    <subjectdef keys="mysql"      href="subject/sql.dita"/>
  </subjectdef>

  <!-- Define an enumeration of the platform attribute, equal to
       each value in the OS subject. This makes the following values
       valid for the platform attribute: linux, mswin, zos -->
  <enumerationdef>
    <attributedef name="platform"/>
    <subjectdef keyref="os"/>
  </enumerationdef>
  <!-- Define an enumeration of the otherprops attribute, equal to
       each value in the application subjects.
       This makes the following values valid for the otherprops attribute:
       apacheserv, mysql -->
  <enumerationdef>
    <attributedef name="otherprops"/>
    <subjectdef keyref="app"/>
  </enumerationdef>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines an attribute that will take a set of enumerated values. | CDATA | #REQUIRED | Yes
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
translate | Indicates whether the content of the element should be translated or not. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value. | yes | no | -dita-use-​conref-​target | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.9 elementdef
Next topic: 3.1.5.1.11 defaultSubject


defaultSubject

3.1.5.1.11 defaultSubject

The <defaultSubject> element is used within an attribute enumeration to set the default value for that attribute in cases where no value is specified on the attribute. The default subject must be one of the controlled values within the categories specified for the attribute.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (data or data-about) (any number) )

Contained by

Doctype | Content model
subjectScheme | enumerationdef

Inheritance

- map/topicref subjectScheme/defaultSubject

Example

The following example declares that each of the four defined "os" values is valid within the platform attribute; if no value is specified, the default is "linux".

<subjectScheme>
  <subjectdef keys="os">
    <subjectdef keys="linux"/>
    <subjectdef keys="mswin"/>
    <subjectdef keys="zos"/>
    <subjectdef keys="macos"/>
  </subjectdef>
  <enumerationdef>
    <attributedef name="platform"/>
    <defaultSubject keyref="linux"/>
    <subjectdef keyref="os"/>
  </enumerationdef>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified.

Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy.

CDATA #IMPLIED No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
toc | Specifies whether a topic appears in the table of contents (TOC). If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.10 attributedef
Next topic: 3.1.5.1.12 subjectHead


subjectHead

3.1.5.1.12 subjectHead

The <subjectHead> element provides a heading for a group of subjects, for use if the scheme is displayed. For instance, a scheme may be displayed to let a user select subjects as part of faceted browsing. The subjectHead element itself does not reference a file and cannot be referenced as a key, so it does not define any controlled values.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (subjectHeadMeta) (optional) then (data or data-about or subjectdef or subjectHead or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead

Inheritance

- map/topicref subjectScheme/subjectHead

Example

In this example the “Server setup” label doesn't classify content but, when selected, is equivalent to the union of its child subjects. That is, the heading covers content about planning for any application, installing for any application, any task for web servers, or any task for database servers.

<subjectScheme toc="yes" search="no">
  ...
  <subjectHead>
    <subjectHeadMeta>
      <navtitle>Server setup</navtitle>
    </subjectHeadMeta>
    <subjectdef href="planningTaskType.dita"/>
    <subjectdef href="installingTaskType.dita"/>
    <subjectdef href="webServerApp.dita"/>
    <subjectdef href="databaseApp.dita"/>
  </subjectHead>
  ...
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(unordered | sequence | -dita-use-​conref-​target) #IMPLIED No
linking | Defines some specific linking characteristics of subject topics. "normal" is the only valid value, and is specified as the default in the DTD and Schema. When attribute values cascade, this causes a linking value of "normal" to cascade to the subjects. | (normal) | normal | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (TOC). If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.11 defaultSubject
Next topic: 3.1.5.1.13 subjectHeadMeta


subjectHeadMeta

3.1.5.1.13 subjectHeadMeta

The <subjectHeadMeta> element allows a navigation title and short description to be associated with a subject heading.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (navtitle) (optional) then (shortdesc) (optional) )

Contained by

Doctype | Content model
subjectScheme | subjectHead

Inheritance

- map/topicmeta subjectScheme/subjectHeadMeta

Example

In this example the “Server setup” label doesn't classify content but, when selected, is equivalent to the union of its child subjects. That is, the heading covers content about planning for any application, installing for any application, any task for web servers, or any task for database servers.

<subjectScheme toc="yes" search="no">
  ...
  <subjectHead>
    <subjectHeadMeta>
      <navtitle>Server setup</navtitle>
    </subjectHeadMeta>
    <subjectdef href="planningTaskType.dita"/>
    <subjectdef href="installingTaskType.dita"/>
    <subjectdef href="webServerApp.dita"/>
    <subjectdef href="databaseApp.dita"/>
  </subjectHead>
  ...
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
lockmeta | Indicates whether any of the meta information should be replaced by meta information in the referenced topic. If the value is yes, the information inside <topicmeta> should not be replaced with information from the topic. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.12 subjectHead
Next topic: 3.1.5.1.14 subjectdef


subjectdef

3.1.5.1.14 subjectdef

The <subjectdef> element defines a subject (also known as a controlled value) within a scheme. To make the subject easy to identify, a <subjectdef> may use a keys attribute to assign a key to the subject. A subject with a key can be identified elsewhere with a keyref. The <subjectdef> may use a navtitle element or attribute to supply a label for the subject. The <subjectdef> may also refer to a topic that captures the consensus definition for the subject.

As with normal <topicref> processing, when the <subjectdef> element specifies a navtitle and refers to a topic, processors should use the actual topic title in place of the navtitle. When the navtitle is preferred as a subject label, the <subjectdef> element must have the locktitle attribute set to "yes".

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (topicmeta) (optional) then (data or data-about or hasInstance or hasKind or hasNarrower or hasPart or hasRelated or subjectdef or subjectHead or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, enumerationdef, relatedSubjects, subjectRole

Inheritance

- map/topicref subjectScheme/subjectdef

Example

<subjectScheme>
  <!-- Pull in a scheme that defines unix OS values -->
  <schemeref href="unixOS.ditamap"/>
  <!-- Define new OS values that are merged with those in the unixOS scheme -->
  <subjectdef keys="os">
    <subjectdef keys="linux"/>
    <subjectdef keys="mswin"/>
    <subjectdef keys="zos"/>
  </subjectdef>
  <!-- Define application values -->
  <subjectdef keys="app" navtitle="Applications">
    <subjectdef keys="apacheserv" href="subject/apache.dita"/>
    <subjectdef keys="mysql"      href="subject/sql.dita"/>
  </subjectdef>

  <!-- Define an enumeration of the platform attribute, equal to
       each value in the OS subject. This makes the following values
       valid for the platform attribute: linux, mswin, zos -->
  <enumerationdef>
    <attributedef name="platform"/>
    <subjectdef keyref="os"/>
  </enumerationdef>
  <!-- Define an enumeration of the otherprops attribute, equal to
       each value in the application subjects.
       This makes the following values valid for the otherprops attribute:
       apacheserv, mysql -->
  <enumerationdef>
    <attributedef name="otherprops"/>
    <subjectdef keyref="app"/>
  </enumerationdef>
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified.

Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy.

CDATA #IMPLIED No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
linking Defines some specific linking characteristics of a topic's current location in the map. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (TOC). If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.13 subjectHeadMeta
Next topic: 3.1.5.1.15 relatedSubjects


relatedSubjects

3.1.5.1.15 relatedSubjects

The <relatedSubjects> element establishes associative relationships between each child subject and every other child subject (unless the association is restricted by the linking attribute of the subjects).

For filtering and flagging, processors need only inspect the subordinate hierarchies under category subjects that are bound to attributes. Filtering and flagging processors do not have to understand specific types of relationships. Explicit relationships are useful primarily for information viewers with advanced capabilities.

The content provider can identify the relationship by specifying a keys attribute, label the relationship by specifying a navtitle element or attribute, and provide a consensus definition of the relationship including by referencing a topic. If the relationship has an identifying key, the content provider can use the keyref attribute to specify the same relationship for different subjects.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (data or data-about or subjectdef or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme

Inheritance

- map/topicref subjectScheme/relatedSubjects

Example

The following scheme establishes that the Linux, the Apache Web Server, and the MySQL Database are related:
<subjectScheme>
  <!-- ... -->
  <relatedSubjects>
    <subjectdef keys="linux"     navtitle="Linux"/>
    <subjectdef keys="apacheweb" navtitle="Apache Web Server"/>
    <subjectdef keys="mysql"     navtitle="MySQL Database"/>
  </relatedSubjects>
  <!-- ... -->
</subjectScheme>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
collection-type Collection types describe how links relate to each other.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(unordered | sequence | choice | family | -dita-use-​conref-​target) family No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
linking Defines some specific linking characteristics of a topic's current location in the map.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) normal No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.14 subjectdef
Next topic: 3.1.5.1.16 subjectRelTable


subjectRelTable

3.1.5.1.16 subjectRelTable

The <subjectRelTable> element is a specialized relationship table which establishes relationships between the subjects in different columns of the same row. This element provides an efficient way to author non-hierarchical relationships between subjects. Tools (such as search tools) that use subject relationships to find related content may use these associative relationships in a similar way to the hierarchical relationships.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (title) (optional) then (topicmeta) (optional) then (subjectRelHeader) (optional) then (subjectRel) (one or more) )

Contained by

Doctype | Content model
subjectScheme | subjectScheme

Inheritance

- map/reltable subjectScheme/subjectRelTable

Example

The subject relationship table in this example establishes environmentFor relationships between operating systems and applications. Based on the subjectRole element, subjects in the first column are operating systems which are the environment for an application, while subjects in the second column are applications that run in that environment. For a user interested in content about the operating system, content about the applications may also be relevant.

<subjectScheme>
  <hasKind>
    <subjectdef keys="operatingSystem">
        <subjectdef keys="linuxOS"/>
        <subjectdef keys="windowsOS"/>
    </subjectdef>
    <subjectdef keys="application">
        <subjectdef keys="IDE">
            <subjectdef keys="eclipseIDE"/>
            <subjectdef keys="visualStudioIDE"/>
        </subjectdef>
        <subjectdef keys="webBrowser">
            <subjectdef keys="firefoxBrowser"/>
            <subjectdef keys="ieBrowser"/>
        </subjectdef>
    </subjectdef>
  </hasKind>
  ...
  <subjectRelTable>
    <subjectRelHeader>
      <subjectRole>
        <subjectdef keyref="operatingSystem">
          <hasRelated keyref="environmentFor">
            <subjectdef keyref="application"/>
          </hasRelated>
        </subjectdef>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="application"/>
      </subjectRole>
    </subjectRelHeader>
    <subjectRel>
      <subjectRole>
        <subjectdef keyref="linuxOS"/>
        <subjectdef keyref="windowsOS"/>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="eclipseIDE"/>
        <subjectdef keyref="firefoxBrowser"/>
      </subjectRole>
    </subjectRel>
    <subjectRel>
      <subjectRole>
        <subjectdef keyref="windowsOS"/>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="ieBrowser"/>
        <subjectdef keyref="visualStudioIDE"/>
      </subjectRole>
    </subjectRel>
  </subjectRelTable>
</subjectScheme>
A table view of the subjectRelTable may look like this; each <subjectRel> represents a single row, and each <subjectRole> represents a cell.
Table 1. subjectRelTable as a table
<subjectdef keyref="operatingSystem">
 <hasRelated keyref="environmentFor">
  <subjectdef keyref="application"/>
 </hasRelated>
</subjectdef>

<subjectdef keyref="application"/>

<subjectdef keyref="linuxOS"/>
<subjectdef keyref="windowsOS"/>

<subjectdef keyref="eclipseIDE"/>
<subjectdef keyref="firefoxBrowser"/>

<subjectdef keyref="windowsOS"/>

<subjectdef keyref="ieBrowser"/>
<subjectdef keyref="visualStudioIDE"/>

Attributes

Name | Description | Data Type | Default Value | Required?
topicref-atts-no-toc attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A related set of attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.15 relatedSubjects
Next topic: 3.1.5.1.17 subjectRelHeader


subjectRelHeader

3.1.5.1.17 subjectRelHeader

The <subjectRelHeader> element specifies the roles played by subjects in associations.

You use the subjectRelHeader element to supply a header row for a subject relationship table when you want to identify the roles played by the subjects in each column. Each cell in the header row identifies a subject topic that defines a role. When specializing the subjectRelTable element, you can accomplish the same purpose by specializing the cells within the rows to enforce the roles.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (subjectRole) (one or more) )

Contained by

Doctype | Content model
subjectScheme | subjectRelTable

Inheritance

- map/relrow subjectScheme/subjectRelHeader

Example

The subject relationship table in this example establishes environmentFor relationships between operating systems and applications. Based on the subjectRole element, subjects in the first column are operating systems which are the environment for an application, while subjects in the second column are applications that run in that environment. For a user interested in content about the operating system, content about the applications may also be relevant.

<subjectScheme>
  <hasKind>
    <subjectdef keys="operatingSystem">
        <subjectdef keys="linuxOS"/>
        <subjectdef keys="windowsOS"/>
    </subjectdef>
    <subjectdef keys="application">
        <subjectdef keys="IDE">
            <subjectdef keys="eclipseIDE"/>
            <subjectdef keys="visualStudioIDE"/>
        </subjectdef>
        <subjectdef keys="webBrowser">
            <subjectdef keys="firefoxBrowser"/>
            <subjectdef keys="ieBrowser"/>
        </subjectdef>
    </subjectdef>
  </hasKind>
  ...
  <subjectRelTable>
    <subjectRelHeader>
      <subjectRole>
        <subjectdef keyref="operatingSystem">
          <hasRelated keyref="environmentFor">
            <subjectdef keyref="application"/>
          </hasRelated>
        </subjectdef>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="application"/>
      </subjectRole>
    </subjectRelHeader>
    <subjectRel>
      <subjectRole>
        <subjectdef keyref="linuxOS"/>
        <subjectdef keyref="windowsOS"/>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="eclipseIDE"/>
        <subjectdef keyref="firefoxBrowser"/>
      </subjectRole>
    </subjectRel>
    <subjectRel>
      <subjectRole>
        <subjectdef keyref="windowsOS"/>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="ieBrowser"/>
        <subjectdef keyref="visualStudioIDE"/>
      </subjectRole>
    </subjectRel>
  </subjectRelTable>
</subjectScheme>
A table view of the subjectRelTable may look like this; each <subjectRel> represents a single row, and each <subjectRole> represents a cell.
Table 1. subjectRelTable as a table
<subjectdef keyref="operatingSystem">
 <hasRelated keyref="environmentFor">
  <subjectdef keyref="application"/>
 </hasRelated>
</subjectdef>

<subjectdef keyref="application"/>

<subjectdef keyref="linuxOS"/>
<subjectdef keyref="windowsOS"/>

<subjectdef keyref="eclipseIDE"/>
<subjectdef keyref="firefoxBrowser"/>

<subjectdef keyref="windowsOS"/>

<subjectdef keyref="ieBrowser"/>
<subjectdef keyref="visualStudioIDE"/>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.16 subjectRelTable
Next topic: 3.1.5.1.18 subjectRel


subjectRel

3.1.5.1.18 subjectRel

The <subjectRel> element contains a set of subjects that are related in some manner. Each group of subjects is contained in a <subjectRole> element; the associations between different columns in the same row are evaluated in the same way as those in a <relrow> (from which <subjectRel> is specialized) but define relationships between the subjects instead of links between topic documents.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (subjectRole) (one or more) )

Contained by

Doctype | Content model
subjectScheme | subjectRelTable

Inheritance

- map/relrow subjectScheme/subjectRel

Example

The subject relationship table in this example establishes environmentFor relationships between operating systems and applications. Based on the subjectRole element, subjects in the first column are operating systems which are the environment for an application, while subjects in the second column are applications that run in that environment. For a user interested in content about the operating system, content about the applications may also be relevant.

<subjectScheme>
  <hasKind>
    <subjectdef keys="operatingSystem">
        <subjectdef keys="linuxOS"/>
        <subjectdef keys="windowsOS"/>
    </subjectdef>
    <subjectdef keys="application">
        <subjectdef keys="IDE">
            <subjectdef keys="eclipseIDE"/>
            <subjectdef keys="visualStudioIDE"/>
        </subjectdef>
        <subjectdef keys="webBrowser">
            <subjectdef keys="firefoxBrowser"/>
            <subjectdef keys="ieBrowser"/>
        </subjectdef>
    </subjectdef>
  </hasKind>
  ...
  <subjectRelTable>
    <subjectRelHeader>
      <subjectRole>
        <subjectdef keyref="operatingSystem">
          <hasRelated keyref="environmentFor">
            <subjectdef keyref="application"/>
          </hasRelated>
        </subjectdef>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="application"/>
      </subjectRole>
    </subjectRelHeader>
    <subjectRel>
      <subjectRole>
        <subjectdef keyref="linuxOS"/>
        <subjectdef keyref="windowsOS"/>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="eclipseIDE"/>
        <subjectdef keyref="firefoxBrowser"/>
      </subjectRole>
    </subjectRel>
    <subjectRel>
      <subjectRole>
        <subjectdef keyref="windowsOS"/>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="ieBrowser"/>
        <subjectdef keyref="visualStudioIDE"/>
      </subjectRole>
    </subjectRel>
  </subjectRelTable>
</subjectScheme>
A table view of the subjectRelTable may look like this; each <subjectRel> represents a single row, and each <subjectRole> represents a cell.
Table 1. subjectRelTable as a table
<subjectdef keyref="operatingSystem">
 <hasRelated keyref="environmentFor">
  <subjectdef keyref="application"/>
 </hasRelated>
</subjectdef>

<subjectdef keyref="application"/>

<subjectdef keyref="linuxOS"/>
<subjectdef keyref="windowsOS"/>

<subjectdef keyref="eclipseIDE"/>
<subjectdef keyref="firefoxBrowser"/>

<subjectdef keyref="windowsOS"/>

<subjectdef keyref="ieBrowser"/>
<subjectdef keyref="visualStudioIDE"/>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.17 subjectRelHeader
Next topic: 3.1.5.1.19 subjectRole


subjectRole

3.1.5.1.19 subjectRole

The <subjectRole> element, when used within a <subjectRel> element, contains a set of subjects that are related to other subjects in the same row of the current <subjectRelTable>. By default, no relationship is defined between multiple subjects in the same <subjectRole> element. When used within the <subjectRelHeader>, the <subjectRole> element defines the category of subject or relationship provided by that column.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
subjectScheme | ( (data or data-about or subjectdef or topicref or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
subjectScheme | subjectRelHeader, subjectRel

Inheritance

- map/relcell subjectScheme/subjectRole

Example

The subject relationship table in this example establishes environmentFor relationships between operating systems and applications. Based on the subjectRole element, subjects in the first column are operating systems which are the environment for an application, while subjects in the second column are applications that run in that environment. For a user interested in content about the operating system, content about the applications may also be relevant.

<subjectScheme>
  <hasKind>
    <subjectdef keys="operatingSystem">
        <subjectdef keys="linuxOS"/>
        <subjectdef keys="windowsOS"/>
    </subjectdef>
    <subjectdef keys="application">
        <subjectdef keys="IDE">
            <subjectdef keys="eclipseIDE"/>
            <subjectdef keys="visualStudioIDE"/>
        </subjectdef>
        <subjectdef keys="webBrowser">
            <subjectdef keys="firefoxBrowser"/>
            <subjectdef keys="ieBrowser"/>
        </subjectdef>
    </subjectdef>
  </hasKind>
  ...
  <subjectRelTable>
    <subjectRelHeader>
      <subjectRole>
        <subjectdef keyref="operatingSystem">
          <hasRelated keyref="environmentFor">
            <subjectdef keyref="application"/>
          </hasRelated>
        </subjectdef>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="application"/>
      </subjectRole>
    </subjectRelHeader>
    <subjectRel>
      <subjectRole>
        <subjectdef keyref="linuxOS"/>
        <subjectdef keyref="windowsOS"/>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="eclipseIDE"/>
        <subjectdef keyref="firefoxBrowser"/>
      </subjectRole>
    </subjectRel>
    <subjectRel>
      <subjectRole>
        <subjectdef keyref="windowsOS"/>
      </subjectRole>
      <subjectRole>
        <subjectdef keyref="ieBrowser"/>
        <subjectdef keyref="visualStudioIDE"/>
      </subjectRole>
    </subjectRel>
  </subjectRelTable>
</subjectScheme>
A table view of the subjectRelTable may look like this; each <subjectRel> represents a single row, and each <subjectRole> represents a cell.
Table 1. subjectRelTable as a table
<subjectdef keyref="operatingSystem">
 <hasRelated keyref="environmentFor">
  <subjectdef keyref="application"/>
 </hasRelated>
</subjectdef>

<subjectdef keyref="application"/>

<subjectdef keyref="linuxOS"/>
<subjectdef keyref="windowsOS"/>

<subjectdef keyref="eclipseIDE"/>
<subjectdef keyref="firefoxBrowser"/>

<subjectdef keyref="windowsOS"/>

<subjectdef keyref="ieBrowser"/>
<subjectdef keyref="visualStudioIDE"/>

Attributes

Name | Description | Data Type | Default Value | Required?
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.1 Subject scheme maps
Previous topic: 3.1.5.1.18 subjectRel
Next topic: 3.1.5.2 Classification domain elements


Classification domain elements

3.1.5.2 Classification domain elements

The classification domain elements are used to identify the subject matter of content that is referenced in a map. These subjects must be subjects defined in a subject scheme map. In particular, this allows an author to classify content in new subject categories that are not bound to existing metadata attributes.

  • 3.1.5.2.1 subjectref
    The <subjectref> element identifies a subject to classify content. The <subjectref> can identify the subject with a keyref attribute (if the scheme has a <subjectdef> with a keys attribute that assigns a key to the subject) or an href attribute (if the scheme is not available and a topic exists that defines the subject).
  • 3.1.5.2.2 topicapply
    The <topicapply> element identifies subjects that qualify the content for filtering or flagging but not retrieval. The <topicapply> element can identify a single subject. Additional subjects can be specified by nested <subjectref> elements.
  • 3.1.5.2.3 topicsubject
    The <topicsubject> element identifies the subjects covered by a topic or map.
  • 3.1.5.2.4 topicSubjectTable
    The <topicSubjectTable> element is a specialized relationship table which allows a map to use relationship tables to associate topics with subjects. Tools (such as search tools) may use these classifications to retrieve content that is relative to a specific subject or combination of subjects.
  • 3.1.5.2.5 topicSubjectHeader
    The <topicSubjectHeader> element specifies constraints on the subjects used in classifications.
  • 3.1.5.2.6 topicSubjectRow
    The <topicSubjectRow> is a grouping element that contains one row of a subject table. It contains topic references in the first column, and relates those references to the subjects in each following column.
  • 3.1.5.2.7 topicCell
    The <topicCell> element contains topics that will be associated with subjects in each following column of the current row in the <topicSubjectTable>.
  • 3.1.5.2.8 subjectCell
    The <subjectCell> element contains subjects that are associated with topics in the first column of the current row in the <topicSubjectTable>. The subjects themselves have no defined relationship across columns, other than the fact that they apply to the same content.
Parent topic: 3.1.5 Classification elements
Previous topic: 3.1.5.1.19 subjectRole
Next topic: 3.1.5.2.1 subjectref


subjectref

3.1.5.2.1 subjectref

The <subjectref> element identifies a subject to classify content. The <subjectref> can identify the subject with a keyref attribute (if the scheme has a <subjectdef> with a keys attribute that assigns a key to the subject) or an href attribute (if the scheme is not available and a topic exists that defines the subject).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
classifyMap | ( (topicmeta) (optional) then (data or data-about) (any number) )

Contained by

Doctype | Content model
classifyMap | topicsubject, topicapply, subjectCell

Inheritance

+ map/topicref classify-d/subjectref

Example

In the following example, the map is classified as covering the Linux subject and the "Developing web applications" topic as covering the web and development subjects. These subjects (and their keys) are defined externally in a subject scheme map; in order to reference the subject directly without the subject scheme map, the href attribute would be used in place of keyref.

<map>
  <title>Working with Linux</title>
  <topicsubject keyref="linux"/>
  <!-- ... -->
  <topicref href="webapp.dita" navtitle="Developing web applications">
    <topicsubject>
      <subjectref keyref="web"/>
      <subjectref keyref="development"/>
    </topicsubject>
    <!-- ... -->
  </topicref>
  <!-- ... -->
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The default for this attribute on this element is "resource-only". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) resource-only No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
linking Defines some specific linking characteristics of a topic's current location in the map. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (toc); on this element the default is no. This value defaults to no for elements such as reltable, which typically cannot appear in the toc, and for elements such as glossref that generally are not desired in the toc. | (yes | no | -dita-use-​conref-​target) | "no" | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.5.2 Classification domain elements
Previous topic: 3.1.5.2 Classification domain elements
Next topic: 3.1.5.2.2 topicapply


topicapply

3.1.5.2.2 topicapply

The <topicapply> element identifies subjects that qualify the content for filtering or flagging but not retrieval. The <topicapply> element can identify a single subject. Additional subjects can be specified by nested <subjectref> elements.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
classifyMap | ( (topicmeta) (optional) then (data or data-about or subjectref or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell

Inheritance

+ map/topicref classify-d/topicapply

Example

The map content should be retrieved for Apache Tomcat and hidden as irrelevant for operating systems other than RedHat or SuSE.

<map>
  <title>Installing Apache Tomcat on RedHat or SuSE Linux</title>
  <topicsubject href="../controlledValues/tomcatServer.dita"/>
  <topicapply>
    <subjectref href="../controlledValues/redhatLinux.dita"/>
    <subjectref href="../controlledValues/suseLinux.dita"/>
  </topicapply>
  ...
</map>

Attributes

Name

 | Description

 | Data Type

 | Default Value

 | Required?

             navtitle

              | Specifies the title of the topic as it will appear in the
                navigation or tables of contents that are generated from the map. Beginning
                with DITA 1.2, the preferred way to specify the navigation title in a map is
                with the navtitle element, available inside the topicmeta element.

              | CDATA

              | #IMPLIED

              | No

             href

              | A pointer to the resource represented by the
                <topicref>. See
                The href attribute for detailed information
                on supported values and processing implications. References to DITA content
                cannot be below the topic level: that is, you cannot reference individual
                elements inside a topic.
                References to content other than DITA topics
                  should use the format attribute to identify the kind of resource being
                  referenced.

              | CDATA

              | #IMPLIED

              | No

             keys

              | Introduces one or more global identifiers for a resource
                referenced from a map. See
                The keys attribute for details on how to
                use the keys attribute.

              | NMTOKEN

              | #IMPLIED

              | No

             keyref

              | Keyref provides a redirectable
                  reference based on a key defined within a map. See
                  The keyref attribute for information on
                  using this attribute.

              | CDATA

              | #IMPLIED

              | No

             query

              | This attribute is deprecated. It may be removed in the
                future.

              | CDATA

              | #IMPLIED

              | No

             collection-type

             Collection types describe how links relate to each other.
                The processing default is "unordered", although no default is specified in the
                DTD or Schema.

unordered

Indicates that the order of the child topics is not
                        significant.

sequence

Indicates that the order of the child topics is
                        significant; output processors will typically link between them in order.

choice

Indicates that one of the children should be selected.

family

Represents a tight grouping in which each of the referenced
                        topics not only relates to the current topic but also relate to each other.

-dita-use-​conref-​target

See
                        Using the -dita-use-conref-target value for more
                        information.

Usage of the collection-type attribute on <reltable> and
                  <relcolspec> is currently undefined and reserved for future use.

             (unordered | sequence | choice | family |
                -dita-use-​conref-​target)

             #IMPLIED

             No

             type

              | Describes the target of a reference. See
                The type attribute for detailed information
                on supported values and processing implications.

              | CDATA

              | #IMPLIED

              | No

             processing-role

             Describes the processing role of the referenced topic. The
                default for this attribute on this element is "resource-only".
                If the value is not specified locally, but
                  is specified on an ancestor, the value will cascade from the closest
                  ancestor.

normal

Normal topic that is a readable part of the information.

resource-only

The topic is used as a resource for processing purposes,
                        but is not a readable unit of information on its own. This topic should not be
                        included in a rendered table of contents, and the topic should not be rendered
                        on its own.

-dita-use-​conref-​target

See
                        Using the -dita-use-conref-target value for more
                        information.

             (normal | resource-only |
                -dita-use-​conref-​target)

             resource-only

             No

             scope

              | The scope attribute identifies the closeness of the
                relationship between the current document and the target resource. See
                The scope attribute for more information on
                values.

              | (local | peer | external |
                -dita-use-​conref-​target)

              | #IMPLIED

              | No

             format

              | The format attribute identifies the format of the resource
                being referenced. See
                The format attribute for details on
                supported values.

              | CDATA

              | #IMPLIED

              | No

             linking

             Defines some specific linking characteristics of a
                topic's current location in the map.
                If the value is not specified locally, but
                  is specified on an ancestor, the value will cascade from the closest
                  ancestor.

targetonly

A topic can only be linked to and cannot link to other
                        topics.

sourceonly

A topic cannot be linked to but can link to other topics.

normal

A topic can be linked to and can link to other topics. Use
                        this to override the linking value of a parent topic.

none

A topic cannot be linked to or link to other topics.

-dita-use-​conref-​target

See
                        Using the -dita-use-conref-target value for more
                        information.

             (targetonly | sourceonly | normal | none |
                -dita-use-​conref-​target)

             #IMPLIED

             No

             toc

              | Specifies whether a topic appears in the table of contents
                (toc); on this element the default is no. This value defaults to no for
                elements such as reltable, which typically cannot appear in the toc, and for
                elements such as glossref that generally are not desired in the
                toc.

              | (yes | no |
                -dita-use-​conref-​target)

              | "no"

              | No

             univ-atts attribute group (includes select-atts, id-atts,
                and localization-atts groups)

              | A set of related attributes, described in
                univ-atts attribute group

             global-atts attribute group (xtrf, xtrc)

              | A set of related attributes, described in
                global-atts attribute group

             class, outputclass

              | Common attributes described in
                Other common DITA attributes

Parent topic: 3.1.5.2 Classification domain elements

Previous topic: 3.1.5.2.1 subjectref

Next topic: 3.1.5.2.3 topicsubject


topicsubject

3.1.5.2.3 topicsubject

The <topicsubject> element identifies the subjects covered by a topic or map.

In order to identify a primary subject, refer to the subject with the <topicsubject> itself, using the keys or The subjects can be identified by keys (if defined in the scheme) or, if the subject definition topic exists, by href (as with ordinary topic references).

Additional secondary subjects can be specified by nested <subjectref> elements.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
classifyMap | ( (topicmeta) (optional) then (data or data-about or subjectref or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
classifyMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, topicsubject, topicapply, topicCell, subjectCell

Inheritance

+ map/topicref classify-d/topicsubject

Example

In the following example, the map is classified as covering Linux as the primary subject; the topic "Developing web applications" also covers the secondary web and development subjects. These subjects (and their keys) are defined externally in a subject scheme map; in order to reference the subject directly without the subject scheme map, the href attribute would be used in place of keyref.

<map>
  <title>Working with Linux</title>
  <topicsubject keyref="linux"/>
  <!-- ... -->
  <topicref href="webapp.dita" navtitle="Developing web applications">
    <topicsubject>
      <subjectref keyref="web"/>
      <subjectref keyref="development"/>
    </topicsubject>
    <!-- ... -->
  </topicref>
  <!-- ... -->
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
keys | Introduces one or more global identifiers for a resource referenced from a map. See The keys attribute for details on how to use the keys attribute. | NMTOKEN | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
processing-role Describes the processing role of the referenced topic. The default for this attribute on this element is "resource-only". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) resource-only No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
toc | Specifies whether a topic appears in the table of contents (toc); on this element the default is no. This value defaults to no for elements such as reltable, which typically cannot appear in the toc, and for elements such as glossref that generally are not desired in the toc. | (yes | no | -dita-use-​conref-​target) | "no" | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.1.5.2 Classification domain elements
Previous topic: 3.1.5.2.2 topicapply
Next topic: 3.1.5.2.4 topicSubjectTable


topicSubjectTable

3.1.5.2.4 topicSubjectTable

The <topicSubjectTable> element is a specialized relationship table which allows a map to use relationship tables to associate topics with subjects. Tools (such as search tools) may use these classifications to retrieve content that is relative to a specific subject or combination of subjects.

In a <topicSubjectTable>, the first column is reserved for references to content. Subsequent columns are reserved for subjects that classify the content, each column supplying the subjects for a different category as identified in the header. The table resembles a traditional relationship table in which the first column identifies the source and the other columns identify the targets, but the relationship reflects the subjects covered by the content rather than linking between documents.

Note: In a traditional reltable, topics in any given column establish relationships with topics in every other cell of the same row. In a <topicSubjectTable>, topics in the first column are related to all of the subjects in the row, but no relationship is implied between subjects in different columns of the same row. Instead, relationships are defined between subjects using a subject scheme map (which provides a <subjectRelTable> element for non-hierarchical relationships between subjects).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
classifyMap | ( (title) then (topicmeta) (optional) then (topicSubjectHeader) (optional) then (topicSubjectRow) (one or more) )

Contained by

Doctype | Content model
classifyMap | map

Inheritance

+ map/reltable classify-d/topicSubjectTable

Example

The topic subject table below classifies topics with goals for retrieval and with operating systems for filtering. The map makes use of definitions in a subject scheme map, defined separately.

Figure 1. Subject scheme map
<subjectScheme>
    <hasKind>
        <subjectdef href="goalType.dita" keys="goal">
            <subjectdef href="performanceGoal.dita" keys="performance"/>
            <subjectdef href="reliabilityGoal.dita" keys="reliability"/>
        </subjectdef>
        <subjectdef href="operatingSystem.dita" keys="os">
            <subjectdef href="linuxOS.dita" keys="linux"/>
            <subjectdef href="unixOS.dita" keys="unix"/>
            <subjectdef href="windowsOS.dita" keys="windows"/>
        </subjectdef>
    </hasKind>
</subjectScheme>
Figure 2. Topic subject table
The following <topicSubjectTable> classifies several topics according to subjects in the previous map. As with any <topicSubjectTable>, the first column is used to specify topics. In this specific example, the second column is used to specify a goal, based on the "goal" subject in the header. The third column is used to specify an operating system. Based on those definitions, the following classifications are made by this table:
  • The topics "Configuring cron for efficient startup" and "Allocating raw storage" are each classified by the goal of "performance"; in addition, they are classified by the operating systems "linux" and "unix.
  • The topics "Analyzing web logs for service issues" and "Detecting denial-of-service attacks" are each classified by the goal of "reliability"; in addition, they are classified by the operating systems "linux", "unix", and "windows".
  • No relationship is defined between subjects in the table, meaning that this table does not define any relationship between the goal of "performance" and the operating systems "linux" or "unix".
<map>
...
<topicSubjectTable>
  <topicSubjectHeader>
    <topicCell type="task"/>
    <subjectCell>
      <topicsubject keyref="goal"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="os"/>
    </subjectCell>
  </topicSubjectHeader>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webServerStart.dita" navtitle="Configuring cron for efficient startup"/>
      <topicref href="dbDisk.dita" navtitle="Allocating raw storage"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="performance"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
    </subjectCell>
  </topicSubjectRow>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webLogAnalyze.dita" navtitle="Analyzing web logs for service issues"/>
      <topicref href="webDenialService.dita" navtitle="Detecting denial-of-service attacks"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="reliability"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
      <topicapply keyref="windows"/>
    </subjectCell>
  </topicSubjectRow>
  ...
</topicSubjectTable>
</map>

A table view of this <topicSubjectTable> might look as follows. This is only one of many possible views; to aid in understanding the example, the content topics in the first column are displayed using only their titles, and related subjects are displayed using only their keyref attribute value.

task | goal | os
Configuring cron for efficient startup Allocating raw storage | performance | linux unix
Analyzing web logs for service issues Detecting denial-of-service attacks | reliability | linux unix windows

Attributes

Name | Description | Data Type | Default Value | Required?
topicref-atts-no-toc attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A related set of attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.2 Classification domain elements
Previous topic: 3.1.5.2.3 topicsubject
Next topic: 3.1.5.2.5 topicSubjectHeader


topicSubjectHeader

3.1.5.2.5 topicSubjectHeader

The <topicSubjectHeader> element specifies constraints on the subjects used in classifications.

You use the <topicSubjectHeader> element to supply a header row for a topic classification table when you want to encourage classification with subjects from different categories (also known as a facet classification). Each cell in the header row identifies the subject for a different category. The subjects in the same column within the classification rows must appear in the category in the subject scheme. For instance, if the cell within the header row specifies the Operating System category, the subjects in the column must be kinds of operating systems.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
classifyMap | ( (topicCell) then (subjectCell) (one or more) )

Contained by

Doctype | Content model
classifyMap | topicSubjectTable

Inheritance

+ map/relrow classify-d/topicSubjectHeader

Example

The topic subject table below classifies topics with goals for retrieval and with operating systems for filtering. The map makes use of definitions in a subject scheme map, defined separately.

Figure 1. Subject scheme map
<subjectScheme>
    <hasKind>
        <subjectdef href="goalType.dita" keys="goal">
            <subjectdef href="performanceGoal.dita" keys="performance"/>
            <subjectdef href="reliabilityGoal.dita" keys="reliability"/>
        </subjectdef>
        <subjectdef href="operatingSystem.dita" keys="os">
            <subjectdef href="linuxOS.dita" keys="linux"/>
            <subjectdef href="unixOS.dita" keys="unix"/>
            <subjectdef href="windowsOS.dita" keys="windows"/>
        </subjectdef>
    </hasKind>
</subjectScheme>
Figure 2. Topic subject table
The following <topicSubjectTable> classifies several topics according to subjects in the previous map. As with any <topicSubjectTable>, the first column is used to specify topics. In this specific example, the second column is used to specify a goal, based on the "goal" subject in the header. The third column is used to specify an operating system. Based on those definitions, the following classifications are made by this table:
  • The topics "Configuring cron for efficient startup" and "Allocating raw storage" are each classified by the goal of "performance"; in addition, they are classified by the operating systems "linux" and "unix.
  • The topics "Analyzing web logs for service issues" and "Detecting denial-of-service attacks" are each classified by the goal of "reliability"; in addition, they are classified by the operating systems "linux", "unix", and "windows".
  • No relationship is defined between subjects in the table, meaning that this table does not define any relationship between the goal of "performance" and the operating systems "linux" or "unix".
<map>
...
<topicSubjectTable>
  <topicSubjectHeader>
    <topicCell type="task"/>
    <subjectCell>
      <topicsubject keyref="goal"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="os"/>
    </subjectCell>
  </topicSubjectHeader>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webServerStart.dita" navtitle="Configuring cron for efficient startup"/>
      <topicref href="dbDisk.dita" navtitle="Allocating raw storage"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="performance"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
    </subjectCell>
  </topicSubjectRow>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webLogAnalyze.dita" navtitle="Analyzing web logs for service issues"/>
      <topicref href="webDenialService.dita" navtitle="Detecting denial-of-service attacks"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="reliability"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
      <topicapply keyref="windows"/>
    </subjectCell>
  </topicSubjectRow>
  ...
</topicSubjectTable>
</map>

A table view of this <topicSubjectTable> might look as follows. This is only one of many possible views; to aid in understanding the example, the content topics in the first column are displayed using only their titles, and related subjects are displayed using only their keyref attribute value.

task | goal | os
Configuring cron for efficient startup Allocating raw storage | performance | linux unix
Analyzing web logs for service issues Detecting denial-of-service attacks | reliability | linux unix windows

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.2 Classification domain elements
Previous topic: 3.1.5.2.4 topicSubjectTable
Next topic: 3.1.5.2.6 topicSubjectRow


topicSubjectRow

3.1.5.2.6 topicSubjectRow

The <topicSubjectRow> is a grouping element that contains one row of a subject table. It contains topic references in the first column, and relates those references to the subjects in each following column.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
classifyMap | ( (topicCell) then (subjectCell) (one or more) )

Contained by

Doctype | Content model
classifyMap | topicSubjectTable

Inheritance

+ map/relrow classify-d/topicSubjectRow

Example

The topic subject table below classifies topics with goals for retrieval and with operating systems for filtering. The map makes use of definitions in a subject scheme map, defined separately.

Figure 1. Subject scheme map
<subjectScheme>
    <hasKind>
        <subjectdef href="goalType.dita" keys="goal">
            <subjectdef href="performanceGoal.dita" keys="performance"/>
            <subjectdef href="reliabilityGoal.dita" keys="reliability"/>
        </subjectdef>
        <subjectdef href="operatingSystem.dita" keys="os">
            <subjectdef href="linuxOS.dita" keys="linux"/>
            <subjectdef href="unixOS.dita" keys="unix"/>
            <subjectdef href="windowsOS.dita" keys="windows"/>
        </subjectdef>
    </hasKind>
</subjectScheme>
Figure 2. Topic subject table
The following <topicSubjectTable> classifies several topics according to subjects in the previous map. As with any <topicSubjectTable>, the first column is used to specify topics. In this specific example, the second column is used to specify a goal, based on the "goal" subject in the header. The third column is used to specify an operating system. Based on those definitions, the following classifications are made by this table:
  • The topics "Configuring cron for efficient startup" and "Allocating raw storage" are each classified by the goal of "performance"; in addition, they are classified by the operating systems "linux" and "unix.
  • The topics "Analyzing web logs for service issues" and "Detecting denial-of-service attacks" are each classified by the goal of "reliability"; in addition, they are classified by the operating systems "linux", "unix", and "windows".
  • No relationship is defined between subjects in the table, meaning that this table does not define any relationship between the goal of "performance" and the operating systems "linux" or "unix".
<map>
...
<topicSubjectTable>
  <topicSubjectHeader>
    <topicCell type="task"/>
    <subjectCell>
      <topicsubject keyref="goal"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="os"/>
    </subjectCell>
  </topicSubjectHeader>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webServerStart.dita" navtitle="Configuring cron for efficient startup"/>
      <topicref href="dbDisk.dita" navtitle="Allocating raw storage"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="performance"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
    </subjectCell>
  </topicSubjectRow>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webLogAnalyze.dita" navtitle="Analyzing web logs for service issues"/>
      <topicref href="webDenialService.dita" navtitle="Detecting denial-of-service attacks"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="reliability"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
      <topicapply keyref="windows"/>
    </subjectCell>
  </topicSubjectRow>
  ...
</topicSubjectTable>
</map>

A table view of this <topicSubjectTable> might look as follows. This is only one of many possible views; to aid in understanding the example, the content topics in the first column are displayed using only their titles, and related subjects are displayed using only their keyref attribute value.

task | goal | os
Configuring cron for efficient startup Allocating raw storage | performance | linux unix
Analyzing web logs for service issues Detecting denial-of-service attacks | reliability | linux unix windows

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.2 Classification domain elements
Previous topic: 3.1.5.2.5 topicSubjectHeader
Next topic: 3.1.5.2.7 topicCell


topicCell

3.1.5.2.7 topicCell

The <topicCell> element contains topics that will be associated with subjects in each following column of the current row in the <topicSubjectTable>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
classifyMap | ( (data or data-about or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (one or more) )

Contained by

Doctype | Content model
classifyMap | topicSubjectHeader, topicSubjectRow

Inheritance

+ map/relrow classify-d/topicSubjectRow

Example

The topic subject table below classifies topics with goals for retrieval and with operating systems for filtering. The map makes use of definitions in a subject scheme map, defined separately.

Figure 1. Subject scheme map
<subjectScheme>
    <hasKind>
        <subjectdef href="goalType.dita" keys="goal">
            <subjectdef href="performanceGoal.dita" keys="performance"/>
            <subjectdef href="reliabilityGoal.dita" keys="reliability"/>
        </subjectdef>
        <subjectdef href="operatingSystem.dita" keys="os">
            <subjectdef href="linuxOS.dita" keys="linux"/>
            <subjectdef href="unixOS.dita" keys="unix"/>
            <subjectdef href="windowsOS.dita" keys="windows"/>
        </subjectdef>
    </hasKind>
</subjectScheme>
Figure 2. Topic subject table
The following <topicSubjectTable> classifies several topics according to subjects in the previous map. As with any <topicSubjectTable>, the first column is used to specify topics. In this specific example, the second column is used to specify a goal, based on the "goal" subject in the header. The third column is used to specify an operating system. Based on those definitions, the following classifications are made by this table:
  • The topics "Configuring cron for efficient startup" and "Allocating raw storage" are each classified by the goal of "performance"; in addition, they are classified by the operating systems "linux" and "unix.
  • The topics "Analyzing web logs for service issues" and "Detecting denial-of-service attacks" are each classified by the goal of "reliability"; in addition, they are classified by the operating systems "linux", "unix", and "windows".
  • No relationship is defined between subjects in the table, meaning that this table does not define any relationship between the goal of "performance" and the operating systems "linux" or "unix".
<map>
...
<topicSubjectTable>
  <topicSubjectHeader>
    <topicCell type="task"/>
    <subjectCell>
      <topicsubject keyref="goal"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="os"/>
    </subjectCell>
  </topicSubjectHeader>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webServerStart.dita" navtitle="Configuring cron for efficient startup"/>
      <topicref href="dbDisk.dita" navtitle="Allocating raw storage"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="performance"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
    </subjectCell>
  </topicSubjectRow>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webLogAnalyze.dita" navtitle="Analyzing web logs for service issues"/>
      <topicref href="webDenialService.dita" navtitle="Detecting denial-of-service attacks"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="reliability"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
      <topicapply keyref="windows"/>
    </subjectCell>
  </topicSubjectRow>
  ...
</topicSubjectTable>
</map>

A table view of this <topicSubjectTable> might look as follows. This is only one of many possible views; to aid in understanding the example, the content topics in the first column are displayed using only their titles, and related subjects are displayed using only their keyref attribute value.

task | goal | os
Configuring cron for efficient startup Allocating raw storage | performance | linux unix
Analyzing web logs for service issues Detecting denial-of-service attacks | reliability | linux unix windows

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.2 Classification domain elements
Previous topic: 3.1.5.2.6 topicSubjectRow
Next topic: 3.1.5.2.8 subjectCell


subjectCell

3.1.5.2.8 subjectCell

The <subjectCell> element contains subjects that are associated with topics in the first column of the current row in the <topicSubjectTable>. The subjects themselves have no defined relationship across columns, other than the fact that they apply to the same content.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
classifyMap | ( (data or data-about or subjectref or topicref or (topicsubject or topicapply) or (anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )

Contained by

Doctype | Content model
classifyMap | topicSubjectHeader, topicSubjectRow

Inheritance

+ map/relcell classify-d/subjectCell

Example

The topic subject table below classifies topics with goals for retrieval and with operating systems for filtering. The map makes use of definitions in a subject scheme map, defined separately.

Figure 1. Subject scheme map
<subjectScheme>
    <hasKind>
        <subjectdef href="goalType.dita" keys="goal">
            <subjectdef href="performanceGoal.dita" keys="performance"/>
            <subjectdef href="reliabilityGoal.dita" keys="reliability"/>
        </subjectdef>
        <subjectdef href="operatingSystem.dita" keys="os">
            <subjectdef href="linuxOS.dita" keys="linux"/>
            <subjectdef href="unixOS.dita" keys="unix"/>
            <subjectdef href="windowsOS.dita" keys="windows"/>
        </subjectdef>
    </hasKind>
</subjectScheme>
Figure 2. Topic subject table
The following <topicSubjectTable> classifies several topics according to subjects in the previous map. As with any <topicSubjectTable>, the first column is used to specify topics. In this specific example, the second column is used to specify a goal, based on the "goal" subject in the header. The third column is used to specify an operating system. Based on those definitions, the following classifications are made by this table:
  • The topics "Configuring cron for efficient startup" and "Allocating raw storage" are each classified by the goal of "performance"; in addition, they are classified by the operating systems "linux" and "unix.
  • The topics "Analyzing web logs for service issues" and "Detecting denial-of-service attacks" are each classified by the goal of "reliability"; in addition, they are classified by the operating systems "linux", "unix", and "windows".
  • No relationship is defined between subjects in the table, meaning that this table does not define any relationship between the goal of "performance" and the operating systems "linux" or "unix".
<map>
...
<topicSubjectTable>
  <topicSubjectHeader>
    <topicCell type="task"/>
    <subjectCell>
      <topicsubject keyref="goal"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="os"/>
    </subjectCell>
  </topicSubjectHeader>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webServerStart.dita" navtitle="Configuring cron for efficient startup"/>
      <topicref href="dbDisk.dita" navtitle="Allocating raw storage"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="performance"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
    </subjectCell>
  </topicSubjectRow>
  <topicSubjectRow>
    <topicCell>
      <topicref href="webLogAnalyze.dita" navtitle="Analyzing web logs for service issues"/>
      <topicref href="webDenialService.dita" navtitle="Detecting denial-of-service attacks"/>
    </topicCell>
    <subjectCell>
      <topicsubject keyref="reliability"/>
    </subjectCell>
    <subjectCell>
      <topicapply keyref="linux"/>
      <topicapply keyref="unix"/>
      <topicapply keyref="windows"/>
    </subjectCell>
  </topicSubjectRow>
  ...
</topicSubjectTable>
</map>

A table view of this <topicSubjectTable> might look as follows. This is only one of many possible views; to aid in understanding the example, the content topics in the first column are displayed using only their titles, and related subjects are displayed using only their keyref attribute value.

task | goal | os
Configuring cron for efficient startup Allocating raw storage | performance | linux unix
Analyzing web logs for service issues Detecting denial-of-service attacks | reliability | linux unix windows

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.5.2 Classification domain elements
Previous topic: 3.1.5.2.7 topicCell
Next topic: 3.1.6 Specialization elements


Specialization elements

3.1.6 Specialization elements

Several DITA elements exist either for architectural reasons or for support of specialized markup yet to be designed. Although there is little need to use these elements unless you are directed to, some of them, such as <state>, can be used if your content makes use of these semantic distinctions. For example, a discussion of signals on a gate of an integrated logic circuit might use the state element to represent either on or off conditions of that gate.

  • 3.1.6.1 boolean
    The <boolean> element was deprecated in DITA version 1.1. It was originally intended to express one of two opposite values, such as yes / no or on / off.
  • 3.1.6.2 data
    The <data> element represents a property within a DITA topic or map. While the <data> element can be used directly to capture properties, it is particularly useful as a basis for specialization. Default processing should treat the content as an unknown kind of metadata and ignore it for rendering, but custom processing may match the name attribute or specialized element and use the element for automated manipulation or to format data associated with the body flow. For example, a specialized data element may be used to format properties as sidebars or other adornments or to harvest properties for automated processing.
  • 3.1.6.3 data-about
    The <data-about> element identifies the subject of a property when the subject isn't associated with the context in which the property is specified. The property itself is expressed by the <data> element. The <data-about> element handles exception cases where a property must be expressed somewhere other than inside the actual subject of the property. The <data-about> element is particularly useful as a basis for specialization in combination with the <data> element.
  • 3.1.6.4 foreign
    The <foreign> element allows the introduction of non-DITA content, for example, MathML, SVG, or Rich Text Format (RTF). The <foreign> element or a specialization may contain more than one type of non-DITA content or a mix of DITA and non-DITA content. Specialization of the <foreign> element generally is implemented as a domain, but architects looking for more control over the content may implement foreign vocabularies as structural specializations.
  • 3.1.6.5 index-base
    The <index-base> element allows indexing extensions to be added by specializing this element.
  • 3.1.6.6 itemgroup
    The <itemgroup> element can be used to sub-divide or organize elements that occur inside a list item, definition, or parameter definition.
  • 3.1.6.7 no-topic-nesting
    The <no-topic-nesting> element is a placeholder in the DITA architecture. It is not actually used by the default DITA document types; it is for use only when creating a validly customized document type where the information designer wants to eliminate the ability to nest topics. Not intended for use by authors, and has no associated output processing.
  • 3.1.6.8 state
    The <state> element specifies a name/value pair whenever it is necessary to represent a named state that has a variable value. The element is primarily intended for use in specializations to represent specific states (like logic circuit states, chemical reaction states, airplane instrumentation states, and so forth).
  • 3.1.6.9 unknown
    The <unknown> element is an open extension that allows information architects to incorporate xml fragments that do not necessarily fit into an existing DITA use case. Processors should ignore this element unless otherwise instructed.
Parent topic: 3.1 Base elements
Previous topic: 3.1.5.2.8 subjectCell
Next topic: 3.1.6.1 boolean


boolean

3.1.6.1 boolean

The <boolean> element was deprecated in DITA version 1.1. It was originally intended to express one of two opposite values, such as yes / no or on / off.

OASIS TC Note: This element is deprecated. It is functionally equivalent to <state value="yes|no"/>, which is recommended as its replacement in all cases.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, b, u, i, tt, sup, sub, howtoavoid
topic (technical content), concept | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, glossterm, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, howtoavoid
learningContent | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/boolean

Example

She said "<boolean state="yes"/>" when I asked her to marry me!

Attributes

Name | Description | Data Type | Default Value | Required?
state | The state of the boolean element. Allowable values are: yes no | (yes | no | -dita-use-​conref-​target) | #IMPLIED | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6 Specialization elements
Next topic: 3.1.6.2 data


data

3.1.6.2 data

The <data> element represents a property within a DITA topic or map. While the <data> element can be used directly to capture properties, it is particularly useful as a basis for specialization. Default processing should treat the content as an unknown kind of metadata and ignore it for rendering, but custom processing may match the name attribute or specialized element and use the element for automated manipulation or to format data associated with the body flow. For example, a specialized data element may be used to format properties as sidebars or other adornments or to harvest properties for automated processing.

The subject of the property is ordinarily the container of the <data> element. In the content model for the <prolog> and <metadata> elements, the property applies to the topic as a whole. In the <topicmeta> element, the property applies to the referenced topic. The <data-about> element may be used to identify the subject of the property with an explicit reference.

The name attribute names the property for processes. A <title> subelement may provide a label for the property. The datatype attribute may be used to identify the type for the value. The value of the property can be any of the following:

  • A simple text value expressed with the value attribute or textual content.
  • A reference to either DITA content or a non-DITA resource expressed with the href attribute.
  • An image or other non-textual object.
  • A brief unit of descriptive text that is not part of the body text flow.
  • A complex structure composed of nested <data> elements.
CAUTION:
Processors should ignore the content of the <data> element by default, so the <data> element should only be used for properties and not to embed text for formatting as part of the flow of the topic body. It might be tempting to specialize the <data> element for text that is part of the body flow, so as to escape the constraints of the base content models. This abuse of the DITA architecture will cause problems. For example, if a particular kind of paragraph is specialized from <data> rather than from <p>, then when the content is exchanged with others that do not recognize the specialized element, their processors will skip the content.

The <data> element may be nested to create structures for complex properties. The name attribute may be to distinguish different semantics associated with different instances of the <data> element such as addresses, times, amounts, and so on. In many cases, however, it is preferable to specialize the <data> element for more precise semantics and for constraints on structures and values. For instance, a specialization can specify an enumeration for the value attribute.

A <data> element containing properties of a topic as a whole should be located in the topic's <prolog> or <metadata> element, or in a <topicmeta> element related to a <topicref> that references the topic. The <data> element generally goes at the beginning of the element to which the properties in it refer. Where this is unwieldy, the <data> element can go in the <prolog>, with the data-about attribute identifying which specific element in the topic is the reference.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or image or object or ph or b or i or sup or sub or tt or u or title) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or image or object or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or title) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or image or object or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or title) (any number)

Contained by

Doctype | Content model
topic (base) | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence
map (base) | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
topic (technical content) | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
concept | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, bookmeta, publisherinformation, person, organization, summary, printlocation, published, reviewed, edited, tested, approved, bookevent, bookpartno, booknumber, maintainer, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
classifyMap | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, topicsubject, topicapply, subjectref, topicCell, subjectCell, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
subjectScheme | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, subjectScheme, schemeref, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, enumerationdef, elementdef, attributedef, defaultSubject, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
machineryTask | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, uicontrol, screen
learningAssessment, learningOverview, learningSummary | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords, lcLom
learningBookmap | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, bookmeta, publisherinformation, person, organization, summary, printlocation, published, reviewed, edited, tested, approved, bookevent, bookpartno, booknumber, maintainer, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, lcLom, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
learningContent | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords, lcLom
learningMap | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, lcLom, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
learningPlan | data-about, data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords, lcLom

Inheritance

- topic/data

Example

Uses of the <data> element may include the following:

  • Complex metadata properties such as bibliographic records corresponding to citations.
  • Hybrid documents with data values as part of the content, such as word processor formats using form fields.
  • Messages in which the payload includes human-readable content. Such applications can use the <data> element to define the addressing on the message envelope. For instance, a topic could model an email message by representing the address with specialized <data> elements in the <prolog> element and the content with the <body> element.
  • Transactional documents in which the values are processed but also displayed with human-readable content. In particular, a library of building blocks for transaction documents can be implemented through a DITA domain as specialized <data> elements including those from the UN/CEFACT Core Components Technical Specification (http://www.unece.org/cefact/).
Figure 1. Using the name attribute on unspecialized data elements

This structure identifies the library and version demonstrated by a code sample. The name attribute is used to identify both the grouping data element and the nested data elements that provide specific properties. These properties will not appear in the output unless a processor is customized to recognize these name attribute values.

<codeblock>
  <data name="exampleOf">
    <data name="library" href="ajaxLibrary.js"/>
    <data name="version" value="2006-6-19"/>
  </data>
  ...
</codeblock>
Figure 2. Specializing data to annotate a code sample

The following example specifies the delimited source code for a code fragment so an automated process can refresh the code fragment. The <fragmentSource>, <sourceFile>, <startDelimiter>, and <endDelimiter> elements are specialized from <data> but the <codeFragment> is specialized from <codeblock>. These properties wouldn't appear in the formatted output (except perhaps for debugging problems in the refresh):

<example>
    <title>An important coding technique</title>
    <codeFragment>
        <fragmentSource>
            <sourceFile     value="helloWorld.java"/>
            <startDelimiter value="FRAGMENT_START_1"/>
            <endDelimiter   value="FRAGMENT_END_1"/>
        </fragmentSource>
        ...
    </codeFragment>
</example>
Figure 3. Specializing data to annotate housing information

The following example identifies a real estate property as part of a house description. The <realEstateProperty> element and its child elements are specialized from <data>. The <houseDescription> element is specialized from <section>. A specialized process can format the values as part of a brochure if they meet criteria for inclusion.

<houseDescription>
  <title>A great home for sale</title>
  <realEstateProperty>
    <realEstateBlock value="B7"/>
    <realEstateLot   value="4003"/>
    ...
  </realEstateProperty>
  <p>This elegant....</p>
  <object data="B7_4003_tour360Degrees.swf"/>
</houseDescription>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6.1 boolean
Next topic: 3.1.6.3 data-about


data-about

3.1.6.3 data-about

The <data-about> element identifies the subject of a property when the subject isn't associated with the context in which the property is specified. The property itself is expressed by the <data> element. The <data-about> element handles exception cases where a property must be expressed somewhere other than inside the actual subject of the property. The <data-about> element is particularly useful as a basis for specialization in combination with the <data> element.

Important: Do not use the <data-about> element to identify the object of a property. The href attribute of the <data> element serves that purpose.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( (data) then (data or data-about) (any number) )

Contained by

Doctype | Content model
topic (base) | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence
map (base), learningMap | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
topic (technical content) | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
concept | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
classifyMap | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, topicsubject, topicapply, subjectref, topicCell, subjectCell, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
subjectScheme | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, subjectScheme, schemeref, hasNarrower, hasKind, hasPart, hasInstance, hasRelated, subjectdef, subjectHead, enumerationdef, elementdef, attributedef, defaultSubject, relatedSubjects, subjectRole, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
machineryTask | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, uicontrol, screen
learningAssessment, learningOverview, learningSummary | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningBookmap | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, map, topicref, relcell, topicmeta, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, topichead, topicgroup, anchorref, mapref, topicset, topicsetref, keydef, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
learningContent | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningPlan | data-about, data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords

Inheritance

- topic/data-about

Example

The full properties of a cited book can be maintained conveniently in the prolog:

<topic id="questions">
    <title>Questions and answers</title>
    <prolog>
        <data-about href="urn:isbn:0156983508" scope="external">
            <data name="title">The World Doesn't End</data>
            <data name="author">
                <data name="firstname">Charles</data>
                <data name="lastname">Simic</data>
            </data>
            <data name="published" datatype="year">1989</data>
            ...
        </data-about>
        ...
    </prolog>
    <body>
        ...
       <lq href="urn:isbn:0156983508">In a forest of question marks ...
       </lq>
       ...
    </body>
</topic>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6.2 data
Next topic: 3.1.6.4 foreign


foreign

3.1.6.4 foreign

The <foreign> element allows the introduction of non-DITA content, for example, MathML, SVG, or Rich Text Format (RTF). The <foreign> element or a specialization may contain more than one type of non-DITA content or a mix of DITA and non-DITA content. Specialization of the <foreign> element generally is implemented as a domain, but architects looking for more control over the content may implement foreign vocabularies as structural specializations.

Processors should attempt to display <foreign> content unless otherwise instructed. If the processor cannot render the content, it may emit a warning.

The enabler of the foreign vocabulary must provide the processing and override the base processing for <foreign>.

  • If <foreign> contains more than one alternative content element, they should all be processed. In the case of <desc> they should be concatenated in a similar way to <section>, but with no title (analogous to <div> in HTML).
  • If alternate content is desired, specialize the <desc> element to contain it. This specialization of <desc> should be used within the element specialized from <foreign>. Such alternate content must of course be valid wherever the <foreign> specialization is valid.
  • If no <desc>, <object>, or <image> element is found within an instance of the <foreign> element, the base processing mayemit a warning about the absence of processable content.
  • The base processing for <object> may emit the content of <foreign> as a file at the location specified by the data attribute of the <object> element. The <object> element should have a data attribute or a <foreign> sub-element but not both. In the event that an <object> element contains both a data attribute and an <foreign> sub-element the processing system should ignore one of them.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ANY

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence
map (base), classifyMap, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
topic (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
subjectScheme | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, uicontrol, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords

Inheritance

- topic/foreign

SVG Example within a <p> element

<p>... as in the formula
  <svg>
    <svg:svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<ellipse cx="300" cy="150" rx="200" ry="80"
style="fill:rgb(200,100,50);
stroke:rgb(0,0,100);stroke-width:2"/>

    </svg:svg>
  </svg>.
</p>

MathML Example within an <object> element

<p>... as in the formula
<object>
  <desc>4 + x</desc>
  <mathML>
    <mml:math display="block">
      <mml:mrow>
        <mml:mo>&sum;</mml:mo>
        <mml:mn>4</mml:mn>
        <mml:mo>+</mml:mo>
        <mml:mi>x</mml:mi>
      </mml:mrow>
    </mml:math>
  </mathML>
 <object>.
</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6.3 data-about
Next topic: 3.1.6.5 index-base


index-base

3.1.6.5 index-base

The <index-base> element allows indexing extensions to be added by specializing this element.

The <index-base> element can only exist as a child of an <indexterm> element. This characteristic makes it the appropriate element to specialize to add indexing extensions. For example, the index-see, index-see-also, and index-sort-as elements only make sense as children of <indexterm> and so are specializations of <index-base>. Those elements are all part of the indexing domain.

On its own, <index-base> has no meaning. Processors should ignore this element and its content if encountered in its unspecialized form.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term or indexterm) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or indexterm) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or indexterm) (any number)

Contained by

Doctype | Content model
topic (base), map (base), topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | indexterm

Inheritance

- topic/index-base

Example

The <index-see-also> element is specialized from index-base; see index-see-also for an example of how index-base may be used with specialization.

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6.4 foreign
Next topic: 3.1.6.6 itemgroup


itemgroup

3.1.6.6 itemgroup

The <itemgroup> element can be used to sub-divide or organize elements that occur inside a list item, definition, or parameter definition.

The <itemgroup> element is particularly useful as a basis for specialization, where it can be used to group content within specialized list items or definitions. For example, in the OASIS task specialization, many elements within the <step> element are specialized from <itemgroup>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningBookmap, learningMap | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (base), map (base), classifyMap, subjectScheme, learningAssessment, learningBookmap, learningMap, learningOverview, learningPlan, learningSummary | li, dd
topic (technical content), map (technical content), concept, glossary, glossentry, glossgroup, reference, bookmap | li, dd, pd
ditabase, task (strict), task (general) | li, dd, stepsection, step, substep, choice, pd
machineryTask | li, dd, stepsection, step, substep, choice, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond
learningContent | li, dd, stepsection, step, substep, choice

Inheritance

- topic/itemgroup

Example

<li>Second point of a list.
 <itemgroup>related discourse</itemgroup>
</li>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6.5 index-base
Next topic: 3.1.6.7 no-topic-nesting


no-topic-nesting

3.1.6.7 no-topic-nesting

The <no-topic-nesting> element is a placeholder in the DITA architecture. It is not actually used by the default DITA document types; it is for use only when creating a validly customized document type where the information designer wants to eliminate the ability to nest topics. Not intended for use by authors, and has no associated output processing.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, concept, ditabase, glossary, glossentry, glossgroup, reference, task, machineryTask, learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossentry
learningAssessment | learningAssessment
learningContent | topic, task, concept, reference, learningSummary, learningAssessment
learningOverview | learningOverview
learningPlan | learningPlan
learningSummary | learningSummary

Inheritance

- topic/no-topic-nesting

Example

This element is not intended to be used in source files.

Attributes

Name | Description | Data Type | Default Value | Required?
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6.6 itemgroup
Next topic: 3.1.6.8 state


state

3.1.6.8 state

The <state> element specifies a name/value pair whenever it is necessary to represent a named state that has a variable value. The element is primarily intended for use in specializations to represent specific states (like logic circuit states, chemical reaction states, airplane instrumentation states, and so forth).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
topic (base) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, howtoavoid
map (base), classifyMap, subjectScheme, learningMap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, b, u, i, tt, sup, sub, howtoavoid
topic (technical content), concept | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, glossterm, glossdef, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, howtoavoid, b, u, i, tt, sup, sub, screen
learningAssessment, learningOverview, learningSummary | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, howtoavoid
learningContent | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | title, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, stentry, draft-comment, fn, cite, xref, entry, abstract, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, b, u, i, tt, sup, sub, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/state

Example

<step><cmd>Verify the presence of  an "on" or high condition at the input gate
(ie,  <state name="inflag" value="high"/>)</cmd></step>

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name of the property whose state is being described. | CDATA | #REQUIRED | Yes
value | The state of the property identified by the name attribute. | CDATA | #IMPLIED | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6.7 no-topic-nesting
Next topic: 3.1.6.9 unknown


unknown

3.1.6.9 unknown

The <unknown> element is an open extension that allows information architects to incorporate xml fragments that do not necessarily fit into an existing DITA use case. Processors should ignore this element unless otherwise instructed.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ANY

Contained by

Doctype | Content model
topic (base) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence
map (base), classifyMap, learningMap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
topic (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, conbody, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, repsep, msgph, msgblock, filepath, userinput, systemoutput
subjectScheme | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, uicontrol, screen
learningAssessment, learningOverview, learningSummary | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningBookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, topicmeta, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence
learningContent | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refbody, refbodydiv, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords
learningPlan | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, fig, figgroup, pre, lines, ph, alt, object, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, metadata, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, body, bodydiv, section, sectiondiv, example, prolog, linktext, linkinfo, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, lcInteractionBase, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem, lcAreaCoords

Inheritance

- topic/unknown

Example

This example features a specialized <unknown> element that includes other non-DITA content. If this specialization is imported to a DTD or schema, the DTD or schema will need to handle declaring the new elements or any namespaces.

<body>
  <my-unknown class="+ topic/unknown mything/my-unknown ">
    <thing value="4"/>
    <otherthing value="16"/>
  </my-unknown>
</body>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.6 Specialization elements
Previous topic: 3.1.6.8 state
Next topic: 3.1.7 Legacy conversion elements


Legacy conversion elements

3.1.7 Legacy conversion elements

Conversion elements exist primarily to aid in the conversion of content to DITA.

  • 3.1.7.1 required-cleanup
    A <required-cleanup> element is used as a placeholder for migrated elements that cannot be appropriately tagged without manual intervention. As the element name implies, the intent for authors is to clean up the contained material and eventually remove the <required-cleanup> element. Authors should not insert this element into documents.
Parent topic: 3.1 Base elements
Previous topic: 3.1.6.9 unknown
Next topic: 3.1.7.1 required-cleanup


required-cleanup

3.1.7.1 required-cleanup

A <required-cleanup> element is used as a placeholder for migrated elements that cannot be appropriately tagged without manual intervention. As the element name implies, the intent for authors is to clean up the contained material and eventually remove the <required-cleanup> element. Authors should not insert this element into documents.

Processing notes:
  • Processors must strip this element from output by default. The content of <required-cleanup> is not considered to be verified data.
  • Processor options may be provided to allow a draft view of migrated content in context.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic, map, concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, classifyMap, subjectScheme, machineryTask, learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ANY

Contained by

Doctype | Content model
topic (base) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example
map (base), classifyMap, subjectScheme, learningMap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry
topic (technical content) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, screen, codeblock, pd
map (technical content) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, screen, codeblock, pd
concept | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, screen, codeblock, pd
ditabase | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, glossdef, glossUsage, glossScopeNote, screen, codeblock, pd
glossary, glossentry, glossgroup | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, glossdef, glossUsage, glossScopeNote, screen, codeblock, pd
reference | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, screen, codeblock, pd
task (strict), task (general) | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, screen, codeblock, pd
bookmap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, organizationname, screen, codeblock, pd
machineryTask | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, screen
learningAssessment, learningOverview, learningSummary | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningBookmap | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, organizationname
learningContent | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem
learningPlan | p, note, lq, sli, li, itemgroup, dd, pre, lines, ph, stentry, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcObjectivesStem, lcObjective, lcAudience, lcTime, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcQuestionBase, lcInstructornote, lcQuestion, lcOpenAnswer, lcFeedback, lcFeedbackCorrect, lcFeedbackIncorrect, lcAnswerContent, lcItem, lcMatchingItem

Inheritance

- topic/required-cleanup

Example

Presuming an original HTML document had contained some content within a <center> tag (for which there is no clear migrational equivalent in DITA), the following might be the result that is valid within an XML editor, but which requires an author to decide how to better tag or revise this original content:

<section>
  <title>Some section title</title>
  <required-cleanup remap="center">Some original content migrated
  from a &lt;center> tag.</required-cleanup>
</section>

Attributes

Name | Description | Data Type | Default Value | Required?
remap | Indicates the element that the contents of the required-cleanup element were mapped from (provides an idea about what the new intent should be). | CDATA | #IMPLIED | No
translate | Indicates whether the content of the element should be translated or not. Setting to "yes" will override the default. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value; because this element uses an actual default, it will always be treated as translate="no" unless overridden as described. | yes | no | -dita-use-​conref-​target | "no" | No
xml:lang | Specifies the language of the element content. The xml:lang attribute and its values are described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. | language token or the null string | #IMPLIED | No
dir | Specifies the directionality of text: left-to-right (ltr, the processing default) or right-to-left (rtl). The value lro indicates an override of normal bidi text presentation, forcing the element into left-to-right mode; rlo overrides normal rules to force right-to-left presentation. See The dir attribute for more information on the dir attribute. | (ltr | rtl | lro | rlo | -dita-use-​conref-​target) | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.1.7 Legacy conversion elements
Previous topic: 3.1.7 Legacy conversion elements
Next topic: 3.1.8 DITAVAL elements


DITAVAL elements

3.1.8 DITAVAL elements

A conditional processing profile (DITAVAL file) is used to identify which values are to be used for conditional processing during a particular output, build, or some other purpose. The profile should have an extension of .ditaval.

The DITAVAL format has several elements: val, the root element, can contain a style-conflict element followed by prop or revprop elements; the prop and revprop elements can contain startflag and endflag elements; and the startflag and endflag elements can contain alt-text elements.

Notes on ditaval messages

Conditional processing code should provide a report of any attribute values encountered in content that do not have an explicit action associated with them.

Note on ditaval flagging of images

If an image in DITA content becomes flagged using a background color, the color should be represented as a thick border. If a foreground color is expressed, it should be represented as a thin border.

  • 3.1.8.1 val
    <val> is the root element of a DITAVAL file.
  • 3.1.8.2 style-conflict
    The style-conflict element declares behavior to be used when one or more flagging methods collide on a single content element.
  • 3.1.8.3 prop
    Identifies an attribute, and usually values in the attribute, to take an action on. The attribute must be a conditional processing attribute: platform, product, audience, props. and otheprops; or a specialization of the props attribute.
  • 3.1.8.4 revprop
    Identifies a value in the rev attribute that should be flagged in some manner. Unlike the other conditional processing attributes, which may be used for both filtering and flagging, the rev attribute may only be used for flagging.
  • 3.1.8.5 startflag
    The startflag takes an optional image reference and an optional alt-text element for identifying the beginning of flagged content. If an image is specified, the specified image will be used to flag the beginning of the content, with the alt-text contents as alternative text. If alt-text is specified without an image, that text will be used to flag the content instead of an image. If no image and no alt-text are specified, then this element has no defined purpose. The startflag element is allowed inside either prop or revprop.
  • 3.1.8.6 endflag
    The endflag takes an optional image reference and an optional alt-text element for identifying the end of flagged content. If an image is specified, the specified image will be used to flag the end of the content, with the alt-text contents as alternative text. If alt-text is specified without an image, that text will be used to flag the content instead of an image. If no image and no alt-text are specified, then this element has no defined purpose. The endflag element is allowed inside either prop or revprop.
  • 3.1.8.7 alt-text
    An element allowed inside either startflag or endflag to provide alternate text for an image when the imageref attribute sets an image to be used for flagging. When no alternate text is specified for a revision flag, the default alternate text for revprop start of change is a localized translation of "Start of change", and the default alternate text for revprop end of change is a localized translation of "End of change".
Parent topic: 3.1 Base elements
Previous topic: 3.1.7.1 required-cleanup
Next topic: 3.1.8.1 val
Related concepts
2.1.2.3.2.1 Conditional processing attributes
2.1.3.6 Conditional processing (profiling)


val

3.1.8.1 val

<val> is the root element of a DITAVAL file.

For information about processing DITAVAL files, including how to filter or flag elements with multiple property attributes or multiple properties within a single attribute, see Conditional processing (profiling).

Contains

style-conflict (optional) then (prop or revprop) (any number)

Example

Figure 1. Sample DITAVAL file
<val>
   <style-conflict backcolor="red"/>
   <prop action="include" att="audience" val="everybody"/>
   <prop action="flag" att="product" val="YourProd" backcolor="purple"/>
   <prop action="flag" att="product" backcolor="blue"
         color="yellow" style="underline" val="MyProd">
      <startflag imageref="startflag.jpg">
        <alt-text>This is the start of my product info</alt-text>
      </startflag>
      <endflag imageref="endflag.jpg">
        <alt-text>This is the end of my product info</alt-text>
      </endflag>
   </prop>
   <revprop action="flag" val="1.2"/>
</val>
This sample DITAVAL file performs the following actions:
  • Elements with audience="everybody" are included without change.
  • Elements with product="YourProd" get a background color of purple.
  • Elements with product="MyProd" get the following actions:
    • The image startflag.jpg is placed at the start of the element.
    • The image endflag.jpg is placed at the end of the element.
    • The element gets a background color of blue.
    • The text in the element appears in yellow, and is underlined.
  • Elements marked with are flagged with the default revision flags, which are implementation dependent.
  • When there are conflicts - such as if an element is marked with product="MyProd YourProd" - it will be flagged with a background color of red.
Figure 2. DITAVAL file that overrides the default "include" action
<val>
   <prop action="exclude"/>
   <prop action="include" att="audience" val="everybody"/>
   <prop action="include" att="audience" val="novice"/>
   <prop action="include" att="product" val="productA"/>
   <prop action="include" att="product" val="productB"/>
</val>
This simple DITAVAL file ditaval performs the following actions:
  • The first <prop> element does not specify an attribute, which sets a default action of "exclude" for every prop value. This means that, by default, any property value not otherwise defined in this file evaluates to "exclude". Note that this same behavior can be limited to a single attribute; the following <prop> element sets a default action of "exclude" for all properties specified on the platform attribute: <prop action="exclude" att="otherprops"/>
  • The second and third <prop> elements set an action of "include" for two values on the audience attribute. All other values on the audience attribute still evaluate to "exclude".
  • The fourth and fifth <prop> elements set an action of "include" for two values on the product attribute. All other values on the product attribute still evaluate to "exclude".
Parent topic: 3.1.8 DITAVAL elements
Previous topic: 3.1.8 DITAVAL elements
Next topic: 3.1.8.2 style-conflict


style-conflict

3.1.8.2 style-conflict

The style-conflict element declares behavior to be used when one or more flagging methods collide on a single content element.

In case of conflicts between flagging methods at different levels (for example, a section is flagged green and a paragraph within the section is flagged red), the most deeply nested flagging method applies.

In case of conflicts between flagging methods on the same element (for example, a single element is being flagged with both green and red color), it is recommended that the conflicts be resolved as follows:
Flagging method
Conflict behavior
startflag/endflag
Add all flags that apply.
color
Follow the style-conflict @foreground-conflict-color setting, or use an output-appropriate default color if no conflict color is set.
backcolor
Follow the style-conflict @background-conflict-color setting, or use an output-appropriate default color if no conflict color is set.
style
Add all font styles that apply. If two different kinds of underline are used, default to the heaviest (double underline) and use the foreground-conflict-color.
changebar
Add all change bars that apply.

Contains

(empty)

Contained by

val

Example

See the example in the <val> description.

Attributes

Name | Description | Data Type | Default Value | Required?
foreground-conflict-color | The color to be used when more than one flagging color applies to a single content element. | CDATA | #IMPLIED | no
background-conflict-color | The color to be used when more than one flagging background color applies to a single content element. | CDATA | #IMPLIED | no
Parent topic: 3.1.8 DITAVAL elements
Previous topic: 3.1.8.1 val
Next topic: 3.1.8.3 prop


prop

3.1.8.3 prop

Identifies an attribute, and usually values in the attribute, to take an action on. The attribute must be a conditional processing attribute: platform, product, audience, props. and otheprops; or a specialization of the props attribute.

A prop element may do one of the following:
  • A prop element with no @att attribute specified sets a default action for every prop element. It is an error to use more than one prop element with no attribute in a single document. Recovery from this error is implementation dependent; in such cases processors may, but need not, provide an error or warning message.
  • A prop element with an @att attribute but no @value attribute sets a default action for that specific attribute. For each specific attribute, it is an error to use more than one prop element with that attribute and no value in a single document. Recovery from this error is implementation dependent; in such cases processors may, but need not, provide an error or warning message.
  • A prop attribute with an @att attribute and a @value attribute sets an action for that value within that attribute. It is an error to use more than one prop element with the same attribute and value. Recovery from this error is implementation dependent; in such cases processors may, but need not, provide an error or warning message.

Contains

startflag (optional) then endflag (optional)

Contained by

val

Example

See the example in the <val> description.

Attributes

Name | Description | Data Type | Default Value | Required?
att | The attribute to be acted upon. Must be one of props, audience, platform, product, otherprops, or a specialization of props. If the att attribute is absent, then the prop element declares a default behavior for any conditional processing attribute. | CDATA | #IMPLIED | no
val | The value to be acted upon. If the val attribute is absent, then the prop element declares a default behavior for any value in the specified attribute. | CDATA | #IMPLIED | no
action The action to be taken. The options are:
include
Include the content in output. This is the default behavior unless otherwise set.
exclude
Exclude the content from output (if all values in the particular attribute are excluded).
passthrough
Include the content in output, and preserve the attribute value as part of the output stream for further processing by a runtime engine, for example runtime filtering based on individual user settings. The value should be preserved in whatever syntax is required by the target runtime. Values that are not explicitly passed through should be removed from the output stream, even though the content is still included.
flag
Include and flag the content on output (if the content has not been excluded).
 (include | exclude | passthrough | flag) #IMPLIED yes
color | If flag has been set, the color to use to flag text. Colors may be entered by name or code. Processor support is recommended for the color names listed under the heading "<color>" in http://www.w3.org/TR/2001/REC-xsl-20011015/slice5.html#section-N8794-Property-Datatypes and for the 6 digit hex code form (#rrggbb, case insensitive). If flag has not been set, this attribute is ignored. | CDATA | #IMPLIED | no
backcolor | If flag has been set, the color to use as background for flagged text. Colors may be entered by name or code. Processor support is recommended for the color names listed under the heading "<color>" in http://www.w3.org/TR/2001/REC-xsl-20011015/slice5.html#section-N8794-Property-Datatypes and for the 6 digit hex code form (#rrggbb, case insensitive). If flag has not been set, this attribute is ignored. | CDATA | #IMPLIED | no
style If flag has been set, the text style to use for flagged text. The following values are enumerated:
  • underline
  • double-underline
  • italics
  • overline
  • bold
If flag has not been set, this attribute is ignored. 		(underline | double-underline | italics | overline | bold) #IMPLIED no
Parent topic: 3.1.8 DITAVAL elements
Previous topic: 3.1.8.2 style-conflict
Next topic: 3.1.8.4 revprop


revprop

3.1.8.4 revprop

Identifies a value in the rev attribute that should be flagged in some manner. Unlike the other conditional processing attributes, which may be used for both filtering and flagging, the rev attribute may only be used for flagging.

It is an error to include more than one <revprop> element with the same @val attribute setting. Recovery from this error is implementation dependent; in such cases processors may, but need not, provide an error or warning message.
When no alternate text is specified for a revision flag, the default alternate text for revprop start of change is a localized translation of "Start of change", and the default alternate text for revprop end of change is a localized translation of "End of change".
The rev attribute identifies when a particular section of a document was added in the lifetime of that document. The attribute is not considered a filtering attribute because this is not sufficient to be used for full version control, such as single-sourcing multiple product variants based on version level – it only represents one aspect of the revision level.

Contains

startflag (optional) then endflag (optional)

Contained by

val

Example

See the example in the <val> description.

Attributes

Name | Description | Data Type | Default Value | Required?
val | The value to be acted upon. If the val attribute is absent, then the revprop element declares a default behavior for any value in the rev attribute. | CDATA | #IMPLIED | no
action The action to be taken. The options are:
include
Include the content in output without flags. This is the default behavior unless otherwise set.
passthrough
Include the content in output, and preserve the attribute value as part of the output stream for further processing by a runtime engine, for example runtime filtering based on individual user settings. The value should be preserved in whatever syntax is required by the target runtime. Values that are not explicitly passed through should be removed from the output stream, even though the content is still included.
flag
Include and flag the content on output (if the content has not been excluded).
 (include | passthrough | flag) #IMPLIED yes
changebar | When flag has been set, specify a changebar color, style, or character, according to the changebar support of the target output format. If flag has not been set, this attribute is ignored. | CDATA | #IMPLIED | no
color | If flag has been set, the color to use to flag text. Colors may be entered by name or code. Processor support is recommended for the color names listed under the heading "<color>" in http://www.w3.org/TR/2001/REC-xsl-20011015/slice5.html#section-N8794-Property-Datatypes and for the 6 digit hex code form (#rrggbb, case insensitive). If flag has not been set, this attribute is ignored. | CDATA | #IMPLIED | no
backcolor | If flag has been set, the color to use as background for flagged text. Colors may be entered by name or code. Processor support is recommended for the color names listed under the heading "<color>" in http://www.w3.org/TR/2001/REC-xsl-20011015/slice5.html#section-N8794-Property-Datatypes and for the 6 digit hex code form (#rrggbb, case insensitive). If flag has not been set, this attribute is ignored. | CDATA | #IMPLIED | no
style If flag has been set, the text style to use for flagged text. The following values are enumerated:
  • underline
  • double-underline
  • italics
  • overline
  • bold
If flag has not been set, this attribute is ignored. 		(underline | double-underline | italics | overline | bold) #IMPLIED no
Parent topic: 3.1.8 DITAVAL elements
Previous topic: 3.1.8.3 prop
Next topic: 3.1.8.5 startflag


startflag

3.1.8.5 startflag

The startflag takes an optional image reference and an optional alt-text element for identifying the beginning of flagged content. If an image is specified, the specified image will be used to flag the beginning of the content, with the alt-text contents as alternative text. If alt-text is specified without an image, that text will be used to flag the content instead of an image. If no image and no alt-text are specified, then this element has no defined purpose. The startflag element is allowed inside either prop or revprop.

Contains

alt-text (optional)

Contained by

prop, revprop

Example

See the example in the <val> description.

Attributes

Name | Description | Data Type | Default Value | Required?
imageref | Provides a URI reference to the image file, using the same syntax as the href attribute. See The href attribute for information on supported values and processing implications. | CDATA | #IMPLIED | yes
Parent topic: 3.1.8 DITAVAL elements
Previous topic: 3.1.8.4 revprop
Next topic: 3.1.8.6 endflag


endflag

3.1.8.6 endflag

The endflag takes an optional image reference and an optional alt-text element for identifying the end of flagged content. If an image is specified, the specified image will be used to flag the end of the content, with the alt-text contents as alternative text. If alt-text is specified without an image, that text will be used to flag the content instead of an image. If no image and no alt-text are specified, then this element has no defined purpose. The endflag element is allowed inside either prop or revprop.

Contains

alt-text (optional)

Contained by

prop, revprop

Example

See the example in the <val> description.

Attributes

Name | Description | Data Type | Default Value | Required?
imageref | Provides a URI reference to the image file, using the same syntax as the href attribute. See The href attribute for information on supported values and processing implications. | CDATA | #IMPLIED | yes
Parent topic: 3.1.8 DITAVAL elements
Previous topic: 3.1.8.5 startflag
Next topic: 3.1.8.7 alt-text


alt-text

3.1.8.7 alt-text

An element allowed inside either startflag or endflag to provide alternate text for an image when the imageref attribute sets an image to be used for flagging. When no alternate text is specified for a revision flag, the default alternate text for revprop start of change is a localized translation of "Start of change", and the default alternate text for revprop end of change is a localized translation of "End of change".

Contains

text data

Contained by

startflag, endflag

Example

See the example in the <val> description.

Parent topic: 3.1.8 DITAVAL elements
Previous topic: 3.1.8.6 endflag
Next topic: 3.2 Technical content elements


Technical content elements

3.2 Technical content elements

Elements in the technical content section include the original Concept, Task, and Reference specializations, as well as the Bookmap and Glossary specializations added with DITA 1.1. It also includes domains designed primarily for technical content, such as the task requirements and software domains.

  • 3.2.1 Concept elements
    DITA concept topics answer "What is..." questions. Use the concept topic to introduce the background or overview information for tasks or reference topics. The concept topic restricts content following a section or example to other sections or examples. For more details on when to use concept and other information types, please refer to the DITA architectural specification.
  • 3.2.2 Task elements
    Task topics answer "How do I?" questions, and have a well-defined structure that describes how to complete a procedure to accomplish a specific goal. Use the task topic to describe the steps of a particular task, or to provide an overview of a higher-level task. The task topic includes sections for describing the context, prerequisites, actual steps, expected results, example, and expected next steps for a task. For more details on when to use task and other information types, please refer to the DITA architectural specification.
  • 3.2.3 Reference elements
    Reference topics describe factual material about a subject, such as the commands in a programming language. This format is also suitable for bibliographies, catalogues, the list of ingredients for recipes, and similar collections of structured descriptive prose. For more details on when to use reference and other information types, please refer to the DITA architectural specification.
  • 3.2.4 Glossary elements
    Glossary elements include those elements designed to specify terms and their definitions, as well as elements that are designed to group, reference, or otherwise make use of information in the glossentry topic.
  • 3.2.5 Bookmap elements
    Elements in the bookmap section are used to organize DITA content into book form. They include elements for dividing up content, such as chapter and appendix, as well as metadata specific to publishing.
  • 3.2.6 Domain elements
    Domains in this section include those generally associated with technical content, such as the programming and software domains.
Parent topic: 3 Language reference
Previous topic: 3.1.8.7 alt-text
Next topic: 3.2.1 Concept elements


Concept elements

3.2.1 Concept elements

DITA concept topics answer "What is..." questions. Use the concept topic to introduce the background or overview information for tasks or reference topics. The concept topic restricts content following a section or example to other sections or examples. For more details on when to use concept and other information types, please refer to the DITA architectural specification.

  • 3.2.1.1 concept
    The <concept> element is the top-level element for a topic that answers the question "what is?" Concepts provide background information that users must know before they can successfully work with a product or interface. Often, a concept is an extended definition of a major abstraction such as a process or function. It might also have an example or a graphic, but generally the structure of a concept is fairly simple.
  • 3.2.1.2 conbody
    The <conbody> element is the main body-level element for a concept.
  • 3.2.1.3 conbodydiv
    The <conbodydiv> element is similar to the <bodydiv> element in that it provides an informal container for content that may be grouped within a concept. There are no additional semantics attached to the conbodydiv element; it is purely a grouping element provided to help organize content.
Parent topic: 3.2 Technical content elements
Previous topic: 3.2 Technical content elements
Next topic: 3.2.1.1 concept


concept

3.2.1.1 concept

The <concept> element is the top-level element for a topic that answers the question "what is?" Concepts provide background information that users must know before they can successfully work with a product or interface. Often, a concept is an extended definition of a major abstraction such as a process or function. It might also have an example or a graphic, but generally the structure of a concept is fairly simple.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
concept | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (conbody) (optional) then (related-links) (optional) then (concept) (any number) )
ditabase | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (conbody) (optional) then (related-links) (optional) then (topic or concept or task or reference or glossentry or glossgroup) (any number) )
glossary, glossentry, glossgroup | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (conbody) (optional) then (related-links) (optional) then (topic) (any number) )
learningContent | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (conbody) (optional) then (related-links) (optional) then ( (no-topic-nesting) (optional) ) (any number) )

Contained by

Doctype | Content model
concept | concept
ditabase | dita, topic, concept, task, reference
learningContent | learningContent

Inheritance

- topic/topic concept/concept

Example

<concept id="concept">
 <title>Introduction to Bird Calling</title>
 <shortdesc>If you wish to attract more birds to your Acme Bird Feeder,
learn the art of bird calling. Bird calling is an efficient way
to alert more birds to the presence of your bird feeder.</shortdesc>
 <conbody>
   <p>Bird calling requires learning:</p>
   <ul>
    <li>Popular and classical bird songs</li>
    <li>How to whistle like a bird</li>
   </ul>
 </conbody>
</concept>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.1 Concept elements
Previous topic: 3.2.1 Concept elements
Next topic: 3.2.1.2 conbody


conbody

3.2.1.2 conbody

The <conbody> element is the main body-level element for a concept.

Like the <body> element of a general <topic>, <conbody> allows paragraphs, lists, and other elements as well as sections and examples. However, <conbody> has a constraint that a section or an example can be followed only by other sections, examples, or <conbodydiv> elements that group sections and examples.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
concept, ditabase, glossary, glossentry, glossgroup | ( (dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or data or data-about or draft-comment or foreign or unknown or required-cleanup) (any number) then (section or example or conbodydiv) (any number) )
learningContent | ( (dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or data or data-about or draft-comment or foreign or unknown or required-cleanup) (any number) then (section or example or conbodydiv) (any number) )

Contained by

Doctype | Content model
concept, ditabase, glossary, glossentry, glossgroup, learningContent | concept

Inheritance

- topic/body concept/conbody

Example

See the example in concept.

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.1 Concept elements
Previous topic: 3.2.1.1 concept
Next topic: 3.2.1.3 conbodydiv


conbodydiv

3.2.1.3 conbodydiv

The <conbodydiv> element is similar to the <bodydiv> element in that it provides an informal container for content that may be grouped within a concept. There are no additional semantics attached to the conbodydiv element; it is purely a grouping element provided to help organize content.

The parent <conbody> element has a restriction that sections or examples can only be followed by other sections or examples. The <conbodydiv> element, which allows groupings of sections and examples, keeps the same restriction in place; once used, only sections, examples, or other <conbodydiv> groups are allowed.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
concept, ditabase, glossary, glossentry, glossgroup, learningContent | (example or section) (any number)

Contained by

Doctype | Content model
concept, ditabase, glossary, glossentry, glossgroup, learningContent | conbody

Inheritance

- topic/bodydiv concept/conbodydiv

Example

One common use case for the <conbodydiv> element is to group a sequence of sections for reuse, so that another concept may reference the entire set with a single conref attribute.

<concept id="sample" xml:lang="en">
 <title>Conbodydiv example</title>
 <shortdesc>This concept is a sample of how to
use conbodydiv.</shortdesc>
 <conbody>
  <p>Introduce the example.</p>
  <p>Next group some sections that may be reused elsewhere.</p>
  <conbodydiv id="my_conbodydiv">
   <section><title>First</title> ... </section>
   <section><title>Second</title> ... </section>
  </conbodydiv>
 </conbody>
</concept>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.1 Concept elements
Previous topic: 3.2.1.2 conbody
Next topic: 3.2.2 Task elements


Task elements

3.2.2 Task elements

Task topics answer "How do I?" questions, and have a well-defined structure that describes how to complete a procedure to accomplish a specific goal. Use the task topic to describe the steps of a particular task, or to provide an overview of a higher-level task. The task topic includes sections for describing the context, prerequisites, actual steps, expected results, example, and expected next steps for a task. For more details on when to use task and other information types, please refer to the DITA architectural specification.

  • 3.2.2.1 task
    The <task> element is the top-level element for a task topic. Tasks are the main building blocks for task-oriented user assistance. They generally provide step-by-step instructions that will enable a user to perform a task. A task answers the question of "how to?" by telling the user precisely what to do and the order in which to do it. Tasks have the same high-level structure as other topics, with a title, short description and body.
  • 3.2.2.2 taskbody
    The <taskbody> element is the main body-level element inside a task topic. A task body is designed to contain information specific to completing a task, such as prerequisites, contextual information, and steps. DITA 1.2 introduces a much looser <taskbody> content model in order to allow for more variations in the structure of a task. A constraint module is also provided in order to maintain compatibility with the previous strict model; this constraint is used in the default task distributed by OASIS.
  • 3.2.2.3 prereq
    The <prereq> element of a task contains prerequisites that the user needs to know or do before starting the current task. Implementations may, but need not, render prerequisite links from the related-links section together with the <prereq> content.
  • 3.2.2.4 context
    The <context> element provides background information for a task. This information helps the user understand what the purpose of the task is and what they will gain by completing the task. This section should be brief and does not replace or recreate a concept topic on the same subject, although the context section may include some conceptual information.
  • 3.2.2.5 steps
    The <steps> element provides the main content of a task topic. The task is described as a series of steps that the user must follow to accomplish the task. At least one <step> element is required inside the <steps> element.
  • 3.2.2.6 steps-informal
    The <steps-informal> element allows authors to describe procedural task information without placing each step in an individual container element, which is a requirement of the related <steps> and <steps-unordered> elements. For example, <steps-informal> may contain a paragraph that describes more than one step in a single sentence, or it may contain sentences that mix steps together with information about the steps.
  • 3.2.2.7 steps-unordered
    Like the <steps> element, the <steps-unordered> element provides the main content of a task topic, but particularly for cases in which the order of steps may vary from one situation to another. At least one <step> element is required inside the <steps-unordered> element.
  • 3.2.2.8 step
    The <step> element represents an action that a user must follow to accomplish a task. Each step in a task must contain a command <cmd> element which describes the particular action the user must do to accomplish the overall task. Beginning with DITA 1.2, it is possible to place a <note> element before the command in order to notify the user of dangers or other important information about the step. The <step> element can also contain additional optional information about the step, such as substeps, a list of choices, or result information.
  • 3.2.2.9 stepsection
    The <stepsection> element provides expository text before a step element. Although the element is specialized from <li> and has the same content model as a list item, it is not intended to represent a step in a task.
  • 3.2.2.10 cmd
    The <cmd> element specifies a command, which is a required element inside the <step> element. It provides the active voice instruction to the user for completing the step, and should not be more than one sentence. If the step needs additional explanation, place the explanation in an <info> element following the <cmd>.
  • 3.2.2.11 info
    The <info> element occurs inside a <step> element to provide additional information about the step.
  • 3.2.2.12 substeps
    The <substeps> element allows you to break a step down into a series of separate actions, and should be used only if necessary. Try to describe the steps of a task in a single level of steps. If you need to use more than one level of substep nesting, you should probably rewrite the task to simplify it.
  • 3.2.2.13 substep
    A <substep> element has the same structure as a <step>, except that it does not allow lists of choices or substeps within it, in order to prevent unlimited nesting of steps.
  • 3.2.2.14 stepxmp
    The <stepxmp> element is used to illustrate a step of a task. The step example can be a couple of words, or an entire paragraph.
  • 3.2.2.15 choicetable
    The <choicetable> element contains a series of optional choices available within a step of a task.
  • 3.2.2.16 chhead
    The <chhead> element is a container inside the <choicetable> element that provides specific heading text to override the default Options and Description headings. The <chhead> element contains both a <choptionhd> and <chdeschd> element as a pair.
  • 3.2.2.17 choptionhd
    The <choptionhd> element provides a specific label for the list of options from which a user chooses in order to accomplish a step. The default label for options is a localized translation of Option.
  • 3.2.2.18 chdeschd
    The <chdeschd> element provides a specific label for the list of descriptions of options from which a user must choose in order to accomplish a step. The default label overridden by <chdeschd> is a localized translation of Description.
  • 3.2.2.19 chrow
    The <chrow> element is a container inside the <choicetable> element. The <chrow> element contains both a <choption> and <chdesc> element as a pair.
  • 3.2.2.20 choption
    The <choption> element describes an option that a user could choose to accomplish a step of a task. In a user interface, for example, this might be the name of radio button.
  • 3.2.2.21 chdesc
    The <chdesc> element is a description of an option that a user chooses while performing a step to accomplish a task. It explains why the user would choose that option and might explain the result of the choice when it is not immediately obvious.
  • 3.2.2.22 choices
    The <choices> element contains a list of <choice> elements. It is used when the user will need to choose one of several actions while performing the steps of a task.
  • 3.2.2.23 choice
    Each <choice> element describes one way that the user could accomplish the current step.
  • 3.2.2.24 stepresult
    The <stepresult> element provides information on the expected outcome of a step. If a user interface is being documented, the outcome could describe a dialog box opening or the appearance of a progress indicator. Step results are useful to assure a user that they are on track, but should not be used for every step as this quickly becomes tedious.
  • 3.2.2.25 tutorialinfo
    The <tutorialinfo> element contains additional information that is useful when the task is part of a tutorial.
  • 3.2.2.26 result
    The <result> element describes the expected outcome for the task as a whole.
  • 3.2.2.27 postreq
    The <postreq> element describes steps or tasks that the user should do after the successful completion of the current task. It is often supported by links to the next task or tasks in the <related-links> section.
Parent topic: 3.2 Technical content elements
Previous topic: 3.2.1.3 conbodydiv
Next topic: 3.2.2.1 task


task

3.2.2.1 task

The <task> element is the top-level element for a task topic. Tasks are the main building blocks for task-oriented user assistance. They generally provide step-by-step instructions that will enable a user to perform a task. A task answers the question of "how to?" by telling the user precisely what to do and the order in which to do it. Tasks have the same high-level structure as other topics, with a title, short description and body.

Note: Beginning with DITA 1.2, there are two task models available in the DTD and Schema packages distributed by OASIS. One model, referred to as the general task, allows two additional elements inside the task body (<section> and <steps-informal>); it also allows multiple instances and orders for each element within <taskbody>. The second model, referred to as the strict task, maintains the order and cardinality of the DITA 1.0 and 1.1 taskbody. This strict task is implemented in the DTD and Schema with a constraint module.

See the taskbody description for additional details about the two models and for a description of impacts to DITA 1.1 documents.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (taskbody) (optional) then (related-links) (optional) then (topic or concept or task or reference or glossentry or glossgroup) (any number) )
task, machineryTask | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (taskbody) (optional) then (related-links) (optional) then (task) (any number) )
learningContent | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (taskbody) (optional) then (related-links) (optional) then ( (no-topic-nesting) (optional) ) (any number) )

Contained by

Doctype | Content model
ditabase | dita, topic, concept, task, reference
task (strict), task (general), machineryTask | task
learningContent | learningContent

Inheritance

- topic/topic task/task

Example

<task id="sqlj">
 <title>Creating an SQLJ file</title>
 <taskbody>
  <context>Once you have set up SQLJ, you need to create a new SQLJ file.
  </context>
  <steps>
   <step><cmd>Open...</cmd></step>
  </steps>
 </taskbody>
</task>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2 Task elements
Next topic: 3.2.2.2 taskbody


taskbody

3.2.2.2 taskbody

The <taskbody> element is the main body-level element inside a task topic. A task body is designed to contain information specific to completing a task, such as prerequisites, contextual information, and steps. DITA 1.2 introduces a much looser <taskbody> content model in order to allow for more variations in the structure of a task. A constraint module is also provided in order to maintain compatibility with the previous strict model; this constraint is used in the default task distributed by OASIS.

Note: Beginning with DITA 1.2, there are two task models available in the DTD and Schema packages distributed by OASIS. One model, referred to as the general task, allows two additional elements inside the task body (<section> and <steps-informal>); it also allows multiple instances and orders for each element within <taskbody>. The second model, referred to as the strict task, maintains the order and cardinality of the DITA 1.0 and 1.1 taskbody. This strict task is implemented in the DTD and Schema with a constraint module.

Authors that use the default task DTD or Schema provided by OASIS will continue to see the strict task model when upgrading to DITA 1.2. Authors wishing to use the general task model will need to migrate their DITA 1.1 documents to reference the general task DTD or Schema.

DITA document type shells that include the task module as-is, or that specialize the <task> element without specializing <taskbody>, will also need to include the strict taskbody constraint module in order to maintain the order and cardinality of prior DITA versions.

Task specializations that specialize the <taskbody> element will not be affected by the new model, although they may be updated as needed to take advantage of the new elements.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task (strict) | ( (prereq) (optional) then (context) (optional) then (steps or steps-unordered) (optional) then (result) (optional) then (example) (optional) then (postreq) (optional) )
task (general), learningContent | ( ( (prereq) or (context) or (section) ) (any number) then ( (steps or steps-unordered or steps-informal) ) (optional) then (result) (optional) then (example) (any number) then (postreq) (any number) )
machineryTask | ( ( (prelreqs) or (context) or (section) ) (any number) then ( (steps or steps-unordered or steps-informal) ) (optional) then (result) (optional) then (example) (any number) then (closereqs) (optional) )

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | task

Inheritance

- topic/body task/taskbody

Example

See task.

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.1 task
Next topic: 3.2.2.3 prereq


prereq

3.2.2.3 prereq

The <prereq> element of a task contains prerequisites that the user needs to know or do before starting the current task. Implementations may, but need not, render prerequisite links from the related-links section together with the <prereq> content.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), learningContent | taskbody

Inheritance

- topic/section task/prereq

Example

<task id="sqlj">
 <title>Creating an SQLJ file</title>
 <taskbody>
  <prereq>Before creating a new SQLJ file, you must
  log in to the SQLJ server.</prereq>
 </taskbody>
</task>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.2 taskbody
Next topic: 3.2.2.4 context


context

3.2.2.4 context

The <context> element provides background information for a task. This information helps the user understand what the purpose of the task is and what they will gain by completing the task. This section should be brief and does not replace or recreate a concept topic on the same subject, although the context section may include some conceptual information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | taskbody

Inheritance

- topic/section task/context

Example

<task id="sqlj">
<title>Creating an SQLJ file</title>
<taskbody>
<context>Once you have set up SQLJ, you need to create a new SQLJ file.
</context>
</taskbody>
</task>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.3 prereq
Next topic: 3.2.2.5 steps


steps

3.2.2.5 steps

The <steps> element provides the main content of a task topic. The task is described as a series of steps that the user must follow to accomplish the task. At least one <step> element is required inside the <steps> element.

Steps with only a single step may be rendered as a paragraph rather than as a list. Two or more steps should typically be rendered as an ordered list. If all of the contained steps are simple (that is, have no more than a <cmd> element each) then the step list should default to compact. Otherwise it should be rendered as expanded (with blank lines between each step).

Note: Beginning with DITA 1.2, the general task model allows multiple <steps> and <steps-unordered> elements. However, the default task model in the OASIS distribution (known as strict task) continues to allow only one <steps> or one <steps-unordered> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask, learningContent | ( (stepsection) (optional) then (step) ) (one or more)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | taskbody

Inheritance

- topic/ol task/steps

Example

<task id="sqlj">
<title>Creating an SQLJ file</title>
 <taskbody>
 <context>Once you have set up SQLJ, you need to create a new SQLJ file.</context>
  <steps>
   <step>
    <cmd>In a text editor, create a new file.</cmd>
   </step>
   <step>
    <cmd>Enter the first query statement.</cmd>
   </step>
  </steps>
 </taskbody>
</task>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.4 context
Next topic: 3.2.2.6 steps-informal


steps-informal

3.2.2.6 steps-informal

The <steps-informal> element allows authors to describe procedural task information without placing each step in an individual container element, which is a requirement of the related <steps> and <steps-unordered> elements. For example, <steps-informal> may contain a paragraph that describes more than one step in a single sentence, or it may contain sentences that mix steps together with information about the steps.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
task (general), machineryTask, learningContent | taskbody

Inheritance

- topic/section task/steps-informal

Example

<steps-informal>
 <p>Put the soil in the container any old way. It doesn't really matter how
you do it as long as it is at least 12 cm deep. Once the soil is in place,
water appropriately and wait.</p>
</steps-informal>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.5 steps
Next topic: 3.2.2.7 steps-unordered


steps-unordered

3.2.2.7 steps-unordered

Like the <steps> element, the <steps-unordered> element provides the main content of a task topic, but particularly for cases in which the order of steps may vary from one situation to another. At least one <step> element is required inside the <steps-unordered> element.

Steps with only a single step may be rendered as a paragraph rather than as a list. Two or more steps should typically be rendered as an unordered list. If all of the contained steps are simple (that is, have no more than a <cmd> element each) then the step list should default to compact. Otherwise it should be rendered as expanded (with blank lines between each step).

Note: Beginning with DITA 1.2, the general task model allows multiple <steps> and <steps-unordered> elements. However, the default task model in the OASIS distribution (known as strict task) continues to allow only one <steps> or one <steps-unordered> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask, learningContent | ( (stepsection) (optional) then (step) ) (one or more)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | taskbody

Inheritance

- topic/ul task/steps-unordered

Example

<task id="sqlj">
 <title>Creating an SQLJ file</title>
 <taskbody>
  <context>Once you have set up SQLJ, you need to create a new SQLJ file.</context>
  <steps-unordered>
   <step><cmd>In a text editor, create a new file.</cmd></step>
  </steps-unordered>
 </taskbody>
</task>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.6 steps-informal
Next topic: 3.2.2.8 step


step

3.2.2.8 step

The <step> element represents an action that a user must follow to accomplish a task. Each step in a task must contain a command <cmd> element which describes the particular action the user must do to accomplish the overall task. Beginning with DITA 1.2, it is possible to place a <note> element before the command in order to notify the user of dangers or other important information about the step. The <step> element can also contain additional optional information about the step, such as substeps, a list of choices, or result information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask | ( (note or hazardstatement) (any number) then cmd then (choices or choicetable or info or itemgroup or stepxmp or substeps or tutorialinfo) (any number) then (stepresult) (optional) )
learningContent | ( (note or lcInstructornote) (any number) then cmd then (choices or choicetable or info or itemgroup or stepxmp or substeps or tutorialinfo) (any number) then (stepresult) (optional) )

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | steps, steps-unordered

Inheritance

- topic/li task/step

Example

<task id="sqlj">
<title>Creating an SQLJ file</title>
<taskbody>
<context>Once you have set up SQLJ, you need to create a new SQLJ file.
</context>
<steps>
<step>
 <cmd>Select <menucascade><uicontrol>File</uicontrol><uicontrol>New</uicontrol></menucascade>.</cmd>
 <info>New files are created with default values based on a standard template.</info>
</step>
</steps>
</taskbody>
</task>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | Describes whether the current step or substep is optional or required. Output processors may (but need not) highlight steps that are optional or required. | optional | required | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.7 steps-unordered
Next topic: 3.2.2.9 stepsection


stepsection

3.2.2.9 stepsection

The <stepsection> element provides expository text before a step element. Although the element is specialized from <li> and has the same content model as a list item, it is not intended to represent a step in a task.

Note: DITA applications which render <stepsection> elements among the <step> elements must provide a way to number the steps without numbering the <stepsection> elements (although this does not need to be the only or default presentation).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | steps, steps-unordered

Inheritance

- topic/li task/stepsection

Example

<steps>
  <step><cmd>Get out a bowl</cmd></step>
  <stepsection>The next two steps are very important!</stepsection>
  <step><cmd>Put on safety gloves</cmd></step>
  <step><cmd>Put on goggles</cmd></step>
  <step><cmd>Pour milk and cereal into the bowl</cmd></step>
</steps>

The sample above would typically be rendered with "Get out a bowl" as step number one, "Put on safety gloves" as step number two, and "The next two steps are very important!" as an unnumbered item in between the first two items.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.8 step
Next topic: 3.2.2.10 cmd


cmd

3.2.2.10 cmd

The <cmd> element specifies a command, which is a required element inside the <step> element. It provides the active voice instruction to the user for completing the step, and should not be more than one sentence. If the step needs additional explanation, place the explanation in an <info> element following the <cmd>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | step, substep

Inheritance

- topic/ph task/cmd

Example

<step><cmd>In a text editor, create a new file.</cmd></step>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.9 stepsection
Next topic: 3.2.2.11 info


info

3.2.2.11 info

The <info> element occurs inside a <step> element to provide additional information about the step.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | step, substep

Inheritance

- topic/itemgroup task/info

Example

<step><cmd>Type a name for the widget.</cmd>
<info>The widget name is created when you configure the widget
in the Widget Configuration Dialog. It is not an actual class
name or file name, just a label for the widget as used in this
application.</info>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.10 cmd
Next topic: 3.2.2.12 substeps


substeps

3.2.2.12 substeps

The <substeps> element allows you to break a step down into a series of separate actions, and should be used only if necessary. Try to describe the steps of a task in a single level of steps. If you need to use more than one level of substep nesting, you should probably rewrite the task to simplify it.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask, learningContent | (substep) (one or more)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | step

Inheritance

- topic/ol task/substeps

Example

<substeps>
<substep><cmd>Hold pencil in a steady, level position.</cmd></substep>
<substep><cmd>Turn handle until resistance diminishes.</cmd>
<info>Note: initially, it may be somewhat difficult to turn the handle if
pencil has never been sharpened before.</info></substep>
<substep><cmd>To determine if pencil is sharp, remove it from the sharpener
and inspect the tip.</cmd></substep>
</substeps>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.11 info
Next topic: 3.2.2.13 substep


substep

3.2.2.13 substep

A <substep> element has the same structure as a <step>, except that it does not allow lists of choices or substeps within it, in order to prevent unlimited nesting of steps.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask | ( (note or hazardstatement) (any number) then cmd then (info or itemgroup or stepxmp or tutorialinfo) (any number) then (stepresult) (optional) )
learningContent | ( (note or lcInstructornote) (any number) then cmd then (info or itemgroup or stepxmp or tutorialinfo) (any number) then (stepresult) (optional) )

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | substeps

Inheritance

- topic/li task/substep

Example

See substeps.

Attributes

Name | Description | Data Type | Default Value | Required?
importance | Describes whether the current step or substep is optional or required. Output processors may (but need not) highlight steps that are optional or required. | optional | required | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.12 substeps
Next topic: 3.2.2.14 stepxmp


stepxmp

3.2.2.14 stepxmp

The <stepxmp> element is used to illustrate a step of a task. The step example can be a couple of words, or an entire paragraph.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | step, substep

Inheritance

- topic/itemgroup task/stepxmp

Example

<step>
 <cmd>Type a name for the widget.</cmd>
 <stepxmp>For example, <userinput>mywidget</userinput></stepxmp>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.13 substep
Next topic: 3.2.2.15 choicetable


choicetable

3.2.2.15 choicetable

The <choicetable> element contains a series of optional choices available within a step of a task.

By default, processors should highlight the choice column is bold. To change the highlighting, set the keycol attribute of the <choicetable> tag to 0 (zero).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask, learningContent | ( (chhead) (optional) then (chrow) (one or more) )

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | step

Inheritance

- topic/simpletable task/choicetable

<step><cmd>Then this</cmd>
<substeps>
<substep importance="optional"><cmd>which is done by doing this</cmd></substep>
<substep importance="required"><cmd>and then this.</cmd></substep>
</substeps>
<choicetable>
<chhead>
<choptionhd>Do something</choptionhd>
<chdeschd>Or Else this</chdeschd>
</chhead>
<chrow><choption>Do this</choption>
<chdesc>and this will happen</chdesc></chrow>
<chrow><choption>Do that</choption>
<chdesc>and that will happen</chdesc></chrow>
</choicetable>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
relcolwidth A relative value to specify the width of a column in relationship to the width of the other columns. The values are totaled and made a percent. For example:
relcolwidth="1* 2* 3*"
causes widths of 16.7%, 33.3%, and 66.7%.
relcolwidth="90* 150*"
causes width of 37.5% and 62.5%. 		CDATA #IMPLIED No
keycol | Defines the column that will be used for row headings. By default, the first column is used. To indicate that no column in the table is the key column, set the attribute to 0. | NMTOKEN | 1 | No
refcols | The refcols attribute is currently undefined, and is reserved for future use. | NMTOKENS | #IMPLIED | No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.14 stepxmp
Next topic: 3.2.2.16 chhead


chhead

3.2.2.16 chhead

The <chhead> element is a container inside the <choicetable> element that provides specific heading text to override the default Options and Description headings. The <chhead> element contains both a <choptionhd> and <chdeschd> element as a pair.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask, learningContent | ( (choptionhd) then (chdeschd) )

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | choicetable

Inheritance

- topic/sthead task/chhead

Example

<step><cmd>Then this</cmd>
 <substeps>
  <substep importance="optional"><cmd>which is done by doing this</cmd></substep>
  <substep importance="required"><cmd>and then this.</cmd></substep>
 </substeps>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.15 choicetable
Next topic: 3.2.2.17 choptionhd


choptionhd

3.2.2.17 choptionhd

The <choptionhd> element provides a specific label for the list of options from which a user chooses in order to accomplish a step. The default label for options is a localized translation of Option.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | chhead

Inheritance

- topic/stentry task/choptionhd

Example

<step><cmd>Then this</cmd>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>And this happens</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.16 chhead
Next topic: 3.2.2.18 chdeschd


chdeschd

3.2.2.18 chdeschd

The <chdeschd> element provides a specific label for the list of descriptions of options from which a user must choose in order to accomplish a step. The default label overridden by <chdeschd> is a localized translation of Description.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | chhead

Inheritance

- topic/stentry task/chdeschd

Example

<step><cmd>Then this</cmd>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.17 choptionhd
Next topic: 3.2.2.19 chrow


chrow

3.2.2.19 chrow

The <chrow> element is a container inside the <choicetable> element. The <chrow> element contains both a <choption> and <chdesc> element as a pair.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask, learningContent | ( (choption) then (chdesc) )

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | choicetable

Inheritance

- topic/strow task/chrow

Example

<step><cmd>Then this</cmd>
 <substeps>
  <substep importance="optional"><cmd>which is done by doing this</cmd></substep>
  <substep importance="required"><cmd>and then this.</cmd></substep>
 </substeps>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>Or Else this</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
  <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
  <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.18 chdeschd
Next topic: 3.2.2.20 choption


choption

3.2.2.20 choption

The <choption> element describes an option that a user could choose to accomplish a step of a task. In a user interface, for example, this might be the name of radio button.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | chrow

Inheritance

- topic/stentry task/choption

Example

<step><cmd>Then this</cmd>
 <choicetable>
  <chhead>
   <choptionhd>Do something</choptionhd>
   <chdeschd>And this happens</chdeschd>
  </chhead>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.19 chrow
Next topic: 3.2.2.21 chdesc


chdesc

3.2.2.21 chdesc

The <chdesc> element is a description of an option that a user chooses while performing a step to accomplish a task. It explains why the user would choose that option and might explain the result of the choice when it is not immediately obvious.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or sl or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | chrow

Inheritance

- topic/stentry task/chdesc

Example

<step><cmd>Then this</cmd>
 <substeps>
  <substep importance="optional"><cmd>which is done by doing this</cmd></substep>
  <substep importance="required"><cmd>and then this.</cmd></substep>
 </substeps>
 <choicetable>
  <chrow><choption>Do this</choption>
     <chdesc>and this will happen</chdesc></chrow>
  <chrow><choption>Do that</choption>
     <chdesc>and that will happen</chdesc></chrow>
 </choicetable>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.20 choption
Next topic: 3.2.2.22 choices


choices

3.2.2.22 choices

The <choices> element contains a list of <choice> elements. It is used when the user will need to choose one of several actions while performing the steps of a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task, machineryTask, learningContent | (choice) (one or more)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | step

Inheritance

- topic/ul task/choices

Example

<step><cmd>Choose a server.</cmd>
<choices>
<choice>If you have a remote server you want to test on, type the
IP address or hostname of the server here.</choice>
<choice>If you want to do local testing, just type localhost.</choice>
</choices>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.21 chdesc
Next topic: 3.2.2.23 choice


choice

3.2.2.23 choice

Each <choice> element describes one way that the user could accomplish the current step.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | choices

Inheritance

- topic/li task/choice

Example

<step><cmd>Choose a server.</cmd>
  <choices>
    <choice>If you have a remote server you want to test on, type the
IP address or hostname of the server here.</choice>
    <choice>If you want to do local testing, just type localhost.</choice>
  </choices>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.22 choices
Next topic: 3.2.2.24 stepresult


stepresult

3.2.2.24 stepresult

The <stepresult> element provides information on the expected outcome of a step. If a user interface is being documented, the outcome could describe a dialog box opening or the appearance of a progress indicator. Step results are useful to assure a user that they are on track, but should not be used for every step as this quickly becomes tedious.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | step, substep

Inheritance

- topic/itemgroup task/stepresult

Example

<steps>
 <step>
  <cmd importance="urgent">Once you have the water place it in the microwave.</cmd>
  <info>Try not to spill any, as water is very wet.</info>
 </step>
 <step importance="required">
  <cmd>Start the Microwave.</cmd>
  <stepxmp>As an example, push the <b>Start</b> button</stepxmp>
  <stepresult>The Microwave starts running. You should hear it humming.</stepresult>
 </step>
 <step importance="optional">
  <cmd>Once the water begins to boil, stop the Microwave.</cmd>
 </step>
</steps>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.23 choice
Next topic: 3.2.2.25 tutorialinfo


tutorialinfo

3.2.2.25 tutorialinfo

The <tutorialinfo> element contains additional information that is useful when the task is part of a tutorial.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | step, substep

Inheritance

- topic/itemgroup task/tutorialinfo

Example

<steps>
 <step>
  <cmd>Do this</cmd>
  <tutorialinfo>In your editor, open the first element and click on
  the dialog.</tutorialinfo>
 </step>
 <step>
  <cmd>Do that</cmd>
  <tutorialinfo>Move the framulator into the foobar box.</tutorialinfo>
 </step>
</steps>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.24 stepresult
Next topic: 3.2.2.26 result


result

3.2.2.26 result

The <result> element describes the expected outcome for the task as a whole.

Note: To describe the outcome of specific step, use the <stepresult> element instead.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), machineryTask, learningContent | taskbody

Inheritance

- topic/section task/result

Example

<task id="sqlj">
 <titleCreating an SQLJ file</title>
 <taskbody>
  <context>Once you have set up SQLJ, you need to create a new SQLJ file.
  You cannot add #sqlj statements directly in the Source pane of the
  Workbench.</context>
  <result>The SQLJ file is successfully created when the SQLJ server
  displays the "File Created" dialog.</result>
 </taskbody>
</task>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.25 tutorialinfo
Next topic: 3.2.2.27 postreq


postreq

3.2.2.27 postreq

The <postreq> element describes steps or tasks that the user should do after the successful completion of the current task. It is often supported by links to the next task or tasks in the <related-links> section.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, task | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, task (strict), task (general), learningContent | taskbody

Inheritance

- topic/section task/postreq

Example

<postreq>Notify the proctor upon completing this self-test.</postreq>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.2 Task elements
Previous topic: 3.2.2.26 result
Next topic: 3.2.3 Reference elements


Reference elements

3.2.3 Reference elements

Reference topics describe factual material about a subject, such as the commands in a programming language. This format is also suitable for bibliographies, catalogues, the list of ingredients for recipes, and similar collections of structured descriptive prose. For more details on when to use reference and other information types, please refer to the DITA architectural specification.

  • 3.2.3.1 reference
    The <reference> element defines a top-level container for a reference topic. Reference topics document programming constructs or facts about a product. Examples of reference topics include (but are not limited to) product specifications, environmental specifications, equipment lists, parts lists, required tools, language elements, class descriptions, commands, functions, and API information. All of these items provide quick access to facts, but no deeper explanation of related concepts or tasks. Reference topics have the same high-level structure as any other topic type, with a title, short description, and body. Within the body, reference topics are typically organized into one or more sections, property lists, and tables. The reference topic type provides general rules that apply to all kinds of reference information, using elements like <refsyn> for syntax or signatures, and <properties> for lists of properties and values.
  • 3.2.3.2 refbody
    The <refbody> element is a container for the main content of the reference topic. Reference topics limit the body structure to tables (both simple and standard), property lists, syntax sections, and generic sections and examples, in any sequence or number.
  • 3.2.3.3 refbodydiv
    The <refbodydiv> element is similar to the <bodydiv> element in that it provides an informal container for content that may be grouped within a reference. Reference topics place many restrictions on their content compared to generic topics; the <refbodydiv> element maintains these restrictions by only allowing elements that are already available within the body of a reference. There are no additional semantics attached to the <refbodydiv> element; it is purely a grouping element provided to help organize content.
  • 3.2.3.4 refsyn
    The <refsyn> element is a special section inside a reference topic. The section often contains syntax or signature content (for example, a command-line utility's calling syntax, or an API's signature). The <refsyn> contains a brief, possibly diagrammatic description of the subject's interface or high-level structure.
  • 3.2.3.5 properties
    The <properties> element gives a list of properties for the subject of the current topic, for example whether a class is public or protected. Each property can include the type, value, and a description. The typical rendering is usually in a table-like format. To represent multiple values for a single type, create additional property elements and use only the <propvalue> element (and <propdesc> when needed) for each successive value.
  • 3.2.3.6 prophead
    The prophead element supports headings for the properties element.
  • 3.2.3.7 proptypehd
    The proptypehd element supports headings for the type column of a properties table.
  • 3.2.3.8 propvaluehd
    The propvaluehd element supports headings for the value column of a properties table.
  • 3.2.3.9 propdeschd
    The propdeschd element supports headings for the description column of a properties table.
  • 3.2.3.10 property
    The <property> element represents a single property of the current topic's subject. For example, if the current reference topic describes a programming class, the property might show that the class is protected rather than public. The <property> element generally appears together with a series of other properties; it contains three optional elements to provide a type, value, or description of the property.
  • 3.2.3.11 proptype
    The <proptype> element describes the type of the property.
  • 3.2.3.12 propvalue
    The <propvalue> element indicates one or more values for the current property type. Values may be placed separate <property> elements if they need separate descriptions. The <proptype> attribute need not be repeated.
  • 3.2.3.13 propdesc
    The <propdesc> element is used to provide a short description of the property type and its listed values.
Parent topic: 3.2 Technical content elements
Previous topic: 3.2.2.27 postreq
Next topic: 3.2.3.1 reference


reference

3.2.3.1 reference

The <reference> element defines a top-level container for a reference topic. Reference topics document programming constructs or facts about a product. Examples of reference topics include (but are not limited to) product specifications, environmental specifications, equipment lists, parts lists, required tools, language elements, class descriptions, commands, functions, and API information. All of these items provide quick access to facts, but no deeper explanation of related concepts or tasks. Reference topics have the same high-level structure as any other topic type, with a title, short description, and body. Within the body, reference topics are typically organized into one or more sections, property lists, and tables. The reference topic type provides general rules that apply to all kinds of reference information, using elements like <refsyn> for syntax or signatures, and <properties> for lists of properties and values.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (refbody) (optional) then (related-links) (optional) then (topic or concept or task or reference or glossentry or glossgroup) (any number) )
reference | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (refbody) (optional) then (related-links) (optional) then (reference) (any number) )
learningContent | ( (title) then (titlealts) (optional) then (abstract or shortdesc) (optional) then (prolog) (optional) then (refbody) (optional) then (related-links) (optional) then ( (no-topic-nesting) (optional) ) (any number) )

Contained by

Doctype | Content model
ditabase | dita, topic, concept, task, reference
reference | reference
learningContent | learningContent

Inheritance

- topic/topic reference/reference

Example

Figure 1. Reference topic for software material
<reference id="refexample">
  <title>A reference topic/title>
  <refbody>
    <refsyn>Describe command or api syntax here, possibly
using synph or syntax elements markup for explicit
definition of syntax or prototype construction.</refsyn>
    <section><title>Some section title</title></section>
    <properties>
      <property>
        <proptype>type</proptype>
        <propvalue>value</propvalue>
        <propdesc>description</propdesc>
      </property>
    </properties>
  </refbody>
</reference>
Figure 2. Reference topic for hardware maintenance

The following information could apply to an entire set of maintenance procedures, each of which would link to this topic.

<reference id="requiredTools">
  <title>Tools required to maintain a big machine</title>
  <refbody>
    <section>
      <title>Small tools</title>
          <ul>
        <li>Hard hat</li>
        <li>Hammer</li>
        <li>Nail</li>
        <li>Metal polish</li>
        <!-- .... -->
      </ul>
    </section>
    <section>
      <title>Expensive tools</title>
      ...
    </section>
  </refbody>
</reference>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3 Reference elements
Next topic: 3.2.3.2 refbody


refbody

3.2.3.2 refbody

The <refbody> element is a container for the main content of the reference topic. Reference topics limit the body structure to tables (both simple and standard), property lists, syntax sections, and generic sections and examples, in any sequence or number.

Reference topics represent the kind of information that users typically consult to understand programming objects, configuration file options, recipes, terminological descriptions, product or other specifications, equipment or parts lists, or any other set of factual information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference, learningContent | (data or data-about or example or foreign or unknown or refbodydiv or refsyn or properties or section or simpletable or table) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | reference

Inheritance

- topic/body reference/refbody

Example

See reference.

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.1 reference
Next topic: 3.2.3.3 refbodydiv


refbodydiv

3.2.3.3 refbodydiv

The <refbodydiv> element is similar to the <bodydiv> element in that it provides an informal container for content that may be grouped within a reference. Reference topics place many restrictions on their content compared to generic topics; the <refbodydiv> element maintains these restrictions by only allowing elements that are already available within the body of a reference. There are no additional semantics attached to the <refbodydiv> element; it is purely a grouping element provided to help organize content.

The <refbodydiv> element may nest itself, which means that it may be used by specializers to create structured information within a specialized reference topic. Another common use case for the <refbodydiv> element is to group a sequence of related elements for reuse, so that another topic may reference the entire set with a single conref attribute.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference, learningContent | (data or data-about or example or foreign or unknown or refbodydiv or refsyn or properties or section or simpletable or table) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | refbody, refbodydiv

Inheritance

- topic/bodydiv reference/refbodydiv

Example

<reference id="sample-refbodydiv" xml:lang="en">
 <title>Sample for refbody</title>
 <shortdesc>This shows how refbodydiv might be used.</shortdesc>
 <refbody>
  <refbodydiv id="widget1">
   <section>This is one part of the sample</section>
   <refsyn>Syntax for this part</refsyn>
  </refbodydiv>
  <refbodydiv id="widget2">
    <section>This is another part of the sample</section>
    <refsyn>Syntax for this part</refsyn>
  </refbodydiv>
 </refbody>
</reference>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.2 refbody
Next topic: 3.2.3.4 refsyn


refsyn

3.2.3.4 refsyn

The <refsyn> element is a special section inside a reference topic. The section often contains syntax or signature content (for example, a command-line utility's calling syntax, or an API's signature). The <refsyn> contains a brief, possibly diagrammatic description of the subject's interface or high-level structure.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | refbody, refbodydiv

Inheritance

- topic/section reference/refsyn

Example

Figure 1. Reference topic for software material
<reference id="MyAPI">
  <title>MyAPI/title>
  <refbody>
    <refsyn>Describe the MyAPI syntax here, possibly
using synph or syntax elements markup for explicit
definition of syntax or prototype construction.</refsyn>
  </refbody>
</reference>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.3 refbodydiv
Next topic: 3.2.3.5 properties


properties

3.2.3.5 properties

The <properties> element gives a list of properties for the subject of the current topic, for example whether a class is public or protected. Each property can include the type, value, and a description. The typical rendering is usually in a table-like format. To represent multiple values for a single type, create additional property elements and use only the <propvalue> element (and <propdesc> when needed) for each successive value.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference, learningContent | ( (prophead) (optional) then (property) (one or more) )

Contained by

Doctype | Content model
ditabase, reference, learningContent | refbody, refbodydiv

Inheritance

- topic/simpletable reference/properties

Example

<properties>
  <prophead>
        <proptypehd>Visual Element</proptypehd>
        <propvaluehd>Value</propvaluehd>
        <propdeschd>Implication</propdeschd>
  </prophead>
  <property>
    <proptype>color</proptype>
    <propvalue>red</propvalue>
    <propdesc>depicts anger</propdesc>
  </property>
  <property>
    <propvalue>green</propvalue>
    <propdesc>depicts permission</propdesc>
  </property>
</properties>

Attributes

Name | Description | Data Type | Default Value | Required?
relcolwidth A relative value to specify the width of a column in relationship to the width of the other columns. The values are totaled and made a percent. For example:
relcolwidth="1* 2* 3*"
causes widths of 16.7%, 33.3%, and 66.7%.
relcolwidth="90* 150*"
causes width of 37.5% and 62.5%. 		CDATA #IMPLIED No
keycol | Defines the column that can contains headings for each row. No value indicates no key column. When present, the numerical value causes the specified column to be treated as a vertical header. | NMTOKEN | #IMPLIED | No
refcols | The refcols attribute is currently undefined, and is reserved for future use. | NMTOKENS | #IMPLIED | No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.4 refsyn
Next topic: 3.2.3.6 prophead


prophead

3.2.3.6 prophead

The prophead element supports headings for the properties element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference, learningContent | ( (proptypehd) (optional) then (propvaluehd) (optional) then (propdeschd) (optional) )

Contained by

Doctype | Content model
ditabase, reference, learningContent | properties

Inheritance

- topic/sthead reference/prophead

Example

See the example in properties.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.5 properties
Next topic: 3.2.3.7 proptypehd


proptypehd

3.2.3.7 proptypehd

The proptypehd element supports headings for the type column of a properties table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | prophead

Inheritance

- topic/stentry reference/proptypehd

Example

See the example in properties.

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.6 prophead
Next topic: 3.2.3.8 propvaluehd


propvaluehd

3.2.3.8 propvaluehd

The propvaluehd element supports headings for the value column of a properties table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | prophead

Inheritance

- topic/stentry reference/propvaluehd

Example

See the example in properties.

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.7 proptypehd
Next topic: 3.2.3.9 propdeschd


propdeschd

3.2.3.9 propdeschd

The propdeschd element supports headings for the description column of a properties table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | prophead

Inheritance

- topic/stentry reference/propdeschd

Example

See the example in properties.

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.8 propvaluehd
Next topic: 3.2.3.10 property


property

3.2.3.10 property

The <property> element represents a single property of the current topic's subject. For example, if the current reference topic describes a programming class, the property might show that the class is protected rather than public. The <property> element generally appears together with a series of other properties; it contains three optional elements to provide a type, value, or description of the property.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference, learningContent | ( (proptype) (optional) then (propvalue) (optional) then (propdesc) (optional) )

Contained by

Doctype | Content model
ditabase, reference, learningContent | properties

Inheritance

- topic/strow reference/property

Example

See properties.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.9 propdeschd
Next topic: 3.2.3.11 proptype


proptype

3.2.3.11 proptype

The <proptype> element describes the type of the property.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | property

Inheritance

- topic/stentry reference/proptype

Example

See properties.

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.10 property
Next topic: 3.2.3.12 propvalue


propvalue

3.2.3.12 propvalue

The <propvalue> element indicates one or more values for the current property type. Values may be placed separate <property> elements if they need separate descriptions. The <proptype> attribute need not be repeated.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningContent | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | property

Inheritance

- topic/stentry reference/propvalue

Example

See properties.

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.11 proptype
Next topic: 3.2.3.13 propdesc


propdesc

3.2.3.13 propdesc

The <propdesc> element is used to provide a short description of the property type and its listed values.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, reference | ( text data or dl or parml or image or lines or lq or note or hazardstatement or ol or p or pre or codeblock or msgblock or screen or sl or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown) (any number)
learningContent | ( text data or dl or image or lines or lq or note or lcInstructornote or ol or p or pre or sl or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
ditabase, reference, learningContent | property

Inheritance

- topic/stentry reference/propdesc

Example

See properties.

Attributes

Name | Description | Data Type | Default Value | Required?
specentry | The specialized entry attribute allows architects of specialized types to define a fixed or default header title for a specialized stentry element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.3 Reference elements
Previous topic: 3.2.3.12 propvalue
Next topic: 3.2.4 Glossary elements


Glossary elements

3.2.4 Glossary elements

Glossary elements include those elements designed to specify terms and their definitions, as well as elements that are designed to group, reference, or otherwise make use of information in the glossentry topic.

  • 3.2.4.1 Glossentry elements
    Use the glossentry topic type to define glossary terms. Each glossentry topic should define a single sense of a term.
  • 3.2.4.2 Glossary related elements
    Elements related to the glossary specialization are not defined as part of the glossary topic type, but are often used in conjunction with those elements.
Parent topic: 3.2 Technical content elements
Previous topic: 3.2.3.13 propdesc
Next topic: 3.2.4.1 Glossentry elements


Glossentry elements

3.2.4.1 Glossentry elements

Use the glossentry topic type to define glossary terms. Each glossentry topic should define a single sense of a term.

  • 3.2.4.1.1 glossentry
    The <glossentry> element defines a single sense of a glossary term. Glossary entries for different term senses can be reused independently of one another. DITA 1.2 adds several elements to the glossentry topic type, allowing it to specify additional information about a term (beyond just the definition).
  • 3.2.4.1.2 glossterm
    The <glossterm> element specifies the preferred term associated with a definition of a sense. If the same term has multiple senses, create a separate <glossentry> topic for each sense.
  • 3.2.4.1.3 glossdef
    The <glossdef> element specifies the definition of one sense of a term. If a term has multiple senses, create a separate <glossentry> topic to define each sense.
  • 3.2.4.1.4 glossAbbreviation
    The <glossAbbreviation> element provides an abbreviated form of the term contained in a <glossterm> element.
  • 3.2.4.1.5 glossAcronym
    The <glossAcronym> element defines an acronym as an alternate form for the term defined in the <glossterm> element.
  • 3.2.4.1.6 glossAlt
    The <glossAlt> element contains a variant term for the preferred term. The variant should have the same meaning as the term in the <glossterm> element; the variant is simply another way to refer to the same term. There may be many ways to refer to a term; each variant is placed in its own <glossAlt> element. The <glossUsage> element may be used within <glossAlt> to indicate when use of the alternate term is appropriate.
  • 3.2.4.1.7 glossAlternateFor
    The <glossAlternateFor> element indicates when a variant term has a relationship to another variant term as well as to the preferred term.
  • 3.2.4.1.8 glossBody
    The <glossbody> element is used to provide details about a glossary term (such as part of speech or additional forms of the term).
  • 3.2.4.1.9 glossPartOfSpeech
    The <glossPartOfSpeech> element identifies the part of speech for the preferred and alternate terms. Alternate terms must have the same part of speech as the preferred term because all terms in the glossentry topic designate the same subject. If the part of speech isn't specified, the default is a noun for the standard enumeration.
  • 3.2.4.1.10 glossProperty
    The <glossProperty> element is an extension point which allows additional details about the preferred term or its subject.
  • 3.2.4.1.11 glossScopeNote
    The <glossScopeNote> element contains a clarification of the subject designated by the <glossterm>, such as examples of included or excluded companies or products. For instance, a scope note for "Linux" might explain that the term doesn't apply to UNIX products and may give some examples of Linux products that are included as well as UNIX products that are excluded.
  • 3.2.4.1.12 glossShortForm
    The <glossShortForm> element provides a shorter alternative to the primary term specified in the <glossterm> element.
  • 3.2.4.1.13 glossStatus
    Identifies the usage status of a preferred or alternate term. If the status isn't specified, the <glossterm> provides a preferred term and an alternate term provides an allowed term.
  • 3.2.4.1.14 glossSurfaceForm
    The <glossSurfaceForm> element specifies an unambiguous presentation of the <glossterm> that may combine multiple forms. The surface form is suitable to introduce the term in new contexts.
  • 3.2.4.1.15 glossSymbol
    The <glossSymbol> element identifies a standard image associated with the subject of the <glossterm>.
  • 3.2.4.1.16 glossSynonym
    Provides a term that is a synonym of the primary value in the <glossterm> element.
  • 3.2.4.1.17 glossUsage
    The <glossUsage> element provides information about the correct use of a term, such as where or how it can be used.
Parent topic: 3.2.4 Glossary elements
Previous topic: 3.2.4 Glossary elements
Next topic: 3.2.4.1.1 glossentry


glossentry

3.2.4.1.1 glossentry

The <glossentry> element defines a single sense of a glossary term. Glossary entries for different term senses can be reused independently of one another. DITA 1.2 adds several elements to the glossentry topic type, allowing it to specify additional information about a term (beyond just the definition).

The recommended (but not required) book processing is to sort and group glossary entries based on the localized term so a back-of-the-book glossary can contain a collated list of terms with the definitions of the individual senses of each term indented under the term. The glossary can have a different organization in different languages depending on the translation of the terms. One possible implementation of a glossary in online processing is to associate a hotspot for mentions of terms in <term> elements and display the definition on hover or click.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( (glossterm) then (glossdef) (optional) then (prolog) (optional) then (glossBody) (optional) then (related-links) (optional) then (no-topic-nesting) (any number) )

Contained by

Doctype | Content model
ditabase | dita, topic, concept, task, reference, glossgroup
glossgroup | glossgroup

Inheritance

- topic/topic concept/concept glossentry/glossentry

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1 Glossentry elements
Next topic: 3.2.4.1.2 glossterm


glossterm

3.2.4.1.2 glossterm

The <glossterm> element specifies the preferred term associated with a definition of a sense. If the same term has multiple senses, create a separate <glossentry> topic for each sense.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or data or data-about or foreign or unknown or image) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossentry

Inheritance

- topic/title concept/title glossentry/glossterm

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.1 glossentry
Next topic: 3.2.4.1.3 glossdef


glossdef

3.2.4.1.3 glossdef

The <glossdef> element specifies the definition of one sense of a term. If a term has multiple senses, create a separate <glossentry> topic to define each sense.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or shortdesc or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossentry

Inheritance

- topic/abstract concept/abstract glossentry/glossdef

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.2 glossterm
Next topic: 3.2.4.1.4 glossAbbreviation


glossAbbreviation

3.2.4.1.4 glossAbbreviation

The <glossAbbreviation> element provides an abbreviated form of the term contained in a <glossterm> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or tm) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossAlt

Inheritance

- topic/title concept/title glossentry/glossAbbreviation

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.3 glossdef
Next topic: 3.2.4.1.5 glossAcronym


glossAcronym

3.2.4.1.5 glossAcronym

The <glossAcronym> element defines an acronym as an alternate form for the term defined in the <glossterm> element.

This element may be used together with the <abbreviated-form> element to display an expanded version of an acronym the first time that acronym appears in a set of text. See <abbreviated-form> for information on how the two elements interact.

Note: Several issues arise when acronyms are translated into other languages. For example, an acronym in one language may not have an equivalent in another language. When acronyms are first displayed, some languages will display the expanded form first followed by the acronym in parenthesis, while other languages do the reverse. For some acronyms, a translation may need to render both the original and the translated version of the acronym. For all of these reasons, DITA allows an author or translator to control what is presented to a reader by using the <glossSurfaceForm> element, which will often accompany the <glossAcronym>. The <abbreviated-form> topic contains information on how the <glossSurfaceForm> and <glossAcronym> elements affect references to the primary term.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or tm) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossAlt

Inheritance

- topic/title concept/title glossentry/glossAcronym

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.4 glossAbbreviation
Next topic: 3.2.4.1.6 glossAlt


glossAlt

3.2.4.1.6 glossAlt

The <glossAlt> element contains a variant term for the preferred term. The variant should have the same meaning as the term in the <glossterm> element; the variant is simply another way to refer to the same term. There may be many ways to refer to a term; each variant is placed in its own <glossAlt> element. The <glossUsage> element may be used within <glossAlt> to indicate when use of the alternate term is appropriate.

Note: Any list of alternative terms is, of course, specific to the language, so translation of a glossentry topic may result in empty elements within a <glossAlt> container.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( (glossAbbreviation or glossAcronym or glossShortForm or glossSynonym) (optional) then (glossStatus) (optional) then (glossProperty) (any number) then (glossUsage) (optional) then (note or hazardstatement) (any number) then (glossAlternateFor) (any number) )

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossBody

Inheritance

- topic/section concept/section glossentry/glossAlt

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.5 glossAcronym
Next topic: 3.2.4.1.7 glossAlternateFor


glossAlternateFor

3.2.4.1.7 glossAlternateFor

The <glossAlternateFor> element indicates when a variant term has a relationship to another variant term as well as to the preferred term.

The <glossAlternateFor> element is available inside the <glossAlt> element, which is a container that provides a variant for the primary glossentry term. In some cases, the variant may also be an alternate for another term. In the example below, the abbreviation "stick" is a variant of the primary term (USB flash drive). The <glossAlternateFor> element indicates that "stick" is also a variant of the synonym "memory stick".

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | no content

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossAlt

Inheritance

- topic/xref concept/xref glossentry/glossAlternateFor

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
href | References a term for which the current variant is an alternate (in addition to the primary term of this glossentry topic). The reference will often be to another glossAlt element within the same glossentry topic, indicating that the current variant is an alternate for both the primary term and the referenced alternate term. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.6 glossAlt
Next topic: 3.2.4.1.8 glossBody


glossBody

3.2.4.1.8 glossBody

The <glossbody> element is used to provide details about a glossary term (such as part of speech or additional forms of the term).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( (glossPartOfSpeech) (optional) then (glossStatus) (optional) then (glossProperty) (any number) then (glossSurfaceForm) (optional) then (glossUsage) (optional) then (glossScopeNote) (optional) then (glossSymbol) (any number) then (note or hazardstatement) (any number) then (glossAlt) (any number) )

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossentry

Inheritance

- topic/body concept/conbody glossentry/glossBody

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.7 glossAlternateFor
Next topic: 3.2.4.1.9 glossPartOfSpeech


glossPartOfSpeech

3.2.4.1.9 glossPartOfSpeech

The <glossPartOfSpeech> element identifies the part of speech for the preferred and alternate terms. Alternate terms must have the same part of speech as the preferred term because all terms in the glossentry topic designate the same subject. If the part of speech isn't specified, the default is a noun for the standard enumeration.

Note: The standard enumeration is extensible or replaceable. If validation is required, the enumeration should be validated by means of the DITA Controlled Values mechanism or through processing rather than validated as an XML enumeration.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | no content

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossBody

Inheritance

- topic/data concept/data glossentry/glossPartOfSpeech

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies the part of speech for the term defined within this glossentry topic. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.8 glossBody
Next topic: 3.2.4.1.10 glossProperty


glossProperty

3.2.4.1.10 glossProperty

The <glossProperty> element is an extension point which allows additional details about the preferred term or its subject.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or image or object or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or title) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossBody, glossAlt

Inheritance

- topic/data concept/data glossentry/glossProperty

Example

<glossentry id="algorithm" xml:lang="es-es">
  <glossterm>El algoritmo</glossterm>
  <glossdef>Un algoritmo define un método de calcular un resultado.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossProperty name="gender" value="masculine"/>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines the name of a property that describes the glossentry term. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies the value of the primary glossary term's property. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.9 glossPartOfSpeech
Next topic: 3.2.4.1.11 glossScopeNote


glossScopeNote

3.2.4.1.11 glossScopeNote

The <glossScopeNote> element contains a clarification of the subject designated by the <glossterm>, such as examples of included or excluded companies or products. For instance, a scope note for "Linux" might explain that the term doesn't apply to UNIX products and may give some examples of Linux products that are included as well as UNIX products that are excluded.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossBody

Inheritance

- topic/note concept/note glossentry/glossScopeNote

Example

<glossentry id="linuxOS" xml:lang="en-us">
  <glossterm>Linux Operating System</glossterm>
  <glossdef>An operating system based on the kernel created by Linus Torvald.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossScopeNote>Doesn't apply to UNIX products that bundle other
kernels. Also, doesn't apply to the Linux Open Source Project that
work on Linux distributions but, instead, only to the distributions
themselves.  Examples include RedHat, SuSE, and Ubuntu. </glossScopeNote>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
type | Defines the type of a note. For example, if the note is a tip, the word Tip is used to draw the reader's attention to it. Note that this differs from the type attribute on many other DITA elements. See The type attribute for detailed information on supported values and processing implications. | (note | tip | fastpath | restriction | important | remember | attention | caution | notice | danger | warning | other | -dita-use-​conref-​target) |  | No
othertype | Indicates an alternate note type, when the type is not available in the type attribute value list. This value is used as the user-provided note title when the type attribute value is set to "other." | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.10 glossProperty
Next topic: 3.2.4.1.12 glossShortForm


glossShortForm

3.2.4.1.12 glossShortForm

The <glossShortForm> element provides a shorter alternative to the primary term specified in the <glossterm> element.

Note: Any list of alternative terms is, of course, specific to the language, so translation of a glossentry topic may result in an empty <glossShortForm> element if there is no equivalent in the target language.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or tm) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossAlt

Inheritance

- topic/title concept/title glossentry/glossShortForm

Example

<glossentry id="www">
  <glossterm>World Wide Web</glossterm>
  <glossdef>A collection of documents available through the Internet.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossAlt>
      <glossShortForm>the Web</glossShortForm>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.11 glossScopeNote
Next topic: 3.2.4.1.13 glossStatus


glossStatus

3.2.4.1.13 glossStatus

Identifies the usage status of a preferred or alternate term. If the status isn't specified, the <glossterm> provides a preferred term and an alternate term provides an allowed term.

Note: The values provided by the glossStatus element are extensible using DITA's Controlled Values mechanism. If validation is required, they should be validated using that mechanism rather than by encoding values directly within the XML declaration.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | no content

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossBody, glossAlt

Inheritance

- topic/data concept/data glossentry/glossStatus

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies the status of an alternate form of a glossary term. For example, it may indicate that an alternate form is obsolete. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.12 glossShortForm
Next topic: 3.2.4.1.14 glossSurfaceForm


glossSurfaceForm

3.2.4.1.14 glossSurfaceForm

The <glossSurfaceForm> element specifies an unambiguous presentation of the <glossterm> that may combine multiple forms. The surface form is suitable to introduce the term in new contexts.

The <glossSurfaceForm> element is most often used for terms that also specify the <glossAcronym> element. In that case it contains the term in a manner that introduces both the term and the acronym, so that later references to the term may be replaced with the acronym alone. See the <abbreviated-form> element for a full description of how the surface form is used together with acronyms.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or tm) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossBody

Inheritance

- topic/p concept/p glossentry/glossSurfaceForm

Example

<glossentry id="abs">
  <glossterm>Anti-lock Braking System</glossterm>
  <glossBody>
    <glossSurfaceForm>Anti-lock Braking System (ABS)</glossSurfaceForm>
    <glossAlt>
      <glossAcronym>ABS</glossAcronym>
    </glossAlt>
  </glossBody>
</glossentry>

This glossentry topic defines "Anti-lock Braking System (ABS)" provides an unambiguous way to render the primary term "Anti-lock Braking System". The <abbreviated-form> explains how the <glossSurfaceForm> element affects references to this topic.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.13 glossStatus
Next topic: 3.2.4.1.15 glossSymbol


glossSymbol

3.2.4.1.15 glossSymbol

The <glossSymbol> element identifies a standard image associated with the subject of the <glossterm>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( (alt) (optional) then (longdescref) (optional) )

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossBody

Inheritance

- topic/image concept/image glossentry/glossSymbol

Example

<glossentry id="atlanticpuffin">
  <glossterm>Atlantic Puffin</glossterm>
  <glossdef>A sea bird that lives in the atlantic</glossdef>
  <glossBody>
    <glossSymbol href="puffinicon.jpg" scope="local">
      <alt>Atlantic puffin icon</alt>
    </glossSymbol>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to the image. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | Yes
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
longdescref (deprecated) | A reference to a textual description of the graphic or object. This attribute supports creating accessible content. See The href attribute for detailed information on supported values and processing implications. For examples of how this attribute is used in output, see this this topic on long descriptions. NOTE: This attribute is deprecated in favor of the longdescref subelement to this element. | CDATA | #IMPLIED | No
height | Indicates the vertical dimension for the resulting image display. If necessary, the image is scaled to the specified size. The value of this attribute is a real number optionally followed by a unit of measure from the set of pc, pt, px, in, cm, mm, em (picas, points, pixels, inches, centimeters, millimeters, and ems respectively). The default unit is px (pixels). Possible values include: "5", "5in", and "10.5cm". If a height value is specified and no width value is specified, the width will be scaled by the same factor as the height. If both a height value and width value are specified, some implementations may not be able to scale the two directions by a different factor and may therefore ignore one of the two values. | NMTOKEN | #IMPLIED | No
width | Indicates the horizontal dimension for the resulting image display. If necessary, the image is scaled to the specified size. The value of this attribute is a real number optionally followed by a unit of measure from the set of pc, pt, px, in, cm, mm, em (picas, points, pixels, inches, centimeters, millimeters, and ems respectively). The default unit is px (pixels). Possible values include: "5", "5in", and "10.5cm". If a width value is specified and no height value is specified, the height will be scaled by the same factor as the width. If both a height value and width value are specified, some implementations may not be able to scale the two directions by a different factor and may therefore ignore one of the two values. | NMTOKEN | #IMPLIED | No
align | Controls the horizontal alignment of an image when placement is specified as "break." Common values include left, right, and center. | CDATA | #IMPLIED | No
scale | Specifies a percentage by which to scale the image in the absence of any specified image height or width; a value of 100 implies that the image should be presented at its intrinsic size. If a value has been specified for this image's height or width attribute (or both), the scale attribute is ignored. It is an error if the value of this attribute is not an unsigned integer. In this case, the implementation may (but need not) give an error message and may (but need not) recover by ignoring this attribute. | NMTOKEN | #IMPLIED | No
scalefit | Allow an image to be scaled to fit within available space. If, for a given image, any one of height, width, or scale is specified, those attributes determine the graphic size, and any setting of scalefit is ignored. If none of those attributes are specified and scalefit="yes", then the image is scaled (the same factor in both dimensions) so that the graphic will just fit within the available height or width (whichever is more constraining). The available width would be the prevailing column (or table cell) width--that is, the width a paragraph of text would have if the graphic were a paragraph instead. The available height is implementation dependent, but if feasible, it is suggested to be the page (or table cell) height or some other reasonable value. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
placement | Indicates whether an image should be displayed inline or separated from the surrounding text. The processing default is inline. Allowable values are: inline or break. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | (inline | break | -dita-use-​conref-​target) | inline | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.14 glossSurfaceForm
Next topic: 3.2.4.1.16 glossSynonym


glossSynonym

3.2.4.1.16 glossSynonym

Provides a term that is a synonym of the primary value in the <glossterm> element.

Note: Any list of alternative terms is, of course, specific to the language, so translation of a glossentry topic may result in an empty <glossSynonym> element if there is no equivalent in the target language.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or tm) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossAlt

Inheritance

- topic/title concept/title glossentry/glossSynonym

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.15 glossSymbol
Next topic: 3.2.4.1.17 glossUsage


glossUsage

3.2.4.1.17 glossUsage

The <glossUsage> element provides information about the correct use of a term, such as where or how it can be used.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossary, glossentry, glossgroup | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
ditabase, glossary, glossentry, glossgroup | glossBody, glossAlt

Inheritance

- topic/note concept/note glossentry/glossUsage

Example

Figure 1. The glossary term "USB flash drive" with additional information
<glossentry id="usbfd">
  <glossterm>USB flash drive</glossterm>
  <glossdef>A small portable drive.</glossdef>
  <glossBody>
    <glossPartOfSpeech value="noun"/>
    <glossUsage>Do not provide in upper case (as in "USB Flash
Drive") because that suggests a trademark.</glossUsage>
    <glossAlt>
      <glossAcronym>UFD</glossAcronym>
      <glossUsage>Explain the acronym on first occurrence.</glossUsage>
    </glossAlt>
    <glossAlt id="memoryStick">
      <glossSynonym>memory stick</glossSynonym>
      <glossUsage>This is a colloquial term.</glossUsage>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>stick</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This is too colloquial.</glossUsage>
      <glossAlternateFor href="#usbfd/memoryStick"/>
    </glossAlt>
    <glossAlt>
      <glossAbbreviation>flash</glossAbbreviation>
      <glossStatus value="prohibited"/>
      <glossUsage>This short form is ambiguous.</glossUsage>
    </glossAlt>
  </glossBody>
</glossentry>

Attributes

Name | Description | Data Type | Default Value | Required?
type | Defines the type of a note. For example, if the note is a tip, the word Tip is used to draw the reader's attention to it. Note that this differs from the type attribute on many other DITA elements. See The type attribute for detailed information on supported values and processing implications. | (note | tip | fastpath | restriction | important | remember | attention | caution | notice | danger | warning | other | -dita-use-​conref-​target) |  | No
othertype | Indicates an alternate note type, when the type is not available in the type attribute value list. This value is used as the user-provided note title when the type attribute value is set to "other." | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.1 Glossentry elements
Previous topic: 3.2.4.1.16 glossSynonym
Next topic: 3.2.4.2 Glossary related elements


Glossary related elements

3.2.4.2 Glossary related elements

Elements related to the glossary specialization are not defined as part of the glossary topic type, but are often used in conjunction with those elements.

  • 3.2.4.2.1 abbreviated-form
    The <abbreviated-form> element represents a reference to a term that may appear in an abbreviated form (often an acronym). The long and short forms of the term are generally defined in a <glossentry> topic. Processors should display the referenced term when rendering an <abbreviated-form> element.
  • 3.2.4.2.2 glossref
    The <glossref> element is a convenience element in maps for creating a reference to a glossary topic. It has a required keys attribute, which forces the author to create a key by which inline terms may reference their definition. For example, when glossentry topics are used to define acronyms, this will remind authors to create a key which <abbreviated-form> elements may use to reference the short and expanded versions of that acronym.
  • 3.2.4.2.3 glossgroup
    The <glossgroup> is a specialized topic element that may be used to contain multiple <glossentry> topics within a single collection.
Parent topic: 3.2.4 Glossary elements
Previous topic: 3.2.4.1.17 glossUsage
Next topic: 3.2.4.2.1 abbreviated-form


abbreviated-form

3.2.4.2.1 abbreviated-form

The <abbreviated-form> element represents a reference to a term that may appear in an abbreviated form (often an acronym). The long and short forms of the term are generally defined in a <glossentry> topic. Processors should display the referenced term when rendering an <abbreviated-form> element.

Rendering <abbreviated-form> references to glossentry

When the writer provides a keyref to a glossentry topic that contains a <glossSurfaceForm> element, a process should emit the surface form in introductory contexts where the term might be unfamiliar to the reader or in other contexts where a precise term is appropriate. In other contexts a process should submit the abbreviated form of the term. Note that the definition of an introductory context will differ for every deliverable format.

For instance, a process composing a book deliverable may emit the surface form of a term on the first reference to the glossentry topic within the book or for every reference within a copyright or a warranty-related warning. A process generating an online page may emit the surface form as a hover tooltip on every instance of the term.

Renderers should follow these rules when displaying an <abbreviated-form> element that refers to a glossentry topic:
  1. In an introductory context, processors SHOULD render the surface form of the term by displaying the contents of the glossSurfaceForm element from the referenced glossentry topic.
  2. If the glossentry topic does not contain a glossSurfaceForm element or the glossSurfaceForm element is empty, processors SHOULD render the contents of the glossterm element in introductory contexts.
  3. In non-introductory contexts, processors SHOULD render the abbreviated form of the term by displaying the contents of the <glossAcronym> element from the referenced glossentry topic.
  4. If the glossentry topic does not contain a glossAcronym element or the glossAcronym element is empty, processors SHOULD render the contents of the glossterm element in non-introductory contexts.

For instance, if the topic with the keyref to the "abs" key provided the first occurrence of the ABS term within a book, the sentence could be rendered as follows:

"The Anti-lock Brake System (ABS) will prevent the car from skidding in adverse weather conditions."

If the ABS term had appeared previously within the book, the same sentence could instead be rendered as follows:

"The ABS will prevent the car from skidding in adverse weather conditions."

Rendering <abbreviated-form> references to other topics

Typically the <abbreviated-form> is used to refer to a glossentry topic. In situations where it refers to another topic type, renderers should display the content of the referenced topic's title.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | no content

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, bookpartno, booknumber, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput

Inheritance

+ topic/term abbrev-d/abbreviated-form

Example

The term and acronym may be defined as follows, in a glossentry topic. Note that the id of the topic does not need to match the term or acronym.

<glossentry id="abs-definition">
  <glossterm>Anti-lock Braking System</glossterm>
  <glossBody>
    <glossSurfaceForm>Anti-lock Braking System (ABS)</glossSurfaceForm>
    <glossAlt>
      <glossAcronym>ABS</glossAcronym>
    </glossAlt>
  </glossBody>
</glossentry>

Note that there are three important elements for the purposes of rendering the <abbreviated-form> element.

  • The glossSurfaceForm element defines the term as it should be displayed in an introductory context.
  • The glossAcronym element defines the acronym associated with this term.
  • The glossterm element provides a fallback version of the term, which will be displayed in situations where the preferred representation is unavailable.

The glossentry topic will be added to a map in the following manner. Again, the key (in this case "abs") does not need to match the term or acronym value.

<glossref keys="abs" href="antilock.dita"/>

An author that wishes to reference this topic may do so using the abbreviated-form element. The keyref attribute should reference the value defined on the keys attribute above.

<section>An <abbreviated-form keyref="abs"/> helps a
driver to stop. For this reason many find an
<abbreviated-form keyref="abs"/> useful.
</section>
When rendered, the introductory usage of "abs" will display the surface form of the referenced term, while the later uses will display the acronym, as demonstrated here.
An Anti-lock Braking System (ABS) helps a driver to stop. For this reason many find an ABS useful.

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | The keyref attribute on <abbreviated-form> is used to reference a term, typically defined in a <glossentry> topic. See The keyref attribute for details about syntax and processing concerns. | CDATA | #REQUIRED | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.2 Glossary related elements
Previous topic: 3.2.4.2 Glossary related elements
Next topic: 3.2.4.2.2 glossref


glossref

3.2.4.2.2 glossref

The <glossref> element is a convenience element in maps for creating a reference to a glossary topic. It has a required keys attribute, which forces the author to create a key by which inline terms may reference their definition. For example, when glossentry topics are used to define acronyms, this will remind authors to create a key which <abbreviated-form> elements may use to reference the short and expanded versions of that acronym.

Note that the key value does not need to match the target term or acronym. In fact, using a more qualified value for the keyref will reduce conflicts in situations where the same term or acronym may resolve in many ways. For example, an information set could use “cars.abs” as the key for the term Anti-lock Braking System, and “ship.abs” to refer to the term American Bureau of Shipping.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
map (technical content) | (topicmeta) (optional)

Contained by

Doctype | Content model
map (technical content) | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef

Inheritance

+ map/topicref glossref-d/glossref

Example

<map>
  ...
  <topicref href="car-maintenance.dita"/>
  ...
  <glossref keys="cars.abs" href="antiLockBrake.dita"/>
  ... key declarations for other referenced acronyms ...
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to a glossary definition, typically a <glossentry> topic. See The href attribute for detailed information on supported values and processing implications. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #REQUIRED | Yes
keys | Associates one or more space-delimited keys with the target of the glossary reference. See The keys attribute for information on using the attribute. | NMTOKEN | #REQUIRED | Yes
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified.

Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy.

CDATA #IMPLIED No
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
linking Defines some specific linking characteristics of a glossary topic's current location in the map. The value defaults to "none" in order to keep individual glossary entries from creating links based on their location in the map.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) none No
toc | Specifies whether a topic appears in the table of contents (toc); on this element the default is no. This value defaults to no for elements such as reltable, which typically cannot appear in the toc, and for elements such as glossref that generally are not desired in the toc. | (yes | no | -dita-use-​conref-​target) | "no" | No
print Specifies whether the topic should be included in a print-specific rendition, such as PDF. On this element the value defaults to "no".
yes
Include the topic in the print-oriented file.
no
Do not include the topic in a print-oriented file.
printonly
Only include the topic when rendering the DITA content in a print-oriented context; the topic should not be included in other contexts, such as when rendering as HTML.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | printonly | -dita-use-​conref-​target) no No
search Describes whether the target is available for searching. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
no
-dita-use-​conref-​target
(yes | no | -dita-use-​conref-​target) #IMPLIED No
chunk When a set of topics is transformed using a map, the chunk attribute allows multi-topic documents to be broken into smaller files and multiple individual topics to be combined into larger combined documents.

For a detailed description of the chunk attribute and its usage, see Chunking in the DITA Architectural Specification.

CDATA #IMPLIED No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes
Parent topic: 3.2.4.2 Glossary related elements
Previous topic: 3.2.4.2.1 abbreviated-form
Next topic: 3.2.4.2.3 glossgroup


glossgroup

3.2.4.2.3 glossgroup

The <glossgroup> is a specialized topic element that may be used to contain multiple <glossentry> topics within a single collection.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
ditabase, glossgroup | ( (title) then (prolog) (optional) then (glossgroup or glossentry) (any number) )

Contained by

Doctype | Content model
ditabase | dita, topic, concept, task, reference, glossgroup
glossgroup | glossgroup

Inheritance

- topic/topic concept/concept glossgroup/glossgroup

Example

<glossgroup id="things" xml:lang="en">
  <title>Some terms</title>
  <glossentry id="bicycle">
    <glossterm>bicycle</glossterm>
    <glossdef>Human powered mode of transport
       with two wheels</glossdef>
  </glossentry>
  <glossentry id="fruitbat">
    <glossterm>Fruit bat</glossterm>
    <glossdef>A bat which likes fruit</glossdef>
  </glossentry>
</glossgroup>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.4.2 Glossary related elements
Previous topic: 3.2.4.2.2 glossref
Next topic: 3.2.5 Bookmap elements


Bookmap elements

3.2.5 Bookmap elements

Elements in the bookmap section are used to organize DITA content into book form. They include elements for dividing up content, such as chapter and appendix, as well as metadata specific to publishing.

  • 3.2.5.1 Bookmap content elements
    The Bookmap specialization of ditamap supports standard book production for collections of DITA topics.
  • 3.2.5.2 Bookmap metadata elements
    The Bookmap specialization of ditamap supports standard book production for collections of DITA topics. This section contains the metadata elements used by bookmap to store book-related metadata.
Parent topic: 3.2 Technical content elements
Previous topic: 3.2.4.2.3 glossgroup
Next topic: 3.2.5.1 Bookmap content elements


Bookmap content elements

3.2.5.1 Bookmap content elements

The Bookmap specialization of ditamap supports standard book production for collections of DITA topics.

The OASIS document type for the bookmap specialization also includes substantial book metadata for describing authors, based on the eXtensible Name and Address Language, or xNAL.

  • 3.2.5.1.1 bookmap
    The <bookmap> element is a map specialization used to describe the relationships among a set of DITA topics intended to be configured as a traditional book. Bookmaps consist of references to topics organized as book content. The topic references therefore are labeled according to the book components they point to, such as booktitle, frontmatter, chapter, and appendix.
  • 3.2.5.1.2 abbrevlist
    The <abbrevlist> element references a list of abbreviations. It indicates to the processing software that the author wants an abbreviation list generated at the particular location.
  • 3.2.5.1.3 amendments
    The <amendments> element references a list of amendments or updates to the book. It indicates to the processing software that the author wants an amendments list generated at the particular location.
  • 3.2.5.1.4 appendices
    The <appendices> element is an optional wrapper for <appendix> elements within a bookmap.
  • 3.2.5.1.5 appendix
    The <appendix> element references a topic as a appendix within a book.
  • 3.2.5.1.6 backmatter
    The <backmatter> element contains the material that follows the main body of a document and any appendices. It may include items such as a colophon, legal notices, and various types of book lists such as a glossary or an index.
  • 3.2.5.1.7 bibliolist
    The <bibliolist> element references a topic containing a list of bibliographic entries within the book. It indicates to the processing software that the author wants a bibliography, containing links to related books, articles, published papers, or other types of material, generated at the particular location. If no href attribute is specified on the <bibliolist> element, an external processor may generate a list of bibliographic entries at this location.
  • 3.2.5.1.8 bookabstract
    The <bookabstract> element references a topic used within a bookmap as a brief summary of book content, generally output as part of the book's frontmatter. It is used to help the reader quickly evaluate the book's purpose.
  • 3.2.5.1.9 booklibrary
    The <booklibrary> element contains the library information for a book. Library entries contain information about the series, library, or collection of documents to which the book belongs.
  • 3.2.5.1.10 booklist
    The <booklist> element is a general purpose element, designed for use in specializations, that references a topic or map containing a list of items within the book. For example, it could be used to reference a topic that contains a list of authors for the book. When a more specific element is already available, such as <tablelist> for a list of tables, that element should be used instead.
  • 3.2.5.1.11 booklists
    The <booklists> element references lists of various kinds within the book. For example, it can be used within frontmatter to reference a <toc>, <tablelist>, and <figurelist>, or within backmatter to reference a <glossarylist>, <indexlist>, and <abbrevlist>. It indicates to the processing software that the author wants the lists generated at the <booklists> location.
  • 3.2.5.1.12 booktitle
    The <booktitle> element contains the title information for a book, including the library title, main title, subtitle, and other titles (as required).
  • 3.2.5.1.13 booktitlealt
    The <booktitlealt> element contains the alternative title, subtitle, or short title for a book. It may be specialized into a specific element for those or other purposes.
  • 3.2.5.1.14 chapter
    The <chapter> element references a topic or map as a chapter within a book.
  • 3.2.5.1.15 colophon
    The <colophon> element references a topic describing how this document was created. In publishing, a colophon describes details of the production of a book. This information generally includes the typefaces used, and often the names of their designers; the paper, ink and details of the binding materials and methods may also receive mention. In the case of technical books, a colophon may specify the software used to prepare the text and diagrams for publication. The colophon may appear in the frontmatter or backmatter.
  • 3.2.5.1.16 dedication
    The <dedication> element references a topic containing a dedication for the book, such as to a person or group.
  • 3.2.5.1.17 draftintro
    The <draftintro> element references a topic used as an introduction to the draft of this book.
  • 3.2.5.1.18 figurelist
    The <figurelist> element references a topic containing a list of figures in the book. It indicates to the processing software that the author wants a list of figures generated at the particular location. If no href attribute is specified on the <figurelist> element, an external processor may generate a list of figures at this location.
  • 3.2.5.1.19 frontmatter
    The <frontmatter> element contains the material that precedes the main body of a document. It may include items such as an abstract, a preface, and various types of book lists such as a <toc>, <tablelist>, or <figurelist>.
  • 3.2.5.1.20 glossarylist
    The <glossarylist> element references a list of glossary entries within the book. It indicates to the processing software that the author wants a glossary list generated at the particular location.
  • 3.2.5.1.21 indexlist
    The <indexlist> element indicates to the processing software that the author wants an index at the particular location. If no href attribute is specified on the <indexlist> element, an external processor may generate an index at this location. If the href attribute references a topic or map, that topic or map should contain a manually created index.
  • 3.2.5.1.22 mainbooktitle
    The <mainbooktitle> element contains the primary title information for a book.
  • 3.2.5.1.23 notices
    The <notices> element references a topic containing special notice information, for example, legal notices about supplementary copyrights and trademarks associated with the book.
  • 3.2.5.1.24 part
    The <part> element references a part topic or a map that references part topics for the book. A new part is started. Use <part> to divide a document's chapters into logical groupings. For example, in a document that contains both guide and reference information, you can define two parts, one containing the guide information and the other containing the reference information.
  • 3.2.5.1.25 preface
    The <preface> element references a topic or map containing introductory information about a book, such as the purpose and structure of the document.
  • 3.2.5.1.26 tablelist
    The <tablelist> element references a topic that contains a list of tables within the book. It indicates to the processing software that the author wants a list of tables generated at the particular location. If no href attribute is specified on the <tablelist> element, an external processor may generate a list of tables at this location.
  • 3.2.5.1.27 toc
    The <toc> element indicates to the processing software that the author wants a table of contents generated at the particular location. If no href attribute is specified on the <toc> element, an external processor may generate table of contents at this location. If the href attribute references a topic or map, that topic or map should contain a manually created table of contents.
  • 3.2.5.1.28 trademarklist
    The <trademarklist> element references a topic that contains a list of trademarks within the book. It indicates to the processing software that the author wants a list of trademarks generated at the particular location. If no href attribute is specified on the <trademarklist> element, an external processor may generate a list of trademarks at this location.
Parent topic: 3.2.5 Bookmap elements
Previous topic: 3.2.5 Bookmap elements
Next topic: 3.2.5.1.1 bookmap


bookmap

3.2.5.1.1 bookmap

The <bookmap> element is a map specialization used to describe the relationships among a set of DITA topics intended to be configured as a traditional book. Bookmaps consist of references to topics organized as book content. The topic references therefore are labeled according to the book components they point to, such as booktitle, frontmatter, chapter, and appendix.

The containing element for a bookmap is the <bookmap> element, which can take title, id, conref, and anchorref attributes. Within the bookmap, use the various book components and subcomponents to add and organize references to the topics comprising the book. You can use the bookmap element to set default attribute values for all topic references in the map.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (title) or (booktitle) ) (optional) then (bookmeta) (optional) then (frontmatter) (optional) then (chapter) (any number) then (part) (any number) then ( (appendices) (optional) or (appendix) (any number) ) then (backmatter) (optional) then (reltable) (any number) )

Contained by

This element is not contained by any other elements.

Inheritance

- map/map bookmap/bookmap

Example

<bookmap xml:lang="en-us">
  <booktitle>
    <booklibrary>Books about stuff</booklibrary>
    <mainbooktitle>A book about one thing</mainbooktitle>
  </booktitle>
  <bookmeta>
    <bookrights>
      <copyrfirst><year>1994</year></copyrfirst>
      <copyrlast><year>2006</year></copyrlast>
      <bookowner>OASIS</bookowner>
    </bookrights>
  </bookmeta>
  <frontmatter>
    <booklists>
      <toc/>
      <figurelist/>
      <tablelist/>
    </booklists>
    <bookabstract href="MyBookAbstract.dita"/>
    <preface href="preface.dita"></preface>
  </frontmatter>
  <chapter href="chapter1.dita">
    <topicref href="subchap1.dita"></topicref>
  </chapter>
  <chapter href="chapter2.dita">
    <topicref href="subchap2.dita"></topicref>
  </chapter>
  <appendix href="app1.dita">
    <topicref href="insideApp1.dita"></topicref>
  </appendix>
  <appendix href="app2.dita">
    <topicref href="insideApp2.dita"></topicref>
  </appendix>
  <backmatter>
    <amendments href="updatesToTheBook.dita"/>
    <booklists>
      <trademarklist href="listoftrademarks.dita"/>
      <indexlist/>
    </booklists>
  </backmatter>
</bookmap>

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by href and conref attributes and for external applications that refer to DITA content. See ID attribute in the Architectural Specification for more details. | NMTOKEN | #IMPLIED | No
conref | This attribute is used to reference an ID on a map that can be reused. See The conref attribute for examples and details about the syntax. | CDATA | #IMPLIED | No
anchorref | Identifies a location within another map file where this map will be anchored at runtime. Resolution of the map is deferred until the final step in the delivery of any rendered content. For example, anchorref="map1.ditamap/a1" causes this map to be pulled into the location of the anchor point "a1" inside map1.ditamap when map1.ditamap is rendered for delivery. | CDATA | #IMPLIED | No
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1 Bookmap content elements
Next topic: 3.2.5.1.2 abbrevlist


abbrevlist

3.2.5.1.2 abbrevlist

The <abbrevlist> element references a list of abbreviations. It indicates to the processing software that the author wants an abbreviation list generated at the particular location.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/abbrevlist

Example

<abbrevlist href="abbrev.dita"/>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.1 bookmap
Next topic: 3.2.5.1.3 amendments


amendments

3.2.5.1.3 amendments

The <amendments> element references a list of amendments or updates to the book. It indicates to the processing software that the author wants an amendments list generated at the particular location.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | backmatter

Inheritance

- map/topicref bookmap/amendments

Example

See the example for bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.2 abbrevlist
Next topic: 3.2.5.1.4 appendices


appendices

3.2.5.1.4 appendices

The <appendices> element is an optional wrapper for <appendix> elements within a bookmap.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (topicmeta) (optional) then (appendix) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmap

Inheritance

- map/topicref bookmap/appendices

Example

<appendices toc="yes" print="no">
  <topicmeta>
    <navtitle>Appendices</navtitle>
  </topicmeta>
  <appendix href="return-codes.dita"/>
  <appendix href="messages.dita"/>
  <appendix href="extra-info.dita"/>
</appendices>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.3 amendments
Next topic: 3.2.5.1.5 appendix


appendix

3.2.5.1.5 appendix

The <appendix> element references a topic as a appendix within a book.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
learningBookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmap, appendices

Inheritance

- map/topicref bookmap/appendix

Example

Appendix topics that include subtopics:
<appendix href="intro.dita">
 <topicref href="caring.dita"/>
 <topicref href="feeding.dita"/>
</appendix>
<appendix href="setup.dita">
 <topicref href="prereq.dita"/>
 <topicref href="download.dita"/>
</appendix>
Appendix that references a ditamap of content:
<appendix href="intro.ditamap" format="ditamap"/>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.4 appendices
Next topic: 3.2.5.1.6 backmatter


backmatter

3.2.5.1.6 backmatter

The <backmatter> element contains the material that follows the main body of a document and any appendices. It may include items such as a colophon, legal notices, and various types of book lists such as a glossary or an index.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | (amendments or booklists or colophon or dedication or notices or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number)
learningBookmap | (amendments or booklists or colophon or dedication or notices or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmap

Inheritance

- map/topicref bookmap/backmatter

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.5 appendix
Next topic: 3.2.5.1.7 bibliolist


bibliolist

3.2.5.1.7 bibliolist

The <bibliolist> element references a topic containing a list of bibliographic entries within the book. It indicates to the processing software that the author wants a bibliography, containing links to related books, articles, published papers, or other types of material, generated at the particular location. If no href attribute is specified on the <bibliolist> element, an external processor may generate a list of bibliographic entries at this location.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/bibliolist

Example

<bookmap>
  <!-- ... -->
  <backmatter>
    <amendments href="updatesToTheBook.dita"/>
    <booklists>
      <trademarklist href="listoftrademarks.dita"/>
      <bibliolist href="bibliography.dita"/>
      <indexlist/>
    </booklists>
  </backmatter>
</bookmap>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.6 backmatter
Next topic: 3.2.5.1.8 bookabstract


bookabstract

3.2.5.1.8 bookabstract

The <bookabstract> element references a topic used within a bookmap as a brief summary of book content, generally output as part of the book's frontmatter. It is used to help the reader quickly evaluate the book's purpose.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | frontmatter

Inheritance

- map/topicref bookmap/bookabstract

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.7 bibliolist
Next topic: 3.2.5.1.9 booklibrary


booklibrary

3.2.5.1.9 booklibrary

The <booklibrary> element contains the library information for a book. Library entries contain information about the series, library, or collection of documents to which the book belongs.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or image) (any number)
learningBookmap | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or image) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | booktitle

Inheritance

- topic/ph bookmap/booklibrary

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.8 bookabstract
Next topic: 3.2.5.1.10 booklist


booklist

3.2.5.1.10 booklist

The <booklist> element is a general purpose element, designed for use in specializations, that references a topic or map containing a list of items within the book. For example, it could be used to reference a topic that contains a list of authors for the book. When a more specific element is already available, such as <tablelist> for a list of tables, that element should be used instead.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/booklist

Example

In this case the <booklist> element references a topic that contains a list of authors of topics in this document.

<booklists>
  <toc/>
  <tablelist/>
  <booklist href="authors.dita" navtitle="List of authors"/>
</booklists>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.9 booklibrary
Next topic: 3.2.5.1.11 booklists


booklists

3.2.5.1.11 booklists

The <booklists> element references lists of various kinds within the book. For example, it can be used within frontmatter to reference a <toc>, <tablelist>, and <figurelist>, or within backmatter to reference a <glossarylist>, <indexlist>, and <abbrevlist>. It indicates to the processing software that the author wants the lists generated at the <booklists> location.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (abbrevlist) or (bibliolist) or (booklist) or (figurelist) or (glossarylist) or (indexlist) or (tablelist) or (trademarklist) or (toc) ) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | frontmatter, backmatter

Inheritance

- map/topicref bookmap/booklists

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.10 booklist
Next topic: 3.2.5.1.12 booktitle


booktitle

3.2.5.1.12 booktitle

The <booktitle> element contains the title information for a book, including the library title, main title, subtitle, and other titles (as required).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (booklibrary) (optional) then (mainbooktitle) then (booktitlealt) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmap

Inheritance

- topic/title bookmap/booktitle

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.11 booklists
Next topic: 3.2.5.1.13 booktitlealt


booktitlealt

3.2.5.1.13 booktitlealt

The <booktitlealt> element contains the alternative title, subtitle, or short title for a book. It may be specialized into a specific element for those or other purposes.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or image) (any number)
learningBookmap | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or image) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | booktitle

Inheritance

- topic/ph bookmap/booktitlealt

Example

<bookmap>
  <booktitle>
    <mainbooktitle>This is my big and fancy book</mainbooktitle>
    <booktitlealt>Shorter title</booktitle>
  </booktitle>
  <!-- ... -->
</bookmap>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.12 booktitle
Next topic: 3.2.5.1.14 chapter


chapter

3.2.5.1.14 chapter

The <chapter> element references a topic or map as a chapter within a book.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
learningBookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmap, part

Inheritance

- map/topicref bookmap/chapter

Example

Chapter topics that include subtopics:
<chapter href="intro.dita">
 <topicref href="caring.dita"/>
 <topicref href="feeding.dita"/>
</chapter>
<chapter href="setup.dita">
 <topicref href="prereq.dita"/>
 <topicref href="download.dita"/>
</chapter>
Chapter that references a ditamap of content:
<chapter href="intro.ditamap" format="ditamap"/>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.13 booktitlealt
Next topic: 3.2.5.1.15 colophon


colophon

3.2.5.1.15 colophon

The <colophon> element references a topic describing how this document was created. In publishing, a colophon describes details of the production of a book. This information generally includes the typefaces used, and often the names of their designers; the paper, ink and details of the binding materials and methods may also receive mention. In the case of technical books, a colophon may specify the software used to prepare the text and diagrams for publication. The colophon may appear in the frontmatter or backmatter.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | frontmatter, backmatter

Inheritance

- map/topicref bookmap/colophon

Example

<bookmap>
  <title>Sample book</title>
  <!-- ... -->
  <backmatter>
    <colophon href="ProdNot.dita" navtitle="Production Notes"/>
  </backmatter>
</bookmap>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.14 chapter
Next topic: 3.2.5.1.16 dedication


dedication

3.2.5.1.16 dedication

The <dedication> element references a topic containing a dedication for the book, such as to a person or group.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | frontmatter, backmatter

Inheritance

- map/topicref bookmap/dedication

Example

<frontmatter>
  <dedication href="dtm.dita"
                  navtitle="Dedicated to Mother"/>
</frontmatter>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.15 colophon
Next topic: 3.2.5.1.17 draftintro


draftintro

3.2.5.1.17 draftintro

The <draftintro> element references a topic used as an introduction to the draft of this book.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
learningBookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | frontmatter

Inheritance

- map/topicref bookmap/draftintro

Example

<frontmatter>
  <draftintro href="introducing.dita"
              navtitle="Introduction to this draft"/>
</frontmatter>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.16 dedication
Next topic: 3.2.5.1.18 figurelist


figurelist

3.2.5.1.18 figurelist

The <figurelist> element references a topic containing a list of figures in the book. It indicates to the processing software that the author wants a list of figures generated at the particular location. If no href attribute is specified on the <figurelist> element, an external processor may generate a list of figures at this location.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/figurelist

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.17 draftintro
Next topic: 3.2.5.1.19 frontmatter


frontmatter

3.2.5.1.19 frontmatter

The <frontmatter> element contains the material that precedes the main body of a document. It may include items such as an abstract, a preface, and various types of book lists such as a <toc>, <tablelist>, or <figurelist>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | (bookabstract or booklists or colophon or dedication or draftintro or notices or preface or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number)
learningBookmap | (bookabstract or booklists or colophon or dedication or draftintro or notices or preface or topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmap

Inheritance

- map/topicref bookmap/frontmatter

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.18 figurelist
Next topic: 3.2.5.1.20 glossarylist


glossarylist

3.2.5.1.20 glossarylist

The <glossarylist> element references a list of glossary entries within the book. It indicates to the processing software that the author wants a glossary list generated at the particular location.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
learningBookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/glossarylist

Example

See backmatter.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.19 frontmatter
Next topic: 3.2.5.1.21 indexlist


indexlist

3.2.5.1.21 indexlist

The <indexlist> element indicates to the processing software that the author wants an index at the particular location. If no href attribute is specified on the <indexlist> element, an external processor may generate an index at this location. If the href attribute references a topic or map, that topic or map should contain a manually created index.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/indexlist

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.20 glossarylist
Next topic: 3.2.5.1.22 mainbooktitle


mainbooktitle

3.2.5.1.22 mainbooktitle

The <mainbooktitle> element contains the primary title information for a book.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or image) (any number)
learningBookmap | ( text data or boolean or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or state or image) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | booktitle

Inheritance

- topic/ph bookmap/mainbooktitle

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.21 indexlist
Next topic: 3.2.5.1.23 notices


notices

3.2.5.1.23 notices

The <notices> element references a topic containing special notice information, for example, legal notices about supplementary copyrights and trademarks associated with the book.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
learningBookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | frontmatter, backmatter

Inheritance

- map/topicref bookmap/notices

Example

This example references a notices topic that contains legal content.

<backmatter>
  <notices href="notices.dita" navtitle="Legal notices"/>
  <booklists>
    <!-- Index, glossary, or other lists -->
  </booklists>
</backmatter>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.22 mainbooktitle
Next topic: 3.2.5.1.24 part


part

3.2.5.1.24 part

The <part> element references a part topic or a map that references part topics for the book. A new part is started. Use <part> to divide a document's chapters into logical groupings. For example, in a document that contains both guide and reference information, you can define two parts, one containing the guide information and the other containing the reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( (topicmeta) (optional) then ( (chapter) or (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) ) (any number) )
learningBookmap | ( (topicmeta) (optional) then ( (chapter) or (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) ) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmap

Inheritance

- map/topicref bookmap/part

Example

Part topics that include chapters and subtopics:
<part href="guide.dita">
 <chapter href="intro.dita">
  <topicref href="caring.dita"/>
  <topicref href="feeding.dita"/>
 </chapter>
 <chapter href="setup.dita">
  <topicref href="prereq.dita"/>
  <topicref href="download.dita"/>
 </chapter>
</part>
<part href="ref.dita">
 <chapter href="commands.dita">
  <topicref href="care.dita"/>
  <topicref href="feed.dita"/>
 </chapter>
 <chapter href="apis.dita">
  <topicref href="acare.dita"/>
  <topicref href="afeed.dita"/>
 </chapter>
</part>
Parts that reference ditamaps of content:
<part href="intro.ditamap" format="ditamap"/>
<part href="guide.ditamap" format="ditamap"/>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.23 notices
Next topic: 3.2.5.1.25 preface


preface

3.2.5.1.25 preface

The <preface> element references a topic or map containing introductory information about a book, such as the purpose and structure of the document.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref) (any number) )
learningBookmap | ( (topicmeta) (optional) then (topicref or anchorref or keydef or mapref or topicgroup or topichead or topicset or topicsetref or learningObject or learningGroup) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | frontmatter

Inheritance

- map/topicref bookmap/preface

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.24 part
Next topic: 3.2.5.1.26 tablelist


tablelist

3.2.5.1.26 tablelist

The <tablelist> element references a topic that contains a list of tables within the book. It indicates to the processing software that the author wants a list of tables generated at the particular location. If no href attribute is specified on the <tablelist> element, an external processor may generate a list of tables at this location.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/tablelist

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.25 preface
Next topic: 3.2.5.1.27 toc


toc

3.2.5.1.27 toc

The <toc> element indicates to the processing software that the author wants a table of contents generated at the particular location. If no href attribute is specified on the <toc> element, an external processor may generate table of contents at this location. If the href attribute references a topic or map, that topic or map should contain a manually created table of contents.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/toc

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.26 tablelist
Next topic: 3.2.5.1.28 trademarklist


trademarklist

3.2.5.1.28 trademarklist

The <trademarklist> element references a topic that contains a list of trademarks within the book. It indicates to the processing software that the author wants a list of trademarks generated at the particular location. If no href attribute is specified on the <trademarklist> element, an external processor may generate a list of trademarks at this location.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | booklists

Inheritance

- map/topicref bookmap/trademarklist

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | Points to a manual listing for the current element. See The href attribute for detailed information on supported values and processing implications. If no href is specified, processors may choose to generate an appropriate listing for this element. All of the book listings operate in a similar manner; for example, <toc href="toc.dita"/> points to a topic which contains a manual table of contents, while <toc/> indicates that a processor should generate the table of contents. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.1 Bookmap content elements
Previous topic: 3.2.5.1.27 toc
Next topic: 3.2.5.2 Bookmap metadata elements


Bookmap metadata elements

3.2.5.2 Bookmap metadata elements

The Bookmap specialization of ditamap supports standard book production for collections of DITA topics. This section contains the metadata elements used by bookmap to store book-related metadata.

Note: The OASIS document type for the bookmap specialization includes the xNAL domain specialization for describing the author or authors of a document. All elements that appear in that domain (the authorinformation element and all of its descendants) are described in the xNAL domain section, rather than in this bookmap metadata section.
  • 3.2.5.2.1 bookmeta
    The <bookmeta> element contains information about the book that is not considered book content, such as copyright information, author information, and any classifications.
  • 3.2.5.2.2 approved
    The <approved> element contains information about when and by whom the book was approved during its publication history.
  • 3.2.5.2.3 bookchangehistory
    The <bookchangehistory> element contains information about the history of the book's creation and publishing lifecycle, including who wrote, reviewed, edited, and tested the book. It also specifies when these events took place.
  • 3.2.5.2.4 bookevent
    The <bookevent> element indicates a general event in the publication history of a book. This is an appropriate element for specialization if the current set of specific book event types does not meet your needs. If an element already exists to describe a specific type of event, such as <reviewed>, <edited>, or <approved>, that element should be used instead.
  • 3.2.5.2.5 bookeventtype
    The <bookeventtype> element indicates the specific nature of a <bookevent>, such as updated, indexed, or deprecated. The required name attribute indicates the event's type.
  • 3.2.5.2.6 bookid
    The <bookid> element contains the publisher's identification information for the book, such as part number, edition number and ISBN number.
  • 3.2.5.2.7 booknumber
    The <booknumber> element contains the book's form number, such as SC21-1920.
  • 3.2.5.2.8 bookowner
    The <bookowner> element contains the owner of the copyright.
  • 3.2.5.2.9 bookpartno
    The <bookpartno> element contains the book's part number, such as 99F1234. A publisher may use a number like this one to identify a book for tracking purposes.
  • 3.2.5.2.10 bookrestriction
    The <bookrestriction> element indicates whether the book is classified or restricted in some way. The value attribute indicates any restrictions on the use of the material, such as declaring the information confidential or for licensed use only.
  • 3.2.5.2.11 bookrights
    The <bookrights> element contains the information about the legal rights associated with the book, including copyright dates and owners.
  • 3.2.5.2.12 completed
    The <completed> element indicates a completion date for some type of book event, such as a review, editing, or testing.
  • 3.2.5.2.13 copyrfirst
    The <copyfirst> element contains the first copyright year within a multiyear copyright statement.
  • 3.2.5.2.14 copyrlast
    The <copylast> element contains the last copyright year within a multiyear copyright statement.
  • 3.2.5.2.15 day
    The <day> element denotes a day of the month.
  • 3.2.5.2.16 edited
    The <edited> element contains information about when and by whom the book was edited during its publication history.
  • 3.2.5.2.17 edition
    The <edition> element contains the edition number information, such as First Edition, or Third Edition, used by a publisher to identify a book.
  • 3.2.5.2.18 isbn
    The <isbn> element contains the book's International Standard Book Number (ISBN).
  • 3.2.5.2.19 maintainer
    The <maintainer> element contains information about who maintains the document; the maintainer may be an organization or a person.
  • 3.2.5.2.20 month
    The <month> element denotes a month of the year.
  • 3.2.5.2.21 organization
    The <organization> element contains the name of an organization. Note that unlike <organizationname>, the <organization> element is not restricted to use within <authorinformation>; it does not have to contain the name of an authoring organization.
  • 3.2.5.2.22 person
    The <person> element contains information about the name of a person. Note that unlike the <personname> element, the <person> element is not restricted to describing the names of authors.
  • 3.2.5.2.23 printlocation
    The <printlocation> element indicates the location where the book was printed. Customarily, the content is restricted to the name of the country.
  • 3.2.5.2.24 published
    The <published> element contains information about the person or organization publishing the book, the dates when it was started and completed, and any special restrictions associated with it.
  • 3.2.5.2.25 publisherinformation
    The <publisherinformation> contains information about what group or person published the book, where it was published, and certain details about its publication history. Other publication history information is found in the <bookchangehistory> element.
  • 3.2.5.2.26 publishtype
    The <publishtype> element indicates whether the book is generally available from the publisher or is restricted in some way. The value attribute indicates the restrictions, such as beta release, limited availability, or general availability.
  • 3.2.5.2.27 reviewed
    The <reviewed> element contains information about when and by whom the book was reviewed during its publication history.
  • 3.2.5.2.28 revisionid
    The <revisionid> element indicates the revision number or revision ID of the book. The processing implementation determines how the level is displayed. Common methods include using a dash, for example "-01", or a period, such as ".01".
  • 3.2.5.2.29 started
    The <started> element indicates a start date for some type of book event, such as a review, editing, or testing.
  • 3.2.5.2.30 summary
    The <summary> element contains a text summary associated with a book event (such as <approved> or <reviewed>) or with the list of copyrights for the book.
  • 3.2.5.2.31 tested
    The <tested> element contains information about when and by whom the book was tested during its publication history.
  • 3.2.5.2.32 volume
    The <volume> element contains the book's volume number, such as Volume 2.
  • 3.2.5.2.33 year
    The <year> element denotes a year.
Parent topic: 3.2.5 Bookmap elements
Previous topic: 3.2.5.1.28 trademarklist
Next topic: 3.2.5.2.1 bookmeta


bookmeta

3.2.5.2.1 bookmeta

The <bookmeta> element contains information about the book that is not considered book content, such as copyright information, author information, and any classifications.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( (linktext) (optional) then (searchtitle) (optional) then (shortdesc) (optional) then (author or authorinformation) (any number) then (source) (optional) then (publisherinformation) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata) (any number) then (audience) (any number) then (category) (any number) then (keywords or exportanchors) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (resourceid) (any number) then (bookid) (optional) then (bookchangehistory) (any number) then (bookrights) (any number) then (data) (any number) )
learningBookmap | ( (linktext) (optional) then (searchtitle) (optional) then (shortdesc) (optional) then (author or authorinformation) (any number) then (source) (optional) then (publisherinformation) (any number) then (critdates) (optional) then (permissions) (optional) then (metadata or lcLom) (any number) then (audience) (any number) then (category) (any number) then (keywords or exportanchors) (any number) then (prodinfo) (any number) then (othermeta) (any number) then (resourceid) (any number) then (bookid) (optional) then (bookchangehistory) (any number) then (bookrights) (any number) then (data) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmap

Inheritance

- map/topicmeta bookmap/bookmeta

Example

In this example:
  • The <authorinformation> contains the content for a reader's comment form; the <maintainer> element references that author information to create the reader comment form.
  • The <prodinfo> element contains the book's product information. This includes the product name, and the version, release, and modification information.
  • The <bookid> element contains the book's form number and part number information. The <maintainer> element contains information about the current maintainer of the book; it may reference the <authorinformation> element to provide detailed information about an author that is also the current maintainer.
  • The <bookrights> element contains the book's copyright information.

This example makes heavy use of authorinformation, which is a domain element that OASIS delivers only with the bookmap specialization. However, other bookmap DTDs or schemas may not include the domain with authorinformation; likewise, authorinformation may be included in other document types.

<bookmeta>
  <authorinformation id="rcf">
    <organizationinfo>
      <namedetails>
        <organizationnamedetails>
          <organizationname>IBM</organizationname>
        </organizationnamedetails>
      </namedetails>
      <addressdetails>ATTN: Dept XYZ<thoroughfare>3905 37th Street NW</thoroughfare>
        <locality>Rochester, MN<postalcode>55901</postalcode></locality>
        <country>USA</country>
      </addressdetails>
      <contactnumbers>
        <contactnumber type="telephone">800-555-1212</contactnumber>
        <contactnumber type="fax">800-555-1213</contactnumber>
      </contactnumbers>
      <emailaddresses><emailaddress>fred@example.com</emailaddress></emailaddresses>
      <urls><url>http://www.example.com/fred</url></urls>
   </organizationinfo>
  </authorinformation>
  <prodinfo>
    <prodname>My Product</prodname>
    <vrmlist><vrm release="Release 1" version="Version 3"/></vrmlist>
  </prodinfo>
  <bookid>
    <bookpartno>99F9999</bookpartno>
    <booknumber>SC00-0000-00</booknumber>
    <maintainer href="#rcf"></maintainer>
  </bookid>
  <bookrights>
    <copyrfirst><year>1996</year></copyrfirst>
    <copyrlast><year>2006</year></copyrlast>
    <bookowner><organization>OASIS</organization></bookowner>
  </bookrights>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
lockmeta | Indicates whether any of the meta information should be replaced by meta information in the referenced topic. If the value is yes, the information inside <topicmeta> should not be replaced with information from the topic. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2 Bookmap metadata elements
Next topic: 3.2.5.2.2 approved


approved

3.2.5.2.2 approved

The <approved> element contains information about when and by whom the book was approved during its publication history.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (organization) or (person) ) (any number) then (revisionid) (optional) then (started) (optional) then (completed) (optional) then (summary) (optional) then (data) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookchangehistory

Inheritance

- topic/data bookmap/approved

Example

See the example in bookchangehistory.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.1 bookmeta
Next topic: 3.2.5.2.3 bookchangehistory


bookchangehistory

3.2.5.2.3 bookchangehistory

The <bookchangehistory> element contains information about the history of the book's creation and publishing lifecycle, including who wrote, reviewed, edited, and tested the book. It also specifies when these events took place.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (reviewed) (any number) then (edited) (any number) then (tested) (any number) then (approved) (any number) then (bookevent) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmeta

Inheritance

- topic/data bookmap/bookchangehistory

Example

<bookmeta>
  <bookchangehistory>
    <reviewed>
      <started><year>2007</year><month>10</month></started>
      <completed><year>2008</year><month>01</month></completed>
    </reviewed>
    <edited>
      <person>Joe T. Editor</person>
      <completed><year>2008</year><month>03</month><day>15</day></completed>
    </edited>
    <tested>
      <organization>OASIS</organization>
      <completed><year>2008</year><month>04</month></completed>
    </tested>
    <approved>
      <organization>OASIS</organization>
      <completed><year>2008</year><month>05</month></completed>
    </approved>
    <bookevent>
      <bookeventtype name="Type of Major Event"/>
      <completed><year>2009</year></completed>
    </bookevent>
  </bookchangehistory>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.2 approved
Next topic: 3.2.5.2.4 bookevent


bookevent

3.2.5.2.4 bookevent

The <bookevent> element indicates a general event in the publication history of a book. This is an appropriate element for specialization if the current set of specific book event types does not meet your needs. If an element already exists to describe a specific type of event, such as <reviewed>, <edited>, or <approved>, that element should be used instead.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (bookeventtype) (optional) then ( ( (organization) or (person) ) (any number) then (revisionid) (optional) then (started) (optional) then (completed) (optional) then (summary) (optional) then (data) (any number) ) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookchangehistory

Inheritance

- topic/data bookmap/bookevent

Example

See the example in bookchangehistory.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.3 bookchangehistory
Next topic: 3.2.5.2.5 bookeventtype


bookeventtype

3.2.5.2.5 bookeventtype

The <bookeventtype> element indicates the specific nature of a <bookevent>, such as updated, indexed, or deprecated. The required name attribute indicates the event's type.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | bookevent

Inheritance

- topic/data bookmap/bookeventtype

Example

See the example in bookchangehistory.

Attributes

Name | Description | Data Type | Default Value | Required?
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
name | The name of the event represented by this element. | CDATA | #REQUIRED | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.4 bookevent
Next topic: 3.2.5.2.6 bookid


bookid

3.2.5.2.6 bookid

The <bookid> element contains the publisher's identification information for the book, such as part number, edition number and ISBN number.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (bookpartno) (any number) then (edition) (optional) then (isbn) (optional) then (booknumber) (optional) then (volume) (any number) then (maintainer) (optional) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmeta

Inheritance

- topic/data bookmap/bookid

Example

See bookmeta.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.5 bookeventtype
Next topic: 3.2.5.2.7 booknumber


booknumber

3.2.5.2.7 booknumber

The <booknumber> element contains the book's form number, such as SC21-1920.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookid

Inheritance

- topic/data bookmap/booknumber

Example

In this example, "99F1234" is a part number assigned to this book by the publisher, while SC21-1234-00 is a number that identifies this book among all of the author's works.

<bookmeta>
 <bookid>
  <bookpartno>99F1234</bookpartno>
  <booknumber>SC21-1234-00</booknumber>
 </bookid>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.6 bookid
Next topic: 3.2.5.2.8 bookowner


bookowner

3.2.5.2.8 bookowner

The <bookowner> element contains the owner of the copyright.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (organization) or (person) ) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookrights

Inheritance

- topic/data bookmap/bookowner

Example

<bookmeta>
  <bookrights>
    <copyrfirst><year>1994</year></copyrfirst>
    <copyrlast><year>2006</year></copyrlast>
    <bookowner>
      <organization>Example Corporation</organization>
    </bookowner>
  </bookrights>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.7 booknumber
Next topic: 3.2.5.2.9 bookpartno


bookpartno

3.2.5.2.9 bookpartno

The <bookpartno> element contains the book's part number, such as 99F1234. A publisher may use a number like this one to identify a book for tracking purposes.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookid

Inheritance

- topic/data bookmap/bookpartno

Example

In this example, "99F1234" is a part number assigned to this book by the publisher, while SC21-1234-00 is a number that identifies this book among all of the author's works.

<bookmeta>
 <bookid>
  <bookpartno>99F1234</bookpartno>
  <booknumber>SC21-1234-00</booknumber>
 </bookid>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.8 bookowner
Next topic: 3.2.5.2.10 bookrestriction


bookrestriction

3.2.5.2.10 bookrestriction

The <bookrestriction> element indicates whether the book is classified or restricted in some way. The value attribute indicates any restrictions on the use of the material, such as declaring the information confidential or for licensed use only.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | bookrights

Inheritance

- topic/data bookmap/bookrestriction

Example

<bookrights>
  <copyrfirst><year>1994</year></copyrfirst>
  <copyrlast><year>2006</year></copyrlast>
  <bookowner><organization>Example Corporation</organization></bookowner>
  <bookrestriction value="unclassified"/>
</bookrights>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
value | Describes restrictions on this version of the publication. Beginning with DITA 1.2, values in this attribute are not limited to a small number of choices; the following values were used in DITA 1.0 and DITA 1.1, and are still provided as sample values: confidential, restricted, licensed, unclassified, and -dita-use-​conref-​target. | NMTOKEN | (beta | limited | general | -dita-use-​conref-​target) | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.9 bookpartno
Next topic: 3.2.5.2.11 bookrights


bookrights

3.2.5.2.11 bookrights

The <bookrights> element contains the information about the legal rights associated with the book, including copyright dates and owners.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (copyrfirst) (optional) then (copyrlast) (optional) then (bookowner) then (bookrestriction) (optional) then (summary) (optional) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmeta

Inheritance

- topic/data bookmap/bookrights

Example

See bookmeta.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.10 bookrestriction
Next topic: 3.2.5.2.12 completed


completed

3.2.5.2.12 completed

The <completed> element indicates a completion date for some type of book event, such as a review, editing, or testing.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (year) then ( (month) then (day) (optional) ) (optional) ) or ( (month) then (day) (optional) then (year) ) or ( (day) then (month) then (year) ) )

Contained by

Doctype | Content model
bookmap, learningBookmap | published, reviewed, edited, tested, approved, bookevent

Inheritance

- topic/ph bookmap/completed

Example

See the example in bookchangehistory.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.11 bookrights
Next topic: 3.2.5.2.13 copyrfirst


copyrfirst

3.2.5.2.13 copyrfirst

The <copyfirst> element contains the first copyright year within a multiyear copyright statement.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | (year)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookrights

Inheritance

- topic/data bookmap/copyrfirst

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.12 completed
Next topic: 3.2.5.2.14 copyrlast


copyrlast

3.2.5.2.14 copyrlast

The <copylast> element contains the last copyright year within a multiyear copyright statement.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | (year)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookrights

Inheritance

- topic/data bookmap/copyrlast

Example

See the example in bookmap.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.13 copyrfirst
Next topic: 3.2.5.2.15 day


day

3.2.5.2.15 day

The <day> element denotes a day of the month.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | started, started, started, completed, completed, completed

Inheritance

- topic/ph bookmap/day

Example

<bookchangehistory>
  <edited>
    <person>Joe T. Editor</person>
    <completed><year>2008</year><month>10</month><day>13</day></completed>
  </edited>
</bookchangehistory>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.14 copyrlast
Next topic: 3.2.5.2.16 edited


edited

3.2.5.2.16 edited

The <edited> element contains information about when and by whom the book was edited during its publication history.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (organization) or (person) ) (any number) then (revisionid) (optional) then (started) (optional) then (completed) (optional) then (summary) (optional) then (data) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookchangehistory

Inheritance

- topic/data bookmap/edited

Example

See the example in bookchangehistory.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.15 day
Next topic: 3.2.5.2.17 edition


edition

3.2.5.2.17 edition

The <edition> element contains the edition number information, such as First Edition, or Third Edition, used by a publisher to identify a book.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookid

Inheritance

- topic/data bookmap/edition

Example

<bookmeta>
  <bookid>
    <edition>1</edition>
  </bookid>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.16 edited
Next topic: 3.2.5.2.18 isbn


isbn

3.2.5.2.18 isbn

The <isbn> element contains the book's International Standard Book Number (ISBN).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookid

Inheritance

- topic/data bookmap/isbn

Example

<bookmeta>
  <bookid>
    <isbn>978-0141000039</isbn>
  </bookid>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.17 edition
Next topic: 3.2.5.2.19 maintainer


maintainer

3.2.5.2.19 maintainer

The <maintainer> element contains information about who maintains the document; the maintainer may be an organization or a person.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (person) or (organization) ) (any number) then (data) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookid

Inheritance

- topic/data bookmap/maintainer

Example

See the example in bookmeta.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.18 isbn
Next topic: 3.2.5.2.20 month


month

3.2.5.2.20 month

The <month> element denotes a month of the year.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | started, started, started, completed, completed, completed

Inheritance

- topic/ph bookmap/month

Example

<bookchangehistory>
  <edited>
    <person>Joe T. Editor</person>
    <completed><year>2008</year><month>10</month><day>13</day></completed>
  </edited>
</bookchangehistory>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.19 maintainer
Next topic: 3.2.5.2.21 organization


organization

3.2.5.2.21 organization

The <organization> element contains the name of an organization. Note that unlike <organizationname>, the <organization> element is not restricted to use within <authorinformation>; it does not have to contain the name of an authoring organization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | publisherinformation, published, reviewed, edited, tested, approved, bookevent, maintainer, bookowner

Inheritance

- topic/data bookmap/organization

Example

<bookmeta>
  <bookrights>
    <copyrfirst><year>1996</year></copyrfirst>
    <copyrlast><year>2006</year></copyrlast>
    <bookowner><organization>OASIS</organization></bookowner>
  </bookrights>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.20 month
Next topic: 3.2.5.2.22 person


person

3.2.5.2.22 person

The <person> element contains information about the name of a person. Note that unlike the <personname> element, the <person> element is not restricted to describing the names of authors.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | publisherinformation, published, reviewed, edited, tested, approved, bookevent, maintainer, bookowner

Inheritance

- topic/data bookmap/person

Example

<bookmeta>
  <bookrights>
    <copyrfirst><year>1977</year></copyrfirst>
    <copyrlast><year>2008</year></copyrlast>
    <bookowner><person>Jane Doe</person></bookowner>
  </bookrights>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.21 organization
Next topic: 3.2.5.2.23 printlocation


printlocation

3.2.5.2.23 printlocation

The <printlocation> element indicates the location where the book was printed. Customarily, the content is restricted to the name of the country.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | publisherinformation

Inheritance

- topic/data bookmap/printlocation

Example

See the example in publisherinformation.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.22 person
Next topic: 3.2.5.2.24 published


published

3.2.5.2.24 published

The <published> element contains information about the person or organization publishing the book, the dates when it was started and completed, and any special restrictions associated with it.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (person) or (organization) ) (any number) then (publishtype) (optional) then (revisionid) (optional) then (started) (optional) then (completed) (optional) then (summary) (optional) then (data) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | publisherinformation

Inheritance

- topic/data bookmap/published

Example

See the example in publisherinformation.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.23 printlocation
Next topic: 3.2.5.2.25 publisherinformation


publisherinformation

3.2.5.2.25 publisherinformation

The <publisherinformation> contains information about what group or person published the book, where it was published, and certain details about its publication history. Other publication history information is found in the <bookchangehistory> element.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (person) or (organization) ) (any number) then (printlocation) (any number) then (published) (any number) then (data) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookmeta

Inheritance

- topic/publisher bookmap/publisherinformation

Example

<bookmeta>
  <publisherinformation>
    <organization>Example Publishers</organization>
    <printlocation>Austin, TX</printlocation>
    <published>
      <publishtype value="general"/>
      <completed><year>1977</year></completed>
    </published>
  </publisherinformation>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.24 published
Next topic: 3.2.5.2.26 publishtype


publishtype

3.2.5.2.26 publishtype

The <publishtype> element indicates whether the book is generally available from the publisher or is restricted in some way. The value attribute indicates the restrictions, such as beta release, limited availability, or general availability.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | no content

Contained by

Doctype | Content model
bookmap, learningBookmap | published

Inheritance

- topic/data bookmap/publishtype

Example

See the example in publisherinformation.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
value | Describes the status of this publication. Beginning with DITA 1.2, values in this attribute are not limited to a small number of values; the following values were used in DITA 1.0 and DITA 1.1: beta, limited, general, and -dita-use-​conref-​target. | CDATA | NMTOKEN | Yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.25 publisherinformation
Next topic: 3.2.5.2.27 reviewed


reviewed

3.2.5.2.27 reviewed

The <reviewed> element contains information about when and by whom the book was reviewed during its publication history.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (organization) or (person) ) (any number) then (revisionid) (optional) then (started) (optional) then (completed) (optional) then (summary) (optional) then (data) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookchangehistory

Inheritance

- topic/data bookmap/reviewed

Example

See the example in bookchangehistory.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.26 publishtype
Next topic: 3.2.5.2.28 revisionid


revisionid

3.2.5.2.28 revisionid

The <revisionid> element indicates the revision number or revision ID of the book. The processing implementation determines how the level is displayed. Common methods include using a dash, for example "-01", or a period, such as ".01".

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | published, reviewed, edited, tested, approved, bookevent

Inheritance

- topic/ph bookmap/revisionid

Example

<bookchangehistory>
  <edited>
    <person>Joe T. Editor</person>
    <revisionid>1</revisionid>
    <completed><year>2008</year><month>03</month><day>15</day></completed>
  </edited>
  <edited>
    <person>Joe T. Editor</person>
    <revisionid>2</revisionid>
    <completed><year>2008</year><month>10</month><day>13</day></completed>
  </edited>
</bookchangehistory>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.27 reviewed
Next topic: 3.2.5.2.29 started


started

3.2.5.2.29 started

The <started> element indicates a start date for some type of book event, such as a review, editing, or testing.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (year) then ( (month) then (day) (optional) ) (optional) ) or ( (month) then (day) (optional) then (year) ) or ( (day) then (month) then (year) ) )

Contained by

Doctype | Content model
bookmap, learningBookmap | published, reviewed, edited, tested, approved, bookevent

Inheritance

- topic/ph bookmap/started

Example

See the example in bookchangehistory.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.28 revisionid
Next topic: 3.2.5.2.30 summary


summary

3.2.5.2.30 summary

The <summary> element contains a text summary associated with a book event (such as <approved> or <reviewed>) or with the list of copyrights for the book.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | published, reviewed, edited, tested, approved, bookevent, bookrights

Inheritance

- topic/ph bookmap/summary

Example

<bookchangehistory>
  <edited>
    <person>Joe T. Editor</person>
    <revisionid>1</revisionid>
    <completed><year>2008</year><month>03</month><day>15</day></completed>
    <summary>Added several new topics</summary>
  </edited>
  <edited>
    <person>Joe T. Editor</person>
    <revisionid>2</revisionid>
    <completed><year>2008</year><month>10</month><day>13</day></completed>
    <summary>Fixed a few typos</summary>
  </edited>
</bookchangehistory>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.29 started
Next topic: 3.2.5.2.31 tested


tested

3.2.5.2.31 tested

The <tested> element contains information about when and by whom the book was tested during its publication history.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( ( (organization) or (person) ) (any number) then (revisionid) (optional) then (started) (optional) then (completed) (optional) then (summary) (optional) then (data) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | bookchangehistory

Inheritance

- topic/data bookmap/tested

Example

See the example in bookchangehistory.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.30 summary
Next topic: 3.2.5.2.32 volume


volume

3.2.5.2.32 volume

The <volume> element contains the book's volume number, such as Volume 2.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | bookid

Inheritance

- topic/data bookmap/volume

Example

<bookmeta>
  <bookid><volume>2</volume></bookid>
</bookmeta>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.31 tested
Next topic: 3.2.5.2.33 year


year

3.2.5.2.33 year

The <year> element denotes a year.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | started, started, started, completed, completed, completed, copyrfirst, copyrlast

Inheritance

- topic/ph bookmap/year

Example

<bookchangehistory>
  <edited>
    <person>Joe T. Editor</person>
    <completed><year>2008</year><month>10</month><day>13</day></completed>
  </edited>
</bookchangehistory>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.5.2 Bookmap metadata elements
Previous topic: 3.2.5.2.32 volume
Next topic: 3.2.6 Domain elements


Domain elements

3.2.6 Domain elements

Domains in this section include those generally associated with technical content, such as the programming and software domains.

  • 3.2.6.1 Task requirements domain
    The task requirements domain contains elements for use in describing tasks that involve machines or other pieces of hardware.
  • 3.2.6.2 Programming elements
    The programming domain elements are used to define the syntax and to give examples of programming languages.
  • 3.2.6.3 Software elements
    The software domain elements are used to describe the operation of a software program.
  • 3.2.6.4 User interface elements
    The user interface domain elements are used to describe the user interface of a software program.
  • 3.2.6.5 xNAL domain elements
    The xNAL domain elements represent a subset of the Extensible Name and Address Standard. It is used to encode information about the author or authors of DITA information. The domain can be included in any DITA document type shell that requires additional metadata for names and addresses, although the implementations provided by OASIS only include it in the bookmap document type.
Parent topic: 3.2 Technical content elements
Previous topic: 3.2.5.2.33 year
Next topic: 3.2.6.1 Task requirements domain


Task requirements domain

3.2.6.1 Task requirements domain

The task requirements domain contains elements for use in describing tasks that involve machines or other pieces of hardware.

  • 3.2.6.1.1 prelreqs
    The <prelreqs> element contains information about preliminary requirements – the things the user needs to know or do before starting a task. This element contains information about personnel requirements, safety conditions, support equipment, supplies, and spare parts.
  • 3.2.6.1.2 closereqs
    The <closereqs> element contains information about closing requirements – steps or tasks that the user should perform after completing a task, for example, "Check around the vehicle for any drips or leaks."
  • 3.2.6.1.3 reqconds
    The <reqconds> element contains information about conditions that must be fulfilled before performing a task.
  • 3.2.6.1.4 reqcond
    The <reqcond> element specifies a condition that must be fulfilled before performing a task, for example, "Rear Oil Seal replacement."
  • 3.2.6.1.5 noconds
    The <noconds> element specifies that there are no conditions to be fulfilled before performing a task.
  • 3.2.6.1.6 reqcontp
    The <reqcontp> element specifies a technical publication that can be used to fulfill a condition before performing a task. It may also specify a publication that is required in order to fulfill the condition, such as a list of local regulations.
  • 3.2.6.1.7 reqpers
    The <reqpers> element contains information about the personnel who are required to perform a task. This information might specify the number of workers, the type and skill level of the workers, and the length of time that they will need to perform the task.
  • 3.2.6.1.8 personnel
    The <personnel> element specifies the minimum number of workers who are required to perform a task.
  • 3.2.6.1.9 perscat
    The <perscat> element specifies the type or category of workers that is required by a task.
  • 3.2.6.1.10 perskill
    The <perskill> element specifies the skill level of the workers who must perform the task.
  • 3.2.6.1.11 esttime
    The <esttime> element provides an estimate of the time that is required to perform a task.
  • 3.2.6.1.12 supeqli
    The <supeqli> element contains a list of the tools, support equipment, or monitoring equipment that is required to perform a task. These pieces of support equipment need to be assembled prior to beginning the task.
  • 3.2.6.1.13 supequi
    The <supequi> element specifies a tool, a piece of support equipment, or a piece of monitoring equipment that is needed to perform a task, such as a slide hammer.
  • 3.2.6.1.14 supequip
    The <supequip> element contains information about the support equipment that is required to perform a task. This element either contains children elements that specify particular items of support equipment or a <nosupreq> element that specifies that no support equipment is required.
  • 3.2.6.1.15 nosupeq
    The <nosupeq> element indicates that there is no support equipment required to perform a task.
  • 3.2.6.1.16 supplies
    The <supplies> element contains information about the supplies or parts that are required to perform a task. These supplies or parts need to be available prior to beginning the task. This element either contains children elements that specify particular supplies or a <nosupply> element that indicates that no supplies are needed.
  • 3.2.6.1.17 supply
    The <supply> element contains information about a single supply in a list of supplies that are needed to perform a task.
  • 3.2.6.1.18 supplyli
    The <supplyli> element specifies a list of supplies needed to perform a task.
  • 3.2.6.1.19 nosupply
    The <nosupply> element specifies that no supplies are needed to perform a task.
  • 3.2.6.1.20 spare
    The <spare> element specifies a particular spare part that is required to perform a task, for example, a "dipstick."
  • 3.2.6.1.21 spares
    The <spares> element contains information about the spare parts that are needed for a task. This information might specify particular spare parts or it might state that no spare parts are required.
  • 3.2.6.1.22 sparesli
    The <sparesli> element contains information about the spare parts that are required to perform a task.
  • 3.2.6.1.23 nospares
    The <nospares> element specifies that no spare parts are needed to perform a task.
  • 3.2.6.1.24 nosafety
    The <nosafety> element specifies that there are no safety conditions that must be considered.
  • 3.2.6.1.25 safecond
    The <safecond> element specifies a safety condition that must be considered prior to completing a task. It may also contain a complete hazard statement.
  • 3.2.6.1.26 safety
    The <safety> element contains information about safety conditions. This element either contains children elements that describe safety conditions or a <nosafety> element that indicates that there are no safety conditions that must be considered.
Parent topic: 3.2.6 Domain elements
Previous topic: 3.2.6 Domain elements
Next topic: 3.2.6.1.1 prelreqs


prelreqs

3.2.6.1.1 prelreqs

The <prelreqs> element contains information about preliminary requirements – the things the user needs to know or do before starting a task. This element contains information about personnel requirements, safety conditions, support equipment, supplies, and spare parts.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( (reqconds) (optional) then (reqpers) (optional) then (supequip) (optional) then (supplies) (optional) then (spares) (optional) then (safety) (optional) )

Contained by

Doctype | Content model
machineryTask | taskbody

Inheritance

+ topic/section task/prereq mitask-d/prelreqs

Example

<prelreqs>
 <reqconds>
  <reqcond>Rear Oil Seal replacement</reqcond>
  <reqcontp>Motor Oil Guide</reqcontp>
 </reqconds>
 <reqpers>
  <personnel>2</personnel>
  <perscat>Mechanic</perscat>
  <perskill>Expert</perskill>
  <esttime>2 hours</esttime>
 </reqpers>
 <supequip>
  <supeqli>
   <supequi>Driver handle</supequi>
   <supequi>Slide hammer</supequi>
   <supequi>Axle seal installer</supequi>
  </supeqli>
</supequip>
<supplies>
 <nosupply/>
</supplies>
<spares>
 <sparesli>
  <spare>dipstick</spare>
  <spare>engine oil</spare>
 </sparesli>
</spares>
<safety>
 <safecond>All personnel shall wear safety shoes and protective
 clothing to reduce the chance of injury.</safecond>
</safety>
</prelreqs>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1 Task requirements domain
Next topic: 3.2.6.1.2 closereqs


closereqs

3.2.6.1.2 closereqs

The <closereqs> element contains information about closing requirements – steps or tasks that the user should perform after completing a task, for example, "Check around the vehicle for any drips or leaks."

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | (reqconds)

Contained by

Doctype | Content model
machineryTask | taskbody

Inheritance

+ topic/section task/postreq mitask-d/closereqs

Example

<closereqs>
  <reqconds>
    <reqcond>Run the engine and then check the
    dipstick to ensure the vehicle has enough
    oil. </reqcond>
    <reqcond>Check around the vehicle for any
    drips or leaks. </reqcond>
  </reqconds>
</closereqs>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.1 prelreqs
Next topic: 3.2.6.1.3 reqconds


reqconds

3.2.6.1.3 reqconds

The <reqconds> element contains information about conditions that must be fulfilled before performing a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( (noconds) or ( (reqcond) or (reqcontp) ) (one or more) )

Contained by

Doctype | Content model
machineryTask | prelreqs, closereqs

Inheritance

+ topic/ol task/ol mitask-d/reqconds

Example

<reqconds>
  <reqcond>The system placed on an accessible, flat surface.</reqcond>
  <reqcond>All anti-static discharge wrist-straps available.</reqcond>
</reqconds>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.2 closereqs
Next topic: 3.2.6.1.4 reqcond


reqcond

3.2.6.1.4 reqcond

The <reqcond> element specifies a condition that must be fulfilled before performing a task, for example, "Rear Oil Seal replacement."

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | reqconds

Inheritance

+ topic/li task/li mitask-d/reqcond

Example

<reqconds>
  <reqcond>The system placed on an accessible, flat surface.</reqcond>
  <reqcond>All anti-static discharge wrist-straps available.</reqcond>
</reqconds>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.3 reqconds
Next topic: 3.2.6.1.5 noconds


noconds

3.2.6.1.5 noconds

The <noconds> element specifies that there are no conditions to be fulfilled before performing a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | no content

Contained by

Doctype | Content model
machineryTask | reqconds

Inheritance

+ topic/li task/li mitask-d/noconds

Example

<reqconds>
    <noconds/>
</reqconds>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.4 reqcond
Next topic: 3.2.6.1.6 reqcontp


reqcontp

3.2.6.1.6 reqcontp

The <reqcontp> element specifies a technical publication that can be used to fulfill a condition before performing a task. It may also specify a publication that is required in order to fulfill the condition, such as a list of local regulations.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | reqconds

Inheritance

+ topic/li task/li mitask-d/reqcontp

Example

<reqconds>
  <reqcontp>USDOD-43109: Preparing your Patriot Missile Control Unit for Railroad Portage.</reqcontp>
  <reqcond>The system placed on an accessible, flat surface.</reqcond>
  <reqcond>All anti-static discharge wrist-straps available.</reqcond>
</reqconds>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.5 noconds
Next topic: 3.2.6.1.7 reqpers


reqpers

3.2.6.1.7 reqpers

The <reqpers> element contains information about the personnel who are required to perform a task. This information might specify the number of workers, the type and skill level of the workers, and the length of time that they will need to perform the task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( (personnel) then ( (perscat) (optional) then (perskill) (optional) then (esttime) (optional) ) (optional) ) (one or more)

Contained by

Doctype | Content model
machineryTask | prelreqs

Inheritance

+ topic/ol task/ol mitask-d/reqpers

Example

<reqpers>
 <personnel>2</personnel>
 <perscat>Mechanic</perscat>
 <perskill>Expert</perskill>
 <esttime>2 hours</esttime>
</reqpers>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.6 reqcontp
Next topic: 3.2.6.1.8 personnel


personnel

3.2.6.1.8 personnel

The <personnel> element specifies the minimum number of workers who are required to perform a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | reqpers

Inheritance

+ topic/li task/li mitask-d/personnel

Example

<reqpers>
 <personnel>2</personnel>
 <perscat>Mechanic</perscat>
 <perskill>Expert</perskill>
 <esttime>2 hours</esttime>
</reqpers>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.7 reqpers
Next topic: 3.2.6.1.9 perscat


perscat

3.2.6.1.9 perscat

The <perscat> element specifies the type or category of workers that is required by a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | reqpers

Inheritance

+ topic/li task/li mitask-d/perscat

Example

<reqpers>
 <personnel>2</personnel>
 <perscat>Mechanic</perscat>
 <perskill>Expert</perskill>
 <esttime>2 hours</esttime>
</reqpers>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.8 personnel
Next topic: 3.2.6.1.10 perskill


perskill

3.2.6.1.10 perskill

The <perskill> element specifies the skill level of the workers who must perform the task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | reqpers

Inheritance

+ topic/li task/li mitask-d/perskill

Example

<reqpers>
 <personnel>2</personnel>
 <perscat>Mechanic</perscat>
 <perskill>Expert</perskill>
 <esttime>2 hours</esttime>
</reqpers>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.9 perscat
Next topic: 3.2.6.1.11 esttime


esttime

3.2.6.1.11 esttime

The <esttime> element provides an estimate of the time that is required to perform a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | reqpers

Inheritance

+ topic/li task/li mitask-d/esttime

Example

<reqpers>
 <personnel>2</personnel>
 <perscat>Mechanic</perscat>
 <perskill>Expert</perskill>
 <esttime>2 hours</esttime>
</reqpers>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.10 perskill
Next topic: 3.2.6.1.12 supeqli


supeqli

3.2.6.1.12 supeqli

The <supeqli> element contains a list of the tools, support equipment, or monitoring equipment that is required to perform a task. These pieces of support equipment need to be assembled prior to beginning the task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | (supequi) (one or more)

Contained by

Doctype | Content model
machineryTask | supequip

Inheritance

+ topic/ul task/ul mitask-d/supeqli

Example

<supequip>
 <supeqli>
  <supequi>Driver handle</supequi>
  <supequi>Slide hammer</supequi>
  <supequi>Axle seal installer</supequi>
 </supeqli>
</supequip>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.11 esttime
Next topic: 3.2.6.1.13 supequi


supequi

3.2.6.1.13 supequi

The <supequi> element specifies a tool, a piece of support equipment, or a piece of monitoring equipment that is needed to perform a task, such as a slide hammer.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | supeqli

Inheritance

+ topic/li task/li mitask-d/supequi

Example

<supequip>
 <supeqli>
  <supequi>Driver handle</supequi>
  <supequi>Slide hammer</supequi>
  <supequi>Axle seal installer</supequi>
 </supeqli>
</supequip>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.12 supeqli
Next topic: 3.2.6.1.14 supequip


supequip

3.2.6.1.14 supequip

The <supequip> element contains information about the support equipment that is required to perform a task. This element either contains children elements that specify particular items of support equipment or a <nosupreq> element that specifies that no support equipment is required.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( (nosupeq) or (supeqli) )

Contained by

Doctype | Content model
machineryTask | prelreqs

Inheritance

+ topic/p task/p mitask-d/supequip

Example

<supequip>
 <supeqli>
  <supequi>Driver handle</supequi>
  <supequi>Slide hammer</supequi>
  <supequi>Axle seal installer</supequi>
 </supeqli>
</supequip>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.13 supequi
Next topic: 3.2.6.1.15 nosupeq


nosupeq

3.2.6.1.15 nosupeq

The <nosupeq> element indicates that there is no support equipment required to perform a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | no content

Contained by

Doctype | Content model
machineryTask | supequip

Inheritance

+ topic/data task/data mitask-d/nosupeq

Example

<supequip>
    <nosupeq/>
</supequip>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.14 supequip
Next topic: 3.2.6.1.16 supplies


supplies

3.2.6.1.16 supplies

The <supplies> element contains information about the supplies or parts that are required to perform a task. These supplies or parts need to be available prior to beginning the task. This element either contains children elements that specify particular supplies or a <nosupply> element that indicates that no supplies are needed.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( (nosupply) or (supplyli) )

Contained by

Doctype | Content model
machineryTask | prelreqs

Inheritance

+ topic/p task/p mitask-d/supplies

Example

<supplies>
 <supplyli>
   <supply>gasket</supply>
   <supply>engine oil</supply>
 </supplyli>
</supplies>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.15 nosupeq
Next topic: 3.2.6.1.17 supply


supply

3.2.6.1.17 supply

The <supply> element contains information about a single supply in a list of supplies that are needed to perform a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | supplyli

Inheritance

+ topic/li task/li mitask-d/supply

Example

<supplies>
  <supplyli>
    <supply>gasket</supply>
    <supply>engine oil</supply>
  </supplyli>
</supplies>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.16 supplies
Next topic: 3.2.6.1.18 supplyli


supplyli

3.2.6.1.18 supplyli

The <supplyli> element specifies a list of supplies needed to perform a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | (supply) (one or more)

Contained by

Doctype | Content model
machineryTask | supplies

Inheritance

+ topic/ul task/ul mitask-d/supplyli

Example

<supplies>
  <supplyli>
    <supply>gasket</supply>
    <supply>engine oil</supply>
  </supplyli>
</supplies>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.17 supply
Next topic: 3.2.6.1.19 nosupply


nosupply

3.2.6.1.19 nosupply

The <nosupply> element specifies that no supplies are needed to perform a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | no content

Contained by

Doctype | Content model
machineryTask | supplies

Inheritance

+ topic/data task/data mitask-d/nosupply

Example

<supplies>
    <nosupply/>
</supplies>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.18 supplyli
Next topic: 3.2.6.1.20 spare


spare

3.2.6.1.20 spare

The <spare> element specifies a particular spare part that is required to perform a task, for example, a "dipstick."

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | sparesli

Inheritance

+ topic/li task/li mitask-d/spare

Example

<spares>
 <sparesli>
  <spare>dipstick</spare>
  <spare>engine oil</spare>
 </sparesli>
</spares>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.19 nosupply
Next topic: 3.2.6.1.21 spares


spares

3.2.6.1.21 spares

The <spares> element contains information about the spare parts that are needed for a task. This information might specify particular spare parts or it might state that no spare parts are required.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( (nospares) or (sparesli) )

Contained by

Doctype | Content model
machineryTask | prelreqs

Inheritance

+ topic/p task/p mitask-d/spares

Example

<spares>
 <sparesli>
  <spare>dipstick</spare>
  <spare>engine oil</spare>
 </sparesli>
</spares>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.20 spare
Next topic: 3.2.6.1.22 sparesli


sparesli

3.2.6.1.22 sparesli

The <sparesli> element contains information about the spare parts that are required to perform a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | (spare) (one or more)

Contained by

Doctype | Content model
machineryTask | spares

Inheritance

+ topic/ul task/ul mitask-d/sparesli

Example

<spares>
 <sparesli>
  <spare>dipstick</spare>
  <spare>engine oil</spare>
 </sparesli>
</spares>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.21 spares
Next topic: 3.2.6.1.23 nospares


nospares

3.2.6.1.23 nospares

The <nospares> element specifies that no spare parts are needed to perform a task.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | no content

Contained by

Doctype | Content model
machineryTask | spares

Inheritance

+ topic/data task/data mitask-d/nospares

Example

<spares>
    <nospares/>
</spares>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.22 sparesli
Next topic: 3.2.6.1.24 nosafety


nosafety

3.2.6.1.24 nosafety

The <nosafety> element specifies that there are no safety conditions that must be considered.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | no content

Contained by

Doctype | Content model
machineryTask | safety

Inheritance

+ topic/li task/li mitask-d/nosafety

Example

<safety>
    <nosafety/>
</safety>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.23 nospares
Next topic: 3.2.6.1.25 safecond


safecond

3.2.6.1.25 safecond

The <safecond> element specifies a safety condition that must be considered prior to completing a task. It may also contain a complete hazard statement.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( text data or dl or fig or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or screen or simpletable or sl or table or ul or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
machineryTask | safety

Inheritance

+ topic/li task/li mitask-d/safecond

Example

<safety>
  <safecond>All power sources disconnected from the system.</safecond>
  <safecond>All networking cables disconnected from the system.</safecond>
</safety>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.24 nosafety
Next topic: 3.2.6.1.26 safety


safety

3.2.6.1.26 safety

The <safety> element contains information about safety conditions. This element either contains children elements that describe safety conditions or a <nosafety> element that indicates that there are no safety conditions that must be considered.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
machineryTask | ( (nosafety) or (safecond) (one or more) )

Contained by

Doctype | Content model
machineryTask | prelreqs

Inheritance

+ topic/ol task/ol mitask-d/safety

Example

<safety>
  <safecond>All power sources disconnected from the system.</safecond>
  <safecond>All networking cables disconnected from the system.</safecond>
</safety>

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.6.1 Task requirements domain
Previous topic: 3.2.6.1.25 safecond
Next topic: 3.2.6.2 Programming elements


Programming elements

3.2.6.2 Programming elements

The programming domain elements are used to define the syntax and to give examples of programming languages.

  • 3.2.6.2.1 apiname
    The <apiname> element provides the name of an application programming interface (API) such as a Java class name or method name. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.2 codeblock
    The <codeblock> element represents lines of program code. Like the <pre> element, line endings and spaces inside the element must be preserved, and the content is typically rendered in a monospaced font. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.3 coderef
    The <coderef> element references an external file that contains literal code. When evaluated, the <coderef> element should cause the target code to be displayed inline. If the target contains non-XML characters such as '<' or '&', those will need to be handled in a way that they may be displayed correctly by the final rendering engine. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.4 codeph
    The code phrase (<codeph>) element represents a snippet of code within the main flow of text. The code phrase is displayed in a monospaced font for emphasis. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.5 option
    The <option> element describes an option that can be used to modify a command (or something else, like a configuration). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.6 parmname
    When referencing the name of an application programming interface parameter within the text flow of your topic, use the parameter name (<parmname>) element to mark up the parameter. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.7 parml
    The parameter list (<parml>) element contains a list of terms and definitions that describes the parameters in an application programming interface. This is a special kind of definition list that is designed for documenting programming parameters. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.8 plentry
    The parameter list entry element (<plentry>) contains one or more parameter terms and definitions (pt and pd). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.9 pt
    A parameter term, within a parameter list entry, is enclosed by the <pt> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.10 pd
    A parameter definition, within a parameter list entry, is enclosed by the <pd> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.11 synph
    The syntax phrase (<synph>) element is a container for syntax definition elements. It is used when a complete syntax diagram is not needed, but some of the syntax elements, such as kwd, oper, delim, are used within the text flow of the topic content. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.12 syntaxdiagram
    The syntax diagram (<syntaxdiagram>) element is the main container for all the syntax elements that make up a syntax definition. The syntax diagram represents the syntax of a statement from a computer language or a command, function call, or programming language statement. Traditionally, the syntax diagram is formatted with "railroad tracks" that connect the units of the syntax together, but this presentation may differ depending on the output media. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.13 groupseq
    The <groupseq> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. Within the syntax definition, groups of keywords, delimiters and other syntax units act as a combined unit, and they occur in a specific sequence, as delimited by the <groupseq> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.14 groupchoice
    The <groupchoice> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. A group choice specifies that the user must make a choice about which part of the syntax to use. Groups are often nested. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.15 groupcomp
    The <groupcomp> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. The group composite means that the items that make up the syntax diagram will be formatted close together rather than being separated by a horizontal or vertical line, which is the usual formatting method. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.16 fragment
    Within a syntax definition, a <fragment> is a labeled subpart of the syntax. The <fragment> element allows breaking out logical chunks of a large syntax diagram into named fragments. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.17 fragref
    The fragment reference (<fragref>) element provides a logical reference to a syntax definition fragment so that you can reference a syntax fragment multiple times, or pull a large section of syntax out of line for easier reading. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.18 synblk
    The syntax block (<synblk>) element organizes small pieces of a syntax definition into a larger piece. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.19 synnote
    The syntax note (<synnote>) element contains a note (similar to a footnote) within a syntax definition group or fragment. The syntax note explains aspects of the syntax that cannot be expressed in the markup itself. The note will appear at the bottom of the syntax diagram instead of at the bottom of the page. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.20 synnoteref
    The syntax note (<synnoteref>) reference element references a syntax note element (<synnote>) that has already been defined elsewhere in the syntax diagram. The same notation can be used in more than one syntax definition. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.21 kwd
    The <kwd> element defines a keyword within a syntax diagram. A keyword must be typed or output, either by the user or application, exactly as specified in the syntax definition. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.22 var
    Within a syntax diagram, the <var> element defines a variable for which the user must supply content, such as their user name or password. Processors typically represent the <var> element in output in an italic font, but are not required to do so. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.23 oper
    The operator (<oper>) element defines an operator within a syntax definition. Typical operators are equals (=), plus (+) or multiply (*). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.24 delim
    Within a syntax diagram, the delimiter (<delim>) element defines a character marking the beginning or end of a section or part of the complete syntax. Typical delimiter characters are the parenthesis, comma, tab, vertical bar or other special characters. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.25 sep
    The separator (<sep>) element defines a separator character that is inline with the content of a syntax diagram. The separator occurs between keywords, operators or groups in a syntax definition. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
  • 3.2.6.2.26 repsep
    The repeat separator (<repsep>) element in a syntax diagram defines a group of syntax elements that can (or should) be repeated. If the <repsep> element contains a separator character, such as a plus (+), this indicates that the character must be used between repetitions of the syntax elements. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.
Parent topic: 3.2.6 Domain elements
Previous topic: 3.2.6.1.26 safety
Next topic: 3.2.6.2.1 apiname


apiname

3.2.6.2.1 apiname

The <apiname> element provides the name of an application programming interface (API) such as a Java class name or method name. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput

Inheritance

+ topic/keyword pr-d/apiname

Example

<p>Use the <apiname>document.write</apiname> method to create text
output in the dynamically constructed view.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2 Programming elements
Next topic: 3.2.6.2.2 codeblock


codeblock

3.2.6.2.2 codeblock

The <codeblock> element represents lines of program code. Like the <pre> element, line endings and spaces inside the element must be preserved, and the content is typically rendered in a monospaced font. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or xref or state or coderef or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd

Inheritance

+ topic/pre pr-d/codeblock

Example

<codeblock>
/* a long sample program */
Do forever
  Say "Hello, World"
End
</codeblock>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, xml:space | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.1 apiname
Next topic: 3.2.6.2.3 coderef


coderef

3.2.6.2.3 coderef

The <coderef> element references an external file that contains literal code. When evaluated, the <coderef> element should cause the target code to be displayed inline. If the target contains non-XML characters such as '<' or '&', those will need to be handled in a way that they may be displayed correctly by the final rendering engine. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | no content

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | codeblock

Inheritance

- topic/xref pr-d/coderef

Example

<example>
  <title>Processing DITA</title>
  <p>This code is an example of how to process DITA.</p>
  <codeblock><coderef href="process-dita.xsl"/></codeblock>
</example>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.2 codeblock
Next topic: 3.2.6.2.4 codeph


codeph

3.2.6.2.4 codeph

The code phrase (<codeph>) element represents a snippet of code within the main flow of text. The code phrase is displayed in a monospaced font for emphasis. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or xref or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote

Inheritance

+ topic/ph pr-d/codeph

Example

<p>The second line of the sample program code, <codeph>Do forever</codeph>,
represents the start of a loop construct.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.3 coderef
Next topic: 3.2.6.2.5 option


option

3.2.6.2.5 option

The <option> element describes an option that can be used to modify a command (or something else, like a configuration). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput

Inheritance

+ topic/keyword pr-d/option

Example

something <option>/modifier</option>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.4 codeph
Next topic: 3.2.6.2.6 parmname


parmname

3.2.6.2.6 parmname

When referencing the name of an application programming interface parameter within the text flow of your topic, use the parameter name (<parmname>) element to mark up the parameter. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, synph, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput

Inheritance

+ topic/keyword pr-d/parmname

Example

Use the <parmname>/env</parmname> parameter of the <cmdname>config</cmdname>
command to update the field value.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.5 option
Next topic: 3.2.6.2.7 parml


parml

3.2.6.2.7 parml

The parameter list (<parml>) element contains a list of terms and definitions that describes the parameters in an application programming interface. This is a special kind of definition list that is designed for documenting programming parameters. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | (plentry) (one or more)

Contained by

Doctype | Content model
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd

Inheritance

+ topic/dl pr-d/parml

Example

Example source:
This code example is a basic method signature:
<codeblock>returnType methodName(pList1, pList2) {</codeblock>
where
<parml>
 <plentry>
  <pt>pList1</pt>
  <pd>is the first variable declaration passed to methodName</pd>
 </plentry>
 <plentry>
  <pt>pList2</pt>
  <pd>is the second variable declaration passed to methodName</pd>
 </plentry>
</parml>
Example output:
This code example is a basic method signature:
returnType methodName(pList1, pList2) {
where
pList1
is the first variable declaration passed to methodName
pList2
is the second variable declaration passed to methodName

Attributes

Name | Description | Data Type | Default Value | Required?
compact Indicates close vertical spacing between the list items. Expanded spacing is the default value. The output result of compact spacing depends on the processor or browser. Allowed values are:
yes
Indicates compact spacing.
no
Indicates expanded spacing.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class, outputclass | Common attributes described in Other common DITA attributes
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.6 parmname
Next topic: 3.2.6.2.8 plentry


plentry

3.2.6.2.8 plentry

The parameter list entry element (<plentry>) contains one or more parameter terms and definitions (pt and pd). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (pt) (one or more) then (pd) (one or more) )

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | parml

Inheritance

+ topic/dlentry pr-d/plentry

Example

See parml.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.7 parml
Next topic: 3.2.6.2.9 pt


pt

3.2.6.2.9 pt

A parameter term, within a parameter list entry, is enclosed by the <pt> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or image) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | plentry

Inheritance

+ topic/dt pr-d/pt

Example

See parml.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.8 plentry
Next topic: 3.2.6.2.10 pd


pd

3.2.6.2.10 pd

A parameter definition, within a parameter list entry, is enclosed by the <pd> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or dl or parml or fig or syntaxdiagram or imagemap or image or lines or lq or note or hazardstatement or object or ol or p or pre or codeblock or msgblock or screen or simpletable or sl or table or ul or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or itemgroup or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | plentry

Inheritance

+ topic/dd pr-d/pd

Example

See parml.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.9 pt
Next topic: 3.2.6.2.11 synph


synph

3.2.6.2.11 synph

The syntax phrase (<synph>) element is a container for syntax definition elements. It is used when a complete syntax diagram is not needed, but some of the syntax elements, such as kwd, oper, delim, are used within the text flow of the topic content. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or codeph or delim or kwd or oper or option or parmname or sep or synph or text or var) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, synph, pt, pd, fragref, synnote

Inheritance

+ topic/ph pr-d/synph

Example

<synph><kwd>format</kwd> <var>volumename</var></synph>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.10 pd
Next topic: 3.2.6.2.12 syntaxdiagram


syntaxdiagram

3.2.6.2.12 syntaxdiagram

The syntax diagram (<syntaxdiagram>) element is the main container for all the syntax elements that make up a syntax definition. The syntax diagram represents the syntax of a statement from a computer language or a command, function call, or programming language statement. Traditionally, the syntax diagram is formatted with "railroad tracks" that connect the units of the syntax together, but this presentation may differ depending on the output media. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (title) (optional) then (fragment or fragref or groupchoice or groupcomp or groupseq or synblk or synnote or synnoteref) (any number) )

Contained by

Doctype | Content model
topic (technical content) | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, pd
map (technical content), bookmap | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, pd
concept | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, pd
ditabase | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, refsyn, proptypehd, propvaluehd, propdeschd, pd
task (strict), task (general) | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd

Inheritance

+ topic/fig pr-d/syntaxdiagram

Example

<syntaxdiagram>
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice> <var>input-filename</var> <kwd>*INFILE</kwd></groupchoice>
 <groupchoice> <var>output-filename</var> <kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.11 synph
Next topic: 3.2.6.2.13 groupseq


groupseq

3.2.6.2.13 groupseq

The <groupseq> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. Within the syntax definition, groups of keywords, delimiters and other syntax units act as a combined unit, and they occur in a specific sequence, as delimited by the <groupseq> element. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (title) (optional) then (repsep) (optional) then (delim or fragref or groupchoice or groupcomp or groupseq or kwd or oper or sep or synnote or synnoteref or var) (any number) )

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment

Inheritance

+ topic/figgroup pr-d/groupseq

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional, required, or default. Output processors may indicate this designation in a generated diagram. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | optional | required | default | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.12 syntaxdiagram
Next topic: 3.2.6.2.14 groupchoice


groupchoice

3.2.6.2.14 groupchoice

The <groupchoice> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. A group choice specifies that the user must make a choice about which part of the syntax to use. Groups are often nested. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (title) (optional) then (repsep) (optional) then (delim or fragref or groupchoice or groupcomp or groupseq or kwd or oper or sep or synnote or synnoteref or var) (any number) )

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment

Inheritance

+ topic/figgroup pr-d/groupchoice

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional, required, or default. Output processors may indicate this designation in a generated diagram. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | optional | required | default | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.13 groupseq
Next topic: 3.2.6.2.15 groupcomp


groupcomp

3.2.6.2.15 groupcomp

The <groupcomp> element is part of the subset of elements that define syntax diagrams in DITA. A group is a logical set of pieces of syntax that go together. The group composite means that the items that make up the syntax diagram will be formatted close together rather than being separated by a horizontal or vertical line, which is the usual formatting method. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (title) (optional) then (repsep) (optional) then (delim or fragref or groupchoice or groupcomp or groupseq or kwd or oper or sep or synnote or synnoteref or var) (any number) )

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment

Inheritance

+ topic/figgroup pr-d/groupcomp

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional, required, or default. Output processors may indicate this designation in a generated diagram. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | optional | required | default | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.14 groupchoice
Next topic: 3.2.6.2.16 fragment


fragment

3.2.6.2.16 fragment

Within a syntax definition, a <fragment> is a labeled subpart of the syntax. The <fragment> element allows breaking out logical chunks of a large syntax diagram into named fragments. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (title) (optional) then (fragref or groupchoice or groupcomp or groupseq or synnote or synnoteref) (any number) )

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | syntaxdiagram, synblk

Inheritance

+ topic/figgroup pr-d/fragment

Example

<syntaxdiagram frame="none">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
 <fragment>
  <groupchoice><kwd>*OVERLAP</kwd><kwd>*Prompt</kwd></groupchoice>
 </fragment>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.15 groupcomp
Next topic: 3.2.6.2.17 fragref


fragref

3.2.6.2.17 fragref

The fragment reference (<fragref>) element provides a logical reference to a syntax definition fragment so that you can reference a syntax fragment multiple times, or pull a large section of syntax out of line for easier reading. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or state or data or data-about or foreign or unknown) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment

Inheritance

+ topic/xref pr-d/fragref

Example

This markup example:
<syntaxdiagram frame="none">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <fragref href="#syntax/overlay"></fragref>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
 <fragment id="overlay">
  <title>Overlay</title>
  <groupchoice><kwd>*OVERLAP</kwd><kwd>*Prompt</kwd></groupchoice>
 </fragment>
</syntaxdiagram>
produces the following output:
CopyFile

>>-COPYF--input-filename*INFILE--output-filename--*OUTFILE------>

>--| Overlay |--+-input-filename-+--+-output-filename-+--------><
                '-*INFILE--------'  '-*OUTFILE--------'

Overlay

|--+-*OVERLAP-+-------------------------------------------------|
   '-*Prompt--'

Attributes

Name | Description | Data Type | Default Value | Required?
href | A reference to a syntax diagram fragment element. The referenced fragment must be in the same diagram as the fragref element. See The href attribute for detailed information on supported values and processing implications. (Processing assumes the equivalent of scope="local" and format="dita".) | CDATA | #IMPLIED | No
importance | The attribute indicates whether this item in a syntax diagram is optional or required. Output processors may indicate this designation in a generated diagram. See this topic for more information on the -dita-use-​conref-​target value. | optional | required | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.16 fragment
Next topic: 3.2.6.2.18 synblk


synblk

3.2.6.2.18 synblk

The syntax block (<synblk>) element organizes small pieces of a syntax definition into a larger piece. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( (title) (optional) then (fragment or fragref or groupchoice or groupcomp or groupseq or synnote or synnoteref) (any number) )

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | syntaxdiagram

Inheritance

+ topic/figgroup pr-d/synblk

Example

<synblk>
<groupseq><kwd>this</kwd><sep>-</sep><kwd>is</kwd><sep>-</sep><kwd>a</kwd>
<sep>-</sep><var>test</var></groupseq>
</synblk>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.17 fragref
Next topic: 3.2.6.2.19 synnote


synnote

3.2.6.2.19 synnote

The syntax note (<synnote>) element contains a note (similar to a footnote) within a syntax definition group or fragment. The syntax note explains aspects of the syntax that cannot be expressed in the markup itself. The note will appear at the bottom of the syntax diagram instead of at the bottom of the page. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment

Inheritance

+ topic/fn pr-d/synnote

Example

<groupcomp><var>one</var><var>two</var><var>three</var></groupcomp>
<synnote>My first syntax note.</synnote>

Attributes

Name | Description | Data Type | Default Value | Required?
callout | Specifies what character is used for the footnote link, for example a number or an alpha character. The attribute may also specify a short string of characters. When no callout value is specified, footnotes are numbered. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.18 synblk
Next topic: 3.2.6.2.20 synnoteref


synnoteref

3.2.6.2.20 synnoteref

The syntax note (<synnoteref>) reference element references a syntax note element (<synnote>) that has already been defined elsewhere in the syntax diagram. The same notation can be used in more than one syntax definition. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | no content

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | syntaxdiagram, synblk, groupseq, groupchoice, groupcomp, fragment

Inheritance

+ topic/xref pr-d/synnoteref

Example

<synnoteref href="#topicid/mysyn"/>

Attributes

Name | Description | Data Type | Default Value | Required?
href | A reference to the target syntax note (<synnote>) element. The referenced syntax note must be in the same syntax diagram as the synnoteref element. See The href attribute for detailed information on supported values and processing implications. (Processing assumes the equivalent of scope="local" and format="dita".) | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.19 synnote
Next topic: 3.2.6.2.21 kwd


kwd

3.2.6.2.21 kwd

The <kwd> element defines a keyword within a syntax diagram. A keyword must be typed or output, either by the user or application, exactly as specified in the syntax definition. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | synph, groupseq, groupchoice, groupcomp

Inheritance

+ topic/keyword pr-d/kwd

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional, required, or default. Output processors may indicate this designation in a generated diagram. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | optional | required | default | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.20 synnoteref
Next topic: 3.2.6.2.22 var


var

3.2.6.2.22 var

Within a syntax diagram, the <var> element defines a variable for which the user must supply content, such as their user name or password. Processors typically represent the <var> element in output in an italic font, but are not required to do so. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | synph, groupseq, groupchoice, groupcomp

Inheritance

+ topic/ph pr-d/var

Example

<syntaxdiagram frame="bottom">
 <title>CopyFile</title>
 <groupseq><kwd>COPYF</kwd></groupseq>
 <groupcomp><var>input-filename</var><kwd>*INFILE</kwd></groupcomp>
 <groupseq><var>output-filename</var><kwd>*OUTFILE</kwd></groupseq>
 <groupchoice><var>input-filename</var><kwd>*INFILE</kwd></groupchoice>
 <groupchoice><var>output-filename</var><kwd>*OUTFILE</kwd></groupchoice>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional, required, or default. Output processors may indicate this designation in a generated diagram. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | optional | required | default | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.21 kwd
Next topic: 3.2.6.2.23 oper


oper

3.2.6.2.23 oper

The operator (<oper>) element defines an operator within a syntax definition. Typical operators are equals (=), plus (+) or multiply (*). This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | synph, groupseq, groupchoice, groupcomp

Inheritance

+ topic/ph pr-d/oper

Example

<syntaxdiagram>
  <title>Adding</title>
  <groupseq><kwd>1</kwd><oper>+</oper><var>two</var>
<delim>=</delim><kwd>something</kwd>
  </groupseq>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional, required, or default. Output processors may indicate this designation in a generated diagram. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | optional | required | default | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.22 var
Next topic: 3.2.6.2.24 delim


delim

3.2.6.2.24 delim

Within a syntax diagram, the delimiter (<delim>) element defines a character marking the beginning or end of a section or part of the complete syntax. Typical delimiter characters are the parenthesis, comma, tab, vertical bar or other special characters. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | synph, groupseq, groupchoice, groupcomp

Inheritance

+ topic/ph pr-d/delim

Example

<syntaxdiagram>
 <title>Adding</title>
 <groupseq><kwd>1</kwd><oper>+</oper><var>two</var><delim>=</delim>
 <kwd>something</kwd>
</groupseq>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional or required. Output processors may indicate this designation in a generated diagram. See this topic for more information on the -dita-use-​conref-​target value. | optional | required | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.23 oper
Next topic: 3.2.6.2.25 sep


sep

3.2.6.2.25 sep

The separator (<sep>) element defines a separator character that is inline with the content of a syntax diagram. The separator occurs between keywords, operators or groups in a syntax definition. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | synph, groupseq, groupchoice, groupcomp

Inheritance

+ topic/ph pr-d/sep

Example

<syntaxdiagram>
 <title>Adding</title>
 <groupseq><kwd>1</kwd><oper>+</oper><sep>(</sep><var>two</var><sep>)</sep>
<delim>=</delim><kwd>something</kwd></groupseq>
</syntaxdiagram>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional, required, or default. Output processors may indicate this designation in a generated diagram. See Using the -dita-use-conref-target value for more information on the -dita-use-​conref-​target value. | optional | required | default | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.24 delim
Next topic: 3.2.6.2.26 repsep


repsep

3.2.6.2.26 repsep

The repeat separator (<repsep>) element in a syntax diagram defines a group of syntax elements that can (or should) be repeated. If the <repsep> element contains a separator character, such as a plus (+), this indicates that the character must be used between repetitions of the syntax elements. This element is part of the DITA programming domain, a special set of DITA elements designed to document programming tasks, concepts, and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap | groupseq, groupchoice, groupcomp

Inheritance

+ topic/ph pr-d/repsep

Example

In this example, the group may be repeated. When repeated, a comma should be used between selections.
<groupchoice>
  <repsep>,</repsep>
  <kwd>This</kwd>
  <kwd>That</kwd>
  <kwd>The other</kwd>
</groupchoice>

Attributes

Name | Description | Data Type | Default Value | Required?
importance | The attribute indicates whether this item in a syntax diagram is optional or required. Output processors may indicate this designation in a generated diagram. See this topic for more information on the -dita-use-​conref-​target value. | optional | required | -dita-use-​conref-​target | #IMPLIED | No
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.2 Programming elements
Previous topic: 3.2.6.2.25 sep
Next topic: 3.2.6.3 Software elements


Software elements

3.2.6.3 Software elements

The software domain elements are used to describe the operation of a software program.

  • 3.2.6.3.1 msgph
    The message phrase (<msgph>) element contains the text content of a message produced by an application or program. It can also contain the variable name (varname) element to illustrate where variable text content can occur in the message. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.
  • 3.2.6.3.2 msgblock
    The message block (<msgblock>) element contains a multi-line message or set of messages. The message block can contain multiple message numbers and message descriptions, each enclosed in a <msgnum> and <msgph> element. It can also contain the message content directly. Line breaks and spaces are preserved when the element is rendered. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.
  • 3.2.6.3.3 msgnum
    The message number (<msgnum>) element contains the number of a message produced by an application or program. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.
  • 3.2.6.3.4 cmdname
    The command name (<cmdname>) element specifies the name of a command when it is part of a software discussion. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.
  • 3.2.6.3.5 varname
    The variable name (<varname>) element defines a variable that must be supplied to a software application. The variable name element is very similar to the variable (var) element, but variable name is used outside of syntax diagrams. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.
  • 3.2.6.3.6 filepath
    The <filepath> element indicates the name and optionally the location of a referenced file by specifying the directory containing the file, and other directories that may precede it in the system hierarchy. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.
  • 3.2.6.3.7 userinput
    The user input (<userinput>) element represents the text a user should input in response to a program or system prompt. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.
  • 3.2.6.3.8 systemoutput
    The system output (<systemoutput>) element represents computer output or responses to a command or situation. A generalized element, it represents any kind of output from the computer, so the author may wish to choose more specific markup, such as msgph, for messages from the application. The system output element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.
Parent topic: 3.2.6 Domain elements
Previous topic: 3.2.6.2.26 repsep
Next topic: 3.2.6.3.1 msgph


msgph

3.2.6.3.1 msgph

The message phrase (<msgph>) element contains the text content of a message produced by an application or program. It can also contain the variable name (varname) element to illustrate where variable text content can occur in the message. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote

Inheritance

+ topic/ph sw-d/msgph

Example

<p>A server log entry of <msgnum>I:0</msgnum> is equivalent to the
text message, <msgph>informational: successful</msgph>.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.3 Software elements
Previous topic: 3.2.6.3 Software elements
Next topic: 3.2.6.3.2 msgblock


msgblock

3.2.6.3.2 msgblock

The message block (<msgblock>) element contains a multi-line message or set of messages. The message block can contain multiple message numbers and message descriptions, each enclosed in a <msgnum> and <msgph> element. It can also contain the message content directly. Line breaks and spaces are preserved when the element is rendered. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd

Inheritance

+ topic/pre sw-d/msgblock

Example

<p>A sequence of failed password attempts generates the following
characteristic message stream:</p>
<msgblock>
I:0
S:3
I:1
S:3
I:1
S:4
S:99 (lockup)
</msgblock>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, xml:space | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.3 Software elements
Previous topic: 3.2.6.3.1 msgph
Next topic: 3.2.6.3.3 msgnum


msgnum

3.2.6.3.3 msgnum

The message number (<msgnum>) element contains the number of a message produced by an application or program. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput

Inheritance

+ topic/keyword sw-d/msgnum

Example

<p>A server log entry of <msgnum>I:0</msgnum> is equivalent to the
text message, <msgph>informational: successful</msgph>.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.3 Software elements
Previous topic: 3.2.6.3.2 msgblock
Next topic: 3.2.6.3.4 cmdname


cmdname

3.2.6.3.4 cmdname

The command name (<cmdname>) element specifies the name of a command when it is part of a software discussion. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput

Inheritance

+ topic/keyword sw-d/cmdname

Example

<p>Use the <cmdname>rm</cmdname> command when
you wish to remove something forever.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.3 Software elements
Previous topic: 3.2.6.3.3 msgnum
Next topic: 3.2.6.3.5 varname


varname

3.2.6.3.5 varname

The variable name (<varname>) element defines a variable that must be supplied to a software application. The variable name element is very similar to the variable (var) element, but variable name is used outside of syntax diagrams. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput

Inheritance

+ topic/keyword sw-d/varname

Example

<filepath>
  <varname>install-dir</varname>\projects\working\<varname>project-dir</varname>
       \source\<varname>filename</varname>.java
</filepath>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.3 Software elements
Previous topic: 3.2.6.3.4 cmdname
Next topic: 3.2.6.3.6 filepath


filepath

3.2.6.3.6 filepath

The <filepath> element indicates the name and optionally the location of a referenced file by specifying the directory containing the file, and other directories that may precede it in the system hierarchy. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote

Inheritance

+ topic/ph sw-d/filepath

Example

<p>Uncompress the <filepath>gbbrsh.gz</filepath> file to the
<filepath>/usr</filepath> directory. Ensure that the
<filepath>/usr/tools/data.cfg</filepath> path is listed in
the execution path system variable.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.3 Software elements
Previous topic: 3.2.6.3.5 varname
Next topic: 3.2.6.3.7 userinput


userinput

3.2.6.3.7 userinput

The user input (<userinput>) element represents the text a user should input in response to a program or system prompt. This element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote

Inheritance

+ topic/ph sw-d/userinput

Example

<p>After you type <userinput>mealplan dinner</userinput>, the meal planning program
will print a <systemoutput>For what day?</systemoutput> message.
Reply by typing the day of the week for which you want a meal plan,
for example, <userinput>Thursday</userinput>.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.3 Software elements
Previous topic: 3.2.6.3.6 filepath
Next topic: 3.2.6.3.8 systemoutput


systemoutput

3.2.6.3.8 systemoutput

The system output (<systemoutput>) element represents computer output or responses to a command or situation. A generalized element, it represents any kind of output from the computer, so the author may wish to choose more specific markup, such as msgph, for messages from the application. The system output element is part of the DITA software domain, a special set of DITA elements designed to document software tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote

Inheritance

+ topic/ph sw-d/systemoutput

Example

<p>After you type <userinput>mealplan dinner</userinput>, the meal planning program
will print a <systemoutput>For what day?</systemoutput> message.
Reply by typing the day of the week for which you want a meal plan,
for example, <userinput>Thursday</userinput>.</p>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.3 Software elements
Previous topic: 3.2.6.3.7 userinput
Next topic: 3.2.6.4 User interface elements


User interface elements

3.2.6.4 User interface elements

The user interface domain elements are used to describe the user interface of a software program.

  • 3.2.6.4.1 uicontrol
    The user interface control (<uicontrol>) element is used to mark up names of buttons, entry fields, menu items, or other objects that allow the user to control the interface. Use the <uicontrol> element inside a <menucascade> element to identify a sequence of menu choices in a nested menu, such as File > New . This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.
  • 3.2.6.4.2 wintitle
    The window title <wintitle> element can be used to mark up names of windows or dialogs, or other user interface elements at the same level of grouping, including wizard titles, wizard page titles, and window pane titles. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.
  • 3.2.6.4.3 menucascade
    The <menucascade> element is used to document a series of menu choices. The <menucascade> element contains one or more user interface control (<uicontrol>) elements, for example: Start > Programs > Accessories > Notepad. If there is more than one <uicontrol> element, the formatter shows connecting characters between the menu items to represent the menu cascade. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.
  • 3.2.6.4.4 shortcut
    The <shortcut> element identifies a keyboard shortcut for a menu or window action. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.
  • 3.2.6.4.5 screen
    The <screen> element contains or refers to a textual representation of a computer screen or user interface panel (window).
Parent topic: 3.2.6 Domain elements
Previous topic: 3.2.6.3.8 systemoutput
Next topic: 3.2.6.4.1 uicontrol


uicontrol

3.2.6.4.1 uicontrol

The user interface control (<uicontrol>) element is used to mark up names of buttons, entry fields, menu items, or other objects that allow the user to control the interface. Use the <uicontrol> element inside a <menucascade> element to identify a sequence of menu choices in a nested menu, such as File > New . This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or image or shortcut) (any number)
machineryTask | ( text data or data or data-about or foreign or unknown or keyword or wintitle or term or image or shortcut) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, menucascade, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, menucascade, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, menucascade, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, menucascade, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, menucascade, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, menucascade, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, menucascade, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, menucascade, screen

Inheritance

+ topic/ph ui-d/uicontrol

Example

Press the <uicontrol>OK</uicontrol> button.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.4 User interface elements
Previous topic: 3.2.6.4 User interface elements
Next topic: 3.2.6.4.2 wintitle


wintitle

3.2.6.4.2 wintitle

The window title <wintitle> element can be used to mark up names of windows or dialogs, or other user interface elements at the same level of grouping, including wizard titles, wizard page titles, and window pane titles. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, machineryTask | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, index-see, index-see-also, index-sort-as, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossAbbreviation, glossAcronym, glossShortForm, glossSynonym, glossProperty, glossSurfaceForm, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, linktext, searchtitle, person, organization, summary, printlocation, revisionid, year, month, day, bookpartno, edition, isbn, booknumber, volume, booklibrary, mainbooktitle, booktitlealt, index-see, index-see-also, index-sort-as, organizationname, honorific, firstname, middlename, lastname, generationidentifier, otherinfo, addressdetails, locality, localityname, administrativearea, thoroughfare, postalcode, country, contactnumber, emailaddress, url, b, u, i, tt, sup, sub, coords, typeofhazard, consequence, howtoavoid, uicontrol, screen, codeph, codeblock, var, oper, delim, sep, pt, pd, fragref, synnote, repsep, msgph, msgblock, filepath, userinput, systemoutput
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, indexterm, index-base, cite, xref, entry, author, source, publisher, copyrholder, category, keywords, prodname, brand, series, platform, prognum, featnum, component, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, coords, index-see, index-see-also, index-sort-as, uicontrol, screen

Inheritance

+ topic/keyword ui-d/wintitle

Example

<step>
  <cmd>Click <uicontrol>Configure</uicontrol>.</cmd>
  <stepresult>The <wintitle>Configuration Options</wintitle> window
  opens with your last set of selections highlighted.</stepresult>
</step>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.4 User interface elements
Previous topic: 3.2.6.4.1 uicontrol
Next topic: 3.2.6.4.3 menucascade


menucascade

3.2.6.4.3 menucascade

The <menucascade> element is used to document a series of menu choices. The <menucascade> element contains one or more user interface control (<uicontrol>) elements, for example: Start > Programs > Accessories > Notepad. If there is more than one <uicontrol> element, the formatter shows connecting characters between the menu items to represent the menu cascade. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, machineryTask | (uicontrol) (one or more)

Contained by

Doctype | Content model
topic (technical content), concept | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
map (technical content) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
ditabase | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
glossary, glossentry, glossgroup | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, glossterm, glossdef, glossProperty, glossUsage, glossScopeNote, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
reference | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, proptype, propvalue, propdesc, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
task (strict), task (general) | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
bookmap | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, linktext, booklibrary, mainbooktitle, booktitlealt, organizationname, b, u, i, tt, sup, sub, typeofhazard, consequence, howtoavoid, screen, codeph, codeblock, pt, pd, fragref, synnote
machineryTask | data, title, navtitle, shortdesc, desc, p, note, lq, q, sli, li, itemgroup, dthd, ddhd, dt, dd, figgroup, pre, lines, ph, alt, stentry, draft-comment, fn, cite, xref, entry, source, searchtitle, abstract, bodydiv, section, sectiondiv, example, linktext, linkinfo, prereq, context, steps-informal, stepsection, cmd, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond, typeofhazard, consequence, howtoavoid, b, u, i, tt, sup, sub, screen

Inheritance

+ topic/ph ui-d/menucascade

Example

This example:
<menucascade>
 <uicontrol>Start</uicontrol>
 <uicontrol>Programs</uicontrol>
 <uicontrol>Accessories</uicontrol>
 <uicontrol>Notepad</uicontrol>
</menucascade>
produces this output: Start > Programs > Accessories > Notepad

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.4 User interface elements
Previous topic: 3.2.6.4.2 wintitle
Next topic: 3.2.6.4.4 shortcut


shortcut

3.2.6.4.4 shortcut

The <shortcut> element identifies a keyboard shortcut for a menu or window action. This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap, machineryTask | ( text data or text) (any number)

Contained by

Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task (strict), task (general), bookmap, machineryTask | uicontrol

Inheritance

+ topic/keyword ui-d/shortcut

Example

This example:
<menucascade>
 <uicontrol>Start</uicontrol>
 <uicontrol><shortcut>P</shortcut>rograms</uicontrol>
</menucascade>
may produce the following result: Start > Programs

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.4 User interface elements
Previous topic: 3.2.6.4.3 menucascade
Next topic: 3.2.6.4.5 screen


screen

3.2.6.4.5 screen

The <screen> element contains or refers to a textual representation of a computer screen or user interface panel (window).

Use <screen> to contain representations of text-based online panels, text consoles ("term" or "curses" windows, for example), or other text-based user interface components. The default print representation is to enclose the screen within a box, suggesting a computer display screen. In contrast to graphical screen captures normally used to represent GUI parts (see the image element description), this element specifically supports constructions for which text is the primary content.

This element is part of the DITA user interface domain, a special set of DITA elements designed to document user interface tasks, concepts and reference information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
topic (technical content), map (technical content), concept, ditabase, glossary, glossentry, glossgroup, reference, task, bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
machineryTask | ( text data or boolean or cite or keyword or wintitle or ph or b or i or sup or sub or tt or u or menucascade or uicontrol or q or term or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
topic (technical content) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, pd
map (technical content), bookmap | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, pd
concept | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, pd
ditabase | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, glossdef, glossUsage, glossScopeNote, pd
glossary, glossentry, glossgroup | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, conbody, glossdef, glossUsage, glossScopeNote, pd
reference | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, pd
task (strict), task (general) | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, pd
machineryTask | desc, p, note, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, reqcond, reqcontp, personnel, perscat, perskill, esttime, supequi, supply, spare, safecond

Inheritance

+ topic/pre ui-d/screen

Example

This example demonstrates using the <screen> element to represent a DOS edit session, where this code:
<p>Type "edit" after the command line prompt and press Enter.  The following
editing interface will be displayed.</p>
<screen>
   File  Edit  Search  View  Options  Help
+--------------------------------- UNTITLED1 ----------------------------------+
¦                                                                              ¦
¦                                                                              ¦
¦                                                                              ¦
¦                                                                              ¦
¦  Line:1    Col:1  F1=Help                                                    ¦
+------------------------------------------------------------------------------+
</screen>
produces this output:

Type "edit" after the command line prompt and press Enter. The following editing interface will be displayed.

   File  Edit  Search  View  Options  Help
+--------------------------------- UNTITLED1 ----------------------------------+
¦                                                                              ¦
¦                                                                              ¦
¦                                                                              ¦
¦                                                                              ¦
¦  Line:1    Col:1  F1=Help                                                    ¦
+------------------------------------------------------------------------------+

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, xml:space | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.4 User interface elements
Previous topic: 3.2.6.4.4 shortcut
Next topic: 3.2.6.5 xNAL domain elements


xNAL domain elements

3.2.6.5 xNAL domain elements

The xNAL domain elements represent a subset of the Extensible Name and Address Standard. It is used to encode information about the author or authors of DITA information. The domain can be included in any DITA document type shell that requires additional metadata for names and addresses, although the implementations provided by OASIS only include it in the bookmap document type.

  • 3.2.6.5.1 xNAL usage guidelines
    Extended information and usage examples for DITA bookmap metadata elements associated with OASIS xNAL Standard (extensible Name and Address Language).
  • 3.2.6.5.2 authorinformation
    The <authorinformation> element contains detailed information about the author or authoring organization.
  • 3.2.6.5.3 addressdetails
    The <addressdetails> element contains information about the address of the author or authoring group.
  • 3.2.6.5.4 administrativearea
    The <administrativearea> element contains information about a county, state, or province.
  • 3.2.6.5.5 contactnumber
    A <contactnumber> element contains the contact number of a person or organization, such as a telephone number, mobile phone number, or fax number.
  • 3.2.6.5.6 contactnumbers
    The <contactnumbers> element contains a list of telephone and fax numbers.
  • 3.2.6.5.7 country
    The <country> element contains the name of a country.
  • 3.2.6.5.8 emailaddress
    The <emailaddress> element contains an e-mail address.
  • 3.2.6.5.9 emailaddresses
    The <emailaddresses> element contains a list of e-mail addresses.
  • 3.2.6.5.10 firstname
    The <firstname> element contains the person's first name.
  • 3.2.6.5.11 generationidentifier
    The <generationidentifier> element contains information about the person's generation, such as: Jr, III, or VIII.
  • 3.2.6.5.12 honorific
    The <honorific> element contains the person's title, such as: Dr., Mr., Ms., or HRH.
  • 3.2.6.5.13 lastname
    The <lastname> element contains the person's last name.
  • 3.2.6.5.14 locality
    The <locality> element contains information about the city and postal or ZIP code. It can contain the information directly, or by acting as a wrapper for <localityname> and <postalcode>.
  • 3.2.6.5.15 localityname
    The <localityname> element contains the name of the locality or city.
  • 3.2.6.5.16 middlename
    The <middlename> element contains the person's middle name or initial.
  • 3.2.6.5.17 namedetails
    The <namedetails> element contains information about the name of the author or the authoring organization.
  • 3.2.6.5.18 organizationinfo
    The <organizationinfo> element contains detailed information about an authoring organization.
  • 3.2.6.5.19 organizationname
    The <organizationname> element contains name information about the authoring organization.
  • 3.2.6.5.20 organizationnamedetails
    The <organizationnamedetails> element contains information about the name of an authoring organization.
  • 3.2.6.5.21 otherinfo
    The <otherinfo> element contains other name information about the author or authoring organization.
  • 3.2.6.5.22 personinfo
    The <personinfo> element is a wrapper containing all relevant data about a person, including name, address, and contact information.
  • 3.2.6.5.23 personname
    The <personname> element contains name information about the author.
  • 3.2.6.5.24 postalcode
    The <postalcode> element contains information about the postal code or the ZIP code.
  • 3.2.6.5.25 thoroughfare
    The <thoroughfare> element contains information about the thoroughfare - for example, the street, avenue, or boulevard - on which an address is located.
  • 3.2.6.5.26 url
    The <url> element contains a Uniform Resource Locator (URL), such as a person's or company's internet address.
  • 3.2.6.5.27 urls
    The <urls> element contains a list of Uniform Resource Locators (URLs).
Parent topic: 3.2.6 Domain elements
Previous topic: 3.2.6.4.5 screen
Next topic: 3.2.6.5.1 xNAL usage guidelines


xNAL usage guidelines

3.2.6.5.1 xNAL usage guidelines

Extended information and usage examples for DITA bookmap metadata elements associated with OASIS xNAL Standard (extensible Name and Address Language).

DITA bookmaps use a set of elements associated with a subset of the OASIS extensible Name and Address Language (xNAL) specification (Version 2) to denote name and address information related to persons and organizations.

While the elements share element names, and the expectation is that content written using this type of metadata should be straightforward to transform, the element name pairs do not share content models. The difference in content models reflects the different purposes of the two standards. The purpose of the name and address elements in DITA is to identify persons or organizations associated with the creation of a document; the purpose of the name and address elements in xNAL is to support customer resource management.

The examples shown after the table provide sample tagging methods for name and address information, using the DITA elements associated with xNAL.

DITA elements associated with xNAL elements

The set of bookmap elements associated with elements from the OASIS extensible Name and Address Language (xNAL) standard are listed in the table below.

Table 1. DITA elements associated with xNAL elements
addressdetails | honorific | otherinfo
administrativearea | lastname | person
authorinformation | locality | personinfo
contactnumber | localityname | personname
contactnumbers | middlename | postalcode
country | namedetails | thoroughfare
emailaddress | organization | url
emailaddresses | organizationinfo | urls
firstname | organizationname
generationidentifier | organizationnamedetails |

Example 1: Tagging personal information in DITA

This example shows a way to tag the following personal name and description.

Mr. Ram V. Kumar Jr.
Chief Technologist
MSI Business Solutions

<authorinformation>
  <personinfo>
    <namedetails>
      <personname>
        <honorific>Mr.</honorific>
        <firstname>Ram</firstname>
        <middlename>V.</middlename>
        <lastname>Kumar</lastname>
        <generationidentifier>Jr.</generationidentifier>
        <otherinfo>Chief Technologist</otherinfo>
      </personname>
    </namedetails>
  </personinfo>
  <organizationinfo>
    <namedetails>
      <organizationnamedetails>
        <organizationname>MSI Business Solutions</organizationname>
      </organizationnamedetails>
    </namedetails>
  </organizationinfo>
</authorinformation>

Example 2: Tagging address information in DITA

This example shows a way to tag the following address.

23 Archer St.
Chatsworth
NSW 2067
Australia

<addressdetails>
  <thoroughfare>123 Archer St.</thoroughfare>
  <locality>
    <localityname>Chatsworth</localityname>
    <postalcode>2067</ppostalcode>
  </locality>
  <administrativearea>NSW</administrativearea>
  <country>Australia</country>
</addressdetails>

Example 3: Tagging complex name and address information in DITA

This example shows two ways to tag a fairly complex collection of personal, organizational, and address information.

Mr. Samuel L. Johnson Jr.
Chief Technologist
c/o XYZ Corporation
52 New Main St.
Carrboro, NC 27510 USA
email: johnson@example.com
phone: 919-555-7987

This method tags all the organizational information as associated with the identified person.

<personinfo>
   <namedetails>
      <personname>
          <firstname>Samuel</firstname>
          <middlename>L.</middlename>
          <lastname>Johnson</lastname>
          <generationidentifier>Jr.</generationidentifier>
          <otherinfo>Chief Technologist</otherinfo>
          <otherinfo>c/o XYZ Corporation </otherinfo>
      </personname>
   </namedetails>
   <addressdetails>
      <thoroughfare>52 New Main St.</thoroughfare>
      <locality>
         <localityname>Carrboro</localityname>
         <postalcode>27510</postalcode>
      </locality>
      <administrativearea>NC</administrativearea>
      <country>USA</country>
   </addressdetails>
   <contactnumbers>
      <contactnumber>919-555-7987</contactnumber>
   </contactnumbers>
   <emailaddresses>
      <emailaddress>johnson@example.com</emailaddress>
   </emailaddresses>
</personinfo>

The following method separates the person and organization information. It might be used if it were necessary to associate address information with organizations rather than persons.

<authorinformation>
  <personinfo>
    <namedetails>
      <personname>
        <firstname>Samuel</firstname>
        <middlename>L.</middlename>
        <lastname>Johnson</lastname>
        <generationidentifier>Jr.</generationidentifier>
        <otherinfo>Chief Technologist</otherinfo>
      </personname>
    </namedetails>
    <contactnumbers>
      <contactnumber>919-555-7987</contactnumber>
    </contactnumbers>
    <emailaddresses>
      <emailaddress>johnson@example.com</emailaddress>
    </emailaddresses>
  </personinfo>
  <organizationinfo>
    <namedetails>
      <organizationnamedetails>
        <organizationname>XYZ Corporation</organizationname>
        <otherinfo>c/o </otherinfo>
      </organizationnamedetails>
    </namedetails>
    <addressdetails>
      <thoroughfare>52 New Main St.</thoroughfare>
      <locality>
         <localityname>Carrboro</localityname>
         <postalcode>27510</postalcode>
      </locality>
      <administrativearea>NC</administrativearea>
      <country>USA</country>
    </addressdetails>
  </organizationinfo>
</authorinformation>
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5 xNAL domain elements
Next topic: 3.2.6.5.2 authorinformation


authorinformation

3.2.6.5.2 authorinformation

The <authorinformation> element contains detailed information about the author or authoring organization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | (organizationinfo or personinfo) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | topicmeta, bookmeta

Inheritance

+ topic/author xnal-d/authorinformation

Example

<authorinformation>
 <personinfo>
  <namedetails><personname>
    <firstname>Derek</firstname>
    <middlename>L.</middlename>
    <lastname>Singleton</lastname>
    <generationidentifier>Jr.</generationidentifier>
    <otherinfo>noted psychologist</otherinfo>
  </personname></namedetails>
  <addressdetails>
    <thoroughfare>123 Yellow Brick Road</thoroughfare>
    <locality>Emerald City</locality>
    <administrativearea>Kansas</administrativearea>
    <country>USA</country>
  </addressdetails>
  <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
  <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
 </personinfo>
</authorinformation>

Attributes

Name | Description | Data Type | Default Value | Required?
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
type Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. Note that this differs from the type attribute on many other DITA elements. Beginning with DITA 1.2, values in this attribute are not limited to a small number of choices; the following values were used in DITA 1.0 and DITA 1.1, and are also recognized for the author element (and its specializations):
creator
The primary or original author of the content.
contributor
An additional author who is not primary.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
NMTOKEN #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group
class | A common attribute described in Other common DITA attributes
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.1 xNAL usage guidelines
Next topic: 3.2.6.5.3 addressdetails


addressdetails

3.2.6.5.3 addressdetails

The <addressdetails> element contains information about the address of the author or authoring group.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or administrativearea or country or locality or thoroughfare) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term or administrativearea or country or locality or thoroughfare) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personinfo, organizationinfo

Inheritance

+ topic/ph xnal-d/addressdetails

Example

 <personinfo>
  <namedetails><personname>
    <firstname>Derek</firstname>
    <middlename>L.</middlename>
    <lastname>Singleton</lastname>
    <generationidentifier>Jr.</generationidentifier>
    <otherinfo>noted psychologist</otherinfo>
  </personname></namedetails>
  <addressdetails>
    <thoroughfare>123 Yellow Brick Road</thoroughfare>
    <locality>Emerald City</locality>
    <administrativearea>Kansas</administrativearea>
    <country>USA</country>
  </addressdetails>
  <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
  <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
 </personinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.2 authorinformation
Next topic: 3.2.6.5.4 administrativearea


administrativearea

3.2.6.5.4 administrativearea

The <administrativearea> element contains information about a county, state, or province.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | addressdetails

Inheritance

+ topic/ph xnal-d/administrativearea

Example

<addressdetails>
<thoroughfare>123 Yellow Brick Road</thoroughfare>
<locality>Emerald City</locality>
<administrativearea>Kansas</administrativearea>
<country>USA</country>
</addressdetails>

Attributes

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.3 addressdetails
Next topic: 3.2.6.5.5 contactnumber


contactnumber

3.2.6.5.5 contactnumber

A <contactnumber> element contains the contact number of a person or organization, such as a telephone number, mobile phone number, or fax number.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | contactnumbers

Inheritance

+ topic/data xnal-d/contactnumber

Example

<personinfo>
 <namedetails><personname>
  <firstname>Derek</firstname>
   <middlename>L.</middlename>
   <lastname>Singleton</lastname>
   <generationidentifier>Jr.</generationidentifier>
   <otherinfo>noted psychologist</otherinfo>
 </personname></namedetails>
 <addressdetails>
   <thoroughfare>123 Yellow Brick Road</thoroughfare>
   <locality>Emerald City</locality>
   <administrativearea>Kansas</administrativearea>
   <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
</personinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.4 administrativearea
Next topic: 3.2.6.5.6 contactnumbers


contactnumbers

3.2.6.5.6 contactnumbers

The <contactnumbers> element contains a list of telephone and fax numbers.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | (contactnumber) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personinfo, organizationinfo

Inheritance

+ topic/data xnal-d/contactnumbers

Example

<personinfo>
 <namedetails><personname>
   <firstname>Derek</firstname>
   <middlename>L.</middlename>
   <lastname>Singleton</lastname>
   <generationidentifier>Jr.</generationidentifier>
   <otherinfo>noted psychologist</otherinfo>
 </personname></namedetails>
 <addressdetails>
   <thoroughfare>123 Yellow Brick Road</thoroughfare>
   <locality>Emerald City</locality>
   <administrativearea>Kansas</administrativearea>
   <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
</personinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.5 contactnumber
Next topic: 3.2.6.5.7 country


country

3.2.6.5.7 country

The <country> element contains the name of a country.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | addressdetails

Inheritance

+ topic/ph xnal-d/country

Example

<addressdetails>
 <thoroughfare>123 Yellow Brick Road</thoroughfare>
 <locality>Emerald City</locality>
 <administrativearea>Kansas</administrativearea>
 <country>USA</country>
</addressdetails>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.6 contactnumbers
Next topic: 3.2.6.5.8 emailaddress


emailaddress

3.2.6.5.8 emailaddress

The <emailaddress> element contains an e-mail address.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | emailaddresses

Inheritance

+ topic/data xnal-d/emailaddress

Example

<personinfo>
 <namedetails><personname>
   <firstname>Derek</firstname>
   <middlename>L.</middlename>
   <lastname>Singleton</lastname>
   <generationidentifier>Jr.</generationidentifier>
   <otherinfo>noted psychologist</otherinfo>
 </personname></namedetails>
 <addressdetails>
   <thoroughfare>123 Yellow Brick Road</thoroughfare>
   <locality>Emerald City</locality>
   <administrativearea>Kansas</administrativearea>
   <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses>
  <emailaddress>wizard@example.org</emailaddress>
 </emailaddresses>
</personinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.7 country
Next topic: 3.2.6.5.9 emailaddresses


emailaddresses

3.2.6.5.9 emailaddresses

The <emailaddresses> element contains a list of e-mail addresses.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | (emailaddress) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personinfo, organizationinfo

Inheritance

+ topic/data xnal-d/emailaddresses

Example

<personinfo>
 <namedetails><personname>
   <firstname>Derek</firstname>
   <middlename>L.</middlename>
   <lastname>Singleton</lastname>
   <generationidentifier>Jr.</generationidentifier>
   <otherinfo>noted psychologist</otherinfo>
 </personname></namedetails>
 <addressdetails>
   <thoroughfare>123 Yellow Brick Road</thoroughfare>
   <locality>Emerald City</locality>
   <administrativearea>Kansas</administrativearea>
   <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
</personinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.8 emailaddress
Next topic: 3.2.6.5.10 firstname


firstname

3.2.6.5.10 firstname

The <firstname> element contains the person's first name.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personname

Inheritance

+ topic/data xnal-d/firstname

Example

<namedetails>
 <personname>
  <honorific>Dr.</honorific>
  <firstname>Derek</firstname>
  <middlename>L.</middlename>
  <lastname>Singleton</lastname>
  <generationidentifier>Jr.</generationidentifier>
  <otherinfo>noted psychologist</otherinfo>
 </personname>
</namedetails>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.9 emailaddresses
Next topic: 3.2.6.5.11 generationidentifier


generationidentifier

3.2.6.5.11 generationidentifier

The <generationidentifier> element contains information about the person's generation, such as: Jr, III, or VIII.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personname

Inheritance

+ topic/data xnal-d/generationidentifier

Example

<namedetails><personname>
  <firstname>Derek</firstname>
  <middlename>L.</middlename>
  <lastname>Singleton</lastname>
  <generationidentifier>Jr.</generationidentifier>
  <otherinfo>noted psychologist</otherinfo>
</personname></namedetails>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.10 firstname
Next topic: 3.2.6.5.12 honorific


honorific

3.2.6.5.12 honorific

The <honorific> element contains the person's title, such as: Dr., Mr., Ms., or HRH.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personname

Inheritance

+ topic/data xnal-d/honorific

Example

<namedetails><personname>
 <honorofic>Dr.</honorific>
 <firstname>Derek</firstname>
 <middlename>L.</middlename>
 <lastname>Singleton</lastname>
 <generationidentifier>Jr.</generationidentifier>
 <otherinfo>noted psychologist</otherinfo>
</personname></namedetails>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.11 generationidentifier
Next topic: 3.2.6.5.13 lastname


lastname

3.2.6.5.13 lastname

The <lastname> element contains the person's last name.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personname

Inheritance

+ topic/data xnal-d/lastname

Example

<namedetails><personname>
 <honorific>Dr.</honorific>
 <firstname>Derek</firstname>
 <middlename>L.</middlename>
 <lastname>Singleton</lastname>
 <generationidentifier>Jr.</generationidentifier>
 <otherinfo>noted psychologist</otherinfo>
</personname></namedetails>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.12 honorific
Next topic: 3.2.6.5.14 locality


locality

3.2.6.5.14 locality

The <locality> element contains information about the city and postal or ZIP code. It can contain the information directly, or by acting as a wrapper for <localityname> and <postalcode>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form or localityname or postalcode) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term or localityname or postalcode) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | addressdetails

Inheritance

+ topic/ph xnal-d/locality

Example

<addressdetails>
<thoroughfare>123 Yellow Brick Road</thoroughfare>
<locality>
<localityname>Emerald City</localityname>
<postalcode>66780</postalcode>
</locality>
<administrativearea>Kansas</administrativearea>
<country>USA</country>
</addressdetails>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.13 lastname
Next topic: 3.2.6.5.15 localityname


localityname

3.2.6.5.15 localityname

The <localityname> element contains the name of the locality or city.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | locality

Inheritance

+ topic/ph xnal-d/localityname

Example

<addressdetails>
<thoroughfare>123 Yellow Brick Road</thoroughfare>
<locality>
<localityname>Emerald City</localityname>
<postalcode>66780</postalcode>
</locality>
<administrativearea>Kansas</administrativearea>
<country>USA</country>
</addressdetails>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.14 locality
Next topic: 3.2.6.5.16 middlename


middlename

3.2.6.5.16 middlename

The <middlename> element contains the person's middle name or initial.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personname

Inheritance

+ topic/data xnal-d/middlename

Example

<namedetails><personname>
 <honorific>Dr.</honorific>
 <firstname>Derek</firstname>
 <middlename>L.</middlename>
 <lastname>Singleton</lastname>
 <generationidentifier>Jr.</generationidentifier>
 <otherinfo>noted psychologist</otherinfo>
</personname></namedetails>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.15 localityname
Next topic: 3.2.6.5.17 namedetails


namedetails

3.2.6.5.17 namedetails

The <namedetails> element contains information about the name of the author or the authoring organization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | (organizationnamedetails or personname) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | personinfo, organizationinfo

Inheritance

+ topic/data xnal-d/namedetails

Example

<personinfo>
 <namedetails><personname>
   <firstname>Derek</firstname>
   <middlename>L.</middlename>
   <lastname>Singleton</lastname>
   <generationidentifier>Jr.</generationidentifier>
   <otherinfo>noted psychologist</otherinfo>
 </personname></namedetails>
 <addressdetails>
   <thoroughfare>123 Yellow Brick Road</thoroughfare>
   <locality>Emerald City</locality>
   <administrativearea>Kansas</administrativearea>
   <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
</personinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.16 middlename
Next topic: 3.2.6.5.18 organizationinfo


organizationinfo

3.2.6.5.18 organizationinfo

The <organizationinfo> element contains detailed information about an authoring organization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (namedetails) (optional) then (addressdetails) (optional) then (contactnumbers) (optional) then (emailaddresses) (optional) then (urls) (optional) )

Contained by

Doctype | Content model
bookmap, learningBookmap | authorinformation

Inheritance

+ topic/data xnal-d/organizationinfo

Example

<organizationinfo>
 <namedetails>
  <organizationnamedetails>
   <organizationname>WizardWorks, Inc.</organizationname>
   <otherinfo>'Best wizard in Oz'</otherinfo>
  <organizationnamedetails>
 </namedetails>
 <addressdetails>
  <thoroughfare>123 Yellow Brick Road</thoroughfare>
  <locality>Emerald City</locality>
  <administrativearea>Kansas</administrativearea>
  <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
 <urls><url>www.wizardworks.example.org</url></urls>
</organizationinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.17 namedetails
Next topic: 3.2.6.5.19 organizationname


organizationname

3.2.6.5.19 organizationname

The <organizationname> element contains name information about the authoring organization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or boolean or cite or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or ph or b or i or sup or sub or tt or u or codeph or synph or filepath or msgph or systemoutput or userinput or menucascade or uicontrol or q or term or abbreviated-form or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)
learningBookmap | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | organizationnamedetails

Inheritance

+ topic/ph xnal-d/organizationname

Example

<organizationinfo>
 <namedetails>
  <organizationnamedetails>
   <organizationname>WizardWorks, Inc.</organizationname>
   <otherinfo>'Best wizard in Oz'</otherinfo>
  <organizationnamedetails>
 </namedetails>
 <addressdetails>
  <thoroughfare>123 Yellow Brick Road</thoroughfare>
  <locality>Emerald City</locality>
  <administrativearea>Kansas</administrativearea>
  <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
 <urls><url>www.wizardworks.example.org</url></urls>
</organizationinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.18 organizationinfo
Next topic: 3.2.6.5.20 organizationnamedetails


organizationnamedetails

3.2.6.5.20 organizationnamedetails

The <organizationnamedetails> element contains information about the name of an authoring organization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (organizationname) (optional) then (otherinfo) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | namedetails

Inheritance

+ topic/ph xnal-d/organizationnamedetails

Example

<organizationinfo>
 <namedetails>
  <organizationnamedetails>
   <organizationname>WizardWorks, Inc.</organizationname>
   <otherinfo>'Best wizard in Oz'</otherinfo>
  </organizationnamedetails>
 </namedetails>
 <addressdetails>
  <thoroughfare>123 Yellow Brick Road</thoroughfare>
  <locality>Emerald City</locality>
  <administrativearea>Kansas</administrativearea>
  <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
 <urls><url>www.wizardworks.example.org</url></urls>
</organizationinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.19 organizationname
Next topic: 3.2.6.5.21 otherinfo


otherinfo

3.2.6.5.21 otherinfo

The <otherinfo> element contains other name information about the author or authoring organization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | organizationnamedetails, personname

Inheritance

+ topic/data xnal-d/otherinfo

Example

<organizationinfo>
 <namedetails>
  <organizationnamedetails>
   <organizationname>WizardWorks, Inc.</organizationname>
   <otherinfo>'Best wizard in Oz'</otherinfo>
  </organizationnamedetails>
 </namedetails>
 <addressdetails>
  <thoroughfare>123 Yellow Brick Road</thoroughfare>
  <locality>Emerald City</locality>
  <administrativearea>Kansas</administrativearea>
  <country>USA</country>
 </addressdetails>
</organizationinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.20 organizationnamedetails
Next topic: 3.2.6.5.22 personinfo


personinfo

3.2.6.5.22 personinfo

The <personinfo> element is a wrapper containing all relevant data about a person, including name, address, and contact information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (namedetails) (optional) then (addressdetails) (optional) then (contactnumbers) (optional) then (emailaddresses) (optional) )

Contained by

Doctype | Content model
bookmap, learningBookmap | authorinformation

Inheritance

+ topic/data xnal-d/personinfo

Example

<personinfo>
 <namedetails><personname>
   <firstname>Derek</firstname>
   <middlename>L.</middlename>
   <lastname>Singleton</lastname>
   <generationidentifier>Jr.</generationidentifier>
   <otherinfo>noted psychologist</otherinfo>
 </personname></namedetails>
 <addressdetails>
   <thoroughfare>123 Yellow Brick Road</thoroughfare>
   <locality>Emerald City</locality>
   <administrativearea>Kansas</administrativearea>
   <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
</personinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.21 otherinfo
Next topic: 3.2.6.5.23 personname


personname

3.2.6.5.23 personname

The <personname> element contains name information about the author.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | ( (honorific) (optional) then (firstname) (any number) then (middlename) (any number) then (lastname) (any number) then (generationidentifier) (optional) then (otherinfo) (any number) )

Contained by

Doctype | Content model
bookmap, learningBookmap | namedetails

Inheritance

+ topic/data xnal-d/personname

Example

<personinfo>
 <namedetails>
  <personname>
   <firstname>Derek</firstname>
   <middlename>L.</middlename>
   <lastname>Singleton</lastname>
   <generationidentifier>Jr.</generationidentifier>
   <otherinfo>noted psychologist</otherinfo>
  </personname>
 </namedetails>
 <addressdetails>
   <thoroughfare>123 Yellow Brick Road</thoroughfare>
   <locality>Emerald City</locality>
   <administrativearea>Kansas</administrativearea>
   <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
</personinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.22 personinfo
Next topic: 3.2.6.5.24 postalcode


postalcode

3.2.6.5.24 postalcode

The <postalcode> element contains information about the postal code or the ZIP code.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle) (any number)
learningBookmap | ( text data or keyword) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | locality

Inheritance

+ topic/ph xnal-d/postalcode

Example

<addressdetails>
<thoroughfare>123 Yellow Brick Road</thoroughfare>
<locality>
<localityname>Emerald City</localityname>
<postalcode>66780</postalcode>
</locality>
<administrativearea>Kansas</administrativearea>
<country>USA</country>
</addressdetails>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.23 personname
Next topic: 3.2.6.5.25 thoroughfare


thoroughfare

3.2.6.5.25 thoroughfare

The <thoroughfare> element contains information about the thoroughfare - for example, the street, avenue, or boulevard - on which an address is located.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | addressdetails

Inheritance

+ topic/ph xnal-d/thoroughfare

Example

<addressdetails>
<thoroughfare>123 Yellow Brick Road</thoroughfare>
<locality>
<localityname>Emerald City</localityname>
<postalcode>66780</postalcode>
</locality>
<administrativearea>Kansas</administrativearea>
<country>USA</country>
</addressdetails>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.24 postalcode
Next topic: 3.2.6.5.26 url


url

3.2.6.5.26 url

The <url> element contains a Uniform Resource Locator (URL), such as a person's or company's internet address.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap | ( text data or data or data-about or foreign or unknown or keyword or apiname or option or parmname or cmdname or msgnum or varname or wintitle or term or abbreviated-form) (any number)
learningBookmap | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | urls

Inheritance

+ topic/data xnal-d/url

Example

<organizationinfo>
 <namedetails>
  <organizationnamedetails>
   <organizationname>WizardWorks, Inc.</organizationname>
   <otherinfo>'Best wizard in Oz'</otherinfo>
  </organizationnamedetails>
 </namedetails>
 <addressdetails>
  <thoroughfare>123 Yellow Brick Road</thoroughfare>
  <locality>Emerald City</locality>
  <administrativearea>Kansas</administrativearea>
  <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
 <urls><url>www.wizardworks.example.org</url></urls>
</organizationinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.25 thoroughfare
Next topic: 3.2.6.5.27 urls


urls

3.2.6.5.27 urls

The <urls> element contains a list of Uniform Resource Locators (URLs).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
bookmap, learningBookmap | (url) (any number)

Contained by

Doctype | Content model
bookmap, learningBookmap | organizationinfo

Inheritance

+ topic/data xnal-d/urls

Example

<organizationinfo>
 <namedetails>
  <organizationnamedetails>
   <organizationname>WizardWorks, Inc.</organizationname>
   <otherinfo>'Best wizard in Oz'</otherinfo>
  </organizationnamedetails>
 </namedetails>
 <addressdetails>
  <thoroughfare>123 Yellow Brick Road</thoroughfare>
  <locality>Emerald City</locality>
  <administrativearea>Kansas</administrativearea>
  <country>USA</country>
 </addressdetails>
 <contactnumbers><contactnumber>123-555-4678</contactnumber></contactnumbers>
 <emailaddresses><emailaddress>wizard@example.org</emailaddress></emailaddresses>
 <urls><url>www.wizardworks.example.org</url></urls>
</organizationinfo>

Attributes

Name | Description | Data Type | Default Value | Required?
name | Defines a unique name for the object. | CDATA | #IMPLIED | No
datatype | Describes the type of data contained in the value attribute or within the data element. A typical use of datatype will be the identifying URI for an XML Schema datatype. | CDATA | #IMPLIED | No
value | Specifies a value associated with the current property or element. | CDATA | #IMPLIED | No
href | Provides a reference to a resource. See The href attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.2.6.5 xNAL domain elements
Previous topic: 3.2.6.5.26 url
Next topic: 3.3 Learning and training elements


Learning and training elements

3.3 Learning and training elements

Elements in the Learning and Training section include specialized topic types designed for learning and training content, as well as specialized domain elements for organizing learning content within maps, specifying learning metadata, and describing learning interactions.

  • 3.3.1 Learning and training topic elements
    Use the learning and training topic types to provide the instructional content, according to the needs identified by the learning goals and objectives.
  • 3.3.2 Learning and training map domain elements
    Use the learning and training map domain to organize groups of topics as learning objects. Defined as a map domain, these elements are available for use within any DITA map, not just a learning-specific DITA map. For example, you could include learning objects in a DITA generic map or in a DITA bookmap.
  • 3.3.3 Learning and training interactions domain elements
    Use the learning interactions to construct a basic set of question and response interaction. The domain also provides an lcInstructornote element, which you can use to provide instructor-specific information in the learning topics.
  • 3.3.4 Learning and training metadata elements
    Use the learning and training metadata to describe specific characteristics of the learning content. The learning and training metadata elements provide a robust metadata model for learning objects, built upon industry standards and best practices. Defined as a domain, these elements are available for use in both the topic prolog and the map topicmeta.
  • 3.3.5 Other learning and training elements
    This group includes those elements that are specifically related to learning, but do not fit in to one of the other major learning groups.
Parent topic: 3 Language reference
Previous topic: 3.2.6.5.27 urls
Next topic: 3.3.1 Learning and training topic elements


Learning and training topic elements

3.3.1 Learning and training topic elements

Use the learning and training topic types to provide the instructional content, according to the needs identified by the learning goals and objectives.

  • 3.3.1.1 learningOverview
    A Learning Overview topic identifies the learning objectives, includes other information helpful to the learner, such as prerequisites, duration, intended audience, and can include information and strategies that seeks to gain attention and stimulate recall of prior learning.
  • 3.3.1.2 learningOverviewbody
    The <learningOverviewbody> element is the main body-level element in a learningOverview topic. A learningOverviewbody has a very specific structure, with the following elements in this order: <lcIntro>, <lcAudience>, <lcDuration>, <lcPrereqs>, <lcObjectives>, <lcResources>, followed by one or more <section> elements. Each of the learningOverviewbody sections are optional.
  • 3.3.1.3 learningContent
    A Learning Content topic provides the learning content itself, and enables direct use of content from DITA task, concept, and reference topics, as well as additional content of any topic type that supports specific objectives declared in the Learning Overview topic type.
  • 3.3.1.4 learningContentbody
    The <learningContentbody> element is the main body-level element in a learningContent topic.
  • 3.3.1.5 learningSummary
    A Learning Summary recaps and provides context for the achievement or accomplishment of learning objectives, provides guidance to reinforce learning and long-term memory, and may pose questions to enhance encoding and verification of the learning content.
  • 3.3.1.6 learningSummarybody
    The <learningSummarybody> element is the main body-level element in a learningSummary topic.
  • 3.3.1.7 learningAssessment
    A Learning Assessment presents questions or interactions that measure progress, encourage recollection, and stimulate reinforcement of the learning content, and can be presented before the content as a pre-assessment or as a post-assessment test. The interactions use a sub-set of the Question-Test Interoperability (QTI) specification, implemented as a DITA domain specialization.
  • 3.3.1.8 learningAssessmentbody
    The <learningAssessmentbody> element is the main body-level element in a learningAssessment topic.
  • 3.3.1.9 learningPlan
    A Learning Plan topic describes learning needs and goals, instructional design models, task analyses, learning taxonomies, and other information necessary to the lesson planning process.
  • 3.3.1.10 learningPlanbody
    The <learningPlanbody> element is the main body-level element in a learningPlan topic.
  • 3.3.1.11 learningBase
    The learningBase topic type is not used to deliver any actual learning content, but instead provides a set of common elements for use in the other more specific learning content types: learningOverview,learningContent, learningSummary, learningAssessment, and learningPlan.
  • 3.3.1.12 learningBasebody
    The <learningBasebody> element is the main body-level element in a learningBase topic. The learningBase topic provides a set of base elements for use in the other specialized learning types. It is not generally intended for creating actual content. As such, each of the body sections in learningBase are optional.
Parent topic: 3.3 Learning and training elements
Previous topic: 3.3 Learning and training elements
Next topic: 3.3.1.1 learningOverview


learningOverview

3.3.1.1 learningOverview

A Learning Overview topic identifies the learning objectives, includes other information helpful to the learner, such as prerequisites, duration, intended audience, and can include information and strategies that seeks to gain attention and stimulate recall of prior learning.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningOverview | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (learningOverviewbody) then (related-links) (optional) then (no-topic-nesting) (any number) )

Contained by

This element is not contained by any other elements.

Inheritance

- topic/topic learningBase/learningBase learningOverview/learningOverview

Example

<learningOverview id="understanding_the_basics" xml:lang="en-us">
  <title>Overview: Understanding the basics</title>
  <shortdesc>Mail basics start from the inbox, viewing and opening messages
    you receive, and moving them to appropriate mail folders for easy access and
    retrieval.</shortdesc>
  <learningOverviewbody>
    <lcAudience>The intended audience includes new users of the company email
      system and anyone wanting a refresher on the basic features.</lcAudience>
    <lcDuration>
      <title>Expected duration</title>
      <lcTime value="00:30">It should take you no more than 30 minutes to complete
        this module.</lcTime>
    </lcDuration>
    <lcObjectives>
      <lcObjectivesStem>When you complete this lesson, you'll know how to perform
        the following mail basics:</lcObjectivesStem>
      <lcObjectivesGroup>
        <lcObjective>Viewing the inbox</lcObjective>
        <lcObjective>Opening a message</lcObjective>
        <lcObjective>Moving messages to a folder</lcObjective>
      </lcObjectivesGroup><
    </lcObjectives>
  </learningOverviewbody>
</learningOverview>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1 Learning and training topic elements
Next topic: 3.3.1.2 learningOverviewbody


learningOverviewbody

3.3.1.2 learningOverviewbody

The <learningOverviewbody> element is the main body-level element in a learningOverview topic. A learningOverviewbody has a very specific structure, with the following elements in this order: <lcIntro>, <lcAudience>, <lcDuration>, <lcPrereqs>, <lcObjectives>, <lcResources>, followed by one or more <section> elements. Each of the learningOverviewbody sections are optional.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningOverview | ( (lcIntro) (optional) then (lcAudience) (any number) then (lcDuration) (optional) then (lcPrereqs) (optional) then (lcObjectives) (optional) then (lcResources) (optional) then (section) (any number) )

Contained by

Doctype | Content model
learningOverview | learningOverview

Inheritance

- topic/body learningBase/learningBasebody learningOverview/learningOverviewbody

Example

See learningOverview.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.1 learningOverview
Next topic: 3.3.1.3 learningContent


learningContent

3.3.1.3 learningContent

A Learning Content topic provides the learning content itself, and enables direct use of content from DITA task, concept, and reference topics, as well as additional content of any topic type that supports specific objectives declared in the Learning Overview topic type.

A Learning Content topic comprises a set of self-contained content about a single terminal learning objective supported by zero or more enabling learning objectives.

A learning content topic should be rendered as single result component (e.g., a single HTML page) when it has subordinate topics, either as direct child elements or associated via a map. This result can be requested by specifying a value of "to-content" for the chunk attribute of topic refs that point to learningContent topics. This is the default value for the learningContentRef topicref type provided by the learning map domain.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningContent | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (learningContentbody) then (related-links) (optional) then ( ( (concept or task or reference or topic) (any number) then (learningAssessment) (optional) then (learningSummary) (optional) ) ) (any number) )

Contained by

This element is not contained by any other elements.

Inheritance

- topic/topic learningBase/learningBase learningContent/learningContent

Example

<learningContent id="learningcontent">
<title>Your Mail Inbox</title>
  <learningContentbody>
    <lcObjectives>
      <lcObjectivesStem>When you complete this topic, you'll understand:</lcObjectivesStem>
        <lcObjectivesGroup>
            <lcObjective>How to use the mail inbox.</lcObjective>
        </lcObjectivesGroup>
    </lcObjectives>
  </learningContentbody>
  <concept id="mail_inbox_concept" xml:lang="en-us">
    <title>Your Mail Inbox</title>
    <shortdesc>Use your mail inbox to track and manage incoming messages.</shortdesc>
    <conbody>
        <p>Knowing which messages you have not yet read and which ones are urgent
        can help you decide how to best review a long list of messages. Unread messages
        are indicated by bold text and a variety of icons identifies a characteristic
        of the message, such as a high priority message or an invitation.</p>
    </conbody>
  </concept>
</learningContent>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.2 learningOverviewbody
Next topic: 3.3.1.4 learningContentbody


learningContentbody

3.3.1.4 learningContentbody

The <learningContentbody> element is the main body-level element in a learningContent topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningContent | ( ( (lcIntro) or (lcDuration) or (lcObjectives) ) (any number) then (lcChallenge) (optional) then (lcInstruction) (optional) then (section) (any number) )

Contained by

Doctype | Content model
learningContent | learningContent

Inheritance

- topic/body learningBase/learningBasebody learningContent/learningContentbody

Example

See learningContent.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.3 learningContent
Next topic: 3.3.1.5 learningSummary


learningSummary

3.3.1.5 learningSummary

A Learning Summary recaps and provides context for the achievement or accomplishment of learning objectives, provides guidance to reinforce learning and long-term memory, and may pose questions to enhance encoding and verification of the learning content.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningContent | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (learningSummarybody) then (related-links) (optional) then ( (no-topic-nesting) (optional) ) (any number) )
learningSummary | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (learningSummarybody) then (related-links) (optional) then (no-topic-nesting) (any number) )

Contained by

Doctype | Content model
learningContent | learningContent

Inheritance

- topic/topic learningBase/learningBase learningSummary/learningSummary

Example

id="learningSummary_ex">
<learningSummary id="learningsummary">
  <title>Summary: Understanding mail basics</title>
    <learningSummarybody>
      <lcObjectives>
        <lcObjectivesStem>You now know how to perform the following mail basics:</lcObjectivesStem>
        <lcObjectivesGroup>
            <lcObjective>Viewing the inbox</lcObjective>
            <lcObjective>Opening a message</lcObjective>
            <lcObjective>Moving messages to a folder</lcObjective>
        </lcObjectivesGroup>
      </lcObjectives>
    </learningSummarybody>
</learningSummary>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.4 learningContentbody
Next topic: 3.3.1.6 learningSummarybody


learningSummarybody

3.3.1.6 learningSummarybody

The <learningSummarybody> element is the main body-level element in a learningSummary topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningContent, learningSummary | ( ( (lcSummary) or (lcObjectives) or (lcReview) or (lcNextSteps) or (lcResources) or (section) ) (any number) )

Contained by

Doctype | Content model
learningContent, learningSummary | learningSummary

Inheritance

- topic/body learningBase/learningBasebody learningSummary/learningSummarybody

Example

See learningSummary.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.5 learningSummary
Next topic: 3.3.1.7 learningAssessment


learningAssessment

3.3.1.7 learningAssessment

A Learning Assessment presents questions or interactions that measure progress, encourage recollection, and stimulate reinforcement of the learning content, and can be presented before the content as a pre-assessment or as a post-assessment test. The interactions use a sub-set of the Question-Test Interoperability (QTI) specification, implemented as a DITA domain specialization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (learningAssessmentbody) then (related-links) (optional) then (no-topic-nesting) (any number) )
learningContent | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (learningAssessmentbody) then (related-links) (optional) then ( (no-topic-nesting) (optional) ) (any number) )

Contained by

Doctype | Content model
learningContent | learningContent

Inheritance

- topic/topic learningBase/learningBase learningAssessment/learningAssessment

Example

id="assessment_example">
<learningAssessment id="testAssess">
  <title>Certification Test</title>
    <shortdesc>Pass this test, and you are a certified genius.</shortdesc>
    <learningAssessmentbody>
      <lcIntro>Here's your test, folks. Good luck!</lcIntro>
      <lcInteraction>
        <lcSingleSelect id="asdf">
        <title>Multiple Choice - IEEE standards trivia</title>
          <lcQuestion>Which one of the listed standards committees
          is responsible for developing the token ring specification?</lcQuestion>
          <lcAnswerOptionGroup>
            <lcAnswerOption>
              <lcAnswerContent>IEEE 802.3</lcAnswerContent>
            </lcAnswerOption>
            <lcAnswerOption>
              <lcAnswerContent>IEEE 802.5</lcAnswerContent>
              <lcCorrectResponse/>
            </lcAnswerOption>
            <lcAnswerOption>
              <lcAnswerContent>IEEE 802.6</lcAnswerContent>
            </lcAnswerOption>
          </lcAnswerOptionGroup>
        </lcSingleSelect>
      </lcInteraction>
      <lcSummary>
        <title>Summary</title>
        You are now certified.
      </lcSummary>
    </learningAssessmentbody>
  </learningAssessment>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.6 learningSummarybody
Next topic: 3.3.1.8 learningAssessmentbody


learningAssessmentbody

3.3.1.8 learningAssessmentbody

The <learningAssessmentbody> element is the main body-level element in a learningAssessment topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent | ( (lcIntro) (optional) then (lcObjectives) (optional) then (lcDuration) (optional) then (lcInteraction) (any number) then (section) (any number) then (lcSummary) (optional) )

Contained by

Doctype | Content model
learningAssessment, learningContent | learningAssessment

Inheritance

- topic/body learningBase/learningBasebody learningAssessment/learningAssessmentbody

Example

See learningAssessment.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.7 learningAssessment
Next topic: 3.3.1.9 learningPlan


learningPlan

3.3.1.9 learningPlan

A Learning Plan topic describes learning needs and goals, instructional design models, task analyses, learning taxonomies, and other information necessary to the lesson planning process.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (learningPlanbody) then (related-links) (optional) then (no-topic-nesting) (any number) )

Contained by

This element is not contained by any other elements.

Inheritance

- topic/topic learningBase/learningBase learningPlan/learningPlan

Example

<learningPlan id="learningPlanTest">
    <title>Learning Plan</title>
    <shortdesc>It's always good to provide a plan.
    </shortdesc>
    <learningPlanbody>
        <lcProject>
            <title>lcProject</title>
            <lcClient>
                <title>lcClient</title>
                <p>Describe the client here.
                </p>
            </lcClient>
            <lcPlanTitle>
                <title>lcPlanTitle</title>
                <p>Describe the plan title here.
                </p>
            </lcPlanTitle>
            <lcCIN>
                <title>lcCIN</title>
                <p>Provide information about the course identification here.
                </p>
            </lcCIN>
            <lcModDate>
                <title>lcModDate</title>
                <p>Provide the modification date and related information here.
                </p>
            </lcModDate>
            <lcDelivDate>
                <title>lcDelivDate</title>
                <p>Provide the delivery date information.
                </p>
            </lcDelivDate>
            <lcPlanSubject>
                <title>lcPlanSubject</title>
                <p>Provide information about the plan subject.
                </p>
            </lcPlanSubject>
            <lcPlanDescrip>
                <title>lcPlanDescrip</title>
                <p>Provide information about the plan description.
                </p>
            </lcPlanDescrip>
            <lcPlanPrereqs>
                <title>lcPlanPrereqs</title>
                <p>Provide information about the plan prerequisites.
                </p>
            </lcPlanPrereqs>
        </lcProject>
        <lcNeedsAnalysis>
            <title>lcNeedsAnalysis</title>
            <lcOrganizational>
                <title>lcOrganizational</title>
                <lcGeneralDescription>Provide general description information.</lcGeneralDescription>
                <lcGoals>Provide information about organization goals related to this instruction.</lcGoals>
                <lcNeeds>Describe organizational needs related to this instruction.</lcNeeds>
                <lcValues>Describe organizational values related to this instruction.</lcValues>
                <lcOrgConstraints>Describe organizational constraints related to this instruction.</lcOrgConstraints>
            </lcOrganizational>
            <lcPlanAudience>
                <title>lcPlanAudience</title>
                <lcGeneralDescription>Provide general description information.</lcGeneralDescription>
                <lcEdLevel>Describe the education level for the learning audience.</lcEdLevel>
                <lcAge>Provide age information.</lcAge>
                <lcBackground>Provide background information.</lcBackground>
                <lcSkills>Describe the skills needed.</lcSkills>
                <lcKnowledge>Describe the knowledge requirements.</lcKnowledge>
                <lcMotivation>Describe the reasons why the learners want and/or need to take the instruction.</lcMotivation>
                <lcSpecChars>Provide information about any special characteristics of the instruction.</lcSpecChars>
            </lcPlanAudience>
            <lcWorkEnv>
                <title>lcWorkEnv</title>
                <lcWorkEnvDescription>Describe the work environment.</lcWorkEnvDescription>
                <lcPlanResources>Provide information about resource planning.</lcPlanResources>
                <lcProcesses>Provide information about important processes.</lcProcesses>
            </lcWorkEnv>
            <lcTask>
                <title>lcTask</title>
                <lcTaskItem>Describe the specific task item.</lcTaskItem>
                <lcKnowledge>Detail the knowledge needed for this task.</lcKnowledge>
                <lcSkills>Describe the skills needed.</lcSkills>
                <lcAttitude>Provide information about important attitudes.</lcAttitude>
            </lcTask>
            <lcTask>
                <title>another lcTask (as many more as you would like...)</title>
                <lcTaskItem>Describe the specific task item.</lcTaskItem>
                <lcKnowledge>Detail the knowledge needed for this task.</lcKnowledge>
                <lcSkills>Describe the skills needed.</lcSkills>
                <lcAttitude>Provide information about important attitudes.</lcAttitude>
            </lcTask>
        </lcNeedsAnalysis>
        <lcGapAnalysis>
            <title>lcGapAnalysis</title>
            <lcGapItem>
                <title>an lcGapItem</title>
                <lcPlanObjective>Describe the related plan objective for this gap.</lcPlanObjective>
                <lcJtaItem>Provide job task analysis information about the gap.</lcJtaItem>
                <lcGapItemDelta>Describe the gap item.</lcGapItemDelta>
            </lcGapItem>
            <lcGapItem>
                <title>and another GapItem for you to consider</title>
                <lcPlanObjective>Describe the related plan objective for this gap.</lcPlanObjective>
                <lcJtaItem>Provide job task analysis information about the gap.</lcJtaItem>
                <lcGapItemDelta>Describe the gap item.</lcGapItemDelta>
            </lcGapItem>
        </lcGapAnalysis>
        <lcIntervention>
            <title>lcIntervention</title>
            <lcInterventionItem>
                <title>lcInterventionItem</title>
                <lcLearnStrat>Describe the manner in which the learning content will be instructed. This should be a high level design that applies instructional-design theories and models.</lcLearnStrat>
                <lcPlanObjective>Describe the objective to be addressed by a gap analysis or intervention.</lcPlanObjective>
                <lcAssessment>Describe assessment plans.</lcAssessment>
                <lcDelivery>Describe the delivery method for this learning content.</lcDelivery>
            </lcInterventionItem>
            <lcInterventionItem>
                <title>another lcInterventionItem (and more if you want 'em)</title>
                <lcLearnStrat>Describe the manner in which the learning content will be instructed. This should be a high level design that applies instructional-design theories and models.</lcLearnStrat>
                <lcPlanObjective>Describe the objective to be addressed by a gap analysis or intervention.</lcPlanObjective>
                <lcAssessment>Describe assessment plans.</lcAssessment>
                <lcDelivery>Describe the delivery method for this learning content.</lcDelivery>
            </lcInterventionItem>
        </lcIntervention>
        <lcTechnical>
            <title>lcTechnical</title>
            <lcLMS>
                <title>lcLMS</title>
                <p>Describe characteristics of the learning management system to be used.
                </p>
            </lcLMS>
            <lcHandouts>
                <title>lcHandouts</title>
                <p>Describe any handouts.
                </p>
            </lcHandouts>
            <lcClassroom>
                <title>lcClassroom</title>
                <p>Provide information about the classroom, if used.
                </p>
            </lcClassroom>
            <lcOJT>
                <title>lcOJT</title>
                <p>Describe the on-the-job training.
                </p>
            </lcOJT>
            <lcConstraints>
                <title>lcConstraints</title>
                <p>Describe any constraints.
                </p>
            </lcConstraints>
            <lcW3C>
                <title>lcW3C</title>
                <p>Provide information about any related web standards.
                </p>
            </lcW3C>
            <lcPlayers>
                <title>lcPlayers</title>
                <p>Detail the tools and plugins used for time-sequenced display at runtime.
                </p>
            </lcPlayers>
            <lcViewers>
                <title>lcViewers</title>
                <p>Detail the viewers used for time-sequenced display at runtime.
                </p>
            </lcViewers>
            <lcResolution>
                <title>lcResolution</title>
                <p>Provide a list of related resources and information about them, such as related articles or samples on the web.
                </p>
            </lcResolution>
            <lcFileSizeLimitations>
                <title>lcFileSizeLimitations</title>
                <p>Describe any file size limitation in the download environment.
                </p>
            </lcFileSizeLimitations>
            <lcDownloadTime>
                <title>lcDownloadTime</title>
                <p>Provide an estimate of the download time.
                </p>
            </lcDownloadTime>
            <lcSecurity>
                <title>lcSecurity</title>
                <p>Describe security concerns or restrictions.
                </p>
            </lcSecurity>
        </lcTechnical>
    </learningPlanbody>
</learningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.8 learningAssessmentbody
Next topic: 3.3.1.10 learningPlanbody


learningPlanbody

3.3.1.10 learningPlanbody

The <learningPlanbody> element is the main body-level element in a learningPlan topic.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (lcProject) (optional) then (lcNeedsAnalysis) (optional) then (lcGapAnalysis) (optional) then (lcIntervention) (optional) then (lcTechnical) (optional) then (section) (any number) )

Contained by

Doctype | Content model
learningPlan | learningPlan

Inheritance

- topic/topic learningBase/learningBase learningPlan/learningPlanbody

Example

See learningPlan.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.9 learningPlan
Next topic: 3.3.1.11 learningBase


learningBase

3.3.1.11 learningBase

The learningBase topic type is not used to deliver any actual learning content, but instead provides a set of common elements for use in the other more specific learning content types: learningOverview,learningContent, learningSummary, learningAssessment, and learningPlan.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) then (titlealts) (optional) then (shortdesc or abstract) (optional) then (prolog) (optional) then (learningBasebody) (optional) then (related-links) (optional) then (topic) (any number) )

Contained by

This element is not contained by any other elements.

Inheritance

- topic/topic learningBase/learningBase

Attributes

Name | Description | Data Type | Default Value | Required?
id | This ID enables topics to be referenced uniquely by topicrefs in DITA maps. | ID |  | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
xmlns:ditaarch | Declares the default DITA namespace. |  | "http://dita.​oasis-open.​org/​architecture/​2005/" |
DITAArchVersion | Designates the version of the architecture that is in use. The default value will increase with each release of DITA. | CDATA | "1.2" | No
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
domains | Indicates the specialized domains that are included in the DTD or Schema. This value will differ depending on what domains are included in the current DTD or Schema. | CDATA | Varies based on the DTD or Schema; a sample value is "(topic ui-d) (topic hi-d) (topic pr-d) (topic sw-d) (topic ut-d) (topic indexing-d)" | No
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.10 learningPlanbody
Next topic: 3.3.1.12 learningBasebody


learningBasebody

3.3.1.12 learningBasebody

The <learningBasebody> element is the main body-level element in a learningBase topic. The learningBase topic provides a set of base elements for use in the other specialized learning types. It is not generally intended for creating actual content. As such, each of the body sections in learningBase are optional.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcAudience or lcChallenge or lcDuration or lcInstruction or lcInteraction or lcIntro or lcNextSteps or lcObjectives or lcPrereqs or lcResources or lcReview or lcSummary or section) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | learningBase

Inheritance

- topic/body learningBase/learningBasebody

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.1 Learning and training topic elements
Previous topic: 3.3.1.11 learningBase
Next topic: 3.3.2 Learning and training map domain elements


Learning and training map domain elements

3.3.2 Learning and training map domain elements

Use the learning and training map domain to organize groups of topics as learning objects. Defined as a map domain, these elements are available for use within any DITA map, not just a learning-specific DITA map. For example, you could include learning objects in a DITA generic map or in a DITA bookmap.

  • 3.3.2.1 learningGroup
    Use a <learningGroup> to structure learning objects into higher-level organizations, such as course-level, module-level, or lesson-level.
  • 3.3.2.2 learningObject
    learningObject organizes topic references to DITA learning topics as a learning object.
  • 3.3.2.3 learningPlanRef
    Use a <learningPlanRef> element to include a topic reference to a learning plan topic as part of a learningObject.
  • 3.3.2.4 learningPreAssessmentRef
    Use a <learningPreAssessmentRef> element to include a topic reference to a learning assessment topic as part of a DITA learningObject.
  • 3.3.2.5 learningOverviewRef
    Use a learningOverviewRef element to include a topic reference to a learning overview topic as part of a learningObject.
  • 3.3.2.6 learningContentRef
    Use a learningContentRef element to include a topic reference to a learning content topic as part of a DITA learningObject.
  • 3.3.2.7 learningContentComponentRef
    Use a learningContentComponentRef element to include a topic reference to a topic that acts as a subtopic of a learningContent topic.
  • 3.3.2.8 learningSummaryRef
    Use a <learningSummaryRef> to include topic reference to a learning summary topic in a DITA learning object.
  • 3.3.2.9 learningPostAssessmentRef
    Use a <learningPostAssessmentRef> element to include a topic reference to a learning assessment topic as part of a DITA learningObject.
Parent topic: 3.3 Learning and training elements
Previous topic: 3.3.1.12 learningBasebody
Next topic: 3.3.2.1 learningGroup


learningGroup

3.3.2.1 learningGroup

Use a <learningGroup> to structure learning objects into higher-level organizations, such as course-level, module-level, or lesson-level.

In addition to organizing learningObjects, a learningGroup may include topic references to learningPlan, learningOverview. and learningSummary topics, and may also include references to learningAssessment topics. A learningGroup can also contain other <learningGroup> elements, allowing you to organize learning content at course, module, or other higher levels of hierarchy.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) then (learningPlanRef) (optional) then ( (learningOverviewRef) or (learningPreAssessmentRef) ) (any number) then ( (learningObject) or (learningGroup) ) (any number) then ( (learningPostAssessmentRef) or (learningSummaryRef) ) (any number) )

Contained by

Doctype | Content model
learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, learningGroup
learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, learningGroup

Inheritance

+ map/topicref learningmap-d/learningGroup

Example

<map id="learningGroup_example">
<!-- a learningGroup can appear anywhere in a map hierarchy but always
     follows a consistent information pattern  -->
<!------------------------------------------------------------------->
<!-- a course=level learning group -->
<learningGroup href="course_top_Overview.dita" type="learningOverview">
<!------------------------------------------------------------------->
  <learningPlanRef href="course_Plan_topic.dita" type="learningPlan" />
  <learningOverviewRef href="course_Overview.dita" type="learningOverview"/>
  <!------------------------------------------------------------------->
  <!-- module-level learning groups -->
  <learningGroup href="module1_Overview.dita" type="learningOverview">
  <!------------------------------------------------------------------->
    <learningOverviewRef href="module1_Overview.dita" type="learningOverview"/>
      <!------------------------------------------------------------------->
      <!-- This module has two lesson-level groups of learning objects -->
      <learningGroup href="lesson1_Overview.dita" type="learningOverview">
      <!------------------------------------------------------------------->
        <learningOverviewRef href="lesson1_Overview.dita" type="learningOverview"/>
        <!-- learning objects in lesson1 -->
        <learningObject collection-type="sequence" href="lo1_Overview.dita" type="learningOverview">
        . . .
        </learningObject>
        <learningObject collection-type="sequence" href="lo2_Overview.dita" type="learningOverview">
        . . .
        </learningObject>
        <learningAssessmentRef href="lesson1_Assessment.dita" type="learningAssessment"/>
        <learningSummaryRef href="lesson1_Summary.dita" type="learningSummary"/>
      </learningGroup>
    <!------------------------------------------------------------------->
    <learningGroup href="lesson2_Overview.dita" type="learningOverview">
    <!------------------------------------------------------------------->
      <learningOverviewRef href="lesson1_Overview.dita" type="learningOverview"/>
        <!-- learning objects in lesson2 -->
        <learningObject collection-type="sequence" href="lo3_Overview.dita" type="learningOverview">
        . . .
        </learningObject>
        <learningObject collection-type="sequence" href="lo4_Overview.dita" type="learningOverview">
        . . .
        </learningObject>
        <learningAssessmentRef href="lesson2_Assessment.dita" type="learningAssessment"/>
        <learningSummaryRef href="lesson2_Summary.dita" type="learningSummary"/>
      </learningGroup>
  </learningGroup>
  <!------------------------------------------------------------------->
  <learningGroup href="module2_Overview.dita" type="learningOverview">
  <!------------------------------------------------------------------->
    <learningOverviewRef href="module1_Overview.dita" type="learningOverview"/>
      <!-- learning objects in module 2 (no lesson-level groups) -->
      <learningObject collection-type="sequence" href="loA_Overview.dita" type="learningOverview">
        . . .
      </learningObject>
      <learningObject collection-type="sequence" href="loB_Overview.dita" type="learningOverview">
      </learningObject>
        . . .
      <learningObject collection-type="sequence" href="loC_Overview.dita" type="learningOverview">
      </learningObject>
    <learningAssessmentRef href="module2_Assessment.dita" type="learningAssessment"/>
    <learningSummaryRef href="module2_Summary.dita" type="learningSummary"/>
  </learningGroup>
<!------------------------------------------------------------------->
<learningAssessmentRef href="course_Assessment.dita" type="learningAssessment"/>
<learningSummaryRef href="course_Summary.dita" type="learningSummary"/>
</learningGroup>
<!------------------------------------------------------------------->
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | learningOverview | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2 Learning and training map domain elements
Next topic: 3.3.2.2 learningObject


learningObject

3.3.2.2 learningObject

learningObject organizes topic references to DITA learning topics as a learning object.

A learningObject follows a specific sequence of topic references to learning content, starting with a learningPlan, then a learning overview or learning pre-assessment, one or more learning content topics, a learning summary, and one or more learning post-assessment topics.

By default, the topic references in a learningObject are expected to use the learning-specific topic types. However, the href can point to content of any type that you want to structure as a learning object. In this way, you can structure any existing DITA content as a learning object, and then take advantage of the learning-specific processing available for building and packaging that content for delivery in a learning system or learning context.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) then (learningPlanRef) (optional) then ( (learningOverviewRef) or (learningPreAssessmentRef) ) (any number) then (learningContentRef) (one or more) then ( (learningPostAssessmentRef) or (learningSummaryRef) ) (any number) )

Contained by

Doctype | Content model
learningBookmap | map, topicref, relcolspec, relcell, frontmatter, backmatter, draftintro, preface, chapter, part, appendix, notices, glossarylist, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, learningGroup
learningMap | map, topicref, relcolspec, relcell, topichead, topicgroup, anchorref, topicset, topicsetref, keydef, learningGroup

Inheritance

+ map/topicref learningmap-d/learningObject

Example

<map title="learningobject_example">
 <!-- learningObject clusters can appear anywhere in a map hierarchy but always
     follow a consistent information pattern within the LO -->
 <learningObject collection-type="sequence" href="topOverview.dita" type="learningOverview">
  <learningPlanRef href="testlearningPlan.dita" type="learningPlan">
  </learningPlanRef>
  <learningOverviewRef href="testlearningOverview.dita" type="learningOverview">
  </learningOverviewRef>
  <learningContentRef href="testlearningContent.dita" type="learningContent">
    <learningContentComponentRef href="termA.dita" type="glossentry"/>
    <learningContentComponentRef href="termB.dita" type="glossentry"/>
  </learningContentRef>
  <learningAssessmentRef href="testlearningAssess.dita" type="learningAssessment">
  </learningAssessmentRef>
  <learningSummaryRef href="testlearningSummary.dita" type="learningSummary">
  </learningSummaryRef>
 </learningObject>
</map>

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | learningOverview | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2.1 learningGroup
Next topic: 3.3.2.3 learningPlanRef


learningPlanRef

3.3.2.3 learningPlanRef

Use a <learningPlanRef> element to include a topic reference to a learning plan topic as part of a learningObject.

By default, a learningPlanRef is expected to link to a learningPlan topic. However, the href in a learningPlanRef can link to content of any type that you want to use as a learning plan in a learning object. In this way, you can structure any existing DITA content as a learning object, and then take advantage of the learning-specific processing available for building and packaging that content for delivery in a learning system or learning context.

When you include a reference to a DITA topic that is not learningPlan, change the type attribute to match the type of topic being referenced.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) )

Contained by

Doctype | Content model
learningBookmap, learningMap | learningGroup, learningObject

Inheritance

+ map/topicref learningmap-d/learningPlanref

Example

See learningObject.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | learningPlan | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2.2 learningObject
Next topic: 3.3.2.4 learningPreAssessmentRef


learningPreAssessmentRef

3.3.2.4 learningPreAssessmentRef

Use a <learningPreAssessmentRef> element to include a topic reference to a learning assessment topic as part of a DITA learningObject.

By default, a learningAssessmentPreRef is expected to link to a learningAssessment topic. However, the href in a learningAssessmentPreRef can link to content of any type that you want to use as a learning assessment in a learning object. In this way, you can structure any existing DITA content as a learning object, and then take advantage of the learning-specific processing available for building and packaging that content for delivery in a learning system or learning context.

When you include a reference to a DITA topic that is not learningAssessment, change the type attribute to match the type of topic being referenced.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) )

Contained by

Doctype | Content model
learningBookmap, learningMap | learningGroup, learningObject

Inheritance

+ map/topicref learningmap-d/learningPreAssessmentRef

Example

See learningObject.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | learningPreAssessment | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2.3 learningPlanRef
Next topic: 3.3.2.5 learningOverviewRef


learningOverviewRef

3.3.2.5 learningOverviewRef

Use a learningOverviewRef element to include a topic reference to a learning overview topic as part of a learningObject.

By default, a learningOverviewRef is expected to link to a learningOverview topic. However, the href in a learningOverviewRef can link to content of any type that you want to use as a learning overview in a learning object. In this way, you can structure any existing DITA content as a learning object, and then take advantage of the learning-specific processing available for building and packaging that content for delivery in a learning system or learning context.

When you include a reference to a DITA topic that is not learningOverview, change the type attribute to match the type of topic being referenced.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) )

Contained by

Doctype | Content model
learningBookmap, learningMap | learningGroup, learningObject

Inheritance

+ map/topicref learningmap-d/learningOverviewRef

Example

See learningObject.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | learningOverview | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2.4 learningPreAssessmentRef
Next topic: 3.3.2.6 learningContentRef


learningContentRef

3.3.2.6 learningContentRef

Use a learningContentRef element to include a topic reference to a learning content topic as part of a DITA learningObject.

By default, a learningContentRef is expected to link to a learningContent topic. However, a learningContentRef can link to content of any type that you want to use as a learning content in a learning object. In this way, you can structure any existing DITA content as a learning object, and then take advantage of the learning-specific processing available for building and packaging that content for delivery in a learning system or learning context.

The presentation intent for learningContent is that the topic be presented as an atomic unit of presentation, for example, as required by SCORM delivery requirements. Thus the default value for the chunk attribute is "to-content". You may use learningContentComponentRef topicrefs to include subordinate topics.

When you include a reference to a DITA topic that is not learningContent, change the type attribute value to match the type of topic being referenced.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) then (learningContentComponentRef) (any number) )

Contained by

Doctype | Content model
learningBookmap, learningMap | learningObject

Inheritance

+ map/topicref learningmap-d/learningContentRef

Example

See learningObject.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | learningContent or topic or task or concept or reference | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2.5 learningOverviewRef
Next topic: 3.3.2.7 learningContentComponentRef


learningContentComponentRef

3.3.2.7 learningContentComponentRef

Use a learningContentComponentRef element to include a topic reference to a topic that acts as a subtopic of a learningContent topic.

The learning and training architecture defines the child topics of learningObject as being atomic units of presentation. However, these topics may include subordinate topics. The learningContentComponentRef topicref may be used to refer to any topic type. The presentation intent is that such topics are presented as integral parts of their parent topics. This intent is reflected in the default chunk attribute value of "to-content" for the topicref types learningContentRef, learningOverviewRef, learningPlanRef, learningPreAssessmentRef, and learningPostAssessmentRef.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) then (learningContentComponentRef) (any number) )

Contained by

Doctype | Content model
learningBookmap, learningMap | learningContentRef, learningContentComponentRef

Inheritance

+ map/topicref learningmap-d/learningContentRef

Example

See learningObject.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | Any topic type | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2.6 learningContentRef
Next topic: 3.3.2.8 learningSummaryRef


learningSummaryRef

3.3.2.8 learningSummaryRef

Use a <learningSummaryRef> to include topic reference to a learning summary topic in a DITA learning object.

By default, a learningSummaryRef is expected to link to a learningSummary topic. However, the href in a learningSummaryRef can link to content of any type that you want to use as a learning summary in a learning object. In this way, you can structure any existing DITA content as a learning object, and then take advantage of the learning-specific processing available for building and packaging that content for delivery in a learning system or learning context.

When you include a reference to a DITA topic that is not learningSummary, change the type attribute to match the type of topic being referenced.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) )

Contained by

Doctype | Content model
learningBookmap, learningMap | learningGroup, learningObject

Inheritance

+ map/topicref learningmap-d/learningSummaryRef

Example

See learningObject.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | learningSummary | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2.7 learningContentComponentRef
Next topic: 3.3.2.9 learningPostAssessmentRef


learningPostAssessmentRef

3.3.2.9 learningPostAssessmentRef

Use a <learningPostAssessmentRef> element to include a topic reference to a learning assessment topic as part of a DITA learningObject.

By default, a learningAssessmentPostRef is expected to link to a learningAssessment topic. However, the href in a learningAssessmentPostRef can link to content of any type that you want to use as a learning assessment in a learning object. In this way, you can structure any existing DITA content as a learning object, and then take advantage of the learning-specific processing available for building and packaging that content for delivery in a learning system or learning context.

When you include a reference to a DITA topic that is not learningAssessment, change the type attribute to match the type of topic being referenced.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningBookmap, learningMap | ( (topicmeta) (optional) )

Contained by

Doctype | Content model
learningBookmap, learningMap | learningGroup, learningObject

Inheritance

+ map/topicref learningmap-d/learningPostAssessmentRef

Example

See learningObject.

Attributes

Name | Description | Data Type | Default Value | Required?
navtitle | Specifies the title of the topic as it will appear in the navigation or tables of contents that are generated from the map. Beginning with DITA 1.2, the preferred way to specify the navigation title in a map is with the navtitle element, available inside the topicmeta element. | CDATA | #IMPLIED | No
href | A pointer to the resource represented by the <topicref>. See The href attribute for detailed information on supported values and processing implications. References to DITA content cannot be below the topic level: that is, you cannot reference individual elements inside a topic. References to content other than DITA topics should use the format attribute to identify the kind of resource being referenced. | CDATA | #IMPLIED | No
query | This attribute is deprecated. It may be removed in the future. | CDATA | #IMPLIED | No
copy-to | Use the copy-to attribute on the <topicref> element to provide a different file name for a particular instance of the topic in the map (for example, to separate out the different versions of the topic, rather than combining them on output). The links and navigation associated with that instance will point to a copy of the topic with the file name you specified. Use the <linktext> and <shortdesc> in the <topicref>'s <topicmeta> to provide a unique name and short description for the new copy. | CDATA | #IMPLIED | No
type | The topic type of the map reference. | CDATA | learningPostAssessment | IMPLIED
topicref-atts attribute group (collection-type, processing-role, type, scope, locktitle, format, linking, toc, print, search, chunk) | A set of related attributes. See topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups. |  |  |
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.2 Learning and training map domain elements
Previous topic: 3.3.2.8 learningSummaryRef
Next topic: 3.3.3 Learning and training interactions domain elements


Learning and training interactions domain elements

3.3.3 Learning and training interactions domain elements

Use the learning interactions to construct a basic set of question and response interaction. The domain also provides an lcInstructornote element, which you can use to provide instructor-specific information in the learning topics.

  • 3.3.3.1 lcInstructornote
    Use the <lcInstructornote> element to provide information or notes you want to provide to the course instructor. These notes can be condionalized out of content you intend to deliver to the learner.
  • 3.3.3.2 DITA learning interaction base domain elements
    The learning interaction base domain defines an "abstract" base type for all learning assessments. This base type enables recognition of elements as interactions as distinct from other topic/fig elements. The lcInteractionBase element is intended to be used only as a base for specialization. It should not be used directly as an element type in DITA documents.
Parent topic: 3.3 Learning and training elements
Previous topic: 3.3.2.9 learningPostAssessmentRef
Next topic: 3.3.3.1 lcInstructornote


lcInstructornote

3.3.3.1 lcInstructornote

Use the <lcInstructornote> element to provide information or notes you want to provide to the course instructor. These notes can be condionalized out of content you intend to deliver to the learner.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteractionBase
learningContent | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, prereq, context, steps-informal, stepsection, step, info, substep, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, propdesc, lcInteractionBase
learningPlan | desc, p, lq, li, itemgroup, dd, fig, figgroup, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, linkinfo, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcClient, lcPlanTitle, lcCIN, lcModDate, lcDelivDate, lcPlanSubject, lcPlanDescrip, lcPlanPrereqs, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcLMS, lcNoLMS, lcHandouts, lcClassroom, lcOJT, lcConstraints, lcW3C, lcPlayers, lcGraphics, lcViewers, lcResolution, lcFileSizeLimitations, lcDownloadTime, lcSecurity, lcInteractionBase

Inheritance

+ topic/note learningInteractionBase-d/note learning-d/lcInstructornote

Example

<lcIntro>
  <title>Introduction</title>
  <p>If you need an introduction, you would
    include it here.</p>
  <note>You can have notes, tables, all kinds of things
    like that here, if you desire.</note>
  <lcInstructornote>You can provide tips for instructors in an
    instructor note, like this one.</lcInstructornote>
</lcIntro>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3 Learning and training interactions domain elements
Previous topic: 3.3.3 Learning and training interactions domain elements
Next topic: 3.3.3.2 DITA learning interaction base domain elements


DITA learning interaction base domain elements

3.3.3.2 DITA learning interaction base domain elements

The learning interaction base domain defines an "abstract" base type for all learning assessments. This base type enables recognition of elements as interactions as distinct from other topic/fig elements. The lcInteractionBase element is intended to be used only as a base for specialization. It should not be used directly as an element type in DITA documents.

  • 3.3.3.2.1 lcInteractionBase
    Use <lcInteractionBase> as the base for more specialized assessment types.
  • 3.3.3.2.2 lcQuestionBase
    The lcQuestionBase element is the base for lcQuestion in the learningDomain domain. This is an "abstract" element type intended only for use as a base for specialization.
  • 3.3.3.2.3 lcOpenQuestion
    Use <lcOpenQuestion> to pose an open-ended question in an assessment interaction.
  • 3.3.3.2.4 lcTrueFalse
    A lcTrueFalse interaction presents the learner with two choices, one correct, the other incorrect, often presented as true/false or yes/no responses.
  • 3.3.3.2.5 lcSingleSelect
    An lcSingleSelect interaction presents three or more choices, only one of which is correct.
  • 3.3.3.2.6 lcMultipleSelect
    In an lcMultipleSelect interaction, the learner must indicate two or more correct answers from a list of choices.
  • 3.3.3.2.7 lcSequencing
    An lcSequencing interaction asks the learner to arrange a list of choices into a predefined order, such as small to large.
  • 3.3.3.2.8 lcMatching
    In an lcMatching interaction, the learner identifies the correct choice that matches another choice and, optionally, any feedback for the pair or for correct or incorrect matches.
  • 3.3.3.2.9 lcHotspot
    In a lcHotspot interaction, the learner clicks on a region of the screen to indicate a choice.
Parent topic: 3.3.3 Learning and training interactions domain elements
Previous topic: 3.3.3.1 lcInstructornote
Next topic: 3.3.3.2.1 lcInteractionBase


lcInteractionBase

3.3.3.2.1 lcInteractionBase

Use <lcInteractionBase> as the base for more specialized assessment types.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcQuestionBase) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

+ topic/fig lcInteractionBase-d/lcInteractionBase

lcInteractionBase should only be used as a base for further specialization.

Attributes

Name | Description | Data Type | Default Value | Required?
id | Defines an ID by which the element may be referenced. | NMTOKEN | #REQUIRED | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2 DITA learning interaction base domain elements
Next topic: 3.3.3.2.2 lcQuestionBase


lcQuestionBase

3.3.3.2.2 lcQuestionBase

The lcQuestionBase element is the base for lcQuestion in the learningDomain domain. This is an "abstract" element type intended only for use as a base for specialization.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcInteractionBase

Inheritance

+ topic/p learningInteractionBase-d/lcQuestionBase

Example

See lcQuestion.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2.1 lcInteractionBase
Next topic: 3.3.3.2.3 lcOpenQuestion


lcOpenQuestion

3.3.3.2.3 lcOpenQuestion

Use <lcOpenQuestion> to pose an open-ended question in an assessment interaction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcQuestion) then (lcAsset) (optional) then (lcOpenAnswer) (optional) then (lcFeedbackIncorrect) (optional) then (lcFeedbackCorrect) (optional) then (data) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

+ topic/fig learningInteractionBase-d/lcInteractionBase learning-d/lcOpenQuestion

Example

   <!--Open Question sample -->
   <lclOpenQuestion id="oq1">
    <title>Cows and moon jumps</title>
    <lcQuestion>Describe how it might be possible for a cow to jump over the moon.</lcQuestion>
    <lcOpenAnswer>Cows can only jump over the moon in nursery rhymes.<lcOpenAnswer>
   </lcOpenQuestion>

Attributes

Name | Description | Data Type | Default Value | Required?
id | Defines an ID by which the element may be referenced. | NMTOKEN | #REQUIRED | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2.2 lcQuestionBase
Next topic: 3.3.3.2.4 lcTrueFalse


lcTrueFalse

3.3.3.2.4 lcTrueFalse

A lcTrueFalse interaction presents the learner with two choices, one correct, the other incorrect, often presented as true/false or yes/no responses.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcQuestion) then (lcAsset) (optional) then (lcAnswerOptionGroup) then (lcFeedbackIncorrect) (optional) then (lcFeedbackCorrect) (optional) then (data) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

+ topic/fig learningInteractionBase-d/lcInteractionBase learning-d/lcTrueFalse

Example

   <!--True - False Interaction                    -->
   <lcTrueFalse id="tf1">
    <title>True - False sun rising</title>
    <lcQuestion>On Earth, the sun rises in the West and sets in the East.</lcQuestion>
    <lcAnswerOptionGroup>
     <lcAnswerOption>
      <lcAnswerContent>True</lcAnswerContent>
     </lcAnswerOption>
     <lcAnswerOption>
      <lcAnswerContent>False</lcAnswerContent>
      <lcCorrectResponse/>
     </lcAnswerOption>
    </lcAnswerOptionGroup>
    <lcFeedbackIncorrect>No, look to the East.</lcFeedbackIncorrect>
    <lcFeedbackCorrect>Yes, look to the East.</lcFeedbackCorrect>
   </lcTrueFalse>

Attributes

Name | Description | Data Type | Default Value | Required?
id | Defines an ID by which the element may be referenced. | NMTOKEN | #REQUIRED | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2.3 lcOpenQuestion
Next topic: 3.3.3.2.5 lcSingleSelect


lcSingleSelect

3.3.3.2.5 lcSingleSelect

An lcSingleSelect interaction presents three or more choices, only one of which is correct.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcQuestion) then (lcAsset) (optional) then (lcAnswerOptionGroup) then (lcFeedbackIncorrect) (optional) then (lcFeedbackCorrect) (optional) then (data) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

+ topic/fig learningInteractionBase-d/lcInteractionBase learning-d/lcSingleSelect

Example

   <!--Single select Interaction                    -->
   <lcSingleSelect id="singleselect">
    <title>Multiple Choice - IEEE standards trivia</title>
    <lcQuestion>Which one of the listed standards committees is responsible for
developing the token ring specification?</lcQuestion>
    <lcAnswerOptions>
     <lcAnswerOption>
      <lcAnswerContent>IEEE 802.3</lcAnswerContent>
      <lcFeedback>Sorry. A little low.</lcFeedback>
     </lcAnswerOption>
     <lcAnswerOption>
      <lcAnswerContent>IEEE 802.5</lcAnswerContent>
      <lcCorrectResponse/>
      <lcFeedback>That's the one.</lcFeedback>
     </lcAnswerOption>
     <lcAnswerOption>
      <lcAnswerContent>IEEE 802.6</lcAnswerContent>
      <lcFeedback>Nope. Too high.</lcFeedback>
     </lcAnswerOption>
     <lcAnswerOption>
      <lcAnswerContent>IEEE 802.11</lcAnswerContent>
      <lcFeedback>Nope. Way too high.</lcFeedback>
     </lcAnswerOption>
    </lcAnswerOptions>
   </lcSingleSelect>

Attributes

Name | Description | Data Type | Default Value | Required?
id | Defines an ID by which the element may be referenced. | NMTOKEN | #REQUIRED | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2.4 lcTrueFalse
Next topic: 3.3.3.2.6 lcMultipleSelect


lcMultipleSelect

3.3.3.2.6 lcMultipleSelect

In an lcMultipleSelect interaction, the learner must indicate two or more correct answers from a list of choices.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcQuestion) then (lcAsset) (optional) then (lcAnswerOptionGroup) then (lcFeedbackIncorrect) (optional) then (lcFeedbackCorrect) (optional) then (data) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

+ topic/fig learningInteractionBase-d/lcInteractionBase learning-d/lcMultipleSelect

Example

      <!--Multiple select Interaction                    -->
      <lcMultipleSelect
        id="ms1">
        <title>Finding Major League Baseball logos</title>
        <lcQuestion>Which one of the following is a logo of a Major League Baseball team? (You may
          choose more than one.)</lcQuestion>
        <lcAnswerOptionGroup>
          <lcAnswerOption
            id="A">
            <lcAnswerContent>
              <image
                href="logo1.gif"/>
            </lcAnswerContent>
            <lcCorrectResponse/>
            <lcFeedback>Yes, that's one.</lcFeedback>
          </lcAnswerOption>
          <lcAnswerOption
            id="B">
            <lcAnswerContent>
              <image
                href="logo2.gif"/>
            </lcAnswerContent>
            <lcCorrectResponse/>
            <lcFeedback>Yes, that's one.</lcFeedback>
          </lcAnswerOption>
          <lcAnswerOption
            id="C">
            <lcAnswerContent>
              <image
                href="logo3.gif"/>
            </lcAnswerContent>
            <lcFeedback>No, not that one. Sorry!</lcFeedback>
          </lcAnswerOption>
          <lcAnswerOption
            id="D">
            <lcAnswerContent>
              <image
                href="logo4.gif"/>
            </lcAnswerContent>
            <lcCorrectResponse/>
            <lcFeedback>Yes, that's one.</lcFeedback>
          </lcAnswerOption>
        </lcAnswerOptionGroup>
      </lcMultipleSelect>

Attributes

Name | Description | Data Type | Default Value | Required?
id | Defines an ID by which the element may be referenced. | NMTOKEN | #REQUIRED | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2.5 lcSingleSelect
Next topic: 3.3.3.2.7 lcSequencing


lcSequencing

3.3.3.2.7 lcSequencing

An lcSequencing interaction asks the learner to arrange a list of choices into a predefined order, such as small to large.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcQuestion) then (lcAsset) (optional) then (lcSequenceOptionGroup) then (lcFeedbackIncorrect) (optional) then (lcFeedbackCorrect) (optional) then (data) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

+ topic/fig learningInteractionBase-d/lcInteractionBase learning-d/lcSequencing

Example

      <lcSequencing id="sequencing">
        <title>Sequencing City Populations in the U.S.</title>
        <lcQuestion>Order the following U.S. cities according to population, from
          largest to smallest.</lcQuestion>
        <lcSequenceOptionGroup>
          <lcSequenceOption>
            <lcAnswerContent>Portland, Oregon</lcAnswerContent>
            <lcSequence name="lcSequence" value="2"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Chicago, Illinois</lcAnswerContent>
            <lcSequence name="lcSequence" value="1"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Portland, Maine</lcAnswerContent>
            <lcSequence name="lcSequence" value="4"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Syracuse, New York</lcAnswerContent>
            <lcSequence name="lcSequence" value="3"/>
          </lcSequenceOption>
        </lcSequenceOptionGroup>
        <lcFeedbackIncorrect>No, try again, please.     </lcFeedbackIncorrect>
        <lcFeedbackCorrect>Very good.</lcFeedbackCorrect>
      </lcSequencing>

Attributes

Name | Description | Data Type | Default Value | Required?
id | Defines an ID by which the element may be referenced. | NMTOKEN | #REQUIRED | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2.6 lcMultipleSelect
Next topic: 3.3.3.2.8 lcMatching


lcMatching

3.3.3.2.8 lcMatching

In an lcMatching interaction, the learner identifies the correct choice that matches another choice and, optionally, any feedback for the pair or for correct or incorrect matches.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcQuestion) then (lcAsset) (optional) then (lcMatchTable) then (lcFeedbackIncorrect) (optional) then (lcFeedbackCorrect) (optional) then (data) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

+ topic/fig learningInteractionBase-d/lcInteractionBase learning-d/lcMatching

Example

<!--Matching Interaction                    -->
<lcMatching id="matching">
  <title>Matching teams with cities</title>
  <lcQuestion>Match the team with the city.</lcQuestion>
  <lcMatchTable>
    <lcMatchingHeader>
      <lcItem>Team</lcItem>
      <lcMatchingItem>City</lcMatchingItem>
    </lcMatchingHeader>
    <lcMatchingPair>
      <lcItem>Boston</lcItem>
      <lcMatchingItem>Red Sox</lcMatchingItem>
      <lcMatchingItemFeedback>
        <lcFeedbackCorrect>The Red Sox play in Boston's Fenway Park</lcFeedbackCorrect>
        <lcFeedbackIncorrect>That is not Boston's home team</lcFeedbackIncorrect>
      </lcMatchingItemFeedback>
    </lcMatchingPair>
    <lcMatchingPair>
      <lcItem>San Francisco</lcItem>
      <lcMatchingItem>Giants</lcMatchingItem>
      <lcMatchingItemFeedback>
        <lcFeedbackCorrect>The Giants play in San Franciso's Candlestick Park</lcFeedbackCorrect>
        <lcFeedbackIncorrect>That is not San Franciso's home team</lcFeedbackIncorrect>
      </lcMatchingItemFeedback>
    </lcMatchingPair>
    <lcMatchingPair>
      <lcItem>Chicago</lcItem>
      <lcMatchingItem>Cubs</lcMatchingItem>
      <lcMatchingItemFeedback>
        <lcFeedbackCorrect>The Cubs play in Chicago's Wrigley Field</lcFeedbackCorrect>
        <lcFeedbackIncorrect>That is not Chicago's home team.</lcFeedbackIncorrect>
      </lcMatchingItemFeedback>
    </lcMatchingPair>
    <lcMatchingPair>
      <lcItem>Toronto</lcItem>
      <lcMatchingItem>Blue Jays</lcMatchingItem>
      <lcMatchingItemFeedback>
        <lcFeedbackCorrect>The Blue Jays play in Toronto's SkyDome</lcFeedbackCorrect>
        <lcFeedbackIncorrect>That is not Toronto's home team.</lcFeedbackIncorrect>
      </lcMatchingItemFeedback>
    </lcMatchingPair>
  </lcMatchTable>
</lcMatching>

Attributes

Name | Description | Data Type | Default Value | Required?
id | Defines an ID by which the element may be referenced. | NMTOKEN | #REQUIRED | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2.7 lcSequencing
Next topic: 3.3.3.2.9 lcHotspot


lcHotspot

3.3.3.2.9 lcHotspot

In a lcHotspot interaction, the learner clicks on a region of the screen to indicate a choice.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcQuestion) then (lcHotspotMap) then (lcFeedbackIncorrect) (optional) then (lcFeedbackCorrect) (optional) then (data) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningSummary | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcInstructornote
learningContent | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, prereq, context, steps-informal, stepsection, info, tutorialinfo, stepxmp, choice, choptionhd, chdeschd, choption, chdesc, stepresult, result, postreq, conbody, refsyn, proptypehd, propvaluehd, propdeschd, lcInstructornote
learningPlan | p, note, lq, li, itemgroup, dd, stentry, draft-comment, fn, entry, abstract, body, bodydiv, section, sectiondiv, example, lcIntro, lcAudience, lcPrereqs, lcSummary, lcNextSteps, lcReview, lcResources, lcChallenge, lcInstruction, lcInteraction, lcGeneralDescription, lcGoals, lcNeeds, lcValues, lcOrgConstraints, lcEdLevel, lcAge, lcBackground, lcSkills, lcKnowledge, lcMotivation, lcSpecChars, lcWorkEnvDescription, lcPlanResources, lcProcesses, lcTaskItem, lcAttitude, lcPlanObjective, lcJtaItem, lcGapItemDelta, lcLearnStrat, lcAssessment, lcDelivery, lcInstructornote

Inheritance

+ topic/fig learningInteractionBase-d/lcInteractionBase learning-d/lcHotspot

Example

   <!--Hotspot Interaction    -->
   <lcHotspot id="hotspots">
    <title>Team logos hotspot</title>
    <lcQuestion>Which of the following is the logo for the Cleveland Indians?</lcQuestion>
    <lcHotspotMap>
     <image href="hotlogos.gif"/>
     <lcArea id="indians">
      <lcAreaShape>rect</lcAreaShape>
      <lcAreaCoords>0,0,50,50</lcAreaCoords>
      <lcCorrectResponse value="indians"/>
      <lcFeedback>Yes.</lcFeedback>
     </lcArea>
     <lcArea id="giants">
      <lcAreaShape>rect</lcAreaShape>
      <lcAreaCoords>50,0,100,50</lcAreaCoords>
      <lcFeedback>No.</lcFeedback>
     </lcArea>
     <lcArea id="cardinals">
      <lcAreaShape>rect</lcAreaShape>
      <lcAreaCoords>0,50,50,100</lcAreaCoords>
      <lcFeedback>No.</lcFeedback>
     </lcArea>
     <lcArea id="orioles">
      <lcAreaShape>rect</lcAreaShape>
      <lcAreaCoords>50,50,100,100</lcAreaCoords>
      <lcFeedback>No.</lcFeedback>
     </lcArea>
    </lcHotspotMap>
   </lcHotspot>

Attributes

Name | Description | Data Type | Default Value | Required?
id | Defines an ID by which the element may be referenced. | NMTOKEN | #REQUIRED | Yes
conref-atts attribute group (conref, conrefend, conaction, conkeyref) | A set of related attributes; includes all of the attributes described in id-atts attribute group except for the id attribute. |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
localization-atts attribute group (translate, xml:lang, dir) | A set of related attributes, described in localization-atts attribute group. |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.3.2 DITA learning interaction base domain elements
Previous topic: 3.3.3.2.8 lcMatching
Next topic: 3.3.4 Learning and training metadata elements


Learning and training metadata elements

3.3.4 Learning and training metadata elements

Use the learning and training metadata to describe specific characteristics of the learning content. The learning and training metadata elements provide a robust metadata model for learning objects, built upon industry standards and best practices. Defined as a domain, these elements are available for use in both the topic prolog and the map topicmeta.

  • 3.3.4.1 lcLom
    The <lcLom> provides a set of specialized data elements to use to specify metadata in the learning topics and learning map domain.
  • 3.3.4.2 lomAggregationLevel
    The <lomAggregationLevel> describes the functional size of the learning resource.
  • 3.3.4.3 lomContext
    The <lomContext> describes the typical learning environment where use of the learning object is intended to take place.
  • 3.3.4.4 lomCoverage
    The <lomCoverage> provides learning metadata about the temporal or spatial characteristics of the content, such as historical context.
  • 3.3.4.5 lomDifficulty
    The <lomDifficulty> provides learning metadata about how hard it is to work through the resource for the typical target audience.
  • 3.3.4.6 lomInstallationRemarks
    The <lomInstallationRemarks> provides learning metadata about how to install and needed resources.
  • 3.3.4.7 lomIntendedUserRole
    The <lomIntendedUserRole> provides learning metadata about the normal user of the resource, most dominant first.
  • 3.3.4.8 lomInteractivityLevel
    The <lomInteractivityLevel> provides learning metadata about the level of interactivity between an end user and the learning object.
  • 3.3.4.9 lomInteractivityType
    The <lomInteractivityType> provides learning metadata about the the type of interactivity supported by the resource.
  • 3.3.4.10 lomLearningResourceType
    The <lomLearningResourceType> provides learning metadata about the specific kind of resource used, most dominant kind first.
  • 3.3.4.11 lomOtherPlatformRequirements
    The <lomOtherPlatformRequirements> provides learning metadata information about other software and hardware requirements.
  • 3.3.4.12 lomSemanticDensity
    The <lomSemanticDensity> provides learning metadata about a subjective measure of the learning object's usefulness as compared to its size or duration.
  • 3.3.4.13 lomStructure
    The <lomStructure> provides learning metadata about the underlying organizational structure of the resource.
  • 3.3.4.14 lomTechRequirement
    The <lomTechRequirement> provides learning metadata about the operating system(s) under which the learning resource can run.
  • 3.3.4.15 lomTypicalAgeRange
    The <lomTypicalAgeRange> provides learning metadata about the age of the typical intended user.
  • 3.3.4.16 lomTypicalLearningTime
    The <lomTypicalLearningTime> provides learning metadata about the approximate or typical time it takes to work with the resource.
Parent topic: 3.3 Learning and training elements
Previous topic: 3.3.3.2.9 lcHotspot
Next topic: 3.3.4.1 lcLom


lcLom

3.3.4.1 lcLom

The <lcLom> provides a set of specialized data elements to use to specify metadata in the learning topics and learning map domain.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( ( (lomStructure) (optional) then (lomCoverage) (optional) then (lomAggregationLevel) (optional) then (lomTechRequirement) (optional) then (lomInstallationRemarks) (optional) then (lomOtherPlatformRequirements) (optional) then (lomInteractivityType) (optional) then (lomLearningResourceType) (optional) then (lomInteractivityLevel) (optional) then (lomSemanticDensity) (optional) then (lomIntendedUserRole) (optional) then (lomContext) (optional) then (lomTypicalAgeRange) (optional) then (lomDifficulty) (optional) then (lomTypicalLearningTime) (optional) ) then (data) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | prolog
learningBookmap | topicmeta, bookmeta
learningMap | topicmeta

Inheritance

+ topic/data learning-d/lcLom

LOM Examples

<learningContent id="learningcontent">
  <title>LOM samples</title>
  <shortdesc>Here are samples of LOM metadata.</shortdesc>
  <prolog>
    <lcLom>
      <lomStructure value="collection"></lomStructure>
      <lomCoverage>This course was first offered in ancient Rome, with no updates
        needed since.</lomCoverage>
      <lomAggregationLevel value="1"></lomAggregationLevel>
      <lomTechRequirement value="ms-windows"></lomTechRequirement>
      <lomInstallationRemarks>No installation is required for this content.</lomInstallationRemarks>
      <lomOtherPlatformRequirements>no other platform requirements</lomOtherPlatformRequirements>
      <lomInteractivityType value="expositive"></lomInteractivityType>
      <lomLearningResourceType value="narrativetext"></lomLearningResourceType>
      <lomInteractivityLevel value="medium"></lomInteractivityLevel>
      <lomSemanticDensity value="medium"></lomSemanticDensity>
      <lomIntendedUserRole value="teacher"></lomIntendedUserRole>
      <lomContext value="other"></lomContext>
      <lomTypicalAgeRange value="18-22"></lomTypicalAgeRange>
      <lomDifficulty value="easy"></lomDifficulty>
      <lomTypicalLearningTime value="00:30"></lomTypicalLearningTime>
    </lcLom>
  </prolog>
  <learningContentbody></learningContentbody>
</learningContent>

Attributes

Name | Description | Data Type | Default Value | Required?
mapkeyref | Identifies the map, if any, from which the contained links are derived. This value is automatically generated by the same process that creates the links from the map, as a way to identify which map the links came from. If the <linklist> or <linkpool> is manually created by the author, there is no need to use this attribute. Note that this attribute is not related to the keyref attribute, and is not used for key based processing. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class | A common attribute described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4 Learning and training metadata elements
Next topic: 3.3.4.2 lomAggregationLevel


lomAggregationLevel

3.3.4.2 lomAggregationLevel

The <lomAggregationLevel> describes the functional size of the learning resource.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learningmeta-d/lomAggregationLevel

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Name of the metadata being specified. | CDATA | lomAggregationLevel |
datatype | Datatype of the metadata being specified. | CDATA |  | no
value | The aggregation level for this content. See this topic for more information on the -dita-use-conref-target value. | (1 | 2 | 3 | 4 | -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.1 lcLom
Next topic: 3.3.4.3 lomContext


lomContext

3.3.4.3 lomContext

The <lomContext> describes the typical learning environment where use of the learning object is intended to take place.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomContext

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Name of the metadata being specified. | CDATA | lomContext |
datatype | Datatype of the metadata being specified. | CDATA |  | no
value | The learning context for this content. See this topic for more information on the -dita-use-conref-target value. | One of the following: (school | highereducation | training | other | -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.2 lomAggregationLevel
Next topic: 3.3.4.4 lomCoverage


lomCoverage

3.3.4.4 lomCoverage

The <lomCoverage> provides learning metadata about the temporal or spatial characteristics of the content, such as historical context.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomCoverage

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Name of the metadata being specified. | CDATA | lomCoverage |
datatype | Datatype of the metadata being specified. | CDATA |  | no
value | The coverage description for this content. See this topic for more information on the -dita-use-conref-target value. | CDATA |  | no
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.3 lomContext
Next topic: 3.3.4.5 lomDifficulty


lomDifficulty

3.3.4.5 lomDifficulty

The <lomDifficulty> provides learning metadata about how hard it is to work through the resource for the typical target audience.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomDifficulty

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lomDifficulty |
datatype | The datatype for this data. | CDATA |  | no
value | The difficulty for this content. See this topic for more information on the -dita-use-conref-target value. | (very easy | easy | medium | difficult | very difficult | -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.4 lomCoverage
Next topic: 3.3.4.6 lomInstallationRemarks


lomInstallationRemarks

3.3.4.6 lomInstallationRemarks

The <lomInstallationRemarks> provides learning metadata about how to install and needed resources.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomInstallationRemarks

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Name of the metadata being specified. | CDATA | lomInstallationRemarks |
datatype | Datatype of the metadata being specified. | CDATA |  | no
value | The installation remarks. | CDATA |  | no
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.5 lomDifficulty
Next topic: 3.3.4.7 lomIntendedUserRole


lomIntendedUserRole

3.3.4.7 lomIntendedUserRole

The <lomIntendedUserRole> provides learning metadata about the normal user of the resource, most dominant first.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomIntendedUserRole

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | Name of the metadata being specified. | CDATA | lomAggregationLevel |
datatype | Datatype of the metadata being specified. | CDATA |  | no
value | The intended user role for this content. See this topic for more information on the -dita-use-conref-target value. | (Teacher | Author | Learner | Manager | -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.6 lomInstallationRemarks
Next topic: 3.3.4.8 lomInteractivityLevel


lomInteractivityLevel

3.3.4.8 lomInteractivityLevel

The <lomInteractivityLevel> provides learning metadata about the level of interactivity between an end user and the learning object.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomInteractivityLevel

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lomInteractivityLevel |
datatype | The datatype for this data. | CDATA |  | no
value | The interactivity level for this content. See this topic for more information on the -dita-use-conref-target value. | (very low | low | medium | high | very high | -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.7 lomIntendedUserRole
Next topic: 3.3.4.9 lomInteractivityType


lomInteractivityType

3.3.4.9 lomInteractivityType

The <lomInteractivityType> provides learning metadata about the the type of interactivity supported by the resource.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learningmeta-d/lomInteractivityType

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required
name | The name used to indicate this data. | CDATA | lomInteractivityType |
datatype | The datatype for this data. | CDATA |  | no
value | The interactivity type for this content. See this topic for more information on the -dita-use-conref-target value. | (Active |Expositive |Mixed |Undefined | -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.8 lomInteractivityLevel
Next topic: 3.3.4.10 lomLearningResourceType


lomLearningResourceType

3.3.4.10 lomLearningResourceType

The <lomLearningResourceType> provides learning metadata about the specific kind of resource used, most dominant kind first.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomLearningResourceType

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lomLearningResourceType |
datatype | The datatype for this data. | CDATA |  | no
value | The interactivity type for this content. See this topic for more information on the -dita-use-conref-target value. | (Exercise | Simulation | Questionnaire | Diagram | Figure | Graph | Index | Slide | Table | Narrative Text | Exam | Experiment | ProblemStatement | SelfAssesment -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.9 lomInteractivityType
Next topic: 3.3.4.11 lomOtherPlatformRequirements


lomOtherPlatformRequirements

3.3.4.11 lomOtherPlatformRequirements

The <lomOtherPlatformRequirements> provides learning metadata information about other software and hardware requirements.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomOtherPlatformRequirements

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lomOtherPlatformRequirements |
datatype | The datatype for this data. | CDATA |  | no
value | The other platform requirements for this content. | CDATA |  | no
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.10 lomLearningResourceType
Next topic: 3.3.4.12 lomSemanticDensity


lomSemanticDensity

3.3.4.12 lomSemanticDensity

The <lomSemanticDensity> provides learning metadata about a subjective measure of the learning object's usefulness as compared to its size or duration.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomSemanticDensity

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lomSemanticDensity |
datatype | The datatype for this data. | CDATA |  | no
value | The semantic density for this content. See this topic for more information on the -dita-use-conref-target value. | (very low | low | medium | high | very high | -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.11 lomOtherPlatformRequirements
Next topic: 3.3.4.13 lomStructure


lomStructure

3.3.4.13 lomStructure

The <lomStructure> provides learning metadata about the underlying organizational structure of the resource.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomStructure

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lomStructure |
datatype | The datatype for this data. | CDATA |  | no
value | The learning structure for this content. See this topic for more information on the -dita-use-conref-target value. | (Collection| Mixed| Linear| Hierarchical| Networked| Branched| Parceled| Atomic| -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.12 lomSemanticDensity
Next topic: 3.3.4.14 lomTechRequirement


lomTechRequirement

3.3.4.14 lomTechRequirement

The <lomTechRequirement> provides learning metadata about the operating system(s) under which the learning resource can run.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomTechRequirement

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | (Operating System | Browser) |
datatype | The datatype for this data. | CDATA |  | no
value | The lomTechRequirements for this content. See this topic for more information on the -dita-use-conref-target value. | (pc-dos | ms-windows | macos | unix | multi-os | none | any | netscapecommunicator | ms-internetexplorer | opera | amaya | -dita-use-conref-target) |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.13 lomStructure
Next topic: 3.3.4.15 lomTypicalAgeRange


lomTypicalAgeRange

3.3.4.15 lomTypicalAgeRange

The <lomTypicalAgeRange> provides learning metadata about the age of the typical intended user.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomTypicalAgeRange

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lomTypicalAgeRange |
datatype | The datatype for this data. | CDATA |  | no
value | The age range intended for this content. | CDATA |  | yes
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.14 lomTechRequirement
Next topic: 3.3.4.16 lomTypicalLearningTime


lomTypicalLearningTime

3.3.4.16 lomTypicalLearningTime

The <lomTypicalLearningTime> provides learning metadata about the approximate or typical time it takes to work with the resource.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | ( text data ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningBookmap, learningContent, learningMap, learningOverview, learningPlan, learningSummary | lcLom

Inheritance

+ topic/data learning-d/lomTypicalLearningTime

Example

See lcLom.

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lomTypicalLearningTime |
datatype | The datatype for this data. | CDATA |  | no
value | The typical learning time for this content. | CDATA |  | no
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.4 Learning and training metadata elements
Previous topic: 3.3.4.15 lomTypicalAgeRange
Next topic: 3.3.5 Other learning and training elements


Other learning and training elements

3.3.5 Other learning and training elements

This group includes those elements that are specifically related to learning, but do not fit in to one of the other major learning groups.

  • 3.3.5.1 Common learning interactions elements
    Elements in this group are designed specifically to describe learning and training interactions.
  • 3.3.5.2 Common learning content elements
    The learning and training content elements provide specialized content for learning topics.
Parent topic: 3.3 Learning and training elements
Previous topic: 3.3.4.16 lomTypicalLearningTime
Next topic: 3.3.5.1 Common learning interactions elements


Common learning interactions elements

3.3.5.1 Common learning interactions elements

Elements in this group are designed specifically to describe learning and training interactions.

  • 3.3.5.1.1 lcAnswerContent
    The <lcAnswerContent> element in a learning assessment interaction provides the content for an answer option, which the learner can select as correct or incorrect.
  • 3.3.5.1.2 lcAnswerOption
    The <lcAnswerOption> element in an assessment interaction provides the content and feedback for a question option, and can indicate the correct option.
  • 3.3.5.1.3 lcAnswerOptionGroup
    The <lcAnswerOptionGroup> element provides a container for the options for a true-false, single-select, or multiple-select assessment interaction.
  • 3.3.5.1.4 lcArea
    A lcArea defines an area of a hotspot image that contains a correct or incorrect choice in a hotspot assessment interaction.
  • 3.3.5.1.5 lcAreaCoords
    The <lcAreaCoords> element specifies the coordinates of a linkable hotspot in a learning image.
  • 3.3.5.1.6 lcAreaShape
    The <lcAreaShape> element defines the shape of a linkable hotspot in a learning image.
  • 3.3.5.1.7 lcAsset
    The <lcAsset> element in an assessment interaction provides the images or other graphic assets to support the interaction.
  • 3.3.5.1.8 lcCorrectResponse
    The <lcCorrectResponse> element in an assessment interaction indicates a correct response.
  • 3.3.5.1.9 lcFeedback
    The <lcFeedback> element in an assessment interaction provides information to the learner about a correct or incorrect response.
  • 3.3.5.1.10 lcFeedbackCorrect
    The <lcFeedbackCorrect> element in an assessment interaction provides feedback to the learner about a correct response.
  • 3.3.5.1.11 lcFeedbackIncorrect
    The <lcFeedbackIncorrect> element in an assessment interaction provides feedback about incorrect response.
  • 3.3.5.1.12 lcHotspotMap
    A lcHotspotMap interaction lets you designate an action area or region over an image, allowing a click in that region to get scored as correct or incorrect in response to an interaction question.
  • 3.3.5.1.13 lcItem
    The <lcItem> element in an assessment interaction provides the content for an item that matches the match item in a match table.
  • 3.3.5.1.14 lcMatchingHeader
    The <lcMatchingHeader> element in an assessment interaction provides column headings for items to present in a matching table.
  • 3.3.5.1.15 lcMatchingItem
    The <lcMatchingItem> element in an assessment interaction provides the content for the matching side of a matching pair of items in a match table interaction.
  • 3.3.5.1.16 lcMatchingItemFeedback
    The <lcMatchingItemFeedback> element in an assessment interaction provides feedback on the match as a whole or on correct and incorrect matches or both.
  • 3.3.5.1.17 lcMatchingPair
    The <lcMatchingPair> element in an assessment interaction provides a table row with the pair of items that comprise a correct match in a matching interaction and, optionally, feedback on the pair or correct and incorrect matches.
  • 3.3.5.1.18 lcMatchTable
    The <lcMatchTable> element in an assessment interaction provides a format for matching items.
  • 3.3.5.1.19 lcOpenAnswer
    Use <lcOpenAnswer> to provide a suggested answer for an >lcOpenQuestion< interaction.
  • 3.3.5.1.20 lcQuestion
    Use the <lcQuestion> element in an interaction to ask the question.
  • 3.3.5.1.21 lcSequence
    The <lcSequence> element in an assessment interaction provides the position of a sequence option in a sequence.
  • 3.3.5.1.22 lcSequenceOption
    The <lcSequenceOption> element in an assessment interaction provides the contents of an item in a sequence interaction.
  • 3.3.5.1.23 lcSequenceOptionGroup
    The <lcSequenceOptionGroup> element provides the options for an assessment sequence interaction.
Parent topic: 3.3.5 Other learning and training elements
Previous topic: 3.3.5 Other learning and training elements
Next topic: 3.3.5.1.1 lcAnswerContent


lcAnswerContent

3.3.5.1.1 lcAnswerContent

The <lcAnswerContent> element in a learning assessment interaction provides the content for an answer option, which the learner can select as correct or incorrect.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcSequenceOption, lcAnswerOption

Inheritance

+ topic/p learningInteractionBase-d/p learning-d/lcAnswerContent

Example

...
   <lcAnswerContent>True</lcAnswerContent>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1 Common learning interactions elements
Next topic: 3.3.5.1.2 lcAnswerOption


lcAnswerOption

3.3.5.1.2 lcAnswerOption

The <lcAnswerOption> element in an assessment interaction provides the content and feedback for a question option, and can indicate the correct option.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcAnswerContent) then (lcCorrectResponse) (optional) then (lcFeedback) (optional) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcAnswerOptionGroup

Inheritance

+ topic/li learningInteractionBase-d/li learning-d/lcAnswerOption

Example

...
<lcAnswerOption>
  <lcAnswerContent>True</lcAnswerContent>
    <lcCorrectResponse/>
</lcAnswerOption>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.1 lcAnswerContent
Next topic: 3.3.5.1.3 lcAnswerOptionGroup


lcAnswerOptionGroup

3.3.5.1.3 lcAnswerOptionGroup

The <lcAnswerOptionGroup> element provides a container for the options for a true-false, single-select, or multiple-select assessment interaction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcAnswerOption) (one or more) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcTrueFalse, lcSingleSelect, lcMultipleSelect

Inheritance

+ topic/ul learningInteractionBase-d/ul learning-d/lcAnswerOptionGroup

Example

...
<lcAnswerOptionGroup>
  <lcAnswerOption>
    <lcAnswerContent>True</lcAnswerContent>
    <lcCorrectResponse/>
  </lcAnswerOption>
  <lcAnswerOption>
    <lcAnswerContent>False</lcAnswerContent>
  </lcAnswerOption>
</lcAnswerOptionGroup>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.2 lcAnswerOption
Next topic: 3.3.5.1.4 lcArea


lcArea

3.3.5.1.4 lcArea

A lcArea defines an area of a hotspot image that contains a correct or incorrect choice in a hotspot assessment interaction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcAreaShape) then (lcAreaCoords) then (xref) (optional) then (lcCorrectResponse) (optional) then (lcFeedback) (optional) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcHotspotMap

Inheritance

+ topic/figgroup learningInteractionBase-d/figgroup learning-d/lcArea

Example

...
  <lcArea id="cardinals">
    <lcAreaShape>rect</lcAreaShape>
    <lcAreaCoords>0,50,50,100</lcAreaCoords>
    <lcFeedback>No.</lcFeedback>
  </lcArea>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.3 lcAnswerOptionGroup
Next topic: 3.3.5.1.5 lcAreaCoords


lcAreaCoords

3.3.5.1.5 lcAreaCoords

The <lcAreaCoords> element specifies the coordinates of a linkable hotspot in a learning image.

This element contains text data representing coordinate data for learning images with linkable hotspots. Pixels are the recommended units for describing coordinates. The syntax of the coordinate data depends on the shape described by the coordinates, and is based on the image map definition in HTML. It uses the following data for the appropriate shapes:
Shape
Data format
rect
left-x, top-y, right-x, bottom-y
circle
center-x, center-y, radius
poly
x1, y1, x2, y2, ..., xN, yN. The first x and y coordinate pair and the last should be the same to close the polygon.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or data or data-about or foreign or unknown or keyword or term) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcArea

Inheritance

+ topic/ph learningInteractionBase-d/ph learning-d/lcAreaCoords

Example

<lcHotspotMap>
   <image href="hotlogos.gif">
     <alt>Baseball team logos</alt>
   </image>
   <lcArea id="giants">
     <lcAreaShape>rect</lcAreaShape>
     <lcAreaCoords>0,50,50,100</lcAreaCoords>
     <lcFeedback>No.</lcFeedback>
   </lcArea>
   <lcArea id="orioles">
     <lcAreaShape>rect</lcAreaShape>
     <lcAreaCoords>50,50,100,100</lcAreaCoords>
     <lcFeedback>No.</lcFeedback>
   </lcArea>
</lcHotspotMap>

Attributes

Name | Description | Data Type | Default Value | Required?
translate | Indicates whether the content of the element should be translated or not. Setting to "yes" will override the default. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value; because this element uses an actual default, it will always be treated as translate="no" unless overridden as described. | yes | no | -dita-use-​conref-​target | "no" | No
xml:lang | Specifies the language of the element content. The xml:lang attribute and its values are described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. | language token or the null string | #IMPLIED | No
dir | Specifies the directionality of text: left-to-right (ltr, the processing default) or right-to-left (rtl). The value lro indicates an override of normal bidi text presentation, forcing the element into left-to-right mode; rlo overrides normal rules to force right-to-left presentation. See The dir attribute for more information on the dir attribute. | (ltr | rtl | lro | rlo | -dita-use-​conref-​target) | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.4 lcArea
Next topic: 3.3.5.1.6 lcAreaShape


lcAreaShape

3.3.5.1.6 lcAreaShape

The <lcAreaShape> element defines the shape of a linkable hotspot in a learning image.

The <lcAreaShape> element supports these values:
rect
Define a rectangular region. If you leave the shape element blank, this is assumed.
circle
Define a circular region.
poly
Define a polygonal region.
default
Indicates the entire diagram.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or text) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcArea

Inheritance

+ topic/keyword learningInteractionBase-d/keyword learning-d/lcAreaShape

Example

<lcHotspotMap>
   <image href="hotlogos.gif">
     <alt>Baseball team logos</alt>
   </image>
   <lcArea id="giants">
     <lcAreaShape>rect</lcAreaShape>
     <lcAreaCoords>0,50,50,100</lcAreaCoords>
     <lcFeedback>No.</lcFeedback>
   </lcArea>
   <lcArea id="orioles">
     <lcAreaShape>rect</lcAreaShape>
     <lcAreaCoords>50,50,100,100</lcAreaCoords>
     <lcFeedback>No.</lcFeedback>
   </lcArea>
</lcHotspotMap>

Attributes

Name | Description | Data Type | Default Value | Required?
translate | Indicates whether the content of the element should be translated or not. Setting to "yes" will override the default. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value; because this element uses an actual default, it will always be treated as translate="no" unless overridden as described. | yes | no | -dita-use-​conref-​target | "no" | No
xml:lang | Specifies the language of the element content. The xml:lang attribute and its values are described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. | language token or the null string | #IMPLIED | No
dir | Specifies the directionality of text: left-to-right (ltr, the processing default) or right-to-left (rtl). The value lro indicates an override of normal bidi text presentation, forcing the element into left-to-right mode; rlo overrides normal rules to force right-to-left presentation. See The dir attribute for more information on the dir attribute. | (ltr | rtl | lro | rlo | -dita-use-​conref-​target) | #IMPLIED | No
id-atts attribute group (id, conref, conrefend, conaction, conkeyref) | A set of related attributes, described in id-atts attribute group |  |  |
select-atts attribute group (props, base, platform, product, audience, otherprops, importance, rev, status) | A set of related attributes, described in select-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass, keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. Class and outputclass are described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.5 lcAreaCoords
Next topic: 3.3.5.1.7 lcAsset


lcAsset

3.3.5.1.7 lcAsset

The <lcAsset> element in an assessment interaction provides the images or other graphic assets to support the interaction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (imagemap or image or object) (any number) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcOpenQuestion

Inheritance

+ topic/p learningInteractionBase-d/p learning-d/lcAsset

Example

. . .
<lcAsset>
  <image href="sunrise.gif">
    <alt>the sun rising on Earth</alt>
  </image>
</lcAsset>
. . .

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.6 lcAreaShape
Next topic: 3.3.5.1.8 lcCorrectResponse


lcCorrectResponse

3.3.5.1.8 lcCorrectResponse

The <lcCorrectResponse> element in an assessment interaction indicates a correct response.

In an lcHotspot interaction, indicate the correct hotspot by setting the value attribute of lcCorrectResponse to the id of the "correct" area in the imagemap.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcAnswerOption, lcArea

Inheritance

+ topic/data learningInteractionBase-d/data learning-d/lcCorrectResponse

Example

..
    <lcAnswerOption>
    <lcAnswerContent>True</lcAnswerContent>
      <lcCorrectResponse/>
    </lcAnswerOption>
...

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lcCorrectResponse | Required
value | The value. | PCDATA | In an lcHotspot interaction, set the value to the id corresponding to the correct area in the imagemap. | Required
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.7 lcAsset
Next topic: 3.3.5.1.9 lcFeedback


lcFeedback

3.3.5.1.9 lcFeedback

The <lcFeedback> element in an assessment interaction provides information to the learner about a correct or incorrect response.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcAnswerOption, lcMatchingItemFeedback, lcArea

Inheritance

+ topic/p learningInteractionBase-d/p learning-d/lcFeedback

Example

. . .
      <lcFeedback>Yes, look to the East.</lcFeedback>
. . .

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.8 lcCorrectResponse
Next topic: 3.3.5.1.10 lcFeedbackCorrect


lcFeedbackCorrect

3.3.5.1.10 lcFeedbackCorrect

The <lcFeedbackCorrect> element in an assessment interaction provides feedback to the learner about a correct response.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion, lcMatchingItemFeedback

Inheritance

+ topic/p learningInteractionBase-d/p learning-d/lcFeedbackCorrect

Example

. . .
    <lcFeedbackIncorrect>No, look to the East.</lcFeedbackIncorrect>
    <lcFeedbackCorrect>Yes, look to the East.</lcFeedbackCorrect>
. . .

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.9 lcFeedback
Next topic: 3.3.5.1.11 lcFeedbackIncorrect


lcFeedbackIncorrect

3.3.5.1.11 lcFeedbackIncorrect

The <lcFeedbackIncorrect> element in an assessment interaction provides feedback about incorrect response.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion, lcMatchingItemFeedback

Inheritance

+ topic/p learningInteractionBase-d/p learning-d/lcFeedbackIncorrect

Example

. . .
    <lcFeedbackIncorrect>No, look to the East.</lcFeedbackIncorrect>
    <lcFeedbackCorrect>Yes, look to the East.</lcFeedbackCorrect>
. . .

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.10 lcFeedbackCorrect
Next topic: 3.3.5.1.12 lcHotspotMap


lcHotspotMap

3.3.5.1.12 lcHotspotMap

A lcHotspotMap interaction lets you designate an action area or region over an image, allowing a click in that region to get scored as correct or incorrect in response to an interaction question.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (image) then (lcArea) (one or more) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcHotspot

Inheritance

+ topic/fig learningInteractionBase-d/figgroup learning-d/lcHotspotMap

Example

   <!--Hotspot Interaction    -->
   <lcHotspot id="hotspots">
    <title>Team logos hotspot</title>
    <lcQuestion>Which of the following is the logo for the Cleveland Indians?</lcQuestion>
    <lcHotspotMap>
     <image href="hotlogos.gif"/>
     <lcArea id="indians">
      <lcAreaShape>rect</lcAreaShape>
      <lcAreaCoords>0,0,50,50</lcAreaCoords>
      <lcCorrectResponse value="indians"/>
      <lcFeedback>Yes.</lcFeedback>
     </lcArea>
     <lcArea id="giants">
      <lcAreaShape>rect</lcAreaShape>
      <lcAreaCoords>50,0,100,50</lcAreaCoords>
      <lcFeedback>No.</lcFeedback>
     </lcArea>
     <lcArea id="cardinals">
      <lcAreaShape>rect</lcAreaShape>
      <lcAreaCoords>0,50,50,100</lcAreaCoords>
      <lcFeedback>No.</lcFeedback>
     </lcArea>
     <lcArea id="orioles">
      <lcAreaShape>rect</lcAreaShape>
      <lcAreaCoords>50,50,100,100</lcAreaCoords>
      <lcFeedback>No.</lcFeedback>
     </lcArea>
    </lcHotspotMap>
   </lcHotspot>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.11 lcFeedbackIncorrect
Next topic: 3.3.5.1.13 lcItem


lcItem

3.3.5.1.13 lcItem

The <lcItem> element in an assessment interaction provides the content for an item that matches the match item in a match table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcMatchingHeader, lcMatchingPair

Inheritance

+ topic/stentry learningInteractionBase-d/stentry learning-d/lcItem

Example

      <lcMatching id="matching">
        <title>Matching teams with cities</title>
        <lcQuestion>Match the team with the city.</lcQuestion>
        <lcMatchTable>
          <lcMatchingHeader>
            <lcItem>Team</lcItem>
            <lcMatchingItem>City</lcMatchingItem>
          </lcMatchingHeader>
          <lcMatchingPair>
            <lcItem>Boston</lcItem>
            <lcMatchingItem>Red Sox</lcMatchingItem>
          </lcMatchingPair>
          <lcMatchingPair>
            <lcItem>San Francisco</lcItem>
            <lcMatchingItem>Giants</lcMatchingItem>
          </lcMatchingPair>
          <lcMatchingPair>
            <lcItem>Chicago</lcItem>
            <lcMatchingItem>Cubs</lcMatchingItem>
          </lcMatchingPair>
          <lcMatchingPair>
            <lcItem>Toronto</lcItem>
            <lcMatchingItem>Blue Jays</lcMatchingItem>
          </lcMatchingPair>
        </lcMatchTable>
        <lcFeedbackCorrect>Good job.</lcFeedbackCorrect>
        <lcFeedbackIncorrect>Not quite.</lcFeedbackIncorrect>
      </lcMatching>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.12 lcHotspotMap
Next topic: 3.3.5.1.14 lcMatchingHeader


lcMatchingHeader

3.3.5.1.14 lcMatchingHeader

The <lcMatchingHeader> element in an assessment interaction provides column headings for items to present in a matching table.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcItem) then (lcMatchingItem) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcMatchTable

Inheritance

+ topic/sthead learningInteractionBase-d/sthead learning-d/lcMatchingHeader

Example

...
     <lcMatchingHeader>
      <lcItem>Team</lcItem>
      <lcMatchingItem>City</lcMatchingItem>
     </lcMatchingHeader>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.13 lcItem
Next topic: 3.3.5.1.15 lcMatchingItem


lcMatchingItem

3.3.5.1.15 lcMatchingItem

The <lcMatchingItem> element in an assessment interaction provides the content for the matching side of a matching pair of items in a match table interaction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcMatchingHeader, lcMatchingPair

Inheritance

+ topic/stentry learningInteractionBase-d/stentry learning-d/lcMatchingItem

Example

...
     <lcMatchingPair>
      <lcItem>Boston</lcItem>
      <lcMatchingItem>Red Sox</lcMatchingItem>
     </lcMatchingPair>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.14 lcMatchingHeader
Next topic: 3.3.5.1.16 lcMatchingItemFeedback


lcMatchingItemFeedback

3.3.5.1.16 lcMatchingItemFeedback

The <lcMatchingItemFeedback> element in an assessment interaction provides feedback on the match as a whole or on correct and incorrect matches or both.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcFeedback) or (lcFeedbackCorrect) or (lcFeedbackIncorrect) ) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcMatchingPair

Inheritance

+ topic/stentry learningInteractionBase-d/stentry learning-d/lcMatchingItemFeedback

Example

...
    <lcMatchingPair>
      <lcItem>Toronto</lcItem>
      <lcMatchingItem>Blue Jays</lcMatchingItem>
      <lcMatchingItemFeedback>
        <lcFeedbackCorrect>The Blue Jays play in Toronto's SkyDome</lcFeedbackCorrect>
        <lcFeedbackIncorrect>That is not Toronto's home team.</lcFeedbackIncorrect>
      </lcMatchingItemFeedback>
    </lcMatchingPair>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.15 lcMatchingItem
Next topic: 3.3.5.1.17 lcMatchingPair


lcMatchingPair

3.3.5.1.17 lcMatchingPair

The <lcMatchingPair> element in an assessment interaction provides a table row with the pair of items that comprise a correct match in a matching interaction and, optionally, feedback on the pair or correct and incorrect matches.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcItem) then (lcMatchingItem) then (lcMatchingItemFeedback) (optional) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcMatchTable

Inheritance

+ topic/strow learningInteractionBase-d/strow learning-d/lcMatchingPair

Example

...
     <lcMatchingPair>
      <lcItem>Boston</lcItem>
      <lcMatchingItem>Red Sox</lcMatchingItem>
      <lcMatchingItemFeedback>
        <lcFeedbackCorrect>The Red Sox play in Boston's Fenway Park</lcFeedbackCorrect>
        <lcFeedbackCorrect>That is not Boston's home team</lcFeedbackCorrect>
      </lcMatchingItemFeedback>
     </lcMatchingPair>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.16 lcMatchingItemFeedback
Next topic: 3.3.5.1.18 lcMatchTable


lcMatchTable

3.3.5.1.18 lcMatchTable

The <lcMatchTable> element in an assessment interaction provides a format for matching items.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcMatchingHeader) (optional) then (lcMatchingPair) (one or more) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcMatching

Inheritance

+ topic/simpletable learningInteractionBase-d/simpletable learning-d/lcMatchTable

Example

      <lcMatching id="matching">
        <title>Matching teams with cities</title>
        <lcQuestion>Match the team with the city.</lcQuestion>
        <lcMatchTable>
          <lcMatchingHeader>
            <lcItem>Team</lcItem>
            <lcMatchingItem>City</lcMatchingItem>
          </lcMatchingHeader>
          <lcMatchingPair>
            <lcItem>Boston</lcItem>
            <lcMatchingItem>Red Sox</lcMatchingItem>
          </lcMatchingPair>
          <lcMatchingPair>
            <lcItem>San Francisco</lcItem>
            <lcMatchingItem>Giants</lcMatchingItem>
          </lcMatchingPair>
          <lcMatchingPair>
            <lcItem>Chicago</lcItem>
            <lcMatchingItem>Cubs</lcMatchingItem>
          </lcMatchingPair>
          <lcMatchingPair>
            <lcItem>Toronto</lcItem>
            <lcMatchingItem>Blue Jays</lcMatchingItem>
          </lcMatchingPair>
        </lcMatchTable>
        <lcFeedbackCorrect>Good job.</lcFeedbackCorrect>
        <lcFeedbackIncorrect>Not quite.</lcFeedbackIncorrect>
      </lcMatching>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.17 lcMatchingPair
Next topic: 3.3.5.1.19 lcOpenAnswer


lcOpenAnswer

3.3.5.1.19 lcOpenAnswer

Use <lcOpenAnswer> to provide a suggested answer for an >lcOpenQuestion< interaction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcOpenQuestion

Inheritance

+ topic/p learningInteractionBase-d/p learning-d/lcOpenAnswer

Example

   <!--Open Question sample                    -->
   <lclOpenQuestion id="oq1">
    <title>Cows and moon jumps</title>
    <lcQuestion>Describe how it might be possible for a cow to jump over the moon.</lcQuestion>
    <lcOpenAnswer>Cow's can only jump over the moon in nursery rhymes.<lcOpenAnswer>
   </lcOpenQuestion>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.18 lcMatchTable
Next topic: 3.3.5.1.20 lcQuestion


lcQuestion

3.3.5.1.20 lcQuestion

Use the <lcQuestion> element in an interaction to ask the question.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcTrueFalse, lcSingleSelect, lcMultipleSelect, lcSequencing, lcMatching, lcHotspot, lcOpenQuestion

Inheritance

+ topic/p learningInteractionBase-d/lcQuestionBase learning-d/lcQuestion

Example

    <lcQuestion>Which one of the following is a logo of a Major League Baseball
team? (You may choose more than one.)</lcQuestion>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.19 lcOpenAnswer
Next topic: 3.3.5.1.21 lcSequence


lcSequence

3.3.5.1.21 lcSequence

The <lcSequence> element in an assessment interaction provides the position of a sequence option in a sequence.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | no content

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcSequenceOption

Inheritance

+ topic/data learningInteractionBase-d/data learning-d/lcSequence

Example

      <lcSequencing id="sequencing">
        <title>Sequencing City Populations in the U.S.</title>
        <lcQuestion>Order the following U.S. cities according to population, from
          largest to smallest.</lcQuestion>
        <lcSequenceOptionGroup>
          <lcSequenceOption>
            <lcAnswerContent>Portland, Oregon</lcAnswerContent>
            <lcSequence name="lcSequence" value="2"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Chicago, Illinois</lcAnswerContent>
            <lcSequence name="lcSequence" value="1"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Portland, Maine</lcAnswerContent>
            <lcSequence name="lcSequence" value="4"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Syracuse, New York</lcAnswerContent>
            <lcSequence name="lcSequence" value="3"/>
          </lcSequenceOption>
        </lcSequenceOptionGroup>
        <lcFeedbackIncorrect>No, try again, please.     </lcFeedbackIncorrect>
        <lcFeedbackCorrect>Very good.</lcFeedbackCorrect>
      </lcSequencing>

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lcSequence | Required
datatype | The datatype for this data. | CDATA | Use numbers for sequence. | Required
value | The position of an option in a sequence of options. | PCDATA | Use a number. | Required
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.20 lcQuestion
Next topic: 3.3.5.1.22 lcSequenceOption


lcSequenceOption

3.3.5.1.22 lcSequenceOption

The <lcSequenceOption> element in an assessment interaction provides the contents of an item in a sequence interaction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcAnswerContent) then (lcSequence) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcSequenceOptionGroup

Inheritance

+ topic/li learningInteractionBase-d/li learning-d/lcSequenceOption

Example

      <lcSequencing id="sequencing">
        <title>Sequencing City Populations in the U.S.</title>
        <lcQuestion>Order the following U.S. cities according to population, from
          largest to smallest.</lcQuestion>
        <lcSequenceOptionGroup>
          <lcSequenceOption>
            <lcAnswerContent>Portland, Oregon</lcAnswerContent>
            <lcSequence name="lcSequence" value="2"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Chicago, Illinois</lcAnswerContent>
            <lcSequence name="lcSequence" value="1"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Portland, Maine</lcAnswerContent>
            <lcSequence name="lcSequence" value="4"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Syracuse, New York</lcAnswerContent>
            <lcSequence name="lcSequence" value="3"/>
          </lcSequenceOption>
        </lcSequenceOptionGroup>
        <lcFeedbackIncorrect>No, try again, please.     </lcFeedbackIncorrect>
        <lcFeedbackCorrect>Very good.</lcFeedbackCorrect>
      </lcSequencing>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.21 lcSequence
Next topic: 3.3.5.1.23 lcSequenceOptionGroup


lcSequenceOptionGroup

3.3.5.1.23 lcSequenceOptionGroup

The <lcSequenceOptionGroup> element provides the options for an assessment sequence interaction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcSequenceOption) (one or more) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcSequencing

Inheritance

+ topic/ol learningInteractionBase-d/ol learning-d/lcSequenceOptionGroup

Example

      <lcSequencing id="sequencing">
        <title>Sequencing City Populations in the U.S.</title>
        <lcQuestion>Order the following U.S. cities according to population, from
          largest to smallest.</lcQuestion>
        <lcSequenceOptionGroup>
          <lcSequenceOption>
            <lcAnswerContent>Portland, Oregon</lcAnswerContent>
            <lcSequence name="lcSequence" value="2"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Chicago, Illinois</lcAnswerContent>
            <lcSequence name="lcSequence" value="1"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Portland, Maine</lcAnswerContent>
            <lcSequence name="lcSequence" value="4"/>
          </lcSequenceOption>
          <lcSequenceOption>
            <lcAnswerContent>Syracuse, New York</lcAnswerContent>
            <lcSequence name="lcSequence" value="3"/>
          </lcSequenceOption>
        </lcSequenceOptionGroup>
        <lcFeedbackIncorrect>No, try again, please.     </lcFeedbackIncorrect>
        <lcFeedbackCorrect>Very good.</lcFeedbackCorrect>
      </lcSequencing>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.1 Common learning interactions elements
Previous topic: 3.3.5.1.22 lcSequenceOption
Next topic: 3.3.5.2 Common learning content elements


Common learning content elements

3.3.5.2 Common learning content elements

The learning and training content elements provide specialized content for learning topics.

  • 3.3.5.2.1 lcAge
    The <lcAge> provides the age range of the intended learner audience, for use by curriculum developers and course planners.
  • 3.3.5.2.2 lcAssessment
    The <lcAssessment> describes assessment plans.
  • 3.3.5.2.3 lcAttitude
    The <lcAttitude> describes mental state that influences the choices of personal actions.
  • 3.3.5.2.4 lcAudience
    The <lcAudience> describes characteristics of the learners who take the instruction.
  • 3.3.5.2.5 lcBackground
    The <lcBackground> provides the learners' professional background and the relevancy to the learning plan.
  • 3.3.5.2.6 lcChallenge
    The <lcChallenge> refers to what it is that you want the student to practice. For example, if you're studying network diagrams, and challenge might be "see if you can put this network into its proper sequence" or "see if you understand this network flow".
  • 3.3.5.2.7 lcCIN
    The <lcCIN> provides a course identification number or other alternate identifier for the project title.
  • 3.3.5.2.8 lcClassroom
    The <lcClassroom> describes the classroom environment.
  • 3.3.5.2.9 lcClient
    The <lcClient> provides the person or organization sponsoring or requiring the learning event development.
  • 3.3.5.2.10 lcConstraints
    The <lcConstraints> describes the organizational or technical aspects that may limit the organization's ability to effectively use the instruction to meet its goals.
  • 3.3.5.2.11 lcDelivDate
    The <lcDelivDate> provides the project delivery date.
  • 3.3.5.2.12 lcDelivery
    The <lcDelivery> describes the delivery method for this learning content.
  • 3.3.5.2.13 lcDownloadTime
    The <lcDownloadTime> describes the maximum time allowed for download time in the client's delivery environment.
  • 3.3.5.2.14 lcDuration
    The <lcDuration> provides an estimated duration for the learning activity.
  • 3.3.5.2.15 lcEdLevel
    The <lcEdLevel> provides the range of learners' education level and the relevancy to the learning plan.
  • 3.3.5.2.16 lcFileSizeLimitations
    The <lcFileSizeLimitations> describes any file size limitation in the download environment.
  • 3.3.5.2.17 lcGapAnalysis
    The <lcGapAnalysis> compares existing learning objectives to current job task analysis.
  • 3.3.5.2.18 lcGapItem
    The <lcGapItem> describes gaps between existing training objectives and related job-task-analysis content.
  • 3.3.5.2.19 lcGapItemDelta
    The <lcGapItemDelta> describes the gap between the learning objective and the task analysis.
  • 3.3.5.2.20 lcGeneralDescription
    The <lcGeneralDescription> provides a space to develop a general description about the organization's training needs.
  • 3.3.5.2.21 lcGoals
    The <lcGoals> provides the outcomes desired by the organization to be addressed by the training effort. These goals may require concurrent efforts outside of training such as technology acquisition, reorganization, and so forth.
  • 3.3.5.2.22 lcGraphics
    The <lcGraphics> describes standards and system requirements for displaying graphics and other related content types.
  • 3.3.5.2.23 lcHandouts
    The <lcHandouts> provides aspects of the course that are provided by the instructor in support of the course learning objectives.
  • 3.3.5.2.24 lcInstruction
    The <lcInstruction> describes the specifics of a learning activity.
  • 3.3.5.2.25 lcInteraction
    The <lcInteraction> is a wrapper element for all the interactions of the assessment. The interactions themselves are based on the lcInteractionBase type. A starter set of interaction types is defined in the learning domain.
  • 3.3.5.2.26 lcIntervention
    The <lcIntervention> describes the approach and strategies to building the learning materials, based on the needs analysis.
  • 3.3.5.2.27 lcInterventionItem
    The <lcInterventionItem> describes how learning content is built, based on a systems approach to analyzing, designing, developing, implementing, and evaluating any instructional experience.
  • 3.3.5.2.28 lcIntro
    The <lcIntro> provides a detailed introduction and description of the content to be delivered, in cases where the <shortdesc> is not adequate to fully describe the content. It may also include instructor notes.
  • 3.3.5.2.29 lcJtaItem
    The <lcJtaItem> provides description of job task analysis (JTA) as related to a particular learning objective.
  • 3.3.5.2.30 lcKnowledge
    <lcKnowledge> describes the learners' current knowledge and the relevancy to the broader plan audience or a specific task in the plan.
  • 3.3.5.2.31 lcLearnStrat
    The <lcLearnStrat> describes the manner in which the learning content will be instructed. This should be a high level design that applies instructional-design theories and models.
  • 3.3.5.2.32 lcLMS
    The <lcLMS> provides the LMS name and version number used in the learning event.
  • 3.3.5.2.33 lcModDate
    The <lcModDate> provides the project modification date.
  • 3.3.5.2.34 lcMotivation
    The <lcMotivation> provides the reasons why the learners want and/or need to take the instruction.
  • 3.3.5.2.35 lcNeeds
    The <lcNeeds> provides the needs behind the outcomes described by the <lcGoals>.
  • 3.3.5.2.36 lcNeedsAnalysis
    The <lcNeedsAnalysis> describes the training requirement and identifies the need to develop or revise content. These include periodic training gap analyses, changes to operational or maintenance requirements, and changes to equipment or systems.
  • 3.3.5.2.37 lcNextSteps
    The <lcNextSteps> suggests next steps to reinforce the knowledge learned.
  • 3.3.5.2.38 lcNoLMS
    Use <lcNoLMS> when you plan to deliver the content as a standalone package, without a learning management system (LMS).
  • 3.3.5.2.39 lcObjective
    The <lcObjective> describes a single learning objective.
  • 3.3.5.2.40 lcObjectives
    The <lcObjectives> lists or describes the learning goals.
  • 3.3.5.2.41 lcObjectivesGroup
    The <lcObjectivesGroup> contains a list of one or more learning objectives.
  • 3.3.5.2.42 lcObjectivesStem
    The <lcObjectivesStem> provides a leading sentence to introduce a list of learning objectives.
  • 3.3.5.2.43 lcOJT
    The <lcOJT> is "the on-the-job training" and describes aspects of the course taking place in the work environment.
  • 3.3.5.2.44 lcOrganizational
    The <lcOrganizational> describes an organization's learning requirements.
  • 3.3.5.2.45 lcOrgConstraints
    The <lcOrgConstraints> provides organizational aspects that may limit the organization's ability to effectively use the instruction to meet its goals.
  • 3.3.5.2.46 lcPlanAudience
    The <lcPlanAudience> describes characteristics of the learners who take the instruction.
  • 3.3.5.2.47 lcPlanDescrip
    The <lcPlanDescrip> provides a plan description.
  • 3.3.5.2.48 lcPlanObjective
    The <lcPlanObjective> describes the objective to be addressed by a gap analysis or intervention.
  • 3.3.5.2.49 lcPlanPrereqs
    <lcPlanPrereqs> provides the knowledge, skills, abilities, courses and other activities learners must have satisfied to take the instruction.
  • 3.3.5.2.50 lcPlanResources
    The <lcPlanResources> describes resource needs.
  • 3.3.5.2.51 lcPlanSubject
    The <lcPlanSubject> provides a complete description of the subject of the planned learning.
  • 3.3.5.2.52 lcPlanTitle
    The <lcPlanTitle> provides a title for a specific module, lesson, or section of the course that this plan describes.
  • 3.3.5.2.53 lcPlayers
    The <lcPlayers> describes tools and plugins used for time-sequenced display at runtime.
  • 3.3.5.2.54 lcPrereqs
    The <lcPrereqs> describes the knowledge, experience, or other prerequisites needed to complete the content.
  • 3.3.5.2.55 lcProcesses
    The <lcProcesses> describes processes learners routinely follow.
  • 3.3.5.2.56 lcProject
    The <lcProject> provides learning content project plan description information.
  • 3.3.5.2.57 lcResolution
    The <lcResolution> describes the required computer screen resolution for the online instruction.
  • 3.3.5.2.58 lcResources
    The <lcResources> provides a list of related resources and information about them, such as related articles or samples on the web.
  • 3.3.5.2.59 lcReview
    The <lcReview> provides a review of the main points.
  • 3.3.5.2.60 lcSecurity
    The <lcSecurity> describes the security requirements in the delivered instruction.
  • 3.3.5.2.61 lcSkills
    The <lcSkills> describes the learners' current skill set and the relevancy to the broader plan audience or a specific task in the plan.
  • 3.3.5.2.62 lcSpecChars
    The <lcSpecChars> provides learner characteristics specific to the population that will influence the design, including learning disabilities, physical handicaps, and so forth.
  • 3.3.5.2.63 lcSummary
    The <lcSummary> provides a textual summary that describes the main learning goals and lessons learned.
  • 3.3.5.2.64 lcTask
    The <lcTask> captures a work item to be performed, as part of the learning plan.
  • 3.3.5.2.65 lcTaskItem
    The <lcTaskItem> describes a discreet task to be taught.
  • 3.3.5.2.66 lcTechnical
    The <lcTechnical> describes the technical requirements to the learning content and how those requirements are supported by the instructional design.
  • 3.3.5.2.67 lcTime
    The <lcTime> specifies the time expected to complete an activity. You can specify the time both as text to display to the user and as an attribute value that follows a specific time format.
  • 3.3.5.2.68 lcValues
    The <lcValues> describes affective components of desired instructional outcomes.
  • 3.3.5.2.69 lcViewers
    The <lcViewers> describes viewers used for time-sequenced display at runtime.
  • 3.3.5.2.70 lcW3C
    The <lcW3C> provides requirements for use of world wide web consortium standards.
  • 3.3.5.2.71 lcWorkEnv
    The <lcWorkEnv> describes the working conditions and contexts in which the training will be applied.
  • 3.3.5.2.72 lcWorkEnvDescription
    The <lcWorkEnvDescription> provides the general working environment in which the training will be applied.
Parent topic: 3.3.5 Other learning and training elements
Previous topic: 3.3.5.1.23 lcSequenceOptionGroup
Next topic: 3.3.5.2.1 lcAge


lcAge

3.3.5.2.1 lcAge

The <lcAge> provides the age range of the intended learner audience, for use by curriculum developers and course planners.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcPlanAudience

Inheritance

- topic/p learningBase/p learningPlan/lcAge

Example

...
  <lcAge>Adults age 30 - 45.</lcAge>
...

See lcPlanAudience.

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2 Common learning content elements
Next topic: 3.3.5.2.2 lcAssessment


lcAssessment

3.3.5.2.2 lcAssessment

The <lcAssessment> describes assessment plans.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcInterventionItem

Inheritance

- topic/p learningBase/p learningPlan/lcAssessment

Example

...
  <lcAssessment>The module includes a pass/fail assessment exam.
  </lcAssessment>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.1 lcAge
Next topic: 3.3.5.2.3 lcAttitude


lcAttitude

3.3.5.2.3 lcAttitude

The <lcAttitude> describes mental state that influences the choices of personal actions.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcTask

Inheritance

- topic/p learningBase/p learningPlan/lcAttitude

Example

...
   <lcAttitude>Learners must be willing to be open and flexible.</lcAttitude>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.2 lcAssessment
Next topic: 3.3.5.2.4 lcAudience


lcAudience

3.3.5.2.4 lcAudience

The <lcAudience> describes characteristics of the learners who take the instruction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningPlan, learningSummary | learningBasebody
learningOverview | learningBasebody, learningOverviewbody

Inheritance

- topic/section learningBase/lcAudience

Example

...
<lcAudience>
  <title>Audience</title>
  Food connoisseurs and chefs
</lcAudience>
...

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.3 lcAttitude
Next topic: 3.3.5.2.5 lcBackground


lcBackground

3.3.5.2.5 lcBackground

The <lcBackground> provides the learners' professional background and the relevancy to the learning plan.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcPlanAudience

Inheritance

- topic/p learningBase/p learningPlan/lcBackground

Example

...
  <lcBackground>Experience with all phases of systems financial analysis and planning.</lcBackground>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.4 lcAudience
Next topic: 3.3.5.2.6 lcChallenge


lcChallenge

3.3.5.2.6 lcChallenge

The <lcChallenge> refers to what it is that you want the student to practice. For example, if you're studying network diagrams, and challenge might be "see if you can put this network into its proper sequence" or "see if you understand this network flow".

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningPlan, learningSummary | learningBasebody
learningContent | learningBasebody, learningContentbody

Inheritance

- topic/section learningBase/lcChallenge

Example

<learningContent id="overview">
  <title>Learning Content topic</title>
  <learningContentbody>
    <lcChallenge><title>Challenge</title>
    <p>Describe the challenge.</p>
   </lcChallenge>
  </learningContentbody>
</learningContent>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.5 lcBackground
Next topic: 3.3.5.2.7 lcCIN


lcCIN

3.3.5.2.7 lcCIN

The <lcCIN> provides a course identification number or other alternate identifier for the project title.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcProject

Inheritance

- topic/fig learningBase/fig learningPlan/lcCIN

Example

...
      <lcCIN>
        <title>CIN</title>
        <p>A life without CIN is an unexciting
            life, indeed.</p>
      </lcCIN>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.6 lcChallenge
Next topic: 3.3.5.2.8 lcClassroom


lcClassroom

3.3.5.2.8 lcClassroom

The <lcClassroom> describes the classroom environment.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcClassroom

Example

...
   <lcClassroom>
     <title>Classroom Setting</title>
     <p>Lecture hall with 500 seats and stage.</p>
   </lcClassroom>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.7 lcCIN
Next topic: 3.3.5.2.9 lcClient


lcClient

3.3.5.2.9 lcClient

The <lcClient> provides the person or organization sponsoring or requiring the learning event development.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcProject

Inheritance

- topic/fig learningBase/fig learningPlan/lcClient

Example

...
      <lcClient>
        <title>Client</title>
        <p>Los Angeles County K-5 elementary schools.</p>
      </lcClient>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.8 lcClassroom
Next topic: 3.3.5.2.10 lcConstraints


lcConstraints

3.3.5.2.10 lcConstraints

The <lcConstraints> describes the organizational or technical aspects that may limit the organization's ability to effectively use the instruction to meet its goals.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/section learningPlan/lcConstraints

Example

...
      <lcConstraints>
        <title>Constraints</title>
        <p>Imagination.</p>
      </lcConstraints>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.9 lcClient
Next topic: 3.3.5.2.11 lcDelivDate


lcDelivDate

3.3.5.2.11 lcDelivDate

The <lcDelivDate> provides the project delivery date.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcProject

Inheritance

- topic/fig learningBase/fig learningPlan/lcDelivDate

Example

...
  <lcDelivDate>20070630</lcDelivDate>
....

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.10 lcConstraints
Next topic: 3.3.5.2.12 lcDelivery


lcDelivery

3.3.5.2.12 lcDelivery

The <lcDelivery> describes the delivery method for this learning content.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcInterventionItem

Inheritance

- topic/p learningBase/p learningPlan/lcDelivery

Example

...
  <lcDelivery>Delivery shall be fast and
    to the point.</lcDelivery>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.11 lcDelivDate
Next topic: 3.3.5.2.13 lcDownloadTime


lcDownloadTime

3.3.5.2.13 lcDownloadTime

The <lcDownloadTime> describes the maximum time allowed for download time in the client's delivery environment.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcDownloadTime

Example

...
      <lcDownloadTime>
        <title>DownloadTime</title>
        <p>On-board download in no more
         than 15 seconds at all times.</p>
      </lcDownloadTime>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.12 lcDelivery
Next topic: 3.3.5.2.14 lcDuration


lcDuration

3.3.5.2.14 lcDuration

The <lcDuration> provides an estimated duration for the learning activity.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcTime) (optional) )

Contained by

Doctype | Content model
learningAssessment | learningBasebody, learningAssessmentbody
learningContent | learningBasebody, learningAssessmentbody, learningContentbody
learningOverview | learningBasebody, learningOverviewbody
learningPlan, learningSummary | learningBasebody

Inheritance

- topic/section learningBase/lcDuration

Example

...
    <lcDuration><title>Duration</title>
      <lcTime name="lcTime" value="00:15"/>
   </lcDuration>
...

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.13 lcDownloadTime
Next topic: 3.3.5.2.15 lcEdLevel


lcEdLevel

3.3.5.2.15 lcEdLevel

The <lcEdLevel> provides the range of learners' education level and the relevancy to the learning plan.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcPlanAudience

Inheritance

- topic/p learningBase/p learningPlan/lcEdLevel

Example

...
        <lcEdLevel>HS or equivalent education level
          is assumed.</lcEdLevel>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.14 lcDuration
Next topic: 3.3.5.2.16 lcFileSizeLimitations


lcFileSizeLimitations

3.3.5.2.16 lcFileSizeLimitations

The <lcFileSizeLimitations> describes any file size limitation in the download environment.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcFileSizeLimitations

Example

...
      <lcFileSizeLimitations>
        <title>File Size Limitations</title>
        <p>Assume very large and complex files
          at all times.</p>
      </lcFileSizeLimitations>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.15 lcEdLevel
Next topic: 3.3.5.2.17 lcGapAnalysis


lcGapAnalysis

3.3.5.2.17 lcGapAnalysis

The <lcGapAnalysis> compares existing learning objectives to current job task analysis.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcGapItem) (any number) )

Contained by

Doctype | Content model
learningPlan | learningPlanbody

Inheritance

- topic/section learningBase/section learningPlan/lcGapAnalysis

Example: lcGapAnalysis

...
    <lcGapAnalysis>
      <title>Gap Analysis</title>
      <lcGapItem>
        <title>Gap item</title>
        <lcPlanObjective>Learn the basics before you go further.</lcPlanObjective>
        <lcJtaItem>Current learning objectives provide guidance to developing small modules with terminal learning objectives.</lcJtaItem>
        <lcGapItemDelta>Current learners do not have the capability to approach learning
         development in a modular strategy that saves time and costs across
         the enterprise.</lcGapItemDelta>
      </lcGapItem>
    </lcGapAnalysis>
...

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.16 lcFileSizeLimitations
Next topic: 3.3.5.2.18 lcGapItem


lcGapItem

3.3.5.2.18 lcGapItem

The <lcGapItem> describes gaps between existing training objectives and related job-task-analysis content.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcPlanObjective) (optional) then (lcJtaItem) (optional) then (lcGapItemDelta) (optional) )

Contained by

Doctype | Content model
learningPlan | lcGapAnalysis

Inheritance

- topic/fig learningBase/fig learningPlan/lcGapItem

Example

...
      <lcGapItem>
        <title>Gap item</title>
        <lcPlanObjective>Learn the basics before you go further.</lcPlanObjective>
        <lcJtaItem>Current learning objectives provide guidance to developing small modules with terminal learning objectives.</lcJtaItem>
        <lcGapItemDelta>Current learners do not have the capability to approach learning
         development in a modular strategy that saves time and costs across
         the enterprise.</lcGapItemDelta>
      </lcGapItem>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.17 lcGapAnalysis
Next topic: 3.3.5.2.19 lcGapItemDelta


lcGapItemDelta

3.3.5.2.19 lcGapItemDelta

The <lcGapItemDelta> describes the gap between the learning objective and the task analysis.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcGapItem

Inheritance

- topic/p learningBase/p learningPlan/lcGapItemDelta

Example: lcGapAnalysis

...
  <lcGapItemDelta>Current learners do not have the capability to approach learning
   development in a modular strategy that saves time and costs across
   the enterprise.</lcGapItemDelta>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.18 lcGapItem
Next topic: 3.3.5.2.20 lcGeneralDescription


lcGeneralDescription

3.3.5.2.20 lcGeneralDescription

The <lcGeneralDescription> provides a space to develop a general description about the organization's training needs.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcOrganizational, lcPlanAudience

Inheritance

- topic/p learningBase/p learningPlan/lcGeneralDescription

Example

...
  <lcGeneralDescription>Generally speaking, this is what to expect.</lcGeneralDescription>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.19 lcGapItemDelta
Next topic: 3.3.5.2.21 lcGoals


lcGoals

3.3.5.2.21 lcGoals

The <lcGoals> provides the outcomes desired by the organization to be addressed by the training effort. These goals may require concurrent efforts outside of training such as technology acquisition, reorganization, and so forth.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcOrganizational

Inheritance

- topic/p learningBase/p learningPlan/lcGoals

Example

...
   <lcGoals>Goals...</lcGoals>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.20 lcGeneralDescription
Next topic: 3.3.5.2.22 lcGraphics


lcGraphics

3.3.5.2.22 lcGraphics

The <lcGraphics> describes standards and system requirements for displaying graphics and other related content types.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcGraphics

Example

...
    <lcGraphics><p>Expect many graphics.</p></lcGraphics>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.21 lcGoals
Next topic: 3.3.5.2.23 lcHandouts


lcHandouts

3.3.5.2.23 lcHandouts

The <lcHandouts> provides aspects of the course that are provided by the instructor in support of the course learning objectives.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcHandouts

Example

...
      <lcHandouts>
        <title>Handouts</title>
        <p>This course may have handouts.</p>
      </lcHandouts>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.22 lcGraphics
Next topic: 3.3.5.2.24 lcInstruction


lcInstruction

3.3.5.2.24 lcInstruction

The <lcInstruction> describes the specifics of a learning activity.

You have two options for including instructive content in a learningContent topic.
  • When you want to include content directly in the body of the learningContent topic, use lcInstruction.
  • When you want to use content that already exists in other DITA topics, or when you want to take advantage of additional topic types, such as concept, task, or reference, you can include that content as additional nested topic content in the learningContent topic, immediately after the learningContentbody.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningPlan, learningSummary | learningBasebody
learningContent | learningBasebody, learningContentbody

Inheritance

- topic/section learningBase/lcInstruction

Example

<learningContent id="overview">
  <title>Learning Content topic</title>
  <learningContentbody>
    <lcInstruction><title>Instruction</title>
      <p>Describe the instruction.</p>
    </lcInstruction>
  </learningContentbody>
</learningContent>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.23 lcHandouts
Next topic: 3.3.5.2.25 lcInteraction


lcInteraction

3.3.5.2.25 lcInteraction

The <lcInteraction> is a wrapper element for all the interactions of the assessment. The interactions themselves are based on the lcInteractionBase type. A starter set of interaction types is defined in the learning domain.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | (lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent | learningBasebody, learningAssessmentbody
learningOverview, learningPlan, learningSummary | learningBasebody

Inheritance

- topic/section learningBase/lcInteraction

Example

id="assessment_example">
<learningAssessment id="testAssess">
  <title>Certification Test</title>
    <shortdesc>Pass this test, and you are a certified genius.</shortdesc>
    <learningAssessmentbody>
      <lcIntro>Here's your test, folks. Good luck!</lcIntro>
      <lcInteraction>
        <lcSingleSelect id="asdf">
        <title>Multiple Choice - IEEE standards trivia</title>
          <lcQuestion>Which one of the listed standards committees
          is responsible for developing the token ring specification?</lcQuestion>
          <lcAnswerOptionGroup>
            <lcAnswerOption>
              <lcAnswerContent>IEEE 802.3</lcAnswerContent>
            </lcAnswerOption>
            <lcAnswerOption>
              <lcAnswerContent>IEEE 802.5</lcAnswerContent>
              <lcCorrectResponse/>
            </lcAnswerOption>
            <lcAnswerOption>
              <lcAnswerContent>IEEE 802.6</lcAnswerContent>
            </lcAnswerOption>
          </lcAnswerOptionGroup>
        </lcSingleSelect>
      </lcInteraction>
      <lcSummary>
        <title>Summary</title>
        You are now certified.
      </lcSummary>
    </learningAssessmentbody>
  </learningAssessment>

Attributes

Name | Description | Data Type | Default Value | Required?
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.24 lcInstruction
Next topic: 3.3.5.2.26 lcIntervention


lcIntervention

3.3.5.2.26 lcIntervention

The <lcIntervention> describes the approach and strategies to building the learning materials, based on the needs analysis.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcInterventionItem) (any number) )

Contained by

Doctype | Content model
learningPlan | learningPlanbody

Inheritance

- topic/section learningBase/section learningPlan/lcIntervention

Example

<learningPlan id="learningPlanTest">
    <title>Learning Plan</title>
    <shortdesc>It's always good to provide a plan.
    </shortdesc>
    <learningPlanbody>
        <lcIntervention>
            <title>Intervention</title>
            <lcInterventionItem>
                <lcLearnStrat>Lesson 5
consists of three SCOs, available from the LMS table of contents. The lesson
addresses teaching points that support the module objectives. </lcLearnStrat>
                <lcPlanObjective>Learn the basics of SCORM.</lcPlanObjective>
                <lcAssessment>The
module will have a final assessment with questions associated to the SCOs that
comprise the module. </lcAssessment>
                <lcDelivery>The course may be presented by
land, by sea, and by air.</lcDelivery>
            </lcInterventionItem>
        </lcIntervention>
    </learningPlanbody>
</learningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.25 lcInteraction
Next topic: 3.3.5.2.27 lcInterventionItem


lcInterventionItem

3.3.5.2.27 lcInterventionItem

The <lcInterventionItem> describes how learning content is built, based on a systems approach to analyzing, designing, developing, implementing, and evaluating any instructional experience.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcLearnStrat) (optional) then (lcPlanObjective) (optional) then (lcAssessment) (optional) then (lcDelivery) (optional) )

Contained by

Doctype | Content model
learningPlan | lcIntervention

Inheritance

- topic/fig learningBase/fig learningPlan/lcInterventionItem

Example

<learningPlan id="learningPlanTest">
    <title>Learning Plan</title>
    <shortdesc>It's always good to provide a plan.
    </shortdesc>
    <learningPlanbody>
        <lcIntervention>
            <title>Intervention</title>
            <lcInterventionItem>
                <lcLearnStrat>Lesson 5
consists of three SCOs, available from the LMS table of contents. The lesson
addresses teaching points that support the module objectives. </lcLearnStrat>
                <lcPlanObjective>Learn the basics of SCORM.</lcPlanObjective>
                <lcAssessment>The
module will have a final assessment with questions associated to the SCOs that
comprise the module. </lcAssessment>
                <lcDelivery>The course may be presented by
land, by sea, and by air.</lcDelivery>
            </lcInterventionItem>
        </lcIntervention>
    </learningPlanbody>
</learningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.26 lcIntervention
Next topic: 3.3.5.2.28 lcIntro


lcIntro

3.3.5.2.28 lcIntro

The <lcIntro> provides a detailed introduction and description of the content to be delivered, in cases where the <shortdesc> is not adequate to fully describe the content. It may also include instructor notes.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment | learningBasebody, learningAssessmentbody
learningContent | learningBasebody, learningAssessmentbody, learningContentbody
learningOverview | learningBasebody, learningOverviewbody
learningPlan, learningSummary | learningBasebody

Inheritance

- topic/section learningBase/lcIntro

Example

<learningOverview id="overview">
  <title>Learning Overview topic</title>
  <learningOverviewbody>
    <lcIntro><title>Introduction</title>
    <p>If you need an introduction, you would
        include it here.</p>
    <note>You can have notes,
    tables, all kinds of things like that here,
    if you desire.</note>
   </lcIntro>
  </learningOverviewbody>
</learningOverview>

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.27 lcInterventionItem
Next topic: 3.3.5.2.29 lcJtaItem


lcJtaItem

3.3.5.2.29 lcJtaItem

The <lcJtaItem> provides description of job task analysis (JTA) as related to a particular learning objective.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcGapItem

Inheritance

- topic/p learningBase/p learningPlan/lcJtaItem

Example: lcGapAnalysis

...
    <lcGapAnalysis>
      <title>Gap Analysis</title>
      <lcGapItem>
        <title>Gap item</title>
        <lcPlanObjective>Learn the basics before you go further.</lcPlanObjective>
        <lcJtaItem>Current learning objectives provide guidance to developing small modules with terminal learning objectives.</lcJtaItem>
        <lcGapItemDelta>Current learners do not have the capability to approach learning
         development in a modular strategy that saves time and costs across
         the enterprise.</lcGapItemDelta>
      </lcGapItem>
    </lcGapAnalysis>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.28 lcIntro
Next topic: 3.3.5.2.30 lcKnowledge


lcKnowledge

3.3.5.2.30 lcKnowledge

<lcKnowledge> describes the learners' current knowledge and the relevancy to the broader plan audience or a specific task in the plan.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcPlanAudience, lcTask

Inheritance

- topic/p learningBase/p learningPlan/lcKnowledge

Example

  <learningPlan id="learningPlanTest">
  <title>Learning Plan</title>
  <shortdesc>It's always good to provide a plan.</shortdesc>
  <learningPlanbody>
    <lcNeedsAnalysis>
      <title>Needs analysis</title>
      <lcTask>
        <title>Tasks</title>
        <lcTaskItem>Explain the importance of content reuse, and provide examples of reuse strategy options.</lcTaskItem>
        <lcKnowledge>Learners understand acquisition procedures, program management, instructional systems design.</lcKnowledge>
        <lcSkills>The audience is skilled in program management.</lcSkills>
        <lcAttitude>Learners must be willing to be open and flexible.</lcAttitude>
      </lcTask>
    </lcNeedsAnalysis>
  </learningPlanbody>
</LearningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.29 lcJtaItem
Next topic: 3.3.5.2.31 lcLearnStrat


lcLearnStrat

3.3.5.2.31 lcLearnStrat

The <lcLearnStrat> describes the manner in which the learning content will be instructed. This should be a high level design that applies instructional-design theories and models.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcInterventionItem

Inheritance

- topic/p learningBase/p learningPlan/lcLearnStrat

Example

<learningPlan id="learningPlanTest">
    <title>Learning Plan</title>
    <shortdesc>It's always good to provide a plan.
    </shortdesc>
    <learningPlanbody>
        <lcIntervention>
            <title>Intervention</title>
            <lcInterventionItem>
                <lcLearnStrat>Lesson 5
consists of three SCOs, available from the LMS table of contents. The lesson
addresses teaching points that support the module objectives. </lcLearnStrat>
                <lcPlanObjective>Learn the basics of SCORM.</lcPlanObjective>
                <lcAssessment>The
module will have a final assessment with questions associated to the SCOs that
comprise the module. </lcAssessment>
                <lcDelivery>The course may be presented by
land, by sea, and by air.</lcDelivery>
            </lcInterventionItem>
        </lcIntervention>
    </learningPlanbody>
</learningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.30 lcKnowledge
Next topic: 3.3.5.2.32 lcLMS


lcLMS

3.3.5.2.32 lcLMS

The <lcLMS> provides the LMS name and version number used in the learning event.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcLMS

Example

...
   <lcLMS>
      <title>LMS</title>
      <p>LMS info, if needed, goes here.</p>
   </lcLMS>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.31 lcLearnStrat
Next topic: 3.3.5.2.33 lcModDate


lcModDate

3.3.5.2.33 lcModDate

The <lcModDate> provides the project modification date.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcProject

Inheritance

- topic/fig learningBase/fig learningPlan/lcModDate

Example

...
   <lcModDate>
    <title>Modification Date</title>
    <p>20070315</p>
  </lcModDate<
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.32 lcLMS
Next topic: 3.3.5.2.34 lcMotivation


lcMotivation

3.3.5.2.34 lcMotivation

The <lcMotivation> provides the reasons why the learners want and/or need to take the instruction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcPlanAudience

Inheritance

- topic/p learningBase/p learningPlan/lcMotivation

Example

...
   <lcMotivation>Want to learn about and manage lifecycle costs of content
       development.</lcMotivation>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.33 lcModDate
Next topic: 3.3.5.2.35 lcNeeds


lcNeeds

3.3.5.2.35 lcNeeds

The <lcNeeds> provides the needs behind the outcomes described by the <lcGoals>.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcOrganizational

Inheritance

- topic/p learningBase/p learningPlan/lcNeeds

Example

...
   <lcNeeds>Training efforts require a greater capability
    in tracking employee learning progress.</lcNeeds>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.34 lcMotivation
Next topic: 3.3.5.2.36 lcNeedsAnalysis


lcNeedsAnalysis

3.3.5.2.36 lcNeedsAnalysis

The <lcNeedsAnalysis> describes the training requirement and identifies the need to develop or revise content. These include periodic training gap analyses, changes to operational or maintenance requirements, and changes to equipment or systems.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcOrganizational) (optional) then (lcPlanAudience) (optional) then (lcWorkEnv) (optional) then (lcTask) (any number) )

Contained by

Doctype | Content model
learningPlan | learningPlanbody

Inheritance

- topic/section learningBase/section learningPlan/lcNeedsAnalysis

Example

<learningPlan id="learningPlanTest">
    <title>Learning Plan</title>
    <shortdesc>It's always good to provide a plan.
    </shortdesc>
    <learningPlanbody>
        <lcNeedsAnalysis>
            <title>lcNeedsAnalysis</title>
            <lcOrganizational>
                <title>Organizational Needs</title>
                <lcGeneralDescription>Organizations with
new requirements can benefit from the use of this
course.</lcGeneralDescription>
                <lcGoals>The goal for taking this course is to
develop organizational self-sufficiency in planning for and developing
conformant courseware.</lcGoals>
                <lcNeeds>Training efforts require a greater
capability in tracking employee learning progress.</lcNeeds>
                <lcValues>The
organization will develop shared expertise in each book enabling an integrative
lesson development environment.</lcValues>
                <lcOrgConstraints>Some organizations
may not have the technical ability to develop training. Overcome this
constraint with guidance on selecting contractor support.</lcOrgConstraints>
            </lcOrganizational>
            <lcPlanAudience>
                <title>lcPlanAudience</title>
                <lcGeneralDescription>Organizations with new
requirements can benefit from the use of this course.</lcGeneralDescription>
                <lcEdLevel>all about lcEdLevel</lcEdLevel>
                <lcAge>all about lcAge</lcAge>
                <lcBackground>all about lcBackground</lcBackground>
                <lcSkills>all about
lcSkills</lcSkills>
                <lcKnowledge>all about lcKnowledge</lcKnowledge>
                <lcMotivation>all about lcMotivation</lcMotivation>
                <lcSpecChars>all about
lcSpecChars</lcSpecChars>
            </lcPlanAudience>
            <lcWorkEnv>
                <title>lcWorkEnv</title>
                <lcWorkEnvDescription>all about
lcWorkEnvDescription</lcWorkEnvDescription>
                <lcPlanResources>all about
lcPlanResources</lcPlanResources>
                <lcProcesses>all about
lcProcesses</lcProcesses>
            </lcWorkEnv>
            <lcTask>
                <title>lcTask</title>
                <lcTaskItem>lcTaskItem is really great...</lcTaskItem>
                <lcKnowledge>all about lcKnowledge</lcKnowledge>
                <lcSkills>lcSkills</lcSkills>
                <lcAttitude>lcAttitude...</lcAttitude>
            </lcTask>
            <lcTask>
                <title>another lcTask (as many more as you would like...)</title>
                <lcTaskItem>lcTaskItem is really great...</lcTaskItem>
                <lcKnowledge>all about
lcKnowledge</lcKnowledge>
                <lcSkills>lcSkills</lcSkills>
                <lcAttitude>lcAttitude...</lcAttitude>
            </lcTask>
        </lcNeedsAnalysis>
    </learningPlanbody>
</learningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.35 lcNeeds
Next topic: 3.3.5.2.37 lcNextSteps


lcNextSteps

3.3.5.2.37 lcNextSteps

The <lcNextSteps> suggests next steps to reinforce the knowledge learned.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningPlan | learningBasebody
learningContent, learningSummary | learningBasebody, learningSummarybody

Inheritance

- topic/section learningBase/lcNextSteps

Example

<learningSummary id="overview">
  <title>Learning Summary topic</title>
  <learningSummarybody>
    <lcNextSteps><title>Next steps</title>
    <p>To provide information about next steps, you would
        include it here.</p>
    <note>You can have notes,
    tables, all kinds of things like that here,
    if you desire.</note>
   </lcNextSteps>
  </learningSummarybody>
</learningSummary>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.36 lcNeedsAnalysis
Next topic: 3.3.5.2.38 lcNoLMS


lcNoLMS

3.3.5.2.38 lcNoLMS

Use <lcNoLMS> when you plan to deliver the content as a standalone package, without a learning management system (LMS).

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/section learningPlan/lcNoLMS

Example

...
  <lcNoLMS>This content does not depend on delivery with a learning management system.</lcNoLMS>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.37 lcNextSteps
Next topic: 3.3.5.2.39 lcObjective


lcObjective

3.3.5.2.39 lcObjective

The <lcObjective> describes a single learning objective.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcObjectivesGroup

Inheritance

- topic/li learningBase/lcObjective

Example

<learningOverview id="overview">
  <title>Learning Overview topic</title>
  <learningOverviewbody>
    <lcObjectives>
    <title>Objectives</title>
    <lcObjectiveStem>When you complete this lesson, you'll know how to do the
     following:</lcObjective>
      <lcObjectivesList>
        <lcObjective>Create a good learning overview topic.</lcObjective>
        <lcObjective>Identify clear learning objectives.</lcObjective>
        <lcObjective>Add good test items to assess knowledge gained.</lcObjective>
      </lcObjectivesList>
    </lcObjectives>
  </learningOverviewbody>
</learningOverview>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.38 lcNoLMS
Next topic: 3.3.5.2.40 lcObjectives


lcObjectives

3.3.5.2.40 lcObjectives

The <lcObjectives> lists or describes the learning goals.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (title) (optional) then (lcObjectivesStem) (optional) then (lcObjectivesGroup) (any number) )

Contained by

Doctype | Content model
learningAssessment | learningBasebody, learningAssessmentbody
learningContent | learningBasebody, learningSummarybody, learningAssessmentbody, learningContentbody
learningOverview | learningBasebody, learningOverviewbody
learningPlan | learningBasebody
learningSummary | learningBasebody, learningSummarybody

Inheritance

- topic/section learningBase/lcObjectives

Example

<learningOverview id="understanding_the_basics" xml:lang="en-us">
  <title>Overview: Understanding the basics</title>
  <shortdesc>Mail basics start from the inbox, viewing and opening messages
    you receive, and moving them to appropriate mail folders for easy access and
    retrieval.</shortdesc>
  <learningOverviewbody>
    <lcAudience>The intended audience includes new users of the company email
      system and anyone wanting a refresher on the basic features.</lcAudience>
    <lcDuration>
      <title>Expected duration</title>
      <lcTime value="00:30">It should take you no more than 30 minutes to complete
        this module.</lcTime>
    </lcDuration>
    <lcObjectives>
      <lcObjectivesStem>When you complete this lesson, you'll know how to perform
        the following mail basics:</lcObjectivesStem>
      <lcObjectivesGroup>
        <lcObjective>Viewing the inbox</lcObjective>
        <lcObjective>Opening a message</lcObjective>
        <lcObjective>Moving messages to a folder</lcObjective>
      </lcObjectivesGroup><
    </lcObjectives>
  </learningOverviewbody>
</learningOverview>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.39 lcObjective
Next topic: 3.3.5.2.41 lcObjectivesGroup


lcObjectivesGroup

3.3.5.2.41 lcObjectivesGroup

The <lcObjectivesGroup> contains a list of one or more learning objectives.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( (lcObjective) (one or more) )

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcObjectives

Inheritance

- topic/ul learningBase/lcObjectivesGroup

Example

<learningOverview id="overview">
  <title>Learning Overview topic</title>
  <learningOverviewbody>
    <lcObjectives>
    <title>Objectives</title>
    <lcObjectivesStem>When you complete this lesson, you'll know how to do the
     following:</lcObjectivesGroup>
      <lcObjectivesGroup>
        <lcObjective>Creating a good learning overview topic.</lcObjective>
        <lcObjective>Identifying clear learning objectives.</lcObjective>
        <lcObjective>Adding good test items to assess knowledge gained.</lcObjective>
      </lcObjectivesGroup>
    </lcObjectives>
  </learningOverviewbody>
</learningOverview>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.40 lcObjectives
Next topic: 3.3.5.2.42 lcObjectivesStem


lcObjectivesStem

3.3.5.2.42 lcObjectivesStem

The <lcObjectivesStem> provides a leading sentence to introduce a list of learning objectives.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcObjectives

Inheritance

- topic/ph learningBase/lcObjectivesStem

Example

<learningOverview id="overview">
  <title>Learning Overview topic</title>
  <learningOverviewbody>
    <lcObjectives>
    <title>Objectives</title>
    <lcObjectivesStem>When you complete this lesson, you'll know how to do the
     following:</lcObjectivesStem>
      <lcObjectivesList>
        <lcObjective>Creating a good learning overview topic.</lcObjective>
        <lcObjective>Identifying clear learning objectives.</lcObjective>
        <lcObjective>Adding good test items to assess knowledge gained.</lcObjective>
      </lcObjectivesList>
    </lcObjectives>
  </learningOverviewbody>
</learningOverview>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.41 lcObjectivesGroup
Next topic: 3.3.5.2.43 lcOJT


lcOJT

3.3.5.2.43 lcOJT

The <lcOJT> is "the on-the-job training" and describes aspects of the course taking place in the work environment.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcOJT

Example

...
    <lcOJT>
      <lcOJT>title>The On-the-Job Training</title>
      <p>Describe the OJT.</p>
    </lcOJT>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.42 lcObjectivesStem
Next topic: 3.3.5.2.44 lcOrganizational


lcOrganizational

3.3.5.2.44 lcOrganizational

The <lcOrganizational> describes an organization's learning requirements.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcGeneralDescription) (optional) then (lcGoals) (optional) then (lcNeeds) (optional) then (lcValues) (optional) then (lcOrgConstraints) (optional) )

Contained by

Doctype | Content model
learningPlan | lcNeedsAnalysis

Inheritance

- topic/fig learningBase/fig learningPlan/lcOrganizational

Example

...
      <lcOrganizational>
        <title>Organizational</title>
        <lcGeneralDescription>all about the organization.</lcGeneralDescription>
        <lcGoals>the Goals</lcGoals>
        <lcNeeds>the Needs...</lcNeeds>
        <lcValues>the Values...</lcValues>
        <lcOrgConstraints>the Constraints...</lcOrgConstraints>
      </lcOrganizational>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.43 lcOJT
Next topic: 3.3.5.2.45 lcOrgConstraints


lcOrgConstraints

3.3.5.2.45 lcOrgConstraints

The <lcOrgConstraints> provides organizational aspects that may limit the organization's ability to effectively use the instruction to meet its goals.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcOrganizational

Inheritance

- topic/p learningBase/p learningPlan/lcOrgConstraints

Example

...
   <lcOrgConstraints>Some organizations may not have
     the technical ability to develop training. Overcome this
     constraint with guidance and planning.</lcOrgConstraints>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.44 lcOrganizational
Next topic: 3.3.5.2.46 lcPlanAudience


lcPlanAudience

3.3.5.2.46 lcPlanAudience

The <lcPlanAudience> describes characteristics of the learners who take the instruction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcGeneralDescription) (optional) then (lcEdLevel) (optional) then (lcAge) (optional) then (lcBackground) (optional) then (lcSkills) (optional) then (lcKnowledge) (optional) then (lcMotivation) (optional) then (lcSpecChars) (optional) )

Contained by

Doctype | Content model
learningPlan | lcNeedsAnalysis

Inheritance

- topic/fig learningBase/fig learningPlan/lcPlanAudience

Example

...
  <lcPlanAudience>
        <title>Audience</title>
        <lcGeneralDescription>Organizations with new training requirements can benefit from the use of this course.</lcGeneralDescription>
        <lcEdLevel>alThe target education levels include some college, college graduate, or post-graduate.</lcEdLevel>
        <lcAge>Adults age 30 - 45.</lcAge>
        <lcBackground>The target audience for this module includes acquisition personnel, program managers, project engineers, instructional designers, and business developers.</lcBackground>
        <lcSkills>The audience is skilled in program management.</lcSkills>
        <lcKnowledge>Learners understand acquisition procedures, program management, instructional systems design.</lcKnowledge>
        <lcMotivation>Want to learn about and manage lifecycle costs of content
           development.</lcMotivation>
        <lcSpecChars>There are no known learning handicaps in the learning audience.</lcSpecChars>
      </lcPlanAudience>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.45 lcOrgConstraints
Next topic: 3.3.5.2.47 lcPlanDescrip


lcPlanDescrip

3.3.5.2.47 lcPlanDescrip

The <lcPlanDescrip> provides a plan description.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcProject

Inheritance

- topic/fig learningBase/fig learningPlan/lcPlanDescrip

Example

...
      <lcPlanDescrip>
        <title>Plan Description</title>
        <p>The goal of the Joint WG module is to provide learners with a broad overview of the Joint WG.</p>
      </lcPlanDescrip>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.46 lcPlanAudience
Next topic: 3.3.5.2.48 lcPlanObjective


lcPlanObjective

3.3.5.2.48 lcPlanObjective

The <lcPlanObjective> describes the objective to be addressed by a gap analysis or intervention.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcGapItem, lcInterventionItem

Inheritance

- topic/p learningBase/p learningPlan/lcPlanObjective

Example: lcGapAnalysis

...
    <lcGapAnalysis>
      <title>Gap Analysis</title>
      <lcGapItem>
        <title>Gap item</title>
        <lcPlanObjective>Learn the basics before you go further.</lcPlanObjective>
        <lcJtaItem>Current learning objectives provide guidance to developing small modules with terminal learning objectives.</lcJtaItem>
        <lcGapItemDelta>Current learners do not have the capability to approach learning
         development in a modular strategy that saves time and costs across
         the enterprise.</lcGapItemDelta>
      </lcGapItem>
    </lcGapAnalysis>
...

Example

<learningPlan id="learningPlanTest">
    <title>Learning Plan</title>
    <shortdesc>It's always good to provide a plan.
    </shortdesc>
    <learningPlanbody>
        <lcIntervention>
            <title>Intervention</title>
            <lcInterventionItem>
                <lcLearnStrat>Lesson 5
consists of three SCOs, available from the LMS table of contents. The lesson
addresses teaching points that support the module objectives. </lcLearnStrat>
                <lcPlanObjective>Learn the basics of SCORM.</lcPlanObjective>
                <lcAssessment>The
module will have a final assessment with questions associated to the SCOs that
comprise the module. </lcAssessment>
                <lcDelivery>The course may be presented by
land, by sea, and by air.</lcDelivery>
            </lcInterventionItem>
        </lcIntervention>
    </learningPlanbody>
</learningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.47 lcPlanDescrip
Next topic: 3.3.5.2.49 lcPlanPrereqs


lcPlanPrereqs

3.3.5.2.49 lcPlanPrereqs

<lcPlanPrereqs> provides the knowledge, skills, abilities, courses and other activities learners must have satisfied to take the instruction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcProject

Inheritance

- topic/fig learningBase/fig learningPlan/lcPlanPrereqs

Example

...
  <lcPlanPrereqs>
    <title>Prerequisites</title>
    <p>This course assumes you have mastery of
      JWG 101 (Fundamentals of Joint Workgroups) or the
      equivalent.</p>
    </lcPlanPrereqs>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.48 lcPlanObjective
Next topic: 3.3.5.2.50 lcPlanResources


lcPlanResources

3.3.5.2.50 lcPlanResources

The <lcPlanResources> describes resource needs.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcWorkEnv

Inheritance

- topic/p learningBase/p learningPlan/lcPlanResources

Example

...
      <lcWorkEnv>
        <title>Work Environment</title>
        <lcWorkEnvDescription>All learners work in a typical office environment.</lcWorkEnvDescription>
        <lcPlanResources>You need lots of pencils.</lcPlanResources>
        <lcProcesses>Follow these processes:
          <ul>
            <li>Fill our the pencil request form.</li>
            <li>Sharpen the pencils as soon as they arrive, to keep them fresh.</li>
          <ul>
        </lcProcesses>
      </lcWorkEnv>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.49 lcPlanPrereqs
Next topic: 3.3.5.2.51 lcPlanSubject


lcPlanSubject

3.3.5.2.51 lcPlanSubject

The <lcPlanSubject> provides a complete description of the subject of the planned learning.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcProject

Inheritance

- topic/fig learningBase/fig learningPlan/lcPlanSubject

Example

...
      <lcPlanSubject>
        <title>Subject</title>
        <p>This course covers the goals of the Joint WG.</p>
      </lcPlanSubject>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.50 lcPlanResources
Next topic: 3.3.5.2.52 lcPlanTitle


lcPlanTitle

3.3.5.2.52 lcPlanTitle

The <lcPlanTitle> provides a title for a specific module, lesson, or section of the course that this plan describes.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcProject

Inheritance

- topic/fig learningBase/fig learningPlan/lcPlanTitle

Example

...
  <lcPlanTitle>
    <title>Plan Title</title>
    <p>Joint goals learning plan.</p>
  </lcPlanTitle>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.51 lcPlanSubject
Next topic: 3.3.5.2.53 lcPlayers


lcPlayers

3.3.5.2.53 lcPlayers

The <lcPlayers> describes tools and plugins used for time-sequenced display at runtime.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcPlayers

Example: lcTechnical

<learningPlan id="learningPlan">
  <title>Learning Plan</title>
  <shortdesc>It's always good to provide a plan.</shortdesc>
  <learningPlanbody>
    <lcTechnical>
      <title>lcTechnical</title>
      <lcPlayers>
        <title>Players</title>
        <p>The learning content requires no additional plugins or players.</p>
      </lcPlayers>
    </lcTechnical>
  </learningPlanbody>
</LearningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.52 lcPlanTitle
Next topic: 3.3.5.2.54 lcPrereqs


lcPrereqs

3.3.5.2.54 lcPrereqs

The <lcPrereqs> describes the knowledge, experience, or other prerequisites needed to complete the content.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningPlan, learningSummary | learningBasebody
learningOverview | learningBasebody, learningOverviewbody

Inheritance

- topic/section learningBase/lcPrereqs

Example

<learningOverview id="overview">
  <title>Learning Overview topic</title>
  <learningOverviewbody>
    <lcPrereqs><title>Prereqs</title>
    <p>You have no need to know anything
    prior to taking this lesson. It informs all.</p>
   </lcPrereqs>
  </learningOverviewbody>
</learningOverview>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.53 lcPlayers
Next topic: 3.3.5.2.55 lcProcesses


lcProcesses

3.3.5.2.55 lcProcesses

The <lcProcesses> describes processes learners routinely follow.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcWorkEnv

Inheritance

- topic/p learningBase/p learningPlan/lcProcesses

Example

...
      <lcWorkEnv>
        <title>Work Environment</title>
        <lcWorkEnvDescription>All learners work in a typical office environment.</lcWorkEnvDescription>
        <lcPlanResources>You need lots of pencils.</lcPlanResources>
        <lcProcesses>Follow these processes:
          <ul>
            <li>Fill our the pencil request form.</li>
            <li>Sharpen the pencils as soon as they arrive, to keep them fresh.</li>
          <ul>
        </lcProcesses>
      </lcWorkEnv>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.54 lcPrereqs
Next topic: 3.3.5.2.56 lcProject


lcProject

3.3.5.2.56 lcProject

The <lcProject> provides learning content project plan description information.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcClient) (optional) then (lcPlanTitle) (optional) then (lcCIN) (optional) then (lcModDate) (optional) then (lcDelivDate) (optional) then (lcPlanSubject) (optional) then (lcPlanDescrip) (optional) then (lcPlanPrereqs) (optional) )

Contained by

Doctype | Content model
learningPlan | learningPlanbody

Inheritance

- topic/section learningBase/section learningPlan/lcProject

Example

<learningPlan id="learningPlanTest">
    <title>Learning Plan</title>
    <shortdesc>It's always good to provide a plan.
    </shortdesc>
    <learningPlanbody>
        <lcProject>
            <title>lcProject</title>
            <lcClient>
                <title>Client</title>
                <p>Joint work group
                </p>
            </lcClient>
            <lcPlanTitle>
                <title>Plan Title</title>
                <p>Joint goals learning plan.
                </p>
            </lcPlanTitle>
            <lcCIN>
                <title>Joint WG</title>
            </lcCIN>
            <lcModDate>
                <title>Modification Date</title>
                <p>20070315
                </p>
            </lcModDate>
            <lcDelivDate>
                <title>Delivery Date</title>
                <p>20070630
                </p>
            </lcDelivDate>
            <lcPlanSubject>
                <title>Subject</title>
                <p>This course covers the goals of the Joint WG.
                </p>
            </lcPlanSubject>
            <lcPlanDescrip>
                <title>Plan Description</title>
                <p>The goal of the Joint WG module is to provide learners with a broad overview
  of the Joint WG.
                </p>
            </lcPlanDescrip>
            <lcPlanPrereqs>
                <title>Prerequisites</title>
                <p>This course assumes you have mastery of JWG 101 (Fundamentals of Joint
  Workgroups) or the equivalent.
                </p>
            </lcPlanPrereqs>
        </lcProject>
    </learningPlanbody>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.55 lcProcesses
Next topic: 3.3.5.2.57 lcResolution


lcResolution

3.3.5.2.57 lcResolution

The <lcResolution> describes the required computer screen resolution for the online instruction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcResolution

Example

...
  <lcResolution><p>Minimum resolution of 800 wide, 600 high.</p></lcResolution>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.56 lcProject
Next topic: 3.3.5.2.58 lcResources


lcResources

3.3.5.2.58 lcResources

The <lcResources> provides a list of related resources and information about them, such as related articles or samples on the web.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningPlan | learningBasebody
learningContent, learningSummary | learningBasebody, learningSummarybody
learningOverview | learningBasebody, learningOverviewbody

Inheritance

- topic/section learningBase/lcResources

Example

<learningOverview id="overview">
  <title>Learning Overview topic</title>
  <learningOverviewbody>
    <lcResources><title>Resources</title>
    <p>Provide information about useful resources here.</p>
   </lcResources>
  </learningOverviewbody>
</learningOverview>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.57 lcResolution
Next topic: 3.3.5.2.59 lcReview


lcReview

3.3.5.2.59 lcReview

The <lcReview> provides a review of the main points.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningOverview, learningPlan | learningBasebody
learningContent, learningSummary | learningBasebody, learningSummarybody

Inheritance

- topic/section learningBase/lcReview

Example

<learningSummary id="summary">
  <title>Learning Summary topic</title>
  <learningSummarybody>
    <lcReview><title>Review</title>
    <p>If you want to offer a review,
        include it here.</p>
    <note>You can have notes,
    tables, all kinds of things like that here,
    if you desire.</note>
   </lcReview>
  </learningSummarybody>
</learningSummary>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.58 lcResources
Next topic: 3.3.5.2.60 lcSecurity


lcSecurity

3.3.5.2.60 lcSecurity

The <lcSecurity> describes the security requirements in the delivered instruction.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcSecurity.dita

Example

...
  <lcSecurity><p>Never leave equipment unattended during this course.</p></lcSecurity>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.59 lcReview
Next topic: 3.3.5.2.61 lcSkills


lcSkills

3.3.5.2.61 lcSkills

The <lcSkills> describes the learners' current skill set and the relevancy to the broader plan audience or a specific task in the plan.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcPlanAudience, lcTask

Inheritance

- topic/p learningBase/p learningPlan/lcSkills

Example

...
        <lcSkills>...all about Skills needed...</lcSkills>
...

Example

  <learningPlan id="learningPlanTest">
  <title>Learning Plan</title>
  <shortdesc>It's always good to provide a plan.</shortdesc>
  <learningPlanbody>
    <lcNeedsAnalysis>
      <title>Needs analysis</title>
      <lcTask>
        <title>Tasks</title>
        <lcTaskItem>Explain the importance of content reuse, and provide examples of reuse strategy options.</lcTaskItem>
        <lcKnowledge>Learners understand acquisition procedures, program management, instructional systems design.</lcKnowledge>
        <lcSkills>The audience is skilled in program management.</lcSkills>
        <lcAttitude>Learners must be willing to be open and flexible.</lcAttitude>
      </lcTask>
    </lcNeedsAnalysis>
  </learningPlanbody>
</LearningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.60 lcSecurity
Next topic: 3.3.5.2.62 lcSpecChars


lcSpecChars

3.3.5.2.62 lcSpecChars

The <lcSpecChars> provides learner characteristics specific to the population that will influence the design, including learning disabilities, physical handicaps, and so forth.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcPlanAudience

Inheritance

- topic/p learningBase/p learningPlan/lcSpecChars

Example

...
   <lcSpecChars>There are no known learning handicaps
     in the learning audience.</lcSpecChars>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.61 lcSkills
Next topic: 3.3.5.2.63 lcSummary


lcSummary

3.3.5.2.63 lcSummary

The <lcSummary> provides a textual summary that describes the main learning goals and lessons learned.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or p or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or sectiondiv or title or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment | learningBasebody, learningAssessmentbody
learningContent | learningBasebody, learningSummarybody, learningAssessmentbody
learningOverview, learningPlan | learningBasebody
learningSummary | learningBasebody, learningSummarybody

Inheritance

- topic/section learningBase/lcSummary

Example

<learningSummary id="overview">
  <title>Learning Summary topic</title>
  <learningSummarybody>
    <lcSummary><title>Summary</title>
    <p>If you need a summary section, you would
        include it here.</p>
    <note>You can have notes,
    tables, all kinds of things like that here,
    if you desire.</note>
   </lcSummary>
  </learningSummarybody>
</learningSummary>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.62 lcSpecChars
Next topic: 3.3.5.2.64 lcTask


lcTask

3.3.5.2.64 lcTask

The <lcTask> captures a work item to be performed, as part of the learning plan.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcTaskItem) (any number) then (lcKnowledge) (optional) then (lcSkills) (optional) then (lcAttitude) (optional) )

Contained by

Doctype | Content model
learningPlan | lcNeedsAnalysis

Inheritance

- topic/fig learningBase/fig learningPlan/lcTask

Example

  <learningPlan id="learningPlanTest">
  <title>Learning Plan</title>
  <shortdesc>It's always good to provide a plan.</shortdesc>
  <learningPlanbody>
    <lcNeedsAnalysis>
      <title>Needs analysis</title>
      <lcTask>
        <title>Tasks</title>
        <lcTaskItem>Explain the importance of content reuse, and provide examples of reuse strategy options.</lcTaskItem>
        <lcKnowledge>Learners understand acquisition procedures, program management, instructional systems design.</lcKnowledge>
        <lcSkills>The audience is skilled in program management.</lcSkills>
        <lcAttitude>Learners must be willing to be open and flexible.</lcAttitude>
      </lcTask>
    </lcNeedsAnalysis>
  </learningPlanbody>
</LearningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.63 lcSummary
Next topic: 3.3.5.2.65 lcTaskItem


lcTaskItem

3.3.5.2.65 lcTaskItem

The <lcTaskItem> describes a discreet task to be taught.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcTask

Inheritance

- topic/p learningBase/p learningPlan/lcTaskItem

Example

  <learningPlan id="learningPlanTest">
  <title>Learning Plan</title>
  <shortdesc>It's always good to provide a plan.</shortdesc>
  <learningPlanbody>
    <lcNeedsAnalysis>
      <title>Needs analysis</title>
      <lcTask>
        <title>Tasks</title>
        <lcTaskItem>Explain the importance of content reuse, and provide examples of reuse strategy options.</lcTaskItem>
        <lcKnowledge>Learners understand acquisition procedures, program management, instructional systems design.</lcKnowledge>
        <lcSkills>The audience is skilled in program management.</lcSkills>
        <lcAttitude>Learners must be willing to be open and flexible.</lcAttitude>
      </lcTask>
    </lcNeedsAnalysis>
  </learningPlanbody>
</LearningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.64 lcTask
Next topic: 3.3.5.2.66 lcTechnical


lcTechnical

3.3.5.2.66 lcTechnical

The <lcTechnical> describes the technical requirements to the learning content and how those requirements are supported by the instructional design.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcLMS) (optional) then (lcNoLMS) (optional) then (lcHandouts) (optional) then (lcClassroom) (optional) then (lcOJT) (optional) then (lcConstraints) (optional) then (lcW3C) (optional) then (lcPlayers) (optional) then (lcGraphics) (optional) then (lcViewers) (optional) then (lcResolution) (optional) then (lcFileSizeLimitations) (optional) then (lcDownloadTime) (optional) then (lcSecurity) (optional) )

Contained by

Doctype | Content model
learningPlan | learningPlanbody

Inheritance

- topic/section learningBase/section learningPlan/lcTechnical

Example: lcTechnical

<learningPlan id="learningPlan">
    <title>Learning Plan</title>
    <shortdesc>It's always good to provide a plan.
    </shortdesc>
    <learningPlanbody>
        <lcTechnical>
            <title>lcTechnical</title>
        </lcTechnical>
    </learningPlanbody>
</learningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.65 lcTaskItem
Next topic: 3.3.5.2.67 lcTime


lcTime

3.3.5.2.67 lcTime

The <lcTime> specifies the time expected to complete an activity. You can specify the time both as text to display to the user and as an attribute value that follows a specific time format.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | ( text data or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or image or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningAssessment, learningContent, learningOverview, learningPlan, learningSummary | lcDuration

Inheritance

- topic/data learningBase/lcTime

Example

<learningOverview id="overview">
  <title>Learning Overview topic</title>
  <learningOverviewbody>
    <lcDuration><title>Duration</title>
      <lcTime name="lcTime" value="00:15">15 minutes</>
   </lcDuration>
  </learningOverviewbody>
</learningOverview>

Attributes

Name | Description | Data Type | Default Value | Required?
name | The name used to indicate this data. | CDATA | lcTime | Required
datatype | The datatype for this data. | CDATA | There is no assumed time-specific data format or type. If you use a specific datatype for the time value, specify it here. | Required
value | There is no assumed time-specific data format or type for the time value. | PCDATA |  | Required
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.66 lcTechnical
Next topic: 3.3.5.2.68 lcValues


lcValues

3.3.5.2.68 lcValues

The <lcValues> describes affective components of desired instructional outcomes.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcOrganizational

Inheritance

- topic/p learningBase/p learningPlan/lcValues

Example

...
   <lcValues>The organization will develop shared
     expertise in each book enabling an integrative lesson
     development environment.</lcValues>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.67 lcTime
Next topic: 3.3.5.2.69 lcViewers


lcViewers

3.3.5.2.69 lcViewers

The <lcViewers> describes viewers used for time-sequenced display at runtime.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcViewers

Example

<learningPlan id="learningPlan">
  <title>Learning Plan</title>
  <shortdesc>It's always good to provide a plan.</shortdesc>
  <learningPlanbody>
    <lcTechnical>
      <title>lcTechnical</title>
      <lcViewers>
        <title>Viewers</title>
        <p>The module uses standard viewers, model 1.0 or 1.1.</p>
      </lcViewers>
    </lcTechnical>
  </learningPlanbody>
</LearningPlan>

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.68 lcValues
Next topic: 3.3.5.2.70 lcW3C


lcW3C

3.3.5.2.70 lcW3C

The <lcW3C> provides requirements for use of world wide web consortium standards.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (dl or image or lines or lq or note or lcInstructornote or object or ol or p or pre or sl or ul or data or data-about or fn or foreign or unknown or simpletable or xref) (any number) )

Contained by

Doctype | Content model
learningPlan | lcTechnical

Inheritance

- topic/fig learningBase/fig learningPlan/lcW3C

Example

...
  <lcW3C><p>Whenever possible, stand up and do a W3C.</p></lcW3C>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.69 lcViewers
Next topic: 3.3.5.2.71 lcWorkEnv


lcWorkEnv

3.3.5.2.71 lcWorkEnv

The <lcWorkEnv> describes the working conditions and contexts in which the training will be applied.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( (title) (optional) then (lcWorkEnvDescription) (optional) then (lcPlanResources) (optional) then (lcProcesses) (optional) )

Contained by

Doctype | Content model
learningPlan | lcNeedsAnalysis

Inheritance

- topic/fig learningBase/fig learningPlan/lcWorkEnv

Example

...
      <lcWorkEnv>
        <title>Work Environment</title>
        <lcWorkEnvDescription>All learners work in a typical office environment.</lcWorkEnvDescription>
        <lcPlanResources>You need lots of pencils.</lcPlanResources>
        <lcProcesses>Follow these processes:
          <ul>
            <li>Fill our the pencil request form.</li>
            <li>Sharpen the pencils as soon as they arrive, to keep them fresh.</li>
          <ul>
        </lcProcesses>
      </lcWorkEnv>
...

Attributes

Name | Description | Data Type | Default Value | Required?
display-atts attribute group (scale, frame, expanse) | A set of related attributes, described in display-atts attribute group |  |  |
spectitle | The specialized title attribute allows architects of specialized types to define a fixed or default title for a specialized element. Not intended for direct use by authors. | CDATA | #IMPLIED | No
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.70 lcW3C
Next topic: 3.3.5.2.72 lcWorkEnvDescription


lcWorkEnvDescription

3.3.5.2.72 lcWorkEnvDescription

The <lcWorkEnvDescription> provides the general working environment in which the training will be applied.

Contains

Note: These models represent only the default document types distributed by OASIS. Actual content models will differ with each new document type.
Doctype | Content model
learningPlan | ( text data or dl or fig or imagemap or lcInteractionBase or lcTrueFalse or lcSingleSelect or lcMultipleSelect or lcSequencing or lcMatching or lcHotspot or lcOpenQuestion or image or lines or lq or note or lcInstructornote or object or ol or pre or simpletable or sl or table or ul or boolean or cite or keyword or ph or b or i or sup or sub or tt or u or q or term or tm or xref or state or data or data-about or foreign or unknown or draft-comment or fn or indextermref or indexterm or required-cleanup) (any number)

Contained by

Doctype | Content model
learningPlan | lcWorkEnv

Inheritance

- topic/p learningBase/p learningPlan/lcWorkEnvDescription

Example

...
   <lcWorkEnvDescription>All learners work in a typical office environment.</lcWorkEnvDescription>
...

Attributes

Name | Description | Data Type | Default Value | Required?
univ-atts attribute group (includes select-atts, id-atts, and localization-atts groups) | A set of related attributes, described in univ-atts attribute group |  |  |
global-atts attribute group (xtrf, xtrc) | A set of related attributes, described in global-atts attribute group |  |  |
class, outputclass | Common attributes described in Other common DITA attributes |  |  |
Parent topic: 3.3.5.2 Common learning content elements
Previous topic: 3.3.5.2.71 lcWorkEnv
Next topic: 3.4 Attributes


Attributes

3.4 Attributes

Many DITA attributes are reused in groups or are too complex to describe in the usual table cell format. Those attributes are collected in this section.

  • 3.4.1 Commonly referenced attribute groups
    Common attribute groups, such as the selection and property attributes of most DITA elements, are described here as sets in order to reduce unnecessary duplication of common information.
  • 3.4.2 Complex attribute definitions
    Several DITA attributes require more explanation than can fit in a single table cell. Those attributes are collected here.
Parent topic: 3 Language reference
Previous topic: 3.3.5.2.72 lcWorkEnvDescription
Next topic: 3.4.1 Commonly referenced attribute groups


Commonly referenced attribute groups

3.4.1 Commonly referenced attribute groups

Common attribute groups, such as the selection and property attributes of most DITA elements, are described here as sets in order to reduce unnecessary duplication of common information.

  • 3.4.1.1 display-atts attribute group
    The "display-atts" attribute group includes attributes whose values may be used for affecting the display of a topic or element.
  • 3.4.1.2 global-atts attribute group
    The "global-atts" attribute group includes a set of debugging attributes that are normally hidden from authoring view.
  • 3.4.1.3 univ-atts attribute group
    The "univ-atts" attribute group defines a set of common attributes available on most DITA elements.
  • 3.4.1.4 id-atts attribute group
    The "id-atts" attribute group includes attributes that enable the naming and referencing of elements in topics and maps.
  • 3.4.1.5 select-atts attribute group
    The "select-atts" attribute group includes common metadata attributes, several of which support conditional processing (filtering and flagging) or the creation of new attribute domain specializations.
  • 3.4.1.6 localization-atts attribute group
    The "localization-atts" attribute group defines a set of common attributes related to translation and localization. These attributes are available on most DITA elements.
  • 3.4.1.7 relational-atts attribute group
    The "relational-atts" attribute group includes attributes whose values may be used for representing navigational relationships. These attributes occur only on elements that represent relationships among DITA elements or between DITA elements and non-DITA resources.
  • 3.4.1.8 topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups
    The "topicref-atts", "topicref-atts-no-toc", and "topicref-atts-without-format" attribute groups represent collections of attributes used in numerous map elements.
  • 3.4.1.9 Other common DITA attributes
    The following attributes are not part of an entity group but are common to many elements.
Parent topic: 3.4 Attributes
Previous topic: 3.4 Attributes
Next topic: 3.4.1.1 display-atts attribute group


display-atts attribute group

3.4.1.1 display-atts attribute group

The "display-atts" attribute group includes attributes whose values may be used for affecting the display of a topic or element.

Attributes

Name Description Data Type Default Value Required?
scale Specifies a percentage, selected from an enumerated list, that is used to resize fonts in relation to the normal text size. This attribute is primarily useful for print-oriented display.

The scale attribute provides an acknowledged style-based property directly on DITA elements. For the table and fig elements, the intent of the property is to allow authors to adjust font sizes on the content of the containing element, primarily for print accomodation. An image in these contexts is to be scaled only by its own direct scale property. If not specifically scaled, such an image is unchanged by the scale property of its parent table or fig.

Some DITA processors or output formats may not be able to support all values.

(50 | 60 | 70 | 80 | 90 | 100 | 110 | 120 | 140 | 160 | 180 | 200 | -dita-use-​conref-​target) #IMPLIED No
frame Specifies which portion of a border should surround the element. Allowable values are:
top
Draw a line before the element
bottom
Draw a line after the element
topbot
Draw a line both before and after the element
all
Draw a box around the element
sides
Draw a line at each side of the element
none
Don't draw any lines around this element
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Some DITA processors or output formats may not be able to support all values.

(top | bottom | topbot | all | sides | none | -dita-use-​conref-​target) #IMPLIED No
expanse Determines the horizontal placement of the element. Allowable values are:
page
Places the element on the left page margin for left-to-right presentation, or right page margin for right-to-left presentation.
column
Aligns the element with the current column margin
textline
Aligns the element with the left (for left to right presentation) or right (for right to left presentation) margin of the current text line and takes indention into account.
spread
Indicates that, if possible, the object should be rendered across a multi-page spread. If the rendition target does not have anything corresponding to spreads then spread has the same meaning as "page".
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

In DITA tables, in place of the expanse attribute used by other DITA elements, the pgwide attribute is used in order to conform to the OASIS Exchange Table Model. This attribute has a similar semantic (1=page width; 0=resize to galley or column).

Some DITA processors or output formats may not be able to support all values.

(page | column | textline | spread | -dita-use-​conref-​target) #IMPLIED No

Example

The "display-atts" attribute group is used within the DITA DTDs and schemas as a common definition for attributes that affect presentation of certain elements. A typical example might be:

<codeblock scale="90" frame="topbot" expanse="page">
/* a long sample program */
Do forever
  Say "Hello, World"
End
</codeblock>
Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1 Commonly referenced attribute groups
Next topic: 3.4.1.2 global-atts attribute group


global-atts attribute group

3.4.1.2 global-atts attribute group

The "global-atts" attribute group includes a set of debugging attributes that are normally hidden from authoring view.

These attributes are intended to store debugging information during intermediate processing. One possible implementation is to use xtrf (xml-trace-filename) to store the original source file name through intermediate processing steps, and use xtrc ( xml-trace-counter) to store an element counter for repositioning authoring tools at the originating element location. If values are assigned in this way in the first stage of a processing stream, values in these attributes can then be used for error recovery.

These attributes are normally hidden from authors and exposed only to processing tools or editor macros. Values used in these attributes may be implementation-dependent.

Attributes

Name | Description | Data Type | Default Value | Required?
xtrf | xml-trace-filename, the original filename | CDATA | #IMPLIED | No
xtrc | xml-trace-counter, an element counter for repositioning editors at a known edit location | CDATA | #IMPLIED | No
Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1.1 display-atts attribute group
Next topic: 3.4.1.3 univ-atts attribute group


univ-atts attribute group

3.4.1.3 univ-atts attribute group

The "univ-atts" attribute group defines a set of common attributes available on most DITA elements.

The "univ-atts" group includes:
  • the attributes in the select-atts attribute group
  • the attributes in the id-atts attribute group
  • the attributes in the localization-atts attribute group
Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1.2 global-atts attribute group
Next topic: 3.4.1.4 id-atts attribute group


id-atts attribute group

3.4.1.4 id-atts attribute group

The "id-atts" attribute group includes attributes that enable the naming and referencing of elements in topics and maps.

Attributes

Name | Description | Data Type | Default Value | Required?
id | An anchor point. This ID is the target for references by href and conref attributes and for external applications that refer to DITA content. See ID attribute in the Architectural Specification for more details. | NMTOKEN | #IMPLIED | No
conref | This attribute is used to reference an ID on content that can be reused. See The conref attribute for examples and details about the syntax. | CDATA | #IMPLIED | No
conrefend | The conrefend attribute is used when reusing a range of elements through conref. The syntax is the same as for the conref attribute; see The conrefend attribute for examples. | CDATA | #IMPLIED | No
conaction | This attribute enables users to push content into a new location. See The conaction attribute for examples and details about the syntax. | (mark | pushafter | pushbefore | pushreplace | -dita-use-​conref-​target) | #IMPLIED | No
conkeyref | Allows conref to operate using a key instead of a URI. See The conkeyref attribute for more details about the syntax and behaviors. | CDATA | #IMPLIED | No
Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1.3 univ-atts attribute group
Next topic: 3.4.1.5 select-atts attribute group


select-atts attribute group

3.4.1.5 select-atts attribute group

The "select-atts" attribute group includes common metadata attributes, several of which support conditional processing (filtering and flagging) or the creation of new attribute domain specializations.

Attributes

Name | Description | Data Type | Default Value | Required?
props | Root attribute from which new metadata attributes can be specialized. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
base | A generic attribute that has no specific purpose. It is intended to act as a base for specialized attributes that have a simple value syntax like the conditional processing attributes (one or more alphanumeric values separated by whitespace), but is not itself a filtering or flagging attribute. The attribute takes a space-delimited set of values. However, when acting as a container for generalized attributes, the content model will be more complex; see Attribute generalization for more details. | CDATA | #IMPLIED | No
platform | Indicates operating system and hardware. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
product | Contains the name of the product to which the element applies. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
audience | Indicates the intended audience for the element. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
otherprops | This attribute can be used for any other properties that might be needed to describe an audience, or to provide selection criteria for the element. Alternatively, the props attribute may be specialized to provide a new metadata attribute instead of using the general otherprops attribute. This is a property attribute which supports conditional processing for filtering or flagging. If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The attribute takes a space-delimited set of values. | CDATA | #IMPLIED | No
importance | A range of values that describe an importance or priority attributed to an element. For example, in steps of a task, the attribute indicates whether a step is optional or required. This attribute is not used for DITAVAL-based filtering or flagging; applications may (but need not) use the importance value to highlight elements. | obsolete | deprecated | optional | default | low | normal | high | recommended | required | urgent | -dita-use-​conref-​target | #IMPLIED | No
rev | Indicates a revision level of an element that identifies when the element was added or modified. It may be used to flag outputs when it matches a run-time parameter; it cannot be used for filtering. It is not sufficient to be used for version control.If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. | CDATA | #IMPLIED | No
status | The modification status of the current element. | new | changed | deleted | unchanged | -dita-use-​conref-​target | #IMPLIED | No

Example

The "select-atts" attribute group is used within the DITA DTDs and Schemas as a common definition for attributes available to most elements for you to enable the content for improved retrievability or for selection. Some typical examples include:

The <keyword platform="Linux">chmod</keyword> command...

<ph product="WhiteknuckleHandsoap">Amalgamated Cleansers get the grime!</ph>

<msgph audience="programmer administrator">Divide by -1 error.</msgph>

<ph otherprops="java">When using Java, use
  <apiname>com.example.obscureclass</apiname> to calculate the value.</ph>

<p importance="recommended" rev="3.2">Update anti-virus software often.</p>

Note that, aside from those with pre-defined values, these attributes allow multiple values. For example, the audience attribute in the example indicates that the message is of interest to both programmers and administrators.

Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1.4 id-atts attribute group
Next topic: 3.4.1.6 localization-atts attribute group
Related concepts
2.1.2.3.2.1 Conditional processing attributes
2.1.3.6 Conditional processing (profiling)
2.1.3.6 Conditional processing (profiling)
2.1.4.3.8.1.5 Attribute domain module coding requirements
Related information
2.1.4.3 Specialization


localization-atts attribute group

3.4.1.6 localization-atts attribute group

The "localization-atts" attribute group defines a set of common attributes related to translation and localization. These attributes are available on most DITA elements.

Attributes

Name | Description | Data Type | Default Value | Required?
translate | Indicates whether the content of the element should be translated or not. The DITA architectural specification contains a list of each OASIS DITA element and its common processing default for the translate value. | yes | no | -dita-use-​conref-​target | #IMPLIED | No
xml:lang | Specifies the language of the element content. The xml:lang attribute and its values are described in the XML Recommendation at http://www.w3.org/TR/REC-xml/#sec-lang-tag. | language token or the null string | #IMPLIED | No
dir | Specifies the directionality of text: left-to-right (ltr, the processing default) or right-to-left (rtl). The value lro indicates an override of normal bidi text presentation, forcing the element into left-to-right mode; rlo overrides normal rules to force right-to-left presentation. See The dir attribute for more information on the dir attribute. | (ltr | rtl | lro | rlo | -dita-use-​conref-​target) | #IMPLIED | No
The translate, xml:lang, and dir attributes identify language-specific words or phrases for specific processing (or non-processing, in the case of translate="no").
<p>The cordial response to the question is
<q translate="no" xml:lang="de-de" dir="ltr">nein.</q></p>
Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1.5 select-atts attribute group
Next topic: 3.4.1.7 relational-atts attribute group
Related concepts
2.1.3.9 Translation and localization


relational-atts attribute group

3.4.1.7 relational-atts attribute group

The "relational-atts" attribute group includes attributes whose values may be used for representing navigational relationships. These attributes occur only on elements that represent relationships among DITA elements or between DITA elements and non-DITA resources.

Attributes

Name | Description | Data Type | Default Value | Required?
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
role | The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time. See The role attribute for information on supported values. The role attribute values sample and external are deprecated. | (parent | child | sibling | friend | next | previous | cousin | ancestor | descendant | sample | external | other | -dita-use-​conref-​target) | #IMPLIED | No
otherrole | Indicates an alternate role. This value is used when the role attribute is set to other. | CDATA | #IMPLIED | No

The "relational-atts" attribute group is used within the DITA DTDs as a common definition for attributes available to elements that represent topic-to-topic relationships. Some typical examples include:

<link type="task" role="child" href="how2uninst.dita" scope="local"/>
<link type="concept" role="parent" href="aboutTheThing.dita" scope="local"/>
Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1.6 localization-atts attribute group
Next topic: 3.4.1.8 topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups


rel-atts attribute group

3.4.1.7.1 rel-atts attribute group

The "rel-atts" attribute group is deprecated in favor of the relational-atts group, which adds new attributes to the original "rel-atts" group.
The "rel-atts" attribute group includes attributes whose values may be used for representing navigational relationships. These attributes occur only on elements that represent relationships between topics. Beginning with DITA 1.2, the parameter is deprecated in favor of the relational-atts group; it is still defined so that specializations which use this entity may upgrade more easily.

Attributes

Name | Description | Data Type | Default Value | Required?
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
role | The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time. See The role attribute for information on supported values. The role attribute values sample and external are deprecated. | (parent | child | sibling | friend | next | previous | cousin | ancestor | descendant | sample | external | other | -dita-use-​conref-​target) | #IMPLIED | No
otherrole | Indicates an alternate role. This value is used when the role attribute is set to other. | CDATA | #IMPLIED | No
Parent topic: 3.4.1.7 relational-atts attribute group
Previous topic: 3.4.1.7 relational-atts attribute group
Next topic: 3.4.1.8 topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups


topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups

3.4.1.8 topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups

The "topicref-atts", "topicref-atts-no-toc", and "topicref-atts-without-format" attribute groups represent collections of attributes used in numerous map elements. With two exceptions, the three groups are identical. Neither "topicref-atts" nor "topicref-atts-without-format" provides a default for the toc attribute, while "topicref-atts-no-toc" provides a default of "no". Both "topicref-atts" and "topicref-atts-no-toc" include the format attribute, while "topicref-atts-without-format" omits the format attribute to allow specialization authors to declare the format attribute with specific default values.

Attributes

Note: The table below describes the "topicref-atts" attribute group. The "topicref-atts-no-toc" group is the same, except for the toc attribute, which is modified to provide a default of "no". The "topicref-atts-without-format" group is also the same as "topicref-atts", except that it does not define the format attribute.
Name | Description | Data Type | Default Value | Required?
collection-type Collection types describe how links relate to each other. The processing default is "unordered", although no default is specified in the DTD or Schema.
unordered
Indicates that the order of the child topics is not significant.
sequence
Indicates that the order of the child topics is significant; output processors will typically link between them in order.
choice
Indicates that one of the children should be selected.
family
Represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.

Usage of the collection-type attribute on <reltable> and <relcolspec> is currently undefined and reserved for future use.

(unordered | sequence | choice | family | -dita-use-​conref-​target) #IMPLIED No
processing-role Describes the processing role of the referenced topic. The processing default is "normal". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
normal
Normal topic that is a readable part of the information.
resource-only
The topic is used as a resource for processing purposes, but is not a readable unit of information on its own. This topic should not be included in a rendered table of contents, and the topic should not be rendered on its own.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(normal | resource-only | -dita-use-​conref-​target) #IMPLIED No
type | Describes the target of a reference. See The type attribute for detailed information on supported values and processing implications. | CDATA | #IMPLIED | No
scope | The scope attribute identifies the closeness of the relationship between the current document and the target resource. See The scope attribute for more information on values. | (local | peer | external | -dita-use-​conref-​target) | #IMPLIED | No
locktitle If locktitle is set to "yes", the <navtitle> element or @navtitle attribute is used if it is present. Otherwise, the navtitle is ignored and the navigation title is retrieved from the referenced file.
Note: The @navtitle attribute is deprecated in favor of the <navtitle> element. When both a <navtitle> element and a navtitle attribute are specified, the <navtitle> element should be used.
yes
The navtitle in the map is used.
no
The navtitle or title of the topic is used. This is the processing default.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | -dita-use-​conref-​target) #IMPLIED No
format | The format attribute identifies the format of the resource being referenced. See The format attribute for details on supported values. | CDATA | #IMPLIED | No
linking Defines some specific linking characteristics of a topic's current location in the map. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
targetonly
A topic can only be linked to and cannot link to other topics.
sourceonly
A topic cannot be linked to but can link to other topics.
normal
A topic can be linked to and can link to other topics. Use this to override the linking value of a parent topic.
none
A topic cannot be linked to or link to other topics.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(targetonly | sourceonly | normal | none | -dita-use-​conref-​target) #IMPLIED No
toc | Specifies whether a topic appears in the table of contents (TOC). If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor. | (yes | no | -dita-use-​conref-​target) | #IMPLIED | No
print Specifies whether the topic should be included in a print-specific rendition, such as PDF. The processing default is "yes". If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
Include the topic in the print-oriented file.
no
Do not include the topic in a print-oriented file.
printonly
Only include the topic when rendering the DITA content in a print-oriented context; the topic should not be included in other contexts, such as when rendering as HTML.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
(yes | no | printonly | -dita-use-​conref-​target) #IMPLIED No
search Describes whether the target is available for searching. If the value is not specified locally, but is specified on an ancestor, the value will cascade from the closest ancestor.
yes
no
-dita-use-​conref-​target
(yes | no | -dita-use-​conref-​target) #IMPLIED No
chunk When a set of topics is transformed using a map, the chunk attribute allows multi-topic documents to be broken into smaller files and multiple individual topics to be combined into larger combined documents.

For a detailed description of the chunk attribute and its usage, see Chunking in the DITA Architectural Specification.

CDATA #IMPLIED No
Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1.7 relational-atts attribute group
Next topic: 3.4.1.9 Other common DITA attributes


Other common DITA attributes

3.4.1.9 Other common DITA attributes

The following attributes are not part of an entity group but are common to many elements.

Name | Description | Data Type | Default Value | Required?
keyref | Keyref provides a redirectable reference based on a key defined within a map. See The keyref attribute for information on using this attribute. | CDATA | #IMPLIED | No
outputclass | Names a role that the element is playing. The role must be consistent with the basic semantic and expectations for the element. In particular, the outputclass attribute can be used for styling during output processing; HTML output will typically preserve outputclass for CSS processing. | CDATA | #IMPLIED | No
class | Not for use by authors. If an editor displays class attribute values, do not edit them. The class attribute supports specialization. Its predefined values allow DITA tools to work correctly with ranges of related content. In a generalized DITA document the class attribute value in the generalized instance may differ from the default value for the class attribute for the element as given in the DTD or schema. See Element type specialization hierarchy declaration (the @class attribute) for more information. | CDATA | Default value differs for each element | Yes
xml:space | This attribute is provided on <pre>, <lines>, and on elements specialized from them. It ensures that parsers in editors and transforms respect the white space, including line-end characters, that is part of the data in those elements. It is intended to be part of the default properties of these elements, and not for authors to change or delete. | (preserve) | preserve | No
Parent topic: 3.4.1 Commonly referenced attribute groups
Previous topic: 3.4.1.8 topicref-atts, topicref-atts-no-toc, and topicref-atts-without-format attribute groups
Next topic: 3.4.2 Complex attribute definitions


Complex attribute definitions

3.4.2 Complex attribute definitions

Several DITA attributes require more explanation than can fit in a single table cell. Those attributes are collected here.

  • 3.4.2.1 The href attribute
    The href attribute is used by many elements to provide a reference to another DITA topic or map, to a specific element inside a DITA topic or map, or to an external Web page or other non-DITA resource.
  • 3.4.2.2 The keys attribute
    A keys attribute consists of one or more space-separated keys. Map authors define keys using a topicref or topicref specialization that contains the “keys” attribute. Each key definition introduces a global identifier for a resource referenced from a map. Keys resolve to the resources given as the href value on the key definition topicref element, to content contained within the key definition topicref element, or both.
  • 3.4.2.3 The keyref attribute
    The keyref attribute provides an indirect, late-bound reference to topics, to collections of topics (ditabase), to maps, to referenceable portions of maps, to non-DITA documents, to external URIs, or to XML content contained within a key definition topic reference. When the DITA content is processed, the key references are resolved using key definitions from DITA maps.
  • 3.4.2.4 The conref attribute
    This attribute is used to reference content that can be reused. It allows reuse of DITA elements, including topic or map level elements.
  • 3.4.2.5 The conaction attribute
    The conaction attribute allows users to push content from one topic into another. It causes the conref attribute to work in reverse, so that the content is pushed from the current topic into another, rather than pulled from another topic into the current one.
  • 3.4.2.6 The conrefend attribute
    The conrefend attribute is used when referencing a range of elements with the conref mechanism. The conref or conkeyref attribute points to the first element in the range, while conrefend points to the last element in the range. Although the start and end elements must be of the same type as the referencing element (or specialized from that element), the intermediary, contiguous nodes in the middle of the range do not have to be the same.
  • 3.4.2.7 The conkeyref attribute
    The conkeyref attribute provides an indirect content reference to topic elements, map elements, or elements within maps or topics. When the DITA content is processed, the key references are resolved using key definitions from DITA maps.
  • 3.4.2.8 The type attribute
    The type attribute is most often used on linking elements to describe the target of a cross-reference. It is also used on the note element to describe the type of the current note, and on several other elements for varying purposes.
  • 3.4.2.9 The format attribute
    The format attribute identifies the format of the resource being cross referenced. The processing default for format is "dita". If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor.
  • 3.4.2.10 The scope attribute
    The scope attribute identifies the closeness of the relationship between the current document and the target resource.
  • 3.4.2.11 The role attribute
    The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time.
Parent topic: 3.4 Attributes
Previous topic: 3.4.1.9 Other common DITA attributes
Next topic: 3.4.2.1 The href attribute


The href attribute

3.4.2.1 The href attribute

The href attribute is used by many elements to provide a reference to another DITA topic or map, to a specific element inside a DITA topic or map, or to an external Web page or other non-DITA resource. The references may be to DITA topics or elements within DITA topics or maps in the same document or in another document.

The value of a DITA href attribute must be a valid URI reference [RFC 3986]. It is an error if the value is not a valid URI reference. An implementation may (but need not) give an error message, and may (but need not) recover from this error condition by attempting to convert the value to a valid URI reference. Note that the path separator character in a URI is always the forward slash (“/”); the backward slash character (“\”) is not permitted unescaped within URIs.

In the case of a reference to a DITA resource, an href value consisting of a URI with no fragment identifier resolves to the document element in the referenced document. For the purposes of rendering, such as when a topicref reference to a DITA document is used to render the content as HTML, this means that all topics (and topic specializations) in the target document are included in the reference. For the purpose of linking, the reference resolves to the first (or only) topic (or topic specialization) in the document.

An href value consisting of a URI with a fragment identifier must have a valid DITA local identifier as the portion after the hash. A DITA local identifier consists of topicID/elementID for a subelement of a topic and of elementID for topics, maps, and map subelements.

Note that certain characters (including, but not limited to, #, ?, \, and space) are not permitted unescaped within URIs. Such characters must be percent-encoding (per RFC 3986) if there is a need to represent them within a string that is a URI. Also note that the “&” (ampersand) and “<” (greater than) characters are not permitted in XML attribute values, so they must be represented by appropriate character or entity references if there is a need to represent them within such a string. (Some tools may do the required encoding on the user's behalf while others may require the user to avoid the special characters or perform the encoding manually.)

Some examples of common href syntax in DITA include the following. Note that these examples represent only a few common scenarios, and are not all inclusive.
  • Target the first topic in a DITA document: href="file.dita"
  • Target a specific topic in a DITA document: href="file.dita#topicid"
  • Target a non-topic element inside a DITA topic: href="#topicid/elementid"
  • Target an element in a DITA map: href="myMap.ditamap#map-branch"
  • Target an image: href="exampleImage.jpg"
  • Target an external resource: href="http://www.example.org"
Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2 Complex attribute definitions
Next topic: 3.4.2.2 The keys attribute


The keys attribute

3.4.2.2 The keys attribute

A keys attribute consists of one or more space-separated keys. Map authors define keys using a topicref or topicref specialization that contains the “keys” attribute. Each key definition introduces a global identifier for a resource referenced from a map. Keys resolve to the resources given as the href value on the key definition topicref element, to content contained within the key definition topicref element, or both.

The @keys attribute uses the following syntax:
  • The value of the @keys attribute is one or more space separated key names.
  • Key names consist of characters that are legal in a URI. The case of key names is significant.
  • The following characters are prohibited in key names: "{", "}", "[", "]", "/", "#", "?", and whitespace characters.

A key may not resolve to sub-topic elements, although a keyref attribute may do so by combining a key with a sub-topic element id.

Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.1 The href attribute
Next topic: 3.4.2.3 The keyref attribute
Related concepts
2.1.3.4.3 Key-based addressing


The keyref attribute

3.4.2.3 The keyref attribute

The keyref attribute provides an indirect, late-bound reference to topics, to collections of topics (ditabase), to maps, to referenceable portions of maps, to non-DITA documents, to external URIs, or to XML content contained within a key definition topic reference. When the DITA content is processed, the key references are resolved using key definitions from DITA maps.

For elements that may only refer to topics or non-DITA resources, the value of the keyref attribute is a key name. For elements that may refer to elements within maps or topics, the value of the keyref attribute is a key name, a solidus ("/"), and the ID of the target element, where the key name must be bound to either the map or topic that contains the target element.

Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.2 The keys attribute
Next topic: 3.4.2.4 The conref attribute
Related concepts
2.1.3.4.3 Key-based addressing


The conref attribute

3.4.2.4 The conref attribute

This attribute is used to reference content that can be reused. It allows reuse of DITA elements, including topic or map level elements.

The value of the conref attribute must be a URI reference to a DITA element. See URI-based (direct) addressing for details on specifying URI references to DITA elements. As with other DITA references, a conref attribute that references a resource without an ID is treated as a reference to the first topic or map in the document.

Note: When using the conref attribute on an element, the content of that element is ignored. For example, if a phrase is marked up like this:
<ph conref="#topic/ph">Something</ph>
the word "Something" will be replaced by the content of the referenced <ph> element.
  • 3.4.2.4.1 Using the -dita-use-conref-target value
    The value -dita-use-conref-target is available on enumerated attributes and may also be specified on other attributes. When an element uses conref to pull in content, for any of its attributes assigned a value of "-dita-use-conref-target", the resulting value for those attributes should also be pulled in from the referenced element.
Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.3 The keyref attribute
Next topic: 3.4.2.4.1 Using the -dita-use-conref-target value
Related concepts
2.1.3.5 Content inclusion (conref)


Using the -dita-use-conref-target value

3.4.2.4.1 Using the -dita-use-conref-target value

The value -dita-use-conref-target is available on enumerated attributes and may also be specified on other attributes. When an element uses conref to pull in content, for any of its attributes assigned a value of "-dita-use-conref-target", the resulting value for those attributes should also be pulled in from the referenced element.

Ordinarily, when an element uses conref, any other attributes specified locally will be preserved when the reference is resolved. This causes problems when attributes are required, because required attributes must be specified regardless of whether the conref attribute is present. The purpose of the -dita-use-conref-target value is to allow the author to specify a value for a required attribute while still allowing the conref resolution process to use the matching attribute from the referenced element. The value has the same result when the attribute is not required.

This example shows a map where the topichead element uses conref. It specifies the navtitle attribute as well as the toc attribute. In the resolved element, navtitle is not preserved because it uses -dita-use-conref-target; the toc attribute overrides the toc attribute on the referenced element using normal conref resolution rules.

Figure 1. Pre-resolution
<map><title>Conref demonstration</title>
  <topichead id="heading"
             navtitle="This is a heading"
             toc="yes"
             print="yes">
    <topicref href="topic.dita" navtitle="content"/>
  </topichead>

  <topichead conref="#heading"
             navtitle="-dita-use-conref-target"
             toc="no">
  </topichead>
</map>
Figure 2. Effective result post-resolution
<map><title>Conref demonstration</title>
  <topichead id="heading"
             navtitle="This is a heading"
             toc="yes"
             print="yes">
    <topicref href="topic.dita" navtitle="content"/>
  </topichead>

  <topichead navtitle="This is a heading"
             toc="no"
             print="yes">
    <topicref href="topic.dita" navtitle="content"/>
  </topichead>
</map>
Parent topic: 3.4.2.4 The conref attribute
Previous topic: 3.4.2.4 The conref attribute
Next topic: 3.4.2.5 The conaction attribute
Related concepts
2.1.3.5 Content inclusion (conref)


The conaction attribute

3.4.2.5 The conaction attribute

The conaction attribute allows users to push content from one topic into another. It causes the conref attribute to work in reverse, so that the content is pushed from the current topic into another, rather than pulled from another topic into the current one.

Note: In the descriptions below, the word target always refers to the element referenced by a conref attribute.

There are three possible functions using the conaction attribute: replacing an element, pushing content before an element, and pushing content after an element. The conaction attribute always declares the desired function while the conref attribute provides the target of the reference using the standard conref syntax.

In each case, an element pushed using conref must be of the same type as, or more specialized than, its target. If the pushed element is more specialized than the target, then it should be generalized when the conref is resolved. This ensures that the content will be valid in the target topic.

  • It is valid to push using conref when the two elements involved are of the same type. For example, a step element may use conref push with another step as the target of the conref.
  • The target element may be more general than the source. For example, it is legal to push a <step> element to replace a general list item (li); the step element should be generalized back to a list item during the process.
  • It is not possible to push a more general element into a specialized context. For example, it is not legal to push a list item (<li>) in order to replace a <step>, because the list item allows many items that are not valid in the specialized context.

Replacing content in another topic

When the conaction attribute is set to "pushreplace", the source element will replace the target specified on the conref attribute. The pushed content remains in the source topic where it was originally authored.

For example, assume that a task in example.dita has the id "example", and contains a step with the id "b":
<task id="example" xml:lang="en">
  <title>Example topic</title>
  <taskbody>
    <steps>
      <step id="a"><cmd>A</cmd></step>
      <step id="b"><cmd>B</cmd></step>
      <step id="c"><cmd>C</cmd></step>
    </steps>
  </taskbody>
</task>
In order to replace the step with id="b", another topic must combine a conaction value of "pushreplace" with a conref attribute that references this step:
<task id="other" xml:lang="en">
  ...
   <step conaction="pushreplace"
         conref="example.dita#example/b">
     <cmd>Updated B</cmd>
   </step>
  ...
</task>
The result will be an updated version of example.dita which contains the pushed step:
<task id="example" xml:lang="en">
  <title>Example topic</title>
  <taskbody>
    <steps>
      <step id="a"><cmd>A</cmd></step>
      <step id="b"><cmd>Updated B</cmd></step>
      <step id="c"><cmd>C</cmd></step>
    </steps>
  </taskbody>
</task>

When resolving a conref push action, attributes are resolved using the same precedence as for normal conref, with one exception. Attributes on the element with the conref attribute (in this case, the source doing the push) will take priority over those on the referenced element. The exception is that if the source element does not specify an ID, the ID on the referenced element remains; if the source element does specify an ID then that replaces the ID on the referenced element.

Note: It is an error for two source topics to replace the same element. Applications may, but need not, warn users if more than one element attempts to replace a single target.

Pushing content before or after another element

Setting the conaction attribute to "pushbefore" allows an element to be pushed before the element referenced by the conref attribute. Likewise, setting the conaction attribute to "pushafter" allows an element to be pushed after the element referenced by the conref attribute. Multiple sources may push content before or after the same target; the order in which that content is pushed is undefined.

When an element is pushed before or after a target, the resulting document will have at least two of that element. Because this is not always valid, a document attempting to push content before or after a target must take an extra step to ensure that the result will be valid. The extra step makes use of the conaction="mark" value.

When pushing before, the conref attribute itself looks just as it did when replacing, but the conaction attribute is set to "mark" because it is marking the target element. This element remains empty; its purpose is to ensure that it is legal to have more than one of the current element. Immediately before the element which marks the target, you will place the content that you actually want to push. This element will set the conaction attribute to "pushbefore".

When pushing after, the procedure is the same, except that the order of the elements is reversed. The element with conaction="pushafter" comes immediately after the element which marks the target.

Attributes on the element which is pushed (the one with conaction="pushbefore") must be retained on the target, apart from the conaction attribute itself. If this causes the result document to end up with duplicate IDs, an application may (but need not) recover by dropping the duplicate ID, modifying it to ensure uniqueness, or warning the user.

Note: The following restrictions apply when pushing content before or after an element:
  • The elements that use conaction="mark" and conaction="pushbefore" must be the same type as each other and must appear in sequence. This restriction prevents a topic from trying to push a <body> element before or after another <body> element, because it is not valid to have two body elements in sequence.
  • The container elements of the source and target must match, or the container of the source element may be a specialization of the target's container. This is also to ensure validity of the target; for example, while it is possible to include multiple titles in a section, it is not possible to do so in a figure. Comparing the parents prevents a second section title from being pushed before a figure title (the resulting figure would not be valid DITA). This restriction only applies to the pushbefore or pushafter actions, not to the pushreplace action.

When content is pushed from one topic to another, it is still rendered in the original context. Processors may delete empty the element that with the conaction="mark" attribute. In order to push content from a topic without actually rendering that topic on its own, the topic should be referenced from the map with the processing-role attribute set to "resource-only".

Example: pushing an element before the target

The following example pushes a step before "b" in the example.dita file shown above.
  <step conaction="pushbefore"><cmd>Do this before B</cmd></step>
  <step conaction="mark"
        conref="example.dita#example/b"/>
The result contains the pushed step element before "b".
<task id="example" xml:lang="en">
  <title>Example topic</title>
  <taskbody>
    <steps>
      <step id="a"><cmd>A</cmd></step>
      <step><cmd>Do this before B</cmd></step>
      <step id="b"><cmd>B</cmd></step>
      <step id="c"><cmd>C</cmd></step>
    </steps>
  </taskbody>
</task>

Example: pushing an element after the target

Pushing an element after a target is exactly the same as pushing before, except that the order of the "mark" element and the pushed element are reversed.
  <step conaction="mark"
        conref="example.dita#example/b"/>
  <step conaction="pushafter"><cmd>Do this AFTER B</cmd></step>
In this case the resulting document has the pushed content after step b:
<task id="example" xml:lang="en">
  <title>Example topic</title>
  <taskbody>
    <steps>
      <step id="a"><cmd>A</cmd></step>
      <step id="b"><cmd>B</cmd></step>
      <step><cmd>Do this AFTER B</cmd></step>
      <step id="c"><cmd>C</cmd></step>
    </steps>
  </taskbody>
</task>

Combining conaction with conkeyref or conrefend

The conkeyref attribute may be used as an indirect way to specify a conref target. If the conkeyref attribute is specified on an element that also uses the conaction attribute, the conkeyref attribute is used to determine the target of the conref push (as it would normally be used to determine the target of conref).

The conref push function does not provide the ability to push a range of elements, so it is an error to specify the conrefend attribute together with the conaction attribute. If the two are specified together an application may (but need not) recover by warning the user and ignoring the conrefend attribute.

Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.4.1 Using the -dita-use-conref-target value
Next topic: 3.4.2.6 The conrefend attribute


The conrefend attribute

3.4.2.6 The conrefend attribute

The conrefend attribute is used when referencing a range of elements with the conref mechanism. The conref or conkeyref attribute points to the first element in the range, while conrefend points to the last element in the range. Although the start and end elements must be of the same type as the referencing element (or specialized from that element), the intermediary, contiguous nodes in the middle of the range do not have to be the same.

Using conref together with conrefend

Several items must be taken into account when using or implementing conrefend.

  • Processors will resolve the range by pulling in the start target and following sibling DOM nodes across to and including the end target.
  • The start and end elements of a range must be of the same type as the referencing element, or they must be generalizable to the referencing element. For example, conref and conrefend may point from <li> to other <li> elements, or to specializations of <li> such as <step>.
  • As with conref, if the conrefend points to a more specialized version of the referencing element, applications should generalize the target when resolving.
  • It is not valid to use conrefend to point to a more general version of an element (such as using step to reference an li element).
  • Other nodes (such as elements or text) between the start and end of a range do not have to match the referencing element.
  • The start and end elements in a range must share the same parent.
  • The parent of the referencing element must be the same as the parent of the target range, OR the parent of the target range may be a specialized version of the reference's parent. For example, it is possible to pull a range from conbody into body, because conbody is specialized from body. It is not possible to pull a range from body into conbody, because the result may not be valid in conbody.
  • With single conref, an id attribute from the target will not be preserved on the resolved content. With a range, an id on both the start and the end will not be preserved. Id attributes on intermediate or child nodes should be preserved, although if this results in duplicate id values, an application may or may not recover by changing the id or by warning the user.
  • With a single conref, attributes specified locally may be used to override attributes on the referenced content. With a conref range, the same is true, with the following clarifications:
    • When an id attribute is specified on the referencing element, it will only be preserved on the first element of the resolved range.
    • When other attributes are specified, they will only apply to referenced elements of the same type. For example, if <step> is used to pull in a range of sequential step elements, locally specified attributes apply to all steps in the range. If <ol> is used to pull in a series of (ol, p, ol), locally specified attributes apply only to the <ol> elements in that range.

Example: reusing a set of list items

Figure 1. List example: Source topic.dita with ids
<topic id="x">
     ...
     <body>
         <ol>
             <li id="apple">A</li>
             <li id="bear">B</li>
             <li id="cat">C</li>
             <li id="dog">D</li>
             <li id="eel">E</li>
         </ol>
     </body>
 </topic>
Figure 2. List example: Reusing topic with conrefs
 <topic id="y">
     ...
     <body>
         <ol>
             <li>My own first item</li>
             <li conref="topic.dita#x/bear" conrefend="topic.dita#x/dog"/>
             <li>And a different final item</li>
         </ol>
     </body>
 </topic>
Figure 3. List example: Processed result of reusing topic
 <topic id="y">
     ...
     <body>
         <ol>
             <li>My own first item</li>
             <li>B</li>
             <li id="cat">C</li>
             <li>D</li>
             <li>And a different final item</li>
         </ol>
     </body>
</topic>

Example: Reusing a set of blocks

Figure 4. Block level example: Source topic.dita with ids
<topic id="x">
     ...
     <body>
   <p id="p1">First para</p>
      <ol id="mylist">
     <li id="apple">A</li>
     <li id="bear">B</li>
     <li id="cat">C</li>
     <li id="dog">D</li>
     <li id="eel">E</li>
   </ol>
   <p id="p2">Second para</p>
     </body>
 </topic>
Figure 5. Block level example: Reusing topic with conrefs
 <topic id="y">
     ...
     <body>
         <p conref="topic.dita#x/p1" conrefend="topic.dita#x/p2"/>
     </body>
 </topic>
Figure 6. Block level example: Processed result of reusing topic
 <topic id="y">
     ...
     <body>
    <p>First para</p>
       <ol id="mylist">
      <li id="apple">A</li>
      <li id="bear">B</li>
      <li id="cat">C</li>
      <li id="dog">D</li>
      <li id="eel">E</li>
    </ol>
    <p>Second para</p>
     </body>
</topic>

Using conrefend together with conkeyref

When the conkeyref attribute is used in place of conref, a key is used to address the target of the reference. The conrefend attribute, which indicates the end of a conref range, may not use a key. Instead the the map or topic element addressed by the key name component of the conkeyref is used in place of whatever map or topic element is addressed by the conrefend attribute.

For example, if the value of the conkeyref attribute is "config/step1" and the value of the conrefend is "defaultconfig.dita#config/laststep", the conref range will end with the step that has id="laststep" in whatever topic is addressed by the key name "config". If the key name "config" is not defined, and the conref attribute itself is not present for fallback, the conrefend attribute is ignored.

Example: Combining conrefend with conkeyref

Figure 7. Defining and referencing a key with conkeyref

In this example the key "xmp" is defined as the first topic in the file examples.dita.

<map>
  <!-- ... -->
  <keydef keys="xmp" href="examples.dita"/>
  <!-- ... -->
</map>

examples.dita:
<topic id="examples">
  <title>These are examples</title>
  <body>
    <ul>
      <li id="first">A first example</li>
      <li>Another trivial example</li>
      <li id="last">Final example</li>
    </ul>
  </body>
</topic>
To reuse these list items by using the key, the conkeyref attribute combines the key itself with the sub-topic id (first) to define the start of the range. The conrefend attribute defines a default high-level object along with the sub-topic id (last) that ends the range:
  <li conkeyref="xmp/first"
      conrefend="default.dita#default/last"/>

The conkeyref attribute uses a key to reference the first topic in examples.dita, so the range begins with the object examples.dita#examples/first. The high-level object in the conrefend attribute (default.dita#default) is replaced with the object represented by the key (the first topic in examples.dita), resulting in a range that ends with the object examples.dita#examples/last.

Figure 8. Combining conref, conkeyref, and conrefend

When conref, conkeyref, and conrefend are all specified, the key value takes priority.

  <li conkeyref="thisconfig/start"
      conref="standardconfig.dita#config/start"
      conrefend="standardconfig.dita#config/end"/>
  • If the key "thisconfig" is defined as mySpecialConfig.dita#myconfig, then the range will go from the list item with id="start" to the list item with id="end" in the topic mySpecialConfig.dita#myconfig.
  • If the key "thisconfig" is defined as myConfig.dita, then the range will go from the list item with id="start" to the list item with id="end" within the first topic in myConfig.dita.
  • If the key "thisconfig" is not defined, then the unchanged conref and conrefend attributes are used as fallback. In that case, the range will go from the list item with id="start" to the list item with id="end" within the topic standardconfig.dita#config.

Error conditions

When encountering an error condition, an implementation may but need not issue an error message.

Condition or Issue | Result
The conref attribute cannot be resolved in the target document (the target element may have been removed or its ids has changed). | The conref is ignored.
The conrefend attribute cannot be resolved in the target document (the target element may have been removed or its id has changed). | Range cannot be resolved, optional recovery processes the result as a simple conref.
Start and end elements are not siblings in the target document. | If the start element exists, optional recovery processes the result as a simple conref.
End element occurs before the start element in the target document. | If the start element exists, optional recovery processes the result as a simple conref.
An element has a conrefend attribute but is missing the conref | No result.
Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.5 The conaction attribute
Next topic: 3.4.2.7 The conkeyref attribute


The conkeyref attribute

3.4.2.7 The conkeyref attribute

The conkeyref attribute provides an indirect content reference to topic elements, map elements, or elements within maps or topics. When the DITA content is processed, the key references are resolved using key definitions from DITA maps.

For content references from map elements to map elements or topic elements to topic elements, the value of the conkeyref attribute is a key name, where the key must be bound to a map element (for references from map elements) or a topic element (for references from topic elements). For all other elements, the value of the conkeyref attribute is a key name, an optional solidus ("/"), and the ID of the target element, where the key name must be bound to the map or topic that contains the topic element.

When the key name specified by the conkeyref attribute is not defined and the element also specifies a conref attribute, the conref attribute is used to determine the content reference relationship. If no conref attribute is specified there is no content reference relationship. Processors should issue a warning when a conkeyref reference cannot be resolved and there is no conref attribute to use as a fallback. Processors may issue a warning when a conkeyref cannot be resolved to an element and a specified conref is used as a fallback.

The conrefend attribute, which defines the end of a conref range, may not include a key. Instead the map or topic element addressed by the key name component of the conkeyref is used in place of whatever map or topic element is addressed by the conrefend attribute. See Using conrefend together with conkeyref for more information and for examples of this behavior.

Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.6 The conrefend attribute
Next topic: 3.4.2.8 The type attribute


The type attribute

3.4.2.8 The type attribute

The type attribute is most often used on linking elements to describe the target of a cross-reference. It is also used on the note element to describe the type of the current note, and on several other elements for varying purposes.

The descriptions for the type attribute on linking elements and on note are too long to fit in the usual attribute table, so they are included in this section; for other elements, such as audience, copyright, or object, the description can be found with the element.

Using type on a linking element

The type attribute describes the target of a cross-reference and may generate cross-reference text based on that description. Only the <xref> element can link to content below the topic level: other types of linking can target whole topics, but not parts of topics. Typically <xref> should also be limited to topic-level targets, unless the output is primarily print-oriented. Web-based referencing works best at the level of whole topics, rather than anchor locations within topics.

If not explicitly specified on an element, the type attribute value cascades from the closest ancestor element. If there is no explicit value for the type attribute on any ancestor, a default value of “topic” is used. During output processing for references to DITA topics (format="dita"), it is an error if the actual type of a DITA topic and the explicit, inherited, or default value for the type attribute are not the same as or a specialization of the type attribute value. In this case, an implementation may (but need not) give an error message, and may (but need not) recover from this error condition by using the type attribute value. During output processing for references to non-DITA objects (i.e., either scope is not “local” or format is neither “dita” nor “ditamap”) or other cases where the type of the referenced item cannot be determined from the item itself, the explicit, inherited, or default value for the type attribute is used without any validation. When a referencing element is first added to or updated in a document, DITA aware editors may, but are not required to, set the type attribute value based on the actual type of a referenced DITA topic.

If the type attribute is specified when referencing DITA content, it should match one of the values in the referenced element's class attribute. The type value may be an unqualified local name (e.g. "fig") or a qualified name exactly as specified in the class attribute (e.g., "mymodule/mytype"). Processors may ignore qualified names or may consider only the local name.

For example, if type="topic", the link could be to a generic topic, or any specialization of topic, including concept, task, and reference. Applications may, but need not, issue a warning when the specified or inherited type attribute value does not match the target (or a specialization ancestor of the target).

Some possible values for use on the xref element and its specializations include:

fig
Indicates a link to a figure.
table
Indicates a link to a table.
li
Indicates a link to an ordered list item.
fn
Indicates a link to a footnote.
section
Indicates a link to a section.

Other values that may be used on any linking element include:

concept, task, reference, topic
Cross-reference to a topic type.
(no value)
The processor should retrieve the actual type from the target if available. If the type cannot be determined, the default should be treated as "topic".
-dita-use-conref-target
See Using the -dita-use-conref-target value for more information.

Other values can be used to indicate other types of topics or elements as targets. Processing is only required to support the above list or specializations of types in that list. Supporting additional types as targets may require the creation of processing overrides.

Using type in a note element

In a note element, this defines the type of note. For example, if the note is a tip, the word Tip may be used to draw the reader's attention to it. The values danger, warning, and notice have new or additional meanings with DITA 1.2 that are based on ANSI Z535 and ISO 3864 regulations.

If type is set to other, the value of the othertype attribute may be used. If you use othertype, many processors will require additional information on how to process the value. Allowable values for the type attribute are:

note
This is just a note.
attention
Please pay extra attention to this note.
caution
Care is required when proceeding.
danger
Important! Be aware of this before doing anything else. When used with the hazardstatement element, this indicates an imminently hazardous situation which, if not avoided, will result in death or serious injury.
fastpath
This note will speed you on your way.
important
This note is important.
notice
Indicates a potential situation which, if not avoided, may result in an undesirable result or state.
remember
Don't forget to do what this note says.
restriction
You can't do what this note says.
tip
This is a fine little tip.
warning
Indicates a potentially hazardous situation. When used with the hazardstatement element, this indicates a situation which, if not avoided, could result in death or serious injury.
other
This is something other than a normal note.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.7 The conkeyref attribute
Next topic: 3.4.2.9 The format attribute


The format attribute

3.4.2.9 The format attribute

The format attribute identifies the format of the resource being cross referenced. The processing default for format is "dita". If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor.

Using the format attribute

Possible values for this attribute include:

dita
The destination uses DITA topic markup or markup specialized from a DITA topic. Unless otherwise specified, the corresponding default type will be treated as "topic."
html
The format of the linked-to resource is HTML or XHTML.
pdf
The format of the linked-to resource is PDF (opens a new window).
ditamap
The linked-to resource is a DITA map. It represents the referenced hierarchy at the current point in the referencing map. References to other maps may occur at any point in a map, but because relationship tables are only valid as children of a map, referenced relationship tables are treated as children of the referencing map.
(no value)
Processors default to "dita"

For other formats, you can use the file extension without the "." (for example, in a link to file "readme.txt", use "txt" as the value).

Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.8 The type attribute
Next topic: 3.4.2.10 The scope attribute


The scope attribute

3.4.2.10 The scope attribute

The scope attribute identifies the closeness of the relationship between the current document and the target resource.

  • Set scope to local when the resource is part of the current set of content.
  • Set scope to peer when the resource is part of the current set of content but is not accessible at build time. An implementation may choose to open such resources in the same browser window to distinguish them from those with scope set to external.
  • Set scope to external when the resource is not part of the current information set and should open in a new browser window.
  • See Using the -dita-use-conref-target value for more information on -dita-use-conref-target.

If no value is specified, but the attribute is specified on an ancestor within a map or within the related-links section, the value will cascade from the closest ancestor. The processing default is local.

Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.9 The format attribute
Next topic: 3.4.2.11 The role attribute


The role attribute

3.4.2.11 The role attribute

The role attribute defines the role the target topic plays in relationship with the current topic. For example, in a parent/child relationship, the role would be "parent" when the target is the parent of the current topic, and "child" when the target is the child of the current topic. This structure could be used to sort and classify links at display time.

Supported values

Allowable values for the role attribute are:

parent
Indicates a link to a topic that is a parent of the current topic.
child
Indicates a link to a direct child such as a directly nested or dependent topic.
sibling
Iindicates a link between two children of the same parent topic.
friend
Indicates a link to a similar topic that is not necessarily part of the same hierarchy.
next
Indicates a link to the next topic in a sequence.
previous
Indicates a link to the previous topic in a sequence.
cousin
Indicates a link to another topic in the same hierarchy that is not a parent, child, sibling, next, or previous.
ancestor
Indicates a link to a topic above the parent topic.
descendant
Indicates a link to a topic below a child topic.
sample
Deprecated.
external
Deprecated--use the scope="external" attribute to indicate external links.
other
Indicates any other kind of relationship or role. Enter that role as the value for the otherrole attribute.
-dita-use-​conref-​target
See Using the -dita-use-conref-target value for more information.
Parent topic: 3.4.2 Complex attribute definitions
Previous topic: 3.4.2.10 The scope attribute
Next topic: 3.5 Element quick reference


Element quick reference

3.5 Element quick reference

  • 3.5.1 Base DITA elements, A to Z
    This section provides links to all of the base DITA elements in alphabetical order.
  • 3.5.2 Technical content elements, A to Z
    This section provides an alphabetized list of links to all elements in the technical content subject area.
  • 3.5.3 Learning and training elements, A to Z
    This topic provides an alphabetical listing of all elements in the Learning and Training group.
  • 3.5.4 All DITA 1.2 elements, A to Z
    This section provides links to all of the elements in DITA 1.2, in alphabetical order.
Parent topic: 3 Language reference
Previous topic: 3.4.2.11 The role attribute
Next topic: 3.5.1 Base DITA elements, A to Z


Base DITA elements, A to Z

3.5.1 Base DITA elements, A to Z

This section provides links to all of the base DITA elements in alphabetical order.

  • abstract
  • alt
  • anchor
  • anchorid
  • anchorkey
  • anchorref
  • area
  • attributedef
  • audience
  • author
  • b
  • body
  • bodydiv
  • boolean
  • brand
  • category
  • cite
  • colspec
  • component
  • consequence
  • coords
  • copyrholder
  • copyright
  • copyryear
  • created
  • critdates
  • data-about
  • data
  • dd
  • ddhd
  • defaultSubject
  • desc
  • dita
  • dl
  • dlentry
  • dlhead
  • draft-comment
  • dt
  • dthd
  • elementdef
  • entry
  • enumerationdef
  • example
  • exportanchors
  • featnum
  • fig
  • figgroup
  • fn
  • foreign
  • hasInstance
  • hasKind
  • hasNarrower
  • hasPart
  • hasRelated
  • hazardstatement
  • hazardsymbol
  • howtoavoid
  • i
  • image
  • imagemap
  • index-base
  • index-see-also
  • index-see
  • index-sort-as
  • indexterm
  • indextermref
  • itemgroup
  • keydef
  • keyword
  • keywords
  • li
  • lines
  • link
  • linkinfo
  • linklist
  • linkpool
  • linktext
  • longdescref
  • longquoteref
  • lq
  • map
  • mapref
  • messagepanel
  • metadata
  • navref
  • navtitle
  • no-topic-nesting
  • note
  • object
  • ol
  • othermeta
  • p
  • param
  • permissions
  • ph
  • platform
  • pre
  • prodinfo
  • prodname
  • prognum
  • prolog
  • publisher
  • q
  • related-links
  • relatedSubjects
  • relcell
  • relcolspec
  • relheader
  • relrow
  • reltable
  • required-cleanup
  • resourceid
  • revised
  • row
  • schemeref
  • searchtitle
  • section
  • sectiondiv
  • series
  • shape
  • shortdesc
  • simpletable
  • sl
  • sli
  • source
  • state
  • stentry
  • sthead
  • strow
  • sub
  • subjectCell
  • subjectHead
  • subjectHeadMeta
  • subjectRel
  • subjectRelHeader
  • subjectRelTable
  • subjectRole
  • subjectScheme
  • subjectdef
  • subjectref
  • sup
  • table
  • tbody
  • term
  • text
  • tgroup
  • thead
  • title
  • titlealts
  • tm
  • topic
  • topicCell
  • topicSubjectHeader
  • topicSubjectRow
  • topicSubjectTable
  • topicapply
  • topicgroup
  • topichead
  • topicmeta
  • topicref
  • topicset
  • topicsetref
  • topicsubject
  • tt
  • typeofhazard
  • u
  • ul
  • unknown
  • vrm
  • vrmlist
  • xref
Parent topic: 3.5 Element quick reference
Previous topic: 3.5 Element quick reference
Next topic: 3.5.2 Technical content elements, A to Z


Technical content elements, A to Z

3.5.2 Technical content elements, A to Z

This section provides an alphabetized list of links to all elements in the technical content subject area.

  • abbreviated-form
  • abbrevlist
  • addressdetails
  • administrativearea
  • amendments
  • apiname
  • appendices
  • appendix
  • approved
  • authorinformation
  • backmatter
  • bibliolist
  • bookabstract
  • bookchangehistory
  • bookevent
  • bookeventtype
  • bookid
  • booklibrary
  • booklist
  • booklists
  • bookmap
  • bookmeta
  • booknumber
  • bookowner
  • bookpartno
  • bookrestriction
  • bookrights
  • booktitle
  • booktitlealt
  • chapter
  • chdesc
  • chdeschd
  • chhead
  • choice
  • choices
  • choicetable
  • choption
  • choptionhd
  • chrow
  • closereqs
  • cmd
  • cmdname
  • codeblock
  • codeph
  • coderef
  • colophon
  • completed
  • conbody
  • conbodydiv
  • concept
  • contactnumber
  • contactnumbers
  • context
  • copyrfirst
  • copyrlast
  • country
  • day
  • dedication
  • delim
  • draftintro
  • edited
  • edition
  • emailaddress
  • emailaddresses
  • esttime
  • figurelist
  • filepath
  • firstname
  • fragment
  • fragref
  • frontmatter
  • generationidentifier
  • glossAbbreviation
  • glossAcronym
  • glossAlt
  • glossAlternateFor
  • glossBody
  • glossPartOfSpeech
  • glossProperty
  • glossScopeNote
  • glossShortForm
  • glossStatus
  • glossSurfaceForm
  • glossSymbol
  • glossSynonym
  • glossUsage
  • glossarylist
  • glossdef
  • glossentry
  • glossgroup
  • glossref
  • glossterm
  • groupchoice
  • groupcomp
  • groupseq
  • honorific
  • indexlist
  • info
  • isbn
  • kwd
  • lastname
  • locality
  • localityname
  • mainbooktitle
  • maintainer
  • menucascade
  • middlename
  • month
  • msgblock
  • msgnum
  • msgph
  • namedetails
  • noconds
  • nosafety
  • nospares
  • nosupeq
  • nosupply
  • notices
  • oper
  • option
  • organization
  • organizationinfo
  • organizationname
  • organizationnamedetails
  • otherinfo
  • parml
  • parmname
  • part
  • pd
  • perscat
  • perskill
  • person
  • personinfo
  • personname
  • personnel
  • plentry
  • postalcode
  • postreq
  • preface
  • prelreqs
  • prereq
  • printlocation
  • propdesc
  • propdeschd
  • properties
  • property
  • prophead
  • proptype
  • proptypehd
  • propvalue
  • propvaluehd
  • pt
  • published
  • publisherinformation
  • publishtype
  • refbody
  • refbodydiv
  • reference
  • refsyn
  • repsep
  • reqcond
  • reqconds
  • reqcontp
  • reqpers
  • result
  • reviewed
  • revisionid
  • safecond
  • safety
  • screen
  • sep
  • shortcut
  • spare
  • spares
  • sparesli
  • started
  • step
  • stepresult
  • steps-informal
  • steps-unordered
  • steps
  • stepsection
  • stepxmp
  • substep
  • substeps
  • summary
  • supeqli
  • supequi
  • supequip
  • supplies
  • supply
  • supplyli
  • synblk
  • synnote
  • synnoteref
  • synph
  • syntaxdiagram
  • systemoutput
  • tablelist
  • task
  • taskbody
  • tested
  • thoroughfare
  • toc
  • trademarklist
  • tutorialinfo
  • uicontrol
  • url
  • urls
  • userinput
  • var
  • varname
  • volume
  • wintitle
  • year
Parent topic: 3.5 Element quick reference
Previous topic: 3.5.1 Base DITA elements, A to Z
Next topic: 3.5.3 Learning and training elements, A to Z


Learning and training elements, A to Z

3.5.3 Learning and training elements, A to Z

This topic provides an alphabetical listing of all elements in the Learning and Training group.

  • lcAge
  • lcAnswerContent
  • lcAnswerOption
  • lcAnswerOptionGroup
  • lcArea
  • lcAreaCoords
  • lcAreaShape
  • lcAssessment
  • lcAsset
  • lcAttitude
  • lcAudience
  • lcBackground
  • lcCIN
  • lcChallenge
  • lcClassroom
  • lcClient
  • lcConstraints
  • lcCorrectResponse
  • lcDelivDate
  • lcDelivery
  • lcDownloadTime
  • lcDuration
  • lcEdLevel
  • lcFeedback
  • lcFeedbackCorrect
  • lcFeedbackIncorrect
  • lcFileSizeLimitations
  • lcGapAnalysis
  • lcGapItem
  • lcGapItemDelta
  • lcGeneralDescription
  • lcGoals
  • lcGraphics
  • lcHandouts
  • lcHotspot
  • lcHotspotMap
  • lcInstruction
  • lcInstructornote
  • lcInteraction
  • lcInteractionBase
  • lcIntervention
  • lcInterventionItem
  • lcIntro
  • lcItem
  • lcJtaItem
  • lcKnowledge
  • lcLMS
  • lcLearnStrat
  • lcLom
  • lcMatchTable
  • lcMatching
  • lcMatchingHeader
  • lcMatchingItem
  • lcMatchingItemFeedback
  • lcMatchingPair
  • lcModDate
  • lcMotivation
  • lcMultipleSelect
  • lcNeeds
  • lcNeedsAnalysis
  • lcNextSteps
  • lcNoLMS
  • lcOJT
  • lcObjective
  • lcObjectives
  • lcObjectivesGroup
  • lcObjectivesStem
  • lcOpenAnswer
  • lcOpenQuestion
  • lcOrgConstraints
  • lcOrganizational
  • lcPlanAudience
  • lcPlanDescrip
  • lcPlanObjective
  • lcPlanPrereqs
  • lcPlanResources
  • lcPlanSubject
  • lcPlanTitle
  • lcPlayers
  • lcPrereqs
  • lcProcesses
  • lcProject
  • lcQuestion
  • lcQuestionBase
  • lcResolution
  • lcResources
  • lcReview
  • lcSecurity
  • lcSequence
  • lcSequenceOption
  • lcSequenceOptionGroup
  • lcSequencing
  • lcSingleSelect
  • lcSkills
  • lcSpecChars
  • lcSummary
  • lcTask
  • lcTaskItem
  • lcTechnical
  • lcTime
  • lcTrueFalse
  • lcValues
  • lcViewers
  • lcW3C
  • lcWorkEnv
  • lcWorkEnvDescription
  • learningAssessment
  • learningAssessmentbody
  • learningBase
  • learningBasebody
  • learningContent
  • learningContentComponentRef
  • learningContentRef
  • learningContentbody
  • learningGroup
  • learningObject
  • learningOverview
  • learningOverviewRef
  • learningOverviewbody
  • learningPlan
  • learningPlanRef
  • learningPlanbody
  • learningPostAssessmentRef
  • learningPreAssessmentRef
  • learningSummary
  • learningSummaryRef
  • learningSummarybody
  • lomAggregationLevel
  • lomContext
  • lomCoverage
  • lomDifficulty
  • lomInstallationRemarks
  • lomIntendedUserRole
  • lomInteractivityLevel
  • lomInteractivityType
  • lomLearningResourceType
  • lomOtherPlatformRequirements
  • lomSemanticDensity
  • lomStructure
  • lomTechRequirement
  • lomTypicalAgeRange
  • lomTypicalLearningTime
Parent topic: 3.5 Element quick reference
Previous topic: 3.5.2 Technical content elements, A to Z
Next topic: 3.5.4 All DITA 1.2 elements, A to Z


All DITA 1.2 elements, A to Z

3.5.4 All DITA 1.2 elements, A to Z

This section provides links to all of the elements in DITA 1.2, in alphabetical order.

  • abbreviated-form
  • abbrevlist
  • abstract
  • addressdetails
  • administrativearea
  • alt
  • amendments
  • anchor
  • anchorid
  • anchorkey
  • anchorref
  • apiname
  • appendices
  • appendix
  • approved
  • area
  • attributedef
  • audience
  • author
  • authorinformation
  • b
  • backmatter
  • bibliolist
  • body
  • bodydiv
  • bookabstract
  • bookchangehistory
  • bookevent
  • bookeventtype
  • bookid
  • booklibrary
  • booklist
  • booklists
  • bookmap
  • bookmeta
  • booknumber
  • bookowner
  • bookpartno
  • bookrestriction
  • bookrights
  • booktitle
  • booktitlealt
  • boolean
  • brand
  • category
  • chapter
  • chdesc
  • chdeschd
  • chhead
  • choice
  • choices
  • choicetable
  • choption
  • choptionhd
  • chrow
  • cite
  • closereqs
  • cmd
  • cmdname
  • codeblock
  • codeph
  • coderef
  • colophon
  • colspec
  • completed
  • component
  • conbody
  • conbodydiv
  • concept
  • consequence
  • contactnumber
  • contactnumbers
  • context
  • coords
  • copyrfirst
  • copyrholder
  • copyright
  • copyrlast
  • copyryear
  • country
  • created
  • critdates
  • data-about
  • data
  • day
  • dd
  • ddhd
  • dedication
  • defaultSubject
  • delim
  • desc
  • dita
  • dl
  • dlentry
  • dlhead
  • draft-comment
  • draftintro
  • dt
  • dthd
  • edited
  • edition
  • elementdef
  • emailaddress
  • emailaddresses
  • entry
  • enumerationdef
  • esttime
  • example
  • exportanchors
  • featnum
  • fig
  • figgroup
  • figurelist
  • filepath
  • firstname
  • fn
  • foreign
  • fragment
  • fragref
  • frontmatter
  • generationidentifier
  • glossAbbreviation
  • glossAcronym
  • glossAlt
  • glossAlternateFor
  • glossBody
  • glossPartOfSpeech
  • glossProperty
  • glossScopeNote
  • glossShortForm
  • glossStatus
  • glossSurfaceForm
  • glossSymbol
  • glossSynonym
  • glossUsage
  • glossarylist
  • glossdef
  • glossentry
  • glossgroup
  • glossref
  • glossterm
  • groupchoice
  • groupcomp
  • groupseq
  • hasInstance
  • hasKind
  • hasNarrower
  • hasPart
  • hasRelated
  • hazardstatement
  • hazardsymbol
  • honorific
  • howtoavoid
  • i
  • image
  • imagemap
  • index-base
  • index-see-also
  • index-see
  • index-sort-as
  • indexlist
  • indexterm
  • indextermref
  • info
  • isbn
  • itemgroup
  • keydef
  • keyword
  • keywords
  • kwd
  • lastname
  • lcAge
  • lcAnswerContent
  • lcAnswerOption
  • lcAnswerOptionGroup
  • lcArea
  • lcAreaCoords
  • lcAreaShape
  • lcAssessment
  • lcAsset
  • lcAttitude
  • lcAudience
  • lcBackground
  • lcCIN
  • lcChallenge
  • lcClassroom
  • lcClient
  • lcConstraints
  • lcCorrectResponse
  • lcDelivDate
  • lcDelivery
  • lcDownloadTime
  • lcDuration
  • lcEdLevel
  • lcFeedback
  • lcFeedbackCorrect
  • lcFeedbackIncorrect
  • lcFileSizeLimitations
  • lcGapAnalysis
  • lcGapItem
  • lcGapItemDelta
  • lcGeneralDescription
  • lcGoals
  • lcGraphics
  • lcHandouts
  • lcHotspot
  • lcHotspotMap
  • lcInstruction
  • lcInstructornote
  • lcInteraction
  • lcInteractionBase
  • lcIntervention
  • lcInterventionItem
  • lcIntro
  • lcItem
  • lcJtaItem
  • lcKnowledge
  • lcLMS
  • lcLearnStrat
  • lcLom
  • lcMatchTable
  • lcMatching
  • lcMatchingHeader
  • lcMatchingItem
  • lcMatchingItemFeedback
  • lcMatchingPair
  • lcModDate
  • lcMotivation
  • lcMultipleSelect
  • lcNeeds
  • lcNeedsAnalysis
  • lcNextSteps
  • lcNoLMS
  • lcOJT
  • lcObjective
  • lcObjectives
  • lcObjectivesGroup
  • lcObjectivesStem
  • lcOpenAnswer
  • lcOpenQuestion
  • lcOrgConstraints
  • lcOrganizational
  • lcPlanAudience
  • lcPlanDescrip
  • lcPlanObjective
  • lcPlanPrereqs
  • lcPlanResources
  • lcPlanSubject
  • lcPlanTitle
  • lcPlayers
  • lcPrereqs
  • lcProcesses
  • lcProject
  • lcQuestion
  • lcQuestionBase
  • lcResolution
  • lcResources
  • lcReview
  • lcSecurity
  • lcSequence
  • lcSequenceOption
  • lcSequenceOptionGroup
  • lcSequencing
  • lcSingleSelect
  • lcSkills
  • lcSpecChars
  • lcSummary
  • lcTask
  • lcTaskItem
  • lcTechnical
  • lcTime
  • lcTrueFalse
  • lcValues
  • lcViewers
  • lcW3C
  • lcWorkEnv
  • lcWorkEnvDescription
  • learningAssessment
  • learningAssessmentbody
  • learningBase
  • learningBasebody
  • learningContent
  • learningContentComponentRef
  • learningContentRef
  • learningContentbody
  • learningGroup
  • learningObject
  • learningOverview
  • learningOverviewRef
  • learningOverviewbody
  • learningPlan
  • learningPlanRef
  • learningPlanbody
  • learningPostAssessmentRef
  • learningPreAssessmentRef
  • learningSummary
  • learningSummaryRef
  • learningSummarybody
  • li
  • lines
  • link
  • linkinfo
  • linklist
  • linkpool
  • linktext
  • locality
  • localityname
  • lomAggregationLevel
  • lomContext
  • lomCoverage
  • lomDifficulty
  • lomInstallationRemarks
  • lomIntendedUserRole
  • lomInteractivityLevel
  • lomInteractivityType
  • lomLearningResourceType
  • lomOtherPlatformRequirements
  • lomSemanticDensity
  • lomStructure
  • lomTechRequirement
  • lomTypicalAgeRange
  • lomTypicalLearningTime
  • longdescref
  • longquoteref
  • lq
  • mainbooktitle
  • maintainer
  • map
  • mapref
  • menucascade
  • messagepanel
  • metadata
  • middlename
  • month
  • msgblock
  • msgnum
  • msgph
  • namedetails
  • navref
  • navtitle
  • no-topic-nesting
  • noconds
  • nosafety
  • nospares
  • nosupeq
  • nosupply
  • note
  • notices
  • object
  • ol
  • oper
  • option
  • organization
  • organizationinfo
  • organizationname
  • organizationnamedetails
  • otherinfo
  • othermeta
  • p
  • param
  • parml
  • parmname
  • part
  • pd
  • permissions
  • perscat
  • perskill
  • person
  • personinfo
  • personname
  • personnel
  • ph
  • platform
  • plentry
  • postalcode
  • postreq
  • pre
  • preface
  • prelreqs
  • prereq
  • printlocation
  • prodinfo
  • prodname
  • prognum
  • prolog
  • propdesc
  • propdeschd
  • properties
  • property
  • prophead
  • proptype
  • proptypehd
  • propvalue
  • propvaluehd
  • pt
  • published
  • publisher
  • publisherinformation
  • publishtype
  • q
  • refbody
  • refbodydiv
  • reference
  • refsyn
  • related-links
  • relatedSubjects
  • relcell
  • relcolspec
  • relheader
  • relrow
  • reltable
  • repsep
  • reqcond
  • reqconds
  • reqcontp
  • reqpers
  • required-cleanup
  • resourceid
  • result
  • reviewed
  • revised
  • revisionid
  • row
  • safecond
  • safety
  • schemeref
  • screen
  • searchtitle
  • section
  • sectiondiv
  • sep
  • series
  • shape
  • shortcut
  • shortdesc
  • simpletable
  • sl
  • sli
  • source
  • spare
  • spares
  • sparesli
  • started
  • state
  • stentry
  • step
  • stepresult
  • steps-informal
  • steps-unordered
  • steps
  • stepsection
  • stepxmp
  • sthead
  • strow
  • sub
  • subjectCell
  • subjectHead
  • subjectHeadMeta
  • subjectRel
  • subjectRelHeader
  • subjectRelTable
  • subjectRole
  • subjectScheme
  • subjectdef
  • subjectref
  • substep
  • substeps
  • summary
  • sup
  • supeqli
  • supequi
  • supequip
  • supplies
  • supply
  • supplyli
  • synblk
  • synnote
  • synnoteref
  • synph
  • syntaxdiagram
  • systemoutput
  • table
  • tablelist
  • task
  • taskbody
  • tbody
  • term
  • tested
  • text
  • tgroup
  • thead
  • thoroughfare
  • title
  • titlealts
  • tm
  • toc
  • topic
  • topicCell
  • topicSubjectHeader
  • topicSubjectRow
  • topicSubjectTable
  • topicapply
  • topicgroup
  • topichead
  • topicmeta
  • topicref
  • topicset
  • topicsetref
  • topicsubject
  • trademarklist
  • tt
  • tutorialinfo
  • typeofhazard
  • u
  • uicontrol
  • ul
  • unknown
  • url
  • urls
  • userinput
  • var
  • varname
  • volume
  • vrm
  • vrmlist
  • wintitle
  • xref
  • year
Parent topic: 3.5 Element quick reference
Previous topic: 3.5.3 Learning and training elements, A to Z
Next topic: 4 Conformance


Conformance

4 Conformance

This section outlines the requirements that must be met in order for documents, document types, vocabulary and constraint modules, and processors to be considered DITA conforming. This section also defines conformance-related terminology and categories.

Conformance to the DITA Specification allows documents and document types that are shared within and across organizations and used with different processors or different versions of a processor to produce the same or similar results with little or no reimplementation or modification.

Key words

The key words "must," "must not," "required," "shall," "shall not," "should," "should not," "recommended," and "optional" in the DITA Specification are to be interpreted as described in IETF RFC 2119: Key words for use in RFCs to Indicate Requirement Levels.

The use of these key words and other conformance requirements increase the level of interoperability that is available between DITA conforming implementations. Their use is not meant to impose particular methods on implementers where the method is not required for interoperability.

The key words informative and non-normative identify content that is not normative. The DITA specifications include examples and other suggestions that are informative rather than normative. While informative information is often very helpful, it is never a binding part of the DITA specifications even when the example or other information is about a feature that is required. Unless it is clearly stated otherwise, examples and the appendices are always informative rather than normative.

Conformance statement

Documents, document types, document type shells, vocabulary and constraint modules, and processors that implement the requirements given in the OASIS approved DITA Specification are considered conforming.

A "DITA implementation" may consist of any combination of processing components that claim DITA awareness, custom vocabulary and constraint modules, and custom document types shells.

non-normative: For example, a DITA implementation may be a DITA-based documentation authoring and production support system within an Enterprise, a task-specific product, such a DITA-aware XML editor or component management system, or just a set of specialization and constraint modules packaged for integration with larger implementations.

Conforming DITA implementations must include a conformance statement that gives the version of the DITA Specification that is supported and lists the DITA features that are supported by the implementation in accordance with the requirements of that specification. Or, if it is clearer, the statement may say that the implementation includes all features except for a specific list of features that are not supported.

Implementations that include some DITA features, but not others, are considered conforming as long as all required features relevant to the implementation are included and all of the features that are included follow the requirements given in the DITA Specification.

An implementation that does not include a particular optional feature must be prepared to interoperate with other implementations that do include the feature, though perhaps with reduced functionality. An implementation that does include a particular optional feature must be prepared to interoperate with other implementations that do not include the feature.

Organizations and individuals are free to impose additional constraints on their own use of DITA that go beyond the requirements imposed by the DITA Specification, possibly including enforcement of the constraints by their local processors, as long as the result continues to meet the requirements given in the DITA Specification. For example, a given user community could impose rules on how files must be named or organized even if those rules go beyond the requirements given in the DITA Specification.

Processors that are not DITA-aware (as defined here) are not considered conforming, but may still be useful when working with DITA.

Conformance of documents

A document is a conforming DITA document if it all of the following criteria are met:
  • is a well-formed XML document
  • all of its elements are DITA elements or are non-DITA elements contained within <foreign> or <unknown>
  • its content conforms to all DITA requirements for element content and attribute values
  • if the document has a document type declaration or an associated XSD, the referenced document type or XSD is a conforming DITA document type shell.
Note: The use of non-DITA-conforming document type declarations or schemas for conforming DITA documents cannot affect the ability of processors to process those documents. However, the use of non-conforming document types or schemas may impede interchange or interoperation of those documents with tools that expect or require the use of conforming DITA document types or schemas.

Conformation of document types and modules

A document type is a conforming DITA document type if it consists only of conforming DITA vocabulary and constraint modules.

A DITA document type shell is a conforming shell if it represents a conforming DITA document type and conforms to the requirements for document type shells.

A vocabulary or constraint module is a conforming module if it conforms to the requirements for its module type.

Conformance of processors

The conformance of processors can only be determined for processors that claim to be "DITA aware".

DITA-aware merely means that the processor can handle documents conforming to at least one conforming DITA document type, as specified by the processor, but need not support any features not required by that document type.

Specialization-aware is a further, more-demanding class of processor that is able to handle any document specialized from some set of supported vocabulary modules and with, possibly, the required use of specific constraint modules.

The most complete DITA implementations are "fully DITA aware" processors that support all base vocabulary modules without constraint, which implies support for all non-vocabulary-specific DITA features, such as content references and key references.

non-normative: For example, a general-purpose processor that can process XML documents to produce a particular output using user-created configurations or scripts is not itself DITA-aware. However, that same processor packaged with a DITA-specific configuration or script would be a DITA-aware processor. A script or configuration for this processor that only operated on tag names as defined in specific DITA vocabulary modules would make the tool DITA aware but not specialization aware. A script or configuration that operated on DITA @class attribute values would be both DITA aware and specialization aware.
Note: A processor that does not claim to be DITA-aware can be neither a conforming nor a non-conforming DITA processor. In particular, processors that process XML generally but do not claim to be DITA aware cannot be described as non-conforming DITA processors. Such processors are simply DITA unaware.

A DITA-aware processor is a conforming DITA processor if it implements all required processing relevant to that processor for the vocabulary modules it claims to support. A DITA-aware processor must support at least one map or topic type, whether defined by the DITA standard or defined as a custom vocabulary module.

A DITA-aware processor is a conforming specialization-aware processor if it is a conforming DITA-aware processor and applies relevant processing to all DITA elements based on their @class and @domains attribute values.

Note: In general, specialization-aware processors will be able to reliably process all conforming DITA documents, providing at least some default behavior for all DITA elements, while non-specialization-aware DITA-aware processors may only be able to reliably process documents that use the vocabulary modules those processors claim to support.

While there are many possible processor types, DITA-aware processors can be classified generally into those that produce some sort of final form output from DITA documents (e.g., publishing systems and tools, such as the DITA Open Toolkit) and those that store, manage, or edit DITA documents (e.g., DITA-aware editors and content or component management systems). A given processor many provide any or all processing types.

Note: For example, a DITA-aware editor that includes the ability to generate print versions of DITA documents represents both a final-form processor and an editing processor. Likewise, a content or component management system may tightly integrate final-form DITA processors. These different processor types may have different conformance requirements even though the processors are part of a single product or package.

For processors that produce final form output, all features that are relevant to the type of processing that the processor performs must be implemented, with the exception of features that are vocabulary-specific. In particular, such processors must implement address resolution and content reference resolution. Such processors should implement filtering.

Non-normative: For example, a specialization-aware processor that produces final form output need not provide special presentation results for glossary entry topics but must implement resolution of key-based references to glossary entry topics from <keyword> or <term> elements, because address resolution is both required and not vocabulary specific.

Processors that store, manage, or edit DITA documents may choose to not implement specific features that would be required for final-form processing. However, such processors must enable the creation or storage of DITA documents that use all DITA features, even if the processor is not aware of the DITA semantics for those features.

Note: For example, a DITA-aware editor need not provide specific support for creating or resolving content references, but it must allow, using normal XML editing methods, the creation and editing of content references. A content management system that supports map types that allow relationship tables but does not directly support relationship table processing must be able to store and manage conforming map documents that include relationship tables.
Previous topic: 3.5.4 All DITA 1.2 elements, A to Z
Next topic: Appendix A Acknowledgments


Acknowledgments

Appendix A Acknowledgments

(Non-normative) Many individuals participated in the creation of this specification and are gratefully acknowledged.

  • Paul Antonov
  • Robert Anderson, IBM
  • Don Day, Individual Member
  • Stanley Doherty, Individual Member
  • Jim Early, Flatirons Solutions Corporation
  • Kristen James Eberlein, SDL International
  • Yas Etessam, JustSystems
  • Rob Frankland, Individual Member
  • Paul Grosso, PTC
  • JoAnn Hackos, Comtech Services, Inc.
  • Richard Hamilton, Individual Member
  • David Helfinstine, PTC
  • Erik Hennum, IBM
  • Alan Houser, Group Wellesley, Inc.
  • John Hunt, IBM
  • Gershon Joseph, Cisco Systems, Inc.
  • Sowmya Kannan, Oracle Corporation
  • Eliot Kimber, Really Strategies, Inc.
  • Christian Kravogel, SeicoDyne GmbH
  • Bruce Nevin, Cisco Systems, Inc.
  • Jeff Ogden, PTC
  • Seth Park, Freescale Semiconductor, Inc.
  • Deborah Pickett, Individual Member
  • Paul Prescod, JustSystems
  • Michael Priestley, IBM
  • Zarella Rendon, PTC
  • Tony Self, Hyperwrite Pty. Ltd.
  • Eric Sirois, IBM
  • Dana Spradley, Oracle Corporation
  • Su-Laine Yeo, JustSystems
Previous topic: 4 Conformance
Next topic: Appendix B Non-normative information


Non-normative information

Appendix B Non-normative information

This section contains non-normative information, including topics about new features in DITA 1.2 and migrating from DITA 1.1 to DITA 1.2.

  • B.1 Changes from previous versions
    (Non-normative) The following topics outline the changes from earlier versions of DITA to the current version.
  • B.2 Migrating from DITA 1.1 to 1.2
    (Non-normative) DITA 1.2 is compatible with prior versions of the DITA specification in that all valid DITA 1.0 and 1.1 documents are valid DITA 1.2 documents. However, some changes to existing document type shells and specializations might be needed in order to maintain the same behavior under DITA 1.2 or to take full advantage of new DITA 1.2 features.
  • B.3 DITA MIME type
    (Non-normative) It is common for Web-based services to establish default actions for content based on the MIME type value sent in HTTP headers. For example, the "text/html" MIME type is what normally causes browsers to interpret the content of a web page as presentation-oriented markup, verus "text/plain" which would cause the markup to be displayed literally. A DITA MIME type enables applications to recognize content as DITA to enable special services such as semantically-informed search indexing or on-the-fly rendering in the browser.
  • B.4 Considerations for generalizing <foreign> elements
    (Non-normative) Generalization of a DITA element employs the value of its @class attribute. The content of a <foreign> element, or of a specialization of the <foreign> element, cannot be generalized because there are no DITA elements in it, and therefore no @class attributes. The non-DITA contents can only be processed by appropriate non-DITA means.
  • B.5 Element-by-element recommendations for translators
    (Non-normative) This topic contains a list of all OASIS DITA elements. It includes recommendations on how to present the element type to translators, whether the element contents are likely to be suitable for translation, and whether the element has attributes whose values are likely to be suitable for translation. Examples of content that is not suitable for translation include code fragments and mailing addresses.
  • B.6 DITA module and shell implementation reference
    (Non-normative) The DITA standard defines a set of base types and vocabulary modules and a set of specialized map types, topic types, and domains.
  • B.7 DTD organization
    (Non-normative) The OASIS DITA document types are implemented with a set of DTD modules. Some of these modules are used by every DITA document type, others are only used by topics or by maps, and some are only used in specific specializations.
  • B.8 XML schema organization
    (Non-normative) The OASIS DITA document types are implemented with a set of schema modules. Some of these modules are used by every DITA schema document, others are only used by topics or by maps, and some are only used in specific specializations.
  • B.9 Processing component modularization and naming conventions
  • B.10 Processing interoperability considerations
    (Non-normative) The DITA specification does not require processors to perform filtering, content reference resolution, key space construction, and other processing related to base DITA semantics in any particular order. This means that different conforming DITA processors may produce different results for the same initial data set and filtering conditions. DITA users and DITA implementers need to be aware of these potential differences in behavior when DITA content will be processed by different processors.
  • B.11 Specialization design, customization, and the limits of specialization
    (Non-normative) The DITA specialization facility necessarily imposes some constraints. An inherent challenge in designing DITA vocabulary modules and document types is understanding how best to satisfy markup requirements within those constraints and, when requirements cannot be met within the DITA-defined constraints, how to create "customized" document types that diverge from DITA requirements as little as possible.
Previous topic: Appendix A Acknowledgments
Next topic: B.1 Changes from previous versions


Changes from previous versions

B.1 Changes from previous versions

(Non-normative) The following topics outline the changes from earlier versions of DITA to the current version.

  • B.1.1 Changes from DITA 1.1 to DITA 1.2
    (Non-normative) DITA 1.2 adds a number of new features to DITA, including indirect addressing via map-defined keys; the ability to define content-model constraints for DITA document types; specializations for learning content and the machine industry; and taxonomies, ontologies, and controlled vocabularies. Other refinements include extended markup for glossaries and terminology.
  • B.1.2 Changes from DITA 1.0 to DITA 1.1
    (Non-normative) The DITA 1.1 specification was designed to be backwards-compatible with applications that conform to the DITA 1.0 specification.
Parent topic: Appendix B Non-normative information
Previous topic: Appendix B Non-normative information
Next topic: B.1.1 Changes from DITA 1.1 to DITA 1.2


Changes from DITA 1.1 to DITA 1.2

B.1.1 Changes from DITA 1.1 to DITA 1.2

(Non-normative) DITA 1.2 adds a number of new features to DITA, including indirect addressing via map-defined keys; the ability to define content-model constraints for DITA document types; specializations for learning content and the machine industry; and taxonomies, ontologies, and controlled vocabularies. Other refinements include extended markup for glossaries and terminology.

New features

The following features are new in DITA 1.2:
  • Keys and key references. See Key-based addressing.
  • Constraint modules. Constraint modules allow base content models to be further constrained without the need for specialization. For example, a constraint module can make optional elements required or disallow optional elements in a specific content model. See Constraint domains.
  • Topic and map specializations for learning and training information, including interactive assessments. See the architectural specification for learning and training content.
  • New elements for use with glossary entry topics for more complete description of terms, definition of acronyms, and so on.
  • New map specialization for defining controlled vocabularies and taxonomies. See subjectScheme.
  • New machine-industry task specialization. See Machinery task topic.

New element types

The following base element types are new in DITA 1.2:
<text>
Allowed in most contexts where text is allowed but neither <ph> nor <keyword> are allowed. Enables reuse of text in almost any context.
<bodydiv>
Allows creation of untitled containers within topic bodies. Intended primarily for specialization.
<sectiondiv>
Allows creation of untitled containers within sections. Intended primarily for specialization.
<keydef>
Topicref specialization for defining keys. Sets the default value for the @processing-role attribute to "resource-only".
<mapref>
Topicref specialization for referring to DITA maps. Sets the default value for the @format attribute to "ditamap".
<topicset>
Used to define sets of topicrefs that represent an atomic unit of reusable navigation structure. Requires the @id attribute be specified.
<topicsetref>
References a <topicset> element. Enables preservation of the identity of the referenced topicset.
<anchor>
Defines a point within a map to which topicrefs can be bound using the <anchorref> element.
<anchorref>
"Pushes" one or more topicrefs onto an anchor point defined by an <anchor> element. Similar to a conref push but allows the relationship to be managed dynamically by the renderer.

Refinements to maps

  • Map elements can use the <title> element in place of the title attribute.
  • Relationship table elements can have <title> as an optional first child.
  • Topicref elements can use the <navtitle> element in place of the navtitle attribute.
  • Maps and topicrefs can now contain the same metadata elements as topic prologs.
  • New topicref attribute named processing-role. Indicates whether or not a topic reference contributes to the navigation structure of the containing map.

Refinements to content references

  • Content references can now point to ranges of elements. For example, a single content reference from a <step> element can include a sequence of <step> elements.
  • Content references can "push" elements into a target context, allowing unilateral augmentation of topics from other topics. For example, given a base topic with generic content, a using map could include both the generic topic and a separate topic that uses conref push to add map-specific content to the generic topic.
  • Content reference resolution can be deferred so that it is done later in a rendering process or completely deferred so that it can be done by a separate delivery mechanism, for example., Eclipse information centers.

Refinements to topic elements

  • The base task topic type has a more relaxed content model. This enables creation of a wider variety of specialized tasks, including task specializations that do not have formal markup for individual steps. The OASIS-defined task shell document type integrates a constraint module that imposes the same constrained content model as defined in the DITA 1.1 task topic type.
  • A number of content elements allow the new @keyref attribute, including the <ph>, <keyword>, and <term> elements. When using the @keyref attribute, these elements can get their effective content from the key-defining <topicref> element and can also be treated as navigation links to the resource pointed to by the key-defining <topicref> element, if any. For example, a term element can use @keyref to link to the glossary entry topics for the term.
  • The <image> element takes the new @scalefit attribute, which indicates whether or not the image should be scaled to fit the presentation context.
  • The <draft-comment> element is now allowed in most contexts.
  • The <figgroup> element now allows <data> as a subelement.

Refinements to specialization

  • Structural and domain vocabulary modules can now both be listed in the domains attribute. Structural modules can depend on and specialize elements from domains. For example, a structural domain for reference topics for a specific programming language could depend on the Programming domain (pr-d) and specialize elements from that domain.
  • Information Architects can indicate whether the use of a given vocabulary module requires strict or weak checking of content reference constraints.
  • The implementation patterns for vocabulary modules have been refined. In particular, each element type now defines a separate parameter entity for its content model and attribute list, allowing per-element configuration of content models and attribute lists through constraint modules.

Other refinements

  • The <dita> element now has the @DITAArchVersion attribute.
  • A number of processing details have been clarified where they were underspecified in DITA 1.1.
  • Most attributes that had enumerated values in DITA 1.1 are now unenumerated, allowing specializations to define different enumerations if they choose.
Parent topic: B.1 Changes from previous versions
Previous topic: B.1 Changes from previous versions
Next topic: B.1.2 Changes from DITA 1.0 to DITA 1.1


Changes from DITA 1.0 to DITA 1.1

B.1.2 Changes from DITA 1.0 to DITA 1.1

(Non-normative) The DITA 1.1 specification was designed to be backwards-compatible with applications that conform to the DITA 1.0 specification.

The following major changes to the architecture provided added functionality for DITA 1.1:
  • A <bookmap> specialization for encoding book-specific information in a DITA map
  • A <glossentry> specialization for glossary entries
  • Indexing specializations for see, see-also, page ranges, and sort order
  • Improvements to graphic scaling capability
  • Improved short description flexibility through a new <abstract> element
  • Specialization support for new global attributes, such as conditional processing attributes
  • Support for integration of existing content structures through the <foreign> element
  • Support for new kinds of information and structures through the <data> and <unknown> elements
  • Formalization of conditional processing profiles
Parent topic: B.1 Changes from previous versions
Previous topic: B.1.1 Changes from DITA 1.1 to DITA 1.2
Next topic: B.2 Migrating from DITA 1.1 to 1.2


Migrating from DITA 1.1 to 1.2

B.2 Migrating from DITA 1.1 to 1.2

(Non-normative) DITA 1.2 is compatible with prior versions of the DITA specification in that all valid DITA 1.0 and 1.1 documents are valid DITA 1.2 documents. However, some changes to existing document type shells and specializations might be needed in order to maintain the same behavior under DITA 1.2 or to take full advantage of new DITA 1.2 features.

Migration of task specializations

DITA 1.2 relaxes the content model for the <taskbody> element in the base <task> topic type. Specializations of <task> that use the <taskbody> element unchanged or use the content-model parameter entities for task body will use the more general DITA 1.2 task model when used with the DITA 1.2 task module.

If a document should use the strict task model instead of the new general task model:
  • Documents that use the task topic type included with the OASIS DITA 1.2 specification will not need to migrate. This includes documents that use task inside of the ditabase document type included with the DITA 1.2 specification.
  • Documents that use the standard task module inside of a new document type shell, or in a local ditabase document type, will need to migrate in order to preserve the module.
  • Documents that use a specialization of task with a specialized element to replace <taskbody> will not need to migrate. Documents that specialize task but reuse the <taskbody> element will need to migrate.

For documents that do not use the standard OASIS DITA doctypes for which the strict task model from DITA 1.0 and 1.1 is desired, the strict task model can be restored by using the strict Taskbody Constraint module, by creating and integrating a constraint module similar to the strict Taskbody Constraint, or by adjusting the specialization's content models to impose the appropriate constraints.

To integrate the strict Taskbody Constraint module in a DTD, add the following content immediately before the section that imports the "topic.mod" file. The strictTaskbodyConstraint.mod file must be defined in any catalog used to locate DTD modules. See the task.dtd file in the OASIS DITA 1.2 DTD package for a sample:
<!ENTITY % strictTaskbody-c-def
  PUBLIC "-//OASIS//ELEMENTS DITA 1.2 Strict Taskbody Constraint//EN"
  "strictTaskbodyConstraint.mod">
%strictTaskbody-c-def;
To do the same thing for a schema, the strictTaskbodyConstraintMod.xsd file must be defined in the catalog used to resolve the schema using the following URN. The <xs:include> element should be placed immediately before the <xs:include> for topicMod.xsd:
<xs:include schemaLocation="urn:oasis:names:tc:dita:xsd:strictTaskbodyConstraintMod.xsd:1.2" />
Documents which use the task document type from OASIS and wish to make use of the general <taskbody> model must also be migrated. In this case, the documents must be updated to reference the General Task document type instead of the traditional Task document type. For DTD-based documents, this means that the document type declaration must change as follows within each task document:
DITA 1.1:
<!DOCTYPE task PUBLIC "-//OASIS//DTD DITA Task//EN"
 "task.dtd">

DITA 1.2:
<!DOCTYPE task PUBLIC "-//OASIS//DTD DITA General Task//EN"
 "generalTask.dtd">
For Schema based documents, the xsi:noNamespaceSchemaLocation attribute must change on each task element:
DITA 1.1:
<task xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:noNamespaceSchemaLocation="urn:oasis:names:tc:dita:xsd:task.xsd"

DITA 1.2:
<task xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:noNamespaceSchemaLocation="urn:oasis:names:tc:dita:xsd:generalTask.xsd"

Use of glossary document type shell and module files

The files named glossary.dtd, glossary.mod, and glossary.ent in DITA 1.1 have been renamed to glossentry.dtd, glossentry.mod, and glossentry.ent in order to follow the file naming requirements for vocabulary modules. The XML Schema files glossary.xsd, glossaryGrp.xsd, and glossaryMod.xsd have been renamed to glossentry.xsd, glossentryGrp.xsd, and glossentryMod.xsd.The DITA 1.2 entity resolution catalogs map the public identifiers for the glossary.* files to the corresponding glossentry.* files and URNs for the glossary*.xsd files to the corresponding glossentry*.xsd files, meaning that existing documents and shell document types that refer to the glossary.* files will continue to work with DITA 1.2.

However, shell document types that refer to the glossary.* files should be updated to refer to the corresponding glossentry.* files as it is convenient to do so.

Migration of specializations to reflect new implementation patterns

DITA 1.2 defines new implementation patterns for specializations. It is not necessary to update existing specialization modules to reflect these new patterns. However, specializations that want to enable the use of constraint modules must be updated to provide per-element-type content model and attribute list parameter entities.

Existing specializations may benefit from the new DITA 1.2 ability to have structural modules that depend on and specialize elements from domains.

Update of domains attributes for specializations

In DITA 1.1 the @domains attribute only listed the domains on which a given map or topic type depended. In DITA 1.2 the @domains attribute should also list structural modules and constraint modules, providing a complete list of the vocabulary modules that a given map or topic type depends on in the context of a given DITA document type.

Existing structural specializations should be updated to include the structural module names in their domains attribute configuration entities. Having a complete declaration of all structural and domains modules in the @domains attribute allows processors to determine the set of required modules for a given topic or map document without also examining all the @class attributes of all the elements in the document.

XML Schema declaration of domains attribute

For XML schema shell document types, the way the domains attribute is declared has changed. In DITA 1.1 the domains attribute was defined using an <xs:redefine> element. For DITA 1.2 the attribute is defined in document type shells and referenced from modules, like so:
<xs:attributeGroup name="domains-att">
    <xs:attribute name="domains" type="xs:string"
     default="(topic ui-d)
              (topic hi-d)
              (topic sw-d)
              (topic pr-d)
              (topic ut-d)
              (topic indexing-d)
              (topic hazard-d)
              (topic abbrev-d)"
     />
</xs:attributeGroup>

XML Schema document type shells must be updated to use the new declaration mechanism in order to continue to be valid XSD schemas.

Parent topic: Appendix B Non-normative information
Previous topic: B.1.2 Changes from DITA 1.0 to DITA 1.1
Next topic: B.3 DITA MIME type


DITA MIME type

B.3 DITA MIME type

(Non-normative) It is common for Web-based services to establish default actions for content based on the MIME type value sent in HTTP headers. For example, the "text/html" MIME type is what normally causes browsers to interpret the content of a web page as presentation-oriented markup, verus "text/plain" which would cause the markup to be displayed literally. A DITA MIME type enables applications to recognize content as DITA to enable special services such as semantically-informed search indexing or on-the-fly rendering in the browser.

The OASIS DITA Technical Committee has requested the registration of "application/dita+xml" with the IANA organization as the formally recognized DITA MIME type. This process is in progress, however the details are public so that implementors can make early use of the proposed value.

More information about the proposal is documented in this note of transmittal to OASIS for registration of the DITA MIME type: http://lists.oasis-open.org/archives/dita/200806/msg00008.html

Parent topic: Appendix B Non-normative information
Previous topic: B.2 Migrating from DITA 1.1 to 1.2
Next topic: B.4 Considerations for generalizing <foreign> elements


Considerations for generalizing <foreign> elements

B.4 Considerations for generalizing <foreign> elements

(Non-normative) Generalization of a DITA element employs the value of its @class attribute. The content of a <foreign> element, or of a specialization of the <foreign> element, cannot be generalized because there are no DITA elements in it, and therefore no @class attributes. The non-DITA contents can only be processed by appropriate non-DITA means.

Only the specialization of the <foreign> element can be generalized with normal rules.

Its contents would be exported to a separate file and replaced in-line with an <object> element. The data attribute of the <object> element would point to the generated file, and the type attribute of the <object> element would be set to the value "DITA-foreign".

If an <object> element is present within the <foreign> element (or specialization thereof) during generalization, it would not be included with the content that is exported to the separate file. This original object element is used to specify alternate content in publishing systems that cannot display the foreign content. It would not be modified except as the ordinary rules of generalization require it.

In the exported file, exported content would be enclosed within a root <foreign> element in order to accommodate the possibility that it may contain several main elements apart from the alternate content.

For easy recognition, the name of the exported file would start with "dita-generalized-" , and it is recommended that the file name also contain the topic ID, specialization type, and element ID or generated identifier.

Example: Simple object generalization

For example, a DITA document could contain a specialization of <foreign> for MathML. It could look like this:

<mathml class="+ topic/foreign mathml/mathml ">
  <math xmlns="http://www.w3.org/1998/Math/MathML">
    <mi>x</mi><mo>+</mo><mn>3</mn>
  </math>
  <object><desc>X plus three</desc></object>
</mathml>

The <mathml> container is a DITA element, so it should be generalized using normal rules. The <math> element, which is not a DITA element, will be exported to another file. The <object> element will remain:

<foreign class="+ topic/foreign mathml/mathml ">
  <object data="dita-generalized-topicid_mathml1.xml" type="DITA-foreign"/>
  <object><desc>X plus three</desc></object>
</foreign>

Contents of dita-generalized-topicid_mathml1.xml:
<foreign class="+ topic/foreign mathml/mathml ">
  <math xmlns="http://www.w3.org/1998/Math/MathML">
    <mi>x</mi><mo>+</mo><mn>3</mn>
  </math>
</foreign>

Example: Multiple object generalization

An object might also contain multiple object elements:

<mathml class="+ topic/foreign mathml/mathml ">
  <math xmlns="http://www.w3.org/1998/Math/MathML">
    <mi>x</mi><mo>+</mo><mn>3</mn>
  </math>
  <object><desc>X plus three</desc></object>
  <math xmlns="http://www.w3.org/1998/Math/MathML">
    <mi>y</mi><mo>-</mo><mn>2</mn>
  </math>
</mathml>

The <mathml> container, which is a normal DITA element, should be generalized using normal rules. A file should generated for each set of elements bounded by the container and any existing object elements. In this case, two files will be generated, and two new object elements added to the source.

The modified source:

<foreign class="+ topic/foreign mathml/mathml ">
  <object data="dita-generalized-topicid_mathml1.xml" type="DITA-foreign"/>
  <object><desc>X plus three</desc></object>
  <object data="dita-generalized-topicid_mathml2.xml" type="DITA-foreign"/>
</foreign>

The contents of dita-generalized-topicid_mathml1.xml, the first exported file:

<foreign class="+ topic/foreign mathml/mathml ">
  <math xmlns="http://www.w3.org/1998/Math/MathML">
    <mi>x</mi><mo>+</mo><mn>3</mn>
  </math>
</foreign>

The contents of dita-generalized-topicid_mathml2.xml, the second exported file:

<foreign class="+ topic/foreign mathml/mathml ">
  <math xmlns="http://www.w3.org/1998/Math/MathML">
    <mi>y</mi><mo>-</mo><mn>2</mn>
  </math>
</foreign>
Parent topic: Appendix B Non-normative information
Previous topic: B.3 DITA MIME type
Next topic: B.5 Element-by-element recommendations for translators


Element-by-element recommendations for translators

B.5 Element-by-element recommendations for translators

(Non-normative) This topic contains a list of all OASIS DITA elements. It includes recommendations on how to present the element type to translators, whether the element contents are likely to be suitable for translation, and whether the element has attributes whose values are likely to be suitable for translation. Examples of content that is not suitable for translation include code fragments and mailing addresses.

Since the distinction between block and inline elements is ultimately controlled by the container of the element and the processing associated with it, the same element may be a block in one context and an inline element in another. Specializing document types may vary this behavior according to the needs of the document type being created, and the distinctions given below are provided only as a guide to known behavior with the base DITA document types.

Notes on the tables below

  • For specializations, the second column gives the ancestor element, and the third column gives a quick yes/no guide to indicate whether all behavior is inherited. If something is not inherited, the change will appear in bold.
  • For any specialization not listed below, the suggested default is to fall back to the closest listed ancestor.
  • The block/inline presentation column indicates whether the element is formatted as a single block.
  • The block/inline translation column indicates whether the element represents a complete translatable segment. For example, the element <cmd> is presented inline with other elements, but represents a complete translation segment.
  • Items marked as block*** are blocks on their own, but may appear in the middle of a segment. They should not break the flow of the current segment. These are considered "subflow" elements for translation. We recommend that, when possible, these elements should only be placed at sentence boundaries to aid in translation.
  • For all elements, the translate attribute will override the suggested default translation setting. So, a translation setting of "yes" or "no" in the table below does not guarantee that an element will always, or never, be translated.
  • If an element has translatable attributes, they are listed in the last column. Note that the spectitle and specentry attributes are described with a footnote.
  • The keyword element (as well as specializations of keyword) is an inline, phrase-like element when it appears in the body of a document. It may also appear in the keywords element in topicmeta (for maps) or in the prolog (for topic). When it appears in the <keywords> element, each keyword represents an individual segment, and is not part of a larger segment; in that location, keyword can be considered a "subflow" element.

topic elements

Element name | Specialized from | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
abstract | N/A | block | block | yes |
alt 5 | N/A | block***1 | block | yes |
audience | N/A | block (metadata) | block | yes |
author | N/A | block (metadata) | block | yes |
body | N/A | block | block | yes |
bodydiv (new in DITA 1.2) | N/A | block | block | yes |
boolean | N/A | inline | inline | n/a |
brand | N/A | block (metadata) | block | yes |
category | N/A | block (metadata) | block | yes |
cite | N/A | inline | inline | yes |
colspec | N/A | n/a | n/a | n/a |
component | N/A | block (metadata) | block | yes |
copyrholder | N/A | block (metadata) | block | yes |
copyright | N/A | block (metadata) | block | yes |
copyryear | N/A | block (metadata) | block | yes |
created | N/A | block (metadata) | block | yes |
critdates | N/A | block (metadata) | block | yes |
data | N/A | N/A (metadata) | block | no (likely to change for some specializations) |
data-about | N/A | N/A (metadata) | block | no |
dd | N/A | block | block | yes |
ddhd | N/A | block | block | yes |
desc | N/A | block | block | yes |
dl | N/A | block | block | yes | @spectitle2
dlentry | N/A | block | block | yes |
dlhead | N/A | block | block | yes |
draft-comment | N/A | block***1 | block | no |
dt | N/A | block | block | yes |
dthd | N/A | block | block | yes |
entry | N/A | block | block | yes |
example | N/A | block | block | yes | @spectitle2
featnum | N/A | block (metadata) | block | yes |
fig | N/A | block | block | yes | @spectitle2
figgroup | N/A | block | block | yes |
fn | N/A | block***1 | block | yes |
foreign 7 | N/A | block3 | block3 | no4 |
image | N/A | block when @placement= break, otherwise inline | block when @placement= break, otherwise inline | yes | @alt5
index-base | N/A | block***1 | block | yes |
index-sort-as (new in DITA 1.2) | N/A | block***xref | block | yes
indexterm | N/A | block***1 | block | yes |
indextermref | N/A | inline | n/a | n/a |
itemgroup | N/A | inline | inline | yes |
keyword | N/A | inline | inline (except when within <keywords> – see note above the table) | yes |
keywords | N/A | block | block | yes |
li | N/A | block | block | yes |
lines | N/A | block | block | yes | @spectitle2
link | N/A | block | block | yes |
linkinfo | N/A | block | block | yes |
linklist | N/A | block | block | yes | @spectitle2
linkpool | N/A | block | block | yes |
linktext | N/A | block | block | yes |
lq | N/A | block | block | yes | @reftitle
metadata | N/A | block (metadata) | block | yes |
navtitle | N/A | block | block | yes |
no-topic-nesting | N/A | n/a | n/a | n/a |
note | N/A | block | block | yes | @othertype, @spectitle2
object | N/A | block | block | yes | @standby
ol | N/A | block | block | yes | @spectitle2
othermeta | N/A | block (metadata) | block | yes | @content
p | N/A | block | block | yes |
param | N/A | block | block | n/a |
permissions | N/A | block (metadata) | block | yes |
ph | N/A | inline | inline | yes |
platform | N/A | block (metadata) | block | yes |
pre | N/A | block | block | yes | @spectitle2
prodinfo | N/A | block (metadata) | block | yes |
prodname | N/A | block (metadata) | block | yes |
prognum | N/A | block (metadata) | block | yes |
prolog | N/A | block (metadata) | block | yes |
publisher | N/A | block (metadata) | block | yes |
q | N/A | inline | inline | yes |
related-links | N/A | block | block | yes |
required-cleanup | N/A | block***1 | block | no |
resourceid | N/A | block (metadata) | block | yes |
revised | N/A | block (metadata) | block | yes |
row | N/A | block | block | yes |
searchtitle | N/A | block | block | yes |
section | N/A | block | block | yes | @spectitle2
sectiondiv (new in DITA 1.2) | N/A | block | block | yes |
series | N/A | block (metadata) | block | yes |
shortdesc | N/A | block | block | yes |
simpletable | N/A | block | block | yes | @spectitle2
sl | N/A | block | block | yes | @spectitle2
sli | N/A | block | block | yes |
source | N/A | block (metadata) | block | yes |
state | N/A | inline | inline | yes | @value
stentry | N/A | block | block | yes | @specentry2
sthead | N/A | block | block | yes |
strow | N/A | block | block | yes |
table | N/A | block | block | yes |
tbody | N/A | block | block | yes |
term | N/A | inline | inline | yes |
text (new in DITA 1.2) | N/A | inline | inline | yes |
tgroup | N/A | block | block | yes |
thead | N/A | block | block | yes |
title | N/A | block | block | yes |
titlealts | N/A | block | block | yes |
tm | N/A | inline | inline | yes |
topic | N/A | block | block | yes |
ul | N/A | block | block | yes | @spectitle2
unknown (new in DITA 1.1) | N/A | block | block | no |
vrm | N/A | block (metadata) | block | yes |
vrmlist | N/A | block (metadata) | block | yes |
xref | N/A | inline | inline | yes |

map elements

As of DITA 1.2, the @navtitle attribute is deprecated, for translation purposes, in favor of the new <navtitle> element. The <navtitle> element is also available in topics, and is included in the topic table above.

Element name | Specialized from | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
anchor | N/A | n/a | n/a | n/a |
linktext | N/A | block | block | yes |
map | N/A | block | block | yes | @title 8
navref | N/A | n/a | n/a | n/a |
relcell | N/A | block | block | yes |
relcolspec | N/A | block | block | yes |
relheader | N/A | block | block | yes |
relrow | N/A | block | block | yes |
reltable | N/A | block | block | yes |
searchtitle | N/A | block | block | yes |
shortdesc | N/A | block | block | yes |
topicmeta | N/A | block | block | yes |
topicref | N/A | block | block | yes | @navtitle

bookmap elements (new in DITA 1.1)

The bookmap specialization contains many phrase-based elements inside the bookmeta. These are metadata, and should not be translated.

As of DITA 1.2, the @navtitle attribute is deprecated, for translation purposes, in favor of the new <navtitle> element.

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
abbrevlist | topicref | yes | block | block | yes | @navtitle
amendments | topicref | yes | block | block | yes | @navtitle
appendix | topicref | yes | block | block | yes | @navtitle
approved | data | yes | block | block | no |
backmatter | topicref | yes | block | block | yes |
bibliolist | topicref | yes | block | block | yes | @navtitle
bookabstract | topicref | yes | block | block | yes | @navtitle
bookchangehistory | data | yes | block | block | no |
bookevent | data | yes | block | block | no |
bookeventtype | data | yes | block | block | no |
bookid | data | yes | block | block | no |
booklibrary | ph | yes | inline | inline | yes |
booklist | topicref | yes | block | block | yes | @navtitle
booklists | topicref | yes | block | block | yes |
bookmap | map | no | block | block | yes | removed title attribute
bookmeta | topicmeta | yes | block | block | yes |
booknumber | data | yes | block | block | no |
bookowner | data | yes | block | block | no |
bookpartno | data | yes | block | block | no |
bookrestriction | data | yes | block | block | no |
bookrights | data | yes | block | block | no |
booktitle | title | yes | block | block | yes |
booktitlealt | ph | yes | inline | inline | yes |
chapter | topicref | yes | block | block | yes | @navtitle
colophon | topicref | yes | block | block | yes | @navtitle
completed | ph | no | inline | inline | no |
copyrfirst | data | yes | block | block | no |
copyrlast | data | yes | block | block | no |
day | ph | no | inline | inline | no |
dedication | topicref | yes | block | block | yes | @navtitle
draftintro | topicref | yes | block | block | yes | @navtitle
edited | data | yes | block | block | no |
edition | data | yes | block | block | no |
figurelist | topicref | yes | block | block | yes | @navtitle
frontmatter | topicref | yes | block | block | yes | @navtitle
glossarylist | topicref | yes | block | block | yes | @navtitle
indexlist | topicref | yes | block | block | yes | @navtitle
isbn | data | yes | block | block | no |
mainbooktitle | ph | yes | inline | inline | yes |
maintainer | data | yes | block | block | no |
month | ph | no | inline | inline | no |
notices | topicref | yes | block | block | yes | @navtitle
organization | data | yes | block | block | no |
part | topicref | yes | block | block | yes | @navtitle
person | data | yes | block | block | no |
preface | topicref | yes | block | block | yes | @navtitle
printlocation | data | yes | block | block | no |
published | data | yes | block | block | no |
publisherinformation | publisher | yes | block | block | yes |
publishtype | data | yes | block | block | no |
reviewed | data | yes | block | block | no |
revisionid | ph | no | inline | inline | no |
started | ph | no | inline | inline | no |
summary | ph | yes | inline | inline | yes |
tablelist | topicref | yes | block | block | yes | @navtitle
tested | data | yes | block | block | no |
toc | topicref | yes | block | block | yes | @navtitle
trademarklist | topicref | yes | block | block | yes | @navtitle
volume | data | yes | block | block | no |
year | ph | no | inline | inline | no |

concept elements

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
conbody | body | yes | block | block | yes |
conbodydiv (new in DITA 1.2) | bodydiv | yes | block | block | yes |
concept | topic | yes | block | block | yes |

glossentry elements (new in DITA 1.1)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
glossAbbreviation (new in DITA 1.2) | title | yes | block | block | yes |
glossAcronym (new in DITA 1.2) | title | yes | block | block | yes |
glossAlt (new in DITA 1.2) | section | yes | block | block | yes | removes @spectitle
glossAlternateFor (new in DITA 1.2) | xref | yes | inline | n/a (empty element) | n/a |
glossbody (new in DITA 1.2) | body, conbody | yes | block | block | yes |
glossdef | abstract | yes | block | block | yes |
glossentry | topic, concept | yes | block | block | yes |
glossPartOfSpeech (new in DITA 1.2) | data | yes | N/A (metadata) | block | no |
glossProperty (new in DITA 1.2) | data | yes | N/A (metadata) | block | no |
glossScopeNote (new in DITA 1.2) | note | yes | block | block | yes | @othertype
glossShortForm (new in DITA 1.2) | title | yes | block | block | yes |
glossStatus (new in DITA 1.2) | data | yes | N/A (metadata) | block | no |
glossSurfaceForm (new in DITA 1.2) | p | yes | block | block | yes |
glossSymbol (new in DITA 1.2) | image | yes | block when @placement= break, otherwise inline | block when @placement= break, otherwise inline | yes | removes @alt
glossSynonym (new in DITA 1.2) | title | yes | block | block | yes |
glossterm (new in DITA 1.2) | title | yes | block | block | yes |
glossUsage (new in DITA 1.2) | note | yes | block | block | yes | @othertype (removes @spectitle)

reference elements

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
propdesc | stentry | yes | block | block | yes | @specentry2
propdeschd | stentry | yes | block | block | yes | @specentry2
properties | simpletable | yes | block | block | yes | @spectitle2
property | strow | yes | block | block | yes |
prophead | sthead | yes | block | block | yes |
proptype | stentry | yes | block | block | yes | @specentry2
proptypehd | stentry | yes | block | block | yes | @specentry2
propvalue | stentry | yes | block | block | yes | @specentry2
propvaluehd | stentry | yes | block | block | yes | @specentry2
refbody | body | yes | block | block | yes |
refbodydiv (new in DITA 1.2) | bodydiv | yes | block | block | yes |
reference | topic | yes | block | block | yes |
refsyn | section | yes | block | block | yes | @spectitle2

task elements

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
chdesc | stentry | yes | block | block | yes | @specentry2
chdeschd | stentry | yes | block | block | yes | @specentry2
chhead | sthead | yes | block | block | yes |
choice | li | yes | block | block | yes |
choices | ul | yes | block | block | yes | removes @spectitle
choicetable | simpletable | yes | block | block | yes | @spectitle2
choption | stentry | yes | block | block | yes | @specentry2
choptionhd | stentry | yes | block | block | yes | @specentry2
chrow | strow | yes | block | block | yes |
cmd | ph | NO | inline | block | yes |
context | section | yes | block | block | yes | removes @spectitle
info | itemgroup | NO | inline | block | yes |
postreq | section | yes | block | block | yes | removes @spectitle
prereq | section | yes | block | block | yes | removes @spectitle
result | section | yes | block | block | yes | removes @spectitle
step | li | yes | block | block | yes |
stepresult | itemgroup | NO | inline | block | yes |
steps | ol | yes | block | block | yes | removes @spectitle
steps-informal (new in DITA 1.2) | section | yes | block | block | yes | removes @spectitle
steps-unordered | ul | yes | block | block | yes | removes @spectitle
stepsection (new in DITA 1.2) | li | yes | block | block | yes |
stepxmp | itemgroup | NO | inline | block | yes |
substep | li | yes | block | block | yes |
substeps | ol | yes | block | block | yes | removes @spectitle
task | topic | yes | block | block | yes |
taskbody | body | yes | block | block | yes |
tutorialinfo | itemgroup | NO | inline | block | yes |

hi-d elements (highlight domain)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
b | ph | yes | inline | inline | yes |
i | ph | yes | inline | inline | yes |
sub | ph | yes | inline | inline | yes |
sup | ph | yes | inline | inline | yes |
tt | ph | yes | inline | inline | yes |
u | ph | yes | inline | inline | yes |

indexing-d elements (indexing domain) (new in DITA 1.1)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
index-see | index-base | yes | block***1 | block | yes |
index-see-also | index-base | yes | block***1 | block | yes |
index-sort-as | index-base | yes | block***1 | block | yes |

pr-d elements (programming domain)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
apiname | keyword | yes | inline | inline | yes |
codeblock | pre | yes | block | block | yes | @spectitle2
codeph | ph | yes | inline | inline | yes |
coderef (new in DITA 1.2) | xref | yes | inline | N/A (empty element) | N/A |
delim | ph | yes | inline | inline | yes |
fragment | figgroup | yes | block | block | yes |
fragref | xref | yes | inline | inline | yes |
groupchoice | figgroup | yes | block | block | yes |
groupcomp | figgroup | yes | block | block | yes |
groupseq | figgroup | yes | block | block | yes |
kwd | keyword | yes | inline | inline | yes |
oper | ph | yes | inline | inline | yes |
option | keyword | yes | inline | inline | yes |
parml | dl | yes | block | block | yes | @spectitle2
parmname | keyword | yes | inline | inline | yes |
pd | dd | yes | block | block | yes |
plentry | dlentry | yes | block | block | yes |
pt | dt | yes | block | block | yes |
repsep | ph | yes | inline | inline | yes |
sep | ph | yes | inline | inline | yes |
synblk | figgroup | yes | block | block | yes |
synnote | fn | yes | block | block | yes |
synnoteref | xref | yes | inline | inline | yes |
synph | ph | yes | inline | inline | yes |
syntaxdiagram | fig | yes | block | block | yes | removes @spectitle
var | ph | yes | inline | inline | yes |

sw-d elements (software domain)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
cmdname | keyword | yes | inline | inline | yes |
filepath | ph | yes | inline | inline | yes |
msgblock | pre | yes | block | block | yes | @spectitle2
msgnum | keyword | yes | inline | inline | yes |
msgph | ph | yes | inline | inline | yes |
systemoutput | ph | yes | inline | inline | yes |
userinput | ph | yes | inline | inline | yes |
varname | keyword | yes | inline | inline | yes |

ui-d elements (UI domain)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
menucascade | ph | yes | inline | inline | yes |
screen | pre | yes | block | block | yes | @spectitle2
shortcut | keyword | yes | inline | inline | yes |
uicontrol | ph | yes | inline | inline | yes |
wintitle | keyword | yes | inline | inline | yes |

ut-d elements (Utilities domain)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
area | figgroup | yes | block | block | yes |
coords | ph | NO | inline | inline | no |
imagemap | fig | yes | block | block | yes (can contain translatable alternate text) | @spectitle2
shape | keyword | NO | inline | inline | no |

mapgroup-d elements (mapgroup domain)

As of DITA 1.2, the @navtitle attribute is deprecated, for translation purposes, in favor of the new <navtitle> element.

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
anchorref (new in DITA 1.2) | topicref | yes | block | block | yes | @navtitle
keydef (new in DITA 1.2) | topicref | yes | block | block | yes | @navtitle
mapref (new in DITA 1.2) | topicref | yes | block | block | yes | @navtitle
topicgroup | topicref | yes | block | block | yes | @navtitle
topichead | topicref | yes | block | block | yes | @navtitle
topicset (new in DITA 1.2) | topicref | yes | block | block | yes | @navtitle
topicsetref (new in DITA 1.2) | topicref | yes | block | block | yes | @navtitle

xnal-d elements (XNAL domain) (new in DITA 1.1)

The XNAL information is all metadata, so it generally does not need to be translated. Exceptions may be needed when selections from this metadata are used for display purposes. The standard behavior may need to change based on local business rules. For example, in some cases it may be appropriate to translate the honorific, country, or organizationname elements.

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
addressdetails | ph | no | block | block | no |
administrativearea | ph | no | block | block | no |
authorinformation | author | no | block | block | no |
contactnumber | data | no | block | block | no |
contactnumbers | data | no | block | block | no |
country | ph | no | block | block | no |
emailaddress | data | no | block | block | no |
emailaddresses | data | no | block | block | no |
firstname | data | no | block | block | no |
generationidentifier | data | no | block | block | no |
honorific | data | no | block | block | no |
lastname | data | no | block | block | no |
locality | ph | no | block | block | no |
localityname | ph | no | block | block | no |
middlename | data | no | block | block | no |
namedetails | data | no | block | block | no |
organizationinfo | data | no | block | block | no |
organizationname | ph | no | block | block | no |
organizationnamedetails | ph | no | block | block | no |
otherinfo | data | no | block | block | no |
personinfo | data | no | block | block | no |
personname | data | no | block | block | no |
postalcode | ph | no | block | block | no |
thoroughfare | ph | no | block | block | no |
url | data | no | block | block | no |
urls | data | no | block | block | no |

Delayed Conref Resolution domain elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
anchorid | keyword | no | N/A (metadata) | n/a | no |
anchorkey | keyword | no | N/A (metadata) | n/a | no |
exportanchors | keywords | no | N/A (metadata) | n/a | no |

Hazard Statement Domain (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
consequence | li | yes | block | block | yes |
hazardstatement | note | yes | block | block | yes | @othertype, @spectitle2
hazardsymbol | image | yes | block when @placement= break, otherwise inline | block when @placement= break, otherwise inline | yes | removes @alt
howtoavoid | li | yes | block | block | yes |
messagepanel | ul | yes | block | block | yes | @spectitle2
typeofhazard | li | yes | block | block | yes |

glossgroup elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
glossgroup | topic | yes | block | block | yes |

glossref domain elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
glossref | topicref | yes | block | block | yes | @navtitle

abbreviated-form domain elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
abbreviated-form | term | yes | inline | N/A empty element | N/A |

task requirements domain (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
closereqs | section, postreq | yes | block | block | yes |
esttime | li | yes | block | block | yes |
noconds | li | yes | block | block | yes |
nosafety | li | yes | block | block | yes |
nospares | data | yes | N/A (metadata) | block | no |
nosupeq | data | yes | N/A (metadata) | block | no |
nosupply | data | yes | N/A (metadata) | block | no |
perscat | li | yes | block | block | yes |
perskill | li | yes | block | block | yes |
personnel | li | yes | block | block | yes |
prelreqs | section, prereq | yes | block | block | yes |
reqcond | li | yes | block | block | yes |
reqconds | ol | yes | block | block | yes |
reqcontp | li | yes | block | block | yes |
reqpers | ol | yes | block | block | yes |
safecond | li | yes | block | block | yes |
safety | ol | yes | block | block | yes |
spare | li | yes | block | block | yes |
spares | p | yes | block | block | yes |
sparesli | ul | yes | block | block | yes | @spectitle2
supeqli | ul | yes | block | block | yes | @spectitle2
supequi | li | yes | block | block | yes |
supequip | p | yes | block | block | yes |
supplies | p | yes | block | block | yes |
supply | li | yes | block | block | yes |
supplyli | ul | yes | block | block | yes | @spectitle2

classification domain elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
subjectCell | relcell | yes | block | block | yes |
subjectref | topicref | yes | block | block | yes | @navtitle
topicapply | topicref | yes | block | block | yes | @navtitle
topicCell | relcell | yes | block | block | yes |
topicsubject | topicref | yes | block | block | yes | @navtitle
topicSubjectHeader | relrow | yes | block | block | yes |
topicSubjectRow | relrow | yes | block | block | yes |
topicSubjectTable | reltable | yes | block | block | yes |

subject scheme elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
attributedef | data | yes | N/A (metadata | block | no |
defaultSubject | topicref | yes | block | block | yes | @navtitle
elementdef | data | yes | N/A (metadata) | block | no |
enumerationdef | topicref | yes | block | block | yes | @navtitle
hasInstance | topicref | yes | block | block | yes | @navtitle
hasKind | topicref | yes | block | block | yes | @navtitle
hasNarrower | topicref | yes | block | block | yes | @navtitle
hasPart | topicref | yes | block | block | yes | @navtitle
hasRelated | topicref | yes | block | block | yes | @navtitle
relatedSubjects | topicref | yes | block | block | yes | @navtitle
subjectdef | topicref | yes | block | block | yes | @navtitle
subjectHead | topicref | yes | block | block | yes | @navtitle
subjectHeadMeta | topicmeta | yes | block | block | yes |
schemeref | topicref | yes | block | block | yes | @navtitle
subjectRel | relrow | yes | block | block | yes |
subjectRelHeader | relrow | yes | block | block | yes |
subjectRelTable | reltable | yes | block | block | yes |
subjectRole | relcell | yes | block | block | yes |
subjectScheme | map | yes | block | block | yes | removes @title

learningAssessment elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
learningAssessment | topic, learningBase | yes | block | block | yes |
learningAssessmentbody | body, learningBasebody | yes | block | block | yes |

learning base elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
lcAudience | section | yes | block | block | yes | @spectitle2
lcChallenge | section | yes | block | block | yes | @spectitle2
lcDuration | section | yes | block | block | yes | @spectitle2
lcInstruction | section | yes | block | block | yes | @spectitle2
lcInteraction | section | yes | block | block | yes | @spectitle2
lcInteractionBase | section | yes | block | block | yes | @spectitle2
lcIntro | section | yes | block | block | yes | @spectitle2
lcNextSteps | section | yes | block | block | yes | @spectitle2
lcObjective | li | yes | block | block | yes |
lcObjectives | section | yes | block | block | yes | @spectitle2
lcObjectivesGroup | ul | yes | block | block | yes |
lcObjectivesStem | ph | yes | inline | inline | yes |
lcPrereqs | section | yes | block | block | yes | @spectitle2
lcResources | section | yes | block | block | yes | @spectitle2
lcReview | section | yes | block | block | yes | @spectitle2
lcSummary | section | yes | block | block | yes | @spectitle2
lcTime | data | yes | inline | inline | no |
learningBase | topic | yes | block | block | yes |
learningBasebody | body | yes | block | block | yes |

learningContent elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
learningContent | topic, learningBase | yes | block | block | yes |
learningContentbody | body, learningBasebody | yes | block | block | yes |

learningOverview elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
learningOverview | topic, learningBase | yes | block | block | yes |
learningOverviewbody | body, learningBasebody | yes | block | block | yes |

learningSummary elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
learningSummary | topic, learningBase | yes | block | block | yes |
learningSummarybody | body, learningBasebody | yes | block | block | yes |

learningPlan elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
lcAge | p | yes | block | block | yes |
lcAssessment | p | yes | block | block | yes |
lcAttitude | p | yes | block | block | yes |
lcBackground | p | yes | block | block | yes |
lcCIN | fig | yes | block | block | yes | @spectitle2
lcClassroom | fig | yes | block | block | yes | @spectitle2
lcClient | fig | yes | block | block | yes | @spectitle2
lcConstraints | fig | yes | block | block | yes | @spectitle2
lcDelivDate | fig | yes | block | block | yes | @spectitle2
lcDelivery | p | yes | block | block | yes |
lcDownloadTime | fig | yes | block | block | yes | @spectitle2
lcEdLevel | p | yes | block | block | yes |
lcFileSizeLimitations | fig | yes | block | block | yes | @spectitle2
lcGapAnalysis | section | yes | block | block | yes | @spectitle2
lcGapItem | fig | yes | block | block | yes | @spectitle2
lcGapItemDelta | p | yes | block | block | yes |
lcGeneralDescription | p | yes | block | block | yes |
lcGoals | p | yes | block | block | yes |
lcGraphics | fig | yes | block | block | yes | @spectitle2
lcHandouts | fig | yes | block | block | yes | @spectitle2
lcIntervention | section | yes | block | block | yes | @spectitle2
lcInterventionItem | fig | yes | block | block | yes | @spectitle2
lcJtaItem | p | yes | block | block | yes |
lcKnowledge | p | yes | block | block | yes |
lcLearnStrat | p | yes | block | block | yes |
lcLMS | fig | yes | block | block | yes | @spectitle2
lcModDate | fig | yes | block | block | yes | @spectitle2
lcMotivation | p | yes | block | block | yes |
lcNeeds | p | yes | block | block | yes |
lcNeedsAnalysis | section | yes | block | block | yes | @spectitle2
lcNoLMS | fig | yes | block | block | yes | @spectitle2
lcOJT | fig | yes | block | block | yes | @spectitle2
lcOrganizational | fig | yes | block | block | yes | @spectitle2
lcOrgConstraints | p | yes | block | block | yes |
lcPlanAudience | fig | yes | block | block | yes | @spectitle2
lcPlanDescrip | fig | yes | block | block | yes | @spectitle2
lcPlanObjective | p | yes | block | block | yes |
lcPlanPrereqs | fig | yes | block | block | yes | @spectitle2
lcPlanResources | p | yes | block | block | yes |
lcPlanSubject | fig | yes | block | block | yes | @spectitle2
lcPlanTitle | fig | yes | block | block | yes | @spectitle2
lcPlayers | fig | yes | block | block | yes | @spectitle2
lcProcesses | p | yes | block | block | yes |
lcProject | section | yes | block | block | yes | @spectitle2
lcResolution | fig | yes | block | block | yes | @spectitle2
lcSecurity | fig | yes | block | block | yes | @spectitle2
lcSkills | p | yes | block | block | yes |
lcSpecChars | p | yes | block | block | yes |
lcTask | fig | yes | block | block | yes | @spectitle2
lcTaskItem | p | yes | block | block | yes |
lcTechnical | section | yes | block | block | yes | @spectitle2
lcValues | p | yes | block | block | yes |
lcViewers | fig | yes | block | block | yes | @spectitle2
lcW3C | fig | yes | block | block | yes | @spectitle2
lcWorkEnv | fig | yes | block | block | yes | @spectitle2
lcWorkEnvDescription | p | yes | block | block | yes |
learningPlan | topic, learningBase | yes | block | block | yes |
learningPlanbody | body, learningBasebody | yes | block | block | yes |

learning map domain elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
learningContentRef | topicref | yes | block | block | yes | @navtitle
learningGroup | topicref | yes | block | block | yes | @navtitle
learningObject | topicref | yes | block | block | yes | @navtitle
learningOverviewRef | topicref | yes | block | block | yes | @navtitle
learningPlanRef | topicref | yes | block | block | yes | @navtitle
learningPostAssessmentRef | topicref | yes | block | block | yes | @navtitle
learningPreAssessmentRef | topicref | yes | block | block | yes | @navtitle
learningSummaryRef | topicref | yes | block | block | yes | @navtitle

learning domain elements (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
lcAnswerContent | p | yes | block | block | yes |
lcAnswerOption | li | yes | block | block | yes |
lcAnswerOptionGroup | ul | yes | block | block | yes |
lcArea | figgroup | yes | block | block | yes |
lcAreaCoords | ph | NO | inline | inline | no |
lcAreaShape | keyword | NO | inline | inline | no |
lcAsset | p | yes | block | block | yes |
lcCorrectResponse | data | yes | N/A | block | no |
lcFeedback | p | yes | block | block | yes |
lcFeedbackCorrect | p | yes | block | block | yes |
lcFeedbackIncorrect | p | yes | block | block | yes |
lcHotspot | fig | yes | block | block | yes |
lcHotspotMap | figgroup | yes | block | block | yes |
lcInstructornote | note | yes | block | block | yes | @spectitle2
lcItem | stentry | yes | block | block | yes | removes @specentry
lcMatching | fig | yes | block | block | yes |
lcMatchingItem | stentry | yes | block | block | yes | removes @specentry
lcMatchingItemFeedback | stentry | yes | block | block | yes | removes @specentry
lcMatchTable | simpletable | yes | block | block | yes | removes @spectitle
lcMatchingHeader | sthead | yes | block | block | yes |
lcMatchingPair | strow | yes | block | block | yes |
lcMultipleSelect | fig | yes | block | block | yes |
lcOpenAnswer | p | yes | block | block | yes |
lcOpenQuestion | fig | yes | block | block | yes |
lcQuestion | p | yes | block | block | yes |
lcQuestionBase | p | yes | block | block | yes |
lcSequence | data | yes | N/A | block | no |
lcSequenceOption | li | yes | block | block | yes |
lcSequenceOptionGroup | ol | yes | block | block | yes |
lcSequencing | fig | yes | block | block | yes |
lcSingleSelect | fig | yes | block | block | yes |
lcTrueFalse | fig | yes | block | block | yes |

learning metadata domain (new in DITA 1.2)

Element name | Specialized from | Inherits everything from ancestor? | Block/Inline (presentation) | Block/Inline (translation) | Translatable content? | Translatable attributes?
lcLom | metadata | yes | block | block | yes |
lomAggregationLevel | data | yes | N/A | block | no |
lomContext | data | yes | N/A | block | no |
lomCoverage | data | yes | N/A | block | no |
lomDifficulty | data | yes | N/A | block | no |
lomInstallationRemarks | data | yes | N/A | block | no |
lomIntendedUserRole | data | yes | N/A | block | no |
lomInteractivityLevel | data | yes | N/A | block | no |
lomInteractivityType | data | yes | N/A | block | no |
lomLearningResourceType | data | yes | N/A | block | no |
lomOtherPlatformRequirements | data | yes | N/A | block | no |
lomSemanticDensity | data | yes | N/A | block | no |
lomStructure | data | yes | N/A | block | no |
lomTechRequirement | data | yes | N/A | block | no |
lomTypicalAgeRange | data | yes | N/A | block | no |
lomTypicalLearningTime | data | yes | N/A | block | no |

DITAVAL elements

The DITAVAL elements are not specialized, and are not rendered on their own, so related columns are dropped from this table. There are no translatable attributes in the DITAVAL element set.

As of DITA 1.2, the only element that directly contains text for translation is <alt-text>.

Element name | Block/Inline (translation) | Translatable content?
alt-text | block | yes
endflag | block | yes (inside nested elements)
prop | block | yes (inside nested elements)
revprop | block | yes (inside nested elements)
startflag | block | yes (inside nested elements)
style-conflict | block | N/A (empty element)
val | block | yes (inside nested elements)
Parent topic: Appendix B Non-normative information
Previous topic: B.4 Considerations for generalizing <foreign> elements
Next topic: B.6 DITA module and shell implementation reference
1 This element is considered a "subflow" element for translation. If it is located in the middle of a translation segment, it should not be translated as part of that segment. For example, indexterm, fn, and draft-comment may divide a sentence in two, but should be treated as blocks, and should not interrupt the sentence.
2 The spectitle and specentry attributes can contain translatable text. The direct use of fixed-in-the-DTD text by tools is discouraged, in favor of using the value as a lookup string to find the translation outside of the file, using accepted localization methods for generated text.
3 The block vs. inline designation for the foreign element is likely to change for some specializations.
4 The desc, object, and image elements inside <foreign> should still be translatable; they provide an alternative display if the foreign content cannot be processed.
5 The use of the alt attribute is deprecated in favor of the alt element.
6 The desc, object, and image elements inside <foreign> should still be translatable; they provide an alternative display if the foreign content cannot be processed.
7 The block vs. inline designation for the foreign element is likely to change for some specializations.
8 (deprecated as of DITA 1.2 for translation purposes)


DITA module and shell implementation reference

B.6 DITA module and shell implementation reference

(Non-normative) The DITA standard defines a set of base types and vocabulary modules and a set of specialized map types, topic types, and domains.

Parent topic: Appendix B Non-normative information
Previous topic: B.5 Element-by-element recommendations for translators
Next topic: B.7 DTD organization


DTD organization

B.7 DTD organization

(Non-normative) The OASIS DITA document types are implemented with a set of DTD modules. Some of these modules are used by every DITA document type, others are only used by topics or by maps, and some are only used in specific specializations.

Description of DITA modules

The tables below describe the modules that are defined by the DITA standard.

Table 1. Description of common modules
Common module files | Purpose
Common elements (commonElements) | Defines all content elements that may appear in both maps and topics.
Metadata elements (metaDecl) | Defines meta elements that may appear in both maps and topics
Table elements (tblDecl) | Defines the complex tables used within DITA, based on the OASIS Exchange Table model.
DITA Architecture attribute (ditaarch.xsd) | XML Schema only - Defines the attribute that defines DITA's architectural version
XML namespace attributes (xml.xsd) | XML Schema only - Defines the attributes with the XML namespace
Table 2. Description of domain modules
Domains | Purpose
Indexing domain | The indexing domain provides several new elements for use with indexing. The new elements allow authors to define "See" and "See also" references, and to override the default sort order for a term.
Highlight domain | The typographic elements are used to highlight text with styles (such as bold, italic, and monospace). Never use these elements when a semantically specific element is available. These elements are not intended for use by specializers, and are intended solely for use by authors when no semantically appropriate element is available and a formatting effect is required.
Programming domain | The programming domain elements are used to define the syntax and to give examples of programming languages.
Software domain | The software domain elements are used to describe the operation of a software program.
UI domain | The user interface domain elements are used to describe the user interface of a software program.
Utilities domain | The utilities domain elements represent common features of a language that may not necessarily be semantic, such as image maps.
Map Group domain | The mapgroup domain elements define, group, or reference content.
xNAL domain | The xNAL domain elements represent a subset of the Extensible Name and Address Standard. The domain can be included in any topic type or map, although the implementations provided by OASIS only include it in the bookmap specialization. It is used to encode information about the author or authors of DITA information.
Hazard Statement domain | The hazard statement domain elements represent labeling for product safety hazards that readers need to be aware of. The domain can be included in any topic type or map. Its elements are used to inform readers about potential hazards, consequences, and avoidance strategies
Machine Industry domain | The machine-industry task domain contains elements for use describing tasks that involve machines or other pieces of hardware.
Delay Resolution domain | The delayed conref resolution domain provides several elements for use when using DITA in situations that enable delayed or run time resolution of conref. The elements allow users to resolve some conref values statically, while delaying others for later resolution.
Abbreviate domain | The abbreviate domain element is used to represent a reference to a term that may appear in an abbreviated form (often an acronym).
Glossref domain | The glossref domain elements are convenience elements that are used to reference glossary topics or to reference multiple topics in a single collection.
Classify domain | The classification domain elements are used to identify subjects covered by the content
Learning domain | The learning domain elements represent the base elements that are used to create learning and training content.
Learning Interaction Base domain | The learning interaction base domain defines an "abstract" base type for all learning assessments.
Learning Map domain | The learning and training map domain organizes groups of topics as learning objects
Learning Metadata domain | The learning and training metadata domain describes specific characteristics of the learning content.
Table 3. Description of topic and its specialization modules
Topic types | Purpose
Topic | Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Base Topic | Topic modules Highlight domain Utilities domain Indexing domain Hazard Statement domain
DITABase | Concept modules Topic modules Reference modules Task modules General Task modules Glossary Entry modules GlossGroup modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Concept | Concept modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Glossary | Glossary Entry modules Concept modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
GlossGroup | GlossGroup modules Concept modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Reference | Reference modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Task | Task modules Topic modules Strict Taskbody module UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
General Task | Task modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Machinery Task | Task modules Topic modules UI domain Highlight domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain Machine Industry domain
Learning Assessment | Learning Assessment modules Topic modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Learning Content | Learning Content modules Learning Assessment modules Learning Summary modules Concept modules Topic modules Reference modules Task modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Learning Overview | Learning Overview modules Topic modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Learning Plan | Learning Plan modules Topic modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Learning Summary | Learning Summary modules Topic modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Table 4. Description of map and its specialization modules
Map types | Purpose
Map | Map modules Map Group domain Indexing domain Delay Resolution domain Glossref domain UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Base Map | Map modules Map Group domain Indexing domain Delay Resolution domain Highlight domain Utilities domain Hazard Statement domain
Bookmap | Bookmap modules Map modules Map Group domain Indexing domain Delay Resolution domain UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Classification Map | Map modules Map Group domain Indexing domain Delay Resolution domain Classification domain Highlight domain Utilities domain Hazard Statement domain
Subject Scheme | Subject Scheme modules Map modules Map Group domain Highlight domain Utilities domain Hazard Statement domain
Learning Map | Map modules Map Group domain Indexing domain Delay Resolution domain Learning Metadata domain Learning Map domain Highlight domain Utilities domain Hazard Statement domain
Learning Bookmap | Map modules Bookmap modules Map Group domain Indexing domain Delay Resolution domain xNAL Domain Learning Metadata domain Learning Map domain Highlight domain Utilities domain Hazard Statement domain
Table 5. Description of constraint modules
Constraint types | Purpose
Strict Taskbody | The strict task body has a constrained structure.
Machinery Taskbody | The machinery task body makes use of elements prelreqs and closereqs instead of prereq and postreq

Public identifiers for DTDs

Each standard DTD has a public identifier that can be used to reference either the latest version or a specific version of the DTD. Each module component has a version-independent public ID as well as a version-specific public ID, one for each version of DITA.

The public IDs follow the pattern "-//OASIS//DTD DITA versionNumber topic-or-map-type//EN", where versionNumber is a DITA version number (1.0, 1.1, etc.) or is omitted entirely and topic-or-map-type is the name of the topic or map type in camel case, e.g., "Concept", "Task", "BookMap", etc.

Note that "OASIS" is the "owner identifier" of the public IDs and indicates artifacts owned by OASIS.

Public identifiers for shells not defined by the DITA Technical Committee should use an owner identifier reflecting the owner of the shell, e.g. "example.com" or "IBM" or a similarly unambiguous identifier. The keyword "DITA" is a convention indicating that the artifact is DITA-related.

The full set of module components and their associated public identifiers is provided in the XML entity resolution catalog that is part of the DITA DTD package.

The identifiers listed below are declared by the DITA Technical Committee for modules that are shipped with the DITA 1.2 distribution. Values that use a version number of 1.2 will always refer specifically to modules delivered with the DITA 1.2 specification. Values that use a version number of 1.x always refer to that module in the latest approved DITA 1.x specification (such as 1.1, 1.2, or 1.3), but will not reference any modules in DITA 2.0 or later. Values without a version number refer to that module in the latest approved DITA specification, regardless of version.

Topic and topic-based specializations

PUBLIC "-//OASIS//DTD DITA Concept//EN" "concept.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Concept//EN" "concept.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Concept//EN" "concept.dtd"

PUBLIC "-//OASIS//DTD DITA Composite//EN" "ditabase.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Composite//EN" "ditabase.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Composite//EN" "ditabase.dtd"

PUBLIC "-//OASIS//DTD DITA Glossary Entry//EN" "glossentry.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Glossary Entry//EN" "glossentry.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Glossary Entry//EN" "glossentry.dtd"

(NOTE: the glossary.dtd file is provided for backward compatibility with
DITA 1.1. Documents should use the glossentry.dtd in new documents.)

PUBLIC "-//OASIS//DTD DITA Glossary//EN" "glossary.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Glossary//EN" "glossary.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Glossary//EN" "glossary.dtd"

PUBLIC "-//OASIS//DTD DITA Reference//EN" "reference.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Reference//EN" "reference.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Reference//EN" "reference.dtd"

PUBLIC "-//OASIS//DTD DITA Task//EN" "task.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Task//EN" "task.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Task//EN" "task.dtd"

PUBLIC "-//OASIS//DTD DITA General Task//EN" "generalTask.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x General Task//EN" "generalTask.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 General Task//EN" "generalTask.dtd"

PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Topic//EN" "topic.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Topic//EN" "topic.dtd"

PUBLIC "-//OASIS//DTD DITA Base Topic//EN" "basetopic.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Base Topic//EN" "basetopic.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Base Topic//EN" "basetopic.dtd"

PUBLIC "-//OASIS//DTD DITA Machinery Task//EN" "machineryTask.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Machinery Task//EN" "machineryTask.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Machinery Task//EN" "machineryTask.dtd"

PUBLIC "-//OASIS//DTD DITA 1.2 Learning Assessment//EN" "learningAssessment.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Learning Assessment//EN" "learningAssessment.dtd"
PUBLIC "-//OASIS//DTD DITA Learning Assessment//EN" "learningAssessment.dtd"

PUBLIC "-//OASIS//DTD DITA 1.2 Learning Content//EN" "learningContent.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Learning Content//EN" "learningContent.dtd"
PUBLIC "-//OASIS//DTD DITA Learning Content//EN" "learningContent.dtd"

PUBLIC "-//OASIS//DTD DITA 1.2 Learning Overview//EN" "learningOverview.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Learning Overview//EN" "learningOverview.dtd"
PUBLIC "-//OASIS//DTD DITA Learning Overview//EN" "learningOverview.dtd"

PUBLIC "-//OASIS//DTD DITA 1.2 Learning Plan//EN" "learningPlan.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Learning Plan//EN" "learningPlan.dtd"
PUBLIC "-//OASIS//DTD DITA Learning Plan//EN" "learningPlan.dtd"

PUBLIC "-//OASIS//DTD DITA 1.2 Learning Summary//EN" "learningSummary.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Learning Summary//EN" "learningSummary.dtd"
PUBLIC "-//OASIS//DTD DITA Learning Summary//EN" "learningSummary.dtd"

Map and map-based specializations

PUBLIC "-//OASIS//DTD DITA Map//EN" "map.dtd"
PUBLIC "-//OASIS//DTD DITA 1.1 Map//EN" "map.dtd"
PUBLIC "-//OASIS//DTD DITA 1.0 Map//EN" "map.dtd"

PUBLIC "-//OASIS//DTD DITA Base Map//EN" "basemap.dtd"
PUBLIC "-//OASIS//DTD DITA 1.1 Base Map//EN" "basemap.dtd"
PUBLIC "-//OASIS//DTD DITA 1.0 Base Map//EN" "basemap.dtd"

PUBLIC "-//OASIS//DTD DITA BookMap//EN" "bookmap.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 BookMap//EN" "bookmap.dtd"
PUBLIC "-//OASIS//DTD DITA 1.1 BookMap//EN" "bookmap.dtd"

PUBLIC "-//OASIS//DTD DITA Subject Scheme Map//EN" "subjectScheme.dtd"
PUBLIC "-//OASIS//DTD DITA Subject Scheme 1.x Map//EN" "subjectScheme.dtd"
PUBLIC "-//OASIS//DTD DITA Subject Scheme 1.2 Map//EN" "subjectScheme.dtd"

PUBLIC "-//OASIS//DTD DITA Classification Map//EN" "classifyMap.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Classification Map//EN" "classifyMap.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 Classification Map//EN" "classifyMap.dtd"

PUBLIC "-//OASIS//DTD DITA 1.2 Learning BookMap//EN" "learningBookmap.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Learning BookMap//EN" "learningBookmap.dtd"
PUBLIC "-//OASIS//DTD DITA Learning BookMap//EN" "learningBookmap.dtd"

PUBLIC "-//OASIS//DTD DITA 1.2 Learning Map//EN" "learningMap.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x Learning Map//EN" "learningMap.dtd"
PUBLIC "-//OASIS//DTD DITA Learning Map//EN" "learningMap.dtd"

DITAVal package for conditional processing

PUBLIC "-//OASIS//DTD DITA DITAVAL//EN" "ditaval.dtd"
PUBLIC "-//OASIS//DTD DITA 1.x DITAVAL//EN" "ditaval.dtd"
PUBLIC "-//OASIS//DTD DITA 1.2 DITAVAL//EN" "ditaval.dtd"

Parent topic: Appendix B Non-normative information
Previous topic: B.6 DITA module and shell implementation reference
Next topic: B.8 XML schema organization


XML schema organization

B.8 XML schema organization

(Non-normative) The OASIS DITA document types are implemented with a set of schema modules. Some of these modules are used by every DITA schema document, others are only used by topics or by maps, and some are only used in specific specializations.

XML schemas versus modules

A significant feature of the DITA implementation is that it places more importance on the modules than on the actual document type shell. All element and attribute type declarations are made in modules, which are then integrated into a document type using a document type shell. Implementers are free to create new document-type shells that reorganize the modules, introduce new modules, redefine modules, or remove modules as appropriate. For example, the standard topic XML Schema from OASIS includes all of the standard topic domains; in addition, while the default topic XML Schema allows topics to nest, it is not possible to include concepts. A new XML Schema can change one or both of these features and still conform to the DITA architecture; the XML Schema may add or remove domains, it may allow topics to nest concepts or allow authoring of different types at the same level, as in the ditabase document type.

Description of DITA modules

The tables below describe the modules that are defined by the DITA standard.

Table 1. Description of common modules
Common module files | Purpose
Common elements (commonElements) | Defines all content elements that may appear in both maps and topics.
Metadata elements (metaDecl) | Defines meta elements that may appear in both maps and topics
Table elements (tblDecl) | Defines the complex tables used within DITA, based on the OASIS Exchange Table model.
DITA Architecture attribute (ditaarch.xsd) | XML Schema only - Defines the attribute that defines DITA's architectural version
XML namespace attributes (xml.xsd) | XML Schema only - Defines the attributes with the XML namespace
Table 2. Description of domain modules
Domains | Purpose
Indexing domain | The indexing domain provides several new elements for use with indexing. The new elements allow authors to define "See" and "See also" references, and to override the default sort order for a term.
Highlight domain | The typographic elements are used to highlight text with styles (such as bold, italic, and monospace). Never use these elements when a semantically specific element is available. These elements are not intended for use by specializers, and are intended solely for use by authors when no semantically appropriate element is available and a formatting effect is required.
Programming domain | The programming domain elements are used to define the syntax and to give examples of programming languages.
Software domain | The software domain elements are used to describe the operation of a software program.
UI domain | The user interface domain elements are used to describe the user interface of a software program.
Utilities domain | The utilities domain elements represent common features of a language that may not necessarily be semantic, such as image maps.
Map Group domain | The mapgroup domain elements define, group, or reference content.
xNAL domain | The xNAL domain elements represent a subset of the Extensible Name and Address Standard. The domain can be included in any topic type or map, although the implementations provided by OASIS only include it in the bookmap specialization. It is used to encode information about the author or authors of DITA information.
Hazard Statement domain | The hazard statement domain elements represent labeling for product safety hazards that readers need to be aware of. The domain can be included in any topic type or map. Its elements are used to inform readers about potential hazards, consequences, and avoidance strategies
Machine Industry domain | The machine-industry task domain contains elements for use describing tasks that involve machines or other pieces of hardware.
Delay Resolution domain | The delayed conref resolution domain provides several elements for use when using DITA in situations that enable delayed or run time resolution of conref. The elements allow users to resolve some conref values statically, while delaying others for later resolution.
Abbreviate domain | The abbreviate domain element is used to represent a reference to a term that may appear in an abbreviated form (often an acronym).
Glossref domain | The glossref domain elements are convenience elements that are used to reference glossary topics or to reference multiple topics in a single collection.
Classify domain | The classification domain elements are used to identify subjects covered by the content
Learning domain | The learning domain elements represent the base elements that are used to create learning and training content.
Learning Interaction Base domain | The learning interaction base domain defines an "abstract" base type for all learning assessments.
Learning Map domain | The learning and training map domain organizes groups of topics as learning objects
Learning Metadata domain | The learning and training metadata domain describes specific characteristics of the learning content.
Table 3. Description of topic and its specialization modules
Topic types | Purpose
Topic | Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Base Topic | Topic modules Highlight domain Utilities domain Indexing domain Hazard Statement domain
DITABase | Concept modules Topic modules Reference modules Task modules General Task modules Glossary Entry modules GlossGroup modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Concept | Concept modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Glossary | Glossary Entry modules Concept modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
GlossGroup | GlossGroup modules Concept modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Reference | Reference modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Task | Task modules Topic modules Strict Taskbody module UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
General Task | Task modules Topic modules UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Machinery Task | Task modules Topic modules UI domain Highlight domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain Machine Industry domain
Learning Assessment | Learning Assessment modules Topic modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Learning Content | Learning Content modules Learning Assessment modules Learning Summary modules Concept modules Topic modules Reference modules Task modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Learning Overview | Learning Overview modules Topic modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Learning Plan | Learning Plan modules Topic modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Learning Summary | Learning Summary modules Topic modules Highlight domain Utilities domain Indexing domain Learning domain Learning Interaction Base domain Learning metadata domain
Table 4. Description of map and its specialization modules
Map types | Purpose
Map | Map modules Map Group domain Indexing domain Delay Resolution domain Glossref domain UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Base Map | Map modules Map Group domain Indexing domain Delay Resolution domain Highlight domain Utilities domain Hazard Statement domain
Bookmap | Bookmap modules Map modules Map Group domain Indexing domain Delay Resolution domain UI domain Software domain Highlight domain Programming domain Utilities domain Indexing domain Hazard Statement domain Abbreviate domain
Classification Map | Map modules Map Group domain Indexing domain Delay Resolution domain Classification domain Highlight domain Utilities domain Hazard Statement domain
Subject Scheme | Subject Scheme modules Map modules Map Group domain Highlight domain Utilities domain Hazard Statement domain
Learning Map | Map modules Map Group domain Indexing domain Delay Resolution domain Learning Metadata domain Learning Map domain Highlight domain Utilities domain Hazard Statement domain
Learning Bookmap | Map modules Bookmap modules Map Group domain Indexing domain Delay Resolution domain xNAL Domain Learning Metadata domain Learning Map domain Highlight domain Utilities domain Hazard Statement domain
Table 5. Description of constraint modules
Constraint types | Purpose
Strict Taskbody | The strict task body has a constrained structure.
Machinery Taskbody | The machinery task body makes use of elements prelreqs and closereqs instead of prereq and postreq

XML Schema catalog identifiers

An XML resolver needs to be able to uniquely identify an XML Schema in order to map to a local resource. The DITA 1.2 specification includes both URN- and URL-based versions of the XML schemas. The URL versions are included as a convenience for use with tools that do not support catalog based resolution and are not normative.

Each schema document must be uniquely identified using a URN (Uniform Resource Name). Each schema document has a version-independent as well as a version-specific URN.

There are two patterns for the URNs. One for schemas that are part of the core standard and one for schemas created by TC subcommittees. The design pattern for the core standard schemas is:

urn:oasis:names:tc:dita:xsd:<filename.xsd>:<version>

The design pattern for schemas created by DITA Technical Committee sub-committees is:

urn:oasis:names:tc:dita:spec:<specialization-family-name>:xsd:<filename.xsd>:<version>

Catalog identifiers for shell schemas and/or specializations that are not defined by the DITA Technical Committee or DITA Technical Committee sub-committees should use an owner identifier reflecting the owner of the shell, e.g. "example.com" then an appropriate URN would be "urn:example.com:names:dita:xsd:topic.xsd". The pattern "urn:oasis:names:tc:dita" is a convention indicating that the artifact is defined by the OASIS DITA Technical Committee.

The identifiers listed below are declared by the DITA Technical Committee for modules that are shipped with the DITA 1.2 distribution. Values that use a version number of 1.2 will always refer specifically to modules delivered with the DITA 1.2 specification. Values that use a version number of 1.x always refer to that module in the latest approved DITA 1.x specification (such as 1.1, 1.2, or 1.3), but will not reference any modules in DITA 2.0 or later. Values without a version number refer to that module in the latest approved DITA specification, regardless of version.

Topic and topic-based specializations

urn:oasis:names:tc:dita:xsd:topic.xsd:1.2
urn:oasis:names:tc:dita:xsd:topic.xsd:1.x
urn:oasis:names:tc:dita:xsd:topic.xsd

urn:oasis:names:tc:dita:xsd:basetopic.xsd:1.2
urn:oasis:names:tc:dita:xsd:basetopic.xsd:1.x
urn:oasis:names:tc:dita:xsd:basetopic.xsd

urn:oasis:names:tc:dita:xsd:concept.xsd:1.2
urn:oasis:names:tc:dita:xsd:concept.xsd:1.x
urn:oasis:names:tc:dita:xsd:concept.xsd

urn:oasis:names:tc:dita:xsd:reference.xsd:1.2
urn:oasis:names:tc:dita:xsd:reference.xsd:1.x
urn:oasis:names:tc:dita:xsd:reference.xsd

urn:oasis:names:tc:dita:xsd:task.xsd:1.2
urn:oasis:names:tc:dita:xsd:task.xsd:1.x
urn:oasis:names:tc:dita:xsd:task.xsd

urn:oasis:names:tc:dita:xsd:generalTask.xsd:1.2
urn:oasis:names:tc:dita:xsd:generalTask.xsd:1.x
urn:oasis:names:tc:dita:xsd:generalTask.xsd

urn:oasis:names:tc:dita:spec:machinery:xsd:machineryTask.xsd:1.2
urn:oasis:names:tc:dita:spec:machinery:xsd:machineryTask.xsd:1.x
urn:oasis:names:tc:dita:spec:machinery:xsd:machineryTask.xsd

urn:oasis:names:tc:dita:xsd:ditabase.xsd:1.2
urn:oasis:names:tc:dita:xsd:ditabase.xsd:1.x
urn:oasis:names:tc:dita:xsd:ditabase.xsd

urn:oasis:names:tc:dita:xsd:ditabaseMod.xsd:1.2
urn:oasis:names:tc:dita:xsd:ditabaseMod.xsd:1.x
urn:oasis:names:tc:dita:xsd:ditabaseMod.xsd

urn:oasis:names:tc:dita:xsd:glossentry.xsd:1.2
urn:oasis:names:tc:dita:xsd:glossentry.xsd:1.x
urn:oasis:names:tc:dita:xsd:glossentry.xsd

(NOTE: the glossary.xsd file is provided for backward compatibility with
DITA 1.1. Documents should use the glossentry.xsd in new documents.)

urn:oasis:names:tc:dita:xsd:glossary.xsd:1.2
urn:oasis:names:tc:dita:xsd:glossary.xsd:1.x
urn:oasis:names:tc:dita:xsd:glossary.xsd

urn:oasis:names:tc:dita:spec:learning:xsd:learningAssessment.xsd:1.2
urn:oasis:names:tc:dita:spec:learning:xsd:learningAssessment.xsd:1.x
urn:oasis:names:tc:dita:spec:learning:xsd:learningAssessment.xsd

urn:oasis:names:tc:dita:spec:learning:xsd:learningContent.xsd:1.2
urn:oasis:names:tc:dita:spec:learning:xsd:learningContent.xsd:1.x
urn:oasis:names:tc:dita:spec:learning:xsd:learningContent.xsd

urn:oasis:names:tc:dita:spec:learning:xsd:learningSummary.xsd:1.2
urn:oasis:names:tc:dita:spec:learning:xsd:learningSummary.xsd:1.x
urn:oasis:names:tc:dita:spec:learning:xsd:learningSummary.xsd

urn:oasis:names:tc:dita:spec:learning:xsd:learningPlan.xsd:1.2
urn:oasis:names:tc:dita:spec:learning:xsd:learningPlan.xsd:1.x
urn:oasis:names:tc:dita:spec:learning:xsd:learningPlan.xsd

urn:oasis:names:tc:dita:spec:learning:xsd:learningOverview.xsd:1.2
urn:oasis:names:tc:dita:spec:learning:xsd:learningOverview.xsd:1.x
urn:oasis:names:tc:dita:spec:learning:xsd:learningOverview.xsd

Map and map-based specializations

urn:oasis:names:tc:dita:xsd:map.xsd:1.2
urn:oasis:names:tc:dita:xsd:map.xsd:1.x
urn:oasis:names:tc:dita:xsd:map.xsd

urn:oasis:names:tc:dita:xsd:basemap.xsd:1.2
urn:oasis:names:tc:dita:xsd:basemap.xsd:1.x
urn:oasis:names:tc:dita:xsd:basemap.xsd

urn:oasis:names:tc:dita:xsd:bookmap.xsd:1.2
urn:oasis:names:tc:dita:xsd:bookmap.xsd:1.x
urn:oasis:names:tc:dita:xsd:bookmap.xsd

urn:oasis:names:tc:dita:spec:classification:xsd:subjectScheme.xsd:1.2
urn:oasis:names:tc:dita:spec:classification:xsd:subjectScheme.xsd:1.x
urn:oasis:names:tc:dita:spec:classification:xsd:subjectScheme.xsd

urn:oasis:names:tc:dita:spec:classification:xsd:classifyMap.xsd:1.2
urn:oasis:names:tc:dita:spec:classification:xsd:classifyMap.xsd:1.x
urn:oasis:names:tc:dita:spec:classification:xsd:classifyMap.xsd

urn:oasis:names:tc:dita:spec:learning:xsd:learningBookmap.xsd:1.2
urn:oasis:names:tc:dita:spec:learning:xsd:learningBookmap.xsd:1.x
urn:oasis:names:tc:dita:spec:learning:xsd:learningBookmap.xsd

urn:oasis:names:tc:dita:spec:learning:xsd:learningMap.xsd:1.2
urn:oasis:names:tc:dita:spec:learning:xsd:learningMap.xsd:1.x
urn:oasis:names:tc:dita:spec:learning:xsd:learningMap.xsd

DITAVal package for conditional processing

urn:oasis:names:tc:dita:xsd:ditaval.xsd:1.2
urn:oasis:names:tc:dita:xsd:ditaval.xsd:1.x
urn:oasis:names:tc:dita:xsd:ditaval.xsd

Parent topic: Appendix B Non-normative information
Previous topic: B.7 DTD organization
Next topic: B.9 Processing component modularization and naming conventions


Processing component modularization and naming conventions

B.9 Processing component modularization and naming conventions

Files that implement processing associated with specific vocabulary or constraint modules should generally be organized by module, such that the implementation components correspond to the vocabulary modules that they implement and are, to the degree the implementation technology provides for it, similarly modular.

For example, the DITA Open Toolkit provides a general plugin mechanism that allows implementation components to be dynamically added to and removed from a Toolkit instance. General practice is to define Toolkit plugins that correspond to modules.

For the specific case of cascading style sheets and XSLTs transformations, two key DITA implementation technologies, the suggested filenaming conventions are:

CSS override files (recommended convention for tool providers)
  • typename.css
  • customization-purpose.css
XSLT override files (recommended convention for tool providers)
  • typename.xsl
  • customization-purpose.xsl
Parent topic: Appendix B Non-normative information
Previous topic: B.8 XML schema organization
Next topic: B.10 Processing interoperability considerations


Processing interoperability considerations

B.10 Processing interoperability considerations

(Non-normative) The DITA specification does not require processors to perform filtering, content reference resolution, key space construction, and other processing related to base DITA semantics in any particular order. This means that different conforming DITA processors may produce different results for the same initial data set and filtering conditions. DITA users and DITA implementers need to be aware of these potential differences in behavior when DITA content will be processed by different processors.

For conditional elements, an element is "applicable" if it is filtered in by active filtering specification and "inapplicable" if it is filtered out.

In general, in any situation in which two elements interact during processing, applying filtering before or after the processing is done will result in different results when either or both of the elements is conditional.

Filtering and content reference resolution

When two elements are merged as result of a content reference, the attributes of the two elements are combined. By default, the attributes of the referencing element take precedence over the referenced element. However, any attribute may specify the value "-dita-use-conref-target", which causes the referenced element's attribute to take precedence. This means that the effective value of the select attributes may reflect either the referencing element or the referenced element depending on how each attribute is configured on the referencing element. This in turn means that, in certain cases, filtering before resolving content references will produce a materially different result than when filtering is applied after resolving content references.

In two cases, the order in which filtering is applied results in either an element being in the effective result or an element not being in the effective result. There is a third case in which there will be either an empty element (and unresolvable content reference) or no element.

In the case where a referenced element is not applicable and the referencing element is explicitly applicable for the same condition (that is, both elements specify values for the same classification domain and the referencing element is applicable), if content references are resolved before filtering, the content reference is resolved and the effective value of the referencing element reflects the referenced element. If content referencing is resolved after filtering, the referenced element is filtered out and the content reference cannot be resolved, typically generating an error.

If the referencing element is not conditional and the referenced element is inapplicable, filtering applied before content reference resolution results in an unresolvable content reference. If filtering is applied after content resolution, the explicit condition on the referenced element becomes the effective value for that condition following content resolution and the result is then filtered out. The difference in these two cases is that in the first case the content reference cannot be resolved, resulting in a processing error and a potentially non-sensical element if the referencing element has required subelements (for example, a content reference from a topic to another topic, where the referencing topic must have a title subelement), but in the second case the element is filtered completely out.

Filtering and key space resolution

DITA allows processors to apply filtering before or after key space construction. Key space construction is the process of determining which key definitions are effective within a given map tree. Given two definitions of the same key with different applicabilities, the effective key space will be different if filtering is applied before key space construction than if it is applied after. In particular, if filtering is applied after key space construction, the key space is invariant, but if filtering is applied before key space construction, the effective key space will differ depending on the active conditions.

As an implementation detail for key-space-constructing processors, if filtering is applied before constructing the key space, then the set of effective key definitions is simply the first definition of each unique key name within the map tree. However, if filtering is applied after key space construction, and in particular, if a processor needs to allow dynamic resolution of keys based on different filtering specifications applied to the same constructed key space, then the set of effective key definitions is the first definition of each pair of unique key name and unique selection specification set. This second form of constructed key space would be needed by processors such as editors and content management systems that need to quickly provide different filtering-specific key bindings without reconstructing the entire key space for each new set of filtering conditions.

For example, given a map that contains two definitions for the key "topic-01", one with an @audience value of "expert" and one with an @audience value of "novice", a filter-first processor would only have at most one effective key definition for the key name "topic-01", whichever of the two definitions was filtered in by the active filter specification and was the first definition encountered (if both happen to be filtered in). In a processor that supports dynamic key definition filtering, there would be two effective definitions for the key name "topic-01", one for @audience of "expert" and one for @audience of "novice". The processor would also need to maintain knowledge of the definition order of the two key definitions in order to correctly handle the case when both "expert" and "novice" are applicable for a given key access request (in which case, whichever of the two definitions was first in the map tree would be used as the effective value of the key).

Link resolution

If a cross reference, link, or other linking element is resolved to its target before filtering and the target is subsequently filtered out, the link would be to a non-existent target but might reflect properties of the target (e.g., a cross reference link text might reflect the target's title). If the link is resolved after filtering is applied and the target is filtered out, the link is to a non-existent target, which will result in a different link text. The rendition effect for the navigation link will be the same: the link cannot be navigated because the target doesn't exist in the rendered result.

Map metadata propagation

Filtering applied before propagation can result in different effective values than if it is applied after. In particular, elements filtered before out will never contribute to propagation.

Topicref resolution

Resolution of topicrefs before filtering can result in use of topic-provided navigation titles or metadata that would not be used if the target topic was filtered out before resolution. In both cases, the topicref as rendered would be to a missing topic.

Chunking

A topicref subsequently filtered out that generates chunks would create chunks in the output if chunk processing is done before filtering but since the topicref would then be filtered out, the chunks would not be referenced.

Copy-to processing

If copy-to processing is done before filtering, two topicrefs, only one of which is applicable, could specify the same copy-to target, leading to a conflict and a potential ambiguity about which governs. If the topicrefs are filtered before copy-to processing, the conflict does not occur.

Parent topic: Appendix B Non-normative information
Previous topic: B.9 Processing component modularization and naming conventions
Next topic: B.11 Specialization design, customization, and the limits of specialization


Specialization design, customization, and the limits of specialization

B.11 Specialization design, customization, and the limits of specialization

(Non-normative) The DITA specialization facility necessarily imposes some constraints. An inherent challenge in designing DITA vocabulary modules and document types is understanding how best to satisfy markup requirements within those constraints and, when requirements cannot be met within the DITA-defined constraints, how to create "customized" document types that diverge from DITA requirements as little as possible.

When applying DITA to new documentation representation and management requirements, an inherent challenge is determining whether or not all requirements can be met by a markup design that fully conforms to the DITA architecture. DITA imposes a few structural constraints that conforming documents must reflect, such as that all topics must have titles, that topic body content must be contained within a body element, that section elements cannot nest, and that element-type-specific metadata must be represented using elements, not attributes.

In cases where markup requirements simply cannot be met by conforming DITA markup but there is a desire to take advantage of DITA features and technology or there is a requirement for content to interoperate or interchange with conforming DITA documents and processing systems, the solution is to define "customized" document types that are not conforming document types but that are, presumably, as close to conforming as possible, so as to minimize the cost of producing conforming documents from non-conforming documents.

Typical reasons for requiring, or appearing to require, custom document types include:
  • Optimizing markup for authoring by excluding unneeded or unwanted element types and attributes provided by the OASIS-provided vocabulary modules.
  • Supporting legacy markup structures that are not consistent with DITA structural rules, such as footnotes within titles or nested sections within what are or should be topic bodies.
  • Defining different forms of existing structures, such as lists, where the DITA-defined structures are too constrained.
  • Providing attributes required by specific processors, such as CMS-defined attributes for maintaining management metadata.
  • Embedding tool-imposed markup in places that do not allow <foreign> or <unknown>.

In many of these cases it is in fact possible to define conforming DITA document types. These techniques should be explored fully before resorting to customized document types.

Optimizing document types for authoring

DITA markup is organized into domain and structural vocabulary modules so that authoring groups can easily select the markup subsets they require by creating new document type shells and, where necessary, new constraint modules.

The base DITA element types necessarily provide very relaxed content models in order to avoid imposing unnecessary constraints on specializers. However, these open content models are often inappropriately open for authoring purposes, where authors are better served by more constrained content models. To address this requirement, DITA provides two configuration mechanisms for defining and configuring document types: document type shells and constraint modules.

Document type shells pull together sets of vocabulary and constraint modules in order to define a working document type. The OASIS-provided shell document types typically include all available vocabulary modules, which is often not what is needed or desired. When the requirement is simply to eliminate unneeded domain modules or topic types, simply define new document type shells that omit unneeded domains or structural types and include any locally-defined or third-party modules you might need. See Configuration (Document type shells) for details.

The DITA constraint mechanism, new with DITA 1.2, makes it possible to configure the content models of individual elements from document type shells. This means you can optimize content models as needed to meet authoring requirements without directly modifying the base vocabulary modules as long as you only need to add constraints or eliminate optional elements, which is usually the case. Again, no specialization is required.

Most authoring optimization requirements can be met with a combination of document type shells and, where necessary, constraint modules when markup requirements are otherwise satisfied by available vocabulary modules.

When markup requirements are not satisfied by existing vocabulary modules, you must create new, specialized, vocabulary modules and integrate them into your document-type shells as needed.

The only case where neither constraint modules nor specialization are applicable for authoring optimization is where authoring requires content models to be less constrained than the DITA-defined rules allow. In that case you have no choice but to define non-conforming document types. This option falls into the category of "custom" document types. Where interchange and interoperation with other DITA systems and information sets are required, you must first transform non-conforming documents into conforming documents, as described below under Map from customized document type to DITA during preprocessing.

Specialization design considerations

Requirements for new markup often appear to be inconsistent or incompatible with DITA architectural rules or existing markup, especially when mapping existing non-DITA markup practice to DITA, where the existing markup may have used structures that cannot be directly expressed in DITA. For example, you may need markup for a specialized form of list where the details are not consistent with the base model for DITA lists.

In this case you have two alternatives, one that conforms to DITA and one that does not.

  • Specialize from more generic base elements or attributes.

  • Define non-conforming structures and map them to conforming DITA structures as necessary for processing by DITA-aware processors or for interchange as conforming DITA documents.

Specializing from more generic base elements, such as defining a list using specializations of <ph> or <p>, while technically conforming, may still impede interchange of such documents because generic DITA processors will have no way of knowing that what they see as a sequence of phrases or paragraphs or whatever is really a list and should be rendered in a listy way. However, your documents will be reliably interchangeable with conforming DITA systems.

Defining non-conforming markup structures means that the documents that use those structures cannot be conforming DITA documents as authored and therefore cannot be reliably processed by generic DITA-aware processors or interchanged with other DITA systems. However, as long as the documents can be transformed into conforming DITA documents without undue effort interchange and interoperation requirements can be satisfied as needed. This approach will often be needed when using content management systems to manage what is nominally DITA content where the content management system imposes requirements onto the content for whatever reason, such as to add its own markup for management metadata or because of implementation limitations.

In addition, non-conforming document types can use the basic specialization mechanism used by the DITA document types, with the same re-use and interoperation benefits, only restricted to the specific domain within which the new document types apply. Such document types are not conforming DITA document types but may be quite useful because of the general benefits of specialization as an enabling technology.

Note that even if one uses the DITA-defined types as a starting point, any change to those base types not accomplished through specialization or the constraint feature defines a completely new document type that has no normative relationship to the DITA document types, and cannot be considered in any way to be a conforming DITA application. In particular, the use of DITA specialization from non-DITA base types does not produce DITA-conforming vocabularies.

Specialize from generic elements or attributes

Most DITA element types have necessarily relaxed content models specifically to allow a wide set of options when specializing from them. However, some DITA element types do impose constraints that may not be acceptable or appropriate for a specific markup application.

In that case, the first option to consider is choosing as your specialization base more generic base elements or attributes. Generic elements are available in DITA at every level of detail, from whole generic topics down to individual generic keywords, and the generic attribute base is available for attribute domain specialization.

For example, if you want to create a new kind of list but cannot usefully do so specializing from <ul>, <ol>, <sl>, or <dl>, you can create a new set of list elements by specializing nested <ph> elements. This new list structure will require specialized processing to generate appropriate output styling, because it is not semantically tied to the other lists by ancestry. Nevertheless, it will remain a valid DITA specialization, with the standard support for generalization, content referencing, conditional processing, and so forth.

The following base elements in <topic> are generic enough to support almost any structurally valid DITA specialization:
topic
any content unit that has a title and associated content
section
any non-nesting division of content within a topic, titled or not
p
any non-titled block of content below the section level
fig
any titled block of content below the section level
ul, ol, dl, sl, simpletable
any structured block of content that consists of listed items in one or more columns
ph
any division of content below the paragraph level
text
text within a phrase
keyword
any non-nesting division of content below the paragraph level
data
any content that acts as metadata rather than core topic or map content
foreign
any content that already has a non-DITA markup standard but needs to be authored as part of the DITA document and for which processors should attempt rendering if at all possible.
unknown
any non-standard markup that does not fit the DITA model but needs to be managed as part of a DITA document and for which processors should not attempt any form of rendition
bodydiv
generic, untitled, nestable container for content within topic bodies
sectiondiv
generic, untitled, nestable container for content within sections
The following attributes in topic are suitable for domain specialization to provide new attributes that are required throughout a document type:
props
any new conditional processing attribute
base
any new attribute that is universally available, has a simple syntax (space-delimited alphanumeric values), and doesn't already have a semantic equivalent

You should specialize from the semantically closest match whenever possible. When some structural requirement forces you to pick a more general ancestor, please inform the technical committee: over time a richer set of generic elements should become available.

Map from customized document type to DITA during preprocessing

Structural and domain specialization of elements or attributes may not be sufficient for some authoring requirements. In particular, specialization cannot split or rename attributes, and an element cannot be renamed without also specializing its container.

In such cases, it may be possible to transform a customized document type to a standard DITA document type during the publishing process.

For example, if an authoring group requires the <p> element to be spelled out as <paragraph>, the document type could be customized to change <p> to <paragraph> for authoring purposes. Documents so created can then be preprocessed to rename <paragraph> back to <p> before feeding them into a standard publishing process.

The type modules should not be edited to create a customized document type. Instead, a document-type shell can provide new definitions of DITA entities, including entities for attributes and content models. The new definitions override entity definitions in the module files before they are imported.

Customized document types do not conform to the DITA standard. Preprocessing can ensure compatibility with existing publishing processes, but does not ensure compatibility with DITA-supporting authoring tools or content management systems. However, when an implementation is being heavily customized in any case, a customized document type can help isolate and control the consequences of non-standard design in a customized implementation.

Parent topic: Appendix B Non-normative information
Previous topic: B.10 Processing interoperability considerations


DITA Version 1.2 Specification

Darwin Information Typing Architecture (DITA) Version 1.2

OASIS Standard

1 December 2010

Specification URIs:

This Version:

http://docs.oasis-open.org/dita/v1.2/os/spec/DITA1.2-spec.html (Authoritative version)

http://docs.oasis-open.org/dita/v1.2/os/spec/DITA1.2-spec.pdf

http://docs.oasis-open.org/dita/v1.2/os/spec/DITA1.2-spec-chm.zip

http://docs.oasis-open.org/dita/v1.2/os/spec/DITA1.2-spec.zip

Previous Version:

http://docs.oasis-open.org/dita/v1.2/cs01/spec/DITA1.2-spec.html (Authoritative version)

http://docs.oasis-open.org/dita/v1.2/cs01/spec/DITA1.2-spec.pdf

http://docs.oasis-open.org/dita/v1.2/cs01/spec/DITA1.2-spec-chm.zip

http://docs.oasis-open.org/dita/v1.2/cs01/spec/DITA1.2-spec.zip

Latest Version:

http://docs.oasis-open.org/dita/v1.2/spec/DITA1.2-spec.html (Authoritative version)

http://docs.oasis-open.org/dita/v1.2/spec/DITA1.2-spec.pdf

http://docs.oasis-open.org/dita/v1.2/spec/DITA1.2-spec-chm.zip

http://docs.oasis-open.org/dita/v1.2/spec/DITA1.2-spec.zip

Technical Committee:

OASIS Darwin Information Typing Architecture (DITA) TC

Chair

Don Day, Individual Member

Editors:

Kristen James Eberlein, SDL International

Robert D. Anderson, IBM

Gershon Joseph, Cisco Systems, Inc.

Related Work:

This specification replaces or supercedes:

OASIS DITA Version 1.1 Architectural Specification (http://docs.oasis-open.org/dita/v1.1/archspec/archspec.html)

OASIS DITA Version 1.1 Language Specification (http://docs.oasis-open.org/dita/v1.1/langspec/ditaref-type.html)

This specification is related to:

OASIS DITA Version 1.2 DTDs (http://docs.oasis-open.org/dita/v1.2/os/DITA1.2-dtds.zip)

OASIS DITA Version 1.2 XML Schemas (http://docs.oasis-open.org/dita/v1.2/os/DITA1.2-xsds.zip)

Declared XML Namespace:

None

Abstract:

The Darwin Information Typing Architecture (DITA) 1.2 specification defines both a) a set of document types for authoring and organizing topic-oriented information; and b) a set of mechanisms for combining, extending, and constraining document types.

Status:

This document was last revised or approved by the OASIS Darwin Information Typing Architecture (DITA) TC on the above date. The level of approval is also listed above. Check the "Latest Version" or "Latest Approved Version" location noted above for possible later revisions of this document.

Technical Committee members should send comments on this specification to the Technical Committee’s email list. Others should send comments to the Technical Committee by using the “Send A Comment” button on the Technical Committee’s web page at http://www.oasis-open.org/committees/tc_home.php?wg_abbrev=dita.

For information on whether any patents have been disclosed that may be essential to implementing this specification, and any offers of patent licensing terms, please refer to the Intellectual Property Rights section of the Technical Committee web page (http://www.oasis-open.org/committees/dita/ipr.php.

The non-normative errata page for this specification is located at http://www.oasis-open.org/committees/tc_home.php?wg_abbrev=dita.

Notices

Copyright © OASIS® 2010. All Rights Reserved.

All capitalized terms in the following text have the meanings assigned to them in the OASIS Intellectual Property Rights Policy (the "OASIS IPR Policy"). The full Policy may be found at the OASIS website.

This document and translations of it may be copied and furnished to others, and derivative works that comment on or otherwise explain it or assist in its implementation may be prepared, copied, published, and distributed, in whole or in part, without restriction of any kind, provided that the above copyright notice and this section are included on all such copies and derivative works. However, this document itself may not be modified in any way, including by removing the copyright notice or references to OASIS, except as needed for the purpose of developing any document or deliverable produced by an OASIS Technical Committee (in which case the rules applicable to copyrights, as set forth in the OASIS IPR Policy, must be followed) or as required to translate it into languages other than English.

The limited permissions granted above are perpetual and will not be revoked by OASIS or its successors or assigns.

This document and the information contained herein is provided on an "AS IS" basis and OASIS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE INFORMATION HEREIN WILL NOT INFRINGE ANY OWNERSHIP RIGHTS OR ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

OASIS requests that any OASIS Party or any other party that believes it has patent claims that would necessarily be infringed by implementations of this OASIS Committee Specification or OASIS Standard, to notify OASIS TC Administrator and provide an indication of its willingness to grant patent licenses to such patent claims in a manner consistent with the IPR Mode of the OASIS Technical Committee that produced this specification.

OASIS invites any party to contact the OASIS TC Administrator if it is aware of a claim of ownership of any patent claims that would necessarily be infringed by implementations of this specification by a patent holder that is not willing to provide a license to such patent claims in a manner consistent with the IPR Mode of the OASIS Technical Committee that produced this specification. OASIS may include such claims on its website, but disclaims any obligation to do so.

OASIS takes no position regarding the validity or scope of any intellectual property or other rights that might be claimed to pertain to the implementation or use of the technology described in this document or the extent to which any license under such rights might or might not be available; neither does it represent that it has made any effort to identify any such rights. Information on OASIS' procedures with respect to rights in any document or deliverable produced by an OASIS Technical Committee can be found on the OASIS website. Copies of claims of rights made available for publication and any assurances of licenses to be made available, or the result of an attempt made to obtain a general license or permission for the use of such proprietary rights by implementers or users of this OASIS Committee Specification or OASIS Standard, can be obtained from the OASIS TC Administrator. OASIS makes no representation that any information or list of intellectual property rights will at any time be complete, or that any claims in such list are, in fact, Essential Claims.

The names "OASIS" and "DITA" are trademarks of OASIS, the owner and developer of this specification, and should be used only to refer to the organization and its official outputs. OASIS welcomes reference to, and implementation and use of, specifications, while reserving the right to enforce its marks against misleading uses. Please see http://www.oasis-open.org/who/trademark.php for above guidance.

Next topic: 1 Introduction